Default schema - Mapping all message in node

hello i need some help. 
I have several xml files all with a different structure mean that the root is always changing. 
what should I give is to take all the input message and insert it into a node (call it b) 
how do I implement a scheme of defautl that works for everyone? How can I make xslt?

Hi,
From what I understand (Question is not that clear), you can consider using <ANY> element .
XSD The <any> Element
Blog Post example 1
Blog Post example 2
Maheshkumar S Tiwari|User Page|Blog|BizTalk
Server : How Map Works on Port Level

Similar Messages

  • Default class map is dropping all Packets

    Hello I have a Cisco 871 router that used to have Access list based security. now I am trying the ZBFW for the first time.  I thought I had a pretty good program until I found all my traffic was getting dropped. This is my first stab at ZBFWs and I am a bit confused esp with the default class part. Any help is greatly appreciated!!!!
    The router is for my house and thus also has to have priority for gaming. I will add the gaming and voice QOS once I get it working,
    Guest VLAN has access to 2 IP's in Data for printing.
    Cisco871#sh run
    Building configuration...
    Current configuration : 8005 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service sequence-numbers
    hostname Cisco871
    boot-start-marker
    boot-end-marker
    logging buffered 4096
    no logging console
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    aaa session-id common
    clock summer-time PST recurring
    crypto pki trustpoint TP-self-signed-4004039535
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-4004039535
    revocation-check none
    rsakeypair TP-self-signed-4004039535
    crypto pki certificate chain TP-self-signed-4004039535
    certificate self-signed 01
      3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 34303034 30333935 3335301E 170D3038 30323037 30373532
      32375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 30303430
      33393533 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100CEC2 7B89C73F AB4860EE 729C3B64 82139630 239A2301 8EA8B4C4 05505E25
      B0F24E7F 26ECEC53 3E266E80 F3104F61 BDDC5592 40E12537 2262D272 08D38F8E
      147F5059 7F632F5E 635B9CDF 652FFE82 C2F45C60 5F619AF0 72E640E0 E69EA9EF
      41C6B06C DD8ACF4B 0A1A33CF AF3C6BFB 73AD6BE0 BD84DD7F 435BD943 0A22E0E5
      F4130203 010001A3 74307230 0F060355 1D130101 FF040530 030101FF 301F0603
      551D1104 18301682 144C7570 696E2E44 61627567 61626F6F 732E6F72 67301F06
      03551D23 04183016 801473C6 E0784818 29A89377 23A22F5E BDD430CE E282301D
      0603551D 0E041604 1473C6E0 78481829 A8937723 A22F5EBD D430CEE2 82300D06
      092A8648 86F70D01 01040500 03818100 299AD241 442F976F 4F030B33 C477B069
      D356C518 8132E61B 1220F999 A30A4E0C D337DCE5 C408E3BC 0439BB66 543CF585
      8B26AA77 91FA510B 14796239 F272A306 C942490C A44336E0 A9430B81 9FC62524
      E55017FA 5C5463D7 B3492753 42315BEC 32B78F24 D10B0CA7 D1844CD5 C3E466B9
      3543BD68 A4B2692D 05CBF6DC C93C8142
                quit
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.0.0.1 10.0.0.5
    ip dhcp excluded-address 172.16.15.1 172.16.15.5
    ip dhcp excluded-address 172.16.15.14
    ip dhcp excluded-address 172.16.17.1 172.16.17.5
    ip dhcp excluded-address 192.168.19.1 192.168.19.5
    ip dhcp pool MyNetNative
       import all
       network 10.0.0.0 255.255.255.248
       default-router 10.0.0.1
       domain-name MyNetNet.org
       dns-server 4.2.2.1 4.2.2.6 8.8.8.8 208.67.220.220
       lease 0 2
    ip dhcp pool MyNetData
       import all
       network 172.16.15.0 255.255.255.240
       dns-server 172.16.15.14 4.2.2.1 4.2.2.6 8.8.8.8 208.67.220.220
       default-router 172.16.15.1
       domain-name MyDomain.org
    ip dhcp pool MyNetVoice
       import all
       network 172.16.17.0 255.255.255.240
       dns-server 172.16.15.14
       default-router 172.16.17.1
       domain-name MyDomain.org
    ip dhcp pool MyNetGuest
       import all
       network 192.168.19.0 255.255.255.240
       default-router 192.168.19.1
       domain-name MyNetGuest.org
       dns-server 4.2.2.1 4.2.2.6 8.8.8.8 208.67.220.220
    ip domain name MyDomain.org
    ip name-server 172.16.15.14
    ip name-server 4.2.2.4
    ip inspect log drop-pkt
    multilink bundle-name authenticated
    parameter-map type inspect TCP_PARAM
    parameter-map type inspect global
    username MyAdmin privilege 15 secret 5 MyPassword
    archive
    log config
      hidekeys
    class-map type inspect match-all MyNetGuest-access-list
    match access-group 110
    class-map type inspect match-any Base-protocols
    match protocol http
    match protocol https
    match protocol ftp
    match protocol ssh
    match protocol dns
    match protocol ntp
    match protocol ica
    match protocol pptp
    match protocol icmp
    match protocol tcp
    match protocol udp
    class-map type inspect match-all MyNetGuest-Class
    match class-map MyNetGuest-access-list
    match class-map Base-protocols
    class-map type inspect match-all MyNetNet-access-list
    match access-group 100
    class-map type inspect match-any Voice-protocols
    match protocol h323
    match protocol skinny
    match protocol sip
    class-map type inspect match-any Extended-protocols
    match protocol pop3
    match protocol pop3s
    match protocol imap
    match protocol imaps
    match protocol smtp
    class-map type inspect match-all MyNetNet-Class
    match class-map MyNetNet-access-list
    match class-map Voice-protocols
    match class-map Extended-protocols
    match class-map Base-protocols
    policy-map type inspect MyNetNet-zone_to_MyNetWAN-zone_policy
    class type inspect MyNetNet-Class
      inspect
    class class-default
    policy-map type inspect MyNetNet-zone_to_MyNetGuest-zone_policy
    class type inspect MyNetNet-Class
      inspect
    class class-default
    policy-map type inspect MyNetGuest-zone_to_MyNetNet-zone_policy
    class type inspect MyNetGuest-access-list
      inspect
    class class-default
    policy-map type inspect MyNetGuest-zone_to_MyNetWAN-zone_policy
    class type inspect MyNetGuest-Class
      inspect
    class class-default
    policy-map type inspect MyNetNet-zone
    class class-default
      pass
    zone security MyNetNet-zone
    zone security MyNetGuest-zone
    zone security MyNetWAN-zone
    zone-pair security MyNetNet->MyNetGuest source MyNetNet-zone destination MyNetGuest-zone
    service-policy type inspect MyNetNet-zone_to_MyNetGuest-zone_policy
    zone-pair security MyNetNet->MyNetWAN source MyNetNet-zone destination MyNetWAN-zone
    service-policy type inspect MyNetNet-zone_to_MyNetWAN-zone_policy
    zone-pair security MyNetGuest->MyNetWAN source MyNetGuest-zone destination MyNetWAN-zone
    service-policy type inspect MyNetGuest-zone_to_MyNetWAN-zone_policy
    zone-pair security MyNetGuest->MyNetNet source MyNetGuest-zone destination MyNetNet-zone
    service-policy type inspect MyNetGuest-zone_to_MyNetNet-zone_policy
    interface FastEthernet0
    description Cisco-2849-Switch
    switchport mode trunk
    speed 100
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    description SBS-Server
    switchport access vlan 10
    spanning-tree portfast
    interface FastEthernet4
    description WAN
    no ip address
    ip mtu 1492
    ip nat outside
    ip virtual-reassembly
    zone-member security MyNetWAN-zone
    ip tcp adjust-mss 1452
    duplex auto
    speed auto
    no cdp enable
    interface Vlan1
    description MyNetNative
    ip address 10.0.0.1 255.255.255.248
    ip nat inside
    ip virtual-reassembly
    zone-member security MyNetNet-zone
    ip tcp adjust-mss 1452
    interface Vlan10
    description MyNetData
    ip address 172.16.15.1 255.255.255.240
    ip nat inside
    ip virtual-reassembly
    zone-member security MyNetNet-zone
    interface Vlan20
    description MyNetVoice
    ip address 172.16.17.1 255.255.255.240
    ip nat inside
    ip virtual-reassembly
    zone-member security MyNetNet-zone
    interface Vlan69
    description MyNetGuest
    ip address 192.168.19.1 255.255.255.240
    ip nat inside
    ip virtual-reassembly
    zone-member security MyNetGuest-zone
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    access-list 100 remark MyNetnet
    access-list 100 permit ip 10.0.0.0 0.0.0.7 any
    access-list 100 permit ip 172.16.15.0 0.0.0.31 any
    access-list 100 permit ip 172.16.17.0 0.0.0.15 any
    access-list 110 remark MyNetGuest
    access-list 110 permit ip 192.168.19.0 0.0.0.15 host 172.16.15.2
    access-list 110 permit ip 192.168.19.0 0.0.0.15 host 172.16.15.3
    access-list 110 deny   ip 192.168.19.0 0.0.0.15 10.0.0.0 0.0.0.7
    access-list 110 deny   ip 192.168.19.0 0.0.0.15 172.16.15.0 0.0.0.31
    access-list 110 deny   ip 192.168.19.0 0.0.0.15 172.16.17.0 0.0.0.15
    access-list 110 permit ip 192.168.19.0 0.0.0.15 any
    control-plane
    banner login ^CC
    You know if you should be here or not.
             if not please leave
    NOW
    ^C
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    privilege level 15
    transport input telnet ssh
    scheduler max-task-time 5000
    ntp server 172.16.15.14
    webvpn cef
    end
    Cisco871#sh zone security
    zone self
      Description: System defined zone
    zone MyNetNet-zone
      Member Interfaces:
        Vlan1
        Vlan10
        Vlan20
    zone MyNetGuest-zone
      Member Interfaces:
        Vlan69
    zone MyNetWAN-zone
      Member Interfaces:
        FastEthernet4
    Cisco871#sh zone-pair security
    Zone-pair name MyNetNet->MyNetGuest
        Source-Zone MyNetNet-zone  Destination-Zone MyNetGuest-zone
        service-policy MyNetNet-zone_to_MyNetGuest-zone_policy
    Zone-pair name MyNetNet->MyNetWAN
        Source-Zone MyNetNet-zone  Destination-Zone MyNetWAN-zone
        service-policy MyNetNet-zone_to_MyNetWAN-zone_policy
    Zone-pair name MyNetGuest->MyNetWAN
        Source-Zone MyNetGuest-zone  Destination-Zone MyNetWAN-zone
        service-policy MyNetGuest-zone_to_MyNetWAN-zone_policy
    Zone-pair name MyNetGuest->MyNetNet
        Source-Zone MyNetGuest-zone  Destination-Zone MyNetNet-zone
        service-policy MyNetGuest-zone_to_MyNetNet-zone_policy
    Cisco871#sh int faste4
    FastEthernet4 is up, line protocol is up
      Hardware is PQUICC_FEC, address is 0016.9d29.a667 (bia 0016.9d29.a667)
      Description: WAN
      Internet address is 10.38.177.98/25
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:00, output 00:34:50, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 2000 bits/sec, 3 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         593096 packets input, 73090812 bytes
         Received 592752 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         9940 packets output, 1016025 bytes, 0 underruns
         0 output errors, 0 collisions, 3 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    Zone-pair: MyNetNet->MyNetWAN
      Service-policy inspect : MyNetNet-zone_to_MyNetWAN-zone_policy
        Class-map: MyNetNet-Class (match-all)
          Match: class-map match-all MyNetNet-access-list
            Match: access-group 100
          Match: class-map match-any Voice-protocols
            Match: protocol h323
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol skinny
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol sip
              0 packets, 0 bytes
              30 second rate 0 bps
          Match: class-map match-any Extended-protocols
            Match: protocol pop3
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol pop3s
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol imap
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol imaps
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol smtp
              0 packets, 0 bytes
              30 second rate 0 bps
          Match: class-map match-any Base-protocols
            Match: protocol http
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol https
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol ftp
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol ssh
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol dns
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol ntp
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol ica
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol pptp
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol icmp
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol tcp
              0 packets, 0 bytes
              30 second rate 0 bps
            Match: protocol udp
              0 packets, 0 bytes
              30 second rate 0 bps
          Inspect
            Session creations since subsystem startup or last reset 0
            Current session counts (estab/half-open/terminating) [0:0:0]
            Maxever session counts (estab/half-open/terminating) [0:0:0]
            Last session created never
            Last statistic reset never
            Last session creation rate 0
            Maxever session creation rate 0
            Last half-open session total 0
        Class-map: class-default (match-any)
          Match: any
          Drop (default action)
            5196 packets, 256211 bytes
    Cisco871#sh log
    Syslog logging: enabled (1 messages dropped, 0 messages rate-limited,
                    0 flushes, 0 overruns, xml disabled, filtering disabled)
    No Active Message Discriminator.
    No Inactive Message Discriminator.
        Console logging: disabled
        Monitor logging: level debugging, 0 messages logged, xml disabled,
                         filtering disabled
        Buffer logging:  level debugging, 1745 messages logged, xml disabled,
                         filtering disabled
        Logging Exception size (4096 bytes)
        Count and timestamp logging messages: disabled
        Persistent logging: disabled
    No active filter modules.
    ESM: 0 messages dropped
        Trap logging: level informational, 1785 message lines logged
    Log Buffer (4096 bytes):
    001779: *Feb 15 11:00:55.979: %FW-6-DROP_UDP_PKT: Dropping Other pkt 172.16.15.6:61806 => 168.94.0.1:53 with ip ident 511 due to  policy match failure
    001780: *Feb 15 11:00:59.739: %FW-6-DROP_TCP_PKT: Dropping Other pkt 172.16.15.6:4399 => 168.94.69.30:443 due to  policy match failure -- ip ident 515 tcpflags 0x7002 seq.no 974122240 ack 0
    001781: *Feb 15 11:01:26.507: %FW-6-DROP_UDP_PKT: Dropping Other pkt 172.16.15.6:51991 => 168.94.0.1:53 with ip ident 625 due to  policy match failure
    001783: *Feb 15 11:01:57.891: %FW-6-DROP_UDP_PKT: Dropping Other pkt 172.16.15.6:64470 => 168.94.0.1:53 with ip ident 677 due to  policy match failure

    Hello Charlie,
    I would recomend you to investigate a little bit more about how the ZBFW features works
    Now I am going to help you on this one at least, then I will give you a few links you could use to study
    We are going to study traffic from MyNetNet-zone to the MyNetWan-zone
    First the zone-pair
    zone-pair security MyNetNet->MyNetWAN source MyNetNet-zone destination MyNetWAN-zone
    service-policy type inspect MyNetNet-zone_to_MyNetWAN-zone_policy
    so lets go policy-map
    policy-map type inspect MyNetNet-zone_to_MyNetWAN-zone_policy
    class type inspect MyNetNet-Class
      inspect
    class class-default
    Finally to the class map
    class-map type inspect match-all MyNetNet-Class
    match class-map MyNetNet-access-list
    match class-map Voice-protocols
    match class-map Extended-protocols
    match class-map Base-protocols
    That keyword MATCH-ALL is the one causing the issues!!
    Why?
    Because you are telling the ZBFW to inspect traffic only if matches all of those class-maps so a packet will need to math the base protocols and the extended protocol and as you know that is not possible ( Just one protocol )
    So here are the links
    http://blogg.kvistofta.nu/cisco-ios-zone-based-policy-firewall/
    https://supportforums.cisco.com/thread/2138873
    http://pktmaniac.info/2011/08/zone-based-firewalls-something-to-keep-in-mind/
    http://www.cisco.com/en/US/products/sw/secursw/ps1018/products_tech_note09186a00808bc994.shtml
    You have some work to do
    Please remember to rate all the helpful posts
    Julio
    CCSP

  • Forum question: How to set Show All Messages as default?

    I seem to remember there was a way to set this as a default, so that when one clicks on a topic, all new (unread) posts are shown. Currently, I only see a subset of the new postings, and I have to click on "Show All Messages" to see them all. The number shown initially seems to be arbitrary. I know that postings that I've read will not show up, but how can I get all unread postings to show by default?
    Thanks!
    Rafael

    R,
    For non-Photoshop/general forum questions, please post your concerns at: http://www.adobeforums.com/cgi-bin/webx?14@@.ee6b30e
    Thanks.
    Neil

  • Assign default tablespace to all schemas

    Hi All,
    How can I assign default tablespace to all schemas present in my DB's ?
    Thanks.

    907490 wrote:
    Hi All,
    How can I assign default tablespace to all schemas present in my DB's ?
    Thanks.whenever you are creating the user ,a default tablespace is assign to that user ........ You can check the default tablespace by database_properties view .....
    To check the default tablespace of each user by using the below query :
    select username,default_tablespace from dba_users ;Hope this help you :)
    --neeraj                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

  • Multi-Mapping and Message Split using BPM

    Hi All,
    Could anyone pls let me know clearly how message mapping can be done for this weblog
    /people/sudharshan.aravamudan/blog/2005/12/01/illustration-of-multi-mapping-and-message-split-using-bpm-in-sap-exchange-infrastructure
    Thanks,
    Ram

    Hi,
    When you are doing Message mapping after adding the Messaget types for source and target messages. You can click on the "" button in the target message and add one more tab. You can go to Message tab as shown in the 5th image and click "" button to add one more message type. Then do the mapping as usual.
    <b>Based on the value of the element(name), the node of input(details)should be directed to one of the two message types</b>
    Here in this blog it is done based on the Name.
    You need to use IFTHENELSE boolean function and do the mapping.
    Thanks,
    Prakash

  • Mapping Error Message

    I have completed the mapping of an IDOC to File Data Structure.
    I ran the testing once and it said successful bu no target fields were populated. I then mapped all of the root nodes to a constant to see if it made a difference and I get the following message
    09:58:51 Start of test
    Compilation of msgMAP_IDOCINVOICE02_INVOICE successful Exception:[java.lang.IllegalArgumentException: Cannot cast to boolean] in class com.sap.aii.mappingtool.flib3.Bool method equals[, 009, com.sap.aii.mappingtool.tf3.rt.Context@191361] com.sap.aii.utilxi.misc.api.BaseRuntimeException: Exception:[java.lang.IllegalArgumentException: Cannot cast to boolean] in class com.sap.aii.mappingtool.flib3.Bool method equals[, 009, com.sap.aii.mappingtool.tf3.rt.Context@191361] at com.sap.aii.mappingtool.tf3.rt.FunctionWrapper.getValue(FunctionWrapper.java:56) at com.sap.aii.mappingtool.flib3.IfWithoutElse.getValue(IfWithoutElse.java:18) at com.sap.aii.mappingtool.tf3.AMappingProgram.processNode(AMappingProgram.java:186) at com.sap.aii.mappingtool.tf3.AMappingProgram.processNode(AMappingProgram.java:204) at com.sap.aii.mappingtool.tf3.AMappingProgram.processNode(AMappingProgram.java:204) at com.sap.aii.mappingtool.tf3.AMappingProgram.start(AMappingProgram.java:298) at com.sap.aii.mappingtool.tf3.Transformer.start(Transformer.java:63) at com.sap.aii.mappingtool.tf3.AMappingProgram.execute(AMappingProgram.java:77) at com.sap.aii.ibrep.server.mapping.ServerMapService.transformInternal(ServerMapService.java:431) at com.sap.aii.ibrep.server.mapping.ServerMapService.execute(ServerMapService.java:169) at com.sap.aii.ibrep.sbeans.mapping.MapServiceBean.execute(MapServiceBean.java:52) at com.sap.aii.ibrep.sbeans.mapping.MapServiceRemoteObjectImpl0.execute(MapServiceRemoteObjectImpl0.java:259) at com.sap.aii.ibrep.sbeans.mapping.MapServiceRemoteObjectImpl0p4_Skel.dispatch(MapServiceRemoteObjectImpl0p4_Skel.java:146) at com.sap.engine.services.rmi_p4.DispatchImpl._runInternal(DispatchImpl.java:304) at com.sap.engine.services.rmi_p4.DispatchImpl._run(DispatchImpl.java:193) at com.sap.engine.services.rmi_p4.server.P4SessionProcessor.request(P4SessionProcessor.java:122) at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:33) at com.sap.engine.core.cluster.impl6.session.MessageRunner.run(MessageRunner.java:41) at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37) at java.security.AccessController.doPrivileged(Native Method) at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:100) at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:170) Root Cause: java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:324) at com.sap.aii.mappingtool.tf3.rt.FunctionWrapper.getValue(FunctionWrapper.java:47) at com.sap.aii.mappingtool.flib3.IfWithoutElse.getValue(IfWithoutElse.java:18) at com.sap.aii.mappingtool.tf3.AMappingProgram.processNode(AMappingProgram.java:186) at com.sap.aii.mappingtool.tf3.AMappingProgram.processNode(AMappingProgram.java:204) at com.sap.aii.mappingtool.tf3.AMappingProgram.processNode(AMappingProgram.java:204) at com.sap.aii.mappingtool.tf3.AMappingProgram.start(AMappingProgram.java:298) at com.sap.aii.mappingtool.tf3.Transformer.start(Transformer.java:63) at com.sap.aii.mappingtool.tf3.AMappingProgram.execute(AMappingProgram.java:77) at com.sap.aii.ibrep.server.mapping.ServerMapService.transformInternal(ServerMapService.java:431) at com.sap.aii.ibrep.server.mapping.ServerMapService.execute(ServerMapService.java:169) at com.sap.aii.ibrep.sbeans.mapping.MapServiceBean.execute(MapServiceBean.java:52) at com.sap.aii.ibrep.sbeans.mapping.MapServiceRemoteObjectImpl0.execute(MapServiceRemoteObjectImpl0.java:259) at com.sap.aii.ibrep.sbeans.mapping.MapServiceRemoteObjectImpl0p4_Skel.dispatch(MapServiceRemoteObjectImpl0p4_Skel.java:146) at com.sap.engine.services.rmi_p4.DispatchImpl._runInternal(DispatchImpl.java:304) at com.sap.engine.services.rmi_p4.DispatchImpl._run(DispatchImpl.java:193) at com.sap.engine.services.rmi_p4.server.P4SessionProcessor.request(P4SessionProcessor.java:122) at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:33) at com.sap.engine.core.cluster.impl6.session.MessageRunner.run(MessageRunner.java:41) at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37) at java.security.AccessController.doPrivileged(Native Method) at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:100) at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:170) Caused by: java.lang.IllegalArgumentException: Cannot cast to boolean at com.sap.aii.mappingtool.flib3.Bool.toBoolean(Bool.java:17) at com.sap.aii.mappingtool.flib3.Bool.equals(Bool.java:37) ... 26 more RuntimeException in Message-Mapping transformation: Exception:[java.lang.IllegalArgumentException: Cannot cast to boolean] in class com.sap.aii.mappingtool.flib3.Bool method equals[, 009, com.sap.aii.mappingtool.tf3.rt.Context@191361]
    09:58:56 End of test
    Could this be because in the IDOC there are various conditions i.e. PARTN------>ID only if PARVW = constant (10)
    NAME1----
    >NAME only if PARVW = Constant 5
    so you see in the mapping this all looks ok but in testing I am unable to give all of these conditions I can only give 5 or 10 but not both. So could it be that the mapping is correct but until I test with a real document where all the fields are complete and all the conditions are met then it wont work?

    Wojtek,
    Could you elaborate on that a little...
    In all of my mapping scenarios I have the ifwithoutelse suppress value to true.... Could this be a problem. Below is the typical mapping. Could you tell me if you think this would work and if so what you think it is saying.... This way I will know if I have given the right instructions.
    I have
    QUALF----
    > EQUALS
    CONSTANT (009)--> EQUALS
    EQUALS----
    > TOP INPUT OF IF THEN (IF WITHOUT ELSE)
    DATUM----
    > BOTTOM INPUT OF IF THEN (IF WITHOUT ELSE)
    IT THEN (IF WITHOUT ELSE) OUTPUT VALUE -
    > INVDATE
    What I am trying to achieve from this is the mapping looks at the QUALF and sees if it is equal to 009. If this is the cae then I want to Map DATUM to INVDATE.
    If not the case then DATUM does not get mapped at all. Is the above the right scenario.

  • XML Schema mapping error when generating web service

    I have created a method in java that returns an array of an object type (a user defined class). When tried to generate a web service JDeveloper did not allow me to select the method, giving the following "Why not.." explanation: "One or more parameters did not have an XML Schema mapping and/or serializer specified".
    Can anyone help me in this?
    Thanks
    Alina

    Thanks Mike for your advice it did work when I changed the setters and getters names, and managed to create a web service with Apache Soap profile. I created the client stub and client application to run the web service but it keep coming with soap-env error messages.
    Error message I get when running the client side:
    F:\JDev9i-0-3\jdk\bin\javaw.exe -ojvm -classpath F:\JDev9i-0-3\jdev\mywork\OrbatListArray\OrbatClient\classes;F:\JDev9i-0-3\jdev\lib\jdev-rt.jar;F:\JDev9i-0-3\jdev\lib\jdev-rt.jar;F:\JDev9i-0-3\soap\lib\soap.jar;F:\JDev9i-0-3\lib\xmlparserv2.jar;F:\JDev9i-0-3\jlib\javax-ssl-1_2.jar;F:\JDev9i-0-3\jlib\jssl-1_2.jar;F:\JDev9i-0-3\j2ee\home\lib\activation.jar;F:\JDev9i-0-3\j2ee\home\lib\mail.jar;F:\JDev9i-0-3\j2ee\home\lib\http_client.jar orbatclientpackage.OrbatListArrayClient
    [SOAPException: faultCode=SOAP-ENV:Server.BadTargetObjectURI; msg=Unable to resolve target object(orbatlistarraypackage.OrbatListArray): orbatlistarraypackage.OrbatListArray [java.lang.ClassNotFoundException]]     orbatlistarraypackage.OrbatType[] orbatclientpackage.OrbatListArrayStub.getOrbatListArray()          OrbatListArrayStub.java:63     void orbatclientpackage.OrbatListArrayClient.main(java.lang.String[])          OrbatListArrayClient.java:19Exception in thread main
    Process exited with exit code 1.
    My wsdl file is:
    <?xml version = '1.0' encoding = 'windows-1252'?>
    <!--Generated by the Oracle9i JDeveloper Web Services WSDL Generator-->
    <!--Date Created: Wed Oct 23 11:16:29 BST 2002-->
    <definitions
    name="OrbatListArray"
    targetNamespace="http://orbatlistarraypackage/OrbatListArray.wsdl"
    xmlns="http://schemas.xmlsoap.org/wsdl/"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
    xmlns:tns="http://orbatlistarraypackage/OrbatListArray.wsdl"
    xmlns:ns1="http://orbatlistarraypackage/IOrbatListArray.xsd">
    <types>
    <schema
    targetNamespace="http://orbatlistarraypackage/IOrbatListArray.xsd"
    xmlns="http://www.w3.org/2001/XMLSchema"
    xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/">
    <complexType name="ArrayOfOrbatType" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/">
    <complexContent>
    <restriction base="SOAP-ENC:Array">
    <attribute ref="SOAP-ENC:arrayType" wsdl:arrayType="ns1:orbatlistarraypackage_OrbatType[]"/>
    </restriction>
    </complexContent>
    </complexType>
    <complexType name="orbatlistarraypackage_OrbatType" jdev:packageName="orbatlistarraypackage" xmlns:jdev="http://xmlns.oracle.com/jdeveloper/webservices">
    <all>
    <element name="OrbatName" type="string"/>
    <element name="OrbatID" type="int"/>
    </all>
    </complexType>
    </schema>
    </types>
    <message name="getOrbatListArray0Request"/>
    <message name="getOrbatListArray0Response">
    <part name="return" type="ns1:ArrayOfOrbatType"/>
    </message>
    <portType name="OrbatListArrayPortType">
    <operation name="getOrbatListArray">
    <input name="getOrbatListArray0Request" message="tns:getOrbatListArray0Request"/>
    <output name="getOrbatListArray0Response" message="tns:getOrbatListArray0Response"/>
    </operation>
    </portType>
    <binding name="OrbatListArrayBinding" type="tns:OrbatListArrayPortType">
    <soap:binding style="rpc" transport="http://schemas.xmlsoap.org/soap/http"/>
    <operation name="getOrbatListArray">
    <soap:operation soapAction="" style="rpc"/>
    <input name="getOrbatListArray0Request">
    <soap:body use="encoded" namespace="orbatlistarraypackage.OrbatListArray" encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"/>
    </input>
    <output name="getOrbatListArray0Response">
    <soap:body use="encoded" namespace="orbatlistarraypackage.OrbatListArray" encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"/>
    </output>
    </operation>
    </binding>
    <service name="OrbatListArray">
    <port name="OrbatListArrayPort" binding="tns:OrbatListArrayBinding">
    <soap:address location="http://192.9.200.200:8888/soap/servlet/soaprouter"/>
    </port>
    </service>
    </definitions>
    My OrbatListArrayDescriptor.dd file:
    <?xml version = '1.0' encoding = 'windows-1252'?>
    <!--Generated by the Oracle9i JDeveloper Web Services Deployment Descriptor Generator-->
    <!--This Deployment Descriptor file is for use with the Oracle9iAS Release 2 / Apache 2.2 SOAP Server SOAP Server-->
    <!--Date Created: Wed Oct 23 11:16:29 BST 2002-->
    <isd:service
    id="orbatlistarraypackage.OrbatListArray"
    xmlns:isd="http://xml.apache.org/xml-soap/deployment">
    <isd:provider
    type="java"
    methods="getOrbatListArray"
    scope="Request">
    <isd:java class="orbatlistarraypackage.OrbatListArray" static="false"/>
    </isd:provider>
    <isd:faultListener>org.apache.soap.server.DOMFaultListener</isd:faultListener>
    </isd:service>
    My Client Web Service Stub class file:
    package orbatclientpackage;
    import oracle.soap.transport.http.OracleSOAPHTTPConnection;
    import org.apache.soap.encoding.soapenc.BeanSerializer;
    import org.apache.soap.encoding.SOAPMappingRegistry;
    import org.apache.soap.util.xml.QName;
    import java.net.URL;
    import org.apache.soap.Constants;
    import org.apache.soap.Fault;
    import org.apache.soap.SOAPException;
    import org.apache.soap.rpc.Call;
    import org.apache.soap.rpc.Parameter;
    import org.apache.soap.rpc.Response;
    import java.util.Vector;
    import orbatlistarraypackage.OrbatType;
    import java.util.Properties;
    * Generated by the Oracle9i JDeveloper Web Services Stub/Skeleton Generator.
    * Date Created: Wed Oct 23 11:19:42 BST 2002
    * WSDL URL: file:/F:/JDev9i-0-3/jdev/mywork/OrbatListArray/OrbatListArrayProject/src/orbatlistarraypackage/OrbatListArray.wsdl
    public class OrbatListArrayStub
    public OrbatListArrayStub()
    m_httpConnection = new OracleSOAPHTTPConnection();
    m_smr = new SOAPMappingRegistry();
    BeanSerializer beanSer = new BeanSerializer();
    m_smr.mapTypes(Constants.NS_URI_SOAP_ENC, new QName("http://orbatlistarraypackage/IOrbatListArray.xsd", "orbatlistarraypackage_OrbatType"), orbatlistarraypackage.OrbatType.class, beanSer, beanSer);
    public String endpoint = "http://192.9.200.200:8888/soap/servlet/soaprouter";
    private OracleSOAPHTTPConnection m_httpConnection = null;
    private SOAPMappingRegistry m_smr = null;
    public OrbatType[] getOrbatListArray() throws Exception
    OrbatType[] returnVal = null;
    URL endpointURL = new URL(endpoint);
    Call call = new Call();
    call.setSOAPTransport(m_httpConnection);
    call.setTargetObjectURI("orbatlistarraypackage.OrbatListArray");
    call.setMethodName("getOrbatListArray");
    call.setEncodingStyleURI(Constants.NS_URI_SOAP_ENC);
    Vector params = new Vector();
    call.setParams(params);
    call.setSOAPMappingRegistry(m_smr);
    Response response = call.invoke(endpointURL, "");
    if (!response.generatedFault())
    Parameter result = response.getReturnValue();
    returnVal = (OrbatType[])result.getValue();
    else
    Fault fault = response.getFault();
    throw new SOAPException(fault.getFaultCode(), fault.getFaultString());
    return returnVal;
    public void setMaintainSession(boolean maintainSession)
    m_httpConnection.setMaintainSession(maintainSession);
    public boolean getMaintainSession()
    return m_httpConnection.getMaintainSession();
    public void setTransportProperties(Properties props)
    m_httpConnection.setProperties(props);
    public Properties getTransportProperties()
    return m_httpConnection.getProperties();
    My Client application main file:
    package orbatclientpackage;
    import java.io.*;
    public class OrbatListArrayClient
    public OrbatListArrayClient()
    public static void main(String[] args) throws Exception
    OrbatListArrayStub s = new OrbatListArrayStub();
    // File xmlFile;
    // BufferedWriter in;
    // xmlFile = new File("f:\\OrbatSoap", "OrbatXMLList.xml");
    // PrintWriter out = new PrintWriter(new BufferedWriter(new FileWriter(xmlFile)));
    // out.println(s.getOrbatListArray());
    // out.flush();
    System.out.println(s.getOrbatListArray());
    When I deployed it to jar I copied the jar file in the following directory:
    <jdevloper home>\soap\webapps\soap\soap\Web-inf\lib\
    I then tried and created a client stub in the same package using JDeveloper 9.0.3 wizard for creating sample java client and added a line to call my getOrbatListArray method and print it to the screen. I get another soap error message, saying:
    F:\JDev9i-0-3\jdk\bin\javaw.exe -ojvm -classpath F:\JDev9i-0-3\jdev\mywork\OrbatListArray\OrbatListArrayProject\classes;F:\JDev9i-0-3\jdev\lib\jdev-rt.jar;F:\JDev9i-0-3\jdbc\lib\classes12.jar;F:\JDev9i-0-3\jdbc\lib\nls_charset12.jar;F:\JDev9i-0-3\rdbms\jlib\xsu12.jar;F:\JDev9i-0-3\lib\xmlparserv2.jar;F:\JDev9i-0-3\lib\xmlcomp.jar;F:\JDev9i-0-3\jdev\lib\jdev-rt.jar;F:\JDev9i-0-3\soap\lib\soap.jar;F:\JDev9i-0-3\lib\xmlparserv2.jar;F:\JDev9i-0-3\jlib\javax-ssl-1_2.jar;F:\JDev9i-0-3\jlib\jssl-1_2.jar;F:\JDev9i-0-3\j2ee\home\lib\activation.jar;F:\JDev9i-0-3\j2ee\home\lib\mail.jar;F:\JDev9i-0-3\j2ee\home\lib\http_client.jar orbatlistarraypackage.EmbeddedOrbatListArrayStub
    [SOAPException: faultCode=SOAP-ENV:IOException; msg=Connection refused: connect; targetException=java.net.ConnectException: Connection refused: connect]     void org.apache.soap.SOAPException.<init>(java.lang.String, java.lang.String, java.lang.Throwable)          SOAPException.java:77     void oracle.soap.transport.http.OracleSOAPHTTPConnection.send(java.net.URL, java.lang.String, java.util.Hashtable, org.apache.soap.Envelope, org.apache.soap.encoding.SOAPMappingRegistry, org.apache.soap.rpc.SOAPContext)          OracleSOAPHTTPConnection.java:765     org.apache.soap.rpc.Response org.apache.soap.rpc.Call.invoke(java.net.URL, java.lang.String)          Call.java:253     orbatlistarraypackage.OrbatType1[] orbatlistarraypackage.EmbeddedOrbatListArrayStub.getOrbatListArray()          EmbeddedOrbatListArrayStub.java:70     void orbatlistarraypackage.EmbeddedOrbatListArrayStub.main(java.lang.String[])          EmbeddedOrbatListArrayStub.java:38Process exited with exit code 0.
    Sorry for the length of this message, but I am getting desparate.
    Thanks again for all you help
    Alina

  • Default schema names in multi-tier landscape

    Hi folks,
    We have an interesting problem due to having different named default schemas in each of our 3 hana systems.  For example lets say these are our default schemas in our development, staging, and production HANA systems;
    DEV_SCHEMA
    QA_SCHEMA
    PROD_SCHEMA
    Each of these replicating data from their corresponding SAP source systems.
    Now, we have a view that is developed on DEV hana box and uses DEV_SCHEMA.  When this view content is imported to QA or PROD we handle easily with schema mapping.  All is well and good although we are not really a fan of this different naming and us developers did not choose this naming (self defense plea here for us brilliant developers whom never make such mistakes... PS: HI LARS! - Go Germany!)
    Now we are setting up a connection from BW into HANA using system connection and inside this is a parameter called 'db user'.  Although it's called db user it's actually looking for a SCHEMA name.  If BW DEV is querying from HANA DEV this schema name would be DEV_SCHEMA.  However if BW_QA is querying from HANA_QA then the name would need to be QA_SCHEMA but in our BW landscape we are locked in QA and PROD and normally can not and/or do not want to edit objects in non-native systems.  Ideally what we need is our default schemas in HANA to have the same exact name throughout the HANA landscape.
    All this said, I can see that it would be great to re-name our entire HANA landscape however that would be a HUGE monumental undertaking as all systems would need to be re-replicated again (at least I think).
    Just curious if anybody else has named their schemas differently on each tier?  What are most people doing?  Naming the default schemas the same consistently or are you using schema mapping?
    Thanks,
    -Patrick

    Hi Luke,
    I am new to the project and there seems to be no original version.  At some point a bunch of the destination field names were changed on the admin console and errors resulted from it both due to mismatched joins and the use of two word field names.  I have documentation of the names for the set of tables in the function area but am having trouble with how everything matches up in the bottom half..  I'll keep working on it
    Z

  • How to set default 'schema' in Pointbase?

    I am using Netbeans EA2 with bundled appserv. I have tried creating a CMP entity bean from the Pointbase sample database (PBPUBLIC), which works. But when i created my own database (MYDATABASE) in Pointbase and a CMP bean for my test-table, i get a SQLException: Invalid table name "Mytable" specified at position 147.
    This exception is thrown when i run "findByPrimaryKey" on my tablebean's home.
    I think i have narrowed the problem down to this:
    When I execute sql-commands on my db, I have to write
    Select * from "MYDATABASE"."Mytable"
    If i try to execute
    Select * from "Mytable"
    i get an error. (Invalid table name)
    Whereas when i execute commands on the Pointbase sample db (PBPUBLIC), both these sql's work:
    select * from "PBPUBLIC"."CUSTOMER_TBL"
    and
    select * from "CUSTOMER_TBL"
    My questions are
    1. How do i specify that "MYDATABASE" should the default schema in my database?
    is it possible at all? I have tried searching the pointbase docs, and looked in Pointbase Commander, but have found nothing.
    2. If I was going to fully qualify, that is, use "MYDATABASE"."Mytable" everytime i query the database, how and where do i specify that my entity bean should map betweed my dbschema and "MYDATABASE"."Mytable" ? Writing
    <table-name>MYDATABASE.Mytable</table-name> in sun-cmp-mappings.xml did not work (but that was no suprise)
    Is it not possible to fully qualify the tablename when using entity ejb's?
    the error i get is similar to the one in this thread, except that my dbschema name is correct.
    http://forum.java.sun.com/thread.jspa?threadID=586762&tstart=0
    I have tried creating a new dbschema in Netbeans, and editing sun-cmp-mappings.xml to point to the new dbschema. But i still get the same error.
    And btw, i know that my database is available, cause when i try to get the DataSource for my db directly, and execute a query, it works. But i have to fully qualify the tablename.
    Any help would be appreciated
    Thanks.

    I solved using the SET PATH statement.
    SET PATH your_default_schema, PointBase;
    Follow an extract from the PointBase Developer�s Guide:
    If you never execute a SET PATH statement, then the CURRENT_PATH consists of the
    schema POINTBASE, followed by your existing schema. When a SET PATH statement is
    issued, it completely replaces the existing CURRENT_PATH, unless CURRENT_PATH is part
    of the schemas being set in the path.
    The order of the schemas in the path is generally crucial. When the database system is looking
    for SQL objects, it looks for them in each schema (unless explicitly referenced otherwise),
    starting with the first schema in the path, then the next, etc...., until an SQL object is found that
    meets the criteria. One way to override the CURRENT_PATH is to explicitly reference the
    SQL object. For example, to reference a table, you can specify schema_name.table_name. In
    the above examples, the SQL object of table_name would be searched in the schema of name
    schema_name.
    I hope this helps,
    regards,
    armando croce

  • Hi , friends pls explain abap mapping and message mapping

    1) pls explain abap mapping and message mapping
       send me screen shorts also.

    Hi
    Mapping Techniques
    XI provides 3 standard ways of interface mapping between source and target.
    Graphical mapping
    Java Mapping
    XSLT Mapping
    Two more additional mapping types can be activated in XI by making changes to the exchange profile. Those two mappings are
    ABAP mapping
    XSLT mapping with ABAP Extensions
    Graphical Mapping
    Graphical mapping is a common approach followed by everyone for generating desired target structure. It involves simple drag-n-drop to correlate respective nodes (fields) from source and target structure. It hardly involves coding. (Exception - User defined functions). But sometimes with graphical mapping it is difficult to produce required output. For example ... text/html output, namespace change, sorting or grouping of records etc.
    ABAP Mapping
    A person comfortable with Object Oriented ABAP can go for ABAP mapping instead.
    Java Mapping
    Java Mapping uses 2 types of parsers. DOM and SAX. DOM is easier to use with lots of classes to help you create nodes and elements, but , DOM is very processor intensive.
    SAX parser is something that parses your XML one after the other, and so is not processor intensive. But, it is not exaclty easy to develop either.
    XSLT Mapping
    One can also think of Java mapping as another option but it is a bit complex and required knowledge of Java. In such cases, XSLT mapping can be the best approach to meet the requirements.
    A few example cases in which an XSLT mapping can be used:-
    When the required output is other than XML like Text, Html or XHTML (html displayed as XML)
    When default namespace coming from graphical mapping is not required or is to be changed as per requirements.
    When data is to be filtered based on certain fields (considering File as source)
    When data is to be sorted based on certain field (considering File as source)
    When data is to be grouped based on certain field (considering File as source)\
    Advantages of using XSLT mapping
    XSLT program itself defines its own target structure.
    XSLT programs can be imported into SAP XI. Message mapping step can be avoided. One can directly go for interface mapping once message interfaces are created and mapping is imported.
    XSLT provides use of number of standard XPath functions that can replaces graphical mapping involving user defined java functions easily.
    File content conversion at receiver side can be avoided in case of text or html output.
    Multiple occurrences of node within tree (source XML) can be handled easily.
    XSLT can be used in combination with graphical mapping.
    Multi-mapping is also possible using xslt.
    XSLT can be used with ABAP and JAVA Extensions.
    Disadvantages of using XSLT mapping
    Resultant XML payload can not be viewed in SXMB_MONI if not in XML format (for service packs < SP14).
    Interface mapping testing does not show proper error description. So errors in XSLT programs are difficult to trace in XI but can be easily identified outside XI using browser.
    XSLT mapping requires more memory than mapping classes generated in Java.
    XSLT program become lengthier as source structure fields grows in numbers.
    XSLT program sometimes become complex to meet desired functionality.
    Some XSL functions are dependent on version of browser.
    Different types of Mappings
    MAPPING SUPPORTED BY XI
    Message Mapping -> Graphical Design and testing environment. Default Provided By XI. Queue based modelling allow handling or large documents. Extensible via user defined functions
    XSLT Mapping - > Based on openstandard, Portable across application platform, Extensible using user defined functions kewl but disadvantage is Memory overload while handling large documents.
    SAX -> Simple Api For XML. -> Allows you to parse through a XML document. Doesn't consume any memory. But the message can be parsed only once from top to bottom. It Has evolved by contributions made by group of ppl itz a open architecture.
    DOM -> Document Object Model -> Itz designed by W3C. Consumes Memory as the message will be loaded. Allows parsing of document in both way top down and bottom up.
    Send me your email id.Shall send you very good docs for both ABAP Mapping and message mapping.
    Thanks

  • Multiple records of schema mapping using looping

    Hi,
    I am trying to resolve a simple looping scenario. Though I have looked some of the posts but could not conclude myself with any final idea. 
    In the below shown picture of B2MML maping, I have an input data "OperationsRequest" tree mapped to "Records" tree on the output/right hand side. This works fine if my input message file has one "OperationsRequest" entry of data. 
    I have multiple records of "OperationsRequest" in the incoming message, which should be linked to "Records". The shown mapping is not working though. That looping used over there may be not correct or incomplete? 
    How I can achieve this?
    Thanks.

    Hi Parny,
    At the first place even looping functoid should do the job for you.
    You have to place a looping functoid and join the Repeating Item Record node from the Source schema to the Repeating Record Node in the Destination Schema.
    I think in your destination schema the "Records" record is not unbounded.
     Please check the schema.
    Rachit
    Please mark the post answered your question as answer, and mark other helpful posts as helpful, it'll help other users who are visiting your thread for the similar problem
    Hi Parny,
    Have you tried this?
    Rachit

  • How can I redirect all messages to 2 another mail servers?

    Hi all
    ./imsimta version
    Sun Java(tm) System Messaging Server 7.3-11.01 64bit (built Sep 1 2009)
    libimta.so 7.3-11.01 64bit (built 19:54:45, Sep 1 2009)
    I wanted to redirect all messages(in and out) to another mail server, I configured as follows,
    - imta.cnf
    ! tcp_local
    tcp_local smtp mx single_sys ....... sourcefilter file:///backother.filter
    ! tcp_intranet
    tcp_intranet smtp mx single_sys ....... sourcefilter file:///backother.filter
    - backother.filter
    require ["fileinto"];
    if address :all :matches ["From"]["*"]{
    redirect "[email protected]";
    keep;
    stop;
    One e-mail account receives all messgaes and those messages will be kept in sender's or receiver's mail storage.
    I want , however, redirect all messages 2 or 3 mail servers.
    I tried several things to do this include edit backother.filter(this is written in Sieve ), but I failed.
    Is there any way to redirect messages to another mail servers?
    Any way would be good , using sieve script, make antoher channel or channel keyword
    Thanks
    Edited by: leeky41 on Mar 9, 2010 10:58 PM
    Edited by: leeky41 on Mar 9, 2010 11:06 PM
    Edited by: leeky41 on Mar 9, 2010 11:07 PM

    leeky41 wrote:
    Redirecting the message means it will not be delivered to the original recipient.I know so I wrote 'keep' keyword to deliver messages to the original recipient.
    capture "[email protected]";
    I tested it but the capture's behavior was very weird, subject had changed to something like,'deliverd status notice', sender had changed to postmaster and additional notice messgae inserted into mail body.The default sieve capture action encapsulates the email to keep a copy of both the envelope information and the original message. MS7u3 also supports the Exchange journal encapsulation format through the addition of the ":journal" parameter.
    I edited 'capture' like this..
    capture :message "[email protected]";
    The ":message" flag removes the encapsulation -- therefore you will have no idea of who the original sender/recipients were as the envelope information has been discarded.
    It worked fine. It was same as the result of 'redirect'.
    but the following line, sent10 messages to each recipients.(receive_01,receive_02)
    capture :message "[email protected],[email protected]";
    maybe there was some 'loop' actions happened.The email produced by the capture sieve action is being "captured" which is resulting in a loop. You can stop this by adding an envelope test e.g.
    require ["envelope"];
    if not envelope :is ["to"] ["[email protected]","[email protected]"]
            capture :message "[email protected]";
            capture :message "[email protected]";
    }Regards,
    Shane.

  • How to delete all Messages in B1-Event-Monitor

    Hello,
    is there a way to delete all Messages from the B1-Event-Monitor.
    Now we have:
    ... But when I try the "Delete All" Function nothing happend, and the Browser hang.
    I found this post.B1if db unexplained growth.. and followed all steps.
    1)Monitoring->B1 Event Monitor->Switch the log off. Now press delete all button. To clear all the logs.
    It is recommended that the B1 Event Monitor is turned on only when debugging& analyzing specific issues. During normal usage, you should switch the B1 Event Monitor off:
    2)Maintenance->Cfg Msglog->Click on Manual Delete and provide the appropriate input and press Delete.
    3)B1if is handling the message log deletion automatically on the daily bases (B1if -> Maintenance -> Cfg MsgLog -> Daily deletion button). By default it#s set to 23.00. It means the server needs to be up at this time. This value can be set according the customer#s requirement and here you can find more option regarding the message log settings as well. (Kindly check whether Backup buffer(days) is set to 0, if yes check by changing it to 1)
    4)Schedule an immediate Transaction-Log Garbage Collect (B1if #> Control Center #> Maintenance #> Schedule TLog GC #> Submit)
    5)Open Integration Framework->Control Center->Maintenance->tlog delete->Select the Execution status as "Completed"->submit. Wait for the process to complete.
    6)Now restart the Integration service.
    Messages are still in the B1-Event-Monitor.
    I think our mistake was the LOG-Level ON during all the time.. the daily deletion I switched to 03:00 with 1 day Buffer
    Thank you for an Idea.
    SAP B1 9.0 PL 12
    B1-Integration PL15 = .1.20.8
    Regards
    Markus

    Hi,
    You Can use DB Purge tools.
    May be it will help you for deleting those data.
    You can also view this thread.
    http://scn.sap.com/thread/3606618
    Thanks,
    Tushar

  • How do I force the print dialog to default to Print All?

    Hi all,
    I've searched the forums for this and found several similar requests but no answers so I am posting this as a fresh post.
    I have a requirement to have the print dialog appear when printing from javascript and have it always default to Print All.  From my research, it appears that there are only two API methods to do this:
    1) Print()
    2) PrintWithDialog()
    Neither take paramters.  Both have the same description in the documentation (which seems odd in of itself).
    From our research, PrintWithDialog() appears immediately when called (even if the PDF is not yet fully loaded) but always defaults to, "Print 1 of x" unless the PDF is only 1 page.  In that case, it defaults to Print All.
    The Print() method defaults to Print All.  However, if you call it before the PDF is fully loaded, it does not show.  I have searched these forums and found many other people running into this issue.  One thread suggested to put in a timer to make sure the PDF is loaded and then call print.  This works for small PDFs but our customers could be printing thousands of pages so there is no way to know how long to make the delay.
    I tried paying for Support to answer this question and was told there were NO PAID OPTIONS for getting support on the Acrobat SDK and to come post the question here.  The Support Engineer I spoke with assured me developers read and respond to these forums.
    This is a critical issue for an important customer so any feedback is much appreciated.
    An Adobe employee (Irosenth) mentioned something about a bug being reopened in this thread (http://forums.adobe.com/message/2601148#2601148) but no bug number was ever given.  If it truly is a bug, please provide the number, description and ETA for fix.
    If there is no solution, can I get a response from Adobe that supports my research as posted above?  In other words, confirm that both the API are working as expected?
    Finally, given that it seems many people want this functionality, how do I submit an enhancement request?
    Best Regards,
    Brian

    I downloaded Reader X and the problem is still occurrring, as was reported by the originator of this thread back in November.
    Are there any parameters that need to be set for this to work?  My customer is getting very impatient with this.
    Also, since downloading Reader X the toolbar does not appear by default. It pops up when you hover over the top of the window.   How do I get the toolbar to appear by default?  (this is not nearly as important as defaulting the print dialog to Print All on mulitple page docs when using printwithdialog).

  • Assigning a default schema to a user.

    In Oracle can I assign a default schema to a user without using the later session command?
    Is there a ALTER USER setting where I can assign a user a default schema?

    Buddy,
    To answer to your question.
    1. First grant select any table or "grant select on all tables of user 'ELLIPSE' to the user "094137".
    2. Later to access schema ELLIPSE's objects, from "094137" user, you ll have to create public synonym to all of the tables in ELLIPSE schema.
    3. This way, the user "094137" can access all tables in SCHEMA ELLIPSE, with out specifying(prefixing) the schema name
    Hope this helps
    Thanks
    I would like the user "094137" to logon and have access to the tables in another schema "ELLIPSE" with out qualifying the table name with "ELLIPSE".
    The user "094137" has no objects of her own and only accesses the object of the schema "ELLIPSE".
    Is there a direct way of assigning a user (with no objects) to have a default schema of another users (without the alter session default schema statement)

Maybe you are looking for