Dns in local network for local server

once agin Im here...
after two days of trying to make my local DNS work, I decide to ask here.
All I want to do is get an website located in "/opt/lampp/htdocs" on server by typing its "name" eg. "www.mygreatsite.org"
www site located on servers web server is working when you issue "localhost" in web browser on server.
Im using bind DNS software...
bind configs:
/etc/named.conf
# cat /etc/named.conf
// /etc/named.conf
options {
directory "/var/named";
pid-file "/var/run/named/named.pid";
auth-nxdomain yes;
datasize default;
// Uncomment these to enable IPv6 connections support
// IPv4 will still work:
// listen-on-v6 { any; };
// Add this for no IPv4:
// listen-on { none; };
// Default security settings.
allow-recursion { 127.0.0.1; };
allow-transfer { none; };
allow-update { none; };
version none;
hostname none;
server-id none;
# recursion yes;
zone "localhost" IN {
type master;
file "localhost.zone";
allow-transfer { any; };
zone "0.0.127.in-addr.arpa" IN {
type master;
file "127.0.0.zone";
allow-transfer { any; };
zone "." IN {
type hint;
file "root.hint";
zone "mmanco.org" IN {
type master;
file "mmanco.org.zone";
// recursion yes;
// masters {
// 192.168.1.100;
// allow-query { any; };
allow-transfer { any; };
logging {
channel xfer-log {
file "/var/log/named.log";
print-category yes;
print-severity yes;
print-time yes;
severity info;
category xfer-in { xfer-log; };
category xfer-out { xfer-log; };
category notify { xfer-log; };
zone file:
/var/named/mmanco.org.zone
# cat /var/named/mmanco.org.zone
@ IN SOA server.mmanco.org tepo.server.mmanco.org. (
2002030601 ; serial
21600
1800
604800
900 )
IN NS server.mmanco.org.
localhost IN A 127.0.0.1
mmanco.org. IN A 192.168.0.10
on client side:
/etc/resolv.conf
# cat /etc/resolv.conf
# Generated by NetworkManager
domain satronet.sk
search satronet.sk
#nameserver 192.168.0.10
nameserver 217.144.16.196
nameserver 192.168.0.1
EDIT:
digs client output:
dig @192.168.0.10 mmanco.org
; <<>> DiG 9.7.1-P2 <<>> @192.168.0.10 mmanco.org
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 19928
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available
;; QUESTION SECTION:
;mmanco.org. IN A
;; Query time: 1 msec
;; SERVER: 192.168.0.10#53(192.168.0.10)
;; WHEN: Sat Nov 20 19:42:03 2010
;; MSG SIZE rcvd: 28
that's it!
I'll be thankful for any answer!
Last edited by greengold (2010-11-20 18:48:02)

# named -g
21-Nov-2010 00:13:30.374 starting BIND 9.7.2-P2 -g
21-Nov-2010 00:13:30.374 built with '--prefix=/usr' '--sysconfdir=/etc' '--localstatedir=/var' '--with-libtool' '--enable-shared' '--disable-threads' '--with-openssl=yes' '--disable-linux-caps' '--without-libxml2' 'CFLAGS=-march=i686 -mtune=generic -O2 -pipe' 'LDFLAGS=-Wl,--hash-style=gnu -Wl,--as-needed' 'CXXFLAGS=-march=i686 -mtune=generic -O2 -pipe'
21-Nov-2010 00:13:30.374 using up to 4096 sockets
21-Nov-2010 00:13:30.386 loading configuration from '/etc/named.conf'
21-Nov-2010 00:13:30.387 reading built-in trusted keys from file '/etc/bind.keys'
21-Nov-2010 00:13:30.388 using default UDP/IPv4 port range: [1024, 65535]
21-Nov-2010 00:13:30.388 using default UDP/IPv6 port range: [1024, 65535]
21-Nov-2010 00:13:30.393 listening on IPv4 interface lo, 127.0.0.1#53
21-Nov-2010 00:13:30.393 listening on IPv4 interface eth0, 192.168.0.10#53
21-Nov-2010 00:13:30.394 generating session key for dynamic DNS
21-Nov-2010 00:13:30.399 set up managed keys zone for view _default, file 'managed-keys.bind'
21-Nov-2010 00:13:30.400 automatic empty zone: 0.IN-ADDR.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 127.IN-ADDR.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 254.169.IN-ADDR.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 2.0.192.IN-ADDR.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 100.51.198.IN-ADDR.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 113.0.203.IN-ADDR.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: D.F.IP6.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 8.E.F.IP6.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 9.E.F.IP6.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: A.E.F.IP6.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: B.E.F.IP6.ARPA
21-Nov-2010 00:13:30.400 automatic empty zone: 8.B.D.0.1.0.0.2.IP6.ARPA
21-Nov-2010 00:13:30.404 command channel listening on 127.0.0.1#953
21-Nov-2010 00:13:30.405 command channel listening on ::1#953
21-Nov-2010 00:13:30.405 ignoring config file logging statement due to -g option
21-Nov-2010 00:13:30.407 zone 0.0.127.in-addr.arpa/IN: loaded serial 42
21-Nov-2010 00:13:30.411 zone localhost/IN: loaded serial 42
21-Nov-2010 00:13:30.411 mmanco.org.zone:1: no TTL specified; using SOA MINTTL instead
21-Nov-2010 00:13:30.411 zone mmanco.org/IN: has no NS records
21-Nov-2010 00:13:30.411 zone mmanco.org/IN: not loaded due to errors.
21-Nov-2010 00:13:30.411 managed-keys-zone ./IN: loading from master file managed-keys.bind failed: file not found
21-Nov-2010 00:13:30.412 managed-keys-zone ./IN: loaded serial 0
21-Nov-2010 00:13:30.413 running
so I add "NS      server.mmanco.org." to zone file like this:
@ IN SOA server.mmanco.org tepo.server.mmanco.org. (
2002030601 ; serial
21600
1800
604800
900 )
IN NS server.mmanco.org.
NS server.mmanco.org.
localhost IN A 127.0.0.1
mmanco.org. IN A 192.168.0.10
but result is the same...

Similar Messages

  • Remote Server Admin not working from outside of network for 1 server

    Our company recently changed ISPs and I had to change our two 10.4 server's IP addresses. We have a mail server (intel xserve) and a file/web server (quicksilver g4). Both servers have two network cards in them. The problem is two-fold:
    1- I can successfully manage the Xserve machine locally on our network and from my home. However, I can only manage the Quicksilver g4 server locally. Any kind of external access is not even acknowledged.
    2- I'm not sure if I missed any steps when changing IP addresses for these server-based computers. Also, I'm not sure if I correctly set our dns names to the correct IP address.
    For some background, this is the exact IP update process I used for each server:
    Quicksilver G4 (file/web server) - Installed network card #2 and configured it with the new Public IP in the "System Preferences/Network" panel. In Server Admin I set our website to use the new public IP address. (network card #2 has no firewall device in between it and the internet.)
    Then, I configured the default network card #1 to a static, yet private IP address that's behind our DLink firewall device with the rest of our network.
    Intel Xserve (e-mail server) - Network card #1 was the only one setup before our network change. It had a static, public IP address. When we changed ISPs, I configured network card #2 to the new static, public IP address supplied to us by the new ISP in the "System Preferences/Network" panel. This new IP address is where all email traffic currently gets pointed to. (All mail is successfully sent and delivered.) Until our former ISP gets shutdown, I still have network card #1 configured to the older static public IP address. After the old ISP is shut off, I plan on changing network card #1 to a static, private address.
    Any assistance would be greatly appreciated.
      Mac OS X (10.4.8)  

    What should I check in AD?  I am by no means an expert with AD.
    Yes, I am using the same client OS.
    I am talking about RDP over the internet, like from home to the office.  We have a static IP assigned to the router from ISP.  A static internal IP assigned to the server on the LAN.  And the router port forwards 3389 to the assigned IP. 
    It was working fine before we reinstalled Server 2012.  These are the steps I took when reinstalling:
    1. format drive and install OS
    2. rename the server
    3. install SQL server
    4. Install TFS and SharePoint
    5. Add Active Directory role and promote to Domain Controller
    6. Add domain users
    7. Enable remote access on the server and add users to remote access list

  • Lion Server DNS service not working for locally created zones. Caching working fine.

    OS Lion Server DNS service not working for local zones. Was fine under Snow leopard server but Lion server upgrade has severely broken my DNS and web sites. Zones look fine under Server Admin but keep getting "query failed (SERVFAIL) for xxxx at /SourceCache/bind9/bind9-42/bind9/bin/named/query.c:3921" in the logs. BTW - Server Admin cant seem to see the log file either.
    Surely someone actually tested that DNS still worked on Lion?

    I upgraded from Snow Leopard Server to Lion Server on day 01.  I hit the same issue where, after the upgrade, my Lion Server stopped serving names for my private local domain.
    I finally took a few minutes to figure out what was wrong.  After turning on debug logging and looking through the logs, I found my particular issue, now resolved.
    The issue I had was, when the domain initially was setup when I installed Snow Leopard Server, for some reason it created a zone just for the server (in my case, something like zone "s-01.mydomain.priv"), and a separate zone for all the other machines (zone "mydomain.priv", containing all the private IPs for my local domain).  I never messed with it because it worked, but generally I would have put all of them in the same zone.
    My zone "mydomain.priv" had a nameserver and mail exchanger entry for my server, s-01.mydomain.priv.  I could see this in the Server Admin app on the DNS bubble, Zones tab, mydomain.priv selected, and the General Info panel.  This was fine in Snow Leopard.  This was failing the zone load in the updated bind for Lion Server, though.  The issue was that the "mydomain.priv" zone was referencing the s-01.mydomain.priv server, which was not defined in the "mydomain.priv" zone but rather in the "s-01.mydomain.priv" zone.
    My fix:
    1. In Server Admin, add the server to the zone "mydomain.priv".  I put an A record (Add Machine) in the "mydomain.priv" zone for my server named s-01.mydomain.priv.
    2. shut down DNS on the OS X Lion Server (hit the Stop DNS button on Server Admin).
    3. edit /etc/named.conf by hand, removing the specialized zones that contianed just the server.  In this case, it would be the section titled 'zone "s-01.mydomain.priv"' and the section titled 'zone "3.10.1.10.in-addr.arpa"'.  Your in-addr.arpa zone name will change based on whatever your server IP address was.  My internal one happened to have s-01.mydomain.priv mapped to 10.1.10.3.
    4. Once the specialized zones for just the server were removed, I started the DNS up again.  Instead of serving four zones as it had in OS X Snow Leopard Server, it now servers two zones.  And, now, it is resolving my local machines for the mydomain.priv zone.
    YMMV.  I did note that it wasn't totally necessary to do step 3, but I never really understood the need for the specialized domain, and keeping it around would have a copy of data that would just confuse things.
    Hope that helps.  That's been the only hiccup I've noticed updating to OS X Lion Server thus far.

  • While trying to access my local network I get the message..."The page could not be opened because server cannot be found."  This, after updating to Yosemite and paying (again) for the server app.

    while trying to access my local network I get the message..."The page could not be opened because server cannot be found."  This, after updating to Yosemite and paying (again) for the server app.

    It's absolutley scandalous that a company with Apple's resources can let this happen.  They should have staggered the release by region rather than opening the flood gates.  The upgrade itself took me about 10 attempts to download it, and then I thought I was home free.  That was until it rebooted and won't activate.  It's over 2 hours now.
    Scandalous!

  • How to set up local server to use a remote server for login authentication?

    Thank you in advance for any help you can offer.
    We are trying to set up a "sub-network" (dont' know if this is the right terminology) using a 10.4 Server OS, to manage a set of clients... the trick is that the client login/home directory information is on a different remote server, and shall remain there, for the most part.
    To make it easy to understand here's the environment:
    *Local Server:* 10.4 G4 Server Quicksilver 1G dual--we have total control of this one
    *Main/remote server:* 10.5 Xserve.. don't know which vintage--we have very very very little input on this machine.. effectively at the mercy of the sysadmin of this system who is very conservative in changing anything (hence the need for a separate server to install applications and client machine-specific profiles, etc since the Xserve admin refuses do it). This serves MacBooks/MacBookPros and few iMacs. (no Windows PC.. as that group of comptuers have their own server)
    client: ~20 eMacs/iBooks all running 10.4.
    use environment: elementary school-->very low network demand (no e-mail, just running local apps linking to server(s) for licensing and login, and some file saving small files on remote server, user preferences, etc).
    The remote server (the Xserve) has all the login authentication, as well as the home directories. every school year, the directories get updated as new students enroll and old students graduate. Currently all the clients are directly linked to the Xserve via LDAP while we bring the local server on-line.
    the local sever (our G4 Quicksilver) will have few network applications that will support the client machines. We also will be setting up computer accounts and groups for our clients so that we can properly set their environments (the Xserve admin will not do this on the Xserve, so currently all the clients are connecting to the server as a "guest computer" from what little I understand watching what was done)
    now, what is the best way to approach this type of set up with minimal "inconvenience" of the Xserve admin?
    I am pretty experienced with standalone UNIX and macOS X administration, but a novice to this whole Server and network setup thing. Any suggestions, instructions, pointers to URLs with how-tos is much appreciated. I am not afraid to use Terminal (grew up on UNIX before GUI), etc., and willing to try safe but unconventional setups if that is what's needed...
    thanks for any help!

    Oh never mind.... I figured it out myself helps to read up on the manuals. d'oh. sorry for the bandwidth waste...

  • Safari can't connect to local server for AirPlay and printer

    I have several Airplay devices and one printer set up using Bonjour or AirPlay. This is all on most up to date Mavericks, iOS 7, and 2009 iMac.
    In the past, I used to be able to enter an IP address (like for the printer or a powered speaker) and log in to check for firmware updates, etc. But now, while the speakers and printer ALL connect and play/print fine from my Mac and iOS and are clearly on my local network — when I try to access the sites for each — Safari says it "can’t connect to the local server because, it can’t connect to the local server"!
    What is happening and, how can I regain web access to these devices?
    It does not seem to be the printer, two powered speakers, or a small Wi-Fi device used with an AV stereo. They are all made by different companies and all can’t be broken. Especially, since they all work fine except for access to their internal web sites.
    What do I have set, somewhere, that would block out web page access in the local network?

    Well, I never could get the Bonjour menu to access device settings in Safari.
    So I looked to see if Bonjour could work in Chrome or Firefox. It can!
    But you need a plugin. I used Ciaociao in Firefox (I think also for Chrome). It places a small globe icon with other things you added like Pinterest, etc. in the tab bar.
    It worked like a charm. I selected the devices from a Bonjour menu Ciaociao presents, accessed the settings, downloaded firmware updates, changed names, etc.
    Clearly, there seems to be a Bonjour Safari issue. At least with Mavericks.
    It was disappointing that hours with multiple Apple techs did not solve this. A lot of time on hold too. Nobody really knew about Bonjour or Airplay at all. Everyone wanted to pass me off to some other “device” when, it was not a device issue but the broader “internet of things” issue.
    Apple is clearly unprepared for customer service in this high growth area.

  • Yosemite 10.10.2 server app. FTP help. I have a program running in my local server enviroment that wants to FTP to my mac folder. It asks for the server , name, password, port and path. what are they?

    So I have set up a localhost area in my Mac. I have the new server.app and I am running yosemite 10.10.2 .
    I have a program running in my local server enviroment that wants to FTP to my mac .
    It asks for the server , name, password, port and path. what are they?
    I am pretty certain that the Serveris "localhost",
    Name is my macs name (like my-mac-min)
    password is "my login password"
    and they suggest port 21.
    But what is the file path, lets just say my site is set up http://localhost/siteftp and is actually at my Users/Sites/siteftp folder.
    Why cant this program connect to the mac.
    Is it because they are both operating in the same localhost enviroment,
    could it be my folder permissions are not correct on siteftp folder?
    Help please !

    I tried turning the computer off and then back on. The alerts don't show the notice to update as resolved. Hopefully this is not a problem or an indicator or another problem. Should I ignore or reload 10.10.1 from the app store to trigger a resolved check in a green circle?
    Interesting that I had to buy server software after my free Yosemite download. I would have hoped that the two pieces of software would have gone together without any complication. It is not positive to end up buying a problem. Ah well, time to move on.

  • Can I use Microsoft SQL Server Management Studio version 11.0 to write SQL queries for "SQL Server Compact 4.0 Local Database"

    Hi, Can I use Microsoft SQL Server Management Studio version 11.0 to write SQL queries for "SQL Server Compact 4.0 Local Database" ?
    When I use Connect Object Explorer, the "Connect to Server" dialog box which pops up has only 4 selections in the Server Type Drop Down List. They are Database Engine, Analysis Services, Reporting Services & Integration Services. I have read
    somewhere that there should be a compact database option. but I do not see it.
    What I would like to do is use free form SQL Queries against the tables in "SQL Server Compact 4.0 Local Database" .
    Once I have validated these queries, then I will use them in my Visual Studio 2012 C#, ASP.NET application. I created the Local Database using Visual Studio 2012 for use by my application.
    Thank you for your help..
    diana4

    Hello,
    With SSMS 2005 we have had the Option to work with SQL CE database files, but not with higher Version of SSMS.
    You can use the free SQL CE Toolbax instead; see
    http://sqlcetoolbox.codeplex.com/
    Olaf Helper
    [ Blog] [ Xing] [ MVP]

  • I need helping!!! configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.

    I need helping configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.
    I have attempted to configure rdp access but it does not seem to be working for me Could I please ask someone to help me modify my current configuration to allow this? Please do step by step as I could use all the help I could get.
    I need to allow the following IP addresses to have RDP access to my server:
    66.237.238.193-66.237.238.222
    69.195.249.177-69.195.249.190
    69.65.80.240-69.65.80.249
    My external WAN server info is - 99.89.69.333
    The internal IP address of my server is - 192.168.6.2
    The other server shows up as 99.89.69.334 but is working fine.
    I already added one server for Static route and RDP but when I try to put in same commands it doesnt allow me to for this new one. Please take a look at my configuration file and give me the commands i need in order to put this through. Also please tell me if there are any bad/conflicting entries.
    THE FOLLOWING IS MY CONFIGURATION FILE
    Also I have modified IP information so that its not the ACTUAL ip info for my server/network etc... lol for security reasons of course
    Also the bolded lines are the modifications I made but that arent working.
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password DowJbZ7jrm5Nkm5B encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.6.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 99.89.69.233 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group network EMRMC
    network-object 10.1.2.0 255.255.255.0
    network-object 192.168.10.0 255.255.255.0
    network-object 192.168.11.0 255.255.255.0
    network-object 172.16.0.0 255.255.0.0
    network-object 192.168.9.0 255.255.255.0
    object-group service RDP tcp
    description RDP
    port-object eq 3389
    object-group service GMED tcp
    description GMED
    port-object eq 3390
    object-group service MarsAccess tcp
    description MarsAccess
    port-object range pcanywhere-data 5632
    object-group service MarsFTP tcp
    description MarsFTP
    port-object range ftp-data ftp
    object-group service MarsSupportAppls tcp
    description MarsSupportAppls
    port-object eq 1972
    object-group service MarsUpdatePort tcp
    description MarsUpdatePort
    port-object eq 7835
    object-group service NM1503 tcp
    description NM1503
    port-object eq 1503
    object-group service NM1720 tcp
    description NM1720
    port-object eq h323
    object-group service NM1731 tcp
    description NM1731
    port-object eq 1731
    object-group service NM389 tcp
    description NM389
    port-object eq ldap
    object-group service NM522 tcp
    description NM522
    port-object eq 522
    object-group service SSL tcp
    description SSL
    port-object eq https
    object-group service rdp tcp
    port-object eq 3389
    access-list outside_1_cryptomap extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 192.168.0.0 255.255.0.0
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-data
    access-list outside_access_in extended permit udp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-status
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ftp
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ldap
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq h323
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq telnet
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq www
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group SSL
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM522
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM1731
    access-list outside_access_in extended permit tcp 173.197.144.48 255.255.255.248 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp any interface outside eq 3389
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333 object-group rdp
    access-list outside_access_in extended permit tcp any host 99.89.69.333 object-group rdp
    access-list out_in extended permit tcp any host 192.168.6.2 eq 3389
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp 99.89.69.334 3389 192.168.6.1 3389 netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 99.89.69.338 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable
    http 192.168.6.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 68.156.148.5
    crypto map outside_map 1 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 1
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    tunnel-group 68.156.148.5 type ipsec-l2l
    tunnel-group 68.156.148.5 ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:f47dfb2cf91833f0366ff572eafefb1d
    : end
    ciscoasa(config-network)#

    Unclear what did not work.  In your original post you include said some commands were added but don't work:
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    and later you state you add another command that gets an error:
    static (inside,outside) tcp 99.89.69.333 3389 192.168.6.2 3389 netmask 255.255.255.255
    You also stated that 99.89.69.333 (actually 99.89.69.233, guessing from the rest of your config and other posts) is your WAN IP address.
    The first static statement matches Cisco's documentation, which states that a static statement must use the 'interface' directive when you are trying to do static PAT utilizing the IP address of the interface.  Since 99.89.69.333 is the assigned IP address of your WAN interface, that may explain why the second statement fails.
    Any reason why you are using static PAT (including the port number 3389) instead of just skipping that directive?  Static PAT usually makes sense when you need to change the TCP port number.  In your example, you are not changing the TCP port 3389.

  • How do I set up networking for DNS resolution?

    I am setting up a brand new iMac (10.9.4). I've put the two internal DNS servers into the network configuration (Windows Servers running DNS). However pinging by hostname and FQDN doesn't work
    Matts-iMac:~ mattgeorge$ ping victor.rafmuseum.local
    ping: cannot resolve victor.rafmuseum.local: Unknown host
    Interestingly, nslookup is fine:
    Matts-iMac:~ mattgeorge$ nslookup victor.rafmuseum.local
    Server: 172.16.0.11
    Address: 172.16.0.11#53
    Name: victor.rafmuseum.local
    Address: 172.16.0.15
    And pinging the IP address works correctly too. Windows servers appear in the finder and I can connect to them from there but the Connect to Server option again will not resolve a DNS address. Also in researching this I note that Directory Access no longer appears in Applications.
    Tim

    This is the chowder-headed default value that's arises from older Windows Server installations.   Microsoft fixed this in more recent versions.  Folks that didn't know DNS and that chose to take the default top-level domain from older Windows Server installations were led into a morass, unfortunately. 
    You're basically going to have to run parallel DNS services until you can reconfigure those Windows Server DNS servers over into a valid top-level domain — when Microsoft specified this default of .local, .local was not a reserved top-level domain — or otherwise limp along here.   This because .local is a reserved domain now, as it's used for Bonjour/mDNS. 
    The usual fix is to move into a real and registered domain, which is obviously a pain now, but only tends to get worse over time.
    The usual workaround is to set up parallel DNS services, to add "local" to the list of search domains within network preferences (haven't tried this recently, but it was the old workaround for this case, see Mac OS X v10.4, 10.5, 10.6: How to look up ".local" hostnames via both Bonjour and standard DNS) and then incrementally migrate preferably to a real-and-registered domain over time, and/or to otherwise avoid using the .local domain where that's feasible. 
    FWIW, rafmuseum.net is currently available for registration, and you can use a subdomain of one you already have — if one of those other existing registrations is associated with your organization — and there are a gazillion other new top-level domains now or coming online to choose from — though you can't have .local here, as that's RFC-reserved for Bonjour/mDNS activity.

  • How to access the local server host website in the internet

    I set up the server and host on local website, I wonder how I could use other mac to access this local website via the internet?
    Thanks!

    The following should give you enough to search for discussions, as well as some general details of IP network gizmos and boxes:  You'll need an ISP tier of service that allows remote access and preferably with a static IP address (static versus dynamic IP).  This as various ISPs prohibit server-oriented protocols such as HTTP TCP port 80 traffic, and some firewall server-oriented ports.   You'll then either need to use either dynamic DNS with your public dynamic IP — this is the hacking-around and not-really-for-production approach — or static IP with traditional DNS, and you'll also need to enable what's called port forwarding (sometimes also called virtual server) through your gateway-firewall-NAT device and into your server for TCP port 80 and possibly also TCP port 443.  This port forwarding gets the incoming connections from the 'net into your public IP address (static or dynamic) mapped through to your NAT'd IP address space and your private IP address for your server. 
    As the first part of getting any of this to work with OS X Server, launch Terminal.app on the server and issue the following harmless diagnostic command:
    sudo changeip -checkhostname
    This checks for common errors in the local DNS setup, and broken networking and broken DNS tends to cause other errors elsewhere in the environment.  You'll need to enter an administrative password for the sudo, you might get a one-time informational message from the sudo, and you'll then get some configuration details and then an indication that DNS and local networking needs no changes, or that there are configuration issues.

  • Creating aliases for a server in DNS

    Hello,
    We are developping a BI solution. We have 4 different environments/domains : development, test and acceptance and production. The servernames differ in each environment. For example the server in development is called SRVDEV10 while the server
    in test is called SRVTEST21. The full names will be like SRVDEV10.development.local and SRVTEST21.test.local
    Now I would like that the network administrators to create a DNS alias called BI_Server.
    If I am in the development environment BI_Server should point to SRVDEV10 and if I am in the test environment BI_Server should point to SRVTEST21.
    Is something possible ? Should they make aliases like BI_Server.development.local : SRVDEV10.development.local and BI_Server.test.local : SRVTEST21.test.local. Those domains are seperated and it should normally not possible to go directly from development
    to test. It is also internal used and not accessable from the outside (internet) 
    Of course I can modify the hosts file but I don't want that.
    What do you think ?
    Constantijn

    Hi Constantijn,
    According to your description, you want to create a DNS alias and point the alias to different servers. The issue is more related to Windows Server DNS, I would like to recommend you post the question in the Windows Server forums at
    https://social.technet.microsoft.com/Forums/en-US/home?category=windowsserver . It is appropriate and more assists will assist you.
    However, if you need to configure hostname alias for SQL Server instance, you can review the steps in this following blog.
    http://blogs.msdn.com/b/dbrowne/archive/2012/05/21/how-to-add-a-hostname-alias-for-a-sql-server-instance.aspx
    Thanks,
    Lydia Zhang
    If you have any feedback on our support, please click
    here.
    Lydia Zhang
    TechNet Community Support

  • I have 2 websites and 1 IP address for my server, how do I set the DNS up?

    I am having trouble following the boards and the Server Admin instructions to make sure I can activate a website.
    IP address for the Snow Leopard Server on a mac mini
    Server Settings for Web has the 2 domain names listed pointing to the same IP address and same port 80.
    How do I point the DNS correctly to the domain I want to respond?  www.ziggythewinegal.com
    If you put the IP address in a browser, it returns the default domain which is just the apache/osx server page. 64.142.85.71
    If you put the first domain name in a browswer, it does the same. www.JoelQuigley.com
    How do I setup the DNS to www.ziggythewinegal.com which is in the folder WebServer>ziggy>index.php ?

    64.142.85.71 has an existing public DNS translation, so you'll be adding DNS CNAME (alias) records for the each of the additional hosts into your public DNS at WorldNIC DNS servers.
    Your local host either isn't running DNS, or it's running local DNS.  If it's running local DNS, then hopefully it's not running with the same domain name as your public DNS services; that you have an external DNS zone and an internal DNS zone, with an external DNS domain and an internal domain name.  If you are running DNS locally and are using the same domain name for internal and external DNS servers, then you'll also need to add the translation for the new web sites into your local DNS server configuration.
    Once the translation is added, add - as John Lockwood indicates - Sites into your web server. 
    The numbers of folders can vary.  Different sites may or may not be in the same folder, depending on what you're doing. Multiple ttraditional static HTML web sites are probably stored in separate folders.  A single site with several names can be in the same folder.  A web content management system (CMS) can be stored in one folder.
    If you have a firewall here (and you should), then you may need some additional steps.  Particularly if you're running NAT, and don't already have rules and port-forwarding enabled on the server.  Given it appears you're using mail with this server, there are likely some rules in place, though you'll need to confirm that port 80 TCP and possibly port 443 TCP are (also) being forwarded for your web services.
    Here is a write-up on adding what Apple calls Sites and what Apache calls virtual hosts.

  • What happens when Sync "connects to" local server?

    While setting up an account, one of the options is "Connect to." There is a drop-down with a default setting of "Firefox Sync Server." I believe the other option is something about setting up your info on a local server, but I can't find anything in the instructions about it.
    I have a Western Digital network attached storage drive which looks just like extra drives to all my PCs. Can Firefox Sync save my data on a device attached to my LAN? If so, can I move the target for the existing account or do I have to make a new account?

    See:
    *https://wiki.mozilla.org/Labs/Weave/1.0/Setup/Storage
    *http://tobyelliott.wordpress.com/2009/09/11/weave-minimal-server/
    *https://wiki.mozilla.org/Labs/Weave/Developer/StorageFormat

  • Unable to connect to local server

    Folks:
    When I tried to access an older Mac running Leopard (10.5.8) from my MacBook Pro running Mavericks (Finder: Go: Connect to Server: LocalServer), I was unable to connect and received a message,
    'There was a problem connecting to the server "LocalServer".  The server may not exist or is unavailable at this time.  Check the server name or IP address, check your network connection, and then try again."
    I tried deleting any keychain refrerence to local computer. 
    I tried deleting the list of recent servers from the Finder. 
    I tried restarting both my laptop and the local server.
    Nothing, 
    There is a local server icon under the "Shared" section of the sidebar of the Finder browsing window.  I can find no way to delete this listing. 
    I can access the the Mavericks MBP from the old Leopard server via remote login, but I was unable access the old Leopard server from the new Mavericks running MBP. 
    I finally achiveved access by
    1) Turning on SMB sharing for my account on the local server
              System Preferences: Sharing: File Sharing: Options: SMB Sharing: MyAccount then storing my password.
    2) On my MBP, connecting via smb.
              Finder: Go: Connect to Server: [Enter smb://Localserver.local]
    It finally worked, BUT … after successfully connecting to the local server, I now have TWO listings for Localserver in my Finder browser window, the live link and the old link which still says "Connecting." 
    I can't figure out how to get rid of the earlier afp link, OR how to make it work.  I would prefer to use AFP as the SMB notation from both computers indicates that the storage of my password is not as secure. 
    Restaring the computer doesn't help.
    I had a similiar problem when I upgraded to Mountain Lion, and I tried many of the same tricks to no avail.  That problem seems to have fixed itself. 
    Anybody have any bright ideas?
    Thanks much.

    I should have been more clear. This is on an 8-core Intel XServe.
    I was able to use Server Admin locally on the machine for weeks. Now I can't. Nothing has changed or been altered on the machine during that period.
    I can not connect to the server via Server Admin remotely or locally. I can connect via SSH, ARD, etc. and the system is still serving NFS just fine, so it's just the process that handles communication with Server Admin that is non responsive.
    Something interesting from the syslog:
    qt1 servermgrd[44258]: servermgr_accounts: noteDirectorySearchPolicyChanged (reopening nodes)
    qt1 servermgrd[44258]: -[AccountsRequestHandler(AccountsOpenDirectoryHelpers) openLocalLDAPNodeIfNeeded]: dsLocalLDAP = (null) , error = Error Domain=com.apple.OpenDirectory Code=2000 UserInfo=0x1066a16c0 "Unable to open Directory node with name /LDAPv3/127.0.0.1."
    qt1 DirectoryService[31]: DirectoryService has 42000 internal references open (due to clients), warning limit is 2000.
    These lines repeated apprx. every 30 secs until I bounced the servermgrd. Now, I see that entry whenever I try to connect to the local server via Server Admin.
    Now, this system is not a LDAP server, but I understand OSXS still uses LDAP for local directory info... I've tried restarting the related directory services as well, but still no joy.
    It looks like my only recourse is a reboot, which is really not a great option for a dedicated file server. Am I the only one who has ever encountered this issue of Server Admin eventually losing contact with a server?

  • Can I set an OU to have 2 GPO's one to pull updates from local server and another from replica server

    I'm looking for a solution where I don't change our current AD groups, (avoid using a local group and a field group), also trying to avoid using a server in a DMZ to handle field people (will need to buy a new server).
    At the end i'm looking to use a replica server to push updates from the internet to the field group (or OU with a GPO pointing to such replica server) and use the local server to host the updates locally and push to the office people.
    Probably this is the question that needs to be answered, can an OU group have 2 different GPO's pointing to 2 different WSUS servers (local and replica) (local updates vs updates from internet) and if an user of such group is in the office they get updates
    from the local server and if he is in the field get the updates from the replica server?  I know GPO's can have precedence set to the OU, but do they work like a trigger or something that tells them to go to the next GPO.
    Thanks in advance

    can an OU group have 2 different GPO's pointing to 2 different WSUS servers (local and replica) (local updates vs updates from internet)
    No.
    and if an user of such group is in the office they get updates from the local server and if he is in the field get the updates from the replica server?
    There are two ways to achieve this. Typically we talk about this scenario when the mobile systems are going to use AU/WU to get Security Updates. Taking advantage of the fact that GROUP policy cannot refresh on a machine which is not "in the office", you
    define a Registry Script to run in the user's STARTUP folder, which will set the registry values to configure that client to use the alternate source.
    But, in the case where you have an Internet-facing WSUS server in the DMZ, and a Corporate-facing WSUS server on the LAN, you use the SAME URL, but use DNS to direct the client to the correct IP Address. When the client is on the LAN, the LAN DNS gives the
    IP Address of the Corporate server; when the client is on the Internet, the Internet DNS gives the IP Address of the DMZ server.
    Lawrence Garvin, M.S., MCSA, MCITP:EA, MCDBA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2014)
    My MVP Profile: http://mvp.microsoft.com/en-us/mvp/Lawrence%20R%20Garvin-32101
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

Maybe you are looking for