Dynamic routing issue

Hello,
well, my question is: I have one central route (Cisco Catalyst 3750G-48TS-S) and twenty Switch with layer three ios (Cisco 3560G-24) conected in star topology....
What i want to know is, how central router can communicate with just another router (Cisco 1841) that is behind any 3560G layer three switch?
the cisco 1841 is always the same router that could be behind any other cisco 3560G switch.
Thanks a lot for your patience!
Bruno

Sorry, Jon
I'm Portuguese and sometimes i have to speak spanish and i'm confusing some words... sorry about that. What i want to mean was backbone....
CISCO 3750 x 1
interface Loopback0
ip address 10.0.0.1 255.255.255.255
ip pim sparse-mode
interface Loopback1
ip address 10.1.1.1 255.255.255.255
ip pim sparse-mode
interface Port-channel1
no ip address
interface Port-channel1.30
description VLAN_INTEGRACAO_1
encapsulation dot1Q 30
ip address 10.210.0.2 255.255.255.248
interface Port-channel1.31
description VLAN_INTEGRACAO_2
encapsulation dot1Q 31
ip address 10.210.0.18 255.255.255.248
interface Port-channel1.201
encapsulation dot1Q 201
ip address 10.10.10.2 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.202
encapsulation dot1Q 202
ip address 10.10.10.10 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.203
encapsulation dot1Q 203
ip address 10.10.10.18 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.204
encapsulation dot1Q 204
ip address 10.10.10.26 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.205
encapsulation dot1Q 205
ip address 10.10.10.34 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.206
encapsulation dot1Q 206
ip address 10.10.10.42 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.207
encapsulation dot1Q 207
ip address 10.10.10.50 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.208
encapsulation dot1Q 208
ip address 10.10.10.58 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.209
encapsulation dot1Q 209
ip address 10.10.10.66 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.210
encapsulation dot1Q 210
ip address 10.10.10.74 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.211
encapsulation dot1Q 211
ip address 10.10.10.82 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.212
encapsulation dot1Q 212
ip address 10.10.10.90 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.213
encapsulation dot1Q 213
ip address 10.10.10.98 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.214
encapsulation dot1Q 214
ip address 10.10.10.106 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.215
encapsulation dot1Q 215
ip address 10.10.10.114 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.216
encapsulation dot1Q 216
ip address 10.10.10.122 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.217
encapsulation dot1Q 217
ip address 10.10.10.130 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.218
encapsulation dot1Q 218
ip address 10.10.10.138 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.219
encapsulation dot1Q 219
ip address 10.10.10.146 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.220
encapsulation dot1Q 220
ip address 10.10.10.154 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.230
encapsulation dot1Q 230
ip address 10.10.10.162 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Port-channel1.500
description VLAN_WIMAX_MANAGEMENT
encapsulation dot1Q 500
ip address 10.10.50.49 255.255.255.0
no ip mroute-cache
interface Port-channel1.555
description VLAN_RADIO_MANAGEMENT
encapsulation dot1Q 555
ip address 10.200.20.2 255.255.255.0
standby ip 10.200.20.1
standby priority 140
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
media-type rj45
no negotiation auto
channel-group 1
interface GigabitEthernet0/1
no ip address
ip pim sparse-mode
duplex auto
speed auto
media-type rj45
no negotiation auto
channel-group 1
interface GigabitEthernet0/2
no ip address
ip pim sparse-mode
no ip mroute-cache
duplex auto
speed auto
media-type rj45
no negotiation auto
interface GigabitEthernet0/2.10
description VLAN_DADOS
encapsulation dot1Q 10
ip address 192.168.120.1 255.255.255.0
ip pim sparse-mode
interface GigabitEthernet0/2.11
description VLAN_MANAGEMENT
encapsulation dot1Q 11
ip address 10.2.120.1 255.255.255.0
ip pim sparse-mode
interface GigabitEthernet0/2.12
description VLAN_VOICE
encapsulation dot1Q 12
ip address 192.168.121.1 255.255.255.0
ip pim sparse-mode
interface GigabitEthernet0/2.13
description VLAN_PRINTERS
encapsulation dot1Q 13
ip address 192.168.122.193 255.255.255.192
interface GigabitEthernet0/2.14
description VLAN_BACKUP
encapsulation dot1Q 14
ip pim sparse-mode
interface GigabitEthernet0/2.15
description VLAN_RED_FW
encapsulation dot1Q 15
ip pim sparse-mode
interface GigabitEthernet0/2.17
description MNG_FW
encapsulation dot1Q 17
ip address 192.168.122.1 255.255.255.192
interface GigabitEthernet0/2.18
description RED_GNR
encapsulation dot1Q 18
ip address 192.168.220.1 255.255.255.0
interface GigabitEthernet0/2.550
description VLAN_SERVER_MANAGEMENT
encapsulation dot1Q 550
ip address 10.10.20.1 255.255.255.0
interface POS1/0
no ip address
encapsulation ppp
crc 32
clock source internal
pos framing sdh
pos scramble-atm
router eigrp 1
network 10.10.10.0 0.0.0.7
network 10.10.10.8 0.0.0.7
network 10.10.10.16 0.0.0.7
network 10.10.10.24 0.0.0.7
network 10.10.10.32 0.0.0.7
network 10.10.10.40 0.0.0.7
network 10.10.10.48 0.0.0.7
network 10.10.10.56 0.0.0.7
network 10.10.10.64 0.0.0.7
network 10.10.10.72 0.0.0.7
network 10.10.10.80 0.0.0.7
network 10.10.10.88 0.0.0.7
network 10.10.10.96 0.0.0.7
network 10.10.10.104 0.0.0.7
network 10.10.10.112 0.0.0.7
network 10.10.10.120 0.0.0.7
network 10.10.10.128 0.0.0.7
network 10.10.10.136 0.0.0.7
network 10.10.10.144 0.0.0.7
network 10.10.10.152 0.0.0.7
network 10.10.10.160 0.0.0.7
network 10.10.50.0 0.0.0.255
network 10.0.0.0
network 192.168.2.0
network 192.168.120.0
network 192.168.121.0
network 192.168.122.192 0.0.0.63
network 192.168.220.0
no auto-summary
ip route 0.0.0.0 0.0.0.0 192.168.2.254
ip route 10.26.8.0 255.255.255.0 192.168.2.254
ip route 10.200.0.0 255.255.0.0 10.200.20.16
ip route 192.168.2.0 255.255.255.0 192.168.120.254
ip route 192.168.125.0 255.255.255.0 10.10.10.163
ip route 192.168.126.0 255.255.255.0 10.10.10.163
ip route 192.168.127.0 255.255.255.0 10.10.10.163
ip route 192.168.130.0 255.255.255.0 10.10.10.113
ip route 192.168.131.0 255.255.255.0 10.10.10.121
ip route 192.168.132.0 255.255.255.0 10.10.10.129
ip route 192.168.133.0 255.255.255.0 10.10.10.137
ip route 192.168.134.0 255.255.255.0 10.10.10.153
ip route 192.168.135.0 255.255.255.0 10.10.10.145
ip route 192.168.136.0 255.255.255.0 10.10.10.57
ip route 192.168.137.0 255.255.255.0 10.10.10.49
ip route 192.168.138.0 255.255.255.0 10.10.10.33
ip route 192.168.139.0 255.255.255.0 10.10.10.41
ip route 192.168.140.0 255.255.255.0 10.10.10.9
ip route 192.168.141.0 255.255.255.0 10.10.10.1
ip route 192.168.142.0 255.255.255.0 10.10.10.17
ip route 192.168.143.0 255.255.255.0 10.10.10.25
ip route 192.168.152.0 255.255.255.0 10.10.10.81
ip route 192.168.153.0 255.255.255.0 10.10.10.73
ip route 192.168.154.0 255.255.255.0 10.10.10.65
ip route 192.168.155.0 255.255.255.0 10.10.10.89
ip route 192.168.156.0 255.255.255.0 10.10.10.97
ip route 192.168.157.0 255.255.255.0 10.10.10.105
ip route 192.168.225.0 255.255.255.0 10.10.10.163
ip http server
ip pim rp-address 10.0.0.1
ip msdp peer 10.1.1.2 connect-source Loopback1
ip msdp redistribute list 111
ip msdp originator-id Loopback1
CISCO 3560G x 20
interface GigabitEthernet0/1
description Digi
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/2
description Codec
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/3
description Switch_Torre
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/4
description Servidor
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/5
description Wimax
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 500-508
switchport mode trunk
interface GigabitEthernet0/6
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/7
description PC_Operador
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/8
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/9
description Telefone_Operador
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/10
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/11
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/12
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/13
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/14
description CCTV1
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/15
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/16
description CCTV2
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/17
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/18
description CCTV3
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/19
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/20
description CCTV4
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/21
description Central_Alarmes
switchport access vlan 115
switchport mode access
switchport block multicast
interface GigabitEthernet0/22
description Intercomunicador
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/23
description Central_Acessos
switchport access vlan 115
switchport mode access
interface GigabitEthernet0/24
description ALCATEL
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 215,500
switchport mode trunk
interface GigabitEthernet0/25
interface GigabitEthernet0/26
interface GigabitEthernet0/27
interface GigabitEthernet0/28
interface Vlan1
no ip address
interface Vlan115
description SEGMENTO_PO
ip address 192.168.130.1 255.255.255.0
ip pim sparse-mode
no ip mroute-cache
interface Vlan215
description SEGMENTO_CCC
ip address 10.10.10.113 255.255.255.248
ip pim sparse-mode
no ip mroute-cache
interface Vlan500
description VLAN_WIMAX_GESTION
ip address 10.10.50.43 255.255.255.0
interface Vlan501
description WIMAX_UM1
ip address 10.10.51.16 255.255.255.0
ip pim sparse-mode
no ip mroute-cache
interface Vlan502
description WIMAX_UM2
ip address 10.10.52.16 255.255.255.0
ip pim sparse-mode
no ip mroute-cache
interface Vlan503
description WIMAX_UM3
ip address 10.10.53.16 255.255.255.0
ip pim sparse-mode
no ip mroute-cache
interface Vlan504
description WIMAX_UM4
ip address 10.10.54.16 255.255.255.0
ip pim sparse-mode
no ip mroute-cache
interface Vlan505
description WIMAX_UM5
ip address 10.10.55.16 255.255.255.0
ip pim sparse-mode
no ip mroute-cache
interface Vlan506
description WIMAX_UM6
ip address 10.10.56.16 255.255.255.0
ip pim sparse-mode
no ip mroute-cache
interface Vlan507
description WIMAX_UM7
ip address 10.10.57.16 255.255.255.0
ip pim sparse-mode
no ip mroute-cache
interface Vlan508
description WIMAX_UM8
ip address 10.10.58.16 255.255.255.0
ip pim sparse-mode
no ip mroute-cache
router eigrp 1
redistribute static
network 10.10.10.112 0.0.0.7
network 10.10.50.0 0.0.0.255
network 10.10.51.0 0.0.0.255
network 10.10.52.0 0.0.0.255
network 10.10.53.0 0.0.0.255
network 10.10.54.0 0.0.0.255
network 10.10.55.0 0.0.0.255
network 10.10.56.0 0.0.0.255
network 10.10.57.0 0.0.0.255
network 10.10.58.0 0.0.0.255
network 192.168.130.0
no auto-summary
ip classless
ip route 192.168.2.0 255.255.255.0 192.168.220.1
ip route 192.168.120.0 255.255.255.0 10.10.10.114
ip route 192.168.121.0 255.255.255.0 10.10.10.114
ip route 192.168.125.0 255.255.255.0 10.10.10.115
ip route 192.168.126.0 255.255.255.0 10.10.10.115
ip route 192.168.220.0 255.255.255.0 10.10.10.114
ip route 192.168.225.0 255.255.255.0 10.10.10.115
ip http server
ip pim rp-address 10.0.0.1
Thanks a lot, Jon.... it's very important to me your help.

Similar Messages

  • OSB 11g Dynamic Routing issue

    Hi,
    I am going to insane for not being able to get DynamicRouting to work. I am using DynamicRouting option in RouteNode and in the *service variable panel of this action I have the following:
    <ctx:route>
         <ctx:service isProxy='false'>/MyProject/Services/BusinessServices/MyBizService.biz</ctx:service>
         <ctx:operation>{$operation}</ctx:operation>
    </ctx:route>
    The business service is there and the path is correct. $Operation is verified to have the correct value.
    The setup is I have a proxy service based on a WSDL and in the route node I am trying to dynamically route to a business service.
    I get the following error:
    The invocation resulted in an error:
    <soapenv:Envelope      xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
         <soapenv:Body>
              <soapenv:Fault>
                   <faultcode>soapenv:Server</faultcode>
                   <faultstring>BEA-382612: Error preparing message for dispatch</faultstring>
                   <detail>
                        <con:fault      xmlns:con="http://www.bea.com/wli/sb/context">
                        <con:errorCode>BEA-382612</con:errorCode>
                        <con:reason>Error preparing message for dispatch</con:reason>
                             <con:location>
                                  <con:node>RoutingToDataServices</con:node>
                                  <con:path>request-pipeline</con:path>
                             </con:location>
                        </con:fault>
                   </detail>
              </soapenv:Fault>
         </soapenv:Body>
    </soapenv:Envelope>
    If just use Routing Table or Route action, there is no error and flow works fine.
    Has anyone else encountered issues with Dynamic Routing in this nature?
    Thanks in advance,
    Mani

    I use the web console for my OSB development and when I click on the business service The path appears like "CommonServices/BusinessService/CreditRatingTemplate" (based on the sample downloaded from the link given by me)
    I guess you are using the Eclipse/Workshop for development and hence you are getting the below:
    */* NGWS/Services/BusinessServices/NGWS_http.*biz*
    Can you replace it without the front / in the beginning of the URL and see if it works.
    Thanks,
    Patrick

  • Issue in Dynamic routing (OSB)

    Hi,
    I implemented dynamic routing in OSB,using xQuery:-
    +<tradingPartnerList xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="C:\bea910\user_projects\eclipse\TradingPartners.xsd">+
    +     <tp>+
    +          <Name>Platinum</Name>+
    +          <URL>DynamicDispatch/p1</URL>+
    +     </tp>+
    +<tp>+
    +          <Name>Gold</Name>+
    +          <URL>DynamicDispatch/p2</URL>+
    +     </tp>+
    +</tradingPartnerList>+
    I am routing it on to another proxy using following xml:-
    <ctx:route>
    <ctx:service isProxy='true'>{$endpoint}</ctx:service>
    <ctx:operation>null</ctx:operation>
    </ctx:route>
    Where the Endpoint is from the above xQuery..
    All work fine but i have a one Issue:-
    In <ctx:service isProxy='true'>{$endpoint}</ctx:service> we specify the folder structure of the proxyservice. but what if i move my proxy in future,if i move some of my proxy to other folder the xquery need to be changed which i feel is vv poor design.
    Is there any way where is can specify URL or URI of the proxy service????

    Is there any way where is can specify URL or URI of the proxy service????First of all, you would not like to move your resources here and there frequently in production. Secondly, if you move the resources, definitely you have to change X-Query/Message flow. There is no alternative.
    If you want this feature to be enhanced, please raise a ER with Oracle Support and if they find it valid, will provide a patch for the same.
    Regards,
    Anuj

  • Dynamic Routing for Failover L2L VPN

    Hi,
    Can someone offer me some guidance with this issue please?
    I've attached a simple diagram of our WAN for reference.
    Overview
    Firewall is ASA 5510 running 8.4(9)
    Core network at Head Office uses OSPF
    Static routes on ASA are redistributed into OSPF
    Static routes on ASA for VPN are redistributed into OSPF with Metric of 130 so redistributed BGP routes are preferred
    Core network has a static route of 10.0.0.0/8 to Corporate WAN, which is redistributed into OSPF
    Branch Office WAN uses BGP - Routes are redistributed into OSPF
    The routers at the Branch Office use VRRP for IP redundancy for the local clients default gateway.
    Primary Branch Office router will pass off VRRP IP to backup router when the WAN interface is down
    Backup BO router (.253) only contains a default route to internet
    Under normal operation, traffic to/from BO uses Local Branch Office WAN
    If local BO WAN link fails, traffic to/from BO uses IPSec VPN across public internet
    I'm trying to configure dynamic routing on our network for when a branch office fails over to the IPsec VPN. What I would like to happen (not sure if it's possible) is for the ASA to advertise the subnet at the remote end of the VPN back into OSPF at the Head Office.
    I've managed to get this to work using RRI, but for some reason the VPN stays up all the time when we're not in a failover scenario. This causes the ASA to add the remote subnet into it's routing table as a Static route, and not use the route advertised from OSPF from the core network. This prevents clients at the BO from accessing the Internet. If I remove the RRI setting on the VPN, the ASA learns the route to the subnet via the BO WAN - normal operation is resumed.
    I have configured the metric of the static routes that get redistributed into OSPF by the ASA to be higher than 110. This is so that the routes redistributed by BGP from the BO WAN into OSPF, are preferred. The idea being, that when the WAN link is available again, the routing changes automatically and the site fails back to the BO WAN.
    I suppose what I need to know is; Is this design feasible, and if so where am I going wrong?
    Thanks,
    Paul

    Hi Paul,
    your ASA keeps the tunnel alive only because that route exists on ASA.  Therefore you have to use IP-SLA on ASA to push network taffic "10.10.10.0/24" based on the echo-reply, by using IP-SLA
    Please look at example below, in the example below shows the traffic will flow via the tunnel, only in the event the ASA cannot reach network 10.10.10.0/24 via HQ internal network.
    This config will go on ASA,
    route inside 10.10.10.0 255.255.2550 10.0.0.2 track 10
    (assuming 10.0.0.2 the peering ip of inside ip address of router at HO)
    route outside 10.10.10.0 255.255.255.0 254 xxx.xxx.xxx.xxx
    (value 254 is higher cost of the route to go via IPSec tunnel and x =  to default-gateway of ISP)
    sla monitor 99
    type echo protocol ipIcmpEcho 10.10.10.254 interface inside
    num-packets 3
    frequency 10
    sla monitor schedule 99 life forever start-time now
    track 10 rtr 99 reachability
    Let me know, if this helps.
    thanks
    Rizwan Rafeek

  • Dynamic routing alternative between ASA and edge routers?

    This is the current setup between two edge routers and an ASA 5580.  The edge routers carry approximately 9200 BGP routes with ISP A also supplying the default route.  Is there a good, i.e. has been successfully implemented, dynamic routing situation between the edge routers and ASA such that the ASA can send traffic to the particular edge router that carries the best specific route?

    Hello,
    Let's remember that the ASA was built as a High-Level Next Generation Firewall.
    That does not mean it's not useful for routing but here we are talking about thousands of routes, I do not think there will be a performance issue on the FW because of that. I mean you have one of the greatest Cisco Firewalls (functionality and power speaking).
    So if that's the case and you really want to do that you will need to implement either RIP,EIGRP,OSPF on the link and then do the redistribution on the routers.
    Makes sense?
    Regards,
    Jcarvaja
    CCIE 42930

  • Dynamic Routing Gateway and ASA

    Greetings,
    We have a requirement to configure a multisite gateway and have run into an issue. According to http://msdn.microsoft.com/en-us/library/azure/dn133793.aspx, dynamic routing gateways are not supported on the ASA platform. Does this simply mean that MS does
    not support this configuration or that this configuration is not possible? I cannot negotiate an ikev2 proposal with a dynamic gateway so I fear that it isn't possible.
    Has anyone here made this work?
    Thanks in advance.

    Hello
    In the link you provided, the combination of ASA with dynamic routing says it is not compatible (it does not say not supported).
    From that I understand that it will not work.
    We have tried a few Juniper combinations in the past with static and dynamic routing that were not on the list you mention - only to find out that they indeed did not work.
    My recommendation is to stick to the supported setup.

  • Dynamic routing protocols over wireless.

    Hello all,
    Are there any issues with running dynamic routing protocols through two access points (1240AG) bridging two LANs that are presumably currently setup with a dynamic routing protocol?
    Thanks,
    Patrick

    There shouldn't be.
    They are acting as bridges ... so no need for a routing protocol in the common broadcast domain.
    Unless you have some flavor of broadcast / multicast control in-place, it should pass the traffic without issue.
    Good Luck
    Scott

  • OSB and dynamic routing

    we are trying to implement dynamic routing using xquery resource like in documentation http://edocs.bea.com/alsb/docs30/userguide/modelingmessageflow.html#wp1100135
    when configuring proxy service while adding the expresssion:
    <ctx: route><ctx: service isProxy=’false’>
    {$routingtable/row[logical/text()=$test_ess/proxy/mes:inventory/mes:inv-id/mes:mac]/physical/text()}
    </ctx: service>
    </ctx: route>
    get an error:
    line 1, column 5: {err}XP0003: Invalid expression: unexpected token: :
    Any suggestion?
    TIA

    Hello there....
    For this issue.. try to stuck the sentences together like this:
    <ctx:route>
         <ctx:service isProxy='false'></ctx:service>
    </ctx:route>
    Which means without the space between "ctx:" and "route"

  • OSB Dynamic Routing and Transaction Rollback

    Hi,
    I have implemented dynamic routing to different jms business services.
    That's the flow:
    1. I have a proxy service which is invoked via a message delivered to a jms queue(XA connection factory), this queue is configured with
    Error Destination, expiration policy redirect, redelivery limit 5 and redelivery delay override 100
    2. I use a dynamic routing action
    <ctx:route isProxy="false">
    <ctx:service>
    $businessServiceXXX
    </ctx:service>
    </ctx:route>
    where $businessServiceXXX is a variable to hold my target jms business service, its value depends on some incoming inbound headers.
    3. if the endpoint is not correct(business service endpoint is dynamic) I catch the error in a Error handler, I raise an Error but :
    THE MESSAGE IS NOT REDIRECTED TO THE ERROR QUEUE.
    I know I could solve the issue with another approach like an external table to capture(fix) the endpoints, but it won't be so flexible in terms of deployment capability.
    Any Ideas ?
    Thanks,
    T.

    Hi Tony,
    Tested this in ALSB 2.5 . Transaction rollbacks fine when error in dynamic routing. I am attaching the test JMS proxy we have used for this.
    We had XA enabled CF for JMS proxy service and target JMS BS. The dynamic route was configured in route node with no route error handler or service error handler. The test case was to pause the target JMS queue for production. We could see messages rolling back to the source queue and getting redelivered.
    Attaching the Sbconfig for this proxy. Proxy Name: Dynamic Routing
    <?xml version="1.0" encoding="UTF-8"?>
    <xml-fragment name="DynamicRouting">
    <ser:coreEntry isEnabled="true" isProxy="true" name="DynamicRouting" isAutoPublish="false" xmlns:ser="http://www.bea.com/wli/sb/services">
    <ser:description/>
    <ser:binding type="abstract XML"/>
    </ser:coreEntry>
    <ser:endpointConfig xmlns:ser="http://www.bea.com/wli/sb/services">
    <tran:provider-id xmlns:tran="http://www.bea.com/wli/sb/transports">jms</tran:provider-id>
    <tran:inbound xmlns:tran="http://www.bea.com/wli/sb/transports">true</tran:inbound>
    <tran:URI xmlns:tran="http://www.bea.com/wli/sb/transports">
    <env:value xmlns:env="http://www.bea.com/wli/config/env">jms://localhost:7001/XACF/InputQueue</env:value>
    </tran:URI>
    <tran:inbound-properties xmlns:tran="http://www.bea.com/wli/sb/transports"/>
    <tran:all-headers xmlns:tran="http://www.bea.com/wli/sb/transports">false</tran:all-headers>
    <tran:provider-specific xsi:type="jms:JmsEndPointConfiguration" xmlns:jms="http://www.bea.com/wli/sb/transports/jms" xmlns:tran="http://www.bea.com/wli/sb/transports" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <jms:is-queue>true</jms:is-queue>
    <jms:is-secure>false</jms:is-secure>
    <jms:inbound-properties>
    <jms:response-required>false</jms:response-required>
    </jms:inbound-properties>
    <jms:request-encoding>UTF-8</jms:request-encoding>
    </tran:provider-specific>
    </ser:endpointConfig>
    <ser:router xmlns:ser="http://www.bea.com/wli/sb/services">
    <con:pipeline name="PipelinePairNode1_request" type="request" xmlns:con="http://www.bea.com/wli/sb/pipeline/config">
    <con:stage name="Configuration">
    <con:comment/>
    <con:context/>
    <con:actions>
    <con1:assign varName="input" xmlns:con1="http://www.bea.com/wli/sb/stages/transform/config">
    <con1:expr>
    <con:xqueryText xmlns:con="http://www.bea.com/wli/sb/stages/config"><![CDATA[<root>
    <type value="jms">
              <service>DynamicRouting/BusinessService/JMS</service>
         </type>
         <type value="http">
         <service>DynamicRouting/BusinessService/HTTP</service>
         <operation>Test</operation>
         </type>
    </root>]]></con:xqueryText>
    </con1:expr>
    </con1:assign>
    </con:actions>
    </con:stage>
    </con:pipeline>
    <con:pipeline name="PipelinePairNode1_response" type="response" xmlns:con="http://www.bea.com/wli/sb/pipeline/config"/>
    <con:flow xmlns:con="http://www.bea.com/wli/sb/pipeline/config">
    <con:pipeline-node name="PipelinePairNode1">
    <con:request>PipelinePairNode1_request</con:request>
    <con:response>PipelinePairNode1_response</con:response>
    </con:pipeline-node>
    <con:route-node name="DynamicRoute">
    <con:comment/>
    <con:context/>
    <con:actions>
    <con1:dynamic-route xmlns:con1="http://www.bea.com/wli/sb/stages/routing/config">
    <con1:service>
    <con:xqueryText xmlns:con="http://www.bea.com/wli/sb/stages/config">&lt;ctx:route>
         &lt;ctx:service isProxy="false">{data($input/*:type[@value=$body/*:body/*:type/text()]/*:service)}&lt;/ctx:service>
              if($input/*:type[@value=$body/*:body/*:type/text()]/*:operation) then
                   &lt;ctx:operation>{data($input/*:type[@value=$body/*:body/*:type/text()]/*:operation)}&lt;/ctx:operation>
    else()
    &lt;/ctx:route></con:xqueryText>
    </con1:service>
    <con1:outboundTransform>
    <con2:routing-options xmlns:con2="http://www.bea.com/wli/sb/stages/transform/config">
    <con2:uriExpr>
    <con:xqueryText xmlns:con="http://www.bea.com/wli/sb/stages/config">$body/*:body/*:url/text()</con:xqueryText>
    </con2:uriExpr>
    </con2:routing-options>
    </con1:outboundTransform>
    <con1:responseTransform/>
    </con1:dynamic-route>
    </con:actions>
    </con:route-node>
    </con:flow>
    </ser:router>
    </xml-fragment>
    Regards,
    Atheek
    Edited by: atheek1 on 27-Apr-2010 19:48

  • AQ Adapter Dynamic Routing

    Hi
    I have posted this query in AQ forum,am posting this again in adapters forum hoping to get some solution for the below issue.
    I am using AQ Adapter to configure my OSB Buisness services to enqueue/Dequeue messages to my AQ queues.
    My requirement is to post messages to different Aq queues at runtime without having to reconfigure adapter everytime.
    For eg: My Multi consumer table name: Publisher_Table
    queues in my Publisher_Table: 1.Pub1
    2.Pub 2
    3.Pub 3 and so on
    I need to post messages on pub1,pub2 etc...however while configuring the AQ adapter in jdev for enqueue opertaion i had to hardcode my queue name to Pub1(One among multiple queues created).
    My query is whether i can have this queuename as a variable,so that at runtime i can change the target, instead of having to configure multiple aq adapters one for each pub queue.
    Is there any other way of acheiving dynamic routing for AQ?
    Thanks
    Gayatri

    Hi Gayatri,
    There is no option other than hard-coding the queue name but your use case can be addressed in OSB easily.
    Create Business Services for each and every queue and in proxy message flow use dynamic routing action to determine at runtime that which Business Service should be invoked. To know more about dynamic routing action in OSB, please refer-
    http://download.oracle.com/docs/cd/E13159_01/osb/docs10gr3/userguide/modelingmessageflow.html#wp1100135
    Re: OSB proxy service lookup
    Regards,
    Anuj

  • PE-CE Dynamic routing

    I am running a PE-CE vpn routing. Now my client wants to access a particulat ip which is on internet and may be the demand can be increased and he doesnot want to add the addtional static routes for this. Can we have any routing solution which can solve the purpose. Please post your comments.
    regards
    shivlu

    Hi Shivlu,
    What i understand is, This is an VPN customer and you running dynamic routing protocol (RIPv2/OSPF/EIGRP/BGP) as PE-CE, the customer want to access specific destination address on the internet (google.com) for example, so now we talking about how to make this route reachable through the customer VPN, i think Route Leaking in MPLS/VPN will solve your issue, but in this case you should consider the customer address space issue, i mean how the customer private routes will talk to internet destination, there is a NAT device should be in the path to NAT the customer private address.
    This is a very simple URL by Cisco explaning MPLS Route Leaking:
    http://www.cisco.com/en/US/tech/tk436/tk832/technologies_configuration_example09186a0080231a3e.shtml
    In this case you will add 2 static routes on your PE and redistribute it by the customer PE-CE routing protocol.
    Correct me if i didn't get your point
    Best Regards,
    Mounir Mohamed

  • MPLS, GRE (with no IPSEC) & Dynamic Routing

    Good day my friends!
    Just wondering if any of you could help shed some light on how I would do something. We are switching over from a Point to Point connection between sites to an MPLS one. I have read that Multicast is not permitted across MPLS, so after terminating the MPLS circuits into our network, I created some GRE Tunnels to allow for Multicast (for Dynamic routing as well as Music on Hold)... Everything went well, other then all traffic between the sites is going over the Tunnel interfaces. I would prefer that only multicast traffic go over the GRE tunnel and all other traffic traverse the MPLS without GRE Encapsulation.
    I attempted to do this by doing the following... I wrote an access list indicating Multicast source addresses, then created a route map and did a match ip address acl and set interface to tunnel. then I applied that route map to the vlan (although it doesn't give me the option for direction on the 6509 switch) that the single interface is a member of. That interface goes to the router provided by the service provider. I did the same in the other site as well (2811 router, appied to the interface). What have I done wrong so far?
    We run EIGRP and I did inject the tunnel ip addresses into eigrp, after which traffic started going across it (the tunnel). I need to make sure that routing can find a path via MPLS in EIGRP outside of GRE, and for that all I have done so far is create static routes (on our 6509 and 2811 devices that the MPLS terminates to) with the destination subnet being in the other site between the qwest router and our router (Did that at both sites). I havent created any static routes for remote sites internal subnets because I would like EIGRP to do that, I don't want to rely on Static routes for routing between sites as far as our internal routing.
    So I guess, my question is 2 fold:
    What else do I need to do to get EIGRP to know about the path between sites over MPLS besides through the GRE tunnel?
    How would you control traffic so only Multicast traversed the GRE tunnel where all other traffic would go over MPLS natively?
    Any help you could lend would be very much appriciated!

    Thanks for the reply Laurent!
    Ok, so I just got off the phone our SP and they said they do not support Multicast transport over MPLS... so your assumption is correct...
    I see, so it sounds like I want to stay away from allowing all traffic to traverse between sites over MPLS via GRE... I never considered the issue with scaling when using GRE for all traffic. Good to know!
    While I was on the phone with our SP, I talked with them about routing protocol's they support via MPLS, to which they responded with BGP as really the only option.
    FYI, this is our current WAN arrangement between 2 of the sites:
    Site A>Cisco 2811>Adtran Router (SP provided)>PE-PESite B
    Site A>Cisco 2811 (same as above)>Adtran Router (SP provided)>PE-PESite B
    The SP suggested we run OSPF between our hardware and the Adtran routers and then 2-way redistribute subnets between EIGRP to OSPF and then from OSPF to BGP as follows:
    EIGRP ran inside Site A and B
    OSPF running on outside facing interface on 2811 and 6509
    OSPF running on inside interfaces on Adtran routers
    Private AS BGP running on Adtran with Public AS neighbor to PE device
    This should work, but wouldn't it work for me to just configure BGP on our 2811 and have a IBGP adjacency between it and the Adtran Router and then filter what routes are redistributed from and to IBGP on our 2811 into EIGRP? If this would work, does one design have any advantages over the other? It seems like the EIGRP to OSPF to BGP idea has to many moving parts...
    My objective is to allow all devices in all locations (4 MPLS sites) to route dynamically, verses relying on static routes.
    Regarding the Tunnel config's... I see... Excellent example. OK, so it sounds and looks like I would first configure each site with the routing protocol solution, then, implement GRE with per the example provided, and that would accomplish Multicast over GRE and everything else over MPLS! Thanks alot Laurent!
    So what would you recommend regarding the routing protocol structure?

  • RT31P2 Routing issue

    Hi,
    I am trying to connect from behind my RT31P2 Router to my company's VPN.  It usually takes about 20 minutes with a ton of failures before it connects.
    I analyzed the traffic on both sides of the router and found that the router is messing up on receiving a fragmented packet on the WAN.  The VPN connection initiates with 2 - ISAKMP request/responses between the client and the server.  These smaller packets exchange without issue.  Then there is a third ISAKMP request response with larger packets.  The Client sends a 1652 byte request, which is properly fragmented into smaller packets by the client, and the server responds with a 1780 byte packet, properly fragmented by the server.  When the RT31P2 received the 2 fragments, each ~900 bytes, It correctly does the NAT for the first fragment, sending it to the client PC.  However the second fragment has incorrect NAT.  The destination address coming out the LAN side is actually the WAN address.  Since the client PC ignores the packet, the first fragment is dumped and the packet lost.  Somehow after a ton of tries, a properly fragment packet gets translated by router and the connection succeeds.
    In a nutshell, here is what I am seeing in wireshark:
    Client address: 192.168.15.102
    Router LAN: 192.168.15.1
    Router WAN: 77.88.99.100
    Server: 167.22.181.21
    1. Clent sends req fragment1 to Router Src:192.168.15.102, Dest:192.168.15.1
    2. Router sends req fragment1 to Server: Src:77.88.99.100, Dest:167.22.181.22
    3. Clent sends req fragment2 to Router Src:192.168.15.102, Dest:192.168.15.1
    4. Router sends req fragment2 to Server: Src:77.88.99.100, Dest:167.22.181.22
    5. Server Sends rsp fragment1 to Router: Src:167.22.181.22, Dest:77.88.99.100
    6. Server Sends rsp fragment2 to Router: Src:167.22.181.22, Dest:77.88.99.100
    7. Router Sends rsp fragment1 to Client: Src:192.168.15.1, Dest:192.168.15.102
    8. Router Sends rsp fragment2: Src:192.168.15.1, Dest:77.88.99.100
    Why it sends a packet out the LAN port with the WAN port as a destination, I have no idea.  Everything works perfectly without the router, or through another Dlink router I have.  I prefer to leave the RT31P2 as the main router to provide QoS.
    Any ideas are appreciated.

    I agree the destination address for the second fragment should be 192.168.15.102.  I've had this problem for quite a while and just never really looked into it until now.
    Its a Windows XP computer, so its possible the XP firewall is running.  I'll see if I can disable that.  Its a work issued computer so I don't have access to change much.
    I have reset the router many times but don't see any difference.  I have also tried playing with a lot of the settings that I'm not sure what they do, such as dynamic routing, and setting a static route so that incoming packets to Port 500 get routed to my PC, but to no avail.

  • Routing Issue with 2 Nics on Windows Server 2008 R2

    Good Day
    My issue is I needed to set up port forwarding for a web server to communicate with our hotels management server to check availability.
    Initially the server has a single Nic configured in the 172.26.1.0 /24 network  , Its default gateway the Switch vlan interface 172.26.1.1
    We have many vlans for all the systems in the hotel and the server also needs to communicate with 3 other servers on different subnets which it does just fine.
    I now added an additional adsl line with a managed router which has an interface of 192.168.10.1 /24 , My servers second NIC has the IP address 192.168.10.2 with its gateway being the 192.168.10.1
    This 192.168.10.0 network is in a L2 Vlan and the rest of the network does not know it exists. It was working fine then just stopped asfter i added a static route to the server , which i did with RRas... I did this as the server could not communicate with
    just one of the servers..
    If i disable the 172.26.1.0 NIC the port forwarding works but then obviously the rest of the network goes down.. I know its a routing issue but am lost
    please help

    Hello,
    using multiple default gateways is not a good idea.
    See details in http://support.microsoft.com/kb/159168/en-us
    Best regards
    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://blogs.msmvps.com/MWeber
    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.
    Twitter:  

  • Routing issue- seeing same IPs for two hops

    Hello All,
    I'm seeing two same IPs in the traceroute output. Is that due to routing issue that nexhop is as the same device for the first time?
    Log:
    6  10.30.102.26  61.060 ms 10.30.100.142  61.266 ms 10.30.102.26  61.071 ms
    7  10.30.102.26  61.139 ms  61.211 ms 10.61.191.2  60.948 ms
    Can you  guys help me to fix the issue??
    Regards,
    Thiyagu

    Are you load balancing anywhere?
    6 10.30.102.26  61.060 ms
       10.30.100.142  61.266 ms
       10.30.102.26  61.071 ms
    7 10.30.102.26  61.139 ms  61.211 ms
       10.61.191.2  60.948 ms
    HTH,
    John
    *** Please rate all useful posts ***

Maybe you are looking for