OSB 11g Dynamic Routing issue

Hi,
I am going to insane for not being able to get DynamicRouting to work. I am using DynamicRouting option in RouteNode and in the *service variable panel of this action I have the following:
<ctx:route>
     <ctx:service isProxy='false'>/MyProject/Services/BusinessServices/MyBizService.biz</ctx:service>
     <ctx:operation>{$operation}</ctx:operation>
</ctx:route>
The business service is there and the path is correct. $Operation is verified to have the correct value.
The setup is I have a proxy service based on a WSDL and in the route node I am trying to dynamically route to a business service.
I get the following error:
The invocation resulted in an error:
<soapenv:Envelope      xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
     <soapenv:Body>
          <soapenv:Fault>
               <faultcode>soapenv:Server</faultcode>
               <faultstring>BEA-382612: Error preparing message for dispatch</faultstring>
               <detail>
                    <con:fault      xmlns:con="http://www.bea.com/wli/sb/context">
                    <con:errorCode>BEA-382612</con:errorCode>
                    <con:reason>Error preparing message for dispatch</con:reason>
                         <con:location>
                              <con:node>RoutingToDataServices</con:node>
                              <con:path>request-pipeline</con:path>
                         </con:location>
                    </con:fault>
               </detail>
          </soapenv:Fault>
     </soapenv:Body>
</soapenv:Envelope>
If just use Routing Table or Route action, there is no error and flow works fine.
Has anyone else encountered issues with Dynamic Routing in this nature?
Thanks in advance,
Mani

I use the web console for my OSB development and when I click on the business service The path appears like "CommonServices/BusinessService/CreditRatingTemplate" (based on the sample downloaded from the link given by me)
I guess you are using the Eclipse/Workshop for development and hence you are getting the below:
*/* NGWS/Services/BusinessServices/NGWS_http.*biz*
Can you replace it without the front / in the beginning of the URL and see if it works.
Thanks,
Patrick

Similar Messages

  • OSB and dynamic routing

    we are trying to implement dynamic routing using xquery resource like in documentation http://edocs.bea.com/alsb/docs30/userguide/modelingmessageflow.html#wp1100135
    when configuring proxy service while adding the expresssion:
    <ctx: route><ctx: service isProxy=’false’>
    {$routingtable/row[logical/text()=$test_ess/proxy/mes:inventory/mes:inv-id/mes:mac]/physical/text()}
    </ctx: service>
    </ctx: route>
    get an error:
    line 1, column 5: {err}XP0003: Invalid expression: unexpected token: :
    Any suggestion?
    TIA

    Hello there....
    For this issue.. try to stuck the sentences together like this:
    <ctx:route>
         <ctx:service isProxy='false'></ctx:service>
    </ctx:route>
    Which means without the space between "ctx:" and "route"

  • Dynamic routing issue

    Hello,
    well, my question is: I have one central route (Cisco Catalyst 3750G-48TS-S) and twenty Switch with layer three ios (Cisco 3560G-24) conected in star topology....
    What i want to know is, how central router can communicate with just another router (Cisco 1841) that is behind any 3560G layer three switch?
    the cisco 1841 is always the same router that could be behind any other cisco 3560G switch.
    Thanks a lot for your patience!
    Bruno

    Sorry, Jon
    I'm Portuguese and sometimes i have to speak spanish and i'm confusing some words... sorry about that. What i want to mean was backbone....
    CISCO 3750 x 1
    interface Loopback0
    ip address 10.0.0.1 255.255.255.255
    ip pim sparse-mode
    interface Loopback1
    ip address 10.1.1.1 255.255.255.255
    ip pim sparse-mode
    interface Port-channel1
    no ip address
    interface Port-channel1.30
    description VLAN_INTEGRACAO_1
    encapsulation dot1Q 30
    ip address 10.210.0.2 255.255.255.248
    interface Port-channel1.31
    description VLAN_INTEGRACAO_2
    encapsulation dot1Q 31
    ip address 10.210.0.18 255.255.255.248
    interface Port-channel1.201
    encapsulation dot1Q 201
    ip address 10.10.10.2 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.202
    encapsulation dot1Q 202
    ip address 10.10.10.10 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.203
    encapsulation dot1Q 203
    ip address 10.10.10.18 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.204
    encapsulation dot1Q 204
    ip address 10.10.10.26 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.205
    encapsulation dot1Q 205
    ip address 10.10.10.34 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.206
    encapsulation dot1Q 206
    ip address 10.10.10.42 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.207
    encapsulation dot1Q 207
    ip address 10.10.10.50 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.208
    encapsulation dot1Q 208
    ip address 10.10.10.58 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.209
    encapsulation dot1Q 209
    ip address 10.10.10.66 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.210
    encapsulation dot1Q 210
    ip address 10.10.10.74 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.211
    encapsulation dot1Q 211
    ip address 10.10.10.82 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.212
    encapsulation dot1Q 212
    ip address 10.10.10.90 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.213
    encapsulation dot1Q 213
    ip address 10.10.10.98 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.214
    encapsulation dot1Q 214
    ip address 10.10.10.106 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.215
    encapsulation dot1Q 215
    ip address 10.10.10.114 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.216
    encapsulation dot1Q 216
    ip address 10.10.10.122 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.217
    encapsulation dot1Q 217
    ip address 10.10.10.130 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.218
    encapsulation dot1Q 218
    ip address 10.10.10.138 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.219
    encapsulation dot1Q 219
    ip address 10.10.10.146 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.220
    encapsulation dot1Q 220
    ip address 10.10.10.154 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.230
    encapsulation dot1Q 230
    ip address 10.10.10.162 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Port-channel1.500
    description VLAN_WIMAX_MANAGEMENT
    encapsulation dot1Q 500
    ip address 10.10.50.49 255.255.255.0
    no ip mroute-cache
    interface Port-channel1.555
    description VLAN_RADIO_MANAGEMENT
    encapsulation dot1Q 555
    ip address 10.200.20.2 255.255.255.0
    standby ip 10.200.20.1
    standby priority 140
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    media-type rj45
    no negotiation auto
    channel-group 1
    interface GigabitEthernet0/1
    no ip address
    ip pim sparse-mode
    duplex auto
    speed auto
    media-type rj45
    no negotiation auto
    channel-group 1
    interface GigabitEthernet0/2
    no ip address
    ip pim sparse-mode
    no ip mroute-cache
    duplex auto
    speed auto
    media-type rj45
    no negotiation auto
    interface GigabitEthernet0/2.10
    description VLAN_DADOS
    encapsulation dot1Q 10
    ip address 192.168.120.1 255.255.255.0
    ip pim sparse-mode
    interface GigabitEthernet0/2.11
    description VLAN_MANAGEMENT
    encapsulation dot1Q 11
    ip address 10.2.120.1 255.255.255.0
    ip pim sparse-mode
    interface GigabitEthernet0/2.12
    description VLAN_VOICE
    encapsulation dot1Q 12
    ip address 192.168.121.1 255.255.255.0
    ip pim sparse-mode
    interface GigabitEthernet0/2.13
    description VLAN_PRINTERS
    encapsulation dot1Q 13
    ip address 192.168.122.193 255.255.255.192
    interface GigabitEthernet0/2.14
    description VLAN_BACKUP
    encapsulation dot1Q 14
    ip pim sparse-mode
    interface GigabitEthernet0/2.15
    description VLAN_RED_FW
    encapsulation dot1Q 15
    ip pim sparse-mode
    interface GigabitEthernet0/2.17
    description MNG_FW
    encapsulation dot1Q 17
    ip address 192.168.122.1 255.255.255.192
    interface GigabitEthernet0/2.18
    description RED_GNR
    encapsulation dot1Q 18
    ip address 192.168.220.1 255.255.255.0
    interface GigabitEthernet0/2.550
    description VLAN_SERVER_MANAGEMENT
    encapsulation dot1Q 550
    ip address 10.10.20.1 255.255.255.0
    interface POS1/0
    no ip address
    encapsulation ppp
    crc 32
    clock source internal
    pos framing sdh
    pos scramble-atm
    router eigrp 1
    network 10.10.10.0 0.0.0.7
    network 10.10.10.8 0.0.0.7
    network 10.10.10.16 0.0.0.7
    network 10.10.10.24 0.0.0.7
    network 10.10.10.32 0.0.0.7
    network 10.10.10.40 0.0.0.7
    network 10.10.10.48 0.0.0.7
    network 10.10.10.56 0.0.0.7
    network 10.10.10.64 0.0.0.7
    network 10.10.10.72 0.0.0.7
    network 10.10.10.80 0.0.0.7
    network 10.10.10.88 0.0.0.7
    network 10.10.10.96 0.0.0.7
    network 10.10.10.104 0.0.0.7
    network 10.10.10.112 0.0.0.7
    network 10.10.10.120 0.0.0.7
    network 10.10.10.128 0.0.0.7
    network 10.10.10.136 0.0.0.7
    network 10.10.10.144 0.0.0.7
    network 10.10.10.152 0.0.0.7
    network 10.10.10.160 0.0.0.7
    network 10.10.50.0 0.0.0.255
    network 10.0.0.0
    network 192.168.2.0
    network 192.168.120.0
    network 192.168.121.0
    network 192.168.122.192 0.0.0.63
    network 192.168.220.0
    no auto-summary
    ip route 0.0.0.0 0.0.0.0 192.168.2.254
    ip route 10.26.8.0 255.255.255.0 192.168.2.254
    ip route 10.200.0.0 255.255.0.0 10.200.20.16
    ip route 192.168.2.0 255.255.255.0 192.168.120.254
    ip route 192.168.125.0 255.255.255.0 10.10.10.163
    ip route 192.168.126.0 255.255.255.0 10.10.10.163
    ip route 192.168.127.0 255.255.255.0 10.10.10.163
    ip route 192.168.130.0 255.255.255.0 10.10.10.113
    ip route 192.168.131.0 255.255.255.0 10.10.10.121
    ip route 192.168.132.0 255.255.255.0 10.10.10.129
    ip route 192.168.133.0 255.255.255.0 10.10.10.137
    ip route 192.168.134.0 255.255.255.0 10.10.10.153
    ip route 192.168.135.0 255.255.255.0 10.10.10.145
    ip route 192.168.136.0 255.255.255.0 10.10.10.57
    ip route 192.168.137.0 255.255.255.0 10.10.10.49
    ip route 192.168.138.0 255.255.255.0 10.10.10.33
    ip route 192.168.139.0 255.255.255.0 10.10.10.41
    ip route 192.168.140.0 255.255.255.0 10.10.10.9
    ip route 192.168.141.0 255.255.255.0 10.10.10.1
    ip route 192.168.142.0 255.255.255.0 10.10.10.17
    ip route 192.168.143.0 255.255.255.0 10.10.10.25
    ip route 192.168.152.0 255.255.255.0 10.10.10.81
    ip route 192.168.153.0 255.255.255.0 10.10.10.73
    ip route 192.168.154.0 255.255.255.0 10.10.10.65
    ip route 192.168.155.0 255.255.255.0 10.10.10.89
    ip route 192.168.156.0 255.255.255.0 10.10.10.97
    ip route 192.168.157.0 255.255.255.0 10.10.10.105
    ip route 192.168.225.0 255.255.255.0 10.10.10.163
    ip http server
    ip pim rp-address 10.0.0.1
    ip msdp peer 10.1.1.2 connect-source Loopback1
    ip msdp redistribute list 111
    ip msdp originator-id Loopback1
    CISCO 3560G x 20
    interface GigabitEthernet0/1
    description Digi
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/2
    description Codec
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/3
    description Switch_Torre
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/4
    description Servidor
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/5
    description Wimax
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 500-508
    switchport mode trunk
    interface GigabitEthernet0/6
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/7
    description PC_Operador
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/8
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/9
    description Telefone_Operador
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/10
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/11
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/12
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/13
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/14
    description CCTV1
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/15
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/16
    description CCTV2
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/17
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/18
    description CCTV3
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/19
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/20
    description CCTV4
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/21
    description Central_Alarmes
    switchport access vlan 115
    switchport mode access
    switchport block multicast
    interface GigabitEthernet0/22
    description Intercomunicador
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/23
    description Central_Acessos
    switchport access vlan 115
    switchport mode access
    interface GigabitEthernet0/24
    description ALCATEL
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 215,500
    switchport mode trunk
    interface GigabitEthernet0/25
    interface GigabitEthernet0/26
    interface GigabitEthernet0/27
    interface GigabitEthernet0/28
    interface Vlan1
    no ip address
    interface Vlan115
    description SEGMENTO_PO
    ip address 192.168.130.1 255.255.255.0
    ip pim sparse-mode
    no ip mroute-cache
    interface Vlan215
    description SEGMENTO_CCC
    ip address 10.10.10.113 255.255.255.248
    ip pim sparse-mode
    no ip mroute-cache
    interface Vlan500
    description VLAN_WIMAX_GESTION
    ip address 10.10.50.43 255.255.255.0
    interface Vlan501
    description WIMAX_UM1
    ip address 10.10.51.16 255.255.255.0
    ip pim sparse-mode
    no ip mroute-cache
    interface Vlan502
    description WIMAX_UM2
    ip address 10.10.52.16 255.255.255.0
    ip pim sparse-mode
    no ip mroute-cache
    interface Vlan503
    description WIMAX_UM3
    ip address 10.10.53.16 255.255.255.0
    ip pim sparse-mode
    no ip mroute-cache
    interface Vlan504
    description WIMAX_UM4
    ip address 10.10.54.16 255.255.255.0
    ip pim sparse-mode
    no ip mroute-cache
    interface Vlan505
    description WIMAX_UM5
    ip address 10.10.55.16 255.255.255.0
    ip pim sparse-mode
    no ip mroute-cache
    interface Vlan506
    description WIMAX_UM6
    ip address 10.10.56.16 255.255.255.0
    ip pim sparse-mode
    no ip mroute-cache
    interface Vlan507
    description WIMAX_UM7
    ip address 10.10.57.16 255.255.255.0
    ip pim sparse-mode
    no ip mroute-cache
    interface Vlan508
    description WIMAX_UM8
    ip address 10.10.58.16 255.255.255.0
    ip pim sparse-mode
    no ip mroute-cache
    router eigrp 1
    redistribute static
    network 10.10.10.112 0.0.0.7
    network 10.10.50.0 0.0.0.255
    network 10.10.51.0 0.0.0.255
    network 10.10.52.0 0.0.0.255
    network 10.10.53.0 0.0.0.255
    network 10.10.54.0 0.0.0.255
    network 10.10.55.0 0.0.0.255
    network 10.10.56.0 0.0.0.255
    network 10.10.57.0 0.0.0.255
    network 10.10.58.0 0.0.0.255
    network 192.168.130.0
    no auto-summary
    ip classless
    ip route 192.168.2.0 255.255.255.0 192.168.220.1
    ip route 192.168.120.0 255.255.255.0 10.10.10.114
    ip route 192.168.121.0 255.255.255.0 10.10.10.114
    ip route 192.168.125.0 255.255.255.0 10.10.10.115
    ip route 192.168.126.0 255.255.255.0 10.10.10.115
    ip route 192.168.220.0 255.255.255.0 10.10.10.114
    ip route 192.168.225.0 255.255.255.0 10.10.10.115
    ip http server
    ip pim rp-address 10.0.0.1
    Thanks a lot, Jon.... it's very important to me your help.

  • Issue in Dynamic routing (OSB)

    Hi,
    I implemented dynamic routing in OSB,using xQuery:-
    +<tradingPartnerList xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="C:\bea910\user_projects\eclipse\TradingPartners.xsd">+
    +     <tp>+
    +          <Name>Platinum</Name>+
    +          <URL>DynamicDispatch/p1</URL>+
    +     </tp>+
    +<tp>+
    +          <Name>Gold</Name>+
    +          <URL>DynamicDispatch/p2</URL>+
    +     </tp>+
    +</tradingPartnerList>+
    I am routing it on to another proxy using following xml:-
    <ctx:route>
    <ctx:service isProxy='true'>{$endpoint}</ctx:service>
    <ctx:operation>null</ctx:operation>
    </ctx:route>
    Where the Endpoint is from the above xQuery..
    All work fine but i have a one Issue:-
    In <ctx:service isProxy='true'>{$endpoint}</ctx:service> we specify the folder structure of the proxyservice. but what if i move my proxy in future,if i move some of my proxy to other folder the xquery need to be changed which i feel is vv poor design.
    Is there any way where is can specify URL or URI of the proxy service????

    Is there any way where is can specify URL or URI of the proxy service????First of all, you would not like to move your resources here and there frequently in production. Secondly, if you move the resources, definitely you have to change X-Query/Message flow. There is no alternative.
    If you want this feature to be enhanced, please raise a ER with Oracle Support and if they find it valid, will provide a patch for the same.
    Regards,
    Anuj

  • Dynamic routing in OSB

    Environment: OSB 10.3.1
    To avoid manual configuring all published services one-by-one (eg. alter logging), I'd like to implement a generic proxy pattern in OSB. Assume that I have business services at /bs1, /bs2, etc, proxy services at /ps1, /ps2, etc.
    What I'd like to achieve is to publish proxy services which routes to the generic proxy first and then reroute to the original proxy service. For this I published eg. /pps1, /pps2, etc all with an Insert action which saves $inbound/ctx:transport/ctx:uri to . in $header and then route to the genericproxy proxy service.
    Generic proxy starts by executing common logic in the pipeline (log, etc), then should fetch the original routing information from the header and use dynamic routing to direct the message to the right proxy service (/ps1, /ps2, etc).
    Now the questions:
    1. is this the right approach to solve the problem of generic configuration of multiple published services in OSB?
    2. appearently the uri itself is not enough for dynamic routing - what else do I need to save from the original message?
    3. can I construct a <ctx:route><ctx:service..><ctx:operation..> construct with only Insert actions? I'd need a concrete example here accomplishing this.
    Thanks.

    Well you have to add Route Node to your proxy pipeline and inside it add a Dynamic Routing action.
    If you select the Dynamic Routing action you'll see in the Properties view something like:
    Service: <Expression>
    Here is where you have to define the <ctx:route> element. You can basically paste the text here.
    You could also create an XQuery transformation (so you can reuse it later) and invoke it here (with the XQuery Resources tab). But if you're not very familiar with XQuery I'd advise to start with the first option just to see it working.
    At first you could also omit the {$proxy} variable and statically specify the service you want to route to. Or you could use an Assign action to define the $proxy (or any name you want to give it) variable. And then once that's working see if you can get the service path from the headers.
    Hope that helps

  • OSB Dynamic service call or dynamic route and transactions

    Hello,
    I've got the following problem in my OSB architecture for asynchronous incomming services.
    OSB version is 10.3.1
    ConnectionFactory is XA
    Problem domain:
    Dynamic service call or dynamic route within transaction boundary
    Elements within transaction:
    1.     JMS Queue ->
    2.     Upper Proxy Service (De-queue) ->
    3.     Lower Proxy Service (Canonical Service) ->
    4.     Business Service (Data Service) ->
    5.     Database Adapter->
    6.     Database
    Dynamic element
    Upper Proxy Service (De-Queue) must be able to determine which Lower Proxy Service (Canonical Service) has to be called on the basis of the message taken from the JMS Queue without losing the transaction (this doesn’t work yet).
    Already tried possible solutions:
    •     Make a service call dynamic by setting the $inbound name attribute. This results in a this property is read-only error.
    •     Use a Dynamic route instead of a service-call. This results in a loss of transaction. The message is deleted from the Queue without taking failure or success into account.
    •     Use a Dynamic route with a quality of service set to exactly once in the header. This seems to be ignored, results in a loss of transaction.
    •     Use a Dynamic route with an explicit reply with failure for errors. Results in a loss of transaction.
    •     Use a Dynamic Publish. This doesn’t fit the required flow because it has no response.
    I hope someone can shed some light on this because I'm at a total loss. I found some references in the forum to what seems to be the same problem but without definite answers. A work-around is also a viable answer.
    Regards,
    Bas Mul

    Hi,
    I'll try to clarify.
    Upper proxy dequeues a message.
    Depending on a value of a specific tag within the message a canonical proxy service (out of 5 at the moment but this numer could increase) has to be called (and be dynamic transform transformed to the format of the specific canonical).
    The canonical service must then pass the message to a database adaper's business service which is responsible for the database insert/update/read.
    If something in the chain from dequeue to database action goes wrong the message may not dissapear from the queue.
    Somehow a dynamic route in the message flow between dequeue proxy and canonical proxy breaks the transaction.
    Bas

  • Dynamic Routing in OSB 10gR3

    Hello All,
    I am trying to do a POC of our use-case and wanted to use the Dynamic Routing feature of OSB 10gR3 -
    - Create a Proxy which will accept service_id, version, operation and generic input request
    - Proxy should do lookup in the Routing Table (XQuery Resource) and based on the service_id as key will provide the service endpoint as -
    <ctx:route>
    <ctx:service isProxy="true"> {$routingtable/row[logical/text()=$body/ServiceRequest/ServiceId/text()]/physical/text()}</ctx:service>
    <ctx:operation>{$body/ServiceRequest/OperationName/text()}</ctx:operation>
    </ctx:route>
    - Proxy should also carry out the transformation from generic input request to specific as per the operation.
    - Proxy should then be able to call the other proxy services (as per endpoint in the routing table) and the specified operation.
    Questions -
    Is this possible in OSB 10gR3? What service type (WSDL, AnySOAP, AnyXML, messaging) should the generic proxy be? Any alternative to this approach.
    So far, I have used ALSB/OSB for simple use-cases and this is more complex so I am seeking information and feedback on this use-case and how to move forward with this use-case.
    Thanks,

    Thanks mneelapu.
    I started this use-case on baby-steps and I tried use the dynamic routing to call the operation on a proxy services
    Generic Proxy (using dynamic routing) -----> Proxy ---> Business <----WSDL (Target Service)
    Here are the steps in my code -
    (1) Created the Proxy ---> Business <----WSDL (Target Service) and tested using the test console.. all works fine.
    (2) Created Generic proxy (Messaging Type with xml as input) and I am passing the xml as
    <ServiceRequest>
    <ServiceId>TestWS</ServiceId>
    <OperationName>getStatus</OperationName>
    </ServiceRequest>
    (3) Created the pipeline pair and in the request pipeline added the stage and -
    - assign the Routing Table (as XQuery Resource) to the $routingtable varible
    (Routing Table XML looks like - <routing><row><logical>TestWS</logical><physical>/TestSB/TestPS_1</physical></row></routing>)
    - assign the XQuery expression
    <ctx:route>
    <ctx:service isProxy="true"> {$routingtable/row[logical/text()=$body/ServiceRequest/ServiceId]/physical/text()}</ctx:service>
    <ctx:operation>{$body/ServiceRequest/OperationName}</ctx:operation>
    </ctx:route>
    to $routeresult variable
    (4) Added the Route Node with dyanmic routing action added the $routeresult in the expression.
    I am getting BEA-382612 (Error preparing message for dispatch). I followed the steps as mentioned on e-docs, what am I missing here?
    -J
    Thanks,

  • Deployment issue with SOA - OSB 11g  environment

    Hi,
    We have Dev Environment configured with SOA 11g (11.1.1.4) and OSB 11g (11.1.1.4) on a single weblogic domain. Developed SOA composite app and deployed to the SOA Server. We are exposing our SOA Composite thru OSB ( created osb proxy and business services and accessed soa composite from the client. It s working fine ) layer for the client to access it. The issue here is while deploying it to the production environment (configured OSB and SOA in two separate WL domain) located offshore.
    What i saw from the soa doc is that we need to deploy SOA composite to the SOA Server and OSB Configuration to the OSB Server.
    but the offshore person is asking us to deploy both SOA composite & osb to the same OSB Server as an .ear file.
    Is it possible to deploy both SOA composite & osb to the same osb server ? is there any document on project that involve both soa and osb.
    please guide me how to do the deployment
    I appreciate all your help.
    thanks
    sumesh.j

    I am wondering if could able to solve the problem of deploying both SOA composite & osb to the same osb server. Even I am facing the same problem....
    If you could able to solve the problem then please let us know the steps that you have followed to solve the same.

  • OSB 11G - Routing with policy and forwarding authentication headers

    Hi there,
    I'm having problems trying to add authentication to some services developed with OSB 11G.
    One of the requirements is that the services authenticate using the "oracle/wss_username_token_service_policy" policy... So far so good...
    My problem now is that one of the services I'm trying to route messages to needs the same authentication as the OSB router... I've tried everything I found but without any success... The headers aren't being propagated...
    I've found out that the header variable has the Authentication segments so I can remove the routing, add a service callout and add the header variable to it.. But this is kind of a hammered solution...
    Is there any other solution that I'm missing?
    Thanks in advance,
    Best Regards,
    Daniel Alves
    Edited by: 863416 on Sep 18, 2012 9:49 AM

    Hi,
    transporting header setting is described here
    Yuan's SOA Blog: Retrieve and pass around http Authorization header with OSB
    but something is missing, I have to set proxy service Authentication  to Basic. But then OSB authenticate inbound request at local scope and I want to authenticate at called web service level. How to do that?

  • OSB Dynamic Routing and Transaction Rollback

    Hi,
    I have implemented dynamic routing to different jms business services.
    That's the flow:
    1. I have a proxy service which is invoked via a message delivered to a jms queue(XA connection factory), this queue is configured with
    Error Destination, expiration policy redirect, redelivery limit 5 and redelivery delay override 100
    2. I use a dynamic routing action
    <ctx:route isProxy="false">
    <ctx:service>
    $businessServiceXXX
    </ctx:service>
    </ctx:route>
    where $businessServiceXXX is a variable to hold my target jms business service, its value depends on some incoming inbound headers.
    3. if the endpoint is not correct(business service endpoint is dynamic) I catch the error in a Error handler, I raise an Error but :
    THE MESSAGE IS NOT REDIRECTED TO THE ERROR QUEUE.
    I know I could solve the issue with another approach like an external table to capture(fix) the endpoints, but it won't be so flexible in terms of deployment capability.
    Any Ideas ?
    Thanks,
    T.

    Hi Tony,
    Tested this in ALSB 2.5 . Transaction rollbacks fine when error in dynamic routing. I am attaching the test JMS proxy we have used for this.
    We had XA enabled CF for JMS proxy service and target JMS BS. The dynamic route was configured in route node with no route error handler or service error handler. The test case was to pause the target JMS queue for production. We could see messages rolling back to the source queue and getting redelivered.
    Attaching the Sbconfig for this proxy. Proxy Name: Dynamic Routing
    <?xml version="1.0" encoding="UTF-8"?>
    <xml-fragment name="DynamicRouting">
    <ser:coreEntry isEnabled="true" isProxy="true" name="DynamicRouting" isAutoPublish="false" xmlns:ser="http://www.bea.com/wli/sb/services">
    <ser:description/>
    <ser:binding type="abstract XML"/>
    </ser:coreEntry>
    <ser:endpointConfig xmlns:ser="http://www.bea.com/wli/sb/services">
    <tran:provider-id xmlns:tran="http://www.bea.com/wli/sb/transports">jms</tran:provider-id>
    <tran:inbound xmlns:tran="http://www.bea.com/wli/sb/transports">true</tran:inbound>
    <tran:URI xmlns:tran="http://www.bea.com/wli/sb/transports">
    <env:value xmlns:env="http://www.bea.com/wli/config/env">jms://localhost:7001/XACF/InputQueue</env:value>
    </tran:URI>
    <tran:inbound-properties xmlns:tran="http://www.bea.com/wli/sb/transports"/>
    <tran:all-headers xmlns:tran="http://www.bea.com/wli/sb/transports">false</tran:all-headers>
    <tran:provider-specific xsi:type="jms:JmsEndPointConfiguration" xmlns:jms="http://www.bea.com/wli/sb/transports/jms" xmlns:tran="http://www.bea.com/wli/sb/transports" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <jms:is-queue>true</jms:is-queue>
    <jms:is-secure>false</jms:is-secure>
    <jms:inbound-properties>
    <jms:response-required>false</jms:response-required>
    </jms:inbound-properties>
    <jms:request-encoding>UTF-8</jms:request-encoding>
    </tran:provider-specific>
    </ser:endpointConfig>
    <ser:router xmlns:ser="http://www.bea.com/wli/sb/services">
    <con:pipeline name="PipelinePairNode1_request" type="request" xmlns:con="http://www.bea.com/wli/sb/pipeline/config">
    <con:stage name="Configuration">
    <con:comment/>
    <con:context/>
    <con:actions>
    <con1:assign varName="input" xmlns:con1="http://www.bea.com/wli/sb/stages/transform/config">
    <con1:expr>
    <con:xqueryText xmlns:con="http://www.bea.com/wli/sb/stages/config"><![CDATA[<root>
    <type value="jms">
              <service>DynamicRouting/BusinessService/JMS</service>
         </type>
         <type value="http">
         <service>DynamicRouting/BusinessService/HTTP</service>
         <operation>Test</operation>
         </type>
    </root>]]></con:xqueryText>
    </con1:expr>
    </con1:assign>
    </con:actions>
    </con:stage>
    </con:pipeline>
    <con:pipeline name="PipelinePairNode1_response" type="response" xmlns:con="http://www.bea.com/wli/sb/pipeline/config"/>
    <con:flow xmlns:con="http://www.bea.com/wli/sb/pipeline/config">
    <con:pipeline-node name="PipelinePairNode1">
    <con:request>PipelinePairNode1_request</con:request>
    <con:response>PipelinePairNode1_response</con:response>
    </con:pipeline-node>
    <con:route-node name="DynamicRoute">
    <con:comment/>
    <con:context/>
    <con:actions>
    <con1:dynamic-route xmlns:con1="http://www.bea.com/wli/sb/stages/routing/config">
    <con1:service>
    <con:xqueryText xmlns:con="http://www.bea.com/wli/sb/stages/config">&lt;ctx:route>
         &lt;ctx:service isProxy="false">{data($input/*:type[@value=$body/*:body/*:type/text()]/*:service)}&lt;/ctx:service>
              if($input/*:type[@value=$body/*:body/*:type/text()]/*:operation) then
                   &lt;ctx:operation>{data($input/*:type[@value=$body/*:body/*:type/text()]/*:operation)}&lt;/ctx:operation>
    else()
    &lt;/ctx:route></con:xqueryText>
    </con1:service>
    <con1:outboundTransform>
    <con2:routing-options xmlns:con2="http://www.bea.com/wli/sb/stages/transform/config">
    <con2:uriExpr>
    <con:xqueryText xmlns:con="http://www.bea.com/wli/sb/stages/config">$body/*:body/*:url/text()</con:xqueryText>
    </con2:uriExpr>
    </con2:routing-options>
    </con1:outboundTransform>
    <con1:responseTransform/>
    </con1:dynamic-route>
    </con:actions>
    </con:route-node>
    </con:flow>
    </ser:router>
    </xml-fragment>
    Regards,
    Atheek
    Edited by: atheek1 on 27-Apr-2010 19:48

  • Error in dynamic Routing in OSB

    I am doing dynamic routing in the proxy service by setting the URL in the Routing Options component in OSB. It's throwing Null Pointer Exception when I am using a URL like this:
    http://hqcsas095:8080/ShowImage/servlet/DisplayImage?dlNumber=1114
    The desination machine is even not getting a request.
    If I remove ?dlNumber=1114 from the URL, then destination machine is getting request. Looks like something is wrong with ? character in the URL but I cannot avoid that. I have to pass paramters.
    Thanks for your help.

    As Hisaak mentioned, try routing option if you want to set URI dynamically. To use the dynamic route action, you need the fully qualified name of the service in Oracle Service Bus as described in http://download.oracle.com/docs/cd/E13159_01/osb/docs10gr3/userguide/modelingmessageflow.html#wp1081507
    Thanks
    Manoj

  • Dynamic endpoints in SOA and OSB 11g

    Hi,
    In AIA we have aiaconfiguration properties.xml from where end points of wsdls will be accessible.
    This enables ease in migrations so that if endpoint changes it is only need to be changed in aiaconfiguration properties.xml.
    Can the same be acheived in SOA and OSB 11g projects?
    Thanks,
    Sowmya

    Hi Sowmya,
    Yes, it is very much possible in OSB 11g using customization (you may use it manually or programmitically). Please refer -
    http://download.oracle.com/docs/cd/E14571_01/doc.1111/e15867/customization.htm#CACJCAGD
    http://download.oracle.com/docs/cd/E14571_01/doc.1111/e15022/toc.htm
    Regards,
    Anuj

  • OSB: Static Vs Dynamic Routing With "Get All Headers"

    Hi
    How Static and Dynamic Routing works when calling Business Service pointing to a service inside or out-side the domain with respect to carrying "Get All Headers".
    The scenario is
    I have two BIZ services of http protocol, B1 pointing to a serive with-in the same domain and B2 pointing to a serivce outside the domain.
    Now i am calling both BIZs throught Static and Dynamic Routing
    1. Proxy X calls BIZ1 using Static Routing
    2. Proxy X calls BIZ1 using Dynamic Routing
    3. Proxy X calls BIZ2 using Static Routing
    4. Proxy X calls BIZ2 using Dynamic Routing
    Question: In all 4 cases, does "Get All Headers" get passed to called service?. How is the behaviour?
    Thanks
    Venkata Madhu

    If you're getting errors like -
    ORA-12514: TNS:listener does not currently know of service requested in connect
    And you're database has been started you can -
    'alter system register'
    and that will register the database with the listener.
    If you are trying to start up databases remotely you need to have a static entry (listener.ora entry) otherwise you will not be able to connect to the database and will get the above error. I've seen people connect remotely, shutdown the database, try startup and they are not able to. Good way to shoot yourself in the foot.

  • OSB 11g - Issue with namespace prefix

    Hi,
    I have a requirement that , whenever I call my target system through business service, always the prefix for a namespace should be 's'.
    I added namespace as -
    s : http://www.starstandards.org/STAR
    When I create request message before calling the Business service, the prefix is -
    star:http://www.starstandards.org/STAR
    In OSB 11g, can we control prefix for a namespace?
    Thanks in Advance

    Disable "Use Chunked Streaming Mode" property in business service configuration and test again. By default, this setting remains enabled.
    Regards,
    Anuj

  • OSB Dynamic Routing Downstream Error Handling.

    Hi
    I've written several services which implement dynamic routing proxys which route to other proxys who then talk to business services.
    My problem is that when the downstream service encounters an error the router seems to throw away that error message and replace it with BEA-380000.
    I've read several posts here and there about this and was wondering if there's a best practice way of dealing with this.
    Thanks,
    Nick

    Hi
    I've written several services which implement dynamic routing proxys which route to other proxys who then talk to business services.
    My problem is that when the downstream service encounters an error the router seems to throw away that error message and replace it with BEA-380000.
    I've read several posts here and there about this and was wondering if there's a best practice way of dealing with this.
    Thanks,
    Nick

Maybe you are looking for

  • Problem with RFC to XI - using tables

    Hi experts, I have a RFC function module in R/3 which uses table - the table has 2 components PartNumber and ComptiaCode. But when the RFC call is made, in XI, the value of ComptiaCode is always blank. This is despite the table in the FM has been pop

  • Showing up small in FF?

    I have an app I wrote in CS3 that has a fullscreen mode. When I load it in to FireFox off my computer, everything works great and looks great. However, when I upload it to the server and go to it in FireFox, it shows up really small in the browser an

  • Dbassist - JNLSException

    When I start dbassist I get this error. JNLS Excepiton:oracle.ntpg.jnls.JNLSException Unable to find any National Character Sets. Please check your Oracle installation. Is there something that will fix this condition? null

  • Light room 3.3 color profiles

    Where do I go and delete color profiles that I no longer need in Adobe lightroom 3.3

  • IPhone will not sync.

    I attempted to sync iphone using itunes. Firmware 2.0.2 was available to download and install. Since donwload and install, when plugged into computer, itunes cannot get activation information from iphone. Message states to check the SIM card in the p