Easy example not so easy!

on the grails+flex plugin site:
http://grails.org/Flex+Plugin
it says that integrating flex and grails is SO easy, but i
can't get the simple example to work!
(i'm using MAC OS X)
here is EXACTLY what i've tried:
1-in my workspace, from the terminal window i type: "grails
create-app helloWorld"
2-i then enter the 'helloWorld' folder on the terminal and
type: "grails create-service hello"
3- i then open helloService.groovy in eclipse and copy the
code from the above URL for the helloService, so that the file
looks like this:
class HelloService {
static expose = ['flex-remoting']
def hello() { return "Hello World!" }
4-I then switch to Flex Builder, open a new project, and in
source view, i create a file and copy in the code from the URL, so
it looks like this:
<?xml version="1.0" encoding="utf-8"?>
<mx:Application xmlns:mx="
http://www.adobe.com/2006/mxml">
<mx:RemoteObject id="ro" destination="helloService"/>
<mx:Button label="Hello" click="ro.hello()"/>
<mx:TextInput text="{ro.hello.lastResult}"/>
</mx:Application>
5-i then switch back to the terminal window, and type:
"grails run-app hello" in the helloWorld root. It starts up OK,
telling me to browse to "
http://localhost:8080/helloWorld".
6-i then run the Flex app from FB3, but when i click on the
button, i get the following error:
[RPC Fault faultString="[MessagingError message='Destination
'helloService' either does not exist or the destination has no
channels defined (and the application does not define any default
channels.)']" faultCode="InvokeFailed" faultDetail="Couldn't
establish a connection to 'helloService'"]
at mx.rpc::AbstractInvoker/
http://www.adobe.com/2006/flex/mx/internal::invoke()[E:\dev\3.0.x\frameworks\projects\rpc\ src\mx\rpc\AbstractInvoker.as:257
at mx.rpc.remoting.mxml::Operation/
http://www.adobe.com/2006/flex/mx/internal::invoke()[E:\dev\3.0.x\frameworks\projects\rpc\ src\mx\rpc\remoting\mxml\Operation.as:197
at
mx.rpc.remoting::Operation/send()[E:\dev\3.0.x\frameworks\projects\rpc\src\mx\rpc\remotin g\Operation.as:113]
at Function/
http://adobe.com/AS3/2006/builtin::apply()
at
mx.rpc.remoting.mxml::Operation/send()[E:\dev\3.0.x\frameworks\projects\rpc\src\mx\rpc\re moting\mxml\Operation.as:170]
at Function/
http://adobe.com/AS3/2006/builtin::apply()
at mx.rpc::AbstractService/
http://www.adobe.com/2006/actionscript/flash/proxy::callProperty()[E:\dev\3.0.x\frameworks \projects\rpc\src\mx\rpc\AbstractService.as:285
at
ReportViewer/___ReportViewer_Button1_click()[/Users/PeterAndrus/Documents/Flex
Builder 3/ReportViewer/src/ReportViewer.mxml:4]
anyone know what i might be doing wrong? i am new to this
whole paradigm, but i thought i understood enough to get this done,
but i'm feeling pretty helpless! =) any aid offered is appreciated.
thanks!
ps-i have successfully run other grails services ( i ran one
where i printed to the STDOUT. The result printed to the terminal
window where i'm running grails from.)

I am new to this but I ran into a very similar problem
(probably same), and saw on another posting that you need to
specify the following as compiler options (I did it in Eclipse for
Properties>>Flex Compiler>>Additional Compiler
Arguments, and added the following structure:
-services "C:\...\services-config.xml" -context-root
"C:\...\myapprootdir"
So, fill in your path to services-config.xml and also to your
app root dir. I'm still attempting to see the remote data in my
flex app, but this configuration seemed to remove the destination
issue.

Similar Messages

  • Easy calculator (not so easy for me.)

    I am taking a basic java development course.
    Right now I am trying to create a simple calculator using "if" statements. I missed several classes due to sickness and have not had any luck finding someone who knows java programming to help me figure out the basics of what I'm doing wrong.
    When I compile the following, I get the error message " ';' expected "
    at the line that says:
    "else Ans = Invalid Entry;"
    I believe that this single error may just be masking a much larger problem. Can anyone help point out the (i'm sure) obvious flaws?
    Thanks,
    mike
    import javax.swing.*;
    import java.lang.String;
    public class Mike_nyc_calc
         public static void main(String[] args)
            //Announce that this is a calculator program. Ask the user to enter a number.
            String sFirstNumber = JOptionPane.showInputDialog("This is a calculator program.\n\nPlease enter the first number you wish to use");
            //Ask the user what operator they wish to use, divide, add, subtract or multiply.
            String sOperator = JOptionPane.showInputDialog("You have entered " + sFirstNumber + "\n\nNow please choose which arithmetic operator you wish to use.\nEnter 'A' for Addition,'M' for Multiplication,'S' for Subtraction,'D' for Division,");
            //Ask the user to enter another number.
         String sSecondNumber = JOptionPane.showInputDialog("Thank you.\n\nNow please enter another number.");
         //This is where the different calculations are done, based on what operator is entered.
                   if (sOperator = A)
                        Ans = sFirstNumber + sSecondNumber;
                   if (sOperator = S)
                        Ans = sFirstNumber - sSecondNumber;
                   if (sOperator = M)
                       Ans = sFirstNumber * sSecondNumber;
                  if (sOperator = D)
                    Ans = sFirstNumber / sSecondNumber;
                   else Ans = Invalid Entry;
         //Print to the screen the numbers the user entered and the answer to their query.
            JOptionPane.showMessageDialog(null, "Thanks.  The answer is:   " + Ans);
         

    Thanks for all the input.
    I have implemented some of your suggestions, along with a couple of improvements I was able to glean from my textbook.
    It gets a little closer to compiling but still not quite there.
    There is something about the 'if' statements I put in here that the compiler does not like. I only get an error saying that it cannot find symbol for variable "result"
    However, when I comment out all the "if" statements and run each of the possibilities (*, /, -, +) one by one, it compiles and runs no problem.
    Can anyone see a problem with the if statements??
    Thanks again for all your help!
    import javax.swing.*;
    import java.lang.String;
    public class Mike_nyc_calc {
         public static void main(String[] args)
        String firstNumber;          // first number entered
        String secondNumber;     // second number entered
            //Announce that this is a calculator program.
            //Read first number the user enters as a string.
            firstNumber = JOptionPane.showInputDialog("This is a calculator program.\n\nPlease enter the first number you wish to use: ");
         //Ask the user what operator they wish to use, divide, add, subtract or multiply.
            String sOperator = JOptionPane.showInputDialog("You have entered " + firstNumber + "\n\nNow please choose which arithmetic operator you wish to use.\nEnter 'A' for Addition,'M' for Multiplication,'S' for Subtraction,'D' for Division,");
        //Ask the user to enter another number and read second number the user enters as a string.
         secondNumber = JOptionPane.showInputDialog("Thank you.\n\nNow please enter another number.");
        //Take two numbers entered as strings and convert them to doubles.
        double number1 = Double.parseDouble(firstNumber);
        double number2 = Double.parseDouble(secondNumber);
         //Make different calculations based on what operator is entered.
                   if (sOperator.equals("A")) {
                        double result = (number1 + number2);
                   if (sOperator.equals("S")) {
                        double result = (number1 - number2);
                   if (sOperator.equals("M")) {
                        double result = (number1 * number2);
                  if (sOperator.equals("D")) {
                       double result = (number1 / number2);
                   //else result = Invalid Entry;
         //Print to the screen the numbers the user entered and the answer to their query.
            JOptionPane.showMessageDialog(null, "Thanks.  The answer is:   " + result);
            System.exit(0);
         

  • Win8.1 Update 1 install was not an easy task. (Win8.1 Pro 64bit)

    Win8.1 Update 1 install was not an easy task. (Win8.1 Pro 64bit)
    KB2919355 Failed to install : 09Apr, 11Apr, 11Apr, 12Apr, 12Apr, 13Apr, 16Apr, 17Apr; succeeded: 17Apr.
    After the first three failures I did an online search and found the following information:
    According to a posting I found, when Windows 8.1 Update first fails to install, the original patch does not clean all leftovers, so all your attempts to manually deploy the new release will obviously fail as well. Andrew B recommends users follow the next
    steps and then try to install Windows 8.1 Update manually.
    1. Launch Command Prompt with administrator privileges
    2. Run the following command: dism /online /remove-package /packagename:Package_for_KB2919355~31bf3856ad364e35~amd64~~6.3.1.14
    3. When step 2 is completed, run this command: dism /online /cleanup-image /startcomponentcleanup
    4. Try to install Windows 8.1 Update manually
    I followed these steps and tried both an online and offline installation a couple of times - without success.  More searching resulted in more information:
    from:
    http://news.softpedia.com/news/Windows-8-1-Update-Installation-Fails-with-Error-Code-80070020-436577.shtml
    1. Dism /Online /Cleanup-Image /RestoreHealth
    2. SFC /scannow
    The next attempt at installing Update 1 worked. I then checked the CBS.log file in the \Windows\Logs\CBS folder and found numerous comments that 'SFC /scannow' found many missing or corrupted files and took action to replace them. I was surprised that many
    of the 'new' files were images and were in the \Windows\Web\Wallpaper\Themes1 or \Themes2 folders.
    I had previously deleted all images I did not want as wallpaper - there was no option to unstall themes using Control Panel > Programs and Features > Turn Windows features on and off.
    So, it appears that Win8.1 Update 1 expects to find 'everything' that was part of the initial/original installation still on the computer even though I "Took Ownership" of the original images and folders and deleted them. SFC /scannow may have
    repaired/installed other files but that information was eliminated with the successful install.

    Hi,
    Thanks for your sharing on this issue.
    The update 1 also change some UI designs, that's why it try to find all related files about theme and components to replace.
    Kate Li
    TechNet Community Support

  • EA4500 - not as easy to set up

    Unfortunately the Linksys EA4500 is not as easy to "Set Up & Manage with Ease" as they claim. After trying to connect my Dell color laser network printer, which was working just fine with the replaced Dlink DIR-655 router, it turns out that the supplied Easy Connect Software does not allow non-USB or non-wireless printers to connect to the network. One must manually configure the IP address, according to the Cisco technical support manager. It is not a simple three step set up as advertised.
    The Linksys technical support manager agrees that it is a good thing to warn people not to buy this router if one is expecting easy connection to their network. "It's out of my hands, how to support you to configure the Dell network printer to work with the Linksys EA4500 router." Linksys referred me to a third party, for a fee, to explain how to manually configure the IP address to connect a network printer to their router.
    Numerous other features are not fully developed. Wait for this product to develop into a more mature product. This router is not ready for primetime.

    The Cisco Connect software comes with the Linksys Wireless-N (E/EA Series) routers that let you manage your network easier. So first of all uninstall the older Cisco connect Software from the computer..  Then make the following connectivity:
    The router’s power adapter needs to be plugged to your router and into an available power outlet.
    If using a wired connection, the first Ethernet cable needs to be plugged to the computer’s LAN port into any of the router’s blue numbered Ethernet ports.
    The second Ethernet cable should be plugged to the modem’s Internet port and the other end into the router’s yellow Internet port.
    Ensure that you have no firewall enabled that may prevent the router from being detected.
    After the connection install the Cisco Connect Software again… Here is the link for the same: http://www6.nohold.net/Cisco2/ukp.aspx?pid=93&login=1&vw=1&app=search&articleid=21463&userrole=Links...
    Instructions to connect Network Printer with a Router
    1 Set the router near the computer that is closest to your cable or broadband modem. Plug the router's electrical plug into a wall outlet but do not connect any other cables yet.
    2 Put the installation CD that came with the router into the computer's disc drive. Follow the on-screen instructions to install the router's software on the computer. Install the printer's software on the computer if you have not already done so.
    3 Connect an Ethernet cable from your modem to the port on the router marked as, "WAN" or "Wide Area Network." Connect an Ethernet cable from the computer to any of the numbered ports on the router. Open the Start menu on the computer and then click "Control Panel."
    4 Scroll through the Control Panel options and then double-click the "Network and Sharing Center" icon. Click on the "Connect to a Network" link at the left side of the window. Find the name of your router in the list of available networks and click on it. Click on "Connect."
    5 Connect an Ethernet cable from the Ethernet port on the printer to any of the numbered ports on the router. Return to the "Network and Sharing Center" window and click on the button labeled as "Turn on Printer Sharing."
    6 Click on the "Apply" button to save the setting. Click on the "View Computers and Devices" link at the left side of the window. Click on the "Add a Printer" button when the new window appears.
    7 Click on the "Add a Network Printer" button and wait for the computer to scan for attached printers. Click on the name of the printer and then click on "Connect."
    8 Connect Ethernet cables from the other computers on your network to the numbered ports on the router. Repeat the process of connecting to the network, turning on printer sharing, and then adding the printer on those computers.

  • An easy Example to send a mail!!

    Hi,
    I never have done anything about send an e_mail.So, i need an easy example about that. Could you tell me how i have to do it.
    Thanks in advance,
    Monica

    Try
    http://www.javacommerce.com/articles/sendingmail.htm
    or other references in the
    "JavaMail API and Internet Mail Resources"
    section on the JavaMail home page
    (http://java.sun.com/products/javamail/)
    Regards
    Dave

  • Remote Desktop Services Printer Redirection with easy print not working as Desired

    Hi,
     I have a Terminal Server Farm with a number of Windows Server 2008 R2 Remote Desktop Session Host Servers in the Environment. There is also a RD Gateway server which is used to connect to the RD Session host servers in the environment. We
    had configure the policy "Use Terminal Services easy Print Driver First" for all the RD Session Host servers. Everything was working well untill a couple of users Complaint about slow printing on Easy Print. While trying to troubleshoot the issue we came
    to know that when we by-pass the RD Gatewat and make a Direct connection to the RD Session Host Servers we are able to Print Really fast using Easy Print. Only When we use the RD gateway server we get the problem with the Printing.
     As we could not get through this problem and we are not in a condition to by-pass RD Gateway for connections we decided to put the TS Easy print Driver as a Second option. We went ahead and identified the 3 printers for which printing was slow. we
    Installed the Drivers for the same printers on all the Terminal Server and Disabled the policy "Use Termianl Server Easy print Driver First". After this we were able to print fast on the 3 printers having Slow printing issues. All the other Printers were using
    Easy print.
    After a day we realised that there were more than 20 drivers for Different printers installed in the Print Server Properties. We started getting viered problems with the Printing on all the Terminal servers like, Print Spooler Service Crashing, Hanging,
    Users not able to redirect printers at all. To avoid this we Removed the Driver Packages but they came back the very next day.
     I am not sure what could be causing this kind of behavior. I would really appriciate if someone can help he with these two problems
    1) Easy print Working Slow only when using RD Gateway Server
    2) Printer Drivers Getting installed on Terminal Servers when Easy Print Policy is disabled.

    1) Easy print Working Slow only when using RD Gateway Server
    > Difficult to track down especially through forum. Looking for some known issues/hotfixes
    954743 FIX: After you apply hotfix 954744, printing performance may be significantly slower when you print documents by using Terminal Services Easy Print
    http://support.microsoft.com/?id=954743  
    The Remote Desktop Easy Print (RD Easy Print or TS Easy Print) uses the XPS print driver that ships with .NET Framework.
    2) Printer Drivers Getting installed on Terminal Servers when Easy Print Policy is disabled.
    > If Easy print is not the first driver then it installs the driver if they are InBox drivers
    > If these are non-inbox drivers - This is because administrators are RDPing to the server from another PC with several printer/drivers installed.
    When they RDP with printer redirection enabled, the drivers get automatically installed.
    To avoid this, either turn off printer redirection at server level from RDP-TCP properties - might not be feasible if users need redirected printers
    Else make sure that when admins RDP, printer redirection is turned off so that drivers are not automatically installed
    This was a major issue in 2k3, i havent tested it in 2k8 though
    This behavior is related to the change you made in Easy print driver behavior
    Sumesh P - Microsoft Online Community Support

  • Whether using Oracle after migrating from MySQL be easy or not?

    Though oracle is tough secured one, I don't know exactly the complexity of using Oracle database. Using MySQL 4.1.22 in my website https://www.puntercalls.com/ . Though the site is based on providing share market tips, it deals with a huge amount of stock market data and in much more real time basis hand-to-hand with NSE and BSE info which means a tough security is the utmost demand of the time.
    My question is whether using Oracle after migrating from MySQL be easy or not. You can check my site at https://www.puntercalls.com/ for different real time data updation parts.
    Kind suggestions are greatly appreciated in advance!
    Edited by: 968684 on Oct 31, 2012 7:04 AM

    Hi,
    As you are really asking about how to setup and use securioty features in an Oracle database it woul db ebetter to raise the question in this forum -
    Forum: Database Security - General
    Database Security - General
    They will have more knowledge about Oracle security features and which it would be best for you to use.
    Regards,
    Mike

  • Is there not an easier way to rate apps?

    So I've seen the posts saying that I cab rate an app on my iPad in the App store, but is there really not an easier way? As I am understanding this, I have to basically search for each app one by one - apps I've already got installed - and then rate them from the app store. This makes no sense at all. A) The only easy access to rating an app is basically as you are first downloading it on your iPad. B) This seems to really devalue the usefulness of something like the genius match thing that will suggest apps based on what I like. Sorry, I am not going to search for each individual app then rate it ... I don't understand why it just won't take me there from the "purchased" tab ... or am I missing something?

    Product feedback
    http://www.apple.com/feedback/

  • [svn:fx-trunk] 10129: Fix for Multiple @example not supported

    Revision: 10129
    Author:   [email protected]
    Date:     2009-09-10 14:07:41 -0700 (Thu, 10 Sep 2009)
    Log Message:
    Fix for Multiple @example not supported
    QE notes: None.
    Doc notes: None
    Bugs: SDK-22763
    Tests run: checkintests
    Is noteworthy for integration: No
    Ticket Links:
        http://bugs.adobe.com/jira/browse/SDK-22763
    Modified Paths:
        flex/sdk/trunk/asdoc/templates/class-files.xslt
        flex/sdk/trunk/modules/compiler/src/java/flex2/compiler/asdoc/TopLevelClassesGenerator.ja va

  • This is not an easy process = Add these lines to user.js: user_pref("capability.policy.policynam For example: Could you make or send a link that will install this for the average user as I would prefer not to use Explorer.

    All I would like is to be able to use the Cut and paste when I am making changes to my Web site . I have loked at the instuctions to do this but it is proviung to hard to apply. Is there an easier way or do you have an update that I can use to make Cut and paste work when web editing,

    Please click the '''Solved It''' button next to the answer that solved your Firefox support issue, '''''it appears when you are logged in''''', so this thread gets marked as '''Solved''' to help other users who may have this same problem.

  • Easy Setups in folder, but not in Easy Setups window in FCP?

    Hi all,
    Just got my own copy of FCP, and have been tinkering around and getting familiar with the sequence settings, easy setups, etc.
    I like the concept of the Easy Setups, however I noticed that not all of the Easy Setups from the "Additional Easy Setups" folder in my Applications folder (which came with the install) are visible in application.
    For example, for one organization I edit for, we use a compact HD camera, a Canon VIXIA HF S200, which is AVCHD based, and we shoot in the XP+ setting (1440x1080) at 60i (29.97fps if you prefer).
    When I did work on FCP6 there (I did not bother much with Easy Setups then) we'd be working with the appropriate sequence: ProRes422 1440x1080i60.
    However in toying with these easy setups, the only ProRes 422 Easy Setup showing up is HDV-Apple ProRest 422 1080p24. However, the easy setups folder HAS a 422, 1440x1080, 60i easy setup config file, it's just not showing up in the app.
    Worst comes to worst I'll just manually change the sequence setting because the sequence settings are there, I was just wondering If I had to "install" the additional easy setups or something so they actually appear as easy setups.
    Again, no big deal, just was wondering if anyone knew, thanks!

    Hi -
    The "Easy Set-Ups" are a legacy feature in FCP from when tape based acquisition was standard.
    Since you will be ingesting your HF S200 material via Log and Transfer, and making transcoding decisions there, the Easy Set Up you have chosen is not relevant.
    Once you have ingested your clips, when you place/edit the first clip to a new sequence, FCP will prompt you to match the sequence settings to your source material settings - again, making the Easy Set Up not relevant.
    MtD

  • S12 Easy Cam not working after upgrade to Windows 7

    Upgraded to Win 7 all went most well but the easy cam no longer works. When you do the FN-ESC the icon indicates that the camera is turned on but no screen with an image appears. Any help would be great, thanks in advance.
    Best Regards
    Brian

    I have the S12 (Intel version) camera working using the program from the Y410 laptop.
    Google  IN1STW11ww3.exe and it hopefully be the first entry.
    The program will say it is not compatible but it works.
    On the first screen click on "Don't show this message again" then click "Run program"
    The next time you start the program it will bypass that first screen.
    Hope this helps
    D i c k Miller
    Hot Springs Village, Arkansas  USA
    S12 Intel, 2GB ram, 160 GB HDD,
    Windows 7 Home Premium.
    Also 3000 Y410 Laptop with Win7 X64 Home Premium and a 3000 K100 with Windows Home Server

  • Easy VPN Server? Hmmm.. Not so Easy...

    I used the Cisco Configuration Professional to add an Easy VPN Server to my 3825. I'm able to connect when remote but I can't ping the default gateway of 192.168.1.1 which is in the same network as the VPN DHCP pool. I can access every single other device on the VLAN segments but not the default gateway which means when i connect I can't look at my router. And there's more,  I cannot ping anything offnet (ie 75.75.75.75). Below is my config. Attached are some images which show some details from the client during the VPN connect and a few from the router (i had to use the lan switch as a jump host). If you can figure this out before I go back to the coffee shop to test this tomorrow I will send you a cake.
    One thing I just thought of, does the virtual-tempalte 1 interface have to have "nat inside" applied?
    Current configuration : 12356 bytes
    ! Last configuration change at 17:21:16 EDT Sat Nov 24 2012 by cluettr
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname router-wan
    boot-start-marker
    boot system flash:c3825-advipservicesk9-mz.151-4.M5.bin
    boot-end-marker
    logging buffered 100000000
    enable password xxxxxxxxxx
    aaa new-model
    aaa authentication login default local
    aaa authentication login ciscocp_vpn_xauth_ml_1 local
    aaa authorization exec default local
    aaa authorization network ciscocp_vpn_group_ml_1 local
    aaa session-id common
    clock timezone EDT -4 0
    dot11 syslog
    no ip source-route
    ip dhcp excluded-address 192.168.1.1 192.168.1.199
    ip dhcp excluded-address 172.16.2.1 172.16.2.199
    ip dhcp excluded-address 172.16.3.1 172.16.3.199
    ip dhcp excluded-address 172.16.4.1 172.16.4.199
    ip dhcp pool 192.168.1.0
    network 192.168.1.0 255.255.255.0
    dns-server 192.168.1.1
    default-router 192.168.1.1
    lease infinite
    ip dhcp pool 172.16.2.0
    network 172.16.2.0 255.255.255.0
    dns-server 172.168.2.1
    default-router 172.168.2.1
    lease 0 4
    ip dhcp pool 172.16.3.0
    network 172.16.3.0 255.255.255.0
    dns-server 172.16.3.1
    default-router 172.16.3.1
    lease infinite
    ip dhcp pool 172.16.4.0
    network 172.16.4.0 255.255.255.0
    dns-server 172.16.4.1
    default-router 172.16.4.1
    lease 0 4
    ip dhcp pool 172.16.5.0
    network 172.16.5.0 255.255.255.0
    dns-server 172.16.5.1
    default-router 172.16.5.1
    lease infinite
    ip cef
    ip domain name robcluett.net
    no ipv6 cef
    multilink bundle-name authenticated
    voice-card 0
    voice service voip
    allow-connections sip to sip
    sip
      registrar server expires max 600 min 60
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-423317436
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-423317436
    revocation-check none
    rsakeypair TP-self-signed-423317436
    archive
    log config
      hidekeys
    vtp domain robcluett.net
    vtp mode transparent
    vtp version 2
    username xxxxxxx privilege 15 secret 5 $1$q8RN$N/gL80J2Rj9qOILvzXPgS.
    redundancy
    vlan 3-5
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp client configuration group cisco
    key xxxxxxxxxxxxxxxxxxxx
    dns 75.75.75.75
    domain robcluett.net
    pool SDM_POOL_2
    crypto isakmp profile ciscocp-ike-profile-1
       description "VPN Default Profile for Group Cisco"
       match identity group cisco
       client authentication list ciscocp_vpn_xauth_ml_1
       isakmp authorization list ciscocp_vpn_group_ml_1
       client configuration address respond
       client configuration group cisco
       virtual-template 1
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec profile CiscoCP_Profile1
    set security-association idle-time 86400
    set transform-set ESP-3DES-SHA
    set isakmp-profile ciscocp-ike-profile-1
    interface Loopback0
    description "Circuitless IP Address / Router Source IP"
    ip address 172.16.1.1 255.255.255.254
    interface GigabitEthernet0/0
    description "WAN :: COMCAST via DHCP"
    ip address dhcp client-id GigabitEthernet0/0
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat outside
    ip virtual-reassembly in
    duplex full
    speed 100
    media-type rj45
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    media-type rj45
    no mop enabled
    interface GigabitEthernet1/0
    description "Uplink to switch-core-lan (Catalyst 2948G-GE-TX)"
    switchport mode trunk
    no ip address
    interface Virtual-Template1 type tunnel
    ip unnumbered GigabitEthernet0/0
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile CiscoCP_Profile1
    interface Vlan1
    description "LAN :: VLAN 1 :: PRIVATE 192.168.1.0"
    ip address 192.168.1.1 255.255.255.0
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly in
    interface Vlan2
    description "LAN :: VLAN 2 :: PUBLIC 172.16.2.0"
    ip address 172.16.2.1 255.255.255.0
    ip access-group 102 in
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly in
    interface Vlan3
    description "WLAN :: VLAN 3 :: PRIVATE SSID=wlan-ap-private (not broadcast)"
    ip address 172.16.3.1 255.255.255.0
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly in
    interface Vlan4
    description "WLAN :: VLAN 4 :: PUBLIC SSID=wlan-ap-public"
    ip address 172.16.4.1 255.255.255.0
    ip access-group 104 in
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly in
    rate-limit input 1024000 192000 384000 conform-action transmit exceed-action drop
    rate-limit output 5120000 960000 1920000 conform-action transmit exceed-action drop
    interface Vlan5
    description "EDMZ :: VLAN 5 :: 10.10.10.0"
    ip address 10.10.10.1 255.255.255.0
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly in
    interface Vlan6
    description "IDMZ :: VLAN 6 :: 10.19.19.0"
    ip address 10.19.19.1 255.255.255.0
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly in
    interface Vlan7
    description "LAN :: VLAN 7 :: Voice 172.16.5.0
    ip address 172.16.5.1 255.255.255.0
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly in
    ip local pool SDM_POOL_2 192.168.1.200 192.168.1.254
    ip forward-protocol nd
    ip flow-export source Loopback0
    ip flow-top-talkers
    top 10
    sort-by bytes
    ip dns server
    ip nat inside source list 2 interface GigabitEthernet0/0 overload
    ip nat inside source static tcp 10.10.10.10 80 interface GigabitEthernet0/0 80
    ip nat inside source static tcp 10.10.10.51 443 interface GigabitEthernet0/0 443
    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 dhcp 2
    logging trap debugging
    logging source-interface Loopback0
    access-list 2 remark NAT
    access-list 2 permit 192.168.1.0 0.0.0.255
    access-list 2 permit 172.16.2.0 0.0.0.255
    access-list 2 permit 172.16.3.0 0.0.0.255
    access-list 2 permit 172.16.4.0 0.0.0.255
    access-list 2 permit 172.16.5.0 0.0.0.255
    access-list 2 permit 10.10.10.0 0.0.0.255
    access-list 2 permit 10.19.19.0 0.0.0.255
    access-list 100 remark WAN Firewall Access List
    access-list 100 permit udp any eq bootps any eq bootpc
    access-list 100 permit tcp any any eq www
    access-list 100 permit udp any eq domain any
    access-list 100 permit tcp any any established
    access-list 100 deny   ip any any log-input
    access-list 102 remark VLAN 2 Prevent Public LAN Access to Other Networks
    access-list 102 deny   ip 172.16.2.0 0.0.0.255 192.168.1.0 0.0.0.255 log
    access-list 102 deny   ip 172.16.2.0 0.0.0.255 172.16.1.0 0.0.0.255 log
    access-list 102 deny   ip 172.16.2.0 0.0.0.255 172.16.3.0 0.0.0.255 log
    access-list 102 deny   ip 172.16.2.0 0.0.0.255 172.16.4.0 0.0.0.255 log
    access-list 102 deny   ip 172.16.2.0 0.0.0.255 172.16.5.0 0.0.0.255 log
    access-list 102 permit ip any any
    access-list 104 remark VLAN 4 Prevent Public Wifi Access to Other Networks
    access-list 104 deny   ip 172.16.4.0 0.0.0.255 192.168.1.0 0.0.0.255 log
    access-list 104 deny   ip 172.16.4.0 0.0.0.255 172.16.1.0 0.0.0.255 log
    access-list 104 deny   ip 172.16.4.0 0.0.0.255 172.16.2.0 0.0.0.255 log
    access-list 104 deny   ip 172.16.4.0 0.0.0.255 172.16.3.0 0.0.0.255 log
    access-list 104 deny   ip 172.16.4.0 0.0.0.255 172.16.5.0 0.0.0.255 log
    access-list 104 permit ip any any
    access-list 105 remark VLAN 5 Prevent EDMZ Access to Other Networks
    access-list 105 deny   ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255 log
    access-list 105 deny   ip 10.10.10.0 0.0.0.255 172.16.2.0 0.0.0.255 log
    access-list 105 deny   ip 10.10.10.0 0.0.0.255 172.16.3.0 0.0.0.255 log
    access-list 105 deny   ip 10.10.10.0 0.0.0.255 172.16.4.0 0.0.0.255 log
    access-list 105 deny   ip 10.10.10.0 0.0.0.255 172.16.5.0 0.0.0.255 log
    access-list 105 deny   ip 10.10.10.0 0.0.0.255 10.19.19.0 0.0.0.255 log
    access-list 105 permit ip any any
    snmp-server trap-source Loopback0
    snmp-server location xxxxxxxxxxxxxxxxxxxxx
    snmp-server contact xxxxxxxxxxxxxxxxxxxxxxx
    control-plane
    mgcp profile default
    telephony-service
    max-conferences 12 gain -6
    web admin system name cluettr password 11363894
    dn-webedit
    transfer-system full-consult
    line con 0
    line aux 0
    line vty 0 4
    transport input telnet ssh
    transport output all
    line vty 5 15
    transport input telnet ssh
    transport output all
    scheduler allocate 20000 1000
    ntp logging
    ntp source Loopback0
    end
    router-wan#

    I was under the impression that using the virtual template and ip unnumbered allows the interface to respond to the DHCP IP provided to Gi0/0 by my ISP. If I were to make, say, VLAN 1 the VPN interface how would I then access it from the WAN given that it has a Nat'd LAN IP? I guess port forwarding would work if that would have to be in addition to using a VLAN?
    > Here's a follow up question which you or someone might be able to answer for me. Sorry for dumping the added question on you. My ultimate goal is to have a WAN accessible VPN and a VPN residing on the local LAN. Reason is so I can secure with encryption any wifi clients I have on the LAN (preventing man-in-the-middle attacks) and be secured at, for exmaple, a coffe shop. I'm not sure if there's a means to have the same configured VPN work when attached locally or remotely? And if roaming in regards to a VPN is something that can be acheived...
    As an aside my reason for going to these lengths for security are valid. I've recently encountered a situation where I was hacked (this is my home network) using a MIMA and what I assume to be SSLstrip or some derivative to obtain my email address and password. Wasn't fun, wasn't pretty.

  • Easy Query not appearing in Gateway Service Builder

    Hi,
    I am working on SAP HCM MSS Analytics lane which gets data from Easy Queries via Gateway Service. We are using ODP framework and required ODP configuration mentioned in SAP documents is maintained. I have installed Bex Query Designer ( based on 7.3 Sp 06 Revision 724 ) .
    I am trying to create easy query and build gateway Service for that in ECC. I am able to open ODP query and change it property in Extended tab to "By Easy Query" but when I redefine service for BW Query in SEGW I do not see any easy query showing for RFC of ECC . In query designer message says successfully created , I even created simple query from info area of ODP , even then no success .
    All configuration mentioned in documentation for Easy Query is maintained. Any suggestions would be of great help!

    Hi,
    I have the same problem, Please Could you solve it?,
    Regards,
    Johnny

  • Easy camera not working s200

    i lost my IP lenovo easy camera,waht should i do?thanks.
    Solved!
    Go to Solution.

    hi rizky21,
    Welcome to Lenovo Community Forums!
    Did you mean that you're missing the Lenovo Easy Camera Software.
       Can you try going to Control Panel/  Programs and Feature / Uninstall a program and make sure it is not there.
    If an Easy camera software, then Uninstall it and Download one below according to your Operating System.
    Vista 32-64bit
    Lenovo Easy Camera Driver
    IN1CAM28WW3.exe
    18.17MB
    Windows 7 32-64 bit
    Lenovo Easy Camera Driver
    IN1CAM16WW5.exe
    8.17 MB
    Let me know if your concern is Different.
    Best Regards
    Solid Cruver
    Did someone help you today? Press the star on the left to thank them with a Kudo!
    If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.
    Follow @LenovoForums on Twitter!

Maybe you are looking for

  • Authentication error while logging in to analytics url

    Hi, I have installed OBIEE 11g on Windows XP 64 bit server recently. I'm unable to login to analytics page "http://xxxxxx:7001/analytics"/"http://xxxxxx:9704/analytics"  But  able to login to enterprise manager('http://xxxxxx:7001/em')and console . I

  • BIC XI Adapter call failed

    Hi, I am working on EDI 850 interface in SAP PI. I am using Seeburger adapter for the EDI data conversion. I am able to convert the data successfully and IDOCs are created successfully. I am facing the problem in creating the 997 (functional acknowle

  • Which software is the best for audio restorati

    I have a great deal of traditional tapes with a bad quality and want to restore and edit them but dont know which software is the best. please anyone reply to this question. thanks

  • HT1766 is ther any way to get my photos and  things back if i never did back up

    is there any way to get my photos games and other things back if  i never had any back up as my ipad ask me to pdate space wich i did and lost every thing plus its frozen and i can not use it then when i got on to suport you asking me for £79.00 to g

  • How to do IDOC debugging for both inbound and outbound

    Hi can somebody please help me on how to debug the idoc both inbound and outbound in SAP PI. Regards Blue