Etherchannel trunk with two cisco switch

Hi, my company using only one Cisco 3750 switch with VLAN1,2,3,4,5. 
Now my company bought another cisco switch and we would like to etherchannel trunk between both and create new VLAN in new switch.  We look over from partner, some of them suggested we use LACP, and some of them suggest we use PAgP.  We are so confuse which will be better in our environment.
Previous: Router <> 3750 switch A (VLAN 1,2,3,4,5)
Now we bought another Cisco Switch B:  Router <>3750 switch A <> switch B (add more VLAN 6,7,8,9,10)
Which of below command is the best choice to suit our company ? suppose we use 2 port of gigabitethernet 1/0/1 and 1/0/2 trunk?  All VLAN 1-10 need to communicate with each other.
interface GigabitEthernet1/0/1
 channel-group 1 mode active  <<< (use "active" or "desirable" is the best choice)
 switchport mode trunk
interface GigabitEthernet1/0/2
 channel-group 1 mode active
 switchport mode trunk
interface Port-channel 1
 switchport trunk encapsulation dot1q << (do we need put this? as we think this is by default after trunk?)
 switchport mode trunk
 switchport nonegotiate <<< (do we need "nonegotiate" if both switch setup same configure?)

Hello
My understanding is pagp and lacp basically perform the same features - however as PAGP is cisco propriety LACP is IEEE standard which can be used between different route/switch vendor platforms.
As for disabling DTP ( switchport nonegotiate) - i would agree to do this suggestion, As so not to  have trunks being dynamically created.
Lastly i would manually prune unused vlans across trunk interfaces, to save on cpu and memory usage because of the stp instances that coild be used ( however such a small vlan database  like yours would not be an issue)
So to summarise:
Cisco to Cisco ehterchannels =PAGP
Cisco to other vendors = LACP
L2 etherchannel
================
1) default physical interfaces (if possible)
2) configure port-channel in physical interfaces
-- port-channel will be created automatically
3)create trunking encapsulation or access port mode directly in port-channel interface
4)enable physical interfaces "no shut"
conf t
default int ran fa0/1 -3 ( if applicable)
int ran fa0/1 -3
shut ( if applicable)
channel-group 1 mode xxx
int port-channel 1
switchport trunk encap dot1q
switchport- mode trunk
switchport nonegotiate
switchport trunk allowed vlan 1-10
res
Paul

Similar Messages

  • Interconnecting cisco switches with non-cisco switches

    I need help concerning interconnecting two Cisco switches (3550’s) using a non-Cisco switch or hub on the LAN. I have noticed that the two Cisco switches connected using a non-Cisco switch are able to communicate well, however a PC connected to the non-Cisco switch/hub can not ping any device on the LAN. The non-Cisco device is a working one. When the two Cisco switches are connected using a Cisco switch, PCs connected to the interconnecting switch are able to ping. What’s the explanation? Please help.

    Building configuration...
    Current configuration : 3342 bytes
    ! No configuration change since last restart
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    clock timezone GMT -2
    ip subnet-zero
    ip rcmd rcp-enable
    ip rcmd remote-username cwuser
    spanning-tree mode pvst
    spanning-tree extend system-id
    interface FastEthernet0/1
    switchport mode dynamic desirable
    interface FastEthernet0/2
    switchport mode dynamic desirable
    interface FastEthernet0/3
    switchport mode dynamic desirable
    interface FastEthernet0/4
    switchport mode dynamic desirable
    interface FastEthernet0/5
    switchport mode dynamic desirable
    interface FastEthernet0/6
    switchport mode dynamic desirable
    interface FastEthernet0/7
    switchport mode dynamic desirable
    interface FastEthernet0/8
    switchport mode dynamic desirable
    interface FastEthernet0/9
    switchport mode dynamic desirable
    interface FastEthernet0/10
    switchport mode dynamic desirable
    interface FastEthernet0/11
    switchport mode dynamic desirable
    interface FastEthernet0/12
    switchport mode dynamic desirable
    interface FastEthernet0/13
    switchport mode dynamic desirable
    interface FastEthernet0/14
    switchport mode dynamic desirable
    interface FastEthernet0/15
    switchport mode dynamic desirable
    interface FastEthernet0/16
    switchport mode dynamic desirable
    interface FastEthernet0/17
    switchport mode dynamic desirable
    interface FastEthernet0/18
    switchport mode dynamic desirable
    interface FastEthernet0/19
    switchport mode dynamic desirable
    interface FastEthernet0/20
    switchport mode dynamic desirable
    interface FastEthernet0/21
    switchport mode dynamic desirable
    interface FastEthernet0/22
    switchport mode dynamic desirable
    interface FastEthernet0/23
    switchport mode dynamic desirable
    interface FastEthernet0/24
    switchport mode dynamic desirable
    interface GigabitEthernet0/1
    switchport mode dynamic desirable
    interface GigabitEthernet0/2
    switchport mode dynamic desirable
    interface Vlan1
    ip address
    ip default-gateway
    ip classless
    ip http server
    snmp-server community
    snmp-server community
    snmp-server location
    snmp-server system-shutdown
    snmp-server enable traps snmp authentication warmstart linkdown linkup coldstart
    snmp-server enable traps config
    snmp-server enable traps entity
    snmp-server enable traps flash insertion removal
    snmp-server enable traps bridge
    snmp-server enable traps stpx
    snmp-server enable traps rtr
    snmp-server enable traps port-security
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps envmon fan shutdown supply temperature status
    snmp-server enable traps MAC-Notification
    snmp-server enable traps hsrp
    snmp-server enable traps cluster
    snmp-server enable traps copy-config
    snmp-server enable traps syslog
    snmp-server enable traps vlan-membership
    line con 0
    line vty 0 4
    login
    line vty 5 15
    login
    ntp clock-period 17180064
    end

  • Bridge with two Cisco AP's

    Hello Everyone,
    So I have a scenario here and I’m wondering if this plan I have will work flawlessly or is there anything I have to lookout for?
    So I'm going to bridge two Cisco AP's 1260 and 3500, which have an 880 router on each side.
    (Currently I have a VPN set-up through the internet for the two locations to communicate)
    (Naturally they are currently in different subnets)
    Will absolutely change this and set up as one subnet.
    There is VLANs setup on each router (same VLANs)
    VLAN 1
    And
    VLAN 10
    Everything is configured on the Routers and AP's for these VLANs (works flawlessly over the VPN).
    So now since I’m going to get rid of the VPN and set-up a bridge with two AP's, will having same VLANs across both routers be a problem?
    Will VLANs work OK through the bridge?
    Besides using (IP helper address DHCP-IP) command on the non-root bridge side router to forward DHCP requests to the root bridge side router,
    Is there anything else I have to consider?
    Also I want to be able to route internet traffic on the non-root bridge side through the WAN port, and only route LAN traffic through the bridge...
    Will I have to use Access list for this?
    Sorry everyone...
    I know this is a lot I'm throwing out there...
    Thanks in Advance
    Regards,
    Ed

    Also, if the IP Helper command is used to relay DHCP request to the root bridge side router.....
    will the VLAN settings (trunks) on non-root bridge side router work ok since I will need to remove the DHCP pools configured there...... Or is it a better idea to keep it there and just exclude addressees that are available to the other side, and vice versa???
    I say this because the non-root bride is also going to serve for wireless clients as well, and has VLANs setup on it so I'm guessing the non-root bridge side router needs the DHCP pools for both VLANs intact, for VLANs to operate correctly.
    Please give me your insight on this....

  • IPSec with two Cisco RV220W's

    I have two Cisco RV220W's. FTP over my VPN is so slow, that I have to slow down the FTP Transfer to about 10kbps in order to keep the tansfer steady. Trying to move TB's of information at that speed is not reasonable. What will resolve this issue?

    Also, if the IP Helper command is used to relay DHCP request to the root bridge side router.....
    will the VLAN settings (trunks) on non-root bridge side router work ok since I will need to remove the DHCP pools configured there...... Or is it a better idea to keep it there and just exclude addressees that are available to the other side, and vice versa???
    I say this because the non-root bride is also going to serve for wireless clients as well, and has VLANs setup on it so I'm guessing the non-root bridge side router needs the DHCP pools for both VLANs intact, for VLANs to operate correctly.
    Please give me your insight on this....

  • VLAN Trunking with SRW2024 & Cisco 2924

    Hi, I'm trying to trunk between my Cisco and Linksys switches but its not working as expected. I have 2 vlans on the Cisco VLAN1 & 2. I have set one port on each switch as a trunk and connected them together. This appears to work for VLAN1. I can't seem to get VLAN2 devices to see each other. I think this is because I am from a Cisco background and can't quite work out what the Linksys is trying to tell me or why its so difficult to force a port to a VLAN other than 1. I've tried the manual/help, but this only reiterates the "help" on the web interface, which isn't "help" but more of a dictionary of terms. What I really want it to do is to force all packets arriving at a port to VLAN2 (in much the same way a switchport access vlan does on the Cisco), and for those to be trunked to the cisco to access the other VLAN2 devices. What's the trick for doing this? Thanks, Julian.

    1. The VLAN configuration of the SRW looks good.
    2. Which port on the Cisco do you connect to? I guess it is the FE0/1.
    3. You have to configure trunk mode on the fe0/1 port. Default is access mode. On my router I have manually added vlans. But I think the Cisco (in contrast to the Linksys) by default will accept all vlans unless configured otherwise. In summary: add the first and maybe the second line to FE0/1
    switchport mode trunk
    switchport trunk allowed vlan 1,2
    4. Is there a VLAN router in the setup to provide internet for those VLANs?
    5. How does VLAN 2 get its IP addresses? Do you have a separate DHCP server for VLAN 2?

  • 802.1q trunking with 3rd party switch

    I'm setting up a project that requires a cisco router, which is capable of doing 802.1q trunking. This is the only function I need to test with a 3rd party switch. What is the cheapest router that I can use to accomplish this.

    Hi,
    This should be the one:
    http://cisco.com/en/US/prod/collateral/routers/ps380/ps6942/product_data_sheet0900aecd804b1b19.html
    Please rate if this helped.
    Regards,
    Daniel

  • Etherchannel 2811 with 4501 Catalyst switch

    I am trying to set up an Etherchannel between two FastEthernet on 2811 with a Catalyst 4501 switch. The channel is established fine except that I can't get any traffic to go across the etherchannel. Any ideas?
    Thanks in advance

    Only ports on etherswitch module support channeling in a 2811(built in FE interfaces do not)

  • Connecting " HP Blade System C7000 enclosure" to Cisco Switch

    Dear
    We moved our data center from on place to another .The network cabinet includes " HP Blade System C7000 enclosure". we have two vlans , one of them is DMZ. In the old place , the HP Blade was connected to two Cisco switches ,on one of them DMZ port was configered and on the another Cisco switch non-DMZ port was configured .Now our  " HP Blade System C7000 enclosure" use one CISCO switch and the DMZ and non-DMZ ports are configured on the same CISCO switch and when we restart any server from any vlan ,the server will not be able to connect to the network although all of the servers have static IPs.
    and after logon to the server , a message appears telling us there is a conflict with the mac address of the gateway. the same mac address conflicts when restarting any server from any vlan.
    Would you help?
    Thanks

    I'd suggest asking your question in the Enterprise section of HP's support forums.
    This section is for consumer devices.
    WyreNut
    I am a Volunteer here, not employed by HP.
    You too can become an HP Expert! Details HERE!
    If my post has helped you, click the Kudos Thumbs up!
    If it solved your issue, Click the "Accept as Solution" button so others can benefit from the question you asked!

  • ISE mab authentication with Avaya/Nortel switches

    Currently using Cisco ISE 1.1 to authentication both dot1x and mab from Cisco switches. Both features are authenticating properly.
    When we use a Nortel/Avaya switch for the authenticator, we are unable to authenticate using mac bypass (non-eap (or neap) in Avaya talk..). The correct authentication policy is found in the ISE, but the mac address is not found in the database. We know it is there because the same mac is authenticating with the Cisco switch. Dot1x authenticates properly from both the Cisco and Avaya authenticators.
    Could this be an issues with the username/password format in the Radius packet from the Cisco?
    Thanks in advance for any assistance.
    -Kurt

    As requested...
    http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fet
    chBugDetails&bugId=CSCuc22732
    MAB works from a cisco switch because the cisco switch places the mac address in the calling-station-attribute and the user-name attribute. The Cisco ISE platform is looking at the calling-station attribute to find the user name.This is the problem.
    The radius RFC says the user name must be in the user-name attribute. The calling-station-attribute is not a required field and is used for the phone number of a voip phone. Basically, the ISE platform is looking at the wrong field for the mac address.

  • How to get info over snmp on cisco switch whether native vlan on a port is tagged or not?

    Hi!
    I want to know which oid(s) should I query to know whether native vlan on trunk port on cisco switch is tagged or not?
    I am querying the oid .1.3.6.1.4.1.9.9.46.1.6.3.0 (vlanTrunkPortsDot1qTag) on cisco 3560 (E Series) and I am getting global value. Also, this OID is showing as deprecated. So I query .1.3.6.1.4.1.9.9.246.1.6 (cltcDot1qAllTagged) and its subtree, but no value is returned.
    Switch Version is
    Cisco IOS Software, C3560E Software (C3560E-UNIVERSALK9-M), Version 12.2(50)SE2

    Keep in mind that DHCP is a broadcast packet to start. So the AP can only listen in the subnet that it has an IP address for.
    Now, for any other subnet you can use the AP for DHCP but you have to have an IP helper address on your L3 pointing back to the AP.
    That being said, I wouldn't use the DHCP server on the AP as it is limited. You'd be better off using a Microsoft server or some other device that is designed for DHCP.
    HTH,
    Steve

  • Etherchannel between two 2950 switches

    I have a etherchannel defined between 2 L2 switches using LACP as shown below. The etherchannel works fine, however when I hard code speed/duplex on both ends the etherchannel fails. What is causing this behaviour?
    SW02:
    interface Port-channel5
    interface GigabitEthernet1/0/1
    switchport mode trunk
    channel-group 5 mode active
    interface GigabitEthernet1/0/2
    switchport mode trunk
    channel-group 5 mode active
    SW02:
    interface Port-channel5
    interface GigabitEthernet1/0/1
    switchport mode trunk
    channel-group 5 mode active
    interface GigabitEthernet1/0/2
    switchport mode trunk
    channel-group 5 mode active

    Thank you for the rating.
    Regarding your replacement scenario, I'll give the standard engineering answer ("it depends"), but actually follow up with something I hope is more helpful.    I'm sincerely interested to see other's viewpoint on this as well, as it has changed over the years.
    Many years ago (let's say a decade) I ran into problems with some devices not being able to auto-negotiate properly.  There was a tendancy for devices to fail or negotiate to half-duplex mode when a full-duplex connection was warranted.  At the time, the problems we experienced were mainly with traffic shaping devices and some other gear.  There were others using fixed settings as a standard practice, and we did the same since we had verifiable issues.
    Fast forward to now.  I personally have not experienced auto-negotiation problems in a long time and am reading more from others in the field that auto-negotiation is the way to go (such as from the link provided).  Indeed, I've now run into the opposite scenario: I had a particular situation where a link between two devices defaulted to half-duplex EVEN THOUGH they were both set to 100/Full.  It turned out to be a race condition between a device and a Cisco router...the other device booted faster, didn't see anything on the link, and "helpfully" dropped down to half-duplex.  I confirmed the issue with the device vendor, who recommended setting ports to auto-negotiate as the fix (their software would not be updated for a bit of time).
    I would recommend auto-negotiate as a standard practice, with the exception of areas where you have encountered specific problems.  Those latter cases should be caught through your pre-deployment testing, and discussed with the respective vendors so that you fully understand why the devices are behaving the way they are so that the proper mitigation measures can be put in place (i.e. - It is going to act the same way every time, and you can work with that).
    Good luck!  -Ed

  • Etherchannel two cisco 3750 stacks for iscsi?

    I have two sites connected by 96 strands of fibre. At each site I have an IBMv7000 relicating to the other one. For iSCSI traffic I have two Cisco 3750 switches, each are in 2 switch stack. 
    SAN A                         Fibre Link                          SAN B
            |                                                                        |
    Cisco Stack A =========================Cisco Stack B
            |                                                                        |
            |                                                                        |
    iSCSI Clients                                                       iSCSI Clients
    My question: Is it ok to connect the the two stacks with etherchannel using the fibre links? Will is provide the necessary redundancy, if one of the interfaces goes down?

    What model numbers of 3750 are you using?
    What is the distance between the stacks as this will dictate your fiber run modules.

  • Creating a 20MB bandwidth using two cisco asa 5515x with a hub (10/100/1000)

    hi all,
    I would like to simulate a bandwidth of 20MB for my DR project testing on my two cisco asa 5515x and with a cisco hub (10/100/1000).  I was thinking to make two connections on my "outside" vlan with both speed of 10 and etherchannel it and do it again on the other asa.
    Do you think it will simulate 20MB bandwidth?  Or any other suggestion?  Please add any comment, thanks to all.

    Hi Nicholas,
    You have the HSRP running between your core devices. You can have your core A - ASA1 & Core-B - ASA2.
    In your core switch you need to have a sepearate VLAN to connect the uplink to the firewall and asusual in asa you can have the primary and standby address configured and in core also you can have the vlan with hsrp ip configured.
    But make sure that in your firewall you should mention the static routes for each subnets pointing to the core device hsrp.
    The other scenario is you have make you ASA a standalone firewalls and in one firewall you need to have route to core a as primary and core b as secondary and in the other firewall vice versa. So that your traffic will get load balanced.
    Please do rate if the given information helps.
    By
    Karthik

  • Etherchannel trunking between 2970 switch & 2851 router

    Hi.
    I'm planning to do router on a stick with my Catalyst 2970 and my Cisco 2851 router. I got it working to do router on a stick with one physical link to do interVLAN routing, but when I try to configure it using an etherchannel trunk between them, I can't get it working. Please help. Here's my running config for the switch and router:
    2970 Switch:
    <removed irrelevant info>
    interface Port-channel1
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 10
    switchport mode trunk
    duplex full
    interface GigabitEthernet0/23
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 10
    switchport mode trunk
    duplex full
    channel-group 1 mode on
    interface GigabitEthernet0/24
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 10
    switchport mode trunk
    duplex full
    channel-group 1 mode on
    interface Vlan1
    no ip address
    no ip route-cache
    interface Vlan10
    ip address 172.16.1.18 255.255.255.240
    no ip route-cache
    ip default-gateway 172.16.1.17
    2851 Router:
    interface Port-channel1
    no ip address
    duplex full
    speed 1000
    interface Port-channel1.10
    encapsulation dot1Q 10 native
    ip address 172.16.1.17 255.255.255.240
    interface Port-channel1.20
    encapsulation dot1Q 20
    ip address 172.16.2.1 255.255.255.240
    interface Port-channel1.30
    encapsulation dot1Q 30
    ip address 172.16.3.1 255.255.255.240
    interface GigabitEthernet0/0
    no ip address
    channel-group 1
    interface GigabitEthernet0/1
    no ip address
    channel-group 1
    Thank you.

    The following is a similar example , try some debuging to find encapsulation errors.
    http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_example09186a00800ef797.shtml
    Also see whether you are meeting the following requirements
    http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094646.shtml

  • Virtual IP for two redundant PCs in Cisco Switch

    Hi Team,
    We have redundant Computers connected to Switch . There is the third  system also connected to the switch.
    We want the two redundant PC ethernet to look like one for the third system. We want a virtual IP for the third System to get connected to any one of the  two PC’s.
    we have a Cisco Small business switch.Is that possible in this switch to create a virtual IP for redundancy ?
    which cisco switch supports this functionality ??
    Attached is the diagram of the setup.

    Hi,
    That is not possible with just a switch.  You need some sort of load balancer in front of the switch with a virtual VIP.  So when a packet comes from SCATA to PC1 and if PC1 is not available it will send it to PC2. A10 makes pretty good load balancers.
    http://www.a10networks.com/
    Is that what you are trying to do?
    HTH

Maybe you are looking for

  • How do I set the column content to automatic break lines

    Hello Guys, I have a problem with the column width and the column content of a standard report. Within the report are hugh entries which aren't interrupted by an space character. I set my column width to a special value by usingen "css style: display

  • ODBC Error in OBIEE

    Hello there, Thanks for your help and sharing ideas. I installed OBIEE new version on my windows vista home premium, I created repository in OBI Administrator, I created ODBC data source withh Oracle driver and named as 'Test'. When Itried to import

  • Alert error when master database is down

    When the master database is down (server maintenance, offline back up) a lot of error messages appear in the alert.log of the slave database. Is possible to disable registration of error ORA 12012 and related when master database is closed ??

  • HT1926 Error when trying to install iTunes 'iTunesSetup.exe was reported as unsafe.'

    Get an error when trying to install iTunes 'iTunesSetup.exe was reported as unsafe.' Any suggestions for how to fix this? I am using Windows Vista and IE9.

  • Why am I getting this - pages "No such file or directory"?

    After building a Pages doc with images and type, the file got pretty big - about 445mb.  Nearing completion, I started getting the error "The document "document name" could not be saved. No such file or directory."  Have I exceeded the file size limi