Extracting multiple variables of different fixed length from a string ( Java )

Dear all,
I am expecting an input string of
NationalBroadCastTony12245tv0930113024213tv0820230022214tv0915140024213rd10002300
I need to display it in the following format:
Telecastor: NationalBroadCast
Presenter:Tony
ch_code
pg_code
source
start_time
end_time
1
2245
tv
0930
1130
2
4213
tv
0820
2300
2
2214
tv
0915
1400
2
4213
rd
1000
2300
I know the starting and ending position of Telecastor, and Presenter in the input string. I also know the position of the start element of the table(starting of the loop). I also know the length of a single row( allows me to contruct the loop). I reckon regex is probably not the best way since there is no pattern matching. I am looking at some sort of a config driven logic.
Are there any java string function that I can use together with some form of config driven configuration that anyone can suggest?
I am looking along the line of some configuration like eg
telecastor 17
Presentor  4
pg_code 4 ( anything after character 21 is the loop)
source 2
start_time 4
end_time 4
For example another input I can expect is
ElementaryScienceAccessment223-Feb-131500-1730RegentHallE32344390E21235487A23443564G23443246
I need to display as
Exam:ElementaryScience
Nature: Accessment2
Date:23-Feb-13
Time:1500-1730
Venue:RegentHall
Student ID
Score
E323443
90
E212354
87
A234435
64
G234432
46
Exam:17
Nature:11
Date:9
Time:9
Venue:10
Student ID:7 (anything after 56 is a loop)
Score:2
Unfortunately the input stream is not in XML format. What sort of string function/config driven logic can I use to allow me to define a 1 config fits all mechanism?

Are there any java string function that I can use together with some form of config driven configuration that anyone can suggest?
Well there is the obvious one: the 'substr' method of the String class.
http://docs.oracle.com/javase/6/docs/api/java/lang/String.html
Your 'config' would be the list of start/end or start/length values for each of the components.
The usual parsing issue is knowing how to determine when one element ends and the next one starts. For this fragment of yours:
12245tv
How do you know if the first component, 'ch_code', is '1', '2', or '122'?

Similar Messages

  • RFC export variable with different output length.

    I have an RFC returning language from R/3 with Datatype SY-LANGU. When I run RFC from R/3, I see language being  returned in two chars. But  I get only one char when I run  the same from Web Dynpro.
    When  I look at Web Dynpro model dictionary,  It is imported  with fixed length '1" and external length as "2".
    From ABAP Dictionary it is of  one char, But output length is two chars with some conversion routine.
    Is it possible to get language output in web Dynpro with two chars with out changing the signature of the RFC?

    Hi,
    I think you can achive this.
    You can involve value attribute context for this tranformation.
    Ashutosh

  • Creating Fixed Length from Database Records

    Hello Folks,
    I need to take records from a table and write a fixed length
    text file. What is the general procedure for doing this? Any
    special packages I need?
    TIA.
    Alex Wolff.

    The mechanisms for creating the text file are either to spool a query result from SQL*Plus or to use the UTL_FILE package to write from a PL/SQL procedure.
    To write fixed length records you would do well to convert every column to text. A sample select clause might be ...
    select to_char(my_number,'99999990.000')||
    to_char(my_date,'DD-MM-YYYY')||
    rpad(my_text,30) as fixed_output
    from ...
    I hope this covers your question.

  • How to extract an integer or a float value from a String of characters

    Hi i have a problem getting to a float value within a string of characters..
    for instance the string is
    "numberItem xxxxxxxxx 700.0" (each x is a space..the forum wouldnt let me put normal spaces for some reason)
    how do i store 700.0 in a float variable
    remember the string is obtained from an inputfile
    so far i got the program to store the inputfile data line by line in a String array..i tried tokenizing the string to get to the the float value but since i have mulitple spaces within my string, the token method only gets "numberItem" from the above String
    This is all i have so far:
    String c;
    String Array[] =new String[g]; (i used a while loop to obtain g(the nubmer of lines in the file))
    while((c=(cr.readLine()))!=null)
    Array[coun]=c;
    it would be reallllllllllllllllllllllllllllllllllllllly easy if there was a predefined method to extract numeric values from a string in java..
    Edited by: badmash on Feb 18, 2009 5:50 PM
    Edited by: badmash on Feb 18, 2009 5:50 PM
    Edited by: badmash on Feb 18, 2009 5:55 PM

    badmash wrote:
    Hi i have a problem getting to a float value within a string of characters..
    for instance the string is
    "numberItem xxxxxxxxx 700.0" (each x is a space..the forum wouldnt let me put normal spaces for some reason)
    with the space included
    how do i store 700.0 in a float variable
    remember the string is obtained from an inputfile
    so far i got the program to store the inputfile data line by line in a String array..i tried tokenizing the string to get to the the float value but since i have mulitple spaces within my string, the token method only gets "numberItem" from the above StringHuh?
    Not true.
    Anyway why not use string split, split on spaces and grab the last element (which by the format you posted would be your 700.0)
    Then there is the Float.parseFloat method.
    It is easy.
    And another thing why not use a List of Strings if you want to store each line? (And why did you post that code which doesn't really have anything to do with your problem?) Also in future please use the code formatting tags when posting code. Select the code you are posting in the message box and click the CODE button.

  • Dynamic Variable name (for int/long) from a String variable

    Hi,
    I want to give a int/long variable name from a String.
    for ex.
    String str = lookup + "Id";
    lookup is a String variable coming from XML. Now, for instance lookup="name". So str = "nameId".
    Now I want to create a int/long variable by nameId.
    Could anybody tell me the way how to do. Please don't tell to use MAP.
    Edited by: Shah on Dec 5, 2007 3:26 PM

    Well you can't. Use a Map.
    The compiler translates variable names into slot numbers, either within an object or withing the local "stack frame" and these slot numbers are assigned names at compile time. No new slots can be created at run time. Java is not Basic.
    Reflection allows you to find existing field names and methods (not local variables), so it's possible to map, for example, XML attribute names to field names or setters in an object but the names have to be known at compile time.

  • Fixed-length numbers and strings

    Hello,
    I have to make a critical decision about API usage. I would be grateful if some of you could share their experiences. This will help me make an informed decision and avoid potential trouble further down the line.
    I have to use fixed-length integer numbers and fixed-length strings such as for example:
    -A string that is exactly 5-letter long (no longer and no shorter than 5 letters). e.g. "abcde"
    -A number that is exactly 8-digit long (no longer and no shorter than 8 digits). e.g. "12345678"
    Ideally I would get some sort of exception when the "container" for the letters or digits contains less or more than what the spec says.
    I am not sure which classes or primitives could meet my needs. As far as the fixed-length string is concerned I initially thought of using a array of chars but an array of chars is not that easy to manipulate and contains "garbage" until you explicitely fill it in with data. I'd rather some sort of class.
    Can anyone please advise me?
    Thanks in advance,
    Julien.

    Why not use the same thing like in the case of the String
    /**Warning: this is an example and not very good design.*/
    public class FixedInteger {
       private int min, max;
       private int value;
       public int getValue() { return value;}
       public void setValue(int v) {
            if (v >= min && v < max) {
                throw new Exception();
            value = v;
       /**ex. min = 10000, max = 100000 for 5 digit numbers*/
       public FixedInteger(int min, int max, int value) {
           this.min = min; this.max = max;
           setValue(value);
    }You can do tricks like convert it to immutabla like the String and Integer class in the Java Api
    Edited by: szgy on Oct 5, 2007 2:22 PM

  • Creating EDI file of fixed length from B2B

    Hi Gurus,
    I want to create an edi 810 file from B2B(Outbound) for a partner which has an unusual requirement of the file length. The file length should be 80 characters long.
    The Output EDI should look something like this.
    ISA*00* *00* *01*041158668B *01*006927180 *110118*022
    0*U*00200*000011924*0*P*>~GS*IN*041158668B*006927180*20110118*0220*11924*X*00401
    0~ST*810*0001~BIG*20110118*4295914~REF*DP*Bakery~REF*IA*5169430~N1*ST*ALBERTSONS
    6002 BAKERY 2*9*06002~ITD*05*****20110128*10~DTM*011*20110118~IT1**1*CA*22.28*
    UP007829619749*VN*167~PID*F****FOCACCIA~PO4*35*12*OZ~IT1**1*CA*18.4**UP*003967
    707020*VN*12034~PID*F****BOULE SOURDOUGH~PO4*12*16*OZ~IT1**1*CA*45.33**UP*077098
    106100*VN*20894~PID*F****SCONE 2BT CRML TOFEE~PO4*24*11.25*OZ~IT1**1*CA*35.22**U
    P*004116398356*VN*22791~PID*F****DONUT PWD SGR HOLE~PO4*24*10*OZ~IT1**1*CA*16.46
    **UP*003967707000*VN*22882~PID*F****LRG BOULE SOURDGH~PO4*10*24*OZ~IT1**1*CA*17.
    5**UP*004116397450*VN*22896~PID*F****ANGEL FOOD BAR~PO4*15*10.5*OZ~IT1**1*CA*15*
    UP004116397451*VN*22897~PID*F****SHORTCAKE CUPS~PO4*30*4.5*OZ~IT1**1*CA*16.8**
    UP*004116397453*VN*22898~PID*F****ANGEL RINGS~PO4*8*16*OZ~IT1**1*CA*20.63**UP*00
    7987940430*VN*23366~PID*F****MUFFIN SF CHOCOLATE MINI~PO4*8*10*OZ~IT1**1*CA*20.9
    6**UP*007987940066*VN*23386~PID*F****LOAF SF SLICED POUND~PO4*8*14*OZ~SAC*A*F800
    ***56*******02***PROMOTION ALLOWANCE~IT1**1*CA*22.27**UP*002056910140*VN*27832~P
    ID*F****DONUT O F BUTTERMILK CAKE~PO4*96*3*OZ~IT1**1*CA*60.1**UP*077388911720*V
    N*28396~PID*F****DANISH PKT ALMOND BEARCLAW~PO4*144*3*OZ~IT1**1*CA*35.5**UP*0773
    88911729*VN*28398~PID*F****DANISH PLAIN RND TWIST~PO4*120*2.5*OZ~IT1**1*CA*20.48
    **UP*002056912011*VN*29120~PID*F****DONUT GOLDEN LONG JOHN~PO4*84*3*OZ~IT1**1*CA
    *22.27**UP*002056910101*VN*29121~PID*F****DONUT VANILLA CAKE~PO4*96*3*OZ~IT1**1*
    CA*39.78**UP*087062500522*VN*29161~PID*F****EGG CHALLAH K~PO4*20*19.75*OZ~IT
    1**1*CA*22.66**UP*002056980050*VN*29288~PID*F****DONUT RASPFILLED SHELL~PO4*84*4
    OZ~IT1*1*CA*22.66**UP*002056980060*VN*29290~PID*F****DONUT CUSTFILLED SHELL~PO
    4*84*4*OZ~IT1**1*CA*24.73**UP*002056912240*VN*29350~PID*F****DONUT GOLDN APPLE F
    RITTER~PO4*72*3*OZ~IT1**1*CA*20.02**UP*002056912030*VN*29359~TDS*61293~CAD*SR***
    ROUTE666~CTT20~SE*71*0118~GE*118*11924~IEA*1*000011924~
    Please help me on this.
    I am using B2B 10.1.2.
    Regards
    Ayush

    This is valid rule as the partner might has AS400 system for processing documents. In this case both inbound/outbound docs to/from that partner need to have this 80 char BLOCK rule applied.
    What method is partner using for file exchange. In case VAN, you might need to ask partner to check their VAN and have this 80 char BLOCK rule applied at mailbox level. This way VAN provider will automatically handle this for both inbound and outbound.
    Thanks,
    Vijay.

  • QOS over multiple GREs with different BW's from core perspective

    We use gre over ipsec, to connect multiple sites to our core. Many of the site have different BW based on remote site carrier limitations. The BW of some are symetrical, some are DSL.
    I have started deploying VOIP at some of these sites, and have begun playing with QOS. I only want to insure voice traffic, and control are passed accordingly, all other traffic can fall into default queue during times of high link usage.
    For the remote sites, I have settled on the below config:
    class-map match-any AutoQoS-VoIP-RTP-Trust
    match ip dscp ef
    class-map match-any AutoQoS-VoIP-Control-Trust
    match ip dscp cs3
    match ip dscp af31
    policy-map AutoQoS-Policy-Trust
    class AutoQoS-VoIP-RTP-Trust
    priority percent 70
    class AutoQoS-VoIP-Control-Trust
    bandwidth percent 5
    class class-default
    fair-queue
    interface Tunnel17
    bandwidth 5000
    ip address 192.168.1.66 255.255.255.252
    ip mtu 1500
    ip tcp adjust-mss 1436
    qos pre-classify
    keepalive 10 3
    tunnel source x.x.x.x
    tunnel destination x.x.x.x
    interface GigabitEthernet0/0
    bandwidth 5000
    ip address x.x.x.x 255.255.255.240
    service-policy output AutoQoS-Policy-Trust
    (only the part of the config related to QOS is included to protect the innocent!)
    My question is, how do I apply a similiar config at the core end, where I have multiple GRE interfaces, with different corresponding bandwidths? I tried to apply the service-policy to the tunnel interface, but it does not accept the command because of the queuing type.
    Thanks in advance.

    Another update, I have applied the follwoing config to my core ipsec router, on which 2 of the 19 gre tunnels have a VOIP solution at the far end. I am not seeing matches to the associated access lists, should I only see matches when the limit hits the shaper figure in the policy map?
    class-map match-all hmh-class
    match access-group name hmh-qos
    class-map match-all hampwellness-class
    match access-group name hampwellness-qos
    class-map match-any AutoQoS-VoIP-RTP-Trust
    match ip dscp ef
    class-map match-any AutoQoS-VoIP-Control-Trust
    match ip dscp cs3
    match ip dscp af31
    policy-map AutoQoS-Policy-Trust
    class AutoQoS-VoIP-RTP-Trust
    priority percent 70
    class AutoQoS-VoIP-Control-Trust
    bandwidth percent 5
    class class-default
    fair-queue
    policy-map qos-shaper
    class hmh-class
    shape average 4000000
    service-policy AutoQoS-Policy-Trust
    class hampwellness-class
    shape average 4000000
    service-policy AutoQoS-Policy-Trust
    interface GigabitEthernet0/1
    service-policy output qos-shaper
    ip access-list extended hampwellness-qos
    permit gre host 192.168.1.69 host 192.168.1.70
    ip access-list extended hmh-qos
    permit gre host 192.168.1.65 host 192.168.1.66
    interface Tunnel10
    description GRE to Hampshire Wellness Center
    bandwidth 5000
    ip address 192.168.1.69 255.255.255.252
    ip mtu 1500
    ip tcp adjust-mss 1436
    load-interval 30
    qos pre-classify
    keepalive 10 3
    tunnel source x.x.x.x
    tunnel destination x.x.x.x
    interface Tunnel17
    description GRE to Hampshire Memorial
    bandwidth 5000
    ip address 192.168.1.65 255.255.255.252
    ip mtu 1500
    ip tcp adjust-mss 1436
    load-interval 30
    qos pre-classify
    keepalive 10 3
    tunnel source x.x.x.x
    tunnel destination x.x.x.x

  • Extracting the partial string from the string in oracle

    Hello Friends,
    I have a string like this
    var str = '/G/CNH/CNHCornerstone/currentCode/data/Working/Images/ModelImages/png/7402203E-607D-E111-9CA5-005056875BD6.png'
    I want to extract only 7402203E-607D-E111-9CA5-005056875BD6 from the string .
    Please let me know how to implement this ..
    thanks/kumar
    Edited by: kumar73 on Apr 10, 2012 12:34 PM

    hope this works
    set serveroutput on
    declare
      str1 varchar(4000);
      str2 varchar(4000);
    begin
      str1 := '/G/CNH/CNHCornerstone/currentCode/data/Working/Images/ModelImages/png/7402203E-607D-E111-9CA5-005056875BD6.png';
      dbms_output.put_line('string 1 : ' || str1);
      str2 := substr(str1,71);
      dbms_output.put_line('string 2 : '||str2);
    end;
    output
    string 1 : /G/CNH/CNHCornerstone/currentCode/data/Working/Images/ModelImages/png/7402203E-607D-E111-9CA5-005056875BD6.png
    string 2 : 7402203E-607D-E111-9CA5-005056875BD6.png
    PL/SQL procedure successfully completed

  • How to define a schema for fixed length consisting of multiple records of different types having header detail and footer at positions 22 and 23 namely having 10 for header 20 for detail and 30 for footer

    how to define a schema for fixed length consisting of multiple records of different types having header detail and footer at positions 22 and 23 namely having 10 for header ,20 for detail and 30 for footer.
    here is the sample file
    DDWTYBILL13092502572 1000000112\\NHLSFS\ORACLE\ORACLE\BILLING\VERIFY\            2013/09/25 01:19:08 BILLEND     
    DDWTYBILL13092502572 2000000212PRIVATE             PRIVATE             STY5572142     010700         INV                              12STYD000789                  02-AUG-20130000010472      STY       STY       1100611006MGIT                91  NNM    DIMPHANA,CN,CELESTE NERINA                                                                                                        09-JAN-1964                              TYG       A2        DR DU PREEZ                                                                                         5602181             63301345       TB731543                                           Suspect TB ?CA, (L) EMPIEEM                                           Ward A2                                           TYGERBERG HOSPITAL                                                                                  Z03.0                                                       Z03.9                                                          05-AUG-201305-AUG-201324-SEP-2013FEND    113.60
    DDWTYBILL13092502572 2000000312PRIVATE             PRIVATE             STY5572149     010700         INV                              12STYD000789                  02-AUG-20130000010472      STY       STY       1100611006MGIT                91  NNM    DIMPHANA,CN,CELESTE NERINA                                                                                                        09-JAN-1964                              TYG       A2        DR DU PREEZ                                                                                         5602181             63301345       TB731548                                           Empyema BPF                                                           Ward A2                                           TYGERBERG HOSPITAL                                                                                  Z03.9                                                       Z03.9                                                          05-AUG-201305-AUG-201324-SEP-2013FEND    113.60
    DDWTYBILL13092502572 2000000412PRIVATE             PRIVATE             STY5572351     010700         INV                              12STYD000789                  02-AUG-20130000010472      STY       STY       1100611006MGIT                91  NNM    DIMPHANA,CN,CELESTE NERINA                                                                                                        09-JAN-1964                              TYG       A2        DR DU PREEZ                                                                                         5602181             63301345       TB731584                                           Suspect TB ?EMPIEEM, ?CA                                              Ward A2                                           TYGERBERG HOSPITAL                                                                                  Z03.0                                                       Z03.9                                                          05-AUG-201305-AUG-201324-SEP-2013FEND    113.60
    DDWTYBILL13092502572 2000000512PRIVATE             PRIVATE             STY5572352     010700         INV                              12STYD000789                  02-AUG-20130000010472      STY       STY       1100611006MGIT                91  NNM    DIMPHANA,CN,CELESTE NERINA                                                                                                        09-JAN-1964                              TYG       A2        DR DU PREEZ                                                                                         5602181             63301345       TB731585                                           Suspect TB ?EMPIEEM, ?CA                                              Ward A2                                           TYGERBERG HOSPITAL                                                                                  Z03.0                                                       Z03.9                                                          05-AUG-201305-AUG-201324-SEP-2013FEND    113.60
    DDWTYBILL13092502572 2000000612MAJOR               MAJOR               STY5577530     010700         INV                              12ZTYG000009                  02-AUG-20130000010472      STY       STY       1100611006MGIT                91  NNS    ZOZI,S,SIYAMBONGA                                                                                                                 27-MAR-2010                              TYG       D3        DR MAHOMED                                                                                          5602181             113799662      TB731663                                           Lymphadenitis                                                         Ward D3                                           TYGERBERG HOSPITAL                                                                                  I88.9                                                       Z03.9                                                       H1 07-AUG-201307-AUG-201324-SEP-2013MEND     58.52
    DDWTYBILL13092502572 2000000712MAJOR               MAJOR               STY5577537     010700         INV                              12ZTYG000009                  06-AUG-20130000010472      STY       STY       1100611006MGIT                91  NNS    DLAMINI,N,NTLANTLA                                                                                                                09-OCT-1976                              TYG       F1        DR WZESE                                                                                            5602181             135524676      TB731666                                           Suspect TB                                                            Ward F1                                           TYGERBERG HOSPITAL                                                                                  Z03.0                                                       Z03.9                                                       H1 07-AUG-201314-AUG-201324-SEP-2013MEND     58.52
    DDWTYBILL13092502572 30003034120000003032END

    You can create an nXSD using Native Format Builder and use lookAhead attribute to read values at specific position and use that as the choice. You can find an example here
    http://docs.oracle.com/cd/E11036_01/integrate.1013/b28994/nfb.htm#BGBBAJFD

  • SQL Extract Variable String in Variable Position with Variable length from ntext field

    i want to extract a variable string from an ntext field. 
    Sample Data in Background_text (ntext)
    function changeFocus()  {         document.getElementById('skipContent').style.visibility = 'visible';         document.getElementById('flashContent').blur();        
    document.getElementById('skip').focus();  }  </script>    </head>  <body onload='hideDiv()'>    <div id="flashContent" align="center">     <object
    classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="700" height="440" id="Animation" align="middle">      <param name="movie"
    value="/assets/abc/images/abcdef.swf" />      <param name="quality" value="high" />
    I want to extract this data:      "/assets/abc/images/abcdef.swf"
    The string will always be preceded by value="     AND end in
    .swf"
    As a first attempt, I tried
    SELECT SUBSTRING([Background_text], CHARINDEX('value="/assets/', [background_text]) + 15, LEN(convert(varchar(max), background_text) -
    CHARINDEX('value="/assets/', [Background_text]) + 15) - 1)
    but I received this error
    Msg 245, Level 16, State 1, Line 1
    Conversion failed when converting the varchar value .......  to data type int
    This query won't completely accomplish what I want. Do you have a suggestion?
    Thanks.

    I'd add an extra bit of logic into the expression to only look for 'swf' AFTER the start of the string - it might be that you can guarantee that no occurrence of 'swf' will ever appear in the ntext, but who knows what might change in the future, and it's
    good practice to code defensively.
    SELECT
    SUBSTRING(
    Background_text,
    CHARINDEX('value="/assets/', background_text) + 6,
    CHARINDEX('.swf', SUBSTRING(
    Background_text,
    CHARINDEX('value="/assets/', background_text) + 6,
    LEN(cast(background_text as varchar(max)))
    ) + 4

  • Fixed length fileadapter [multiple records are of multiple types]

    Hi,
    I am using Jdev 10133 and SOA suite 10133.
    I am using fixed length(multiple records are of different type) file adapter to read data from a DAT file.
    I need to read the data based on condition.
    i.e: the DAT file looks like below
    city1           EMPName1                      female                organisation1
    city2           EMPName2                      male                   organisation2
    city2           EMPName3                      male                   organisation1
    city1           EMPName4                      female                organisation1Here i need to read the records based on gender.
    I was able to read based on city i.e first column.
    In adapter wizard it is giving only endposition.
    How to read data based on gender??
    Plz help me regarding this.
    Regards.
    Edited by: [email protected] on May 21, 2009 1:44 AM

    not sure if this is an exact example but when you create youe xsd you can use white space as a delimiter, so if your fields don't have spaces you can use this.
    Also you can mix and match fixed length with delimiters
    cheers
    James

  • File Adapter - Multiple fixed length records in the same file

    Hi
    I am developing a BPEL process that "Sync Read" a file. The file is a flat file comprising of multiple records and each record is of fixed length. There are no delimiters in the file. I got the xsd associated to this flat file and each element is defined with some fixed length and starting position. The xsd is valid.
    When I execute the BPEL Process, I get the following error - I verified the file structure and the position of the fields map correctly. Remember this is not an xml file just a plain text file. Can BPEL process such files or should I always provide an "xml" file?
    <bpelFault><faultType>0</faultType><bindingFault xmlns="http://schemas.oracle.com/bpel/extension"><part name="detail"><detail>Start of root element expected.</detail></part><part name="summary"><summary>Exception occured when binding was invoked. Exception occured during invocation of JCA binding: "JCA Binding execute of Reference operation 'SynchRead' failed due to: Error while translating. Translation exception. Error occured while translating content from file /tmp/inputDir/VDA1.txt ". The invoked JCA adapter raised a resource exception. Please examine the above error message carefully to determine a resolution. </summary></part><part name="code"><code>null</code></part></bindingFault></bpelFault>
    Thanks
    Shanthi

    hi,
    see you actually read a XML file and when you read it it is verified by a XSD the location of the XSD is in the XML file it self,
    <tns:abc xmlns:tns="http://xmlns.int.aaa.co.uk/xmlns/BPELXXX"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://xmlns.int.aaa.co.uk/xmlns/BPELXXX *c:/aaa/bbb/ccc/XSD/abc.xsd*">
    if the file you are reading is valid then it is read, other wise not, I am not sure about sys read, but in empty BPEL process, if the XML is not validated with the XSD, then the XML is not read, I am still not sure what is the meaning of flat file, are you doing a opaque read?
    Yatan

  • How to delete multiple variables from the variables list

    Hello,
    Iam using FrameMaker 9.0. Is there a way I can select multiple variables from the book and delete them together.
    Thanks,
    CP.

    NO in FM9. Take SQUIDDS TOOLBOX the free tool: 'Formats'
    'Formats' is a very helpful tool for 'deleting' paragraph formats, character formats, cross reference formats, table formats, color definitions and variables.
    You can delete unused one or all formats of selected. For paragraph and character you can also decide to 'add new one in catalog'.
    -Georg

  • Managing multiple iOS devices on different Apple accounts from the same iMac

    May be a very simple question to answer, but can I manage multiple iOS devices on different Apple accounts from the same iMac?
    I ask as whilst I'm totally Mac'd, my partner who has her own Apple account has a Winows laptop and experiences problems updating iOS software on her iPhone 4S and iPad 3 Gen via the laptop. I'm thinking the problems may be overcome if we manage her iOS devices through my iMac.

    Thanks dwb .... I thought there'd be a catch .... not to keen on all that media and apps on my iMac!
    The specific problem is that whenever she updates to the latsest version of iOS using the latest iTunes for Windows on her PC laptop she seems to lose something in the process. One time she lost all her texts and the other day when updating to 5.1.1 she lost all her reminders. Not the end of the world but frustrating and shouldn't really happen and doesn't happen to me using the iMac and OSX.

Maybe you are looking for

  • Erro Faturamento/NF - Saldo em moeda da transação

    Durante a configuracao do cenario de transferencia de estoque por MM/SD , na hora de fazer a SM que ia gerar a NF acontecia o erro abaixo: Saldo em moeda da transação Nº mensagem F5702 Diagnóstico Ocorre um saldo na moeda de transação 'BRL': Categori

  • Apple Remote Desktop 3.7.1 lag problem

    Hello, Since updating to Apple Remote Desktop 3.7.0, I have had this problem. I just updated to 3.7.1 and the problem is still occuring. I am using RealVNC Viewer 5.0.6 Windows 64bit on a Windows 7 machine to connect to my Mac through Apple Remote De

  • HT201250 Can I use my time capsule as an external hard drive?

    Will my time capsule act as an external hard drive?  I would like to move my iTunes from my MacBook Pro to my time capsule.  Is this possible?

  • 64 bit windows and odbc connection

    I am new to the forum, so please bear with me. We have developers that have to run in Win 7 64 bit. I have installed Crystal Reports 12 on three systems. I used the c:\windows\SysWOW64\odbcad32.exe to set up the ODBC. BTW, this is an Intersystems Cac

  • Hide Radi Button

    Hi Friends, I have a requirement where i have to hide or show radio buttons based on employee SUBTYPE , say example i have three radio buttons like 1. Savings 2. Checking 3. Fixed Here the Scenario: String Value = wdContext.currentSubtypesElement().g