Flex SkinnableContainer skin access Group inside contentGroup

I have skin class in which I defined a Group inside my contentGroup:
<s:Group id="contentGroup" left="0" right="0" top="0" bottom="0" minWidth="475" minHeight="0">
    <s:layout>
                                  <s:HorizontalLayout paddingLeft="0" paddingRight="0" paddingTop="0" paddingBottom="0" gap="2" />
                        </s:layout>
    <s:Group id="group_nav_custom_comp_hgroup_prevnext" left="0" right="0" top="0" bottom="0" minWidth="100" minHeight="0">
                                  <s:layout>
                                            <s:HorizontalLayout paddingLeft="0" paddingRight="0" paddingTop="0" paddingBottom="0" gap="5" />
                                  </s:layout>
                                       <s:Button label="Test Button"/>
                        </s:Group>
</s:Group>
Now, in my CustomComponent that extends the skin class above I am trying to access the "group_nav_custom_comp_hgroup_prevnext" (which is the child group inside the contentGroup) so I can add elements to it at runtime:
  public class GroupNavCustomContainer extends SkinnableContainer
                        private var m_group_prev_next:Group = null;
                        private var m_bAdded_btns:Boolean = true;
                        private var _prevbtn:UIComponent = null;
                        public function GroupNavCustomContainer()
                                  super();
                                  setStyle("skinClass", GroupNavCustomSkin);
                        public function set prevBtn(ui_comp_prev:UIComponent):void
                            if(m_group_prev_next)
                                            _prevbtn = ui_comp_prev;
                                            m_bAdded_btns = true;
                                            invalidateProperties();
                        override protected function partAdded(partName:String, instance:Object):void
                                  trace("In partAdded");
                                  if(partName == "contentGroup")
                                            var group:Group = instance as Group;
                                            var visualElem:IVisualElement = group.getElementAt(0);
                                            m_group_prev_next = visualElem as Group;
                                  super.partAdded(partName, instance);
                        override protected function commitProperties():void
                                  super.commitProperties();
                                  if (m_bAdded_btns)
                                            m_bAdded_btns = false;
                                            m_group_prev_next.addElement(_prevbtn);
The result is my: group_nav_custom_comp_hgroup_prevnext is just not showing up at all, evidenced by the fact that the button present in it at compile time is not visible. Anyone know how to get it to show up?    - thx in advance -Mike

Based on Nikos tip, I rearranged my code and added 'group_nav_custom_comp_hgroup_prevnext' as a SkinPart, so now I have access to it, in other functions of the class, but still I do not see the button inside that nested group showing up. 
@ drkstr_1 :  Are you saying I cannot have a group inside my contentGroup? if so if then how can I have a group appear right next to it? --- do I have to add it programmatically in the  parent component -- but doesn't that defeat the purpose of the skin?
thx - Mike
package com.viiv.digi.views.navigation
          import mx.core.IVisualElement;
          import mx.core.UIComponent;
          import skins.GroupNavCustomSkin;
          import spark.components.Group;
          import spark.components.SkinnableContainer;
          public class GroupNavCustomContainer extends SkinnableContainer
                    private var m_group_prev_next:Group = null;
                    private var m_bAdded_btns:Boolean = false;
                    private var _prevbtn:UIComponent = null;
                    [SkinPart(required="true")]
                    public var group_nav_custom_comp_hgroup_prevnext:Group;
                    public function GroupNavCustomContainer()
                              super();
                              setStyle("skinClass", GroupNavCustomSkin);
                    public function set prevBtn(ui_comp_prev:UIComponent):void
                        _prevbtn = ui_comp_prev;
                              m_bAdded_btns = true;
                              invalidateProperties();
                    public function get prevBtn():UIComponent
                              return _prevbtn;
                    override protected function partAdded(partName:String, instance:Object):void
  trace("In partAdded");
                              super.partAdded(partName, instance);
                    override protected function commitProperties():void
                              super.commitProperties();
                              if (m_bAdded_btns)
                                        m_bAdded_btns = false;
                                        group_nav_custom_comp_hgroup_prevnext.addElement(_prevbtn);

Similar Messages

  • Internet Access from Inside to Outside ASA 5510 ver 9.1

    Hi everyone, I need help setting up an ASA 5510 to allow all traffic going from the inside to outside so I can get internet access through it. I have worked on this for days and I have finally got traffic moving between my router and my ASA, but that is it. Everything is blocked because of NAT rules I assume.
    I get errors like this when I try Packet Tracer:
    (nat-xlate-failed) NAT failed
    (acl-drop) Flow is denied by configured rule
    Version Information:
    Cisco Adaptive Security Appliance Software Version 9.1(4)
    Device Manager Version 7.1(5)
    Compiled on Thu 05-Dec-13 19:37 by builders
    System image file is "disk0:/asa914-k8.bin"
    Here is my ASA config, all I want for this exercise is to pass traffic from the inside network to the outside to allow internet access so I can access the internet and then look for specific acl's or nat for specific services:
    Thank You!
    Config:
    ASA5510# sh running-config
    : Saved
    ASA Version 9.1(4)
    hostname ASA5510
    domain-name
    inside.int
    enable password <redacted> encrypted
    xlate per-session deny tcp any4 any4
    xlate per-session deny tcp any4 any6
    xlate per-session deny tcp any6 any4
    xlate per-session deny tcp any6 any6
    xlate per-session deny udp any4 any4 eq domain
    xlate per-session deny udp any4 any6 eq domain
    xlate per-session deny udp any6 any4 eq domain
    xlate per-session deny udp any6 any6 eq domain
    passwd <redacted> encrypted
    names
    dns-guard
    interface Ethernet0/0
    description LAN Interface
    nameif Inside
    security-level 100
    ip address 10.10.1.1 255.255.255.252
    interface Ethernet0/1
    description WAN Interface
    nameif Outside
    security-level 0
    ip address 199.199.199.123 255.255.255.240
    boot system disk0:/asa914-k8.bin
    ftp mode passive
    dns domain-lookup Outside
    dns server-group DefaultDNS
    name-server 199.199.199.4
    domain-name
    inside.int
    object network inside-net
    subnet 10.0.0.0 255.255.255.0
    description Inside Network Object
    access-list USERS standard permit 10.10.1.0 255.255.255.0
    access-list OUTSIDE-IN extended permit ip any any
    access-list INSIDE-IN extended permit ip any any
    pager lines 24
    logging enable
    logging asdm informational
    mtu Inside 1500
    mtu Outside 1500
    mtu management 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-715.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    nat (Inside,Outside) source dynamic any interface
    object network inside-net
      nat (Inside,Outside) dynamic interface
    access-group INSIDE-IN in interface Inside
    access-group OUTSIDE-IN in interface Outside
    router rip
    network 10.0.0.0
    network 199.199.199.0
    version 2
    no auto-summary
    route Outside 0.0.0.0 0.0.0.0 199.199.199.113 1
    route Inside 172.16.10.0 255.255.255.0 10.10.1.2 1
    route Inside 172.16.20.0 255.255.255.0 10.10.1.2 1
    route Inside 192.168.1.0 255.255.255.0 10.10.1.2 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 Inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association pmtu-aging infinite
    crypto ca trustpool policy
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 Inside
    ssh timeout 60
    ssh version 2
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    username <redacted> password <redacted> encrypted privilege 15
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns migrated_dns_map_1
      parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns migrated_dns_map_1
      inspect ftp
      inspect h323 h225
      inspect h323 ras
       inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http
    https://tools.cisco.com/its/service/oddce/services/DDCEService
       destination address email
    [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
       subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    password encryption aes
    Cryptochecksum:
    <redacted>
    : end
    SH NAT:
    ASA5510# sh nat
    Manual NAT Policies (Section 1)
    1 (Inside) to (Outside) source dynamic any interface
        translate_hits = 0, untranslate_hits = 0
    Auto NAT Policies (Section 2)
    1 (Inside) to (Outside) source dynamic inside-net interface
         translate_hits = 0, untranslate_hits = 0
    SH RUN NAT:
    ASA5510# sh run nat
    nat (Inside,Outside) source dynamic any interface
    object network inside-net
    nat (Inside,Outside) dynamic interface
    SH RUN OBJECT:
    ASA5510(config)# sh run object
    object network inside-net
    subnet 10.0.0.0 255.255.255.0
    description Inside Network Object
    Hi all,Hello everyone, I need some help before my head explodes. Idddddddd

    Hello Mitchell,
    First of all how are you testing this:
    interface Ethernet0/0
    description LAN Interface
    nameif Inside
    security-level 100
    ip address 10.10.1.1 255.255.255.252
    Take in consideration that the netmask is /30
    The Twice NAT is good, ACLs are good.
    do the following and provide us the result
    packet-tracer input inside tcp 10.10.1.2 1025 4.2.2.2 80
    packet-tracer input inside tcp 192.168.1.100 1025 4.2.2.2 80
    And provide us the result!
    Looking for some Networking Assistance? 
    Contact me directly at [email protected]
    I will fix your problem ASAP.
    Cheers,
    Julio Carvajal Segura
    Note: Check my website, there is a video about this that might help you.
    http://laguiadelnetworking.com

  • Flex 4 skin  how to set tree control corner radius..?

    hi .,
         i have using flex4 mx tree control to reduce the corner radius.
    application using tree control code...
    <mx:Tree   contentBackgroundColor="#FFFFFF"  id="folderTree" labelField="documentFolderName" dataProvider="{folderTreeArray}" itemClick="clcikchanged(event)" height="650" borderColor="#FFFFFF">        </mx:Tree>
    <fx:Style>
        @namespace s "library://ns.adobe.com/flex/spark";
        @namespace mx "library://ns.adobe.com/flex/halo";
        @namespace mx1 "library://ns.adobe.com/flex/mx";
         mx|Tree
        border-skin: ClassReference('com.istmanagement.skins.Application.boaderskin');
        </fx:Style>
    borderskin.mxml coding here...
    <?xml version="1.0" encoding="utf-8"?>
    <s:Skin xmlns:fx="http://ns.adobe.com/mxml/2009" xmlns:s="library://ns.adobe.com/flex/spark"
        xmlns:fb="http://ns.adobe.com/flashbuilder/2009" alpha.disabled="0.5">
        <fx:Metadata>
    [HostComponent("spark.components.BorderContainer")]
    </fx:Metadata>
        <s:states>
            <s:State name="normal" />
            <s:State name="disabled" />
        </s:states>
          <s:Rect id="background"  left="0" right="0" top="0" bottom="0" >
            <s:fill>
                <s:SolidColor id="bgFill" color="#FFFFFF"/>
            </s:fill>
        </s:Rect>
       <s:BorderContainer cornerRadius="8" width="255" height="650">
        </s:BorderContainer>
        <s:Group id="contentGroup" left="0" right="0" top="0" bottom="0" minWidth="0" minHeight="0">
            <s:layout>
                <s:BasicLayout/>
            </s:layout>
        </s:Group>
    </s:Skin>
    tree control corner radius is reduced to display., after i have using  <mx:HDividedBox > to drag this to override a tree control...
    how to solve this problem.,
    With Regards.,
    LinFlex-

    Did you every solve this issue?

  • AnyConnect access to Inside IPs

    I'm having problems getting AnyConnect clients to reach a server (192.168.139.3) on the Inside interface of my ASA 5505.  Ideally, this would be accessible from the DfltAccessPolicy or another dedicated policy, but right now I'm happy with any access.  Everything else seems to be working as expected.  I've rebuilt this config a number of times without success.  I can ping the IP from the ASA itself.
    Can anyone give me suggestions?

    I've cut down the config, disabling the IPSEC tunnel to ease troubleshooting:
    : Saved
    ASA Version 8.2(1)
    hostname asa-dal
    domain-name dtainc.us
    enable password LpOk82NJGblSbuos encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 192.168.239.0 anyconnect-vpn-dal
    name 192.168.39.0 dmz-network
    name 192.168.139.3 dalRumServer description dalRumServer
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.139.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 209.xxx.xxx.xxx 255.255.255.248
    interface Vlan5
    no forward interface Vlan1
    nameif dmz
    security-level 0
    ip address 192.168.39.1 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    switchport access vlan 5
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    boot system disk0:/asa821-k8.bin
    boot system disk0:/asa831-k8.bin
    ftp mode passive
    clock timezone EST -5
    clock summer-time EDT recurring
    dns domain-lookup inside
    dns domain-lookup outside
    dns domain-lookup dmz
    dns server-group DefaultDNS
    name-server 8.8.8.8
    name-server 8.8.4.4
    domain-name dtainc.us
    same-security-traffic permit intra-interface
    object-group protocol DM_INLINE_PROTOCOL_1
    protocol-object ip
    protocol-object icmp
    protocol-object udp
    protocol-object tcp
    access-list inside_nat0_outbound extended permit ip 192.168.139.0 255.255.255.0 any
    access-list inside_nat0_outbound extended permit icmp any any
    access-list icmp_ping extended permit icmp any any echo-reply
    access-list icmp_ping extended permit ip 192.168.139.0 255.255.255.0 any
    access-list split-tunnel standard permit 192.168.139.0 255.255.255.0
    access-list 100 extended permit icmp any any echo-reply
    access-list 100 extended permit icmp any any time-exceeded
    access-list 100 extended permit icmp any any unreachable
    access-list NO_NAT extended permit ip anyconnect-vpn-dal 255.255.255.0 any
    access-list NONAT extended permit ip 192.168.139.0 255.255.255.0 anyconnect-vpn-dal 255.255.255.0
    access-list outside_access_in extended permit tcp any interface outside eq ssh
    access-list outside_access_in extended permit icmp any any echo-reply
    access-list outside_access_in extended permit icmp any any time-exceeded
    access-list outside_access_in extended permit icmp any any unreachable
    pager lines 24
    logging enable
    logging asdm informational
    logging permit-hostdown
    mtu inside 1500
    mtu outside 1500
    mtu dmz 1500
    ip local pool AnyConnectDal 192.168.239.101-192.168.239.125 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-631.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list NONAT
    nat (inside) 1 0.0.0.0 0.0.0.0
    access-group icmp_ping in interface inside
    access-group 100 in interface outside
    route outside 0.0.0.0 0.0.0.0 209.xxx.xxx.xxx 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    network-acl inside_nat0_outbound
    network-acl NO_NAT
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.139.0 255.255.255.0 inside
    http anyconnect-vpn-dal 255.255.255.0 inside
    http redirect outside 80
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    fqdn vpn-dallas.xxx.xxx
    subject-name CN=dallas-vpn
    crl configure
    crypto ca certificate chain ASDM_TrustPoint0
    certificate b948614e
        308201eb 30820154 a0030201 020204b9 48614e30 0d06092a 864886f7 0d010104
        0500303a 31133011 06035504 03130a64 616c6c61 732d7670 6e312330 2106092a
        864886f7 0d010902 16147670 6e2d6461 6c6c6173 2e647461 696e632e 7573301e
        170d3131 30393032 32313230 35375a17 0d323130 38333032 31323035 375a303a
        31133011 06035504 03130a64 616c6c61 732d7670 6e312330 2106092a 864886f7
        0d010902 16147670 6e2d6461 6c6c6173 2e647461 696e632e 75733081 9f300d06
        092a8648 86f70d01 01010500 03818d00 30818902 81810091 27a70739 bb960ebf
        28a9e2f1 99f832c5 075d4024 2b2e0faf dd05fe3e 10aed542 eace4100 b55ce871
        b7b0cd05 07f0ba2f 4050f881 b70a9f88 131651b1 beecbb1c b810f09b 7efee750
        210e0c36 fff115dc ff1d212c c941f13d b9fd3538 d9c7f07d 9e26bd5c d1c9c8fd
        58b6d6fb 964f460e 2de4e380 17858b75 3cdc7a1c d43c5902 03010001 300d0609
        2a864886 f70d0101 04050003 81810044 750fd8f8 95031536 bd2b2b0b 747e460d
        94b9462b c773ac8e bcf47696 833ef1d6 134a80e5 02e87817 7c3614b7 181c146d
        90191a9c 131bf1e0 1f6f5a7d 7b9e741e 02693ae8 6c323aa0 83fb6605 4bf420d1
        dfa54549 15f6dda0 69650778 c681d596 0cbe6f3e 9ca57c91 f3d23c1f 608e2a7e
        eef41a77 2e7ab2b2 08eb902c cdc017
      quit
    crypto isakmp enable outside
    crypto isakmp policy 1
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 5
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 10
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp nat-traversal 22
    telnet timeout 5
    ssh 192.168.139.0 255.255.255.0 inside
    ssh timeout 60
    console timeout 0
    management-access inside
    dhcpd dns 8.8.8.8 8.8.4.4
    dhcpd auto_config outside
    dhcpd address 192.168.139.101-192.168.139.132 inside
    dhcpd dns 8.8.8.8 8.8.4.4 interface inside
    dhcpd lease 86400 interface inside
    dhcpd domain dtainc.internal interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server 129.6.15.29
    ntp server 129.6.15.28 prefer
    webvpn
    enable inside
    enable outside
    anyconnect-essentials
    svc image disk0:/anyconnect-win-2.4.1012-k9.pkg 1
    svc enable
    tunnel-group-list enable
    group-policy DfltGrpPolicy attributes
    vpn-tunnel-protocol l2tp-ipsec svc webvpn
    group-policy Dal-AnyConnect internal
    group-policy Dal-AnyConnect attributes
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value split-tunnel
    tunnel-group DefaultRAGroup general-attributes
    strip-realm
    strip-group
    tunnel-group AnyConnectClientProfile type remote-access
    tunnel-group AnyConnectClientProfile general-attributes
    address-pool AnyConnectDal
    default-group-policy Dal-AnyConnect
    tunnel-group AnyConnectClientProfile webvpn-attributes
    group-alias AnyConnectVPNClient enable
    class-map global-class
    match default-inspection-traffic
    policy-map global-policy
    class global-class
      inspect pptp
      inspect icmp
    service-policy global-policy global
    prompt hostname context
    Cryptochecksum:507852f675a4b501578fe5574a49c3ae
    : end
    asdm image disk0:/asdm-631.bin
    asdm location dalRumServer 255.255.255.255 inside
    no asdm history enable

  • Flex 4 skin question

    I am looking into Flex SDK skins and see a reference to hostComponent. What is it exactly for?

    The hostComponent attribute is a reference to the component instance that the skin is currently attached to. It is a convenient way to access properties or methods from the component.
    In general, you want to push data from the component to the skin. However, on occasion, you need to pull information from the component to the skin and hostComponent provides a way to do that.

  • Port access to inside

    I am trying to allow access to my inside users on port 5222 for a new phone system application on a ASA5505. All of my inside users are using DHCP from a Domain Controller.  If I connect to another network that does not have a ASA 5505 in place I am able to open the application that uses port 5222, but from the network behind the ASA I am not able to.

    The Source IP is 74.43.254.162
    The Destination IP will be 10.10.10.0/24  Internal subnet
    This applications allows the users to see how many calls are the in queue, if they have voice mail, who is in or away
    ASA configuration;
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.10.10.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 216.255.166.36 255.255.255.240
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    time-range Close_Portol
    boot system disk0:/asa804-28-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
    domain-name tvcconnect.net
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group network FTPHosts
    description Those that are allowed to use FTP
    network-object 216.255.166.7 255.255.255.255
    network-object 63.161.147.154 255.255.255.255
    network-object 63.161.147.10 255.255.255.255
    network-object host 216.255.162.47
    network-object host 64.161.190.116
    network-object host 208.85.128.5
    network-object host 208.85.128.2
    network-object host 75.13.65.241
    network-object host 10.10.10.151
    network-object host 10.10.10.8
    object-group network PeakViewSolutions
    network-object host 10.10.10.21
    object-group network TVCBlackBerryIPs
    *object-group network TVCDroidsIPs
    object-group network TVC_GLDS_External_Hosts
    object-group network BLUE_MOON
    access-list 100 extended permit ip 10.10.10.0 255.255.255.0 172.16.205.0 255.255.255.0
    access-list nonat extended permit ip 10.10.10.0 255.255.255.0 host 172.16.205.15
    access-list nonat extended permit ip any 192.168.250.0 255.255.255.0
    access-list nonat extended permit ip any 10.7.7.0 255.255.255.248
    access-list nonat extended permit ip 172.16.208.0 255.255.255.0 host 172.16.205.10
    access-list nonat extended permit ip 172.16.208.0 255.255.255.0 host 172.16.205.20
    access-list nonat extended permit ip host 10.10.10.101 172.16.205.0 255.255.255.0
    access-list TVC_In extended permit tcp object-group FTPHosts host 216.255.166.41 eq ftp
    access-list TVC_In extended permit ip 74.62.190.0 255.255.255.0 host 216.255.166.40
    access-list TVC_In extended permit icmp host 216.255.162.36 host 216.255.166.37
    access-list TVC_In extended permit ip host 216.255.162.37 host 216.255.166.37
    access-list TVC_In extended permit tcp host 216.255.162.36 host 216.255.166.37 eq 15802
    access-list TVC_In extended permit udp host 216.255.162.36 host 216.255.166.37 eq 15802
    access-list TVC_In extended permit tcp host 216.255.162.36 host 216.255.166.37 eq 15803
    access-list TVC_In extended permit udp host 216.255.162.36 host 216.255.166.37 eq 15803
    access-list TVC_In extended permit tcp host 216.255.162.36 host 216.255.166.40 eq 15802
    access-list TVC_In extended permit udp host 216.255.162.36 host 216.255.166.40 eq 15802
    access-list TVC_In extended permit tcp host 216.255.162.36 host 216.255.166.40 eq 15803
    access-list TVC_In extended permit udp host 216.255.162.36 host 216.255.166.40 eq 15803
    access-list TVC_In extended permit tcp host 216.255.162.37 host 216.255.166.40 eq 15802
    access-list TVC_In extended permit udp host 216.255.162.37 host 216.255.166.40 eq 15802
    access-list TVC_In extended permit tcp host 216.255.162.37 host 216.255.166.40 eq 15803
    access-list TVC_In extended permit udp host 216.255.162.37 host 216.255.166.40 eq 15803
    access-list TVC_In extended permit tcp object-group TVCBlackBerryIPs host 216.255.166.42 eq www log
    access-list TVC_In extended permit tcp object-group TVCBlackBerryIPs host 216.255.166.42 eq https log
    access-list TVC_In extended permit tcp object-group TVCDroidsIPs host 216.255.166.42 eq www log
    access-list TVC_In extended permit tcp object-group TVCDroidsIPs host 216.255.166.42 eq https log
    access-list TVC_In extended permit ip object-group TVC_GLDS_External_Hosts host 216.255.166.40
    access-list TVC_In extended permit udp any any eq sip
    access-list TVC_In extended permit udp any any range 10000 20000
    access-list TVC_In extended permit udp any any eq 5061
    access-list TVC_In permit tcp any any eq 5222
    access-list TVC_In extended permit tcp any any range 10000 20000
    access-list Split_Tunnel standard permit 10.10.10.0 255.255.255.0
    !Lines removed
    logging enable
    logging timestamp
    logging buffered debugging
    logging trap errors
    logging asdm informational
    logging host inside 10.10.10.9
    mtu inside 1500
    mtu outside 1500
    ip local pool VPN_Pool 192.168.250.1-192.168.250.50 mask 255.255.255.0
    ip local pool TVC&GU_VPN_Pool 192.168.250.51
    ip local pool MIR_VPN_Pool 10.7.7.1-10.7.7.2 mask 255.255.255.248
    ip local pool TVC_3Cs_VPN_Pool 192.168.250.60-192.168.250.62 mask 255.255.255.0
    ip local pool BLUE_MOON_VPN_Pool 192.168.250.55-192.168.250.58 mask 255.255.255.0
    ip verify reverse-path interface outside
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit host 216.255.162.36 outside
    icmp permit host 216.255.166.7 outside
    icmp permit host 216.255.166.37 outside
    icmp deny any outside
    asdm image disk0:/asdm-611.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (outside) 2 216.255.166.37 netmask 255.255.255.255
    global (outside) 3 216.255.166.38 netmask 255.255.255.255
    global (outside) 4 216.255.166.40 netmask 255.255.255.255
    nat (inside) 0 access-list nonat
    nat (inside) 3 10.10.10.11 255.255.255.255
    nat (inside) 2 10.10.10.12 255.255.255.255
    nat (inside) 4 10.10.10.15 255.255.255.255
    nat (inside) 1 10.10.10.0 255.255.255.0
    static (inside,outside) 216.255.166.37 10.10.10.12 netmask 255.255.255.255
    static (inside,outside) 216.255.166.39 10.10.10.50 netmask 255.255.255.255
    static (inside,outside) 216.255.166.40 10.10.10.15 netmask 255.255.255.255
    static (inside,outside) 216.255.166.41 10.10.10.11 netmask 255.255.255.255
    static (inside,outside) 216.255.166.42 10.10.10.21 netmask 255.255.255.255
    access-group TVC_In in interface outside
    route outside 0.0.0.0 0.0.0.0 216.255.166.33 1
    route outside 172.16.205.0 255.255.255.0 216.255.166.9 1
    route inside 172.16.208.0 255.255.255.0 10.10.10.4 1
    route outside 192.168.0.0 255.255.255.0 216.255.166.9 1
    route inside 0.0.0.0 0.0.0.0 10.10.10.2 tunneled
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record TVC_VPN_DAP
    description "Non TVC 3Cs access"
    priority 1
    dynamic-access-policy-record TVC_3Cs_DAP
    description "TVC 3Cs DAP"
    priority 10
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server TVC-DC-01 protocol ldap
    aaa-server TVC-DC-01 (inside) host 10.10.10.30
    ldap-base-dn dc=tvcconnect, dc=net
    ldap-scope subtree
    ldap-naming-attribute sAMAccountName
    ldap-login-password *
    ldap-login-dn CN=ASA ASA,CN=Users,DC=tvcconnect,DC=net
    server-type microsoft
    aaa authentication ssh console LOCAL
    http server enable
    http 10.10.10.8 255.255.255.255 inside
    http 10.10.10.9 255.255.255.255 inside
    http 10.10.10.7 255.255.255.255 inside
    http 10.10.10.6 255.255.255.255 inside
    http 10.10.10.163 255.255.255.255 inside
    http 10.10.10.151 255.255.255.255 inside
    http 10.10.10.38 255.255.255.255 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set myset esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-3DES-SHA ESP-3DES-MD5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000
    crypto map outside_map 1 match address GU
    crypto map outside_map 1 set peer 216.255.166.9
    crypto map outside_map 1 set transform-set myset
    crypto map outside_map 1 set security-association lifetime seconds 28800
    crypto map outside_map 1 set security-association lifetime kilobytes 4608000
    crypto map outside_map 20 match address 100
    crypto map outside_map 20 set peer 216.255.166.7
    crypto map outside_map 20 set transform-set myset
    crypto map outside_map 20 set security-association lifetime seconds 28800
    crypto map outside_map 20 set security-association lifetime kilobytes 4608000
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp identity address
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 60
    ssh version 2
    console timeout 0
    management-access inside
    priority-queue inside
    threat-detection basic-threat
    threat-detection statistics port
    threat-detection statistics protocol
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    group-policy TVC_GLDS internal
    group-policy TVC_GLDS attributes
    dns-server value 10.10.10.30 10.10.10.31
    vpn-tunnel-protocol IPSec
    default-domain value tvcconnect.net
    group-policy TVC_ACCESS internal
    group-policy TVC_ACCESS attributes
    dns-server value 10.10.10.30 10.10.10.31
    vpn-access-hours none
    vpn-tunnel-protocol IPSec
    default-domain value tvcconnect.net
    group-policy TVC_3Cs_GP internal
    group-policy TVC_3Cs_GP attributes
    vpn-tunnel-protocol IPSec
    group-policy DfltGrpPolicy attributes
    vpn-tunnel-protocol IPSec webvpn
    group-policy TVC&GU_VPN internal
    group-policy TVC&GU_VPN attributes
    dns-server value 10.10.10.30 10.10.10.31
    vpn-tunnel-protocol IPSec
    default-domain value tvcconnect.net
    group-policy TVC_BLUE_MOON internal
    group-policy TVC_BLUE_MOON attributes
    dns-server value 10.10.10.30 10.10.10.31
    vpn-tunnel-protocol IPSec
    default-domain value tvcconnect.net
    group-policy PeakView_Solutions internal
    group-policy PeakView_Solutions attributes
    dns-server value 10.10.10.30 10.10.10.31
    vpn-tunnel-protocol IPSec
    default-domain value tvcconnect.net
    username raufm password ******************* encrypted privilege 15
    username koschmiederv password ********************** encrypted
    username koschmiederv attributes
    vpn-group-policy TVC_ACCESS
    username PeakViewSolutions password ******************* encrypted privilege 0
    username PeakViewSolutions attributes
    vpn-group-policy PeakView_Solutions
    username danielles password ************************* encrypted privilege 0
    username danielles attributes
    vpn-group-policy TVC_ACCESS
    username summerst password ************************** encrypted privilege 15
    username summerst attributes
    vpn-group-policy TVC_ACCESS
    username GLDS password ********************* encrypted privilege 0
    username GLDS attributes
    vpn-group-policy TVC_GLDS
    username zawackij password ********************* encrypted privilege 0
    username zawackij attributes
    vpn-group-policy TVC_ACCESS
    username kennistonh password ***************** encrypted privilege 0
    username bluemoon password ******************* encrypted
    username bluemoon attributes
    vpn-group-policy TVC_BLUE_MOON
    tunnel-group TVC&GU_VPN type remote-access
    tunnel-group TVC&GU_VPN general-attributes
    address-pool TVC&GU_VPN_Pool
    tunnel-group TVC&GU_VPN ipsec-attributes
    pre-shared-key *
    tunnel-group TVC_GLDS type remote-access
    tunnel-group TVC_GLDS general-attributes
    address-pool VPN_Pool
    default-group-policy TVC_GLDS
    tunnel-group TVC_GLDS ipsec-attributes
    pre-shared-key *
    tunnel-group TVC_ACCESS type remote-access
    tunnel-group TVC_ACCESS general-attributes
    address-pool VPN_Pool
    default-group-policy TVC_ACCESS
    tunnel-group TVC_ACCESS ipsec-attributes
    pre-shared-key *
    tunnel-group 216.255.166.9 type ipsec-l2l
    tunnel-group 216.255.166.9 ipsec-attributes
    pre-shared-key *
    isakmp keepalive threshold 15 retry 10
    tunnel-group GU_Information_Technology type remote-access
    tunnel-group GU_Information_Technology general-attributes
    address-pool MIR_VPN_Pool
    tunnel-group GU_Information_Technology ipsec-attributes
    pre-shared-key *
    isakmp keepalive threshold 15 retry 10
    tunnel-group PeakView_Solutions type remote-access
    tunnel-group PeakView_Solutions general-attributes
    address-pool VPN_Pool
    default-group-policy TVC_GLDS
    tunnel-group PeakView_Solutions ipsec-attributes
    pre-shared-key *
    tunnel-group TVC_BLUE_MOON type remote-access
    tunnel-group TVC_BLUE_MOON general-attributes
    address-pool BLUE_MOON_VPN_Pool
    tunnel-group TVC_BLUE_MOON ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect netbios
      inspect tftp
      inspect ftp
      inspect icmp
      inspect icmp error
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:3667be2845ce3329b1bf61a9e260d350

  • How do I access group calendars on 10.8 server from a calendar client?

    Hi,
    I have a brand new installation of 10.8.2 . I installed the server app and started Calendar, Contacts, DNS, File Sharing, Mail, Open Directory and the Wiki services. I created a group with some users in it. I also created a group wiki and enabled the calendar for that wiki. The user group has r/w access to the wiki. The web interface to the wiki works from a client 10.8.2 client system. I can edit the group calendar through the web interface. I created an account in the Calendar application that connects to the server and shows the users' calendar. I altered the server path to /principals/__uids__/wiki-GROUPNAME/.
    The calendar shown is still that for the user and not the one of the group. Hence my question: how do I access group calendars on a 10.8 server from the calendar application on a client?

    yrmomsadic wrote:
    Forgot to mention, you can techinically force it to work, but iCal breaks it for some unknow reason, taking it back to the users account after a day or two.  The best work around has been to create a new user, named the group name, and then allow delegates to access the calendar.  This however screws things up with the iphone calendar, as it didn't/doesn't handle delegates.  Again, hoping Apple comes to their senses on this.
    You can still delegated calendars on iOS, but the setup is a little tricky.  You have to add an entirely new calendar account, and enter the full ugly url with the users uuid.  It would be so nice if iOS just supported CalDav delegation.

  • How to access group policy in windows 8 home premium, not 8.1 to disable snipping tool

    how do I access group policy to disable the snipping tool in windows 8 home premium? client has not installed update 8.1. client is trying to save pictures to pictures album, but it also saves a screenshot to the documents folder as well regardless
    of what save method is used.
    thanks.

    You can disable the Snipping Tool by creating the below registry setting
    (save as a .REG file)
    Windows Registry Editor Version 5.00
    [HKEY_CURRENT_USER\Software\Policies\Microsoft\TabletPC]
    "DisableSnippingTool"=dword:00000001
    ref: http://gpsearch.azurewebsites.net/Default.aspx?PolicyID=2426
    I am not aware of any Snipping Tool feature which automatically saves the snip, as a file.
    (there are other utilities available which can perform similar functions)
    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)
    This has apparently resolved the problem with the saving of screenshots based on the customers response. thanks so much.

  • Flex DataGrid with Dynamic Grouping

    Does anyone know of any examples of Flex datagrids that have
    grouping features comparable to the numerous grid components
    available in the ASP.NET world? I’m thinking of .NET
    component vendors such as Telerik, Infragistics, Component Art,
    DevExpress, etc.
    The way these .NET controls generally work is that you drag
    the header of a column to a bar above the grid, which causes the
    grid to redraw based on the new grouping you just specified.
    This is an example of a grid component that I am currently
    using:
    Telerik
    Grid
    Thank you,
    Mike Chabot

    The renderer's data property is the data for the entire row so you can get the column1 data and assign the combobox's dataprovider accordingly.
    Alex Harui
    Flex SDK Developer
    Adobe Systems Inc.
    Blog: http://blogs.adobe.com/aharui

  • Class-map type inspect match access-group name question

    I'm creating a zone base firewall solution and all appears to be fine until I create a class-map type inspect match-all or any
    and match access-group name acl to match an extended ACL and once I match it the commands runs but when I go back to view the configuration of the class-map it is not there. 
    I have tried other named ACLs and it works if the ACL contents are simple like permit ip any any but for complex ACLs with ranges, tcp, udp, icmp etc etc it does not take it but  it does not report an issue either and when I view the config its not there for the complex extended acl but for the simple extended acl it does show.
    Any restrictions or possible bugs I'm running into?
    Thanks for all looking

    This could be a bug.  Could you post the exact configuration you are trying to implement?  I just set up a small test and I have been unable to reproduce what you are seeing.  I would like to see if I get the same result using your config. 
    Please remember to select a correct answer and rate helpful posts

  • Grouping inside current grouping in BIP

    Hi All,
    I need to create a sub report inside the parent report. For the parent report, I am grouping the rows on the basis of emp id which is the primary key and then I am grouping my rest of the columns by using current group. The parent report and sub report are linked to each other by emp id which I am using as a parameter
    Similar is for the sub report, I need to group this report too on some column.
    The data for the sub report comes from a different query. So I created two data models, one for parent and one for sub report, contactenated the data sets with row names unique.
    data comes something like this
    <DATA>
    <PARENT>
    +<PARENT_ROW>
    +<PARENT_ROW>
    </PARENT_ROW>
    </PARENT>
    <SUB>
    +<SUB_ROW>
    +<SUB_ROW>
    </SUB>
    </DATA>
    So there are two nodes, PARENT and SUB. Now I have to show my grouped sub report inside the group parent report but the issue is since my sub report refers to a different node ( which is SUB) inside the parent report ( which refers to PARENT node), I don't see the data for sub report when i place it inside the PARENT report and when I place it out of the PARENT report, it works. Now this is how I want to place my sub and parent reports
              --PARENT Report starts
    PARENT_DATA_FIELD1
    PARENT_DATA_FIELD2
              --SUB report starts
    SUB_DATA_FIELD1
    SUB_DATA_FIELD2
              --SUB report ends
    PARENT_DATA_FIELD3
    PARENT_DATA_FIELD4
    --PARENT Report starts
    Long story short, I need to refer to the different node (and use grouping) inside an another running group of a differnt node. Can I do this?
    Request you to let me know, any help would be much appreciated.
    Thanks,
    Ronny

    Take a look at the following link: http://blogs.oracle.com/xmlpublisher/entry/formatting_concatenated_dataso
    and give it a try or you send me the RTF template and xml to [email protected] I can try to help.
    Thanks,
    Bipuser

  • Access elements inside a dialog box/window using applescripts

    Am new to applescript. I want to access elements inside a dialog box/window. I tried following code.
    tell application "System Events" set procs to processes set windowName to {} repeat with proc in procs try if exists (window 1 of proc) then repeat with w in windows of proc if w's name contains "App Name" then copy w's name to the end of windowName copy properties of w to the end of windowName end if end repeat end if end try -- ignore errors end repeat end tell return windowName
    But am only able to get the 4 elements from window: 1.Close 2.Minimize 3.Maximize 4.window title
    Nothing from inside the window/dilog.
    Can any one help me with this pls?

    Hi,
    Like this :
    tell application "System Events"
          tell process "App Name"
                tell (first window) to if exists then return UI elements
          end tell
    end tell

  • Mail 4 Exchange should allow Access Groups

    It's a shame the Mail for Exchange Connection menu requires an Access Point setting - and doesn't allow the selection of an Access Group.
    I have an Access Group set-up where my WLAN is used, but when I leave the office, the 2nd preference is a 3G/UMTS data connection.
    I should be able to sync with my Exchange server in the office, and when I leave, maintain the connection without any user intervention required (by auto-switching to UMTS)
    It would seem so simple, but unfortunately it's not supported. Hopefully someone from Nokia is watching....

    Don't know what kind of phone but I assume an E series. Try downloading Smart Roaming (go to "Catalog" on the phone). THen configure smart roaming to be your wifi and then gprs. Then configure mail 4 exchange to use smart roaming as its access point. Works well.

  • Limited access group for some switches only

    Hi ,
    We have around 80 x cisco 3750 switches using AAA Windows Radius server and AD as authentication for IT users login.
    How do we setup a limited access group which allow them to access some switches ONLY?
    Any advice is very much appreciated.
    Thanks
    Qle

    Well its Prod (you have a dashboard called testdashboard in Prod?) anyway - someone might have changed the presentation catalogue permissions on the dashboard. All it takes is for someone to remove 'Everyone' or change a Group permission and it could effect.
    If they changed the Parent folder and cascaded the changes down this might cause this issue.
    You have a folder called 'Shared' - check the groups that the people are in have 'Traverse' , 'Read' or higher. Also chek dashboard permissions themselves from Settings-Manage Interactive Dashboards - Check the Padlock icon.
    Are you users getting allocated into the correct WEBGROUPS ? Is this assisngment done explicitly in the webcat or via an RPD Variable ? Have you checked NQQueryl.log to make sure any init blocks are completing successfully?
    Either persmissions have changed or group memebership is not completing.
    Good luck
    Alastair

  • Can't access Group Tabs, unresponsive script 6955 loop.

    Tried to access group tabs and Firefox froze up along with everything else. Had to close Firefox using task manager via. Control/Alt/Delete. Once Firefox closed the rest of the computer worked. Now when opening Firefox I get "unresponsive script 6991". I press continue and I get "unresponsive script 6995" in a never ending loop. If I stop the script Firefox works, but I can't access Group Tabs. Also, in the middle of all of this Firefox updated to Ver. 28 from 27 something. I have rebooted my computer several times and searched the support topics but have not seen anything like this problem. The only thing I have come across to do that might help is reset Firefox. Wanted more info before I did.

    You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data.
    Rename (or delete) the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox profile folder.
    *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
    *http://kb.mozillazine.org/Profile_folder_-_Firefox
    *http://kb.mozillazine.org/Multiple_profile_files_created
    Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

Maybe you are looking for