Get server address from RemoteStub?

I hope this is possible...
How can I get the hostname/port from a java.rmi.server.RemoteStub?
I can see it, when I call a toString() on it, along with a lot of other interesting information as well, for example:
   gnu.cajo.invoke.Remote_Stub[RemoteStub[ref:[endpoint:
   [JohnnyLaptop:1234,gnu.cajo.invoke.Remote$RCSF@1479feb]
   (remote), objID:[fa3ac1:febb6046e0:-8000, 0]]]]I really don't want to parse this string; there must be a simple way to get these; right?
Many Dukes of appreciation!
John

Unfortunately the SecurityManager approach is already causing problems; obviously on hosts which prohibit its installation. Keep looking... sigh.
To be honest Esmond, I am still considering all of the implications of clients being aware of the host from which a remote reference came. However, it still astonishes me that is not more easily available. I understand the motivation for data hiding and all, but I really see no harm in letting a user know, if he wants to. In fact I can see more harm in not.
For example, a server, particularly one with an RMISecurityManager installed, could then prevent a potentially catastrophic compromise that could occur by simply calling any method. (As a trojan could even be carried in a RemoteException)
I don't want to say too much on that; as I would rather not provide skr1pt k1dd13z with information on crashing J2EE infrastructure. But you know what I mean.

Similar Messages

  • VWLC clients getting DHCP address from management VLAN

    Hi,
    We have a strange scenario whereby some wireless employees are obtaining addresses from the management VLAN.
    Some details:
    DHCP managed by MS DHCP 2008 R2 (in remote data centre)
    Cisco vWLC AIR-CTVM-K9 running v7.6.110.0
    AP's are a mix of 2602 and 3702 (46 and 2 of each respectively)
    SSID's are employee, guest, and production devices (all mapped to their own interface with relevant VLAN tag as per normal)
    AP's all in FlexConnect mode as per vWLC caveats
    Some employees are receiving addresses in the wireless management VLAN. This network only has six DHCP addresses available as it is solely for AP's, WLC and HSRP gateway. Obviously this gets exhausted very quickly leaving us with a scenario where clients are not obtaining DHCP addresses.
    I understand that with FlexConnect mode, it will assign IP's from the native VLAN. What I don't understand is why most clients receive addresses in the correct VLAN, but a handful do not, and then cannot get an address from DHCP. Obviously the ideal scenario would be to put the AP's into local mode but unless this has changed in a SW release then I don't believe it's possible...
    My question is: How do I get ALL the employees to obtain addresses from their interface and not the management VLAN?
    Thanks in advance.

    Hi,
    I think we need a closer look to your configurarion to eliminate some possibilities:
    - What is the WLAN security you choose?
    - What is the interface that is configured under the WLAN?
    - Does your WLAN have local switching enabled?
    - If your security is using RADIUS server, do you have AAA override enabled under the WLAN config?
    - If your security is using RADIUS server, do you send any attributes to the users?
    - You have eliminate that clients that got management vlan IPs are always on same AP or they can be on any AP.
    HTH
    Amjad

  • How to get IP address from login screen in 10.7 Lion

    Hi All,
    In 10.7 I didn't find any option to get IP address from login screen as used to got in 10.4,10.5,10.6
    Thanks

    Jason,
    is there any way to make that example
    work with release 6.0, preverribly
    with IE5 (native VM)?
    The WHEN-CUSTOM-ITEM-EVENT Trigger
    doesn't seem to fire.
    Thanks
    Anton Weindl
    <BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by Jason Pepper ([email protected]):
    If you are using web deployed forms then you need to use a javabean to obtain the IP of the local machine - you can get one that does it here..
    http://technet.oracle.com/sample_code/products/forms/listing.htm#pjcexamp
    If you are running client server then there is a utility in d2kwutil.pll that allows you to read the registry and do things like get the IP address. d2kwutil is shipped with your copy of Forms - just have a look for it - the code is self documenting, but there is also a manual you can read too.
    Jason Pepper
    Principal Product Manager
    Enterprise Internet Tools
    Oracle Corp<HR></BLOCKQUOTE>
    null

  • How can I get the address from a map struct?

    Hello,
    Who knows how to get the address from a map struct, and what's the meaning of the eighth argument (addr) of ufs_getpage() ?
    I developed a modular to encrypt certain files. The approach is: I�fll change the vnode's v_op pointer when opening a file which should be decoded. I make the vnode->v_op point to my own ops struct. I made a new ufs_getpage function like below:
    static int newufs_getpage(struct vnode* vp, offset_t off, size_t len,
    uint_t* protp, page_t* plarr[], size_t plsz,
    struct seg* seg, caddr_t addr, enum seg_rw rw,
    struct cred* cr)
    call old ufs_getpage(vp, off, len, protp, plarr, plsz, seg, addr, rw, cr);
    decode the page.
    After reading some source code about kernel, I know the plarr is the page which is read from the disk. But I don't know how to get the address of the page. I tried like below, but failed.
    caddr_t baseaddr;
    page_t *pp;
    pp = plarr[0];
    �c�c
    baseaddr = hat_kpm_page2va(pp, 0);
    �c�c
    I logged the baseaddr:
    cmn_err(CE_NOTE, �gbaseaddr %s�h, baseaddr);
    or
    char _buff[8];
    int _len;
    copyinstr(baseaddr, buff, 8, &len);
    cmn_err(CE_NOTE, �gbaseaddr %s�h, _buff);
    But I found the baseaddr is not what I want. Is there something wrong with my approach? What's the meaning of the eighth argument (addr) of ufs_getpage()
    By the way, is there any documents concerning to the functions such as segvn_fault�Appmapin/ppmapout except the source code?

    Hiya,
    I think the address is the faulting address in segmap.
    But why not have a look at the file event management framework in NFSv4:
    http://cvs.opensolaris.org/source/xref/on/usr/src/uts/common/fs/fem.c
    To support NFSv4 delegation, FEM provides hooks to intercept filesystem operations.
    Maybe you could use that to implement what you want? Probably safer than doing what you are doing now. Go see fem_install().
    Cheers,
    R.
    Message was edited by:
    ralphyt

  • How to get MAC address from IP address in LAN

    Hi all,
    How to get MAC address from IP address in LAN (windows or any OS), I would have all IP addresses of my LAN, so I would like to know all MAC address.
    Code examples are highly appreciated.
    Thanks & Regards,
    abel...

    abel wrote:
    Yeah that is only working for local system, but how to get remote system's MAC ..?
    Thanks for quick reply ...
    Edited by: abel on Jan 28, 2009 12:10 AMIt is my understanding that only one person ever found the holy grail which you seek. But sadly [_he's dead_|http://forums.sun.com/profile.jspa?userID=649366]
    As a curious aside how did you manage to get the list of IPs?

  • Need powershell commands to get email addresses from public folder created in EAC to CSV

    Need powershell commands to get email addresses from public folder created in EAC to CSV
    1. Created Public folders via EAC - not mail enabled - just to hold contacts.
    2. Assigned owners and showed to add new contacts - then add to favorites and finally to display as address book.
    Now I need a powershell command to get those email contacts in those public folders.
    I need to view them because when we send emails to those groups (via select all) in the public folders, it is creating an NDR for 3 users saying - "..blah blah -OFFICE FAX or HOME FAX) - yet they are getting the emails.
    I suspect that their contact details are corrupt somehow and want to see what contacts are actually listed in the public folders. I already checked to see if the source of the contacts was the public folder or "my contacts" and they are not.'
    I have tried multiple get recipient commands and get public folder commands with no results in the CSV

    The only way to get that data is either via the Outlook com object or using EWS. None of the commands in the Exchange shell look inside of a folder, the most you can get with those is email addresses for mail-enabled Public folders. Here is a link that can
    get you started with how to connect to public folders via EWS, then its just enumerating the folders and looping through the items in the folders for the details of the items. 
    http://gsexdev.blogspot.com/2013/08/public-folder-ews-how-to-rollup-part-1.html
    DJ Grijalva | MCITP: EMA 2007/2010 SPA 2010 | www.persistentcerebro.com

  • Unable to get ip address from DHCP server for Aironet 1130AG Access Point

    I have a network in which DHCP server is enabled. I have read the installation guide also there it is mentioned that 1130G Access point will not have any staic ip assigned to it.So it will automatically get the ip from the DHCP server from the network. I have connected that from the network but it is unable to get the ip address from the same. The same thing i have configured in the netgear it is coming fine. I have seen the sonic wall and used the IPSU tool also from checking the ip address from Mac Address but i am not able to get the same. Please provide me some tips to check where i am wrong in configuration because the first web page also not coming because of the ip address.

    narendra,
    I would suggest that the AP be connected to a laptop or desktop pc that would run a local dhcp server with a small scope setup...plenty of free ones on the web(this pc would obviously not be connected to your currnet network). This way you can watch the dhcp server hand the AP it's address (this can take a few minutes). Once you have the address use it to access the GUI and give the AP a static address (I find it good pratice to give all my autonomous AP's static addresses for ease of troubleshooting)...Hope that helps.

  • Unable to get IP address from DHCP

    hi all,
    I have a AP1131 which cannot get IP from DHCP server. I have tried to configure static IP address and controller IP by lwapp command and the AP can successfully joined the controller. However, after I changed it to DHCP in WLC, it cannot get IP address and all lwapp config is gone. It cannot join the controller anymore only after I reset it and configure a static IP for it. The following error message appears after I changed it to DHCP in the WLC:
    *Mar 7 08:44:36.511: RESETTING THE STATIC IP ADDRESS: LWAPP goes back to discovery
    %WIDS-6-DISABLED: IDS Signature is removed and disabled.
    %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY
    %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY
    %LINK-3-UPDOWN: Interface Dot11Radio0, changed state to up
    %LINK-3-UPDOWN: Interface Dot11Radio1, changed state to up
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LINK-5-CHANGED: Interface Dot11Radio1, changed state to reset
    %LINK-5-CHANGED: Interface Dot11Radio0, changed state to reset
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    Any expert has some idea on it?
    Thanks.

    Is that AP on the same subnet as the other AP's? The thing is, when you configure the AP with static information, you say the AP is able to join the WLC. This means that there is no issue with the AP. Now when you set the AP to use DHCP and not static, the AP does not obtain a DHCP address? Is that correct? If you have more than one AP on the same switch and on the same vlan, and only one has an issue, then maybe reset that AP to default and see if that fixes it. I'm also assuming that the vlan is being forwarded and you have enough dhcp address in the scope.

  • How to Get IP address from 6i?

    I would like to know command or syntax for get IP ADDRESS of computer?
    SELECT SYS_CONTEXT('USERENV','IP_ADDRESS')
    FROM DUAL;
    It can't work in syntax of FORM6i.
    null

    Jason,
    is there any way to make that example
    work with release 6.0, preverribly
    with IE5 (native VM)?
    The WHEN-CUSTOM-ITEM-EVENT Trigger
    doesn't seem to fire.
    Thanks
    Anton Weindl
    <BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by Jason Pepper ([email protected]):
    If you are using web deployed forms then you need to use a javabean to obtain the IP of the local machine - you can get one that does it here..
    http://technet.oracle.com/sample_code/products/forms/listing.htm#pjcexamp
    If you are running client server then there is a utility in d2kwutil.pll that allows you to read the registry and do things like get the IP address. d2kwutil is shipped with your copy of Forms - just have a look for it - the code is self documenting, but there is also a manual you can read too.
    Jason Pepper
    Principal Product Manager
    Enterprise Internet Tools
    Oracle Corp<HR></BLOCKQUOTE>
    null

  • Trouble getting IP address from DHCP-enabled router

    I've recently set up a LinkSys WRT54G wired/wireless router on a home network that has a wired Windows XP machine and a wireless PowerBook with AirPort.
    The WRT54G assigns network addresses using DHCP. The PowerBook is able to find the wireless network established by the WRT54G, but doesn't get an IP address from it.
    The router seems to be behaving correctly, so I'm guessing there's a problem in the PowerBook setup somewhere. Any ideas?

    Double-check your AirPort's settings:
    System Preferences > Network > Show > Network Port Configurations
    - Verify that an AirPort option exists. If it does not, click "New" to create one. (Note: If you are unable to create an AirPort configuration, the AirPort card in your computer either doesn't exist or it is not recognized.)
    - Verify that AirPort is "On" (checked)
    - Verify that AirPort is at the top of the list. If it isn't, you can drag it to the top.
    Systems Preferences > Network > Show > AirPort
    AirPort tab
    - By default, join: Automatic
    TCP/IP tab
    - Configure IPv4: Using DHCP
    - Configure IPv6: Automatically or Off
    Proxies tab
    - Configure Proxies: Manually
    - Select a proxy server to configure: <All proxies should be unchecked unless you specifically require a proxy for Internet access.>
    - Exclude simple hostnames (unchecked)
    - Bypass proxy settings for these Hosts & Domains: <leave blank>
    - Use Passive FTP Mode (PASV) (checked)

  • How to get Plant address from SAP R/3 to SRM

    Hi Gurus,
    We need to retrieve the plant address from SAP R/3 to SRM and display it in the output list of the report (SRM).
    Suggest any standard FM or should we need to create a Custom Remote enabled FM and put the select query to get the address.
    Regards
    Paul

    Hi Paul,
    Try using the RFC_READ_TABLE function module...
    Pass the table name as t001w which contains the plant details.
    Hope this helps.
    Thanks,
    Pradeep

  • How to get GPIB address from VISA resource

    Hi All,
    Is there a way (CVI API) to get the GPIB address of a GPIB instrument from an alias or a VISA resource name defined in MAX?
    Thanks,
    Rick.

    Thanks mkossmann, I was actually looking for an api that would get the gpib address from the visa resource name defined in MAX which has already scanned in the gpib instruments.
    I guess it may not be good that way even if there's such an api because instrument gpib address might get changed and if MAX has not been asked to rescan then the address will be out of sync.

  • How can i get my addresses from my old windows laptop (Microsoft outlook) on my iphone?

    hi, i would like to learn how i can get my address file from my old windows laptop (microsoft outlook) on my new iphone? who can help?

    It should be possible with microsoft exchange but I do not know how... (sorry no Outlook expert)

  • How get email address from received email?

    In the old days, like 6 months ago, I could depend on being able to salvage an intended recipient's email address from a note they sent to me. Just click on the name in a received email, then open a "new" email under that address, bang out the message, and send it. Not any more. How do I do it? This seems like a really stupid change. Why does it require complication?

    There are several ways. First is to double click the message and the message should appear on-screen with the complete address. Next is you will see a small down arrow like in my example below, click it and you will get the info you need.

  • Wireless Router 877W users cannot get ip address from DHCP

    Users can connect to wireless but they cant get ip address what can be the problem ?
    Thanks
    no aaa new-model
    resource policy
    ip subnet-zero
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 192.168.239.1 192.168.239.50
    ip dhcp pool users
       network 192.168.239.0 255.255.255.0
       default-router 192.168.239.1
       dns-server 4.2.2.2
    bridge irb
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    interface ATM0.1 point-to-point
    no snmp trap link-status
    pvc 8/35
      pppoe-client dial-pool-number 1
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface Dot11Radio0
    no ip address
    encryption vlan 1 key 1 size 40bit 0 1234567890 transmit-key
    encryption vlan 1 mode wep mandatory
    ssid wirele
        vlan 1
        authentication open
        guest-mode
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    channel 2437
    station-role root
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no snmp trap link-status
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 192.168.239.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    bridge-group 1
    bridge-group 1 spanning-disabled
    interface Dialer1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username xxxx password xxx
    crypto map MerkezVPN
    interface Dialer0
    no ip address
    interface BVI1
    no ip address
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1

    go into config t and add "bridge 1 route ip" and see what you get....

Maybe you are looking for

  • How to set a common page for all users after loging on?

    hi all, Now "My Dashboard" is the default page after logon. i want to set a default home page for all users. users can see the home page after loging on. how to change the default dashboard from "My Dashboard" to "Home page" for all users? thanks, da

  • Pearl 8100 Battery Issues

    My BB Pearl 8100 is always losing battery charge.  Anybody else having this issue and how can I fix it?  I charge my BB at least 3 times a day.  Once in the morning plugged into the outlet, once during the day at work through a USB port on my compute

  • Calendar view on page for Published site.

    I have a subsite, and I create a calendar for meetings, on a new page I added a web part to show the calendar (calendar view). when I logged on the site, each event has their one link to details, (disform.aspx?id= something)  but as soon I publish th

  • Positioning ALV Grid displayed via FM REUSE_ALV_GRID_DISPLAY

    Hi, i'm displaying an ALV List via FM REUSE_ALV_GRID_DISPLAY, the user can edit and change values. But after refreshing the table the user losses his scroll position, the refreshed list starts always at line 1. How can i scroll down to the users last

  • French language messages.

    My forms created with Designer 7.0 are working fine. My users are using Reader 7 and 8. My problem is some of the users are French and are of course receiving the standard Acrobat messages: "Data typed into this form will not be saved..." etc. I have