Getting the ACE's of an ACL

Hi,
Is there a way using the iFS Java API, to get the set of ACE (AccessControlEntry) objects associated with an ACL (AccessControlList) object?
I'm trying to write code that allows one to edit an ACL, similar to what Oracle iFS Entreprise Manager allows doing.
Thanks,
Ilan

Here's a sample :
AccessControlList myAcl = createAcl("NewAcl");
// add ACEs here
AccessControlEntry[] aces = myAcl.getAccessControlEntrys();
int i;
for (i=0;i<aces.length;i++){
DirectoryUser du = (DirectoryUser) aces.getGrantee();
System.err.println("Directory User "+ du.getName());
Hope this helps,
Bob

Similar Messages

  • ACE30 - Accessing the ACE Applicance Device Manager

    Hi...
    I've got basic connectivty to our ACE30 module and when I try connecting to the management IP address (attached to the Admin context), I see a very basic GUI which only lists the CSM to ACE config conversion tool.  I don't see a GUI as detailed in the document:
    http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA1_7_/configuration/device_manager/guide/UG_over.html#wp1072950
    How do I get the ACE Applicance Device Manager GUI working so that I can then configure real servers, serverfarms etc rather than via the GUI?
    Having read through copious amount of documentation I can't seem to find a refrence that would help here.  This should be a fairly straight forward exercise - do I need to install some other software to get the full fledged GUI working?
    thanks
    Sheldon

    Only the ACE 4710 appliances have the GUI.   If you are looking for a GUI for the ACE30 module you will need to use Cisco Application Network Manager (ANM)   It will provide the GUI for the ACE30 to be able to configure it.   As you have seen, only the conversion tool is available on the module.

  • A problem with ACL in the class-map on the ACE module

                      Hi all,
    I configured the following on the ACE module:
    object-group network test
      host 192.168.1.21
      host 192.168.1.22
      host 192.168.1.23
    object-group service port
      tcp eq www
      tcp eq 8080
    access-list T line 8 extended permit object-group port object-group test any
    I tried to configure a class-map for matching this ACL:
    ACE-4710-2/Lab-OPT-11(config)# class-map match-any TEST_C
    ACE-4710-2/Lab-OPT-11(config-cmap)# match access-list T
    Error: Cannot associate acl having object-group ACEs in class-map.
    So couldn't I  configure the class-map by using ACL with object-groups involved? Is it the bug or the normal behaviour? Because the customer uses object-groups in ACLs and he has to configure ACL without object-groups for the traffic classification. It is horrible.
    Thank you
    Roman

    Hi Roman,
    I'm afraid it's the expected behavior. You cannot use an ACL with object-groups inside a class-map.
    Regards
    Daniel

  • ACE applicationControl Engine Appliance (get the system message:%ACE-4-400000: IDS:1000)

    HI:
          It is work normally when have finish ACE config .But the ACE has show some error message:(May  5 2011 11:05:44 : %ACE-4-400000: IDS:1000 IP Option Bad Option List from 192.168.2.198 to 224.0.0.22 on interface vlan51 May  5 2011) recently,so the clients can not get respons form servers vip ip address 192.168.2.72;
         I have shutdown the IDS machine and this message still shows;
         How i do can resolve this problem and let clients get respons server vip normaly?
    ---------------------------The follow is my config on ACE!------------------------------
    logging enable
    logging timestamp
    logging history 5
    logging buffered 5
    peer hostname TJHQCB01DLB02
    hostname TJHQCB01DLB01
    boot system image:c6ace-t1k9-mz.A2_2_3.bin
    resource-class all
      limit-resource all minimum 5.00 maximum unlimited
      limit-resource sticky minimum 5.00 maximum unlimited
    clock timezone BJT 8 0
    context Admin
      member all
    access-list anyone line 8 extended permit ip any any
    access-list anyone line 16 extended permit icmp any any
    rserver host 115-116-s1
      ip address 192.168.2.115
      inservice
    rserver host 115-116-s2
      ip address 192.168.2.116
      inservice
    rserver host 204-205-s1
      ip address 192.168.2.204
      inservice
    rserver host 204-205-s2
      ip address 192.168.2.205
      inservice
    rserver host 68-69-s1
      ip address 192.168.2.68
      inservice
    rserver host 68-69-s2
      ip address 192.168.2.69
      inservice
    serverfarm host 115-116_pool
      rserver 115-116-s1
        inservice
      rserver 115-116-s2
        inservice
    serverfarm host 204-205_pool
      rserver 204-205-s1
        inservice
      rserver 204-205-s2
        inservice
    serverfarm host 68-69_pool
      rserver 68-69-s1
        inservice
      rserver 68-69-s2
        inservice
    class-map match-any 115-116-vip
      2 match virtual-address 192.168.2.117 any
    class-map match-any 204-205-vip
      2 match virtual-address 192.168.2.207 any
    class-map match-any 68-69-vip
    2 match virtual-address 192.168.2.72 any
    class-map type management match-any admin
      2 match protocol https any
      3 match protocol icmp any
      4 match protocol telnet any
      5 match protocol snmp any
      6 match protocol ssh any
      7 match protocol http any
    policy-map type management first-match admin
      class admin
        permit
    policy-map type loadbalance first-match 115-116-policy
      class class-default
        serverfarm 115-116_pool
    policy-map type loadbalance first-match 204-205-policy
      class class-default
        serverfarm 204-205_pool
    policy-map type loadbalance first-match 68-69-policy
      class class-default
        serverfarm 68-69_pool
    policy-map multi-match tiens-vip
      class 68-69-vip
        loadbalance vip inservice
        loadbalance policy 68-69-policy
        loadbalance vip icmp-reply active
        loadbalance vip advertise active
        nat dynamic 1 vlan 51
      class 204-205-vip
        loadbalance vip inservice
        loadbalance policy 204-205-policy
        loadbalance vip icmp-reply active
        loadbalance vip advertise active
        nat dynamic 1 vlan 51
      class 115-116-vip
        loadbalance vip inservice
        loadbalance policy 115-116-policy
        loadbalance vip icmp-reply active
        loadbalance vip advertise active
        nat dynamic 1 vlan 51
    service-policy input admin
    service-policy input tiens-vip
    interface vlan 51
      ip address 192.168.2.250 255.255.255.0
      alias 192.168.2.253 255.255.255.0
      peer ip address 192.168.2.251 255.255.255.0
      access-group input anyone
      access-group output anyone
      nat-pool 1 192.168.2.252 192.168.2.252 netmask 255.255.255.255 pat
      no shutdown
    ft interface vlan 999
      ip address 10.1.69.125 255.255.255.252
      peer ip address 10.1.69.126 255.255.255.252
      no shutdown
    ft peer 1
      heartbeat interval 300
      heartbeat count 10
      ft-interface vlan 999
    ft group 2
      peer 1
      priority 110
      associate-context Admin
      inservice
    ip route 0.0.0.0 0.0.0.0 192.168.2.254

    hi:
        everyone ,the up of config have changed.i have update the config about ACE,and about the ids:1000 still shows on it;
      the fllow is my ace config:
    logging enable
    logging standby
    logging timestamp
    logging history 5
    logging buffered 5
    peer hostname TJHQCB01DLB02
    hostname TJHQCB01DLB01
    boot system image:c6ace-t1k9-mz.A2_2_3.bin
    resource-class all
      limit-resource all minimum 5.00 maximum unlimited
      limit-resource sticky minimum 5.00 maximum unlimited
    clock timezone BJT 8 0
    context Admin
      member all
    access-list anyone line 8 extended permit ip any any
    access-list anyone line 16 extended permit icmp any any
    probe tcp 68-69_pool-tcp-http
      interval 2
      faildetect 2
      passdetect interval 5
      passdetect count 2
    rserver host 115-116-s1
      ip address 192.168.2.115
      inservice
    rserver host 115-116-s2
      ip address 192.168.2.116
      inservice
    rserver host 204-205-s1
      ip address 192.168.2.204
      inservice
    rserver host 204-205-s2
      ip address 192.168.2.205
      inservice
    rserver host 68-69-s1
      ip address 192.168.2.68
      inservice
    rserver host 68-69-s2
      ip address 192.168.2.69
      inservice
    serverfarm host 115-116_pool
      rserver 115-116-s1
        inservice
      rserver 115-116-s2
        inservice
    serverfarm host 204-205_pool
      rserver 204-205-s1
        inservice
      rserver 204-205-s2
        inservice
    serverfarm host 68-69_pool
      probe 68-69_pool-tcp-http
      rserver 68-69-s1
        inservice
      rserver 68-69-s2
        inservice
    sticky ip-netmask 255.255.255.255 address source 68-69_pool
      timeout 720
      timeout activeconns
      replicate sticky
      serverfarm 68-69_pool
    class-map match-any 115-116-vip
      2 match virtual-address 192.168.2.117 any
    class-map match-any 204-205-vip
      2 match virtual-address 192.168.2.207 any
    class-map match-any 68-69-vip
      2 match virtual-address 192.168.2.72 any
    class-map type management match-any admin
      2 match protocol https any
      3 match protocol icmp any
      4 match protocol telnet any
      5 match protocol snmp any
      6 match protocol ssh any
      7 match protocol http any
    policy-map type management first-match admin
      class admin
        permit
    policy-map type loadbalance first-match 115-116-policy
      class class-default
        serverfarm 115-116_pool
    policy-map type loadbalance first-match 204-205-policy
      class class-default
        serverfarm 204-205_pool
    policy-map type loadbalance first-match 68-69-policy
      class class-default
        sticky-serverfarm 68-69_pool
    policy-map multi-match tiens-vip
      class 68-69-vip
        loadbalance vip inservice
        loadbalance policy 68-69-policy
        loadbalance vip icmp-reply active
        loadbalance vip advertise active
        nat dynamic 1 vlan 51
      class 204-205-vip
        loadbalance vip inservice
        loadbalance policy 204-205-policy
        loadbalance vip icmp-reply active
        loadbalance vip advertise active
        nat dynamic 1 vlan 51
      class 115-116-vip
        loadbalance vip inservice
        loadbalance policy 115-116-policy
        loadbalance vip icmp-reply active
        loadbalance vip advertise active
        nat dynamic 1 vlan 51
    service-policy input admin
    service-policy input tiens-vip
    interface vlan 51
      ip address 192.168.2.250 255.255.255.0
      alias 192.168.2.253 255.255.255.0
      peer ip address 192.168.2.251 255.255.255.0
      access-group input anyone
      access-group output anyone
      nat-pool 1 192.168.2.252 192.168.2.252 netmask 255.255.255.255 pat
      no shutdown
    ft interface vlan 999
      ip address 10.1.69.125 255.255.255.252
      peer ip address 10.1.69.126 255.255.255.252
      no shutdown
    ft peer 1
      heartbeat interval 300
      heartbeat count 10
      ft-interface vlan 999
    ft group 2
      peer 1
      priority 110
      associate-context Admin
      inservice
    ip route 0.0.0.0 0.0.0.0 192.168.2.254
    username admin password 5 $1$faXJEFBj$TJR1Nx7sLPTi5BZ97v08c/  role Admin domain default-domain
    username www password 5 *  role Admin domain default-domain

  • A few questions on the ACE

    I am getting up to speed on the ACE and was wondering if someone could please clarify a couple of things for me as the docs I am using are pretty confusing.
    We have the ACE module in a Cisco 65XX switch, along with FWSM.
    1) Do I need to create a Layer 3 int on the switch for the Vlan's that I have assigned to the ACE?
    2) I have created a Layer 3 Client side and a Server side Vlans on the ACE. Do I need to create a default gateway for each of these Vlan's or create just one DG and point it to the switch?
    3)Do I need to create a class map, a policy map and a service policy for the Client and Server Vlan L3 interfaces on the ACE?
    Thanks much.

    Have you had a chance to read through the config guide?
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/v3.00_A2/configuration/rtg_brdg/guide/rtbrgdgd.html
    In general,
    1) yes for client-side vlans
    no for server-side vlans
    2) just one default route to an SVI on MSFC
    3) yes

  • I am getting the following error when i am trying to check in new created content profile

    Hi All,
    I am getting the following error when i am trying to check in new created content profile as:
    An error has occurred. The stack trace below shows more information.
    !csUserEventMessage,weblogic,localhost:16200!$!csServiceDataException,CHECKIN_NEW_SUB,validateStandard!$!syParameterNotFound,dDocTitle
    intradoc.common.ServiceException: !csServiceDataException,CHECKIN_NEW_SUB,validateStandard!$
    *ScriptStack CHECKIN_NEW_SUB
    3:doScriptableAction,**no captured values**3:doSubService,**no captured values**CHECKIN_NEW_SUB,**no captured values**3:validateStandard,dDocName=myucm-005202
      at intradoc.server.ServiceRequestImplementor.buildServiceException(ServiceRequestImplementor.java:2115)
      at intradoc.server.Service.buildServiceException(Service.java:2260)
      at intradoc.server.Service.createServiceExceptionEx(Service.java:2254)
      at intradoc.server.Service.createServiceException(Service.java:2249)
      at intradoc.server.ServiceRequestImplementor.handleActionException(ServiceRequestImplementor.java:1766)
      at intradoc.server.ServiceRequestImplementor.doAction(ServiceRequestImplementor.java:1716)
      at intradoc.server.Service.doAction(Service.java:477)
      at intradoc.server.ServiceRequestImplementor.doActions(ServiceRequestImplementor.java:1458)
      at intradoc.server.Service.doActions(Service.java:472)
      at intradoc.server.ServiceRequestImplementor.executeSubServiceCode(ServiceRequestImplementor.java:1322)
      at intradoc.server.Service.executeSubServiceCode(Service.java:3866)
      at intradoc.server.ServiceRequestImplementor.executeServiceEx(ServiceRequestImplementor.java:1200)
      at intradoc.server.Service.executeServiceEx(Service.java:3861)
      at intradoc.server.Service.executeService(Service.java:3845)
      at intradoc.server.Service.doSubService(Service.java:3760)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at intradoc.common.IdcMethodHolder.invokeMethod(IdcMethodHolder.java:86)
      at intradoc.common.ClassHelperUtils.executeMethodEx(ClassHelperUtils.java:310)
      at intradoc.common.ClassHelperUtils.executeMethod(ClassHelperUtils.java:295)
      at intradoc.server.Service.doCodeEx(Service.java:550)
      at intradoc.server.Service.doCode(Service.java:505)
      at intradoc.server.ServiceRequestImplementor.doAction(ServiceRequestImplementor.java:1643)
      at intradoc.server.Service.doAction(Service.java:477)
      at intradoc.server.Service.doScriptableAction(Service.java:3807)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at intradoc.common.IdcMethodHolder.invokeMethod(IdcMethodHolder.java:86)
      at intradoc.common.ClassHelperUtils.executeMethodEx(ClassHelperUtils.java:310)
      at intradoc.common.ClassHelperUtils.executeMethod(ClassHelperUtils.java:295)
      at intradoc.server.Service.doCodeEx(Service.java:550)
      at intradoc.server.Service.doCode(Service.java:505)
      at intradoc.server.ServiceRequestImplementor.doAction(ServiceRequestImplementor.java:1643)
      at intradoc.server.Service.doAction(Service.java:477)
      at intradoc.server.ServiceRequestImplementor.doActions(ServiceRequestImplementor.java:1458)
      at intradoc.server.Service.doActions(Service.java:472)
      at intradoc.server.ServiceRequestImplementor.executeActions(ServiceRequestImplementor.java:1391)
      at intradoc.server.Service.executeActions(Service.java:458)
      at intradoc.server.ServiceRequestImplementor.doRequest(ServiceRequestImplementor.java:737)
      at intradoc.server.Service.doRequest(Service.java:1890)
      at intradoc.server.ServiceManager.processCommand(ServiceManager.java:435)
      at intradoc.server.IdcServerThread.processRequest(IdcServerThread.java:265)
      at intradoc.idcwls.IdcServletRequestUtils.doRequest(IdcServletRequestUtils.java:1343)
      at intradoc.idcwls.IdcServletRequestUtils.processFilterEvent(IdcServletRequestUtils.java:1715)
      at intradoc.idcwls.IdcIntegrateWrapper.processFilterEvent(IdcIntegrateWrapper.java:222)
      at sun.reflect.GeneratedMethodAccessor133.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at idcservlet.common.IdcMethodHolder.invokeMethod(IdcMethodHolder.java:87)
      at idcservlet.common.ClassHelperUtils.executeMethodEx(ClassHelperUtils.java:305)
      at idcservlet.common.ClassHelperUtils.executeMethodWithArgs(ClassHelperUtils.java:278)
      at idcservlet.ServletUtils.executeContentServerIntegrateMethodOnConfig(ServletUtils.java:1600)
      at idcservlet.IdcFilter.doFilter(IdcFilter.java:352)
      at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
      at oracle.security.jps.ee.http.JpsAbsFilter$1.run(JpsAbsFilter.java:111)
      at java.security.AccessController.doPrivileged(Native Method)
      at oracle.security.jps.util.JpsSubject.doAsPrivileged(JpsSubject.java:313)
      at oracle.security.jps.ee.util.JpsPlatformUtil.runJaasMode(JpsPlatformUtil.java:413)
      at oracle.security.jps.ee.http.JpsAbsFilter.runJaasMode(JpsAbsFilter.java:94)
      at oracle.security.jps.ee.http.JpsAbsFilter.doFilter(JpsAbsFilter.java:161)
      at oracle.security.jps.ee.http.JpsFilter.doFilter(JpsFilter.java:71)
      at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
      at oracle.dms.servlet.DMSServletFilter.doFilter(DMSServletFilter.java:136)
      at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
      at oracle.security.jps.ee.http.JpsAbsFilter$1.run(JpsAbsFilter.java:111)
      at java.security.AccessController.doPrivileged(Native Method)
      at oracle.security.jps.util.JpsSubject.doAsPrivileged(JpsSubject.java:313)
      at oracle.security.jps.ee.util.JpsPlatformUtil.runJaasMode(JpsPlatformUtil.java:413)
      at oracle.security.jps.ee.http.JpsAbsFilter.runJaasMode(JpsAbsFilter.java:94)
      at oracle.security.jps.ee.http.JpsAbsFilter.doFilter(JpsAbsFilter.java:161)
      at oracle.security.jps.ee.http.JpsFilter.doFilter(JpsFilter.java:71)
      at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
      at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(WebAppServletContext.java:3715)
      at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3681)
      at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
      at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)
      at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2277)
      at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2183)
      at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1454)
      at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
      at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)
    Caused by: intradoc.data.DataException: !syParameterNotFound,dDocTitle
      at intradoc.data.DataBinder.getEx(DataBinder.java:1251)
      at intradoc.data.DataBinder.get(DataBinder.java:1050)
      at intradoc.server.DocServiceHandler.validateStandard(DocServiceHandler.java:1257)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at intradoc.common.IdcMethodHolder.invokeMethod(IdcMethodHolder.java:86)
      at intradoc.common.ClassHelperUtils.executeMethodReportStatus(ClassHelperUtils.java:324)
      at intradoc.server.ServiceHandler.executeAction(ServiceHandler.java:79)
      at intradoc.server.Service.doCodeEx(Service.java:533)
      at intradoc.server.Service.doCode(Service.java:505)
      at intradoc.server.ServiceRequestImplementor.doAction(ServiceRequestImplementor.java:1643)
      ... 79 more

    Your error states:
    !syParameterNotFound,dDocTitle
    Can you confirm that your profile includes all required data, specifically, the dDocTitle? Fix this issue, then re-check your logs. if there are other missing required parameters, fix each one.
    Eventually, you should have a successful check-in.
    Hope this helps,
    -ryan

  • Unable to get the file system information for: \\****servername\E$\; error = 64 Unable to distribute content to DP

    One of our DPs has stopped loading content. 
    I've research for quite a bit and cannot find a clear cut reason to this.  This server only has a DP role, I verified sharing permissions, all looked good. This DP has been running just fine for the last year or so and all sudden it will no longer load
    packages.  The disk drive is still present I can still reach the hidden share \\servername.com\E$
    Verified that the SMSSIG$ folder is there and the last entry is from 4/23/2015 
    SCCM 2012 R2 
    OS 2008 R2 Standard
    Any help is greatly appreciated!
    Here's a snipit from the distmgr.log
    Start updating the package on server ["Display=\\*****.com\"]MSWNET:["SMS_SITE=1AB"]\\*****.com\...
    Attempting to add or update a package on a distribution point.
    Will wait for 1 threads to end.
    Thread Handle = 0000000000001E48
    STATMSG: ID=2342 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_DISTRIBUTION_MANAGER" SYS=***.com SITE=1AB PID=2472 TID=8252 GMTDATE=Thu Apr 30 19:12:01.972 2015 ISTR0="SYSMGMT Source" ISTR1="["Display=\\*****.com\"]MSWNET:["SMS_SITE=1AB"]\\*****.com\"
    ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=2 AID0=400 AVAL0="CAS00087" AID1=404 AVAL1="["Display=\\*****.com\"]MSWNET:["SMS_SITE=1AB"]\\*****.com\"
    SMS_DISTRIBUTION_MANAGER 4/30/2015 2:12:01 PM
    8252 (0x203C)
    The current user context will be used for connecting to ["Display=\\*****.com\"]MSWNET:["SMS_SITE=1AB"]\\*****.com\.
    Successfully made a network connection to \\*****.com\ADMIN$.
    Ignoring drive \\*****.com\C$\.  File \\*****.com\C$\NO_SMS_ON_DRIVE.SMS exists.
    Unable to get the file system information for: \\*****.com\E$\; error = 64.
    Failed to find a valid drive on the distribution point ["Display=\\*****.com\"]MSWNET:["SMS_SITE=1AB"]\\*****.com\
    Cannot find or create the signature share.
    STATMSG: ID=2324 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_DISTRIBUTION_MANAGER" SYS=sccmprdpr1sec2.mmm.com SITE=1AB PID=2472 TID=8252 GMTDATE=Thu Apr 30 19:12:55.206 2015 ISTR0="["Display=\\*****.com\"]MSWNET:["SMS_SITE=1AB"]\\*****.com\"
    ISTR1="CAS00087" ISTR2="" ISTR3="30" ISTR4="94" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=2 AID0=400 AVAL0="CAS00087" AID1=404 AVAL1="["Display=\\*****.com\"]MSWNET:["SMS_SITE=1AB"]\\*****.com\"
    Error occurred. Performing error cleanup prior to returning.
    Cancelling network connection to \\*****.com\ADMIN$.

    Error 64 is being returned which is simply "the network name is no longer available".
    There can be a number of reasons for this from SMB compatibility issues (2003 servers wont support SMB2), to the expected and actual computer name of the boxes don't match (tries to authenticate with server.tld.com when the actual name is srv-01.tld.com and
    you just put a C-name in). I'd start from the top:  Try opening said share from the Primary Site server as that's the box doing the work.  Verify the IP and computer name is legit and that no one has played ACL games between the two systems (remember
    RPC only initiates/listens on port 135 but established connections are up in the dynamic port range).
    At the end of the day it's an issues "underneath" SCCM, and not an SCCM problem specifically. 

  • When I try to install itunes 10.5.2, I get the following error message "The installer has insufficient privileges to modify this file c\progamfiles\itunes\itunes.exe and won't install. help

    When I try to install itunes 10.5.2, I get the following error message "The installer has insufficient privileges to modify this file c\progamfiles\itunes\itunes.exe and won't install. help

    Okay ... so it's not one of the cases of bodged up ACLs on the Apple folder in Common Files. (That's been underlying a few of the recalcitrant E7W5s.
    Just in case, let's try the fixit from the following document:
    Fix problems with programs that can't be installed or uninstalled

  • XML..: Problem getting the data in the XML-file..

    I'm developing a flash-file for my customer to use when
    displaying list of products he's selling.
    His list of products is inside a XML-file and he want me to
    display an overview of the products inside a datagrid, so when you
    click on the product you're interested in the productinfo will be
    displayed.
    But.. I'm having problems grabbing the data I want as it
    seems to me that I have to use the unik ID's for each products to
    get the data I want. I've tried adding the unik ID-code to my
    action script but it still won't work.
    Here's a part of the XML-code:
    <Tooldata>
    <Store name="N/A" zipcode="0033450" city="N/A" url="N/A"
    phone="N/A" fax="N/A" email="N/A">
    <Tool unikID="5_0022" control="14" cmnd="update">
    <Toolgroupe>Hammer</Toolgroupe>
    <Brand>Knipps</Brand>
    <Model>K55_Knipps</Model>
    <Price>35€</Price>
    <Weight>N/A</Weight>
    <Soldout>0</Soldout>
    <Color>Red/Black</Color>
    <Images>
    <Images image="5_0022.jpg" prioritet="1" gen_id="16"
    desc="MainImage"/>
    <Images image="5_0022_1.jpg" prioritet="2" gen_id="16"
    desc="Image 1"/>
    <Images image="5_0022_2.jpg" prioritet="3" gen_id="16"
    desc="Image 2"/>
    <Images image="5_0022_3.jpg" prioritet="4" gen_id="16"
    desc="Image 3"/>
    </Images>
    Now, the code above is only one item/product. But there are
    several proucts listed in the XML-file and I find it hard to get
    the product and the product info that I want to be displayed.
    Here's my action script:
    var xmlLoader:URLLoader = new URLLoader();
    var xmlData:XML = new XML();
    xmlLoader.addEventListener(Event.COMPLETE, LoadXML);
    xmlLoader.load(new URLRequest("ToolData.xml"));
    function LoadXML(e:Event):void {
    xmlData = new XML(e.target.data);
    ParseBildata(xmlData);
    function ParseTooldata(TooldataInput:XML):void {
    trace("XML Output");
    trace("------------------------");
    trace(TooldataInput.Store);
    If I want to trace the images I just write
    "trace(TooldataInput.Store.Images);
    But if I want to trace one unik tool it's impossible. Well,
    maybe not impossible.. I just don't know how to do just that.
    When you trace (TooldataInput.Store); you get all the tools
    at that store. But how do I trace only one tool using the unikID??
    Thanks a lot in advance!

    Ace,
    When using E4X if you have multiple nodes at the same level
    you should be able to access them as an XMLList. Looking at your
    XML you should be able to access each <Tool> node as:
    TooldataInput.Store.Tool[0];
    TooldataInput.Store.Tool[1];
    or as an entire list
    TooldataInput.Store.children()
    WL

  • Issue while getting the Hibernate EntityManagerFactory in Weblogic (EJB3)

    I am facing an issue when am getting the EntityManagerFactory from JPA from the following code in weblogic StartUp Class
    EntityManagerFactory emf =
    Persistence.createEntityManagerFactory("testEJBPU");
    logger.info("Created EntityManagerFactory");
    Context ctx = new InitialContext();
    ctx.rebind("testEJBPU", emf);
    The above code is only returning the OPenJPA EntityManagerFactory instead of the Hibernate's I have the following in my Presistence.xml file
    <?xml version="1.0" encoding="UTF-8"?>
    <!--
    Copyright (c) 2006 Illuminatics, Inc.
    All rights reserved.
    -->
    <persistence xmlns="http://java.sun.com/xml/ns/persistence"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd"
    version="1.0">
    <persistence-unit name="testEJBPU" transaction-type="JTA">
    <provider>org.hibernate.ejb.HibernatePersistence</provider>
    <jta-data-source>jdbc/evolvDS</jta-data-source>
    <properties>
    <property name="hibernate.ejb.cfgfile"
    value="META-INF/hibernate.cfg.xml"/>
    <property name="hibernate.transaction.factory_class"
    value="org.hibernate.ejb.transaction.JoinableCMTTransactionFactory"/>
    <property name="hibernate.transaction.manager_lookup_class"
    value="org.hibernate.transaction.WeblogicTransactionManagerLookup"/>
    <property name="hibernate.cache.provider_class"
    value="org.hibernate.cache.EhCacheProvider"/>
    <property name="hibernate.cache.jndi"
    value="evolv-cache"/>
    </properties>
    </persistence-unit>
    </persistence>
    and am getting the following error which is related to openJPA when application starts up
    <Apr 14, 2009 9:48:18 AM PKT> <Critical> <WebLogicServer> <BEA-000286> <Failed to invoke startup class "binder", <1.0.0 fatal user error> org.apache.openjpa.util.UserException: A JDBC Driver or DataSource class name must be specified in the ConnectionDriverName property.
    <1.0.0 fatal user error> org.apache.openjpa.util.UserException: A JDBC Driver or DataSource class name must be specified in the ConnectionDriverName property.
    at org.apache.openjpa.jdbc.schema.DataSourceFactory.newDataSource(DataSourceFactory.java:70)
    at org.apache.openjpa.jdbc.conf.JDBCConfigurationImpl.createConnectionFactory(JDBCConfigurationImpl.java:802)
    at org.apache.openjpa.jdbc.conf.JDBCConfigurationImpl.getDBDictionaryInstance(JDBCConfigurationImpl.java:568)
    at org.apache.openjpa.jdbc.meta.MappingRepository.endConfiguration(MappingRepository.java:1185)
    at org.apache.openjpa.lib.conf.Configurations.configureInstance(Configurations.java:450)
    at org.apache.openjpa.lib.conf.Configurations.configureInstance(Configurations.java:375)
    at org.apache.openjpa.lib.conf.PluginValue.instantiate(PluginValue.java:102)
    at kodo.conf.CachingMetaDataRepositoryPlugin.instantiate(CachingMetaDataRepositoryPlugin.java:29)
    at org.apache.openjpa.lib.conf.ObjectValue.instantiate(ObjectValue.java:79)
    at org.apache.openjpa.conf.OpenJPAConfigurationImpl.newMetaDataRepositoryInstance(OpenJPAConfigurationImpl.java:833)
    at org.apache.openjpa.conf.OpenJPAConfigurationImpl.getMetaDataRepositoryInstance(OpenJPAConfigurationImpl.java:828)
    at org.apache.openjpa.kernel.AbstractBrokerFactory.makeReadOnly(AbstractBrokerFactory.java:539)
    at org.apache.openjpa.kernel.AbstractBrokerFactory.readResolve(AbstractBrokerFactory.java:381)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at java.io.ObjectStreamClass.invokeReadResolve(ObjectStreamClass.java:1033)
    at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1728)
    at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1305)
    at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1908)
    at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1832)
    at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1719)
    at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1305)
    at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1908)
    at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1832)
    at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1719)
    at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1305)
    at java.io.ObjectInputStream.readObject(ObjectInputStream.java:348)
    at weblogic.rmi.extensions.server.CBVInputStream.readObjectInternal(CBVInputStream.java:71)
    at weblogic.rmi.extensions.server.CBVInputStream.readObject(CBVInputStream.java:65)
    at weblogic.jndi.internal.JNDIHelper.copyObject(JNDIHelper.java:36)
    at weblogic.jndi.internal.WLEventContextImpl.copyObject(WLEventContextImpl.java:379)
    at weblogic.jndi.internal.WLEventContextImpl.rebind(WLEventContextImpl.java:114)
    at javax.naming.InitialContext.rebind(InitialContext.java:367)
    at com.illuminatics.test.weblogic.EntityManagerFactoryBinder.main(EntityManagerFactoryBinder.java:52)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeMain(ClassDeploymentManager.java:353)
    at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClass(ClassDeploymentManager.java:263)
    at weblogic.management.deploy.classdeployment.ClassDeploymentManager.access$000(ClassDeploymentManager.java:54)
    at weblogic.management.deploy.classdeployment.ClassDeploymentManager$1.run(ClassDeploymentManager.java:205)
    at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
    at weblogic.security.service.SecurityManager.runAs(Unknown Source)
    at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClassDeployment(ClassDeploymentManager.java:198)
    at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClassDeployments(ClassDeploymentManager.java:177)
    at weblogic.management.deploy.classdeployment.ClassDeploymentManager.runStartupsAfterAppActivation(ClassDeploymentManager.java:158)
    at weblogic.management.deploy.classdeployment.StartupClassPrelistenService.start(StartupClassPrelistenService.java:13)
    at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
    at weblogic.work.ExecuteThread.execute(ExecuteThread.java:200)
    at weblogic.work.ExecuteThread.run(ExecuteThread.java:172)
    >
    My EAR Structure is as:
    testEJBProject.ear
    -->lib/
    -->META-INF/
    ----->application.xml
    ----->MANIFEST.MF
    -->testEJB.jar
    ----->META-INF/
    --------->hibernate.cfg.xml
    --------->INDEX.LST
    --------->MANIFEST>MF
    --------->persistence.xml
    ----->com/../..*
    Kindly Let me know its solution if anyone has encountered it before!.

    Hi,
    It doesn't look like your persistence.xml file is being found so Kodo (the current default JPA provider in WLS) is being used (and it's complaining because it doesn't see a datasource configured or any necessary properties for Kodo to setup its own connection pool).
    In order for your persistence.xml to be found it must be visible to the context ClassLoader on the Thread when the Persistence.createEntityManagerFactory call is made. Is your startup class configured at the server level or is it configured in your application (via a weblogic-application.xml file)?
    I don't think a server startup class would work in this case but an application startup class should.
    - Matt

  • In oracle Httpuritype - Not getting the output correctly

    Hi, I am trying out httpuritype in oracle for the first time. My requirement is to get the input string and the from_language and to_language and has to be converted accordingly.
    I am using oracle 11.2.0.1.
    So had setup acl explicitly and started writing the below program.
    create or replace procedure trans_new_prc1
    (p_words in varchar2, -- words to be translated
    p_to in varchar2 , -- language to translate to
    p_from in varchar2 ) -- language to translate from
    is
    l_res varchar2(2000);
    l_words varchar2(2000);
    txt varchar2(2000);
    begin
    txt:=utl_url.escape(l_words);
    l_words:=regexp_substr(httpuritype('http://translate.google.co.in/?hl=en&tab=wT#'||p_from||'/'||p_to|| txt).getclob(),'"(.*?)"',1,1,null,1);
    Dbms_output.put_line( l_words);
    end;
    While converting from polish language to english language I get the output as
    SQL> exec trans_new_prc1('hen','pl','en');
    text/html; charset=ISO-8859-2
    But i need the exact string in polish language, which i am not getting. Please guide me.
    Even while converting it into chinese language, i get the following message
    SQL> exec trans_new_prc1('hen','zh-CN','en');
    text/html; charset=ISO-8859-2
    Please guide me to get the output exactly in chinese language.

    I think the problem is, google translate is not giving that info with this URL ! I removed REGEXP_SUBSTR and get all html code from HTTPURITYPE, in returned code, there is no translated word info!
    for the code
      exec trans_new_prc1('hen','ENGLISH','AUTO');result is:
    <!DOCTYPE html><html><head><meta content="text/html; charset=ISO-8859-1" http-equiv="content-type"><meta name=keywords content="translate, translations, translation, translator, machine translation, online translation"><meta name=description content="Google's free online language translation service instantly translates text and web pages. This translator supports: English, Afrikaans, Albanian, Arabic, Armenian, Azerbaijani, Basque, Belarusian, Bengali, Bulgarian, Catalan, Chinese, Croatian, Czech, Danish, Dutch, Esperanto, Estonian, Filipino, Finnish, French, Galician, Georgian, German, Greek, Gujarati, Haitian Creole, Hebrew, Hindi, Hungarian, Icelandic, Indonesian, Irish, Italian, Japanese, Kannada, Korean, Latin, Latvian, Lithuanian, Macedonian, Malay, Maltese, Norwegian, Persian, Polish, Portuguese, Romanian, Russian, Serbian, Slovak, Slovenian, Spanish, Swahili, Swedish, Tamil, Telugu, Thai, Turkish, Ukrainian, Urdu, Vietnamese, Welsh, Yiddish"><meta name=robots content=noodp><meta name=google content=notranslate><link rel="canonical" href="http://translate.google.com/"><title>Google Translate</title><link rel="search" type="application/opensearchdescription+xml" href="/opensearch.xml?hl=en" title="Google Translate"><script>function _gtErr(e){var i=new Image();i.src='/gen204?jserr='+encodeURIComponent(e+": "+e.stack).substr(0,2000);i.onload=function(){i.onload=null;};}window.onerror=_gtErr;</script><script>(function(){var ti_a=function(b){this.t={};this.tick=function(b,c,a){a=void 0!=a?a:(new Date).getTime();this.t=[a,c]};this.tick("start",null,b)},ti_b=new ti_a;window.jstiming={Timer:ti_a,load:ti_b};if(window.performance&&window.performance.timing){var ti_c=window.performance.timing,ti_d=window.jstiming.load,ti_e=ti_c.navigationStart,ti_f=ti_c.responseStart;0<ti_e&&ti_f>=ti_e&&(ti_d.tick("_wtsrt",void 0,ti_e),ti_d.tick("wtsrt_","_wtsrt",ti_f))}
    there is no "THEM" (translated word) in it.  (I couldnt write whole returned info because exceed post limits.)                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

  • Where could I get the Adobe Reader Mobile 9 SDK?

    I am develop a windows mobile 6.5 application and want to do some tests on viewing PDF file with the mobile.
    http://www.adobe.com/devnet/readermobile/
    I followed as above instruction to mail to [email protected] several times but returned with Mail Failure each time.
    Then where could I get the Adobe Reader Mobile 9 SDK, please? Thanks.
    Besk Regards

    You sure?
    http://www.adobe.com/devnet/readermobile/
    According to the text of that link, the Reader 9 Mobile SDK supersedes the 2.5 SDK. The same page has a link ot a request form, which I guess could get the ball rolling for a proper conversation on the SDK and whether Reader 9 Mobile would work for you.
    I just reread your message - obviously you tried there already. I'll have a dig about see if I can rustle up some extra info for you.
    HTH.
    Steve
    Message was edited by: Steve Howard * ACE *

  • Urgent pls : sftp proxy service failing to get the file

    Hi All ,
    I have a proxy service polling for a file . I have setup the service on test environment , where it works fine . When i deploy the same code with only change is the Managed server target for polling , as the production server is clustered .
    I get the following error in the domain log :
    ####<21-03-2013 18:08:59 CET> <Error> <SFTPTransport> <xxxx> <xxxxx> <[ACTIVE] ExecuteThread: '21' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <BEA1-68CA827ADB4536852D4A> <11d1def534ea1be0:-5e793040:13ccb101998:-8000-00000000007dc42f> <1363885739466> <BEA-381803> <Unable to get file : /HOME/xxxxxx_00359.zip__2412735349618735005--5e793040.13d8cdd6ccb.7a58.stage on attempt number : 0 :
    java.io.FileNotFoundException: /xxxx/xxxx/xxxx/ftp_files/download/xxxxxxx00359.zip (No such file or directory)
         at java.io.FileOutputStream.open(Native Method)
         at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
         at java.io.FileOutputStream.<init>(FileOutputStream.java:70)
         at com.bea.wli.sb.transports.sftp.client.SFTPClient.get(SFTPClient.java:389)
         at com.bea.wli.sb.transports.sftp.connector.SFTPResource.get(SFTPResource.java:112)
         at com.bea.wli.sb.transports.sftp.connector.SFTPPublishedTask.processFileDownload(SFTPPublishedTask.java:206)
         at com.bea.wli.sb.transports.sftp.connector.SFTPPublishedTask.process(SFTPPublishedTask.java:169)
         at com.bea.wli.sb.transports.poller.listener.PolledMessageListenerMDB.__onMessage(PolledMessageListenerMDB.java:52)
         at com.bea.wli.sb.transports.poller.listener.PolledMessageListenerMDB.access$000(PolledMessageListenerMDB.java:31)
         at com.bea.wli.sb.transports.poller.listener.PolledMessageListenerMDB$1.run(PolledMessageListenerMDB.java:41)
         at com.bea.wli.sb.transports.poller.listener.PolledMessageListenerMDB$1.run(PolledMessageListenerMDB.java:39)
         at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
         at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)
         at weblogic.security.Security.runAs(Security.java:41)
         at com.bea.wli.sb.transports.poller.listener.PolledMessageListenerMDB.onMessage(PolledMessageListenerMDB.java:39)
         at weblogic.ejb.container.internal.MDListener.execute(MDListener.java:574)
         at weblogic.ejb.container.internal.MDListener.transactionalOnMessage(MDListener.java:477)
         at weblogic.ejb.container.internal.MDListener.onMessage(MDListener.java:379)
         at weblogic.jms.client.JMSSession.onMessage(JMSSession.java:4659)
         at weblogic.jms.client.JMSSession.execute(JMSSession.java:4345)
         at weblogic.jms.client.JMSSession.executeMessage(JMSSession.java:3821)
         at weblogic.jms.client.JMSSession.access$000(JMSSession.java:115)
         at weblogic.jms.client.JMSSession$UseForRunnable.run(JMSSession.java:5170)
         at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
         at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
    Note : I am able to manually sftp the file from and to my osb server . I am initiating the sftp session from osb server.
    Any help on this in urgent basis is a lot of help . Thank you in advance.
    Edited by: Harry1234 on 2013-03-22 03:46

    Nop... The poller gets the file, but then publishes in a distributed queue, which means that any managed server can process it. Therefore, they need acesss to a shared file system.
    http://docs.oracle.com/cd/E14571_01/doc.1111/e15022/config.htm#OSBDG176
    Section 4.1:
    "Oracle Service Bus load balances File, Email, and FTP transport processing across the managed servers in a cluster. All managed servers in the cluster should be able to access the Archive, Stage, and Error directories specified in any File, Email, or FTP proxy service configuration. These directories should be configured in a shared file system such as NFS. By using a shared file system, users and programs can access files on remote systems almost as if they were local files."
    Regards,
    Fabio Douek

  • I can't use Photobooth - when I open the app, I get the message: "Photo Booth couldn't save your photos - Photo Both encountered an error when trying to save your photos. You photos cannot be saved at this time."

    I can't use Photobooth - when I open the app, I get the message: "Photo Booth couldn't save your photos - Photo Both encountered an error when trying to save your photos. You photos cannot be saved at this time."
    i tried adding user macintosh hd/users/your_user/pictures/"photo booth"  but still photo booth is not working and even images in photo booth cant be deleted they keep coming back

    Back up all data.
    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.
    I've tested these instructions only with the Safari web browser. If you use another browser, they may not work as described.
    Step 1
    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. To do that, unlock the preference pane using the credentials of an administrator, check the box markedAllow user to administer this computer, then reboot. You can demote the problem account back to standard status when this step has been completed.
    Triple-click anywhere in the following line on this page to select it:
    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:staff ~ $_ ; sudo chmod -R u+rwX ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null
    Copy the selected text to the Clipboard by pressing the key combination command-C.
    Launch the Terminal application in any of the following ways:
    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)
    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.
    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.
    Paste into the Terminal window (command-V). I've tested these instructions only with the Safari web browser. If you use  another browser, you may have to press the return key after pasting.
    You'll be prompted for your login password. Nothing will be displayed when you type it. You may get a one-time warning to be careful. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.
    The command may take a few minutes to run, or perhaps longer if you have literally millions of files in your home folder. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.
    Step 2 (optional)
    Take this step only if you have trouble with Step 1 or if it doesn't solve the problem.
    Boot into Recovery. When the OS X Utilities screen appears, select
    Utilities ▹ Terminal
    from the menu bar. A Terminal window will open.
    In the Terminal window, type this:
    res
    Press the tab key. The partial command you typed will automatically be completed to this:
    resetpassword
    Press return. A Reset Password window will open. You’re not going to reset a password.
    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.
    Select your username from the menu labeled Select the user account if not already selected.
    Under Reset Home Directory Permissions and ACLs, click the Reset button.
    Select
     ▹ Restart
    from the menu bar.

  • Looking up a specific connection on the ACE

    Hi.
    We're running the ACE SMs version A2(3.3) and need to be able to look up the connection that traversed the ACE awhile ago. Since it was a successful connection, it didn't get register in the logs. Is there any other way to find it?
    thanks..
    Greg...                  

    Hi Greg,
    depending on the version of the ACE. The connection may be their on ACE for max 3600 seconds. ( idle connection) 
    If you are curious to track a connection which has been established within an hour and not closed by client then you can use the following link that explains everything.
    http://docwiki.cisco.com/wiki/Cisco_Application_Control_Engine_(ACE)_Troubleshooting_Guide_--_Troubleshooting_Connectivity#Internal_Mapping_of_ACE_TCP_and_UDP_Flows
    Read section : Tracking Connections Through the ACE
    Ideally commands such as
    show conn details or show conn
    You can also filter with pipe specifying the ip address of client
    show conn detail | in 10.10.10.10
    regards,
    Ajay Kumar

Maybe you are looking for

  • RV120W- How to create new unique self-signed certificate?

    Hello, how to create new unique self-signed certificate on RV120W? I can create request for singning by external CA, but I cannot create new unique self-signed certificate itself. Any idea? Did I miss something? Many thanks! Abudef

  • HT5517 got an apple TV but cannot get it TV with  HDMI

    cannot get HDMI to activate on Sony bravia bx400 TV with my apple TV

  • Share video dimensions for iDvd ??

    Hi, when checking out the share dialog I was confused as to what dimension to use when Wanting the use the video in iDvd. None of the dimensions are dvd standard ( 720x 480 : ntsc ) ( 720 x 576 : pal ). Any ideas ?? Cheers, Gerrit.

  • HT4623 ScreenLockOut on OS6 upgrade

    I upgraded my iPhone 4 to IOS6... and went smoothly however my phone has locked me out as it is not recognizing my screen logon

  • BPEL deployment error in production server

    Hi, I am deploying my BPEL project on Web-logic server through my JDeveloper 11g. its working fine. but when I selected my different environment for deployment(new one) then I got the following error. Error is due to one of my BPEL prcess "TaskProces