Green - Home Lab Setup problem - Help Appreciated

Below you will find my config for a 2520 Router and an AS2509-RJ. I am attempting to reverse telnet from my AS to 2520. However when I try this I end up telnetting back to the AS. (Very confusing, but confirmed as the only password accepted is test1.)
From my AS I am entering:
Telnet R1 2001
Note: Setup is as follows.
AS(RJ45-1) via Rolled cable to 2520 (console port)
Can someone help me out?
R1_2520 Config:
Current configuration : 760 bytes
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname R1_2520
enable secret xxx
enable password xxx
ip subnet-zero
ip tftp source-interface Ethernet0
interface Loopback0
ip address 169.1.x.x.255.255.255
interface Ethernet0
ip address 10.1.1.1 255.255.0.0
interface Serial0
no ip address
no ip mroute-cache
shutdown
interface Serial1
no ip address
shutdown
interface Serial2
no ip address
shutdown
interface Serial3
no ip address
shutdown
interface BRI0
no ip address
shutdown
ip classless
no ip httpserver
line con 0
line aux 0
line vty 0 4
password xxx
login
end
R0_2509 Config:
Current configuration : 976 bytes
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname R0_2509
enable secret xxx
enable password xxx
ip subnet-zero
no ip domain-lookup
ip host R1 2001 10.101.1.1
interface Loopback0
ip address 10.101.1.1 255.255.255.255
interface Ethernet0
ip address 10.10.10.10 255.255.0.0
no ip mroute-cache
shutdown
no cdp enable
interface Serial0
no ip address
no ip mroute-cache
shutdown
interface Group-Async0
ip unnumbered Ethernet0
async mode interactive
group-range 1 8
ip classless
ip httpserver
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
no cdp run
line con 0
password test1
login
no exec
transport preferred telnet
line 1 8
password test1
login
no exec
transport preferred telnet
line aux 0
line vty 0 4
password lions
login
no exec
transport preferred telnet
end
Debug Info from Telnet:
4d20h: TCB001E7458 created
4d20h: TCB001E7458 setting property TCP_TOS (11) 273F4F
4d20h: TCB001E7458 bound to UNKNOWN.11073
4d20h: TCP: sending SYN, seq 541398595, ack 0
4d20h: TCP0: Connection to 10.101.1.1:2001, advertising MSS 1474
4d20h: tcp0: O CLOSED 10.101.1.1:2001 10.101.1.1:11073 seq 541398595
OPTS 4 SYN WIN 4128
4d20h: IP: s=10.101.1.1 (local), d=10.101.1.1 (Loopback0), len 44, sending
4d20h: TCP0: state was CLOSED -> SYNSENT [11073 -> 10.101.1.1(2001)]
4d20h: IP: s=10.101.1.1 (Loopback0), d=10.101.1.1 (Loopback0), len 44, rcvd 3
4d20h: tcp0: I LISTEN 10.101.1.1:11073 10.101.1.1:2001 seq 541398595
OPTS 4 SYN WIN 4128
4d20h: TCP: connection attempt to port 2001
4d20h: TCP: sending RST, seq 0, ack 541398596
4d20h: TCP: sent RST to 10.101.1.1:11073 from 10.101.1.1:2001
4d20h: IP: s=10.101.1.1 (local), d=10.101.1.1 (Loopback0), len 40, sending
4d20h: IP: s=10.101.1.1 (Loopback0), d=10.101.1.1 (Loopback0), len 40, rcvd 3
4d20h: tcp0: I SYNSENT 10.101.1.1:2001 10.101.1.1:11073 seq 0
ACK 541398596 RST WIN 0
4d20h: TCP0: state was SYNSENT -> CLOSED [11073 -> 10.101.1.1(2001)]
4d20h: TCP0: bad seg from 10.101.1.1 -- closing connection: seq 0 ack 541398596 rcvnxt 0 rcvwnd 0
4d20h: TCP0: connection closed - remote sent RST
4d20h: TCB 0x1E7458 destroyed

So, now we're sure the connection is broken. Let's analyze the problem this way.
There are 3 components in this connection:
1.The 2520's console port
2.rollover cable
3.The 2509's line ports
If one of the above components have any problem, it will cause a broken connection.
First let's check the 2520's console port. Can you login to the 2520 by directly conecting the console port to your PC? If so, this can be excluded from being a probable cause.
Second, change the rollover cable. Is it improved then? If so, the rollover cable you were using is bad. If not, the rollover cable can be likely excluded from being the probable cause.(One possibility is that all the rollver you have are bad, but not likely)
Third, plug your rollover cable to line 2, then type "telnet 10.101.1.1 2002", and see whether you can login to the 2520. If not, repeat the process on line 3, line4 ,...,and line 8.
If all the 8 lines cannot be used, there is the last chance. Remember your aux port? It's your line 9. Before repeat the above process, add some command lines in your confiuration:
line aux 0
no exec
transport preffered telnet
then type "telnet 10.101.1.1 2009
Good lucks
SSLIN
(I have had the same problem before; it's just the cable problem)

Similar Messages

  • Home LAB Setup Advice

    Dear All,
    I would like to know and get advices from you guys how to setup home lab?
    The configuration i have
    1 server with below mentioned config
    Intel Xeon 2.3Ghz dual Processors in Intel s5000PSL Motherboard
    12GB RAM
    500GB SATA HDD
    Rackable Server with Virtualization Bios enabled
    I have installed Windows 2012 R2 Datacenter Evaluation for 180 days and i have setup Domain Controller and HYPERVServer in that Machine
    I have created 3 Virtual Machines in that Server
    1. Domain Controller Windows 2012 R2 Datacenter Eval
    2. Additional DC same windows 2012 R2 Datacenter Eval
    3. Win 7 64bit Client VM for me to test
    Please advice me i need to configure more servers in this HyperV Server and to learn
    Please advice what servers i can configure to setup home lab to learn and practice.
    I need to install exchange 2013 also in my mind.I have aDSL at my home with domain name.
    Your Valuble inputs are appreciated.
    Thanks in advance
    Tony

    Hi Sir,
    >>Please advice me i need to configure more servers in this HyperV Server and to learn
    >>Please advice what servers i can configure to setup home lab
    to learn and practice.
    I agree with Tim .
    Actually you can install any OS in the guest OS list to build what  the lab you want  :
    https://technet.microsoft.com/en-us/library/dn792027.aspx
    Best Regards,
    Elton Ji
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact [email protected] .

  • WRH54G linksys setup problem help plz

    i just bought the WRH54G linksys wireless-G home router. I put the cd rom in and i followed every step and i have everything in the right place but when it is at step 9 when u have to choose between DHCP, PPPoE, or Static Ip i dont know which one to choose so i go with DHCP then step 10 after i put in the passwords and click next and it is checking internet connection it says the router is not able to connect to the internet. try turning cable/dsl modem off and back on again. do you want to try again?. that is where i get stuck and i have tried to turn it off and back on again and i doesnt work. can anyone help me out?

    I HAVE A DSL .. ROUTER PROBLEM
    STAYS IN STEP 9 AS WELL .. 
    checking internet connection it says the router is not able to connect to the internet. try turning cable/dsl modem off and back on again. do you want to try again?
    after some research am going to try to put MY MODEM in brigde Mode. maybe that'll fix the problem... Since it apears the linksys WRH54G is trying to connect to the internet DIRECTLY...  i dont knoe .... first time newbe  , i have a high level of computer experties.. but am having pro with dis NAW 25$ discounted outer.lol
    I have DSL from verizon... in there instusction on how to.. the first thing is to put the MODEM that they issued A WESTELL into brigde mode .. and setup..
    if anione gat this thing working after u gat this CANT CONECT TO INTERNET
    the router is not able to connect to the internet. try turning cable/dsl modem off and back on again. do you want to try again?
    please e-mail me with anifinding..
    .thanks in advance

  • MATSHITA DVD-R   UJ-85J Problem, help appreciated

    I have been trying to burn an I Movie through I DVD on the Matshita DVD-R UJ-85J. The program seems to work correctly until right at the last minute. The burning process gets to Multiplexing and burning and suddenly the disc ejects and says done. The disc when reinserted still is blank. I am fairly new at this and was wondering if I am doing something wrong or is their a problem with my drive? Any help from anyone would be greatly appreciated. Thanks.

    I too am having a similar problem. Whenever I burn a Memorex DVD-R through my drive, SimplyBurns stops the operation immediately, saying "disc not writable." I read somewhere that resetting PRAM fixes some problems; that didn't work. Furthermore, here is what System Profiler reports:
    MATSHITA DVD-R UJ-85J:
    Firmware Revision: FCQ5
    Interconnect: ATAPI
    Burn Support: Yes (Apple Shipping Drive)
    Cache: 2048 KB
    Reads DVD: Yes
    CD-Write: -R, -RW
    DVD-Write: -R, -RW, +R, +R DL, +RW
    Write Strategies: CD-TAO, CD-SAO, DVD-DAO
    Media:
    Type: DVD-R
    ID: RITEKF1
    Blank: No
    Erasable: No
    Overwritable: No
    Appendable: Yes
    Write Speeds: 2x, 4x, 8x
    Message was edited by: andlabs

  • Moving iTunes Problem(help appreciated)

    Ok. My computer's disk space was almost full, so I bought an external hard drive and simply cut and pasted the iTunes folder on my computer. I then simply added all the files(from the external hard drive) into iTunes. The problem is that it's registering this library as a new one and I have to erase and sync. Is there anyway to undo what I've done? Help is much appreciated !!
    [email protected](contact me)

    Hi,
    Press the Windows Button + R.
    Once Run Pops Up,
    Type: dxdiag
    and hit ok.
    link this:
    Then DirectX Diagnostic Tool Should appear.
    Select "Save All information..."
    Then save it onto your Desktop.
    Open the DxDiag.txt (The information you saved onto the desktop)
    Then copy all and paste it here as a reply.
    Thanks,
    Blueloony

  • A Bit of an Odd Problem (Help Appreciated)

    Or at least I assume this is the problem...
    I have windows 8 and Skype came as an app on my laptop; that's fine, it worked really well. But several weeks ago I bought a Student edition of MS Office 365 and installed it on my laptop, and the package said that a skype account was needed (or something like that, I think because you needed a microsoft account), and I was like "Okay that's fine". 
    When activing Office account it required a microsoft sign in, and while trying to sign in, what I thought was my account didn't work so I though that I was mistaken (didn't make the connection between MS and Skype at that moment) and that I didn't have one. Now the Student edition only works if you prove you're a student,  so I used my college email when signing up for a microsoft account. 
    And next thing I know my skype is screwed up. Not just that it won't connect, but it won't call anyone, I can't answer incoming calls, and (going by the sounds) it doesn't know whether I'm signed on or trying to call someone.  
    I think the problem is that it's registering two different accounts and doesn't know which one to go with - the one already set up on the laptop, or the one MS Office 365 is supposed to be signed in? 
    Does anyone have any suggestions for what I should do? I'm afraid of uninstalling it incase that messes up my other apps (since this laptop came with Skype installed as an app), even if I re-installed it. I was also thinking about leaving it and just not touching it, while installing Skype on the desktop... but how much confusion could that cause? 
    I could really use some help with this. 

    you need to contact skype support (this is just a user forum)
    log on to the skype webpage on a computer
    klick help
    scroll down
    klick "get more help" almost at the bottom
    there you'll find how to get in touch with them

  • Invoice setup trouble - Help appreciated!!!!

    Hey there.
    I've been making some stationary for my company and need to finish this invoice in Pages. I have 5 columns (Date, Description, Daily Rate, Days Worked and Total) and a final cell as a total due on the last row. I've obviously managed to do the sume to multiply the daily rate with days worked to make the total and then the total due underneith, but this is only one row.
    I want to set it up so that I can add a row underneith and the calculations all work and add up to the total due. At the moment when you add a new row, it just adds a blank one with no calculation info. Is it possible to make this work?
    Would also be nice if you could dynamically put the date in, but thats not much of a problem.
    Thanks for any help!!!
    Christian

    Someone else may have a better idea for this, but here goes mine.
    As far as I can tell, you can't add a dynamic date within table cells. (I assume you are using a table for your form.) The simple solution is to add the date (Insert->Date&Time) outside of the table proper -- say the upper left or right corner of the document just above the table proper.
    While you can't add rows and have calculations work, you can delete them. For example, if I have a formula that says =SUM(B2:B7), and I delete rows 6 & 7, the formula still works. What you might have to do is start with more rows than you need and then delete the unused ones as you work with each form.
    Jim

  • Very unusual LCD display problem, help appreciated

    First post, I want to thank anyone who can help me in advance. I just took over my sister's MBP Unibody, and she has been having an issue where there is about a 1.5 inch wide strip of complete distortion on the left hand side of the screen. Everything in that strip is completely color distorted with constant screen tearing and flickering. I suspect there is something wrong with a wire in the lcd screen, as this problem only starts after using the computer for 15 minutes, and goes away initially by tapping the screen or adjusting the screen. After about half an hour of use however, it does not go away. In a completely unrelated incident, the glass panel cracked yesterday (This problem has been going on for about a month and a half), and i ordered a replacement, so I will be "under the hood" on Thursday. If anyone has any recommendations of what I might do to try to fix this, I would greatly appreciate it.
    3 pictures of my screen:
    http://i771.photobucket.com/albums/xx356/basicallydylan/IMG_0179.jpg
    http://i771.photobucket.com/albums/xx356/basicallydylan/IMG_0178-1.jpg
    http://i771.photobucket.com/albums/xx356/basicallydylan/IMG_0177.jpg

    Well its 70 dollars vs 600 dollars and it wasn't me who bought the applecare. And I would gladly bring it in to an apple technician instead, however my only problem with that is its not like they can just take off the glass, take a look at it and then tell me how much it costs. i mean the glass is shattered, you take it off and its going to be in pieces. Likewise, they very well might say that they can't do anything about it because the broken glass is clearly accidental damage and immediately attribute it to the lcd problem even though it has nothing to do with it. If the glass wasn't broken, I would never have even posted and immediately taken it to the apple store. Please, tell me I'm wrong and I will take it to them right away to tell me exactly why the screen is the way it is, and it will probably be covered seeing how it started out of no where. My understanding of apples policy however is that with the glass cracked as it is, they will have no choice but to immediately charge me for a full repair. But like I said, if I'm wrong please tell me and I'll take it in tomorrow

  • External SCSI HD setup problems - HELP

    Hello out there in cyberland (especially T.B) --
    I have had GREAT success in the past getting help on this forum (i.e. T.B.).
    I have installed an Adeptec Ultra PowerDomain 2930 SCSI controller card in a PCI slot in a G4 MDD computer running OS X 10.4.11.
    The controller card was purchased new and contained a CD that was supposed to assist in getting the external HD "up and running."
    Even though Adaptec says this particular card and software will run on this computer and the OS contains an extension (Adeptec 290x-2930.kext) for the controller I have been unsuccessful in getting the HD operational.
    The Adaptec card shows up in the System Profiler but the HD does NOT show up anywhere. I think (?) the HD should show up in the Parallel SCSI portion of the System Profiler. I turn on the HD BEFORE starting the computer and have checked the HD SCSI termination and cable setup. I have the HD SCSI ID# set to 0.
    The SCSIProbe (v. 5.1.1) and PowerDomain Control (v. 5.0) located on the packaged CD both open a window stating they will not work with "Classic."
    I have downloaded SCSIProbe v. 5.2 from the Adaptec site and it opens the same window. There is mention of a SCSIProbe v. 5.1.2 in the Adaptec help discussions but I was unable to find it on their site to download it.
    Adaptec would not answer my written (email) calls for help or even whether or not the card will work under OS X. However, their specifications state the system will work as I have it configured.
    I would appreciate any help that you folks are willing to provide.
    T.O.M

    Hi,
    The Adaptec software you mention is only for OS8.6-9.2, not for OSX. Do you have Jaguar or Panther also installed on the same machine? If so, if you boot into Jaguar, do you see the HD in Apple System Profiler? Have you tried setting the HD SCSI id to something other than 0?
    I recently had a similar issue w/an Adaptec 29160 and an HP tape drive. Everything worked fine in Jaguar. The Adaptec card not only showed up in Apple System Profile (ASP) in Jaguar (10.2.8), but the specific version of the firmware and driver were reported correctly. The same card in Panther (10.3.9) also showed up in ASP, but the firmware and driver version nos. were not reported correctly, but rather just binary addresses were displayed. Under Tiger the same card also only showed these binary addresses in ASP for the Adaptec card's firmware and driver version nos. The backup software did not work though under Tiger. I had to swap the Adaptec card for an ATTO SCSI card. Then the backup to the HP tape drive worked again.
    I'd look to see if the SCSI HD you have has drivers specifically written for Tiger and see if installing them will result in the HD being detected.
    Good luck!
    Ed

  • Color Saturation Problem (help appreciated!)

    Hi.
    I'm in Spain and making DVD's from footage shot on NTSC cameras (a bad idea in the first place, I know).
    At the moment I have no way of verifying my results on an NTSC tv, so.... My question is that the majority (but strangely, not quite all) of the DVD's I've produced, when watched on a normal PAL television, have EXTREMELY over-saturated colors. They are so saturated that they're flattened and bleedy so that subtle textures aren't discernible.
    Aside from that, the image appears stuttery and jumpy. This makes sense to me, being an NTSC DVD on a PAL tv, but should the COLORS be so drastically affected also?
    I've done five project here. 4 of them look stuttery and with bad colors, but 1 of them looks fine. This is the mystery. Is there some encoding setting that I'm overlooking that can reduce the problem?? Is this a normal symptom of NTSC seen on PAL equipment?
    I've tried on various different PAL tv's and players. no change.
    (this problem occurs with both 24p and regular NTSC footage. I use DVDSP4 and FCP4)
    THanks for your time!!
    powerbook 1.5GHz 15"   Mac OS X (10.4.1)  

    any ideas anyone? thanks

  • Difficult problem, help appreciated.

    Hi,
    I have the following tables:
    1.assessments
    2.meters
    3.meter_readings
    assessment : meters = 1:M
    meters : meter_readings = 1:M
    Now, I need to calculate "meter usage" which is a sum of a usage field in meter_readings for certain period for each meter, and "assessment usage", which is the sum of those "meter usages" for the each assessment.
    So I would like to have something like:
    assess_num meter max_date m_usage a_usage
    1 1A 1/1/00 100 160
    1B 3/1/00 50 160
    1C 4/1/00 10 160
    2 2A 5/1/00 12 32
    2B 6/1/00 20 32
    Now, in disco admin, I have done the following:
    1. On the meter readings folder, created
    - max date on date item
    2. Joined assessments folder with meters folder based on meter ID.
    These 2 steps will give me everything up to meter_usage.
    I'm wondering how I can get the assessment usage. I tried using a function that takes in assessment number in the workbook, but it altered the meter_usage figures and gives unexpected/wrong assessment_usage figures whenever the function is used.

    I figured out a work around but it would be nice to display GROUP Calendars via anonymous. The workaround is to create a calid (useranem) for every calendar you want to group together. Then on ww command line you can call or calids that you want grouped and it will group them into one calendar ie. http://mycalendar.com/command.shtml?calid=username1;username2;userndame3;username4&view=weekview

  • Jsp:forward problem, help appreciated

    hi all,
    The following piece of code from a jsp page is giving the following error
    "java.lang.IllegalStateException: Error: Attempt to clear a buffer that's already been flushed".
    updateToCompAccount is a button on the previous page
    <%
    if(request.getParameter("updateToCompAccount")!=null){
    %>
    <jsp:forward page="UpdateToCompAccount.jhtml" />
    <% } %>
    here is the stack trace:
    java.lang.IllegalStateException: Error: Attempt to clear a buffer that's already been flushed
    at org.apache.jasper.runtime.PageContextImpl.forward(PageContextImpl.java:376)
    at org.apache.jsp.adminUserProfileUpdate_jhtml._jspService(adminUserProfileUpdate_jhtml.java:474)
    at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:92)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:809)
    at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:162)
    at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:240)
    at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:187)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:809)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:200)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:146)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:209)
    at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:596)
    at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:433)
    at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:948)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:144)
    at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:596)
    at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:433)
    at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:948)
    at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2358)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:133)
    at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:596)
    at org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java:118)
    at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:594)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:116)
    at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:594)
    at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:433)
    at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:948)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:127)
    at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:596)
    at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:433)
    at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:948)
    at org.apache.ajp.tomcat4.Ajp13Processor.process(Ajp13Processor.java:409)
    at org.apache.ajp.tomcat4.Ajp13Processor.run(Ajp13Processor.java:528)
    at java.lang.Thread.run(Thread.java:595)
    Anybody have any ideas?
    Thanks.

    Well, the simplest way to do this would be:
    public class MyClass extends HttpServlet {
      public void doGet(HttpServletRequest request, HttpServletResponse response) {
           String buttonName = request.getParameter("myButtonRequestVariable");
           if ("update".equals(buttonName)) {
               request.getRequestDispatcher("UpdateToCompAccount.jhtml").
                             forward(request, response)
             } else if ("delete".equals(buttonName)) {
                  request.getRequestDispatcher("DeleteCompAccount.jhtml").
                            forward(request, response)
             } else {
                  request.getRequestDispatcher("ErrorPage.jhtml").
                      forward(request, response)
      public void doPost(HttpServletRequest request,
    } But that can get unwieldy if you've loads of buttons. Have you studied the concept of Model View Controller (MVC)?

  • Sql  problem - help appreciated!

    I have two tables, report_t and report_details_t.
    report_t has the following structure
    reportId fiscalYear
    ============
    1 2007
    2 2008
    Report_details_T
    reportID fund_type fund_value
    ========================
    1 direct 40
    1 indirect 20
    2 direct 30
    2 direct 5
    I am trying to generate a report using just SQL statment, the result will look like this
    report_id fund_type, 2007_fund_value, 2008_fund_value
    ====================================
    1 direct 40 0
    1 indirect 20 0
    2 direct 0 30
    2 indirect 0 5
    Is there any way achieving it?
    Thanks in advance.

    ah, ok - and was there a typo in your original set of data for the report_details_t table? there are two rows for direct for fiscal year id = 2, but one has morphed into indirect in your results.
    Assuming there was a typo:
    with    report_t as (select 1 reportid, 2007 fiscalyear from dual union all
                         select 2 reportid, 2008 fiscalyear from dual),
    report_details_t as (select 1 reportid, 'direct' fundtype, 40 fund_value from dual union all
                         select 1 reportid, 'indirect' fundtype, 20 fund_value from dual union all
                         select 2 reportid, 'direct' fundtype, 30 fund_value from dual union all
                         select 2 reportid, 'indirect' fundtype, 5 fund_value from dual)
    -- end of mimicking your data: USE SQL below:
    select rdt.reportid,
           rdt.fundtype,
           decode(rt.reportid, 1, rdt.fund_value, 0) "2007_FUND_VALUE",
           decode(rt.reportid, 2, rdt.fund_value, 0) "2008_FUND_VALUE"
    from   report_t rt,
           report_details_t rdt
    where  rt.reportid = rdt.reportid;
      REPORTID FUNDTYPE 2007_FUND_VALUE 2008_FUND_VALUE
             1 direct                40               0
             1 indirect              20               0
             2 direct                 0              30
             2 indirect               0               5Edited by: Boneist on 30-Mar-2009 15:00

  • Home Lab with Domain - Windows 10 upgrade

    As long as the OSes that you intend to upgrade to W10 are not volume licenses, then the upgrade process will properly handle the activation and product key details. (If you do an in-place upgrade. You can't overlay a fresh install until you first do an upgrade)

    I have a home lab setup with 2012 R2 DC. All of my Windows machines both physical and virtual are joined to the Domain setup here. They're currently running a mix of Windows 7 Pro and Windows 8.1 Pro. Will I be able to get the free Windows 10 upgrade for these? None of them are currently showing the "Get Windows 10" app icon.
    This topic first appeared in the Spiceworks Community

  • Help with design of this home network setup

    Hello all
    My friend's home has internet through Comcast and their modem is an RCA DHG535-2. This modem is currently functional in their office within the home. Their problem is the wireless signal is very weak in their basement. They have purchased a TC and have placed it in their office and wired to their iMac through ethernet. Is their a better way to design this setup so the Time Capsule can provide a broader and better range throughout their home?
    For example,
    1) Can the physical location of the TC change in order to broaden and evenly provide wireless range throughout the home? I would think not since the TC needs to be wired connected to the modem.
    2) Would an Airport Express help out?
    If you can provide a step by step to set this up, I would greatly appreciate this
    Many thanks
    RezF

    Rezf, welcome to the discussion area!
    1) Can the physical location of the TC change in order to broaden and evenly provide wireless range throughout the home? I would think not since the TC needs to be wired connected to the modem.
    Since you mention that the TC is connected to the iMac with an ethernet cable, it sounds like the location options of the TC are going to be somewhat limited. Technically, you could locate the TC anywhere as long it was connected to the modem with an ethernet cable.
    If the office is located in a central area of the home, that would be a good location for the TC
    2) Would an Airport Express help out?
    Possibly. The usual location for an AirPort Express is a point that is approximately 1/2 to 2/3 the distance from the main router (the TC) to the area that needs more coverage. If you have a laptop handy, move it to the proposed location of the AirPort Express and see if you can get a good, stable internet connection at that location. If you can, the AirPort Express should provide improved wireless coverage to the basement.
    If your friends can pull an ethernet cable from the TC to the area in the basement that needs more wireless coverage and connect an AirPort Express to the ethernet cable, that will provide the strongest wireless signal to the specific area.

Maybe you are looking for