Hashing URLs

Is there anyway to use the ACE to hash urls? It doesn't seem to be possible, but I was thinking maybe there was some kind of workaround.
Many CDNs offer the service of hashing an URL and changing it at a fixed interval to offer a little extra protection against deep linking to content. It would be great to offload this all from our redirector cgi directly onto the load balancer

a loadbalancer does not modify http content.
So you can't replace the header.
Although it does sound like a good feature to add, you will kill the performance of the box by having the check all url, replace it where needed, recompute the tcp checksum, fragments/reassembles the packets where needed,... a total pain to achieve.
Gilles.

Similar Messages

  • ERROR 47: Invalid URL () Needs To Be Fixed...

    Hi,
    I have read a lot of discussions on this website and others,
    When I do a web search for this error it brings up a lot of unanswered topics.
    And it looks like there s a error that needs fixing by the developers of Quicktime Player.
    ERROR 47: Invalid URL () Needs
    This error appears in a pop up window when I try to play certain URLs in quicktime player,
    We also tested it with the pro version and the same error occurs.
    It was working fine then it just throws this error.
    This type of hashed URL use to work fine:
    http://www.site.com/file-a5f81d6-bb2c-4aa4-8737-4a3a81a529a6&MovieID=314

    I got some code a few years back, I used it to build a video delivery application.
    The system can deliver video URLs, when the user clicks the system, it fetches a fake/hashed URL from the database.
    The user receives an URL similar to the one I posted above, when they put the URL in Quicktime player it loads up the actual .mov file.
    But the hashed URL is all that's seen, I tested it in QuicktimePlayer 100's of times, even in web browser, it would open Quicktime plugin.
    Not any more.

  • ACE 4700 hash address source

    Hello I'm using an ACE4700 to redirect connection toward 2 Cache boxes (cache2 and cache3).
    I'm using "predictor hash address source".
    On the cache boxes I see that on the first one I have 400 src IP and on the second one i have 200 src IP.
    I was expecting to have half ip src on one cache and half on other one.
    Since the predictor is based on "hash address source" the two cache should be loaded with the same number of ip src.
    How can I view on the ACE the src IPs redirected to cache1 and the src IPs redirected to chache2 ?
    serverfarm host proxiesAC
      description Batteria dei BlueCoat
      transparent
      failaction purge
      predictor hash address source
      rserver cache1
        probe probe_ICMP
      rserver cache2
        probe probe_ICMP
        inservice
      rserver cache3
        probe probe_ICMP
        inservice
      rserver cache4
        probe probe_ICMP
      rserver cache5
        probe probe_ICMP
      rserver cache6
        probe probe_ICMP

    When described like this, it sounds easy to find a hash algorithm which will split 600 ip addresses in 2 equal size groups.
    But this is actually very complicated.
    First because when we designed the ACE code, we didn't know how many ip, which ip ... would be used.
    Morever, this information changes with every customer of ours.
    In conclusion we made a generic algorithm which works most of the time.
    But this algorithm can't guarantee that you will have equal loadbalancing.
    If you need equal load on your caches, you need to switch to leastconn or roundrobin.
    Finally, I don't see the need to use hash address source.
    Usually when using ACE with caches, we use either hash url (if we want to make sure one object only exists on one cache - save disk space) or roundrobin/leastconn to have equal load on the caches.
    Regards,
    Gilles.

  • Accessing Navigation target through anonymous content.

    Hello,
    1. I created sitemap. From code I am accessing
    /irj/portal?navigationTarget=ROLES://portal_content//AboutUS/Welcome
    I am trying to access navigation target as anonymous user. For any type of iView  portal presenting me Logon screen.
    2. I already set up above mentioned iView as anonymous. I given permissions on Portal Content , Role, Workset and iView for anonymous user/guest user
    3. Can I access navigationTarget=Roles://   as anonymous/guest  user  OR  I must be   log in to access
    navigationTarget=Roles://
    I will appreciate any help in this issue.
    Thanks
    Mark

    Hi Mark!
    First of all, there is no real anonymous access to portal. If you call up a portal page with no authorization required, you are logged in as the default anonymous user automaticly.
    To access your pages via NavigationTarget and "anonymous" user the call is
    /irj/portal/anonymous?navigationTarget=ROLES://portal_content//AboutUS/Welcome
    You may also use hashed URLs or Quicklinks.
    It is even possible to use different anonymous users on the same portal by giving the URL parameter "guest_user" like this example:
    http://myserver.mycompany.com/irj/portal/anonymous/home?guest_user=anonymous_de. All guest users have to be configured in the J2EE engine too (via Visual admin). See SAP HELP for more on this topic.
    "home" is the quicklink to the start page in our case.
    Regards,
      Jürgen

  • Transparent Cache; Need separation for YouTube.

    Gurus,
    here I'm again trying to get some insight to my clients cache issues:
    We recently wanted to separate Youtube traffic from the global cache pool and make a separate 3-cache pool, we hit a major issue, the moment we added the paramters/class-maps/policy-maps, we saw ACE dropping 80% of normal existing traffic and we were left with an outage of the web, the ACE just wont pass traffic, even after we removed the class-maps and polices and reloading the ACE module , had to reboot the c6500s
    Here the config:
    YOUTUBE SERVERFARM:
    rserver host BCXX
    description BC-YOUTUBE-x
    ip address X.X.X.X
    inservice
    rserver host BCYY
    description BC-YOUTUBE-y
    ip address Y.Y.Y.Y
    inservice
    rserver host BCZZ
    description YOUTUBE -z
    ip address Z.Z.Z.Z
    inservice
    serverfarm host LEASTCONNECTIONS_FARM
    description Transparent Proxy Least Connection Farm
    transparent
    failaction purge
    predictor leastconns slowstart 60
    probe PORT_80
    rserver BC05
    inservice
    rserver BC06
    inservice
    rserver BC07
    serverfarm host YOUTUBE_FARM
    transparent
    failaction purge
    predictor roundrobin
    probe PORT_80
    rserver BC-YOUTUBE-x
    inservice
    reserver BC-YOUTUBE-y
    inservice
    rserver BC-YOUTUBE-z
    inservice
    class-map type http loadbalance match-any YOUTUBE-1
    2 match http header Host header-value "www.youtube.com"
    class-map type http loadbalance match-any YOUTUBE-2
    2 match http url /get_video.*
    sticky ip-netmask 255.255.255.255 address both STICKY_SF
    timeout 30
    timeout activeconns
    replicate sticky
    serverfarm LEASTCONNECTIONS_FARM
    policy-map type loadbalance first-match TRANSPARENT_LB_PM
    class YOUTUBE-1
    serverfarm YOUTUBE_FARM
    class YOUTUBE-2
    serverfarm YOUTUBE_FARM
    class class-default
    sticky-serverfarm STICKY_SF
    , We saw some buffer crunches but not sure, we are running A2(1.3) .
    last year we had same config with ONLY mathcing URL /get_video.* and was working fine with dest_ip hashing,
    this time we added the host www.youtube.com and 3 separate caches.
    doesnt seem to make sense to us,
    if anyone has worked to segregate U-tube , do share their config philosophy.
    we are thinking about separate context or diff policies, but that's too much config related, still all options open.
    do let me now champs..
    Shukla.

    if you had to reboot the cat6k this is not a ACE issue.
    The ACE module sits inside the cat6k but should be considered as an external device.
    To separate Youtube traffic you need a new feature of A2(1.4) to hash the secondary cookie value.
    CSCsq99736: ACE predictor hash url should not stop parsing at "?" delimiter
    All video in youtube comes from the same url but with an option "watch?v=9LMTClqvCGs"
    What you need to do is hash the value which can be done with A2(1.4).
    This will guarantee that you always get to the same cache for the same video.
    But your total meltdown was not the result of ACE.
    Sth else must have happened.
    If ACE was the problem, a reboot of ACE w/ a known-working config should have been enough.
    Try not to reboot as a way to fix problems.
    Call the TAC and let them troubleshoot your issue live.
    Gilles.

  • Using ACE for proxy server load balancing

    Hello groups,
    I wanted to know your experiences of using ACE for proxy server load balancing.
    I want to load balance to a pool of proxy servers. Note: load-balancing should be based on the HTTP URL (i can't use source or dest. ip address) so that
    a certain domain always gets "cached/forwarded" to the same proxy server. I don't really want to put matching
    criteria in the configuration (such as /a* to S1, /b* to S2, /c* to S3,etc..), but have this hash calculated automatically.
    Can the ACE compute its own hash based on the number of "online" proxy servers ? ie. when 4 servers are online, distribute domains between 1,2,3,4 evenly.
    Should server 4 fail, recalculate hash so that the load of S4 gets distributed across the other 3 evenly. Also load-balancing domains of S1 ,S2 and S3 should not change if S4 fails.....
    regards,
    Geert

    This is done with the following predictor command:
    Scimitar1/Admin# conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Scimitar1/Admin(config)# serverfarm Proxy
    Scimitar1/Admin(config-sfarm-host)# predictor hash ?
      address         Configure 'hash address' Predictor algorithms
      content         Configure 'hash http content' Predictor algorithms
      cookie          Configure 'hash cookie' Predictor algorithms
      header          Configure 'hash header' Predictor algorithm
      layer4-payload  Configure 'hash layer4-payload' Predictor algorithms
      url             Configure 'hash url' Predictor algorithm
    Scimitar1/Admin(config-sfarm-host)# predictor hash url
    It does hash the url and the result takes into account the number of active proxies dynamically.
    This command has been designed for this kind of scenario that you describe.
    Gilles.

  • ACE best practice for proxy servers

    Dear,
    I would like to know which is the best practice scenario to load balance proxy servers:
    1- Best practice to have transparent proxy or proxy setting on the web browser?
    2- for transparent proxy: best practice to use ip wccp or route-map pointing to the ACE VIP?
    3- What are the advantages and disadvantages of transparent proxy V/S web browser proxy setting.
    Regards,
    Pierre

    Hi,
    Sorry, that seem to be an internal link.
    You can also check the below post where a sample config is posted here for transparent cache.
    https://supportforums.cisco.com/thread/129106
                   Best practice :
    VIP would be a catch all address.
    To optimize the caching predictor hash url is used.
    You can also use mac-sticky on interface so proper flow persistence is used within ACE
    The mode is transparent so we preserve the destination ip address.
    Regards,
    Siva

  • ACE 4710 transparent LB with two Caches and two routers.

    Hello,
    I have ACE 4710 that load balance two cach flows (bluecoat), i am doing pbr on the routers to send the traffic destined to port 80 to ACE then Cach farm. After that the Cach flow will get the page from the internet via two routers. The return traffic will match another pbr on the routers with source port 80 that will send it to the ACE then CachFlow again .....then to the users.
    I am not using ip-spoofing on the CachFlow for now. In the figure attached i created a VIP 0.0.0.0 0.0.0.0 port 80 on the interface on the ACE facing the routers, but the question is do i have to create another VIP 0.0.0.0 0.0.0.0 port 80 on the interface on ACE facing the Cach Flow? or just forward the traffic on the default route? What might be the default route since i have to use two routers and i cannot use hsrp?
    Kindly I need some assistance
    Thank you and regards,
    George
    access-list PERMIT_ALL line 8 extended permit ip any any
    access-list CFLOW line 8 extended permit ip any any
    ip name-server 8.8.8.8
    ip name-server 4.2.2.2
    ##################################Config for Cache Cache Servers###################
    probe http CISCO_WWW_PROBE
      ip address 72.163.4.161
      interval 2
      faildetect 2
      passdetect interval 2
      passdetect count 5
      request method head url /index.html
      expect status 200 200
      exit
    probe http YAHOO_WWW_PROBE
      ip address 87.248.112.181
      interval 2
      faildetect 2
      passdetect interval 2
      passdetect count 5
      request method head url /index.html
      expect status 200 200
      exit
    serverfarm host TRANSPARENT_PROXY_SF
      description Transparent Proxy Farm
      transparent
      predictor hash url
      probe CISCO_WWW_PROBE
      probe YAHOO_WWW_PROBE
      rserver CFLOW01
        inservice
      rserver CFLOW02
        inservice
      exit
      exit
    ############################################# Router Cache Farm ############################
    probe icmp ICMP_PROBE
      description *** Probe for icmp health monitoring ***
      interval 5
      faildetect 2
      passdetect interval 60
      passdetect count 2
      exit
    rserver host Router01
      description Connection to Sodetel Router
      ip address 192.168.14.4
      probe ICMP_PROBE
      inservice
    rserver host Router02
      description Connection to IDM Router
      ip address 192.168.14.5
      probe ICMP_PROBE
      inservice
    serverfarm host Routers
      description Transparent Proxy Farm
      transparent
      predictor hash url
      probe ICMP_PROBE
      rserver Router01
        inservice
      rserver Router02
        inservice
      exit
      exit
    ################################# Management################################
    class-map type management match-any REMOTE_MGMT
      description Allow Remote management for below protocols
      8 match protocol icmp any
      9 match protocol ssh source-address 172.31.13.31 255.255.255.255
      10 match protocol ssh source-address 172.31.31.21 255.255.255.255
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
      class REMOTE_MGMT
        permit
    class-map match-all CFLO2Internet
      2 match virtual-address 0.0.0.0 0.0.0.0 any
    class-map match-all TRANSPARENT_VIP_CM
      2 match virtual-address 0.0.0.0 0.0.0.0 tcp eq www
    policy-map type loadbalance first-match TRANSPARENT_LB_PM
      class class-default
        serverfarm TRANSPARENT_PROXY_SF backup Routers
    policy-map type loadbalance first-match CFLO2Internet_LB
      class class-default
        serverfarm Routers
    policy-map multi-match CFLO2Internet_PM
      class CFLO2Internet
        loadbalance vip inservice
        loadbalance policy CFLO2Internet_LB
        loadbalance vip icmp-reply active
        connection advanced-options TCP
    policy-map multi-match L3L4_PM
      class TRANSPARENT_VIP_CM
        loadbalance vip inservice
        loadbalance policy TRANSPARENT_LB_PM
        loadbalance vip icmp-reply active
        connection advanced-options TCP
    ====Interfaces======
    interface vlan 11
      description Interface between Routers and ACE
      ip address 192.168.14.2 255.255.255.224
      alias 192.168.14.1 255.255.255.224
      peer ip address 192.168.14.3 255.255.255.224
      no icmp-guard
      access-group input PERMIT_ALL
      service-policy input REMOTE_MGMT_ALLOW_POLICY
      service-policy input L3L4_PM
      no shutdown
    interface vlan 21
      description Connection to CFlow ServerFarm
      ip address 192.168.12.2 255.255.255.224
      alias 192.168.12.1 255.255.255.224
      peer ip address 192.168.12.3 255.255.255.224
      no icmp-guard
      access-group input CFLOW
      service-policy input CFLO2Internet_PM ------>>>> Is this necessary???
      no shutdown

    Hi George,
    In the topology you described, only the service-policy in the interface towards the routers is necessary. For the traffic from the caches, the ACE will just forward to the default gateway.
    The only problem is, as you mentioned, that you cannot use HSRP. In that case, you can still configure two default gateways, but there is no way to predict which one the ACE will use at a given time (the way it does to select the one it will use is sending an ARP request to both gateways and using the one that replies first until the ARP entry expires)
    If you need to load-balance the traffic between both routers, then yes, you would need to configure a new VIP on the cache side and load-balanced to a transparent serverfarm composed of both routers.
    Regards
    Daniel

  • New features in EP7.0

    Hi All,
               Can you please direct me to the link/document where in I can get new features that are released as part of EP7.0 and comparisons with EP6.0.
    Thanks
    Prathima

    HII prathima..
    NW2004s–the External Facing Portal features are planned to be released as part of NW2004s SPS6.
    This supports External facing portal also
    In External facing portal
    1.Anonymous user support with hashed URLs –general limitation until SPS16 -see note –913367 . Planed to be fixed with NW2004s SPS7 (NW2004 SPS16)
    2.Collaboration rooms are not supported –Planed to be supported with SPS7.
    Look at this thread
    why SAP Netweaver 2004s
    THere is a good comparison between EP5 and EP6. A similar one comparing EP6 & EP7 would be nice
    Java iView Development EP5-EP6 Comparison
    Thanks
    Rewards r welcome

  • Have any one configure transparent caching on ACE module

    How to configure transparent caching on ACE module? Please kindly give me a example configure. Thank you very much.

    here is a basic config.
    The module will intercept traffic coming in on vlan 20 and loadbalance it doing a url hashing to caches in vlan 30.
    The mode is transparent so the destination ip address is preserved.
    serverfarm host CACHES
    transparent
    predictor hash url
    rserver linux1
    inservice
    rserver linux1-24
    inservice
    class-map match-all VIP-TCP80
    2 match virtual-address 0.0.0.0 0.0.0.0 tcp eq www
    policy-map type loadbalance first-match SF-CACHES
    class class-default
    serverfarm CACHES
    policy-map multi-match SLB-CACHES
    class VIP-TCP80
    loadbalance vip inservice
    loadbalance policy SF-CACHES
    interface vlan 20
    ip address 192.168.20.123 255.255.255.0
    peer ip address 192.168.20.121 255.255.255.0
    access-group input PERMIT-ANY
    service-policy input ALLOW-ALL
    service-policy input SLB-CACHES
    no shutdown

  • ACE for Cache servers how-to??

    We have ACE10 installed on 7609 Internet-router, we intend to force Internet http traffic on the 7609 to a third party Cache servers without using either PBR or WCCP to obtain backbone bandwidth savings. In addition the ACE will distribute the http traffic to the cache servers which are 8 in number. Can anybody help out with how to do it (some reference documents will be appreciated).

    HI,
    The ACE uses the predictors to select the best server to fulfill a client request.
    Use the Hash URL method as predictor as it selects the server using a hash value based on the requested URL. You can specify a beginning pattern and an ending pattern to match in the URL. Use this predictor method to load balance cache servers.
    Cache servers perform better with the URL hash method because you can divide the contents of the caches evenly if the traffic is random enough. In a redundant configuration, the cache servers continue to work even if the active ACE switches over to the standby ACE.
    You have to understand the reason of url hash.
    The goal is to guarantee that the same object will not be cached on mayne servers and therefore maximise disk usage.
    So, if you don't really need to maximize this disk usage, you could use any other balancing method.
    There is not one-best-for-all solution.
    It all depends on what are your priorities.
    Kindly see how to configure Hash URL method Below:
    http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/rsfarms.html#wpmkr1039375
    Kindly see below the article in this regard:
    http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Data%20Center&topic=Application%20Networking&topicID=.ee7814f&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cc060ee
    Kindly Rate if you find this information of any use to you or please ask furhter about your queries.
    Sachin garg

  • ViewController.jpx error?

    Hello:
    I've a JDev ADF Fusion appi have been working on for awhile, and all of a sudden today when i open the application, the following error displays:
    "Unable to load Business Components Project. File not found. Object: oracle.epm.SR.view.ViewController.
    C:\<path>\ViewController\src\oracle\epm\SR\view\ViewController.jpx"
    Not familiar with ViewController.jpx -how does one fix this error?
    The odd thing is that i checked my older versions of the a.pp, and it never has contained a file named ViewController.jpx. The only .jpx has been Model.jpx.
    Am using JDev 11.1.1.4.0.
    Would appreciate any help. Thanks.
    -george

    I had reverted to a previous version yesterday as John suggested, and it was fine at first. However, the problem occurred again later - so just reverting isn't going to be the solution unfortunately.
    I searched project files for .jpx and found the following in ViewController.jpr:
    <value n="jbo.JpxName" v="oracle.epm.SR.view.ViewController"/>
    Based on John's comment and the little info i could google on "jbo.JpxName", I wonder if this is the issue - i wonder if this should be pointing to the model.jpx directory?
    However, i could not find a UI option in JDev to do this, and am not sure if just editing this .jpr atribute in a text editor is a good idea - for example, is there a dependency on some other item that also needs to be changed. So could someone provide some guidance on the correct way to fix this issue?
    If it is useful for troubleshooting, below is the content of ViewController.jpr:
    <?xml version = '1.0' encoding = 'UTF-8'?>
    <jpr:project xmlns:jpr="http://xmlns.oracle.com/ide/project">
    <value n="ADFComponentWizard.LAST_TAG_NS_PREF" v="component"/>
    <value n="ADFComponentWizard.LAST_TAGLIB_URI_PREF"/>
    <hash n="component-versions">
    <value n="oracle.adfdt.controller.adfc.source.migration.AdfControllerSchemaMigrator" v="11.1.1.1.0"/>
    <value n="oracle.adfdt.controller.common.migrator.ProjectMigrator" v="11.1.1.1.0"/>
    <value n="oracle.adfdt.controller.jsf2.diagram.migrate.JsfNodeMigratorHelper" v="11.1.1.1.0"/>
    <value n="oracle.adfdt.controller.struts.addin.db.ADFStrutsProjectMigrator" v="11.1.1.1.0"/>
    <value n="oracle.adfdt.controller.struts.addin.StrutsProjectMigrator" v="11.1.1.1.0"/>
    <value n="oracle.adfdtinternal.dvt.datapresdt.migration.DVTDataMapMigrator" v="11.1.1.1.0"/>
    <value n="oracle.adfdtinternal.model.ide.migration.ProjectMigrator" v="11.1.1.1.0.11.1.1"/>
    <value n="oracle.adfdtinternal.model.ide.security.wizard.FormPageMigrator" v="11.1.1.0.0"/>
    <value n="oracle.adfdtinternal.model.ide.security.wizard.JpsFilterMigrator" v="11.1.1.1.0"/>
    <value n="oracle.adfdtinternal.model.ide.xmled.migration.ADFNodeMigrator" v="11.1.1.1.0.5"/>
    <value n="oracle.adfdtinternal.model.ide.xmled.migration.PageDefinitionParameterValueMigrator" v="11.1.1.1.0.5"/>
    <value n="oracle.adfdtinternal.model.ide.xmled.migration.WebXmlMigrator" v="11.1.1.1.0"/>
    <value n="oracle.adfdtinternal.view.common.migration.wizards.MigrationHelper" v="11.1.1.1.0.3"/>
    <value n="oracle.adfdtinternal.view.rich.binding.migration.JarResourceMigrator" v="11.1.1.1.0"/>
    <value n="oracle.adfdtinternal.view.rich.migration.ComponentIdNodeMigratorHelper" v="11.1.1.1.0.01"/>
    <value n="oracle.adfdtinternal.view.rich.migration.LibraryVersionMigrator" v="11.1.1.1.0"/>
    <value n="oracle.bm.commonIde.ProjectUpgrader" v="11.1.1.1.0"/>
    <value n="oracle.bm.migration.project.MigratorRegistryProjectUpgradeAdapter" v="11.1.1.1.0"/>
    <value n="oracle.ide.model.Project" v="11.1.1.1.0"/>
    <value n="oracle.ide.model.ResourcePathsMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jbo.dt.jclient.migrator.JCProjectMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jbo.dt.jdevx.deployment.JbdProjectMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jbo.dt.jdevx.ui.appnav.APProjectMigrator" v="11.1.1.0.1.5"/>
    <value n="oracle.jbo.dt.migrate.ResourceBundlePathMigrator" v="11.1.1.1.0.5"/>
    <value n="oracle.jbo.dt.migration.ServiceInterfaceMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jdeveloper.ejb.EjbMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jdeveloper.library.ProjectLibraryMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jdeveloper.model.OutputDirectoryMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jdevimpl.deploy.DeploymentProfilesMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jdevimpl.deploy.jps.JpsDataMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jdevimpl.jsp.JspMigrator" v="11.1.1"/>
    <value n="oracle.jdevimpl.offlinedb.migration.OfflineDBProjectMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jdevimpl.offlinedb.migration.OfflineTransferMigrator" v="11.1.1.1.0"/>
    <value n="oracle.jdevimpl.resourcebundle.XliffAddin$XliffMigratorHelper" v="11.1.1.1.0"/>
    <value n="oracle.jdevimpl.webapp.jsp.libraries.JspLibraryMigrator" v="11.1.1.1.4"/>
    <value n="oracle.jdevimpl.webapp.WebAppContentSetNodeMigratorHelper" v="11.1.1"/>
    <value n="oracle.jdevimpl.webapp.WebAppNodeMigratorHelper" v="11.1.1.1.0"/>
    <value n="oracle.jdevimpl.webservices.WebServicesMigratorHelper" v="11.1.1.1.0"/>
    <value n="oracle.jdevimpl.xml.wl.WeblogicMigratorHelper" v="11.1.1.1.0"/>
    <value n="oracle.modeler.bmmigrate.management.Migration" v="11.1.1.1.0"/>
    <value n="oracle.tip.tools.ide.bpel.v1.designer.addin.migrator.BPELProjectMigrator" v="11.1.1.1.0"/>
    <value n="oracle.tip.tools.ide.fabric.addin.SCAProjectMigrator" v="11.1.1.1.0.06"/>
    <value n="oracle.tip.tools.ide.workflow.addin.TaskFormMigratorAddin" v="11.1.1.1.0"/>
    <value n="oracle.tip.tools.ide.workflow.addin.WorkflowProjectMigrator" v="11.1.1.1.0.09"/>
    <value n="oracle.toplink.workbench.addin.migration.PersistenceProjectMigrator" v="11.1.1.1.1"/>
    <value n="oracle.toplink.workbench.addin.migration.TopLinkProjectMigrator" v="11.1.1.1.0"/>
    <value n="oracle.webcenter.internal.dt.migration.WebCenterProjectMigrator" v="11.1.1.4.0.101019.0800"/>
    </hash>
    <list n="contentSets">
    <string v="oracle.jdeveloper.model.PathsConfiguration/javaContentSet"/>
    <string v="oracle.ide.model.ResourcePaths/resourcesContentSet"/>
    <string v="oracle.jdeveloper.offlinedb.model.OfflineDBProjectSettings/offlineDBContentSet"/>
    <string v="oracle.jdeveloper.model.J2eeSettings/webContentSet"/>
    <string v="oracle.mds.internal.dt.ide.MDSLibraryCustCSProvider/mdsContentSet"/>
    <string v="oracle.bm.commonIde.data.project.ModelerProjectSettings/modelersContentSet"/>
    <string v="oracle.tip.tools.ide.fabric.addin.SCAContentSetProvider/sca-content"/>
    <string v="oracle.adfdtinternal.model.ide.settings.ADFMSettings/adfmContentSet"/>
    <string v="oracle.toplink.workbench.addin/toplinkContentSet"/>
    <string v="oracle.bpm.fusion.repository.BPMProjectSettings/bpmProjectsProcessesContentSet"/>
    </list>
    <value n="defaultPackage" v="oracle.epm.SR.view"/>
    <value n="jbo.JpxName" v="oracle.epm.SR.view.ViewController"/>
    <value n="JboProject" v="true"/>
    <hash n="oracle.adfdtinternal.model.ide.security.SecurityPolicies">
    <value n="grantOption" v="none"/>
    </hash>
    <hash n="oracle.ide.model.DependencyConfiguration">
    <list n="dependencyList">
    <hash>
    <value n="class" v="oracle.jdeveloper.library.ProjectLibrary"/>
    <url n="sourceOwnerURL" path="../EPM_String_Repository.jws"/>
    <url n="sourceURL" path="../Model/Model.jpr"/>
    </hash>
    <hash>
    <value n="class" v="oracle.jdeveloper.library.ProjectLibrary"/>
    <value n="sourceOwnerURL"/>
    <url n="sourceURL" path="ViewController.jpr"/>
    </hash>
    </list>
    </hash>
    <hash n="oracle.ide.model.TechnologyScopeConfiguration">
    <list n="technologyScope">
    <string v="Java"/>
    <string v="HTML"/>
    <string v="JSP"/>
    <string v="JSF"/>
    <string v="ADFc"/>
    <string v="ADF_FACES"/>
    <string v="XML"/>
    <string v="ADFbc"/>
    </list>
    </hash>
    <value n="oracle.jbo.SavedPreferences" v="true"/>
    <hash n="oracle.jdeveloper.compiler.OjcConfiguration">
    <list n="copyRes">
    <string v=".gif"/>
    <string v=".jpg"/>
    <string v=".jpeg"/>
    <string v=".png"/>
    <string v=".properties"/>
    <string v=".xml"/>
    <string v=".ejx"/>
    <string v=".xcfg"/>
    <string v=".cpx"/>
    <string v=".dcx"/>
    <string v=".sva"/>
    <string v=".wsdl"/>
    <string v=".ini"/>
    <string v=".tld"/>
    <string v=".tag"/>
    <string v=".xlf"/>
    <string v=".xsl"/>
    <string v=".xsd"/>
    <string v=".jpx"/>
    </list>
    <value n="internalEncoding" v="UTF-8"/>
    <list n="Javac.commandline.optionlist">
    <string v="-g"/>
    <string v="-Xlint:all"/>
    <string v="-Xlint:-cast"/>
    <string v="-Xlint:-empty"/>
    <string v="-Xlint:-fallthrough"/>
    <string v="-Xlint:-path"/>
    <string v="-Xlint:-serial"/>
    <string v="-Xlint:-unchecked"/>
    </list>
    <value n="webIANAEncoding" v="UTF-8"/>
    </hash>
    <hash n="oracle.jdeveloper.deploy.dt.DeploymentProfiles">
    <hash n="profileDefinitions">
    <hash n="EPM_String_Repository_ViewController_webapp1">
    <hash n="appletArchives"/>
    <hash n="appletFiles">
    <value n="autoInclude" v="true"/>
    <list n="selectionFilters">
    <string v="oracle.jdevimpl.deploy.common.JavaSelectionFilter"/>
    </list>
    </hash>
    <hash n="archiveOptions">
    <value n="hasManifest" v="false"/>
    </hash>
    <url n="earURL" path="deploy/EPM_String_Repository_ViewController_webapp1.ear"/>
    <value n="enterpriseAppName" v="EPM_String_Repository_ViewController_webapp1"/>
    <hash n="fileGroups">
    <list n="groups">
    <hash>
    <list n="contributors">
    <hash>
    <value n="type" v="5"/>
    </hash>
    </list>
    <value n="displayName" v="Web Files"/>
    <hash n="filters">
    <list n="rules"/>
    </hash>
    <value n="internalName" v="web-files"/>
    <value n="type" v="1"/>
    </hash>
    <hash>
    <list n="contributors">
    <hash>
    <value n="type" v="2"/>
    </hash>
    <hash>
    <value n="type" v="7"/>
    </hash>
    </list>
    <value n="displayName" v="WEB-INF/classes"/>
    <hash n="filters">
    <list n="rules"/>
    </hash>
    <value n="internalName" v="project-output"/>
    <value n="targetWithinJar" v="WEB-INF/classes"/>
    <value n="type" v="1"/>
    </hash>
    <hash>
    <value n="displayName" v="WEB-INF/lib"/>
    <hash n="filters">
    <list n="rules">
    <hash>
    <value n="pattern" v="**"/>
    </hash>
    </list>
    </hash>
    <value n="internalName" v="libraries"/>
    <value n="targetWithinJar" v="WEB-INF/lib"/>
    <value n="type" v="3"/>
    </hash>
    </list>
    </hash>
    <url n="jarURL" path="deploy/EPM_String_Repository_ViewController_webapp1.war"/>
    <hash n="libraryDependencies">
    <value n="IncludeLibrariesFromOtherContainers" v="true"/>
    </hash>
    <value n="profileClass" v="oracle.jdeveloper.deploy.war.WarProfile"/>
    <value n="profileName" v="EPM_String_Repository_ViewController_webapp1"/>
    </hash>
    </hash>
    <list n="profileList">
    <string v="EPM_String_Repository_ViewController_webapp1"/>
    </list>
    </hash>
    <hash n="oracle.jdeveloper.model.J2eeSettings">
    <value n="j2eeWebAppName" v="EPM_String_Repository-ViewController-webapp"/>
    <value n="j2eeWebContextRoot" v="EPM_String_Repository-ViewController-context-root"/>
    </hash>
    <hash n="oracle.jdeveloper.model.PathsConfiguration">
    <hash n="javaContentSet">
    <list n="constituent-sets">
    <hash>
    <url n="content-folder-url" path="../Model/src/oracle/epm/SR/model/EOs/"/>
    <list n="pattern-filters">
    <string v="+Labels.xml"/>
    </list>
    <list n="url-path">
    <url path="../Model/src/oracle/epm/SR/model/EOs/"/>
    </list>
    </hash>
    </list>
    <list n="pattern-filters">
    <string v="+**"/>
    </list>
    <list n="url-path">
    <url path="src/"/>
    </list>
    </hash>
    </hash>
    <hash n="oracle.jdeveloper.runner.RunConfigurations">
    <hash n="runConfigurationDefinitions">
    <hash n="Default">
    <value n="custom" v="false"/>
    <value n="name" v="Default"/>
    <hash n="oracle.adfdt.controller.adfc.source.runner.AdfcRunnerLaunchSettings">
    <value n="unboundedTaskFlow" v="true"/>
    <value n="viewActivityId" v="Welcome"/>
    </hash>
    <url n="targetURL" path="public_html/Welcome.jspx"/>
    </hash>
    </hash>
    <list n="runConfigurationList">
    <string v="Default"/>
    </list>
    </hash>
    <hash n="oracle.jdevimpl.config.JProjectLibraries">
    <list n="exportedReferences">
    <hash>
    <value n="id" v="JSP Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JSF 1.2"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JSTL 1.2"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Page Flow Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Controller Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Controller Schema"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Faces Runtime 11"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Common Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Web Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="MDS Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="MDS Runtime Dependencies"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Commons Beanutils 1.6"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Commons Logging 1.0.4"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Commons Collections 3.1"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF DVT Faces Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF DVT Faces Databinding Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF DVT Faces Databinding MDS Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JPS Designtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Oracle JEWT"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Faces Databinding Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Resource Bundle Support"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Resource Bundle Variable Resolver"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JSTL 1.2 Tags"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="BC4J Security"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="BC4J Tester"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Oracle XML Parser v2"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JDeveloper Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="SQLJ Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Model Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="BC4J Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Oracle JDBC"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Connection Manager"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="BC4J Oracle Domains"/>
    <value n="isJDK" v="false"/>
    </hash>
    </list>
    <list n="libraryReferences">
    <hash>
    <value n="id" v="JSP Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JSF 1.2"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JSTL 1.2"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Page Flow Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Controller Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Controller Schema"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Faces Runtime 11"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Common Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Web Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="MDS Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="MDS Runtime Dependencies"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Commons Beanutils 1.6"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Commons Logging 1.0.4"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Commons Collections 3.1"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF DVT Faces Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF DVT Faces Databinding Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF DVT Faces Databinding MDS Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JPS Designtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Oracle JEWT"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Faces Databinding Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Resource Bundle Support"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Resource Bundle Variable Resolver"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JSTL 1.2 Tags"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="BC4J Security"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="BC4J Tester"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Oracle XML Parser v2"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="JDeveloper Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="SQLJ Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="ADF Model Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="BC4J Runtime"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Oracle JDBC"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="Connection Manager"/>
    <value n="isJDK" v="false"/>
    </hash>
    <hash>
    <value n="id" v="BC4J Oracle Domains"/>
    <value n="isJDK" v="false"/>
    </hash>
    </list>
    </hash>
    <hash n="oracle.jdevimpl.config.JProjectPaths">
    <url n="outputDirectory" path="classes/"/>
    </hash>
    <hash n="oracle.jdevimpl.webapp.jsp.libraries.model.ProjectTagLibraries">
    <list n="tag-libraries">
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="JSF Core"/>
    <value n="version" v="1.2"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="JSF Core"/>
    <value n="tldURL" v="@oracle.home@../oracle_common/modules/oracle.jsf_1.2.9/glassfish.jsf_1.0.0.0_1-2-15.jar!/META-INF/jsf_core.tld"/>
    <value n="URI" v="http://java.sun.com/jsf/core"/>
    <value n="version" v="1.2"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="JSF HTML"/>
    <value n="version" v="1.2"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="JSF HTML"/>
    <value n="tldURL" v="@oracle.home@../oracle_common/modules/oracle.jsf_1.2.9/glassfish.jsf_1.0.0.0_1-2-15.jar!/META-INF/html_basic.tld"/>
    <value n="URI" v="http://java.sun.com/jsf/html"/>
    <value n="version" v="1.2"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="ADF Faces Components"/>
    <value n="version" v="11"/>
    </hash>
    <value n="jspVersion" v="1.2"/>
    <value n="name" v="ADF Faces Components"/>
    <value n="tldURL" v="@oracle.home@../oracle_common/modules/oracle.adf.view_11.1.1/adf-richclient-impl-11.jar!/META-INF/afu.tld"/>
    <value n="URI" v="http://xmlns.oracle.com/adf/faces/rich"/>
    <value n="version" v="11"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="ADF Data Visualization"/>
    <value n="version" v="1.1"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="ADF Data Visualization"/>
    <value n="tldURL" v="@oracle.home@../oracle_common/modules/oracle.adf.view_11.1.1/dvt-faces.jar!/META-INF/bi.tld"/>
    <value n="URI" v="http://xmlns.oracle.com/dss/adf/faces"/>
    <value n="version" v="1.1"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="JSTL Core"/>
    <value n="version" v="1.2"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="JSTL Core"/>
    <value n="runInEditor" v="true"/>
    <value n="tldURL" v="@oracle.home@../modules/glassfish.jstl_1.2.0.1.jar!/META-INF/c.tld"/>
    <value n="URI" v="http://java.sun.com/jsp/jstl/core"/>
    <value n="version" v="1.2"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="JSTL Format"/>
    <value n="version" v="1.2"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="JSTL Format"/>
    <value n="tldURL" v="@oracle.home@../modules/glassfish.jstl_1.2.0.1.jar!/META-INF/fmt.tld"/>
    <value n="URI" v="http://java.sun.com/jsp/jstl/fmt"/>
    <value n="version" v="1.2"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="JSTL SQL"/>
    <value n="version" v="1.2"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="JSTL SQL"/>
    <value n="tldURL" v="@oracle.home@../modules/glassfish.jstl_1.2.0.1.jar!/META-INF/sql.tld"/>
    <value n="URI" v="http://java.sun.com/jsp/jstl/sql"/>
    <value n="version" v="1.2"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="JSTL XML"/>
    <value n="version" v="1.2"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="JSTL XML"/>
    <value n="tldURL" v="@oracle.home@../modules/glassfish.jstl_1.2.0.1.jar!/META-INF/x.tld"/>
    <value n="URI" v="http://java.sun.com/jsp/jstl/xml"/>
    <value n="version" v="1.2"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="JSTL Functions"/>
    <value n="version" v="1.2"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="JSTL Functions"/>
    <value n="tldURL" v="@oracle.home@../modules/glassfish.jstl_1.2.0.1.jar!/META-INF/fn.tld"/>
    <value n="URI" v="http://java.sun.com/jsp/jstl/functions"/>
    <value n="version" v="1.2"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="JSTL Permitted Taglibs"/>
    <value n="version" v="1.2"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="JSTL Permitted Taglibs"/>
    <value n="tldURL" v="@oracle.home@../modules/glassfish.jstl_1.2.0.1.jar!/META-INF/permittedTaglibs.tld"/>
    <value n="URI" v="http://jakarta.apache.org/taglibs/standard/permittedTaglibs"/>
    <value n="version" v="1.2"/>
    </hash>
    <hash>
    <hash n="baseLibrary">
    <value n="name" v="JSTL Script Free"/>
    <value n="version" v="1.2"/>
    </hash>
    <value n="jspVersion" v="2.1"/>
    <value n="name" v="JSTL Script Free"/>
    <value n="tldURL" v="@oracle.home@../modules/glassfish.jstl_1.2.0.1.jar!/META-INF/scriptfree.tld"/>
    <value n="URI" v="http://jakarta.apache.org/taglibs/standard/scriptfree"/>
    <value n="version" v="1.2"/>
    </hash>
    </list>
    </hash>
    <hash n="oracle.toplink.workbench.addin">
    <hash n="toplinkContentSet">
    <list n="pattern-filters">
    <string v="+**"/>
    </list>
    <list n="url-path">
    <url path="toplink/"/>
    </list>
    </hash>
    </hash>
    <hash n="ResourceBundleOptions">
    <value n="ADFRestricted" v="true"/>
    <value n="BundleCreationPolicy" v="0"/>
    <value n="DefaultBundleTypeId" v="xliffResourceBundleId"/>
    <list n="RegisteredResourceBundles"/>
    <value n="WarnAboutHardcodedTranslatableStrings" v="true"/>
    </hash>
    </jpr:project>
    Thanks.

  • Retreive named anchor from On Load page process

    I am trying to utilize named anchors on a page and need to access the named anchor from a PL/SQL page process of type: On Load - Before Header.
    I first tried owa_util.get_cgi_env ('QUERY_STRING') which has been helpful in retrieving GET params, but for a URL like:
    http://host:port/pls/apex/f?p=121:75:3747918990426914:::75:P75_ID:25769#asdf
    it returns:
    http://host:port/pls/apex/f?p=121:75:3747918990426914:::75:P75_ID:25769
    What I actually need is everything else ... in this case: #asdf (or just asdf).
    I don't see anything relevant here either:
    owa_util.print_cgi_env();
    I'm punting now, assuming that there is no way to retrieve these hash url parameters. If somebody has any insight into this, I would greatly appreciate your direction!
    Thanks,
    John

    Could you use location.href in javascript to stuff the URL value into a page ITEM and then substr/instr it out?
    Just a thought.
    Jeff

  • Verification of Transparent cache configuration

    I would like to load balancing a web cache server.
    whenever a client connect to http, the traffic reached a MSFC,
    the MSFC check dst:0.0.0.0:80, and then forwarding to ACE?
    the flow right? It just check only a http to redirect cache!
    So I made a configuration like below.
    access-list anyone line 10 extended permit ip any any
    access-list anyone line 20 extended permit igmp any any
    access-list anyone line 30 extended permit icmp any any
    access-list anyone line 40 extended permit pim any any
    rserver host Cache_1
    ip address 192.168.2.10
    inservice
    rserver host Cache_2
    ip address 192.168.2.11
    serverfarm host CACHES
    transparent
    predictor hash url
    rserver linux1
    inservice
    rserver linux1-24
    inservice
    class-map match-all VIP-TCP80
    2 match virtual-address 0.0.0.0 0.0.0.0 tcp eq www
    class-map type management match-any remote_access
    2 match protocol telnet any
    3 match protocol icmp any
    4 match protocol http any
    5 match protocol https any
    policy-map type loadbalance first-match SF-CACHES
    class class-default
    serverfarm CACHES
    policy-map multi-match SLB-CACHES
    class VIP-TCP80
    loadbalance vip inservice
    loadbalance policy SF-CACHES
    interface vlan 20
    description From_Client
    ip address 192.168.1.2 255.255.255.0
    access-group input anyone
    access-group input PERMIT-ANY
    service-policy input remote_mgmt_allow
    service-policy input SLB-CACHES
    no shutdown
    inter vlan 30
    description From_Server
    ip address 192.168.2.1 255.255.255.0
    service-policy input remote_mgmt_allow
    no shutdown

    this looks good to me.
    Except you should configure an access-group input on interface vlan 30 to allow traffic from the cache.
    Gilles.

  • ACE4710 Transparent Caching

    Hello Friends,
    I am facing a problem with the ACE4710, problem description as follows;
    We have two IronPort web security boxes loadbalanced using the ACE4710 which configured in the bridged mode for transparent caching . Now we are facing a strange problem with downloading from websites like cisco.com, ibm.com etc.. it gives the error ;;connection timedout''  in the final stage...What we observed that these sites are initially https and then changing to http something like that... below is the configuration details;
    ==================
    serverfarm host IRONPORT-SF
      transparent
      predictor hash url
      rserver IRONPORT-1
        probe IRONPORT-ICMP
        inservice
      rserver IRONPORT-2
        probe IRONPORT-ICMP
        inservice
    sticky ip-netmask 255.255.255.255 address source IRONPORT-STICKY
      timeout 60
      timeout activeconns
      replicate sticky
      serverfarm IRONPORT-SF
    policy-map type loadbalance first-match IRONPORT-LB
      class class-default
        sticky-serverfarm IRONPORT-STICKY
    class-map match-all VIP-TCP443
      2 match virtual-address 0.0.0.0 0.0.0.0 tcp eq https
    class-map match-all VIP-TCP80
      2 match virtual-address 0.0.0.0 0.0.0.0 tcp eq www
    policy-map multi-match SERVERFARM-POLICY
      class VIP-TCP80
        loadbalance vip inservice
        loadbalance policy IRONPORT-LB
        loadbalance vip icmp-reply active
      class VIP-TCP443
        loadbalance vip inservice
        loadbalance policy IRONPORT-LB
        loadbalance vip icmp-reply active
    policy-map type loadbalance first-match IRONPORT-LB
      class class-default
        sticky-serverfarm IRONPORT-STICKY
    policy-map multi-match SERVERFARM-POLICY
      class VIP-TCP80
        loadbalance vip inservice
        loadbalance policy IRONPORT-LB
        loadbalance vip icmp-reply active
    interface vlan 20
      description ---------CLIENT SIDE INTERFACE---------
      ip address <<IP Address>> <<Mask>>
      alias <<IP Address>> <<Mask>>
      peer ip address <<IP Address>> <<Mask>>
      no normalization
      no icmp-guard
      access-group input ACL-IN
      service-policy input REMOTE-ACCESS
      service-policy input SERVERFARM-POLICY
      no shutdown
    interface vlan 208
      description ---------SERVER SIDE INTERFACE--------
      ip address <<IP Address>> <<Mask>>
      alias <<IP Address>> <<Mask>>
      peer ip address <<IP Address>> <<Mask>>
      no normalization
      mac-sticky enable
      no icmp-guard
      access-group input ACL-IN
      no shutdown
    =============================
    If anybody has the same setup or anyone faced similar problem....Pls comment.
    Rgds
    Sudheer.

    Hi Sudheer,
    You mentioned that you are using the ACE in bridge mode, please confirm this point as I don't see any BVI interface configured, so I guess you are using it in routed mode?!
    Looking through your configuration and considering routed mode deployment, I don't see how the ACE could effect these connection in anyway, you are doing basic L4 load balancing, and sharing the same sticky group under both policy map, which mean the client will stay stuck to the same server even if it been redirected by the web-site, so this connection change will not effect the ACE load balancing decision.
    I would recommend you to capture the traffic on the client, ACE, IronPort simultaneously then have a look who is breaking the communication, that should give you better understanding about the problem.
    Best regards,
    Ahmad   

Maybe you are looking for

  • Problem with dreamweaver site on internet explorer

    Hi all Help required! i have a website up and running www.villaneptunecyprus.co.uk which works fine in most browsers apart from Internet Explorer! If you have a look you will see a slider banner picture come across the screen  which then slides out t

  • Macbook pro 2011 13" i5 slowed down, any help would be much appreciated (detailed info).

    Ok first off let me preface with as much detailed information as possible, as i have read many many posts on problems and hopefully mine will be detailed enough to not cause all you wonderful people a headache. Machine Details Macbook Pro 13inch mode

  • Calendar duplicates not showing up in ical/snow leopard

    After upgrading to ios5 and activating icloud, my ical entries on my macbook duplicated (as did the calendar entries on my iphone and ipad).  I cleaned the macbook duplicates with spanning tools, resulting in an ical file on my macbook that is withou

  • LMS 4.2 communication protocol

    Hi All, We are using the below functionality in the LMS 4.2 - Fault Monitoring (DFM) - Performance Management (HUM) - Inventory Collection and Configuration collections (RME) On device side configuration currently we have configured the RO and RW str

  • Captivate Exit button not exiting

    I updated the SCORM.htm file to stop bookmarking, which is now working wonderfully (thanks to all who posted those solutions!). BUT, now the Exit button is no longer closing the course. I click the Exit button on the skin and it just sits there. Befo