Having problems with assignment

Hello all, I'm fairly new to java and finding this assignment quite hard as Ive had no assistance with it from my trainer.
In a brief description, its has to work like a financial system, where a user inputs several numbers into a JOptionPane.showInputDialog and they are displayed down in a JtextArea. At the bottom these inputs need to be added up. Below I have pasted what Ive done so far, as I said I�m still new to java. I have not added the calculate part but it should be located under the final text area.
The major difficulty I�m having at the moment is displaying the inputs from the user into the Jtextarea created.
Here is the code, cut and paste to run (hopefully this will show u more what I�m talking about.
When i tested this i get [Ljava.lang.String;@46cbe9ee in the program, i dont know why this is comming up, but under AccountName and AccountNo.  the static names that have been decleared should be displaying, and under debit and account there should be nothing there till user has inputed it.
import java.awt.*;
import java.awt.event.*;
import javax.swing.*;
import java.text.DecimalFormat;
public class prog3c3 extends JFrame {
// DECLARE VARIABLES //
private JTextArea textArea1;
private JButton inputButton;
private String output, output1, output2, output3, output4, output5,output6;
private String output7,output8,output9,output10,output11,output12, output13;
private String output14, output15, output16, output17, output18, output19;
private String output20, output21, output22, output23, output24, output25;
private String output26, output27, output28, output29; //Declearing outputs from the dialog boxes
private int pointer = 14;
private String accounttitle [] = { "Cash", "Acts Recievable", "Merch Inventory", "Supplies", "Pre Insurance", "Sam's Drawing", "Purchases", "Delivery Exp", "Miscel Exp", "Rent Expense", "Salary Expense", "Acct Payable","Sam's Capital", "Sales"};
private String accountno [] = { "1001", "1002", "1003", "1004", "1005", "3002", "5001", "6001", "6003", "6004", "6005", "2001", "3001", "4001" };
private JTextField textField1; //Declearing text area
private JButton plainButton; //Declearing input button
public prog3c3()
super( "RIT Reports" ); //JPane heading
Box box = Box.createHorizontalBox();
//Text are output
output = "\t\t\t\t Sam's Computers\n \t\t\t\t Trial balance\n \t\t\t\t For Month Ending \n\n\n " +
"Account Title \t\t\t Act No \t Debit \t Credit \n\n";
// set up textArea1
for ( int i = 0; i < 14; i++ ) {
output = output + accounttitle +"\t\t\t" + accountno + "\n"; }
textArea1 = new JTextArea( output, 10, 15 );
textArea1.setToolTipText ( "Values and Calculations for this month" );
textArea1.setEditable(false);
box.add( new JScrollPane( textArea1 ) );
// set up Input button
inputButton = new JButton( "Input Financial Data" );
inputButton.setToolTipText ( "Click this button to start entering the montly values" );
inputButton.addActionListener(
new ActionListener() {
public void actionPerformed( ActionEvent event )
output1 = JOptionPane.showInputDialog( "Please enter todays date" );
output2 = JOptionPane.showInputDialog( "Please enter the Cash debit amount" );
output3 = JOptionPane.showInputDialog( "Please enter the Cash credit amount" );
output4 = JOptionPane.showInputDialog( "Please enter the Accounts Recievable debit amount" );
output5 = JOptionPane.showInputDialog( "Please enter the Accounts Recievable credit amount" );
output6 = JOptionPane.showInputDialog( "Please enter the Merchandise Inventory debit amount" );
output7 = JOptionPane.showInputDialog( "Please enter the Merchandise Inventory credit amount" );
output8 = JOptionPane.showInputDialog( "Please enter the Supplies debit amount" );
output9 = JOptionPane.showInputDialog( "Please enter the Supplies credit amount" );
output10 = JOptionPane.showInputDialog( "Please enter the Prepaid Insurance debit amount" );
output11 = JOptionPane.showInputDialog( "Please enter the Prepaid Insurance credit amount" );
output12 = JOptionPane.showInputDialog( "Please enter the Sam's Drawing debit amount" );
output13 = JOptionPane.showInputDialog( "Please enter the Sam's Drawing credit amount" );
output14 = JOptionPane.showInputDialog( "Please enter the Purchases debit amount" );
output15 = JOptionPane.showInputDialog( "Please enter the Purchases credit amount" );
output16 = JOptionPane.showInputDialog( "Please enter the Delivery Expense debit amount" );
output17 = JOptionPane.showInputDialog( "Please enter the Delivery Expense credit amount" );
output18 = JOptionPane.showInputDialog( "Please enter the Miscellaneous Expense debit amount" );
output19 = JOptionPane.showInputDialog( "Please enter the Miscellaneous Expense credit amount" );
output20 = JOptionPane.showInputDialog( "Please enter the Rent Expense debit amount" );
output21 = JOptionPane.showInputDialog( "Please enter the Rent Expense credit amount" );
output22 = JOptionPane.showInputDialog( "Please enter the Salary Expense debit amount" );
output23 = JOptionPane.showInputDialog( "Please enter the Salary Expense credit amount" );
output24 = JOptionPane.showInputDialog( "Please enter the Accounts Payable debit amount" );
output25 = JOptionPane.showInputDialog( "Please enter the Accounts Payable credit amount" );
output26 = JOptionPane.showInputDialog( "Please enter the Sam's Capital debit amount" );
output27 = JOptionPane.showInputDialog( "Please enter the Sam's Capital credit amount" );
output28 = JOptionPane.showInputDialog( "Please enter the Sales debit amount" );
output29 = JOptionPane.showInputDialog( "Please enter the Sales credit amount" );
JOptionPane.showMessageDialog( null,
"Thank you for useing the Financial system.\n Your input is now being calculated." );
} // end anonymous inner class
); // end call to addActionListener
box.add( inputButton );
// add box to content pane
Container container = getContentPane();
container.add( box ); // place in BorderLayout.CENTER
setSize( 690, 500 ); //Box Size
setVisible( true ); //set vusiblity
// execute application
public static void main( String args[] )
prog3c3 application = new prog3c3();
Any help would be great im really stuck on this.
PS thank you to guguBanana

here is a slight modifiction of your orriginal program... i hope this is what you are asking for.
import java.awt.*;
import java.awt.event.*;
import javax.swing.*;
import java.text.DecimalFormat;
public class prog3c3 extends JFrame {
// DECLARE VARIABLES //
private JTextArea textArea1;
private JButton inputButton;
private String output, output1, output2, output3, output4, output5,output6;
private String output7,output8,output9,output10,output11,output12, output13;
private String output14, output15, output16, output17, output18, output19;
private String output20, output21, output22, output23, output24, output25;
private String output26, output27, output28, output29; //Declearing outputs from the dialog boxes
private int pointer = 14;
private String accounttitle [] = { "Cash", "Acts Recievable", "Merch Inventory", "Supplies", "Pre Insurance", "Sam's Drawing", "Purchases", "Delivery Exp", "Miscel Exp", "Rent Expense", "Salary Expense", "Acct Payable","Sam's Capital", "Sales"};
private String accountno [] = { "1001", "1002", "1003", "1004", "1005", "3002", "5001", "6001", "6003", "6004", "6005", "2001", "3001", "4001" };
private JTextField textField1; //Declearing text area
private JButton plainButton; //Declearing input button
public prog3c3()
super( "RIT Reports" ); //JPane heading
Box box = Box.createHorizontalBox();
//Text are output
output = "\t\t\t\t Sam's Computers\n \t\t\t\t Trial balance\n \t\t\t\t For Month Ending \n\n\n " +
"Account Title \t\t\t Act No \t Debit \t Credit \n\n";
// set up textArea1
for ( int i = 0; i < 14; i++ ) {
output = output + accounttitle[i] +"\t\t\t" + accountno[i] + "\n"; }
textArea1 = new JTextArea( output, 10, 15 );
textArea1.setToolTipText ( "Values and Calculations for this month" );
textArea1.setEditable(false);
box.add( new JScrollPane( textArea1 ) );
// set up Input button
inputButton = new JButton( "Input Financial Data" );
inputButton.setToolTipText ( "Click this button to start entering the montly values" );
inputButton.addActionListener(
new ActionListener() {
     public void actionPerformed( ActionEvent event )
String debit[]     =new String[14];
String credit[]     =new String[14];
String date;
date = JOptionPane.showInputDialog( "Please enter todays date" );
debit[0] = JOptionPane.showInputDialog( "Please enter the Cash debit amount" );
credit[0] = JOptionPane.showInputDialog( "Please enter the Cash credit amount" );
debit[1] = JOptionPane.showInputDialog( "Please enter the Accounts Recievable debit amount" );
credit[1] = JOptionPane.showInputDialog( "Please enter the Accounts Recievable credit amount" );
debit[2] = JOptionPane.showInputDialog( "Please enter the Merchandise Inventory debit amount" );
credit[2] = JOptionPane.showInputDialog( "Please enter the Merchandise Inventory credit amount" );
debit[3] = JOptionPane.showInputDialog( "Please enter the Supplies debit amount" );
credit[3] = JOptionPane.showInputDialog( "Please enter the Supplies credit amount" );
debit[4] = JOptionPane.showInputDialog( "Please enter the Prepaid Insurance debit amount" );
credit[4] = JOptionPane.showInputDialog( "Please enter the Prepaid Insurance credit amount" );
debit[5] = JOptionPane.showInputDialog( "Please enter the Sam's Drawing debit amount" );
credit[5] = JOptionPane.showInputDialog( "Please enter the Sam's Drawing credit amount" );
debit[6] = JOptionPane.showInputDialog( "Please enter the Purchases debit amount" );
credit[6] = JOptionPane.showInputDialog( "Please enter the Purchases credit amount" );
debit[7] = JOptionPane.showInputDialog( "Please enter the Delivery Expense debit amount" );
credit[7] = JOptionPane.showInputDialog( "Please enter the Delivery Expense credit amount" );
debit[8] = JOptionPane.showInputDialog( "Please enter the Miscellaneous Expense debit amount" );
credit[8] = JOptionPane.showInputDialog( "Please enter the Miscellaneous Expense credit amount" );
debit[9] = JOptionPane.showInputDialog( "Please enter the Rent Expense debit amount" );
credit[9] = JOptionPane.showInputDialog( "Please enter the Rent Expense credit amount" );
debit[10] = JOptionPane.showInputDialog( "Please enter the Salary Expense debit amount" );
credit[10] = JOptionPane.showInputDialog( "Please enter the Salary Expense credit amount" );
debit[11] = JOptionPane.showInputDialog( "Please enter the Accounts Payable debit amount" );
credit[11] = JOptionPane.showInputDialog( "Please enter the Accounts Payable credit amount" );
debit[12] = JOptionPane.showInputDialog( "Please enter the Sam's Capital debit amount" );
credit[12] = JOptionPane.showInputDialog( "Please enter the Sam's Capital credit amount" );
debit[13] = JOptionPane.showInputDialog( "Please enter the Sales debit amount" );
credit[13] = JOptionPane.showInputDialog( "Please enter the Sales credit amount" );
JOptionPane.showMessageDialog( null,
"Thank you for useing the Financial system.\n Your input is now being calculated." );
String newoutput = "\t\t\t\t Sam's Computers\n \t\t\t\t Trial balance\n \t\t\t\t For Month Ending "+date +"\n\n\n " +
"Account Title \t\t\t Act No \t Debit \t Credit \n\n";
// set up textArea1
for ( int i = 0; i < 14; i++ ) {
newoutput = newoutput + accounttitle[i] +"\t\t\t" + accountno[i] + "\t"+debit[i]+"\t"+credit[i]+"\n"; }
textArea1.setText(newoutput);
} // end anonymous inner class
); // end call to addActionListener
box.add( inputButton );
// add box to content pane
Container container = getContentPane();
container.add( box ); // place in BorderLayout.CENTER
setSize( 690, 500 ); //Box Size
setVisible( true ); //set vusiblity
// execute application
public static void main( String args[] )
prog3c3 application = new prog3c3();

Similar Messages

  • Having problem with gmail smtp server.  Since going to google 2-step, and entering 16-digit code in gmail account, I can receive mail on my iMac, but cannot send.  What do I do?

    Having problem with gmail smtp outgoing server.  Since going to google 2-step, and entering 16-digit code in gmail account, I can receive mail on my iMac, but cannot send.  I keep getting an error message that Mail "Cannot send message using Gmail (my assigned name) server."  What do I do?

    Confirm you did this: https://support.google.com/mail/answer/1173270?hl=en
    You might also try removing all gmail passwords from your keychain in Keychain Access. Then connect again and enter the password code given by Google.

  • Still having problems with VPN access

    Hello!
    I am having problems with my VPN clients getting access to the networks over a MPLS infrastruture. I can reach these resources form my Core network (172.17.1.0/24) and my Wifi (172.17.100.0/24) but not from my VPN network (172.17.200.0/24). From the VPN I can reach the Wifi network (which is behind a router) and the rule that allows that also allows access to the other networks but for some reason it is not working.
    When I ping inside the core network from VPN I can connect and get responses. When I ping to the Wifi network, I can get responses and connect to resources there. A tracert to the wifi network shows it hitting the core switch (a 3750 stack) @ 172.17.1.1, then the Wifi router (172.17.1.3) and then the host. A tracert to a resource on the MPLS network from the VPN shows a single entry (the destination host) and then 29 time outs but will not ping that resource nor connect.
    I've posted all the info I can think of below. Any help appreciated.
    *** Here is a tracert from a core network machine to the resource we need on the MPLS:
    C:\Windows\system32>tracert 10.2.0.125
    Tracing route to **************** [10.2.0.125]
    over a maximum of 30 hops:
      1     1 ms    <1 ms    <1 ms  172.17.1.1
      2     1 ms    <1 ms    <1 ms  172.17.1.10
      3     5 ms     5 ms     5 ms  192.168.0.13
      4    31 ms    30 ms    31 ms  192.168.0.5
      5    29 ms    30 ms    29 ms  192.168.0.6
      6    29 ms    29 ms    29 ms  192.168.20.4
      7    29 ms    29 ms    29 ms  RV-TPA-CRMPROD [10.2.0.125]
    Trace complete.
    172.17.1.10 is the mpls router.
    **** Here is the routing table (sh ip route) from the 3750 @ 172.17.1.1
    Gateway of last resort is 172.17.1.2 to network 0.0.0.0
    S    192.168.30.0/24 [1/0] via 172.17.1.10
         172.17.0.0/24 is subnetted, 3 subnets
    S       172.17.200.0 [1/0] via 172.17.1.2
    C       172.17.1.0 is directly connected, Vlan20
    S       172.17.100.0 [1/0] via 172.17.1.3
         172.18.0.0/24 is subnetted, 1 subnets
    S       172.18.1.0 [1/0] via 172.17.1.10
    S    192.168.11.0/24 [1/0] via 172.17.1.10
         10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    S       10.2.0.0/24 [1/0] via 172.17.1.10
    S       10.10.10.0/24 [1/0] via 172.17.1.10
    S       10.20.0.0/24 [1/0] via 172.17.1.10
    S       10.3.0.128/25 [1/0] via 172.17.1.10
    S    192.168.1.0/24 [1/0] via 172.17.1.10
    S*   0.0.0.0/0 [1/0] via 172.17.1.2
    *** Here is the firewall config (5510):
    ASA Version 8.4(1)
    hostname RVGW
    domain-name ************
    enable password b5aqRk/6.KRmypWW encrypted
    passwd 1ems91jznlfZHhfU encrypted
    names
    interface Ethernet0/0
    nameif Outside
    security-level 10
    ip address 5.29.79.10 255.255.255.248
    interface Ethernet0/1
    nameif Inside
    security-level 100
    ip address 172.17.1.2 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 172.19.1.1 255.255.255.0
    management-only
    banner login RedV GW
    ftp mode passive
    dns server-group DefaultDNS
    domain-name RedVector.com
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network WiFi
    subnet 172.17.100.0 255.255.255.0
    description WiFi 
    object network inside-net
    subnet 172.17.1.0 255.255.255.0
    object network NOSPAM
    host 172.17.1.60
    object network BH2
    host 172.17.1.60
    object network EX2
    host 172.17.1.61
    description Internal Exchange / Outbound SMTP
    object network Mail2
    host 5.29.79.11
    description Ext EX2
    object network NETWORK_OBJ_172.17.1.240_28
    subnet 172.17.1.240 255.255.255.240
    object network NETWORK_OBJ_172.17.200.0_24
    subnet 172.17.200.0 255.255.255.0
    object network VPN-CLIENT
    subnet 172.17.200.0 255.255.255.0
    object-group service DM_INLINE_TCP_1 tcp
    port-object eq www
    port-object eq https
    object-group network DM_INLINE_NETWORK_1
    network-object object BH2
    network-object object NOSPAM
    object-group network VPN-CLIENT-PAT-SOURCE
    description VPN-CLIENT-PAT-SOURCE
    network-object object VPN-CLIENT
    object-group network LAN-NETWORKS
    network-object 10.10.10.0 255.255.255.0
    network-object 10.2.0.0 255.255.255.0
    network-object 10.3.0.0 255.255.255.0
    network-object 172.17.100.0 255.255.255.0
    network-object 172.18.1.0 255.255.255.0
    network-object 192.168.1.0 255.255.255.0
    network-object 192.168.11.0 255.255.255.0
    network-object 192.168.30.0 255.255.255.0
    object-group network VPN-POOL
    network-object 172.17.200.0 255.255.255.0
    object-group protocol DM_INLINE_PROTOCOL_1
    protocol-object ip
    protocol-object icmp
    access-list Outside_access_in extended permit tcp any object-group DM_INLINE_NETWORK_1 eq smtp
    access-list Outside_access_in extended permit tcp any object BH2 object-group DM_INLINE_TCP_1
    access-list global_mpc extended permit ip any any
    access-list Inside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 any any
    pager lines 24
    logging enable
    logging asdm informational
    no logging message 106015
    no logging message 313001
    no logging message 313008
    no logging message 106023
    no logging message 710003
    no logging message 106100
    no logging message 302015
    no logging message 302014
    no logging message 302013
    no logging message 302018
    no logging message 302017
    no logging message 302016
    no logging message 302021
    no logging message 302020
    flow-export destination Inside 172.17.1.52 9996
    mtu Outside 1500
    mtu Inside 1500
    mtu management 1500
    ip local pool VPN 172.17.1.240-172.17.1.250 mask 255.255.255.0
    ip local pool VPN2 172.17.200.100-172.17.200.200 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    nat (Inside,Outside) source static EX2 Mail2
    nat (Inside,Outside) source static any any destination static NETWORK_OBJ_172.17.1.240_28 NETWORK_OBJ_172.17.1.240_28
    nat (Inside,Outside) source static any any destination static NETWORK_OBJ_172.17.200.0_24 NETWORK_OBJ_172.17.200.0_24
    nat (Inside,Outside) source static inside-net inside-net destination static NETWORK_OBJ_172.17.1.240_28 NETWORK_OBJ_172.17.1.240_28
    nat (Inside,Outside) source static LAN-NETWORKS LAN-NETWORKS destination static VPN-POOL VPN-POOL
    object network inside-net
    nat (Inside,Outside) dynamic interface
    object network NOSPAM
    nat (Inside,Outside) static 5.29.79.12
    nat (Outside,Outside) after-auto source dynamic VPN-CLIENT-PAT-SOURCE interface
    access-group Outside_access_in in interface Outside
    access-group Inside_access_in in interface Inside
    route Outside 0.0.0.0 0.0.0.0 5.29.79.9 1
    route Inside 10.2.0.0 255.255.255.0 172.17.1.1 1
    route Inside 10.3.0.0 255.255.255.128 172.17.1.1 1
    route Inside 10.10.10.0 255.255.255.0 172.17.1.1 1
    route Inside 172.17.100.0 255.255.255.0 172.17.1.3 1
    route Inside 172.18.1.0 255.255.255.0 172.17.1.1 1
    route Inside 192.168.1.0 255.255.255.0 172.17.1.1 1
    route Inside 192.168.11.0 255.255.255.0 172.17.1.1 1
    route Inside 192.168.30.0 255.255.255.0 172.17.1.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server RedVec protocol ldap
    aaa-server RedVec (Inside) host 172.17.1.41
    ldap-base-dn DC=adrs1,DC=net
    ldap-group-base-dn DC=adrs,DC=net
    ldap-scope subtree
    ldap-naming-attribute sAMAccountName
    ldap-login-password *****
    ldap-login-dn CN=Hanna\, Roger,OU=Humans,OU=WPLAdministrator,DC=adrs1,DC=net
    server-type microsoft
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 172.17.1.0 255.255.255.0 Inside
    http 24.32.208.223 255.255.255.255 Outside
    snmp-server host Inside 172.17.1.52 community *****
    snmp-server location Server Room 3010
    snmp-server contact Roger Hanna
    snmp-server community *****
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map Outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map Outside_map interface Outside
    crypto ikev1 enable Outside
    crypto ikev1 policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 30
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet 172.17.1.0 255.255.255.0 Inside
    telnet timeout 5
    ssh 172.17.1.0 255.255.255.0 Inside
    ssh timeout 5
    console timeout 0
    dhcpd address 172.17.1.100-172.17.1.200 Inside
    dhcpd dns 172.17.1.41 172.17.1.42 interface Inside
    dhcpd lease 100000 interface Inside
    dhcpd domain adrs1.net interface Inside
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    webvpn
    group-policy RedV internal
    group-policy RedV attributes
    wins-server value 172.17.1.41
    dns-server value 172.17.1.41 172.17.1.42
    vpn-tunnel-protocol ikev1
    default-domain value ADRS1.NET
    group-policy RedV_1 internal
    group-policy RedV_1 attributes
    wins-server value 172.17.1.41
    dns-server value 172.17.1.41 172.17.1.42
    vpn-tunnel-protocol ikev1
    split-tunnel-policy tunnelspecified
    default-domain value adrs1.net
    username rparker password FnbvAdOZxk4r40E5 encrypted privilege 15
    username rparker attributes
    vpn-group-policy RedV
    username mhale password 2reWKpsLC5em3o1P encrypted privilege 0
    username mhale attributes
    vpn-group-policy RedV
    username dcoletto password g53yRiEqpcYkSyYS encrypted privilege 0
    username dcoletto attributes
    vpn-group-policy RedV
    username rhanna password Pd3E3vqnGmV84Ds2 encrypted privilege 15
    username rhanna attributes
    vpn-group-policy RedV
    tunnel-group RedV type remote-access
    tunnel-group RedV general-attributes
    address-pool VPN2
    authentication-server-group RedVec
    default-group-policy RedV
    tunnel-group RedV ipsec-attributes
    ikev1 pre-shared-key *****
    class-map global-class
    match access-list global_mpc
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
    class global-class
      flow-export event-type all destination 172.17.1.52
    service-policy global_policy global
    prompt hostname context
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    hpm topN enable
    Cryptochecksum:202ad58ba009fb24cbd119ed6d7237a9

    Hi Roger,
    I bet you already checked it, but does the MPLS end router has route to VPN client subnet 172.17.200.x (or default) pointing to core rtr)?
    Also, if the MPLS link has any /30 subnet assigned, you may need to include that as well in Object group LAN-NETWORKS.
    Thx
    MS

  • Problem With Assignment, Need Tips

    Hi, i'll try and keep the code to a minimum. My assignment (at UNI) is to create a JUG Program (Java Ultimate Graphist) which works like a paint program.
    So far ive done most of it. But im having problems with combo boxes. Basically its required to have a combo box at the bottom where you choose your shape (rectangle, line, ellipse etc etc). When you choose your shape, and click on the screen, it draws that shape.
    This is the bit thats troubling me. The way ive programmed it, (we're using frames) I have one file "Application.java" which runs everything. Another file "Settings.java" which holds most of my methods as well as the control panel (for combo boxes) at the bottom, and a menu bar at the top.
    The final file is the actual drawing panel - "PaintPanel.java". This has the paint method etc in it.
    Now the problem im having is getting the combo box (Prefrences.java) to interact with the "PaintPanel.java". If i could put all this in one file it would probably work but i just get errors and it just wont work.
    Does anyone know how i can make an action listener, listen for my choice in the combo box, then change the shape drawn in the paint panel.
    I can post the entire code if you want it
    Thanks!

    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    public class ClassCommunication
        DrawingCode drawCode;
        EventCode eventCode;
        public ClassCommunication()
            // pass a reference of/for/to the DrawingCode instance
            // to EventCode that EventCode can use to call methods
            // in the DrawingCode class
            drawCode = new DrawingCode();
            eventCode = new EventCode(drawCode);
        private JPanel getCenterPanel()
            return drawCode;
        private JPanel getSouthPanel()
            return eventCode.getUIPanel();
        public static void main(String[] args)
            ClassCommunication app = new ClassCommunication();
            JFrame f = new JFrame();
            f.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
            f.getContentPane().add(app.getCenterPanel());
            f.getContentPane().add(app.getSouthPanel(), "South");
            f.setSize(300,175);
            f.setLocation(200,200);
            f.setVisible(true);
    class DrawingCode extends JPanel
        String s;
        public DrawingCode()
            s = "hello world";
        public void setString(String s)
            this.s = s;
            repaint();
        protected void paintComponent(Graphics g)
            super.paintComponent(g);
            g.setFont(g.getFont().deriveFont(18f));
            g.drawString(s, 100, 50);
    class EventCode implements ActionListener
        DrawingCode drawCode;
        public EventCode(DrawingCode dc)
            drawCode = dc;
        public void actionPerformed(ActionEvent e)
            JComboBox cb = (JComboBox)e.getSource();
            String s = (String)cb.getSelectedItem();
            drawCode.setString(s);
        public JPanel getUIPanel()
            String[] items = { "rectangle", "ellipse", "line" };
            JComboBox combo = new JComboBox(items);
            combo.addActionListener(this);
            JPanel panel = new JPanel();
            panel.add(combo);
            return panel;
    }

  • Having problems with Bridge shutting down after saving photo in PS Cs5,,,,,,,,,  Also when i attempt to update either PS or bridge get an error message in Adobe application manger "Error loading updater workflow"

    Having problems with Bridge shutting down after saving photo in PS Cs5,,,,,,,,,  Also when i attempt to update either PS or bridge get an error message in Adobe application manger "Error loading updater workflow"

    Sorry for the late reply. My email firewall has become a little over zealous & sent a lot of my emails straight to my junk email folder, so I have only just now discovered your reply in my junk mail folder.
    The only "don't open files exceeding xxx megabytes" instruction I can find in my Prefs, is in the Bridge Prefs for Thumbnails, & mine is set at 1000mb. The biggest files I handle are bigger than 200mb so I should be able to open a few, not just one.
    However, this doesn't explain why I can open a psd format file of 180mb, close it, but then can't open a RAW format file of only 26mb immediately after.
    I can open the RAW file only if I restart my computer - very annoying!
    However, thanks for the advice about the video card & memory.
    So, I'm still stuck as to what the issue is.

  • Is anyone having problems with the battery heating up and draining the power?  Mine has been doing this for about 2 months now.

    Is anyone having problems with the battery heating up and draining the power?  Mine has been doing this for about 2 months now.

    This is a major problem with Lollipop, but yo said it started 2 months ago.   Several people have fixed problem by removing FaceBook And Face book messenger and then re loading the apps again.   You might want to clear your cache before reloading.  Not sure this is your problem, but worth a try.  Good Luck

  • I am having problems with creating my apple id. On the phone it is advising me that the ID is not created and then when i do it online it says that it has been created. Can you advise me on what to do please?

    I am having problems with creating my apple id. On the phone it is advising me that the ID is not created and then when i do it online it says that it has been created. Can you advise me on what to do please?

    Apple ID FAQ   http://support.apple.com/kb/HE37

  • HT1657 I am having problems with sound in my rental movies

    We rent movies all the time but lately we are having problems with sound for our movie rentals.  We watch the first half hour without a problem than the voice is choppy all the time.  Sometimes it is good for five minutes than noting for a while.  We  have tried everything we could think of with no avail.  I could see one movie but the last 5 or so have been the same.  Done trying we need to fix this!  Help!  Any ideas?

    First try resetting your iPad by simultaneously pressing and holding the Home and Sleep/Wake buttons until you see the Apple Logo. This can take up to 15 seconds so be patient and don't release the buttons until the logo appears. Try again to see if the problem persists.
    If you still have the same issue, it's possible that something is lodged in the earphone jack. This can cause the iPad to think earphones are plugged in when they are not. Use a vacuum to try to suck any dust, lint or other foreign matter from the jack. If that still doesn't work, try CAREULLY using a toothpick.

  • Hi Can anyone help. I'm having problem with FaceTime on my IPAD .It connects but cuts out Simolarly when someone calls me it connects , then cuts out ThanksBrian

    Hi Having problem with FACETIME on my IPAD Connects to call but then cuts out , similarly calls in connect &amp; cut out Can someone help. Brian

    My ipad is doing the same thing to it won't let me except a incoming call on Facebook and I don't know what to do

  • I am using my Ipad on a remote craftshow site and am having problems with battery lasting 8 hrs. Can I use a 12v rv battery to recharge it or atleast maintain the charg over longer periods of time? I have a dc adapter. thanks

    I am using my Ipad on a remote craftshow site and am having problems with battery lasting 8 hrs. Can I use a 12v rv battery to recharge it or at least maintain the charge over longer periods of time? I have a dc adapter. thanks

    You should be able to use the battery if you get a car type charger which recharges mobile devices.
    The full size iPads use a 10-12W charger, whereas the mini uses a 5W charger. Many car chargers only supply 5W. But at 5W, the car charger should give you some extra time on your iPad. It would be best to use a 10-12W car charger.
     Cheers, Tom

  • I am having problems with my music collection, after burning all of my music to the computer I organized it into folders and placed it in the iTunes Folder. Starting on a new computer now. I can get my music from old computer?

    I am having problems with my music collection, after burning all of my music to the computer I organized it into folders and placed it in the iTunes Folder. As of now i realize this was a mistake. Starting on a new computer now. I cant get my music to transfer from the itunes folder on the old computer? I keep getting error "Can't Read from the source file or disk." Whenever I got to folder properties its always checked read only. But when i play the song it works just fine. Im sure this is just because I added music into itunes folder but is there anyway to fix it?

    WMA files are 'window media audio' files, which is a Microsoft format. If you want to add them to your iTunes library on your Mac then you will need to convert them into a compatible format first. If you still have your windows machine then iTunes for Windows can convert them from WMA to MP3 format : https://discussions.apple.com/message/24158701#24158701
    Or try a search for, for example, 'convert wma to mp3' to find programs to convert them.

  • I am having problem with MDV Studio.

    Hello happy guys, whatzup? Guess all ya 'r doing fine? Right!
    I am using Dreamweaver from Macromedia Studio 2004. I am having problem with Inserting Record into Access database using the forms I create on my .asp document. I am using IIS and Javascript as my Document Technology. The error I usually have is:
    "Technical Information (for support personnel)
    Error Type:
    Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
    [Microsoft][ODBC Microsoft Access Driver] Operation must use an updateable query.
    /site_files/user_regform.asp, line 78
    Browser Type:
    Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.5 (KHTML, like Gecko) Chrome/2.0.172.28 Safari/530.5
    Page:
    POST 41 bytes to /site_files/user_regform.asp
    POST Data:
    uname=Honesty&pword=admin&MM_insert=form1
    Time:
    Tuesday, June 02, 2009, 1:49:39 PM"
    Please I need assistance on how to solve this problem. Thank you.
    Similarly, I don't really know how to write sql strings - I just give commands and Dreamweaver will generate the sql strings. Yet, I still observe errors. But I think, for the sql aspect, I'm undergoing a tutorial note that I downloaded on the internet.
    Please help me to solve this error problem at the moment. The sql knowledge is not the problem. I can get that at my leisure.
    Thank you.
    Eyo Eyo (Nigeria).

    It sounds like you do not have an internet connection (wifi arcs in the upper left does not mean you have a connection) since Safari does not work also.. Try the following:
    - Reset the iPod. Nothing will be lost.
    Reset iPod touch:  Hold down the On/Off button and the Home button at the same time for at
    least ten seconds, until the Apple logo appears.
    - Power off and then back on the router
    - Reset networks settings: Settings>General>Reset>Reset Network Settings
    - iPhone and iPod touch: Troubleshooting Wi-Fi networks and connections

  • I am having problems with my itunes, when plugging my iphone or ipod to the laptop - i can see iphone/ipod in the top right corner of itunes but when i click this to the see what is on theis iphone/ipod the option is no longer there, this was working

    I am having problems with the new itunes set up ........
    when i plug in my iphone or ipod touch it shows in the top right hand corner of itunes
    BUT when i click on the shown iphone/ipod the icon its no longer there, i was useing this fine yesterday and it was showing yesterday what is on this ipod and would allow me to add/remove music, but now this option is no longer availlable - i have added a couple of albums to my itunes i can listen to the music from the laptop but cannot sync the ipods to trancefer these albums to the handheld devices -
    i have been trying to sort this all day with no luck not sure if there is a problems with itunes or is it something i am doing ????
    HELP !!!!!!!!!!!!

    BOB we need you urgently
    Perhaps Bob will see this thread, he is the professor in these cases.
    You do not use a WEP password but wpa/wpa2 on router and equipment.
    All equipment connects to WiFi, but for your iPad.
    Even with all other equipment WiFi off, you cannot connect your iPad.
    Your iPad connects to other WiFi nets correctly.
    All resets etc done on iPad and Router.
    Still I am not sure it is your router for sure, frustrating...
    I want to test 2 other things:
    1. in your iPad, set everything OFF in Settings/Cellular, turn off/then/on your WiFi, and see whether it will still not connect...
    2. If that does not do it: disconnect the router as well as the modem from the power, for 15 seconds, then reconnect the modem, let it fully start, then reconnect the routet let it fully start, turn of your WiFi in iPad, then on, and see whether it will connect.

  • I am having problem with me Iphone4, looks like the mic of my phone is not working. no one can hear me if I make a call to them

    Can any one please help me I am having problem with me Iphone4, looks like the mic of my phone is not working. no one can hear me if I make a call to them. I have tried all restoring options but no use. please help me

    The mic on my iPhone4 has just quit also. Similar symptoms to yours in that people I'm talking to hear only static or my voice very faintly. The voice/memo recorder also only really records static.
    It happened suddenly and seemed to get better after a day or two but then went completely after another day.
    I'm returning it to Vodafone New Zealand shortly but will have to wait 5-10 days for a replacement. There are NO Apple accredited means to speed this procedure up in NZ.
    We don't even have a single physical Apple Store where you could walk in and talk to a Genius.

  • I am having problems with the Preview application.  When I try to use it to open a pdf document it gets hung-up and I have to select force quit to close it.   Any ideas on how to resolve this problem?  Thanks for any help

    I am having problems with the Preview application.  When I try to use it to open a pdf document it gets hung-up and I have to select force quit to close it.   Any ideas on how to resolve this problem?  Thanks for any help

    Can you open the Preview program without loading a file, like by itself?
    If it doesn't load then I suspect a corrupt Preview preference file.
    Deleting the System Preference or other .plist file
    Can you open other files with Preview, like jpg's and images?
    How about other PDFs? or is it just that one you have downloaded?
    Run through this list of fixes
    Step by Step to fix your Mac

Maybe you are looking for

  • How can I add a custom footnote at the beginning of my document?

    Hi, I need to start a document adding my credentials using a custom footnote (the traditional * footnote...), but can't seem to do that without having to change the whole numbering of the other footnotes in the document. Is there any way to do it?

  • Apple TV no longer works off-line

    Trying to figure out if this is just me. It is normal for me to power down my modem at night but leave my router on-line. Previously this has not caused a problem with my apple TV since the network is up still just no internet access. I did it tonigh

  • Field length in internal table

    hi, how to selt field length in internal table?. i have created on report the report out puts down load to using download function . the out format is: op1  op2   op3      op4 1     3       4                i want op1   op2   op3       op4 1         

  • Help!  iMac G5 no longer turns on!

    Hey Guys, i hope you're all well on this fine Monday! Over the last week my iMac G5 has been acting a little peculiarly - as in, heading downstairs to make a cup of coffee, only to return to find that it has merrily turned itself off. This was worryi

  • X1 Carbon restore after Win 8 clean install

    I've tried to boot to the F11 recovery, but the system will not boot to the recovery partition - and it is there. Is it possible to still boot to that partition and recover the original Windows OS or will I need to get recovery media some other way?