Help! How to communicate 2 beans which r in different Servers

Hi There,
Here is my problem. I have IBM WebSphere running on os/390 and I have sun J2ee server running on win2k. I want to call a bean on j2ee server from a bean running on websphere server any help, reference, link is appreciated.
-regards

SOAP is a really easy way to do that. http://xml.apache.org/soap/

Similar Messages

  • [Seeking help] How to create a bean with annotations @ runtime?

    I would like 2 create a bean, @ runtime, as below:
    public class A {
      @MyAnnotation(id = "ID")
      private String id = "";
      public String getId() { ... }
      public void setId(String id) { ... }
    }Can anyone tell me how 2 achieve this? I know how 2 create a bean dynamically, however with annotations it is a bit tricky ..
    Cheers!
    Edited by: olove66 on Aug 7, 2009 2:00 AM

    @_@ I guess anyone interested in this topic can turn 2 ASM. Maybe BCEL has not got anything 2 support annotation creation yet.

  • How to deploy sharepoint central administration 2013 in different servers

    I want to deploy sharepoint central administration 2013 in different servers, So if one service is down in sever. It is up in other server.
    How I can achieve this.
    Thanks,
    Siva

    Yes. 
    http://www.mssharepointtips.com/tip.asp?id=1006
    http://blog.fpweb.net/how-to-run-sharepoint-central-admin-on-two-servers/#.VLSH_CuUeIU
    Thanks, Ashish | Please mark a post helpful/answer if it is helpful or answer your query.

  • How to use composite entities which driven by different PU via hibernate

    Hi experts,
    There are 2 different persistence unit in my project.
    PU_A: Application entities, that can execute all crud operations.
    PU_B: This one has some views which contains outside data. I can just read data from here
    But i want to create foreign key in some entities which are in PU_A by using immutable-entity which managed by PU_B persistence-unit.
    If you could view on following snippets. I have IncomingPaperwork entity which is driven by PU_A and ProjectView which is driven by PU_B.
    After i applied this issue; When deploy the application exception that is below occured :
    30-Jan-2013 15:13:05 o'clock EET> <Warning> <Deployer> <BEA-149078> <Stack trace for message 149004
    weblogic.application.ModuleException:
         at weblogic.ejb.container.deployer.EJBModule$1.execute(EJBModule.java:326)
         at weblogic.deployment.PersistenceUnitRegistryInitializer.setupPersistenceUnitRegistries(PersistenceUnitRegistryInitializer.java:62)
         at weblogic.servlet.internal.WebAppModule.initPersistenceUnitRegistry(WebAppModule.java:411)
         at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:365)
         at weblogic.application.internal.flow.ScopedModuleDriver.prepare(ScopedModuleDriver.java:176)
         Truncated. see log file for complete stacktrace
    Caused By: org.hibernate.AnnotationException: @OneToOne or @ManyToOne on com.acme.model.entity.IncomingPaperwork.projectView references an unknown entity: com.acme.integrationmodel.entity.ProjectView
         at org.hibernate.cfg.ToOneFkSecondPass.doSecondPass(ToOneFkSecondPass.java:81)
         at org.hibernate.cfg.AnnotationConfiguration.processEndOfQueue(AnnotationConfiguration.java:456)
         at org.hibernate.cfg.AnnotationConfiguration.processFkSecondPassInOrder(AnnotationConfiguration.java:438)
         at org.hibernate.cfg.AnnotationConfiguration.secondPassCompile(AnnotationConfiguration.java:309)
         at org.hibernate.cfg.Configuration.buildMappings(Configuration.java:1162)
         Truncated. see log file for complete stacktrace
    >
    [03:13:05 PM] #### Deployment incomplete. ####
    Is there a way to achieve this? Any suggestions?
    Thanks in advance
    ___persistence.xml___
    <persistence xmlns="http://java.sun.com/xml/ns/persistence"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_2_0.xsd"
    version="2.0">
    <persistence-unit name="PU_A" transaction-type="JTA">
    <description>This unit manages all application entities</description>
    <provider>org.hibernate.ejb.HibernatePersistence</provider>
    <jta-data-source>jdbc/A_DS</jta-data-source>
    <class>com.acme.model.entity.IncomingPaperwork</class>
    <properties>
    <property name="hibernate.jndi.url" value="t3://localhost:7101"/>
    <!--DataSource-->
    <property name="hibernate.connection.datasource"
    value="jdbc/A_DS"/>
    <property name="hibernate.transaction.manager_lookup_class"
    value="org.hibernate.transaction.WeblogicTransactionManagerLookup"/>
    <property name="hibernate.dialect"
    value="org.hibernate.dialect.Oracle10gDialect"/>
    <property name="hibernate.hbm2ddl.auto" value="update"/>
    <property name="hibernate.show_sql" value="true"/>
    <property name="hibernate.format_sql" value="true"/>
    <property name="hibernate.use_sql_comments" value="true"/>
    <property name="hibernate.current_session_context_class" value="jta"/>
    <property name="hibernate.archive.autodetection" value="jar,class"/>
    </properties>
    </persistence-unit>
    <persistence-unit name="PU_B" transaction-type="JTA">
    <description>This unit manages all integration entities</description>
    <provider>org.hibernate.ejb.HibernatePersistence</provider>
    <jta-data-source>jdbc/B_DS</jta-data-source>
    <class>com.acme.integrationmodel.entity.ProjectView</class>
    <properties>
    <property name="hibernate.jndi.url" value="t3://localhost:7101"/>
    <!--DataSource-->
    <property name="hibernate.connection.datasource"
    value="jdbc/B_DS"/>
    <property name="hibernate.transaction.manager_lookup_class"
    value="org.hibernate.transaction.WeblogicTransactionManagerLookup"/>
    <property name="hibernate.dialect"
    value="org.hibernate.dialect.Oracle10gDialect"/>
    <property name="hibernate.hbm2ddl.auto" value="validate"/>
    <property name="hibernate.show_sql" value="true"/>
    <property name="hibernate.format_sql" value="true"/>
    <property name="hibernate.use_sql_comments" value="true"/>
    <property name="hibernate.current_session_context_class" value="jta"/>
    </properties>
    </persistence-unit>
    </persistence>
    ___IncomingPaperwork.class___
    import com.arsivist.structure.BaseEntity;
    import com.acme.integrationmodel.entity.ProjectView;
    import com.acme.model.entity.listener.EntityListener;
    import com.acme.model.entity.listener.IncomingPaperworkListener;
    import javax.persistence.Column;
    import javax.persistence.Entity;
    import javax.persistence.EntityListeners;
    import javax.persistence.GeneratedValue;
    import javax.persistence.GenerationType;
    import javax.persistence.Id;
    import javax.persistence.JoinColumn;
    import javax.persistence.ManyToOne;
    import javax.persistence.SequenceGenerator;
    import javax.persistence.Table;
    @Entity(name = "IncomingPaperwork")
    @Table(name = "INCOMINGPAPERWORKS")
    @SequenceGenerator(name = "INCOMINGPAPERWORK_SEQ", sequenceName = "INCOMINGPAPERWORK_SEQ", allocationSize = 1)
    @EntityListeners( { EntityListener.class, IncomingPaperworkListener.class })
    public class IncomingPaperwork extends BaseEntity
    private Company company;
    private ProjectView projectView;
    public IncomingPaperwork()
    entityName = "IncomingPaperwork";
    @Id
    @GeneratedValue(strategy = GenerationType.SEQUENCE, generator = "INCOMINGPAPERWORK_SEQ")
    @Column(name = "ID")
    public int getId()
    return id;
    public void setId(int id)
    this.id = id;
    public void setCompany(Company company)
    this.company = company;
    @ManyToOne(targetEntity = com.acme.model.entity.Company.class, cascade = { })
    @JoinColumn(name = "COMPANYID", nullable = false)
    public Company getCompany()
    return company;
    public void setProjectView(ProjectView projectView)
    this.projectView = projectView;
    @ManyToOne(targetEntity = com.acme.integrationmodel.entity.ProjectView.class, cascade = { })
    @JoinColumn(name = "PROJECTVIEWID")
    public ProjectView getProjectView()
    return projectView;
    ___ProjectView.class___
    import com.arsivist.structure.BaseEntityView;
    import javax.persistence.Column;
    import javax.persistence.Entity;
    import javax.persistence.Id;
    import org.hibernate.annotations.Immutable;
    import org.hibernate.annotations.Subselect;
    @Entity(name = "ProjectView")
    @Immutable
    @Subselect("SELECT * FROM ProjectView")
    public class ProjectView extends BaseEntityView
    private String code;
    private String name;
    public ProjectView()
    entityName = "ProjectView";
    public ProjectView(int id, String name)
    entityName = "ProjectView";
    this.id = id;
    this.name = name;
    @Id
    @Column(name = "ID")
    public int getId()
    return id;
    public void setId(int id)
    this.id = id;
    public void setCode(String code)
    this.code = code;
    @Column(name = "CODE")
    public String getCode()
    return code;
    public void setName(String name)
    this.name = name;
    @Column(name = "NAME")
    public String getName()
    return name;
    @Override
    public String toString()
    return "" + getName();
    Edited by: webyildirim on Jan 30, 2013 5:36 AM

    Not quite what I meant - I was suggesting you load the entity immediately after reading it from PU_B, or anytime before associating it into PU_A, so before the merge. What you have not shown though is any code on how you are obtaining IntegrationDepartment and integrating it into PU_A, or what you mean by it is returning a refreshed version of Topic. This problem could also be the result of how your provider works internally - this is a TopLink/EclipseLink forum post so I cannot really tell you why you get the exception other than it would be expected to work as described with EclipseLink as the JPA provider.
    So the best suggestions I can come up with are prefetch your entity, try posting in a hibernate forum, or try using EclipseLink/TopLink so someone here might be better able to help you with any problems that arise.
    Best Regards,
    Chris

  • How to access two entity managers from two different servers?

    Hello
    My test programm is trying to access two glassfish application servers (gf 2.1). The code base of these servers is the same, the persistence layers are just accessing different databases -> one ist the staging/test system, the other the live server.
    After setting the connection and obtaining the em via the class persistence i can not fetch the em from the other system.
              properties.setProperty("org.omg.CORBA.ORBInitialHost", "host1");
              properties.setProperty("org.omg.CORBA.ORBInitialPort", "port1");
                    InitialContext ctx = new InitialContext(properties);
              entityManagerFactory1 = Persistence.createEntityManagerFactory("pu/refdata");               
              entityManager1 = entityManagerFactory.createEntityManager();After that Persistence seems to have been bound to host1 forever, so i can not fetch a reference to the em of host2. There is another createEntityManagerFactory method accepting a map but i dont find any reference for the properties, maybe that would help - dont know.
    Regardless of what i do, any further call to Persistence.createEntityManagerFactory returns the handle of entityManagerFactory1.
    Regards

    I want to use the EntityManagers bound to the DataSources provided by different app servers.
    Below you find an example persistence.xml with three entries. 1 & 2 have the same jta data source, 3 is different.
    My point is that Persistence binds the new factory in a wrong way if the jta data source String has already been resolved.
    If a progamm sets connection properties for app server 1 and fetches an entityManagerFactory for pu/refdata_Live, then sets connection properties for app server 2 with pu/refdata_Test they get different factory instances bound to the same server, in this case app server 1.
    If i know set the connection properties for app server 3 with pu/refdata3 Persistence sees that the jta data source "dbc/ref3" has not yet been resolved and tries to connect to the app server 3. Which it should have done for app server 2 too.
    <persistence-unit name="pu/refdata_Live" transaction-type="JTA">
         <provider>oracle.toplink.essentials.PersistenceProvider</provider>
        <jta-data-source>jdbc/ref</jta-data-source>
        <properties>
          <property name="toplink.ddl-generation" value="none"/>
        </properties>
      </persistence-unit>
        <persistence-unit name="pu/refdata_Test" transaction-type="JTA">
        <provider>oracle.toplink.essentials.PersistenceProvider</provider>
        <jta-data-source>jdbc/ref</jta-data-source>
        <properties>
          <property name="toplink.ddl-generation" value="none"/>
        </properties>
      </persistence-unit>
        <persistence-unit name="pu/refdata3" transaction-type="JTA">
        <provider>oracle.toplink.essentials.PersistenceProvider</provider>
        <jta-data-source>jdbc/ref3</jta-data-source>
        <properties>
          <property name="toplink.ddl-generation" value="none"/>
        </properties>
      </persistence-unit>

  • How can I sync my iPhone on a different computer without erasing my applications? My iPhone was earlier synced with a PC which I don't use anymore. Please help with proper steps, if any.

    How can I sync my iPhone on a different computer without erasing my applications? My iPhone was earlier synced with a PC which I don't use anymore.
    On the new computer, I am getting a message that my all purchases would be deleted if I sync it with new iTunes library.
    Please help with proper steps, if any.

    Also see... these 2 Links...
    Recovering your iTunes library from your iPod or iOS device
    https://discussions.apple.com/docs/DOC-3991
    Syncing to a New Computer...
    https://discussions.apple.com/docs/DOC-3141

  • How to display an Image which is on Panel behind JScrollPane - Please Help

    Hiii All,
    How to display an Image which is on Panel behind JScrollPane. I have set the setOpaque() method of JScrollPane to false still when i run the program the JScrollPane is set as Opaque.. Can some one please help me in this...
    Thanks,
    Piush

    you need to set both
    scrollPane.setOpaque(false);
    scrollPane.getViewport().setOpaque(false);

  • Please Help,how do i get my iphone 4 to play all my songs from icloud, it is currently only playing just a smal number of songs from my library which is stored in icloud.

    Please Help,how do i get my iphone 4 to play all my songs from icloud, it is currently only playing just a smal number of songs from my library which is stored in icloud.

    There are a number of OS X apps, many free, that will save your messages, allowing to view and print them. 
    http://www.softwarebbs.com/wiki/How_to_transfer_SMS_from_iPhone_to_Mac,_backup_i Phone_SMS_message_on_Mac
    Google, for other options
    Your "other" of 6 GB may include corrupted data or file sytem errors. If after removing the messages there is still >2GB, you will need to restore the phone in iTunes, first using a backup (made after deleting the messages) and if needed as a new iPhone.
    iTunes: Restoring iOS software

  • How to track beans which are destroyed, but no exception log?

    According to the WLS console, we have two out of about 30 entity beans
    which have instances which are being destroyed. However, I cannot find
    the exception which is causing them to be destroyed. I see nothing in
    the WLS logs, nothing in our own logs, nothing, nothing, nothing.
    I am wondering if this might be because for those two beans, there are
    finder methods which are being invoked, and which may not find anything,
    in which case the exception is caught and processing continues
    appropriately. Is this a scenario where a bean instance might be created
    and then destroyed?
    Any ideas on how I can determine why these beans on being destroyed, if
    the above scenario does not apply?
    Thanks!

    Well, there are only 2 paths to 'does not exist' in the spec.
    unsetEntityContext or system exception. If unsetEntityContext isn't being
    called, then it must be a system exception. If that isn't being logged, the
    container isn't obeying the spec. If a FinderException is causing the
    destruction of the instance, that isn't spec compliant, either. A
    reproducible test case and a support call may be your best course of action.
    Bill
    "Jay Schmidgall" <no@spam> wrote in message news:41dd5bd9$1@mail...
    Well, I put logging in the unsetEntityContext method and it is
    apparently not being called; max-beans-in-cache is not explicity set, so
    it defaults to 1000, I believe, and the console tells me the cached
    beans current count is under 50 for both.
    On the other hand, the scenario I suggested does seem to cooincide well
    with the destroyed count; that is, after the bean is not found by the
    finder, the destroyed count goes up. From your description, that seems
    like it is just coincidence, but it is definitely there.
    bill kemp wrote:
    Finder methods are called on a pooled instance of the bean. If the
    finder
    doesn't find the entity, a FinderException(which is just an application
    exception) should be thrown, which is reported to the client, but the
    instance is not destroyed. If a system exception is thrown, thecontainer is
    supposed to log it before it destroys the instance. The only other pathto
    destruction in the state diagram is when the bean goes from 'pooled' to
    'does not exist' when the container calls the unsetEntityContext method.So,
    maybe put some output code in the unsetEntityContext method to see ifthe
    container is removing beans because of cache size considerations. Just a
    guess. Do you have <max-beans-in-cache> set to anything in particular?

  • How to change MANAGED-BEAN-SCOPE??????

    Hi Gurus,
    How to change the managed-bean-scope? In my ADF application I have created one backing bean which has attched with the page fragment. I cant able to set the bean scope other than REQUEST....
    If I set the bean scope request, then page and the inside fragment is rendering without any error. But I need to make that bean scope to pageFlow... but if I do, getting the below error. Non of the scopes are working except request... Please help me how to set the other scope which will solve my major development issue!!!!
    Error:
    Error trying to include:viewId:/advsearch-flow-definition/advUserSearch uri:/app/advUserSearch.jsffjavax.faces.FacesException: javax.el.PropertyNotFoundException: Target Unreachable, identifier 'UserSearch' resolved to null
    My ADFC-Config.xml:
    <?xml version="1.0" encoding="ISO-8859-1" ?>
    <adfc-config xmlns="http://xmlns.oracle.com/adf/controller" version="1.2">
    <managed-bean>
    <managed-bean-name>backing_app_idm</managed-bean-name>
    <managed-bean-class>edu.syr.oim.backing.app.Idm</managed-bean-class>
    <managed-bean-scope>backingBean</managed-bean-scope>
    <!--oracle-jdev-comment:managed-bean-jsp-link:1app/idm.jspx-->
    </managed-bean>
    <managed-bean>
    <managed-bean-name>backing_app_userMgmt</managed-bean-name>
    <managed-bean-class>edu.syr.oim.backing.app.UserMgmt</managed-bean-class>
    <managed-bean-scope>backingBean</managed-bean-scope>
    <!--oracle-jdev-comment:managed-bean-jsp-link:1app/userMgmt.jspx-->
    </managed-bean>
    *<managed-bean>*
    *<managed-bean-name>UserSearch</managed-bean-name>*
    *<managed-bean-class>edu.syr.oim.backing.app.UserSearch</managed-bean-class>*
    *<managed-bean-scope>request</managed-bean-scope>*
    *</managed-bean>*
    </adfc-config>
    -kln
    Edited by: klogube on Jan 14, 2010 7:23 AM

    *public class UserSearch {*
    private RichTable searchResultTable;
    private Row currentRow;
    private String selectedNetID;
    private RichInputText inputOne;
    private RichInputText inputTwo;
    private RichInputText inputThree;
    private RichSelectOneChoice choiceOne;
    private RichSelectOneChoice choiceTwo;
    private RichSelectOneChoice choiceThree;
    private RichRegion region;
    private String choiceOneVal;
    private String choiceTwoVal;
    private String choiceThreeVal;
    DCBindingContainer bindings;
    int choiceOneRowIndex;
    int choiceTwoRowIndex;
    int choiceThreeRowIndex;
    Row choiceOnerw;
    Row choiceTworw;
    Row choiceThreerw;
    String choiceOneUserSelected = null;
    String choiceTwoUserSelected = null;
    String choiceThreeUserSelected = null;
    static String  txnTypeOne  = null;
    static String  txnTypeTwo  = null;
    static String  txnTypeThree  = null;
    String netid;
    RequestContext requestContext = RequestContext.getCurrentInstance();
    HashMap rcBackupHM = new HashMap();
    FacesContext facesContext = FacesContext.getCurrentInstance();
    Application app = facesContext.getApplication();
    ExpressionFactory elFactory = app.getExpressionFactory();
    ELContext elContext = facesContext.getELContext();
    FacesContext fc = FacesContext.getCurrentInstance();
    HttpServletRequest request = (HttpServletRequest)fc.getExternalContext().getRequest();
    HttpSession session = request.getSession();
    *public UserSearch() {*
    *public String userSelected() {*
    FacesCtrlHierNodeBinding binding = (FacesCtrlHierNodeBinding) searchResultTable.getSelectedRowData();
    currentRow = binding.getRow();
    selectedNetID = (String) currentRow.getAttribute("netid");
    requestContext.getPageFlowScope().put("netid",selectedNetID);
    return "goToDetails";
    ** Invoke this method when user double click the row in searchResult*
    *public void doDbClick(ClientEvent clientEvent) {*
    FacesCtrlHierNodeBinding binding = (FacesCtrlHierNodeBinding) searchResultTable.getSelectedRowData();
    currentRow = binding.getRow();
    selectedNetID = (String) currentRow.getAttribute("netid");
    requestContext.getPageFlowScope().put("netid",selectedNetID);
    *try{*
    FacesContext facesCtx = FacesContext.getCurrentInstance();
    NavigationHandler nh = facesCtx.getApplication().getNavigationHandler();
    nh.handleNavigation(facesCtx, "", "goDetails");
    *// Refresh the current region; advse1 is the id of the region component inside jspx page*
    AdfFacesContext.getCurrentInstance().addPartialTarget(region);
    *catch(Exception e){ }*
    *public void setSearchResultTable(RichTable searchResultTable) {*
    this.searchResultTable = searchResultTable;
    *public RichTable getSearchResultTable() {*
    return searchResultTable;
    *public void setInputOne(RichInputText inputOne) {*
    this.inputOne = inputOne;
    *public RichInputText getInputOne() {*
    return inputOne;
    *public void setInputTwo(RichInputText inputTwo) {*
    this.inputTwo = inputTwo;
    *public RichInputText getInputTwo() {*
    return inputTwo;
    *public void setInputThree(RichInputText inputThree) {*
    this.inputThree = inputThree;
    *public RichInputText getInputThree() {*
    return inputThree;
    *public void setChoiceOne(RichSelectOneChoice choiceOne) {*
    this.choiceOne = choiceOne;
    *public RichSelectOneChoice getChoiceOne() {*
    return choiceOne;
    *public void setChoiceTwo(RichSelectOneChoice choiceTwo) {*
    this.choiceTwo = choiceTwo;
    *public RichSelectOneChoice getChoiceTwo() {*
    return choiceTwo;
    *public void setChoiceThree(RichSelectOneChoice choiceThree) {*
    this.choiceThree = choiceThree;
    *public RichSelectOneChoice getChoiceThree() {*
    return choiceThree;
    *public void setChoiceOneVal(String choiceOneVal) {*
    this.choiceOneVal = choiceOneVal;
    *public String getChoiceOneVal() {*
    return choiceOneVal;
    *public void setChoiceTwoVal(String choiceTwoVal) {*
    this.choiceTwoVal = choiceTwoVal;
    *public String getChoiceTwoVal() {*
    return choiceTwoVal;
    *public void setChoiceThreeVal(String choiceThreeVal) {*
    this.choiceThreeVal = choiceThreeVal;
    *public String getChoiceThreeVal() {*
    return choiceThreeVal;
    *public void setRegion(RichRegion region) {*
    this.region = region;
    *public RichRegion getRegion() {*
    return region;
    Can you please explain how to define the 2nd bean in the pageFlowScope and injnect?...bacially my problem is I am loosing the pageFlowScope value when I navigate from first page to next page which I am setting by this above class....I need to carry forward the netid which I am losing ...any idea plz

  • How do the Entity Bean in SUN J2EE1.3 Connect to Oracle Database9i

    I can connect to Database in my applications with codes:
    Connection conn = DriverManager.getConnection(
    "jdbc:oracle:thin:@172.28.200.43:1521:s
    hcd",
    "system", "manager");
    Statement stmt = conn.createStatement();
    But I can not connect to DB in my EJB, I have config J2EE1.3
    Server and my EJB
    1.in EJB,the code is:
    InitialContext ic = new InitialContext();
    DataSource ds = (DataSource) ic.lookup(dbName);
    con = ds.getConnection();
    2.When I assemble the EJB, I set Resource Refs for JNDI and fill
    user name, password
    3. modify the config/resource.propertities
    jdbcDataSource.5.name=jdbc/ora/test
    jdbcDataSource.5.url=jdbc:oracle:thin:@172.28.200.43:1521:shcd;cr
    eate=true
    when I use cloudscape, it runs OK(with JNDI jdbc/Cloudscape),
    but after i change to use Oracle , the EJB return a Exception:
    Caught an exception.
    java.rmi.ServerException: RemoteException occurred in server
    thread; nested exce
    ption is:
    java.rmi.RemoteException: nested exception is:
    javax.ejb.EJBException: U
    nable to connect to database. Io Exception: Connection refused
    (DESCRIPTION=(TMP=)(VSN
    NUM=150999297)(ERR=12505)(ERROR_STACK=(ERROR=(CODE=12505)
    (EMFI=4)))); nested exc
    eption is:
    javax.ejb.EJBException: Unable to connect to database.
    Io Exception: Connecti
    on refused(DESCRIPTION=(TMP=)(VSNNUM=150999297)(ERR=12505)
    (ERROR_STACK=(ERROR=(C
    ODE=12505)(EMFI=4))))
    java.rmi.RemoteException: nested exception is:
    javax.ejb.EJBException: Unable to
    connect to database. Io Exception: Connection refused
    (DESCRIPTION=(TMP=)(VSNNUM=1509
    99297)(ERR=12505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))));
    nested exception i
    s:
    javax.ejb.EJBException: Unable to connect to database.
    Io Exception: Connecti
    on refused(DESCRIPTION=(TMP=)(VSNNUM=150999297)(ERR=12505)
    (ERROR_STACK=(ERROR=(C
    ODE=12505)(EMFI=4))))
    javax.ejb.EJBException: Unable to connect to database. Io
    Exception: Connection refus
    ed(DESCRIPTION=(TMP=)(VSNNUM=150999297)(ERR=12505)(ERROR_STACK=
    (ERROR=(CODE=1250
    5)(EMFI=4))))
    <<no stack trace available>>

    Hi,
    Just run the db_setup.sh script located in the bin directory of ias
    If you just give the Oracle Home directory the libraries will be found.
    Register a Datasource pointing to the service you defined in tnsnames.ora
    Cheers, Robert
    Malay Biswas wrote:
    Hi,
    How can I configure native and third party database drivers for
    connecting to Oracle. The oracle client is set up. Also, which one is
    advisable to work with, third party or native? I am using iAS EE 6.0
    Test Drive on Solaris 8.0. Also I am not sure what should be the
    Client library file in this case for ORACL_OCI driver.
    I am trying to run a Entity bean which gives null pointer error while
    doing home.create() or home.findByPrimaryKey, and I don't know what's
    the problem, but my guess is it cannot find or instantiate the object
    since it cannot connect to the proper database.
    Could anybody help me with it?
    Thanks
    Malay
    Try our New Web Based Forum at http://softwareforum.sun.com
    Includes Access to our Product Knowledge Base!--
    Robert Schrijvers
    Javix Training & Software development
    e-mail: [email protected]
    website: www.javix.nl
    phone +31 (0) 629594749

  • How to communicate between UNI ports?

    Hi
    I have a new  ME3400 series switch with IOS (me340x-metrobase-mz.122-37.SE1), it has 24 fastethernet and 2 gig fiber uplinks
    Now all the ports except fiber uplinks are uni ports by default.
    So can't communicate with each other. Now i wishes to make them communicate while remaining in uni port-type.
    On forums the solution is to declare them as member of community vlan.
    My questions are
    1) can i no shut the secondry vlan interface?
    2) From which pool i have to give ip to my system either from primary vlan pool or secondry vlan pool?
    3) In both cases i can't communicate with the default gateway i.e: the ip of vlan even the port is member of community vlan. so how to communicate them while being in uni ports?
    The sh run of switch is below
    Switch#sh run
    Building configuration...
    Current configuration : 2088 bytes
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    hostname Switch
    no aaa new-model
    system mtu routing 1500
    ip subnet-zero
    no file verify auto
    spanning-tree mode rapid-pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    vlan 100
      private-vlan primary
      private-vlan association 101-102
    vlan 101
      private-vlan isolated
    vlan 102
      private-vlan community
    interface FastEthernet0/1
    switchport private-vlan host-association 100 101
    switchport mode private-vlan host
    interface FastEthernet0/2
    switchport access vlan 102
    switchport private-vlan host-association 100 102
    switchport mode private-vlan host
    interface FastEthernet0/3
    switchport private-vlan host-association 100 102
    switchport mode private-vlan host
    interface FastEthernet0/4
    shutdown
    interface FastEthernet0/5
    interface FastEthernet0/6
    shutdown
    interface FastEthernet0/7
    shutdown
    interface FastEthernet0/8
    shutdown
    interface FastEthernet0/9
    shutdown
    interface FastEthernet0/10
    shutdown
    interface FastEthernet0/11
    shutdown
    interface FastEthernet0/12
    shutdown
    interface FastEthernet0/13
    shutdown
    interface FastEthernet0/14
    shutdown
    interface FastEthernet0/15
    shutdown
    interface FastEthernet0/16
    shutdown
    interface FastEthernet0/17
    shutdown
    interface FastEthernet0/18
    shutdown
    interface FastEthernet0/19
    shutdown
    interface FastEthernet0/20
    shutdown
    interface FastEthernet0/21
    shutdown
    interface FastEthernet0/22
    shutdown
    interface FastEthernet0/23
    shutdown
    interface FastEthernet0/24
    shutdown
    interface GigabitEthernet0/1
    port-type nni
    interface GigabitEthernet0/2
    port-type nni
    interface Vlan1
    ip address 192.168.0.1 255.255.255.0
    no ip route-cache
    interface Vlan100
    ip address 10.10.100.1 255.255.255.0
    no ip route-cache
    interface Vlan101
    no ip address
    no ip route-cache
    shutdown
    interface Vlan102
    no ip address
    no ip route-cache
    shutdown
    no ip http server
    control-plane
    line con 0
    line vty 5 15
    end
    Any help will be apritiated and thanks in advance

    njb7ty wrote:
    Create two separate connection pools. Each one has its own url/userID/password to its own database. Example: If both are Oracle databases, you need the JDBC driver jar file in your classpath. You'll have to research how to create a connection pool.That is a pretty specific answer. Certainly inappropriate, for example, if the OP is attempting to just move records. Or compare records.
    Probably ony useful if the OP wants to present to a client data from two databases. But since the OP said "communicate" that seems unlikely.

  • Help:How can I run the J2EE Client Application? Thanks

    Help:How can I run the J2EE Client Application that will access the remote J2EE1.4 application server which runs on another host computer?
    I have developped a stateles senterprise java bean name converter and deloyed it in the j2ee1.4 application server on the host machine A. The converterbean provides the remote home interface and remote interface. At the same time I have developped the j2ee application client named convertappclient. When I access the conveter bean at host computer A through the script 'appclient.bat' as 'appclient -client convertappclient.jar', the client can access the bean sucessfully. Now I want to access the bean through the script 'appclient.bat' at host computer B,what files should I copy from host computer A to host computer B;and what the command line should be like? Thanks!
    The following are the code of the enterprise java bean and it's home interface .
    The client code is also provided.
    The enterprise java bean:
    package converter;
    import java.rmi.RemoteException;
    import javax.ejb.SessionBean;
    import javax.ejb.SessionContext;
    import java.math.*;
    public class ConverterBean implements SessionBean {
    BigDecimal yenRate = new BigDecimal("121.6000");
    BigDecimal euroRate = new BigDecimal("0.0077");
    public ConverterBean() {
    public BigDecimal dollarToYen(BigDecimal dollars) {
    BigDecimal result = dollars.multiply(yenRate);
    return result.setScale(2, BigDecimal.ROUND_UP);
    public BigDecimal yenToEuro(BigDecimal yen) {
    BigDecimal result = yen.multiply(euroRate);
    return result.setScale(2, BigDecimal.ROUND_UP);
    public void ejbCreate() {
    public void ejbRemove() {
    public void ejbActivate() {
    public void ejbPassivate() {
    public void setSessionContext(SessionContext sc) {
    The bean's remote home interface :
    package converter;
    import java.rmi.RemoteException;
    import javax.ejb.CreateException;
    import javax.ejb.EJBHome;
    public interface ConverterHome extends EJBHome {
    Converter create() throws RemoteException, CreateException;
    The bean's remote interface:
    package converter;
    import javax.ejb.EJBObject;
    import java.rmi.RemoteException;
    import java.math.*;
    public interface Converter extends EJBObject {
    public BigDecimal dollarToYen(BigDecimal dollars) throws RemoteException;
    public BigDecimal yenToEuro(BigDecimal yen) throws RemoteException;
    The j2ee application client:
    import converter.Converter;
    import converter.ConverterHome;
    import javax.naming.Context;
    import javax.naming.InitialContext;
    import javax.rmi.PortableRemoteObject;
    import java.math.BigDecimal;
    public class ConverterClient {
    public static void main(String[] args) {
    try {
    Context initial = new InitialContext();
    System.setProperty("java.naming.factory.initial","org.jnp.interfaces.NamingContextFactory");
                   System.setProperty("java.naming.provider.url","jnp://10.144.97.250:3700");
    Context myEnv = (Context) initial.lookup("java:comp/env");
    Object objref = myEnv.lookup("ejb/SimpleConverter");
    ConverterHome home =
    (ConverterHome) PortableRemoteObject.narrow(objref,
    ConverterHome.class);
    Converter currencyConverter = home.create();
    BigDecimal param = new BigDecimal("100.00");
    BigDecimal amount = currencyConverter.dollarToYen(param);
    System.out.println(amount);
    amount = currencyConverter.yenToEuro(param);
    System.out.println(amount);
    System.exit(0);
    } catch (Exception ex) {
    System.err.println("Caught an unexpected exception!");
    ex.printStackTrace();
    }

    Surprisingly I find an upsurge in the number of posts with this same problem. I recently found a post which gave a nice link for this. Follow the steps and it should help:
    http://docs.sun.com/source/819-0079/dgacc.html#wp1022105

  • Tag attempted to define a bean which already exists

    I am having problems with something i thought was solved in version 10.1.3.0.0, but obviously not.
    Here is the error message i get:
    500 Internal Server Error
    OracleJSP: oracle.jsp.parse.JspParseException: /html/portlet/journal_content/view.jsp: Line # 101, </liferay-portlet:renderURL>
    Error: Tag attempted to define a bean which already exists: portletURL
    I have tried adding init-param forgive_dup_dir_attr to the jsp servlet, but it doesn't help.
    Any ideas how to solve this??
    BR's

    500 Internal Server Error
    OracleJSP: oracle.jsp.parse.JspParseException: /html/portlet/journal_content/view.jsp:
    Line # 101, </liferay-portlet:renderURL>
    Error: Tag attempted to define a bean which already exists: portletURLPlease see my message how to avoid "Tag attempted to define a bean which already exists". Please tell me if it helps.
    I am having problems with something i thought was solved in version 10.1.3.0.0, but
    obviously notUnfortunately, it is not. It should be resolved in the next major version.

  • Help reg. read only CMP bean in the examples!!

    Hi,
    I have been working with examples of EJB in WLS 6.1
    I used the Access database with CMP.
    The basic entity beans, both CMP and BMP worked well.
    However when I tried the read-only Stock Bean and write StockWriter Beans... I received the following error... I am not sure what does it say...
    ==============================================
    Beginning readMostly.Client...
    Creating a StockWriter for BEAS
    There was an exception while creating and using the Beans.
    This indicates that there was a problem communicating with the server: java.rmi.RemoteException: EJB Exception:; nested exception is:
    java.sql.SQLException: [Microsoft][ODBC Microsoft Access Driver]Optional feature not implemented
    Start server side stack trace:
    java.rmi.RemoteException: EJB Exception:; nested exception is:
    java.sql.SQLException: [Microsoft][ODBC Microsoft Access Driver]Optional feature not implemented
    java.sql.SQLException: [Microsoft][ODBC Microsoft Access Driver]Optional feature not implemented
    at sun.jdbc.odbc.JdbcOdbc.createSQLException(JdbcOdbc.java:6026)
    at sun.jdbc.odbc.JdbcOdbc.standardError(JdbcOdbc.java:6183)
    at sun.jdbc.odbc.JdbcOdbc.SQLBindInParameterFloat(JdbcOdbc.java:852)
    at sun.jdbc.odbc.JdbcOdbcPreparedStatement.setLong(JdbcOdbcPreparedStatement.java:575)
    at weblogic.jdbc.pool.Statement.setLong(Statement.java:369)
    at weblogic.jdbc.rmi.internal.PreparedStatementImpl.setLong(PreparedStatementImpl.java:114)
    at weblogic.jdbc.rmi.SerialPreparedStatement.setLong(SerialPreparedStatement.java:147)
    at ejb.readMostly.StockWriterBean_u4qwd5__WebLogic_CMP_RDBMS.__WL_create(StockWriterBean_u4qwd5__WebLogic_CMP_RDBMS.java:589)
    at ejb.readMostly.StockWriterBean_u4qwd5__WebLogic_CMP_RDBMS.ejbCreate(StockWriterBean_u4qwd5__WebLogic_CMP_RDBMS.java:518)
    at java.lang.reflect.Method.invoke(Native Method)
    at weblogic.ejb20.manager.DBManager.create(DBManager.java:519)
    at weblogic.ejb20.manager.DBManager.remoteCreate(DBManager.java:489)
    at weblogic.ejb20.internal.EntityEJBHome.create(EntityEJBHome.java:190)
    at ejb.readMostly.StockWriterBean_u4qwd5_HomeImpl.create(StockWriterBean_u4qwd5_HomeImpl.java:78)
    at ejb.readMostly.StockWriterBean_u4qwd5_HomeImpl_WLSkel.invoke(Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:305)
    at weblogic.rmi.cluster.ReplicaAwareServerRef.invoke(ReplicaAwareServerRef.java:93)
    at weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:274)
    at weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:22)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:139)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
    End server side stack trace
    ; nested exception is:
    java.sql.SQLException: [Microsoft][ODBC Microsoft Access Driver]Optional feature not implemented
    Start server side stack trace:
    java.sql.SQLException: [Microsoft][ODBC Microsoft Access Driver]Optional feature not implemented
    at sun.jdbc.odbc.JdbcOdbc.createSQLException(JdbcOdbc.java:6026)
    at sun.jdbc.odbc.JdbcOdbc.standardError(JdbcOdbc.java:6183)
    at sun.jdbc.odbc.JdbcOdbc.SQLBindInParameterFloat(JdbcOdbc.java:852)
    at sun.jdbc.odbc.JdbcOdbcPreparedStatement.setLong(JdbcOdbcPreparedStatement.java:575)
    at weblogic.jdbc.pool.Statement.setLong(Statement.java:369)
    at weblogic.jdbc.rmi.internal.PreparedStatementImpl.setLong(PreparedStatementImpl.java:114)
    at weblogic.jdbc.rmi.SerialPreparedStatement.setLong(SerialPreparedStatement.java:147)
    at ejb.readMostly.StockWriterBean_u4qwd5__WebLogic_CMP_RDBMS.__WL_create(StockWriterBean_u4qwd5__WebLogic_CMP_RDBMS.java:589)
    at ejb.readMostly.StockWriterBean_u4qwd5__WebLogic_CMP_RDBMS.ejbCreate(StockWriterBean_u4qwd5__WebLogic_CMP_RDBMS.java:518)
    at java.lang.reflect.Method.invoke(Native Method)
    at weblogic.ejb20.manager.DBManager.create(DBManager.java:519)
    at weblogic.ejb20.manager.DBManager.remoteCreate(DBManager.java:489)
    at weblogic.ejb20.internal.EntityEJBHome.create(EntityEJBHome.java:190)
    at ejb.readMostly.StockWriterBean_u4qwd5_HomeImpl.create(StockWriterBean_u4qwd5_HomeImpl.java:78)
    at ejb.readMostly.StockWriterBean_u4qwd5_HomeImpl_WLSkel.invoke(Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:305)
    at weblogic.rmi.cluster.ReplicaAwareServerRef.invoke(ReplicaAwareServerRef.java:93)
    at weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:274)
    at weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:22)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:139)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
    End server side stack trace
    End readMostly.Client...
    ==========================================
    please help
    SP
    [att1.html]

    <entity-cache>
              <max-beans-in-cache>...</max-beans-in-cache>
              <read-timeout-seconds>...</read-timeout-seconds>
              <concurrency-strategy>ReadOnly</concurrency-strategy>
              </entity-cache>
              I believe this is what you are looking for and this is part of entity-descriptor.
              -- Prasad
              Aruna wrote:
              > Hi
              > I am trying to develop few entity beans which is for only reading the
              > data from the data base, As Read only entity beans are treated like stateless
              > session beans(ie lead balancing at method calls as well auto failover) in the
              > cluster. I want to know how to specify an entity bean as read only entity bean???
              > ie in deployment descriptor so that ejb container treats it as a read only entity
              > bean.
              >
              > Any help on this highly appreciated
              >
              > Thanks and Regards
              > Aruna
              

Maybe you are looking for

  • DVD RW DW-U10A won't read burned Dual Layer DVD

    My friend created a dual layer dvd for me on his PC. I put it in my G5 and after about 15 seconds of the drive trying to read the dist it just gets spit out. It won't mount or anything. Why is this happening? I've never had problems reading discs cre

  • How to customize Details dialog?

    Hi everyone, I’ve created an iView and I would like to add it into folder details dialog. It is possible? How it could be done? Thanks in advanced, Alcides Flach

  • Help me || i have nokia E63 black and i forget my ...

    hello evry bady >>> i have nokia E63 black and i forget my phone password !! Is there any way to open the phone ?? i search on the internet >> but >> no thing I'm waiting

  • Roles in portal for NWDS

    Hello , What all roles are needed for a particular user in portal to allow , NWDS java programming and deployment? Thanks Ronniee

  • Module Pool - Pop-Up Input Screen

    Hi Experts,   I have this scenario:      I have a table control and two radio buttons say R1 and R2.      R1 -> Single First Requirement-> When R2 is clicked, a button to its adjacent position should become visible and activated. Second Requirement->