Help with J2ME streaming

Hi,
My name is Constantinos Loizou and I am a student and currently developing a project for my Master's degree.
I need to stream audio and/or video to a PDA device. There is a trick here which is:
The PDA must receive the stream from a multicast address. For this I have implemented a Bridge application which joins the multicast group on behalf of the PDA and receives the Multicast RTP packets (which are sent from JMStudio) and Unicasts them to the PDA.(HP iPAQ) I had no problem implementing this. The streaming is done using JMStudio player which encodes the streaming audio data into a number of encodings (DVI/RTP in my case). I choose DVI/RTP and stream a .wav audio file.
Now I have to accept the packets and play the stream on the PDA.
The j2me application receives all the RTP packets successfully and I can extract usefull information from the packets such as: Timestamp, sequence number, payload type. The payload type is 5 which means it is a DVI4 encoding therefor the packets are accepted without any problem. I then save the data of the packet into a byte[] array and in regular intervals (50 000 bytes) I load them into a new ByteArrayInputStream(buffer); When I try to load the BytearrayInputStream and open it with a player I get the following error message:
javax.microedition.media.MediaException: Failed to realize Player: Malformed wave media: expected 'RIFF'
at com.sun.mmedia.WavPlayer.doRealize(+160)
at com.sun.mmedia.BasicPlayer.realize(+84)
at src.ViewVideoCanvas.run(ViewVideoCanvas.java:112)
The command I run is: player = Manager.createPlayer(input, "audio/x-wav");//create new player
And the error occurs on player.realize();
I believe that this happens beacause the data is encoded to DVI/rtp. I have searched a lot and found the algorithm of decompressing the DVI data but again I get the same error
Anyway, this is a brief description of my problem and I hope you can help me.
Contact me for any more details or help you can provide (code sammples, decoding algorithms and implementations in java)
Thank you
Constantinos Loizou

Hi my name is shaun benjamin and I am sorry I dont have the solution to this problem but could you please do me a fovor. I am looking for j2me source code for an audio streaming midlet tha can stream mp3 or wav. Could you please kindly send me some source code because I am not too fimiliar with j2me and am learning.

Similar Messages

  • Need help with Photo Stream

    I am having issues with Photo Stream and iPhoto when the iPhoto library is stored on a Drobo NAS. When I access the library stored on the NAS I see Photo Stream on the menu and when I access the library I get a  message that tells me I need to switch Photo Stream to this Library. I did select to switch Photo Stream over to this NAS library and I did get a big blue button that is suppose to start Photo Stream but when I push it nothing happens.
    I have contacted Apple support and they said that this is the way Photo Stream works and recommended that I submit a request to have this feature added at Apple\Feedback, if it is something I would like to have. They said if enough people request this feature they will add it but that Photo Stream does not currently support an iPhoto library stored on a remote NAS or shared network drive.
    My question is has anyone found a work around for this?  If you would like to have this feature added to Photo Stream can you please submit your request to Apple so they will add it, perhaps a little sooner than later?

    I checked today and this issue has been solved with the latest iPhoto update from Apple. I am running iPhoto 9.2.3 on my Snow Leopard Server which is sharing a Drobo NAS. I am also running iPhoto 9.2.3 on my MBP running Lion and I can now open my iPhoto Library and Photostream will work with the library and even automatically create events and move all my Photostream pictures into these events within the Library. I can then close the Library on my MBP and open the same Library from my Snow Leopard server and the new Events are there and I can move them around with no problem. Thank you Apple for this fix.   Even though I cannot deal with Photostream directly from the Snow Leopard server this is a very eligant work around.

  • TS3989 help with photo stream not making it to pc folder.. uploads a no no also..???

    the photos from My I phone photo stream,do not appear in the folder i assigned it to be in. Also when i put photos in my upload folder, they do not make it to my photo stream on m y iphone ??? ive tried everything with the help ??

    No, I certainly am not saying it's a feature; just a widely discussed issue that as far as I know has no current solution.  I was only sharing this so you were aware that you weren't alone in having this problem, and that it may not be solvable at the current time.  If you search the forums perhaps you'll find a solution I'm not aware of.

  • I am Stuck! Need Help With Multicast Streaming Using VLC Player

    I have a Multicast network topology shown below
    and my configs
    HUB ROUTER
    no ip domain lookup
    ip domain name primestarhotel.com
    ip multicast-routing
    interface Loopback0
    ip address 5.5.5.5 255.255.255.255
    ip pim sparse-dense-mode
    interface FastEthernet0/0
    ip address 200.0.0.2 255.255.255.240
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.65
    description "Server Vlan"
    encapsulation dot1Q 65
    ip address 10.1.65.1 255.255.255.0
    ip pim sparse-dense-mode
    ip virtual-reassembly
    router ospf 200
    log-adjacency-changes
    network 5.5.5.5 0.0.0.0 area 0
    network 10.1.65.0 0.0.0.255 area 0
    network 200.0.0.0 0.0.0.15 area 0
    ip route 200.1.1.0 255.255.255.252 200.0.0.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    no ip http server
    no ip http secure-server
    ip pim send-rp-announce Loopback0 scope 6
    ip pim send-rp-discovery Loopback0 scope 6
    ISP ROUTER
    interface FastEthernet1/0
    interface FastEthernet1/1
    no switchport
    ip address 200.0.0.1 255.255.255.240
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/2
    no switchport
    ip address 200.1.1.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/3
    no switchport
    ip address 200.2.2.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    router ospf 200
    log-adjacency-changes
    network 200.0.0.0 0.0.0.15 area 0
    network 200.1.1.0 0.0.0.3 area 0
    network 200.2.2.0 0.0.0.3 area 0
    SPOKE 1 Router
    interface FastEthernet0/0
    ip address 200.1.1.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    no ip address
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.12
    description "Workstation pc"
    encapsulation dot1Q 12
    ip address 10.1.12.1 255.255.255.0
    ip pim sparse-dense-mode
    router ospf 200
    log-adjacency-changes
    network 10.1.12.0 0.0.0.255 area 0
    network 200.1.1.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.1.1.1
    SPOKE 2
    interface FastEthernet0/0
    ip address 200.2.2.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    ip address 10.2.22.1 255.255.255.0
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    router ospf 200
    log-adjacency-changes
    network 10.2.22.0 0.0.0.255 area 0
    network 200.2.2.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.2.2.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    I have implemented multicast on the network in a hub and spoke topology. i have set up ospf routing protocol and broadcast all network and can successfully ping.
    I am currently using VLC player as my media streaming server and client. i have set up rtp streaming from the HUb router using multicast ip 224.2.2.2 and unable to broadcast the multicast traffic across the spokes 1 and 2 PC's
    I have never used vlc player  never set up multicast network before and i am struggling with this and need help.
    these are my router configs below
    http://dl.dropbox.com/u/20145606/ip%20video%20config.txt
    Message was edited by: Louis Ojuwu

    I have edited the message and the configs and topology are visible above now. instead of the links i provided

  • Help with j2me games

    I'm a student that needs help for my school thesis.I'm new to j2me. I'm trying to develop a multiplayer game via GPRS. i have a few general question to ask.I',m doing a round robin game.
    1) I saw in the nokia forum about the http server and tcp server. What is the main difference?Isn't the internet stack is divided to application, transport and network layer and so on?why will have http server and tcp server?isn't that tcp connection also implemented in http server?
    2) In the http server, the server won't start a connection with the client. If i send a http request to the server to start a new game with my opponent, how do the server will nodify my opponent?My opponent don't know i'm sending a game to him.
    3) Is that tcp server has already successfully implemented now?Is there any free tcp server or i need to code it in J2se?
    4) Is that using WAP or IP router to send the internet stack to the server?Which 1 is better?

    internet stack is divided to application, transport
    and network layer and so on?Yes, but a mobile might not have a IP stack, instead a simple connection to a proxy server, which "talks" to the net.
    how do the server will nodify my opponent?My opponent
    don't know i'm sending a game to him.Perodic updates (polling).
    3) Is that tcp server has already successfully
    implemented now?I dont understand the question. Has anyone used TCP/IP on mobile phones (as client software), yes me: http://j2mevnc.sourceforge.net
    Has anyone used the serversocket. Other than demo-ware, not that I know of, not many phones support socket://, let alone serversocket://
    4) Is that using WAP or IP router to send the internet
    stack to the server?Which 1 is better?Depends on your need.

  • Please help with video streaming

    I'm trying to play a video on a web page. I got the below
    script from
    a website tutorial, but it does not work correctly. The
    script will
    play a video in both IE and firefox browsers, but in IE, it
    will not
    show the video player controls even though I have added more
    than
    enough height.
    <OBJECT ID="MediaPlayer" WIDTH="208" HEIGHT="300"
    CLASSID="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
    STANDBY="Loading Windows Media Player components..."
    TYPE="application/x-oleobject">
    <PARAM NAME="FileName" VALUE="videofilename.wmv">
    <PARAM name="autostart" VALUE="true">
    <PARAM name="ShowControls" VALUE="true">
    <param name="ShowStatusBar" value="false">
    <PARAM name="ShowDisplay" VALUE="false">
    <EMBED TYPE="application/x-mplayer2"
    SRC="videofilename.wmv"
    NAME="MediaPlayer"
    WIDTH="208" HEIGHT="300" ShowControls="1" ShowStatusBar="0"
    ShowDisplay="0" autostart="1"> </EMBED>
    </OBJECT>

    That is an older site but there is a lot of information there
    8)
    John Malone
    =========
    "Canned Heat" <[email protected]> wrote in message
    news:[email protected]...
    |A followup. The site you linked to (mediacollege) does have
    a wealth
    | of info. However, for anybody else reading this post I did
    want to
    | point out that it is the same site is where I got the
    script (in my
    | original post) that didn't work. It was located here:
    |
    |
    http://www.mediacollege.com/video/format/windows-media/streaming/index.html
    |
    | So I would recommend using Joh's much simpler script, not
    the one from
    | mediacollege referenced above.
    |
    | Again, thanks John.
    |
    |
    |
    | On Fri, 23 Mar 2007 11:06:56 -0500, "John Malone" <John
    Malone@no
    | spam.com> wrote:
    |
    | >Well I couldn't get it to work in IE7..
    | >And you get the prompt to "click here to activate this
    control"
    | >here is a sample >
    | >
    | >
    http://www.xmas-i-am.com/test/video2.htm
    Autoplay when page loads.
    | >
    | >If you look at the source code on the page you will see
    I am using an external script
    | >file...
    | >This takes care of the outlined player (in IE) with the
    prompt to "click here to
    | >activate".
    | >By changing the script you can load the page without
    starting the movie.
    | >
    | >Like this..>
    | >
    http://www.xmas-i-am.com/test/video.htm
    | >
    | >Steal the code and the script (test.js or auto.js) and
    your good to go...
    | >
    | >Or look at .....>
    | >
    | >
    http://www.midistudio.com/MPlayer9/index.htm
    | >and read how......
    | >This is mostly for MIDI music but can work with video
    with minimal modifications.
    | >
    | >Also here is a good site...
    | >
    http://www.mediacollege.com/video/streaming/formats/
    | >You will need to follow the links>> to get a
    wealth of information.
    | >
    | >Hope this helps...
    | >
    | >Just an after thought...
    | >
    | >Beware of bandwidth limitations of your site this could
    cost you money!!!
    | >
    | >On that sample site(at the top) is a movie (1.3 Megs)
    that is viewed enough to cause
    the
    | >usage to be about 3 Gigs a month. (now)
    | >But at times (September) that goes up to 10~20 Gigs and
    at it's peak I had 17 Gigs a
    week
    | >usage.
    | >(It is the 911 Flash movie)
    | >
    | >Hope this helps......
    | >
    | >John Malone
    | >===============
    | >"Canned Heat" <[email protected]> wrote in message
    | >news:[email protected]...
    | >| Thanks for taking the time to test it. I want to make
    sure, tho, that
    | >| we're not talking about two different things.
    | >|
    | >| The script plays videos fine for me too. However, the
    problem is that
    | >| when playing with IE the video controls such as play,
    pause, etc are
    | >| not displayed.
    | >|
    | >| When you played it did you see the controls in IE?
    | >|
    | >| I have tested it on three machines, ones with the
    same IE version as
    | >| yours, and I get no controls. I only see the controls
    in firefox.
    | >|
    | >| Thanks,
    | >| -Dan
    | >|
    | >|
    | >| On Thu, 22 Mar 2007 15:48:02 -0500, "Eugene J. Maes"
    | >| <[email protected]> wrote:
    | >|
    | >| >Your script works fine in ie 6 with my wmv file.
    | >| >
    | >| >gene
    | >| >"Canned Heat" <[email protected]> wrote in
    message
    | >|
    >news:[email protected]...
    | >| >> I'm trying to play a video on a web page. I
    got the below script from
    | >| >> a website tutorial, but it does not work
    correctly. The script will
    | >| >> play a video in both IE and firefox
    browsers, but in IE, it will not
    | >| >> show the video player controls even though I
    have added more than
    | >| >> enough height.
    | >| >>
    | >| >> <OBJECT ID="MediaPlayer" WIDTH="208"
    HEIGHT="300"
    | >| >>
    CLASSID="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
    | >| >> STANDBY="Loading Windows Media Player
    components..."
    | >| >> TYPE="application/x-oleobject">
    | >| >> <PARAM NAME="FileName"
    VALUE="videofilename.wmv">
    | >| >> <PARAM name="autostart" VALUE="true">
    | >| >> <PARAM name="ShowControls"
    VALUE="true">
    | >| >> <param name="ShowStatusBar"
    value="false">
    | >| >> <PARAM name="ShowDisplay"
    VALUE="false">
    | >| >> <EMBED TYPE="application/x-mplayer2"
    SRC="videofilename.wmv"
    | >| >> NAME="MediaPlayer"
    | >| >> WIDTH="208" HEIGHT="300" ShowControls="1"
    ShowStatusBar="0"
    | >| >> ShowDisplay="0" autostart="1">
    </EMBED>
    | >| >> </OBJECT>
    | >| >
    | >|
    | >
    |

  • Need help with HP Stream Tablet 8 and 4G

    So, recently I decided I wanted to buy an HP Stream 8 tablet. I had told my mother and she bought me the stream 7 for Christmas, as no stores in our area carried the 8. However, I really wanted the 8 because the 7 didn't have the free 200MB of data, so she returned it, I covered the difference and we ordered the 8 from the Canadian website.
    It just arrived today and I'm having some issues with the free 200MB of 4G that was advertised to come with it. When I go to the Mobile Broadband section of my internet connection window, it tells me to insert a sim card. Was the sim card supposed to be in the box? Did I have to order it seperately? Does it not really come with 200MB free a month? I would really like to know how to get to this 200MB because without it I wouldn't have gone with this line of tablet. Any help would be appreciated.
    Thank you very much.
    -Wrocksum
    Full tablet information: Hp Stream 8 5901, SKU is K4F57UA#ABL

    Hey @Wrocksum ,
    Welcome to the HP Forums!
    According to the Specs listed for this tablet on the (CAN) HPShopping.ca website here (K4F57UA#ABA) it does not indicate anywhere on the page that it comes with the free 200 MB monthly plan. This model does not come with a microSIM but does have an available SIM slot for you to add a SIM card with your own provider.
    If you view the Stream 8 on the (US) HPShopping.com website here (K4F55UA#ABA) it does show that it comes with the 200 MB monthly plan. This model comes with a microSIM that can be used on the free plan, or you can use your own microSIM for your own plan.
    The free 200 MB offer is only available on select SKUs in the US only, as noted on the HPShopping.com website.
    Thanks.
    Please click the "Kudos, Thumbs Up" at the bottom of this post if you want to say "Thanks" for helping!
    Please click "Accept as Solution" if you feel my post solved your issue, it will help others find the solution.
    The Great Deku Tree
    I work on behalf of HP.

  • Help with USB streaming

    I have a Hauppauge USB live adapter connected to my computer and am trying to get streaming video into an applet. I captured it in JMStudio and it works fine, but when I try to put it into an applet or applcation, the screen is there, but it is all black. Here is one way I tried to do it using the media player sample from sun:
    import java.awt.*;
    import java.applet.*;
    import javax.media.bean.playerbean.*;
    import javax.swing.*;
    import javax.swing.event.*;
    import java.io.*;
    import javax.media.*;
    import javax.media.format.*;
    import javax.media.util.*;
    import javax.media.control.*;
    import javax.media.protocol.*;
    import java.util.*;
    import java.awt.*;
    import java.awt.image.*;
    import java.awt.event.*;
    import com.sun.image.codec.jpeg.*;
    public class MediaPlayerSample extends Applet
    Player player = null;
    MediaLocator ml = null;
    CaptureDeviceInfo di = null;
         public void init()
              //{{INIT_CONTROLS
              setLayout(null);
              setSize(518,347);
    String str2 = "vfw:Microsoft WDM Image Capture (Win32):0";
    di = CaptureDeviceManager.getDevice(str2);
    ml = di.getLocator();
    try
    player = Manager.createRealizedPlayer(ml);
    player.start();
    catch (Exception e)
    e.printStackTrace();
    mediaPlayer1.setPlayer(player);
              add(mediaPlayer1);
              mediaPlayer1.setBounds(36,24,324,272);
              //{{REGISTER_LISTENERS
              SymComponent aSymComponent = new SymComponent();
              this.addComponentListener(aSymComponent);
              SymContainer aSymContainer = new SymContainer();
              this.addContainerListener(aSymContainer);
         public void stop()
         if (mediaPlayer1!=null)
         mediaPlayer1.stop();
         public void destroy()
         if (mediaPlayer1!=null)
         mediaPlayer1.deallocate();
    if (player != null)
    player.deallocate();
         //{{DECLARE_CONTROLS
         javax.media.bean.playerbean.MediaPlayer mediaPlayer1 = new javax.media.bean.playerbean.MediaPlayer();
         class SymComponent extends java.awt.event.ComponentAdapter
              public void componentShown(java.awt.event.ComponentEvent event)
                   Object object = event.getSource();
                   if (object == MediaPlayerSample.this)
                        MediaPlayerSample_ComponentShown(event);
         void MediaPlayerSample_ComponentShown(java.awt.event.ComponentEvent event)
              // to do: code goes here.
              MediaPlayerSample_ComponentShown_Interaction1(event);
         class SymContainer extends java.awt.event.ContainerAdapter
              public void componentRemoved(java.awt.event.ContainerEvent event)
                   Object object = event.getSource();
                   if (object == MediaPlayerSample.this)
                        MediaPlayerSample_ComponentRemoved(event);
         void MediaPlayerSample_ComponentRemoved(java.awt.event.ContainerEvent event)
              // to do: code goes here.
              MediaPlayerSample_ComponentRemoved_Interaction1(event);
         void MediaPlayerSample_ComponentShown_Interaction1(java.awt.event.ComponentEvent event)
              try {
                   mediaPlayer1.start();
              } catch (Exception e) {
         void MediaPlayerSample_ComponentRemoved_Interaction1(java.awt.event.ContainerEvent event)
              try {
              mediaPlayer1.stop();
                   mediaPlayer1.deallocate();
              } catch (Exception e) {
    Im not getting any errors with it, it just is black instead of pushing the image to the screen. Any help would be greatly appreciated (I have to demo this on friday).
    Thanks

    I am currenty a college student trying the same thing. I am very early in the development stage though, so I am more interested in finding some information about streaming raw data from a usb (or possibly firewire 800) device into a Java application as video.
    Any help would be awesome!

  • HT201317 Help with photo stream?

    I have photo stream turned on at my mac and at my Iphone. In Iphoto, I clicked on an album to share to my photo stream, but it won't show up on my phone. Help?

    Hi teacheryo,
    If you are having issues getting Photo Stream to behave as expected, you may want to take a look at the following article:
    iCloud: Photo Stream troubleshooting
    http://support.apple.com/kb/ts3989
    Cheers,
    - Brenden

  • Can you help with WebQT stream, Muxed, Export to dv, to iMovie

    Can you help?
    Downloaded several QT video clips, muxed.
    In QT Pro (7.1.2), joined several clips into one QT movie.
    Exported to dv, to iMovie.
    Problem: 1st imported clip plays ok, but remaining joined clips won't. iMovie recognizes entire time length of joined clips, but they just won't play.
    Ideas?
    (P.S. I record audio with Audio Hijack Pro (http://www.rogueamoeba.com/audiohijack/) from original QT clips, then paste into iMovie. This works very well.)

    I found an answer to my issue but I have no idea why it was fixed. A post on another site suggested opening up Garage band and playing a few notes on the on-screen keyboard and them closing the application. What ever settings that invoked, it worked and I can now import video from my original Canon ZR !

  • Help with J2ME installation !

    Hi all,
    I am a complete newbie to J2ME.
    I need to start working small applications for Ericsson K750i as a part of my project.
    Can anyone let me know which package I will need to install to be able to write apps for k750i ? Is it the Java Wireless Toolkit that I need ?
    All help much appreciated.
    Thank you.

    First of all I'd suggest you read through MIDP 1.0a and 2.0 specs (see http://www.jcp.org/). This will give you overview of what to expect from J2ME. Additionaly you could read Bluetooth API spec and others.
    For books, Core J2ME by John W. Muchow (http://www.amazon.com/exec/obidos/tg/detail/-/0130669113/002-3226980-2560825?v=glance) is a good starter. If you require it, check out also J2ME Game Programming (http://www.amazon.com/exec/obidos/tg/detail/-/1592001181/002-3226980-2560825?v=glance)
    Hope this helps,
    Peter

  • Help with Oracle Streams. How to uniquely identify LCRs in queue?

    We are using strems for data replication in our shop.
    When an error occours in our processing procedures, the LCR is moved to the error queue.
    The problem we are facing is we don't know how to uniquely identify LCRs in that queue, so we can run them again when we think the error is corrected.
    LCRs contain SCN, but as I understand it, the SCN is not unique.
    What is the easy way to keep track of LCRs? Any information is helpful.
    Thanks

    Hi,
    When you correct the data,you would have to execute the failed transaction in order.
    To see what information the apply process has tried to apply, you have to print that LCR. Depending on the size (MESSAGE_COUNT) of the transaction that has failed, it could be interesting to print the whole transaction or a single LCR.
    To do this print you can make use of procedures print_transaction, print_errors, print_lcr and print_any documented on :
    Oracle Streams Concepts and Administration
      Chapter - Monitoring Streams Apply Processes
         Section - Displaying Detailed Information About Apply Errors
    These procedures are also available through Note 405541.1 - Procedure to Print LCRs
    To print the whole transaction, you can use print_transaction procedure, to print the error on the error queue you can use procedure print_errors and to print a single_transaction you can do it as follows:
    SET SERVEROUTPUT ON;
    DECLARE
       lcr SYS.AnyData;
    BEGIN
        lcr := DBMS_APPLY_ADM.GET_ERROR_MESSAGE
                    (<MESSAGE_NUMBER>, <LOCAL_TRANSACTION_ID>);
        print_lcr(lcr);
    END;
    Thanks

  • Help with photo stream

    Photos in photo stream stopped transferring from iPhone to iPad on May 5.  I was out of the country (with only my iPhone) and when I returned home that's what I found.  Now with both devices connected the photos still do not transfer.  When I turned on my PC they transferred to it just fine.  I can't fine anything wrong with any of my settings.

    You will probably need to turn my photo stream off, then back on again to get things working again.  When you turn it off, it will delete the photo stream photos from your devices so be sure to save any photo stream photos that you want to keep on your devices to your camera roll before doing this.

  • Help with photo streaming

    I have downloaded iphone app to PC. But can not up load photos into photo stream on PC, or atleast see them there. I looked online and was told I should also have a seperate photo stream icon on phone which I do not have.. Not sure what to do next...TIA

    Did you already check these articles?
    iCloud: Photo Stream Troubleshooting
    iCloud: Photo Stream FAQ

  • Help with j2me concept

    I still not very clear about http and tcp? Is taht i can choose whether use http or tcp connect to the game server?
    If i use http server and i want to play a multiplayer game with my oppnent. I will send an invitation to the game server.How do the game server inform my opponent?Is that my opponent will always polling from the server although the game haven't start?Isn't that my ooponent will poll from the server jz only the multiplayer game between us start?
    Where can i find a http server and tcp server?IS tomcat a http server?Then, where can i find a tcp server?

    Is taht i can choose whether use http or tcp connect to the game server?A tcp implementation would obviously perform better, but many phones don't support tcp. So if you want to support all these phones you have to fall back to an http implementation.
    Is that my opponent will always polling from the server although the game haven't start?Yes, both players poll the server all the time.
    The server, for every time a clients polls it, would run something like:
    if this client have a game open then send a game update
    else if someone invited this client then send invitation
    else send available player list.
    shmoove

Maybe you are looking for

  • Can't enter credit card details

    Hi, Last week I tried to download an app but my credit card declined due to an expiry date. I no longer use that credit card/company, so I used iTunes to change my billing information over to my new credit card. However, when I press 'done' at the en

  • Time capsule as back up & external hard drive, & transferring itunes to TC

    I have 90% of my itunes files on an external hard drive which I used as the location of my itunes library when I was using a pc. I now use a macbook 80GB. I cannot use my external hard drive with my macbook as it's filing system is NTFS, and so incom

  • Grouping of Business Area

    Hi Gurus,       I want to do the grouping of business area.  Can i do the grouping by Maintain consolidation business area (SPRO Way). If not what is the procedure. Does it will affect the financial structure by Maintain consolidation business area o

  • Where do you write your code?

    I've just started to learn Flex. One question I have is where you put the ActionScript code? I know i can put it in several locations (e.g. inline, within a script-tag, in actionscript-files, in actionscript classes) but what's the best way to go? Up

  • How can I get My Macbook Body ReStored?

    I Got A Macbook home need to fix the body from cracks n scratched... how can i get the body restored ?