How can i read client IP address

Hello,
I try to read the user IP address using Request.UserHostAddres and this is always 127.0.0.1 (=localhost)
This is happens (i think..) because the request is not submitted directly to my .net portal application .
What is the solution on this issue ?
Thanks !

Hello,
I try to read the user IP address using Request.UserHostAddres and this is always 127.0.0.1 (=localhost)
This is happens (i think..) because the request is not submitted directly to my .net portal application .
What is the solution on this issue ?
Thanks !

Similar Messages

  • How can I get Client IP Address in oracle?senthil

    How can I get Client IP Address in oracle?senthil

    Hi,
    Following query can help you to get the Client IP Address.
    select sys_context('userenv','ip_address') from dual;
    Thanks,

  • How can I get client IP address in portlet (servlet) ?

    How can I get client IP address in portlet (servlet) ?
    request.getRemoteAddr() return server IP.
    May be I must use Portal API, which extend Servlet classes, but I can't find this.
    Can any help me?

    Hi,
    Following query can help you to get the Client IP Address.
    select sys_context('userenv','ip_address') from dual;
    Thanks,

  • How can I preserve Client IP address?

    I am configuring the ACE for bridged mode. However, the real server is seeing VIP IP but not Client IPs. Our business requires that the real server must see client IPs. Do you have any idea how to set that up?
    I tried to turn ON/OFF normalization but it is still not working.
    Thanks,
    Vincent
    ==============================
    Here is my configuration:
    rserver host 192.168.71.71
      ip address 192.168.71.71
      inservice
    serverfarm host WEB_FARM
      failaction purge
      probe ICMP
      rserver 192.168.71.71
        inservice
    access-list PERMIT-BPDU ethertype permit bpdu
    access-list ALL line 8 extended permit ip any any
    sticky ip-netmask 255.255.255.255 address source WEB_FARM_Sticky
      timeout 180
      replicate sticky
      serverfarm WEB_FARM
    class-map match-all WEB_FARM_VIP
      2 match virtual-address 192.168.71.154 tcp eq 80
    class-map type management match-any remote_access
      2 match protocol xml-https any
      4 match protocol icmp any
      5 match protocol telnet any
      6 match protocol ssh any
      7 match protocol http any
      8 match protocol https any
      9 match protocol snmp any
    policy-map type loadbalance first-match WEB_FARM_Policy
      class class-default
        sticky-serverfarm WEB_FARM_Sticky
    policy-map multi-match WEB_VIPS
      class WEB_FARM_VIP
        loadbalance vip inservice
        loadbalance policy WEB_FARM_Policy
        loadbalance vip icmp-reply active
        nat dynamic 6 vlan 31
        nat dynamic 5 vlan 21
    interface vlan 21
      description Client VLAN
      bridge-group 171
      no normalization
      mac-sticky enable
      access-group input PERMIT-BPDU
      access-group input ALL
      service-policy input WEB_VIPS
      nat-pool 5 192.168.71.154 192.168.71.154 netmask 255.255.255.255 pat
    interface vlan 31
      description Server VLAN
      bridge-group 171
      no normalization
      mac-sticky enable
      access-group input PERMIT-BPDU
      access-group input ALL
      service-policy input WEB_VIPS
      nat-pool 6 192.168.71.154 192.168.71.154 netmask 255.255.255.255 pat
      no shutdown
    interface bvi 171
      ip address 192.168.71.3 255.255.255.0
      no shutdown

    Do you have a default route on the ACE and the rservers? Are they all pointing to the same IP? I have the same configuration.  An ACE 4710 in transparent mode, but I have no NATing and my rservers are able to see the original client IPs (security requirement).
    Here is part of my config for one serverfarm
    rserver host RS_MIDTIER_220
      description
      ip address 172.31.0.131
      inservice
    rserver host RS_MIDTIER_221
      description
      ip address 172.31.0.132
      inservice
    rserver host RS_MIDTIER_222
      description
      ip address 172.31.0.133
      inservice
    rserver redirect RS_SSL_Redirects
      webhost-redirection https://%h/%p 301
      inservice
    action-list type modify http SSL_URL_REWRITE
      ssl url rewrite location ".*"
    serverfarm redirect SF_SSL_Redirects
      predictor leastconns
      rserver RS_SSL_Redirects
      inservice
    serverfarm host SF_Midtier_Prod
      description Midtier Production
      predictor leastconns
      probe APACHE
      probe ICMP
      rserver RS_MIDTIER_220 80
        inservice
      rserver RS_MIDTIER_221 80
        inservice
      rserver RS_MIDTIER_222 80
        inservice
    ssl-proxy service SSL_PSERVICE_MIDTIER_PROD
      key
      cert
      chaingroup EntrustChainGroup
    sticky http-cookie JSESSIONID Sticky_Jsession_Cookie_Midtier_Prod
      timeout 90
      serverfarm SF_Midtier_Prod
    class-map type management match-any REMOTE_MGT_ACCESS
      description remote access traffic match
      2 match protocol ssh source-address
      4 match protocol https source-address
      5 match protocol snmp source-address
    class-map match-any VS_Midtier_Prod_L3SLB
      description Midtier Prod IPs
      2 match virtual-address 172.31.0.46 tcp eq https
      3 match virtual-address 172.31.0.47 tcp eq https
    class-map match-any VS_SSL_Redirects
      description Redirects any http VIPS to https
      5 match virtual-address 172.31.0.46 tcp eq www
      6 match virtual-address 172.31.0.47 tcp eq www
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
      class REMOTE_MGT_ACCESS
        permit
    policy-map type loadbalance http first-match Midtier_Prod_L4SLB
      class class-default
        sticky-serverfarm Sticky_Jsession_Cookie_Midtier_Prod
        action SSL_URL_REWRITE
    policy-map type loadbalance first-match SSL_Redirect_L4SLB
      class class-default
        serverfarm SF_SSL_Redirects
    policy-map multi-match Farm_VIPS
      class VS_SSL_Redirects
        loadbalance vip inservice
        loadbalance policy SSL_Redirect_L4SLB
      class VS_Midtier_Prod_L3SLB
        loadbalance vip inservice
        loadbalance policy Midtier_Prod_L4SLB
        loadbalance vip icmp-reply active
        ssl-proxy server SSL_PSERVICE_MIDTIER_PROD
    interface vlan 100
      description DMZ ACE frontside
      bridge-group 1
      access-group input BPDUALLOW
      access-group input ALL
      service-policy input REMOTE_MGMT_ALLOW_POLICY
      service-policy input Farm_VIPS
      no shutdown
    interface vlan 110
      description DMZ ACE backside
      bridge-group 1
      access-group input BPDUALLOW
      access-group input ALL
      no shutdown
    interface bvi 1
      ip address 172.31.0.150 255.255.255.0
      no shutdown
    rserver redirect RS_SSL_Redirects
      webhost-redirection https://%h/%p
    301
      inservice
    domain
    ip route 0.0.0.0 0.0.0.0 172.31.0.1

  • How can I exclude client IP address from access log using WebServer 6.0? WebServer 3.x has Do not log client accesses from: option under Log Preferences". But I cant find it when we upgrade to 6.0

     

    Hi,
    Please go through the below link.
    http://docs.iplanet.com/docs/manuals/enterprise/60sp1/ag/esmonsvr.htm#18110
    I hope this helps. If you need any help let me know.
    Regards,
    Dakshin.
    Developer Technical Support
    Sun Microsystems
    http://www.sun.com/developers/support.

  • HOW CAN I FIND OUT BOUNED ADDRESS

    When you get a bounced email using javamail, is there a way of getting the address that coused the bounce.
    ie
    if person A sends an email to Person B using address [email protected]
    asuming this email bounces, how can i read or get at the addreess [email protected]
    am asumming that when an email bounces the server stores the bounced address somewhere
    any help would be grealy appreciated

    If you look at SMTP and the way it works you will see that there is no way to detect a bad address on the client. Consider that when a client application sends to a server all that happens is the client establishes a connection, transmits the message, and recieves a reply from the server that it got the message.
    At this point the connection between the sender and the server is dropped and the server puts the message in its outbound queue. The server will then try to send the message and after a number of failures it will send a message to the from address in the message saying that the message could not be sent. The connection back to the email client is long gone at this point.
    Since most SMTP servers use IP address ranges to verify if they should send or deny there is no account information associated with the transaction. All bounced messages would have to go into a single queue, since the server doesn't have any account information on it, and if you make those messages accessable you would be allowing anyone to read anything that is in there.
    If you really need to do this for some reason you can set the from address in your messages to a specific email address. Then write a client that will fetch from it and parse out the bad address. Since the bounced messages are automated it is really pretty easy to parse out the address.
    The entire architecture was setup in the days when the connection from A to B would not always be there. Instead of having to have the connection to send a message you could send to the server. When the connection comes up the server could then send the message.

  • How can I remove a mailbox address from the "From" drop down box in a new e-mail my old e-mail address continue to populate as the sender address

    How can I remove a mailbox address from the "From" drop down box in a new e-mail my old e-mail address continue to populate as the sender address

    Hello,
    Try Mail>Preferences>Accounts icon>Account Information tab>Click on the Outgoing SMTP server drop down, choose edit Server list, highlight the old one & click Remove.
    (Such convolution is worthy of Windows® in my estimation)

  • How can I change my email address in iMessages so that I can receive messages. My apple seems to have two different email identities and I cannot figure out how to change the wrong one.

    My email address in the imessage part of my ipad is incorrect. How can I change the email address to conform with the email address on the rest of my apple products? I can get messages on my iphone, mac but not on my ipad because of the incorrect address.

    Go on to settings> Messages > send and receive
    this should give you the opportunity to edit email adressed
    Hope it helps.

  • How can I change the email address linked to my iCloud account on iPhone 4S running iOS 7?

    How can I change the email address linked to my iCloud account for iPhone 4s?

    Welcome to the Apple Community.
    If it's your non-iCloud mail address, start here, change your country if necessary and go to manage your account
    If it is your iCloud mail address you want to change, you can't.

  • Whenever I update my iPhone software, it asks me to sign in to iCloud with an old email address.  My other devices all have the correct address.  How can I get the correct address for my iPhone?  The only Apple ID that works for logging in is my new one.

    Whenever I update my iPhone software, it asks me to sign in to iCloud with an old email address.  My other devices all have the correct address.  How can I get the correct address for my iPhone?  The only Apple ID that works for logging in is my new one.

    To change the iCloud ID you have to go to Settings>iCloud, tap Delete Account, provide the password for the old ID when prompted to turn off Find My iPhone (if you're using iOS 7), then sign back in with the ID you wish to use.  If you don't know the password for your old ID, or if it isn't accepted, go to https//appleid.apple.com, click Manage my Apple ID and sign in with your current iCloud ID.  Tap edit next to the primary email account, tap Edit, change it back to your old email address and save the change.  Then edit the name of the account to change it back to your old email address.  You can now use your current password to turn off Find My iPhone on your device, even though it prompts you for the password for your old account ID. Then go to Settings>iCloud, tap Delete Account and choose Delete from My iDevice when prompted (your iCloud data will still be in iCloud).  Next, go back to https//appleid.apple.com and change your primary email address and iCloud ID name back to the way it was.  Now you can go to Settings>iCloud and sign in with your current iCloud ID and password.

  • How can I correct my email address on my iphone for the app store

    How can I correct my email address on my iphone so I can access the app store and itunes via my phone. The address is correct on my laptop and ipad so have no idea what's going on. All I know is that I cannot get into the app store or itunes on my iphone. Does anyone have any ideas please

    Hi there gillian115,
    You may find the information in the article below helpful.
    iOS: Changing the signed-in iTunes Store Apple ID account
    http://support.apple.com/kb/ht1311
    -Griff W. 

  • How can I change my email address on my ipad?

    How can I change my email address on my ipad?

    If you mean for your email account in the mail app, go to Settings>Mail, Contacts, Calendars>Your email account>Delete Account. Then tap Add Account and enter the new information.
    I get the feeling that you are really asking about something else.

  • How can I get the MAC address of my Apple TV?

    How can I get the MAC address of my Apple TV? I currently do not have an HDMI device to connect it to, and the MAC is not listed on the box or the Apple TV itself.
    (to answer the obvious, I am trying to pair it with an iPad, and I need to register the Apple TV for the network so the two can see each other)

    As long as I know java doesn't have support to work on link-layer, only internet and transport layers. You may write simple native code. On windows, IP Helper functions, like SendARP allow you to pass an IP address and get the hardware address. You store the hardware address on your database/file and later, when that machine is off, you send a frame to the address you stored previous.
    [http://msdn.microsoft.com/en-us/library/aa366071(VS.85).aspx]
    I haven't seen it on Linux, but if you need help let me know I'll check the Linux API's too.

  • How can I add multiple email addresses to Address Book?

    How can I add multiple email addresses to Address Book?
    Can it be done from an .xlsx file?

    I have tried that, but the system reads the emails as one long email and I can't find any way of separating them - it ignores spaces, colons and I have also tried putting them through a word doc... still does not work. It works perfectly easily on a PC system!! ( I have just moved to a mac!)
    any ideas would be good
    thanks

  • How can I add multiple email addresses  from spreadsheet into email?

    how can I add multiple email addresses  from spreadsheet into email?

    I have tried that, but the system reads the emails as one long email and I can't find any way of separating them - it ignores spaces, colons and I have also tried putting them through a word doc... still does not work. It works perfectly easily on a PC system!! ( I have just moved to a mac!)
    any ideas would be good
    thanks

Maybe you are looking for

  • Can i setup multiple Apple IDs on one computer

    Hi My partner and I recently sold our laptops and bought an iMac and want to keep our itunes, music, playlists separate.  Is it possible to setup multiple Apple IDs on one computer? Thanks Denise

  • Duplicate missing songs

    Hi, I recently had to move my entire music library from one partition to another, and made a bit of a mess of working with iTunes. Now iTunes has two copies of every song in the library, every other one being marked with a question mark because (obvi

  • Rows not showing up

    Can someone help me figure out why these rows are not showing up? the navigation shows up but not the rows above and below. website: primalmd.com <tr> <td height="30" colspan="4" bgcolor="00457C" class="headerlogo"><strong>SKINCARE</strong> FOR <stro

  • Will iPad support Appeture

    Hi, I was about to buy a Mac Air primarily to download and save my photographs when on holiday as I fear keeping several full compact flash cards in my bag. I see that iPad allows storage of photos but not sure if it is done within iPhoto. As I use A

  • Base SDK Missing error

    I previously coded a test iPhone application on Mac OS X 10.4 (Leopard), which uses the older XCode SDK. I now upgraded to Mac OS X 10.6.4 (Snow Leopard) and is now using XCode 3.2.4. When I attempt to run the iPhone application with the upgraded ver