How does my provider route to me

Hi all my service provider has a router and pix on my site, the router connects to the internet via a serial, the pix and router are on the same network, would the router be using ip unnumbered on the serial interface ? and also we have been assigned ip addresses using a x.x.255.x network, how come we can use the 255 network ?

Hi
I think you want to know how your provider route subnet to you.
it seems you unnumbered you serial interface to your ethernet so the serial interface uses the ethernet ip address.
at the service provider they can define a loopback interface with another ip address out of your range and unnumbered their serial interface to it ,only thing that they need is an "ip route" the configuration at service provider should like this :
NOTE ALL THIS STATEMENTs NOT REAL AND It s ONLY AN EXAMPLE
interface loopback 0
ip add 200.1.1.1 255.255.255.255
interface serial 1
ip unnumbered loopback 0
//this the interface that connect directly to you//
ip route (your network address) (mask) serial 1
like :
ip route 20.1.1.0 255.255.255.0 serial 1
in this sample 20.1.1.0 is your network range.
so you can have all of 255 ip address by assigning the ip address to your ethernet or fast ethernet and then unnumbered your serial to them.
Thanks.
hope usefull.

Similar Messages

  • How does webserver provide html components as httprequest

    How does a component and it's value in a html page is passed as a HTTPRequest to a JSP page?
    eg:
    <input type=text name=textbox value="hi>
    how is this component sent to my calling JSP page in the form of HTTPRequest,such that the value of the component is available to me when is use the code,
    request.getParameter("textbox")?
    Can anyone provide with a sample code how this is done?
    Thanks in advance.
    Regds,
    --Jagan.

    How does a component and it's value in a html page is passed as a HTTPRequest to a JSP page?
    eg:
    <input type=text name=textbox value="hi>
    how is this component sent to my calling JSP page in the form of HTTPRequest,such that the value of the component is available to me when is use the code,
    request.getParameter("textbox")?
    Can anyone provide with a sample code how this is done?
    Thanks in advance.
    Regds,
    --Jagan.

  • How does J2EE SDK provide JNDI DataSource ?

    Still new to J2EE and working my way thorugh Wrox press "professional java server programming". Im using the deploy tool and im wondering how does J2EE provide JNDI names for a DataSource ? Im somewhat familiar with JNDI and I thought you had to use a directory service such as OpenLDAP to use JNDI.
    my questions then are:
    (1) What kinds of things can you do with JNDI without using a directory service ?
    (2) How does the J2EE SDK physically store references to a DataSource without using a directory service. In otherwords, how does the J2EE server provide for using JNDI names for a DataSource and is this a typical feature of J2EE containers ?

    i wish someone would answer this. i curious myself about these exact same things.

  • MPLS - How are external/internal routes distinguished?

    Hi all
    I was setting up an MPLS environment and wanted to get some more information about how MPLS VPN's work. Basically I have three sites connected to the MPLS cloud. Site A runs EIGRP on the customer side and Site B runs OSPF on the customer side. Site C is the one in question. The way I have it designed, Sites A and C have full visability into one another and sites B and C have full visibility into one another. When I configure site C with eigrp, all proper routes are seen, but the OSPF routes from site B are seen as EIGRP external routes. When I switch site C to OSPF, EIGRP routes from site A are seen as OSPF External type 2 routes. I guess my ultimate question is, How does the PE router at site C know the originating protocol? All the routes it receives are from BGP. Does a certain attribute carry this? If so, is this feature specific to Cisco gear or an RFC standard? Thanks in advance for all your help. I can include configs if that would help, below I'll show you my RD and RT's for each VRF and the routing tables of the CE router at Site C before and after the change.
    Site A
    ip vrf a
    rd 1:111
    route-target export 1:100
    route-target import 1:101
    Site B
    ip vrf c
    rd 3:333
    route-target export 3:301
    route-target import 1:101
    Site C
    ip vrf a
    rd 1:111
    route-target export 1:101
    route-target import 1:100
    route-target import 3:301
    Change from EIGRP to OSPF
    Gateway of last resort is not set
         6.0.0.0/32 is subnetted, 1 subnets
    D       6.6.6.6 [90/435200] via 10.2.1.1, 00:05:26, Ethernet0/0
         7.0.0.0/32 is subnetted, 1 subnets
    C       7.7.7.7 is directly connected, Loopback1
         8.0.0.0/32 is subnetted, 1 subnets
    D EX    8.8.8.8 [170/2560025856] via 10.2.1.1, 00:02:13, Ethernet0/0
    D EX 111.0.0.0/8 [170/2560025856] via 10.2.1.1, 00:02:13, Ethernet0/0
         10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C       10.2.1.0/24 is directly connected, Ethernet0/0
    D       10.1.1.0/24 [90/307200] via 10.2.1.1, 00:05:56, Ethernet0/0
    D       10.20.0.0/16 [90/435200] via 10.2.1.1, 00:05:56, Ethernet0/0
    C       10.77.0.0/16 is directly connected, Loopback2
    D EX 192.168.1.0/24 [170/2560025856] via 10.2.1.1, 00:02:43, Ethernet0/0
    R7(config)#no router eigrp 22
    *Mar  1 02:10:20.747: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 22: Neighbor 10.2.1.1 (Ethernet0/0) is
    down: interface down
    R7(config)#router ospf 3
    R7(config-router)#network 10.0.0.0 0.255.255.255 area 0
    R7(config-router)#network 7.7.7.7 0.255.255.255 area 0
    R7(config-router)#end
    R7#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    Gateway of last resort is not set
         6.0.0.0/32 is subnetted, 1 subnets
    O E2    6.6.6.6 [110/409600] via 10.2.1.1, 00:00:27, Ethernet0/0
         7.0.0.0/32 is subnetted, 1 subnets
    C       7.7.7.7 is directly connected, Loopback1
         8.0.0.0/32 is subnetted, 1 subnets
    O IA    8.8.8.8 [110/21] via 10.2.1.1, 00:00:27, Ethernet0/0
    O IA 111.0.0.0/8 [110/21] via 10.2.1.1, 00:00:27, Ethernet0/0
         10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C       10.2.1.0/24 is directly connected, Ethernet0/0
    O E2    10.1.1.0/24 [110/1] via 10.2.1.1, 00:00:26, Ethernet0/0
    O E2    10.20.0.0/16 [110/409600] via 10.2.1.1, 00:00:26, Ethernet0/0
    C       10.77.0.0/16 is directly connected, Loopback2
    O IA 192.168.1.0/24 [110/11] via 10.2.1.1, 00:00:26, Ethernet0/0
    R7#trace 6.6.6.6
    Type escape sequence to abort.
    Tracing the route to 6.6.6.6
      1 10.2.1.1 652 msec 396 msec 192 msec
      2 40.1.1.9 [MPLS: Labels 18/24 Exp 0] 2264 msec 2640 msec 2532 msec
      3 30.1.1.3 [MPLS: Labels 18/24 Exp 0] 2320 msec *  *
      4 10.1.1.1 [MPLS: Label 24 Exp 0] 1816 msec 1792 msec 2148 msec
      5 10.1.1.2 1940 msec *  2200 msec
    R7#

    Hello Edward,
    I see nothing strange in the results you have posted. They are completely natural to the process of carrying customer routes over MPLS L3 VPN.
    You know yourself that the customer routes are carried between PE routers using BGP, and from PE towards CE, these routes are redistributed from BGP into the particular routing protocol running between PE and CE. Each of these routing protocols automatically marks redistributed networks as external networks. For OSPF, this is a normal part of the open protocol specification - that routes injected into OSPF via redistribution shall be represented as external routes (and carried in LSA-5). Similarly, when you redistribute into EIGRP from a different routing protocol, these routes will be carried by EIGRP as external networks. So what you see here is natural and normal. Even if all sites ran the same routing protocol (EIGRP or OSPF), one site would see networks from other sites as external routes.
    In fact, there are extensions to BGP using extended community attributes that try to preserve the original nature of the redistributed routes. The prerequisite is that all sites run the same IGP, either OSPF or EIGRP. In that case, EIGRP routes carried over MPLS can be made look like internal routes although they are redistributed, and OSPF will make the routes appear as inter-area routes, not as external routes. There is even a modification to OSPF allowing you to see other sites as intra-area routes (though this requires configuring so-called OSPF sham links between PEs). All of this is done because an internal network is always preferred to an external network. This causes trouble if there is a backup link directly interconnecting two sites, bypassing the MPLS cloud. As the routing protocol run over this link advertises all networks as internal, this link would always be preferred to the MPLS VPN which is exactly the opposite of what you want to do.
    Please feel welcome to ask further!
    Best regards,
    Peter

  • I would like to know which app/software in MAC gives us the same feature that is provided by System Restore in Windows, and how does that work

    I would like to know which app/software in MAC gives us the same feature that is provided by System Restore in Windows, and how does that work.

    Time Machine is one such program, although it is a recursive backup program which offers limited archive capability, based on the capacity of the backup destination, and it requires you set it up before you start editing your files.   Some programs are also Versions aware, which offers a kind of restore capability by file.  Again needs to be setup before you start editing.
    Just a for-your-info:
    Mac is not an acronym, it is a nickname for Macintosh.

  • HT2736 How does a content provider obtain a redemption code to provide to others for free downloads of their own content

    How does a content provider obtain a redemption code to provide to others for a free iTunes download of their own content. This would be similar to what Starbucks does. However, it would the actual content provider and not a third party.

    Same issue. We produce a number of Podcasts and are about to launch a national print campaign to promote them under a single brand identity.
    I tried that method already as well, but got the response back that I needed to contact a different department using the "report this podcast" link associated with the Podcast in iTunes (which, of course, doesn't have any options for anything close to this type of request.) Been 48 hours and no response yet. Anyone had any success with this?

  • I wanted to know how does technical support work via icloud and is there any new technology out that helps providing technical support

    i wanted to know how does technical support work via icloud and is there any new technology out that helps providing technical support?

    basically I’m doing a project were I wanted to find out if there are recent technology  out that provides technical support for example they do it with remote access but is they any new ways that  they can support us and just wanted to find out if icloud gives technical support then how?

  • How do I compress a file on a Mac.  I do not see and option to compress a file when I right click on it and the Apple help does not provide and accurate answer

    How do I compress a file on a Mac.  I do not see and option to compress a file when I right click on it and the Apple help does not provide and accurate answer

    Select the file with one click, then go to File in the menu bar and select Compress...
    By the way Niel's post says control - click. This means click with the control key held down. It produces the same result as going to File in the menu bar and selecting Compress...

  • So if Aperture does not provide the ability to burn photos to dvd/cd how do you go about doing that?

    So if Aperture does not provide the ability to burn photos to dvd/cd how do you go about doing that?

    Simply mount a disc in the drive, then in Aperture Export your versions to that location.  Later in the Finder, Burn.  No need for special function.
    Ernie

  • How does a switch learn its route

    Hi
    I have a cisco switch and somehow it finds the best route through different routers, I tested this with traceroute from the switch. How does the switch learn these routes?
    Thanks
    Dan

    Hi Rick
    Thanks for the info. My switch is a 3500 layer 2 switch. Here's the config for my switch:
    Current configuration:
    ! Last configuration change at 16:04:28 GMT Wed Mar 15 2006
    ! NVRAM config last updated at 09:49:35 GMT Wed Apr 27 2005
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    hostname switch1
    enable secret 5 ttttttttttt
    clock timezone GMT 1
    ip subnet-zero
    ip name-server 10.11.10.2
    ip name-server 10.11.10.1
    cluster enable l3 0
    cluster member 1 mac-address 0007.ebc9.9380
    cluster member 2 mac-address 0007.ebc9.94c0
    cluster member 3 mac-address 0007.853f.6d00
    interface FastEthernet0/1
    switchport access vlan 102
    interface FastEthernet0/2
    duplex full
    speed 100
    port monitor FastEthernet0/8
    switchport access vlan 110
    interface FastEthernet0/3
    switchport access vlan 102
    interface FastEthernet0/4
    switchport access vlan 102
    interface FastEthernet0/5
    port monitor FastEthernet0/19
    port monitor FastEthernet0/22
    switchport access vlan 100
    interface FastEthernet0/6
    switchport access vlan 101
    interface FastEthernet0/7
    duplex full
    speed 100
    switchport access vlan 102
    interface FastEthernet0/8
    duplex full
    speed 100
    switchport access vlan 110
    interface FastEthernet0/9
    duplex full
    speed 100
    switchport access vlan 102
    interface FastEthernet0/10
    duplex full
    speed 100
    switchport access vlan 102
    interface FastEthernet0/11
    duplex full
    speed 100
    switchport access vlan 102
    interface FastEthernet0/12
    switchport access vlan 101
    interface FastEthernet0/13
    switchport access vlan 102
    interface FastEthernet0/14
    duplex full
    speed 100
    port monitor FastEthernet0/23
    switchport access vlan 102
    interface FastEthernet0/15
    duplex full
    speed 100
    switchport access vlan 102
    interface FastEthernet0/16
    duplex full
    speed 100
    switchport access vlan 108
    interface FastEthernet0/17
    duplex full
    speed 100
    switchport access vlan 108
    interface FastEthernet0/18
    duplex full
    speed 100
    switchport access vlan 102
    interface FastEthernet0/19
    duplex full
    speed 100
    switchport access vlan 100
    interface FastEthernet0/20
    duplex full
    speed 100
    switchport access vlan 108
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 108
    switchport mode trunk
    interface FastEthernet0/21
    duplex full
    speed 100
    port monitor FastEthernet0/7
    switchport access vlan 102
    interface FastEthernet0/22
    switchport access vlan 100
    interface FastEthernet0/23
    duplex full
    speed 100
    switchport access vlan 102
    no cdp enable
    interface FastEthernet0/24
    switchport access vlan 102
    interface GigabitEthernet0/1
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 102
    switchport mode trunk
    interface GigabitEthernet0/2
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 102
    switchport mode trunk
    interface VLAN1
    no ip address
    no ip directed-broadcast
    ip nat outside
    shutdown
    interface VLAN102
    ip address 10.11.8.21 255.255.248.0
    no ip directed-broadcast
    ip nat outside
    ip nat inside source list 199 interface VLAN102 overload
    logging facility local6
    logging 10.11.9.21
    logging 10.24.21.1
    access-list 199 dynamic Cluster-NAT permit ip any any
    banner motd ^C
    Switch 1
    ^C
    line con 0
    password 7 xxxxxxxx
    transport input none
    stopbits 1
    line vty 0 4
    exec-timeout 35000 0
    password 7 xxxxxxxx
    login
    line vty 5 15
    password 7 xxxxxxxx
    login
    ntp clock-period 11259714
    ntp server 10.11.9.21
    end
    I haven't got a default gateway, any idea how its finding its route?
    Thanks again
    Dan

  • How do you use Airport extreme at hotels etc, when traveling? I can plug my computer into the Airport with my ethernet but how does Airport pickup signal?

    How do you use Airport extreme at hotels etc, when traveling? I can plug my computer into the Airport with my ethernet but how does Airport pickup signal? What equipment & devices do I need to travel with to make this possible?

    You may mean the AirPort Express.....not AirPort Extreme.....as the Express is a popular travel router.
    The whole idea behind using this device is that the hotel must provide an Ethernet jack in the hotel room. Then you connect the AirPort Express to the Ethernet jack with an Ethernet cable and configure it to provide your own wireless network in the room. You still have to agree to terms, pay the fees, etc.
    The problem with this approach is that it is getting very difficult to find hotels in North America that prrovide an Ethernet jack....most have moved to wireless networks and the others are not far behind.
    So, if the hotel is already providing a wireless signal, the AirPort Express is of no use in that situation.
    If you normally stay at the same hotels, and know that they provide Ethernet ports, an AirPort Express might make sense in terms of convenience.

  • How does Facebook application utilize Blackberry push based architecture?

    Hi Friends,
    I have posted this message in Blackberry Java Development forum. But was told that "if you are not RIM you will not be able to use the push-architecture with BIS". 
    Here goes the actual message. Please provide your valuable inputs.
    I am developing an Blackberry client application which will be similar to Facebook application for Blackberry.
    Since, this application can be  download by any blackberry user who would be subscribed to different BES or BIS, how will the push based architecture of BB work here.
    See my previous post 'Push content to devices on different BES' (http://supportforums.blackberry.com/rim/board/message?board.id=java_dev&message.id=3196&jump=true#M3196), which says that push will work through BES.
    If that is the case,
    How does the FaceBook application for Blackberry work?
    Users who download the Fackebook application will definetly not be on the same BES or might be on BIS as well.
    Then how will Facebook application receive notificatios and messages instantly using blackberry's push architecture?
    (http://www.blackberry.com/news/press/2007/pr-24_10_2007-01.shtml)
    Does RIM provide any framework or support for developing facebook like applications which would utilize push architecture irrespective of BES or BIS?
    Thanks,
    Suresh.

    Facebook doesn't use the BlackBerry network, it uses the standard data network.  If you're on BES, that typically is routed through your BES server.  If you're not on a BES, it will use BIS.
    I don't believe the application is a "push" application either - it's more likely a real time IM client. 
    Jerry

  • HT204053 My daughter and me use the same cloud ID and to buy songs and now all her contacts ended up on my new iphone 5  and I manually erased all from my phone and now they are gone from her phone.  How does she get back her contacts?

    My daughter and me use the same cloud and apple id to buy songs in the past.  I got first iphone 5 and after trying to set up itunes to phone I ended up with all my daughters contacts from her iphone on my iphone.  I then deleted them from my phone one by one and now they are gone from her phone as well.  How does she get them back on hers and what happen????  Help with cloud!

    That's what happens when you share the same iCloud account.  First, migrate his phone to a different iCloud account using a different ID (you can continue to share the same ID for other services such as iTunes if you want).  To do this, on his phone save any photo stream photos that he wants to keep to his camera roll (unless already there) by opening your my photo stream album, tapping Select, tapping the photos, tap the share icon (box with upward facing arrow), then tapping Save to Camera Roll.  If he are syncing notes with iCloud that he wants to keep, you'll need to open each of your notes and email them to him so he can later copy and paste the text into new notes created in his new account.  Then go to Settings>iCloud, tap Delete Account (which only deletes it from this device, not from iCloud; this won't effect your phone), provide the password to turn off Find My iPhone and choose Keep on My iPhone when prompted.  Then sign back in with a different Apple ID to create his new account and choose Merge to upload the data.  After doing this, he can go to icloud.com and safely delete your data from his new account.
    Then, if your contacts were on your phone when you last backed it up to iCloud, you can restore them by following Winston Churchill's user tip here: https://discussions.apple.com/docs/DOC-4841.  This involves turning off your wifi after your phone restarts during the restore process, then saving the contacts on your phone and deleting them from iCloud prior to turning your wifi back on and allowing the restore process to finish.  You can turn off your wifi either by pulling the cord out of the WAN port in your wifi router, or by simply unplugging it.

  • How does the time capsule work?

    I am unfamiliar with this device. Can anyone explain how this works? I have a Gateway NV79, an IPad 2 and an IPhone. Will the time capsule work with these devices and a printer(Officejet Pro 8600)? If so, how does it do this? I am also wondering how it works as a router? Does it provide the internet access itself or do you have to have a separate source of internet to link to the device?

    A Time Capsule is a wireless router and a hard drive in one package. It does not have a modem built in, so a modem and broadband service is required if you want to be able to connect to the Internet.
    As a wireless router, the Time Capsule can provide connections for up to 50 users and 3 wired Ethernet devices. If you need more Ethernet connections, a switch can be easily added to the Time Capsule for that purpose.
    Your printer could connect to the Time Capsule using either a wired Ethernet connection or wireless connection
    Apple's literature does a good job of describing the product. Be sure to click the links in the upper right hand corner of the main page to learn more about the Backup capabilities, Wireless performance, and detailed Specifications.
    Time Capsule

  • How does Imac connect to the internet?

    How does Imac connects to the internet?

    Through your ISP (internet service provider); once you set up an account with them, you can decide to connect via ethernet cable to their modem, or, if you have a router (which is connected to their modem, you can connect wirelessly.
    Is that what you were wondering about or did I misunderstand your question?

Maybe you are looking for