How is serial interfacing done in labview

how is serial interfacing done in labview

well i would like to send a command A0H to digital video recorder and recieve acknowledgements at serial port. in order to recieve i am calling the visa read function. but i am recieving no response of acknowledgement string.
well i am able to send eject command (2AH)successfully, but i am not recieving any response string from digital video recorder
i am using digital video recorder DSR-20/20P.
moreover when i call read vi for time code request, i get error message (-1073807339). may be the read function i am calling is not the right one?
i am sending my source code. can u correct it please.
Attachments:
serial_port_digital_recording.vi ‏51 KB

Similar Messages

  • How would I interface an instrument with a serial UART output to LabVIEW?

    I am trying to gather some information on a upcoming project. I have a instrument that outputs a serial UART stream. I would like to interface this with LabView. This is the product that I am planning to interface with. http://www.pressureprofile.com/products-digitacts.php I am just learning how to use LabView so this is all new to me, any help would be greatly appreciated.

    First- I would recommend takinga look into the Basic serial read and write example that ships with LabVIEW.  Second, RTFM (Read The Friendly Manual) for the device.  A Google search for serial comms will provide a reasonable backround for how serial comms can be configured. 
    As to how to implement the specific serial protocol in LabVIEW-- well, use a VISA call to the serial port to configure the various properties of the VISA ser:instr class and IF you learn the equipment's expected settings and what, and when, it responds, the "nuts-and-bolts" of wiring your device driver becomes reasonably simple.
    Jeff

  • How to upgrade IP/KVM Console AF620A via serial interface?

    Hi
    I've got a "HP 1x1Ex8 KVM IP Console Switch G2 with Virtual Media CAC Software - AF620A" which is not booting correctly anymore.
    Symptoms:
    - blank screen
    - status leds constantly blinking
    - serial output hangs after "Booting:1.2.10.15038"
    Hooking up to the serial interface, the terminal gives me, that the current version as well as the alternate version of the used firmware is 1.2.10.15038. As far as I was able to find out, I should upgrade to the latest firmware in order to get rid of the problem and make the device usable again.
    My problem is, that I don't know how to upgrade the firmware via the serial console, knowing that the device is not booting up the firmware.
    Yes, I've done a factory reset as well as a configuration reset. No change ...
    I've opened up the case to see if there is any hardware reset button, but there is none. The only thing I found is a 4pin header labeled "HDR2" but neither the user guide not the technical guide gives any details about the interior of the device (of course not ...).
    Has anyone had the same problem with this or any similar device?
    Or does anyone has a good advice what I could try to revive the KVM?
    greetings

    I finally got through the helpline, but as my device is out of warranty, the official solution for my problem is to buy a new device!
    Ending is better than mending ... welcome our the brave new world ...

  • Labview communication to Hart equipment using serial interface

    I am trying to communicate with various Fluke / Hart temperature equipment (Chubb E4, 9107 Dry well..) with LabView 8.0 thru the serial interface. I have the list of commands from Hart but they are not the same as the typical serial write / read commands and are not working. I am communicating to other equipment using the serial interface with normal serial command formats (i.e.  001c000000FABD, etc... ) but Hart commands are single letters (i.e.   t<CR> )   for reading the temperature. I'm not sure if the problem is with Hart or LabView VIs that I am using.
    Thanks in advance

    I'm sorry.  I was the one who jumped to the conclusion that it was Hart protocol.
    You are using in USB/RS-232 converter.  I assume you see this as another Com port on your computer.  I've used these devices before without problems, those a few people on the forums have said that certain brands just haven't worked for them.
    As I said before, double check all the baud and parity settings.  Double check that you have the right cable, whether it need to be null modem or a straight through cable.
    The manual  ftp://ftp.hartscientific.com/manuals/9105-07.pdf looks like it should be a null modem cable.
    Check that  you are actually sending out a CR character at the end of your string.  Do you need to send a capital T or a lower case t.  That actually messed me up for a few minutes recently on a device I was trying to communicate with.   t<CR> should look like t\r if the constant you are writing is set to \codes display or 74 0D (lower case t) or 540D (upper case T).
    Is the device set up to return a line feed in its response?  Have you provide enough of a delay between the VISA write and read to give the instrument time to send the response?
    Try things in hyperterminal.  It is a simple place to start to see if you have basic communication there.  If you do, then you can focus on the LabVIEW.  If you don't, then you know the issue is with the wiring, device, or Windows driver or settings.
    Are you using the basic LabVIEW VI's for Serial Read and Write or VI's that from somewhere else?  You said "I'm wondering if LabView's VIs are feeding the newer information in the old format or something like that."  LabVIEW is only going to send out whatever you tell it to send out. 
    Sorry it's a bunch of questions rather than answers, but hopefully it gets you looking in different areas that you may not have thought of.

  • Can someone tell me how to emulate serial terminal window in labview??

    Hi can someone tell me how to emulate serial terminal window in labview?  or provide me simple code to do it? 
    baud rate 9600

    Have you tried looking through the example finder?  There's a a few great examples in there on how to read from and write to a serial port.  In LabVIEW just choose Help > Find Examples... and then navigate to Hardware Input and Output > Serial > Basic Serial Write and Read.vi
    David_L | Certified LabVIEW Architect
    LabVIEW Tools Network | LabVIEW Tools Network Developer Center

  • Communication through RS232c serial interface using labview

    i am trying to communicate with a device through RS232c serial interface using labview 6.1....i have tried to run the example "Serial communication.vi" provided in 6.1 and it doesnt work....do i need any special hardware or do i need to configure my hardware to communicate through RS232c...
    thanks in advance
    shri

    Seems like I placed a small (maybe 30ms) delay at the end of the serialcommunications.vi structure.. for some reason my PC didn't like running as fast as it tried to go. Also look into the actual serial communication.vi and open the vi's inside it - check that the port setting (0 or 1) are ok, the baud rate (probably 9600) are ok. I'm running with only three wires in my application, TX, RX and Common. The PC may need to be rebooted to enable the com port - or use device manager and see if it says the com ports 0 and 1 are both OK..
    Try buildinga loopback plug with TX to RX, RX to TX, and Common to Common and see if hyperterminal (or other serial communications program works - there is also Loopback.VI in the NI library somewhere that can be used. Good Luck!! Dave

  • How to use the serial interface to control the oscilloscope tds1012

    The driver for tds1012 we downloaded from the site is not working with the serial interface. And to do the same we have to set the serial settings on the instrument to be the same as the serial settings on the block diagram.Can anyone help me ,how to do the settings?

    Have you referred to the manuals for the oscilloscope, that information is typically contained within them.
    ~~~~~~~~~~~~~~~~~~~~~~~~~~
    "It’s the questions that drive us.”
    ~~~~~~~~~~~~~~~~~~~~~~~~~~

  • How can i interface labview to Two way Radio freq (452 MHZ, 450 MHZ) transrecei​ver for point to point communicat​ion?

    Transreceiver specications are nearabout
    point a to point b message 452 MHZ
    and point b to point a message 457 MHZ
    transmit power 2 watt
    Transmitting 16 bit data

    The PXI-5660 RF Signal Analyzer is a PXI-based hardware product from National Instruments that can receive signals from 9 kHz to 2.7 GHz with a 1 W max input power. If you transmit at 2W and after reaching the antenna connected to the 5660 the power is > 1W (+30 dBm), you will need an attenuator in front of the 5660 to bring the signal level down to a point which the 5660 can handle.
    As for the Tx side, you can Tx with the PXI-5670 RF Vector Signal Generator at a max output power of +13 dBm, which is ~20 mW. You would need an RF amplifier for sure between the PXI-5670 output and the ensuing antenna.
    In both cases, the devices come with software to control them that are LabVIEW-based and quite easy to use. If you already have RF Tx and RX hardware, they
    probably have LabVIEW drivers, or some other interface with which LabVIEW can interact with. I recommend contacting NI at 1-800-IEEE-488 and asking for an internal sales representative to discuss your app with. Or, you can post more details here and I can definitely answer your questions.

  • How to program different graphical interface in a labview

    Hi
     i  adding different graphical inface in labview,by taking tab control in that add menu,go-online, and some function,i did this for touch screen by clicking it go on linking..I attached this i, already did  some partr in labview.I also attached ms_Paper prasentation refference  i doing this,give me the solltion how to link these slides in labview
    Attachments:
    temlate.vi ‏21 KB

    Sham,
    If English is your second language you might want to post on another forum.  I am really not sure what you are trying to do but you are telling us, "give me the sollition how to link these slides in labview"  so I'll attach a community example you may want to look at. 
    https://decibel.ni.com/content/docs/DOC-34150
    Also, if you are going to attach code, please do something in the block diagram.  I have almost no idea what you want to do and opening the VI did not help at all.
    Matt J
    Professional Googler and Kudo Addict
    National Instruments

  • How to call another program from LabVIEW?

    Hi!
    Is there anyone that can answer my question? I have found a similar thread where the user needed to call labVIEW from some program but I want to do the opposite.
    I made a program in labVIEW that communicates via COM-ports (serial communication) with the processor I use at the job (Ubicom´s IP2022).
    Now I want to add more funcionality to this program. I want to be able to program re-program IP2022 through this LabVIEW application.
    The programming is done via an Ethernet-dongle. I start a program called IP2kProg, I write the ip-address of the dongle and the program-file (.elf) downloads at this address. But how can I do this from
    LabVIEW, do I need to open IP2kProg or can I send some values to it via LabViEW?
    Ant suggestions?
    Thanks, Amir

    Amir,
    There are couple of options:
    1.  If your IP2kProg program has a command-line interface, you can use LabVIEW's System Exec.vi and send the commands and parameters to it. 
    2.  If the IP2kProg has an API / exported functions, you can call them from LabVIEW using the Call Library Function Node. 
    Hope this gives you some ideas. 
    -Khalid

  • Advice on constructing a test engine and formatting a spreadsheet test file to perform command line interface testing on a product through telnet or serial interface

    Advice on constructing a test engine and formatting a spreadsheet test file to perform command line interface testing on a range of products through telnet or serial interface and output pass/fail results.

    If I understand correctly, you want to do the following:
    1. Create one or more tab-delimited files that specify a series of query strings (that LabVIEW will send to your products) and expected reply strings (that LabVIEW will look for in response to each query)
    2. Run your LabVIEW program (the test engine) and have it execute one or more test scripts from file using either TCP/IP or serial communication to your units under test
    3. Track how many of the queries are met with the expected response, and output an indication of whether each step passed or failed
    If this is close to correct, then I've attached a sample test file and LabVIEW VI as an example; I chose the TCP/telnet method because it allowed me to use the ni.com Web site to simulate my tes
    t hardware. If you happen to own the LabVIEW Internet Toolkit, there's a VI called "Telnet Play Script" in the Telnet palette that does something fairly similar using TCP. The same general model would also work for Serial communications.
    Hope it helps,
    John Lum
    Attachments:
    test_engine.zip ‏24 KB

  • Advice on constructi​ng a test engine and formatting a spreadshee​t test file to perform command line interface testing on a product through telnet or serial interface

    Advice on constructing a test engine and formatting a spreadsheet test file to perform command line interface testing on a range of products through telnet or serial interface and output pass/fail results.

    Hello j. smith,
    TestStand gives you the ability to create "sequence files" which are lists of tests to be run sequentially or in parallel. These tests can be written in any language: LabVIEW VIs, C/C++ DLLs, EXEs, ActiveX objects, .NET Assemblies, etc.
    You can run your TestStand sequence files from a command-line prompt using the following syntax:
    \bin\SeqEdit.exe" /quit -run
    This will launch the TestStand Sequence Editor (and optionally prompt you for TestStand login information if you have this configured), run your sequence file, then exit.
    If you're using the TestStand process model, it can output your results to a report file or database if you configure this. To use a TestStand process mo
    del to execute your sequence file, use the following syntax:
    \bin\SeqEdit.exe" /quit -runEntryPoint
    Here's an example:
    C:\>"C:\Program Files\National Instruments\TestStand 3.0\bin\SeqEdit.exe" /quit -runEntryPoint "Single Pass" "C:\Program Files\National Instruments\TestStand 3.0\Examples\Demo\C\computer.seq"
    Note that multiple sequences and sequence files can be specified on the command line.
    TestStand supports remote sequence execution using DCOM (Distributed COM), which is an east way to remotely execute tests. But as for running tests or commands through a telnet or serial interface, you would have need to check Windows documentation on how to execute command-line remotely like this.
    David Mc.
    NI Applications Engineer

  • Serial interfaces, ip vrf forwarding, and PBR with set vrf

    I am doing some work with VRF-lite but I am having some trouble with serial interfaces. I have a PE router with a serial interface where I want to take incoming traffic and using policy-based routing send the traffic to the appropriate VRF. I want to assign the serial interface itself to be in one of those VRFs, not the global routing table. Eventually, I also want to overlap the VPNs/VRFs to send traffic going out the serial interface through the VRF assigned to the serial interface. Initially, it looks something like this:
    ip vrf VRF1
    rd 65000:3
    route-target export 65000:3
    ip vrf VRF2
    rd 65000:18
    route-target import 65000:3
    ip route vrf VRF1 10.90.51.0 255.255.255.0 192.168.11.18
    interface Serial0/0/0
    ip vrf forwarding VRF1
    ip address 192.168.11.17 255.255.255.252
    router bgp 65000
    no synchronization
    bgp log-neighbor-changes
    no auto-summary
    address-family ipv4 vrf VRF1
    redistribute static
    no auto-summary
    no synchronization
    exit-address-family
    ip access-list extended remote-source
    permit ip 10.90.0.0 0.0.255.255 any
    route-map SERIAL-INCOMING permit 100
    match ip address remote-source
    set vrf VRF2
    But if I try to turn on the policy based routing at the serial interface, I get an error:
    Router(conf)#interface Serial0/0/0
    Router(config-if)#ip policy route-map SERIAL-INCOMING
    % Can not apply route-map SERIAL-INCOMING to this interface
    % Either remove 'set vrf' from route-map or unconfigure 'ip vrf forward'
    I can sort of get around the problem by using an "ip vrf receive" instead of "ip vrf forward", but unfortunately, that leaves my Serial interface in the global table which isn't what I wanted.
    What troubles me is that I can do this without any problems on an Ethernet interface. Are there any known issues with "ip vrf forward" and using PBR and "set vrf" on Serial interfaces, or have I configured something wrong?
    If I stick with the "ip vrf receive", how can I force the physical Serial interface into the appropriate VRF?
    Thanks.
    Clarke Morledge
    College of William and Mary

    Upon further investigation....
    The serial interface issue was a red herring. It just so happens that every other time I've done this it has been on a flavor of 12.2x on a 6500/7600 where this feature is supported. The only systems I have with Serial interfaces are 1841s.
    The problem with the 1841 is that most of the code revisions out there do not support this feature. It was only added to the regular code train with the recent release of 12.2(24)T. I tested with 12.2(24)T1 and you are now able to use "ip vrf forwarding" on all interfaces along with a PBR route-map that uses the "set vrf" option.
    Thanks, Laurent, for pointing me towards the TAC on this.
    Clarke Morledge
    College of William and Mary

  • Third Party Bluetooth Serial Interface

    Hi,
    I have a third party EEG headbox with bluetooth connectivity using serial interface. I did the followings:
    From Bluetooth, added the device that was successful. Furhtermore, two unidirectional ports were added to the device i.e. COM3 (incoming) and CoM4 (outgoing) - VISA
    The device is successfully accepting the commands i sent with a beep acknowledgement.
    The followings are the issues.
    The device is not responsing with any data i.e. nothing coming to pc/ laptop because of the device is using two unidicrectional COMs.
    Query:
    How can i assign the one COM to the device so that i can receive the bytes as well.
    Regards,
    Abdul 

    You may have to make some compromises have a look at
    iMuffs
    www.wi-gear.com
    While they don't satisfy all your requirments have a look

  • C-Series Module NI 9871, 4-Port, RS485/422 Serial Interface

    I have a question regarding the C-Series Module NI 9871, 4-Port, RS485/422 Serial Interface.
    I need to find out how it recovers the data from the link. I need to compare it with 8b/10b encoding.
    Does anyone know what UARTs are used or how the data is recovered.
    Thanks
    John Lee

    Hi John,
    I have had a look into this and I cannot find any specific information on the Transciever or UART. However I have come across an example using the 9871 with processing on a cRIO FPGA.
    To find this example open up Labview » go to Help » Find Examples » Search for 9871 and open up NI-987x Serial Loopback.lvproj.
    Hopefully this should give you a good start. Once your serial data is passed onto the FPGA you can then decode the 8b/10b within the FPGA code.
    Best Regards,
    Ben B.
    Applications Engineer
    National Instruments UK & Ireland
    "I've looked into the reset button, the science is impossible!"

Maybe you are looking for

  • Can I use my iPod to copy files from one PC to another?

    I recently bought a Mac Powerbook and an iPod, and want to move all my personal stuff off my work laptop (an IBM ThinkPad) onto the Powerbook. Most of my files are photos, Word documents, excel files; only a few are music files. When I bought the Pow

  • Missing pictures in iPhoto

    Today when I opened iPhoto it said it could not find the Library. When I searched for the Library I found that all the pictures in it were grayed out and cannot be accessed. What happened and how can I fix it, Thanks.

  • Very long shutdown time after Yosemite install

    After installing Yosemite my Macbookpro has shutdown times of over more than 5 minutes. This is what i got from Etrecheck. Problem description: very long shutdown time after yosemite install EtreCheck version: 2.1.8 (121) Report generated 19 Feb 2015

  • Macbook Pro and Verizon LG VX9400 cell phone

    Is it possible to synchronize my Verizon cell phone (LG VX9400) with the MacBook Pro or .Mac account? I am new to the Mac and have a number of contacts in the cell phone to add to the address book in the Macbook. Also via .Mac is it possible to synch

  • Interactive Report Hide all customisations

    Hi, I have an IR and have created a number of highlights. What I want to do is hide the search bar (done by the option in the report) but also the details of the highlights (it shows these in a list just above the report) Is there anyway to hide thes