How to change the source ip address

hi all,
i got the problem that how to change the source ip address when i
get a website's page!
i mean i want to change the source ip address when i access the
remote website, sure i know when change the source ip, i can not get
the result correctly when changing the source ip address, but it is not
important to get the result i just want to send out a "click" event to the website by calling a post method in the site!
does anybody have some ideas?
Best Regards,
Eric Gau

Here's some code that connects to google and does a get:
import java.io.*;
import java.net.*;
public class HTTPTest {
    private Socket sock;
    private BufferedReader in;
    private BufferedWriter out;
    private boolean running = false;
    HTTPTest() {
    private void go(String site) {
        try {
            sock = new Socket(site, 80);
            in = new BufferedReader(new InputStreamReader(sock.getInputStream()));
            out = new BufferedWriter(new OutputStreamWriter(sock.getOutputStream()));
            System.out.println("Connected");
            out.write("GET / HTTP/1.1\r\n\r\n");
            out.flush();
            doRead();
        } catch (IOException e) {
            e.printStackTrace();
    private void doRead() {
        running = true;
        String line;
        System.out.println("Read started");
        while (running) {
            try {
                line = in.readLine();
            } catch (IOException e) {
                e.printStackTrace();
                line = null;
            if (line == null) {
                running = false;
            } else {
                System.out.println(line);
        System.out.println("Socket closed");
    public static void main(String [] args) {
        String site;
        if (args.length > 0) {
            site = args[0];
        } else {
            site = "google.ca";
        new HTTPTest().go(site);
}

Similar Messages

  • I have read the help info, but I can't find how to change the default email address, to the one that is my adobe I'd?

    I have read the help info, but I can't find how to change the default email address, to the one that is my adobe I'd?

    Adobe Reader for iOS doesn't set the default email address when you email a PDF.
    It's found in the Settings app:
    Settings > Mail, Contacts, Calendars > Mail > Default Account

  • How to change the source level in java Studio creator

    Hi,
    I am using Sun Java Studio Creator 2 Update 1 IDE, in this IDE how to change the source level to 1.5 for an existing project.
    Thanks in advance,
    Rajesh.

    Hi!
    Unfortunately Sun Java Studio Creator 2 Update 1 doesn't support 1.5 source level. But You can try to download NetBeans IDE (from http://www.netbeans.org) and there with Visual Web project You will find the same functionality as for Creator. And 1.5 source level is supported by NetBeans.
    Thanks,
    Roman.

  • How to change the source module version

    Hi All,
    In the OWB i created a source module and during those steps i clicked on version 10.1, but during deployment in the deployment managaer when i tried to register the location, its giving me an error as "Source verison 10.1 is not matching with the target version 10.2", can any one please help me or Advice me as to how to change the "source module version"?
    Thanks

    Hi
    what i understood is that the source module is associate with the location and you have provided the 10.1 which you need to change.
    so you can change that under location.
    Cheers
    Nawneet

  • I need to know how to change the identity (email address) used for the iTunes store as I no longer use that email

    I need to know how to change the identity (email address) used for the iTunes store as I no longer use that email.

    Settings > iTunes & App store.
    Tap AppleID, sign out then sign back in.
    The Apple ID is right everywhere else. I've synced the phone. I've reset it in Settings on the phone. I've changed it at Apple.
    When you write, "I've changed it at Apple, this means you updated yoru old AppleID or you ceated a new AppleID?

  • How to change the source type for a primary key on a form?

    Hi,
    At the time of creating a form, I had set the source type for the primary key to an existing sequence.
    Now I want to change the source to a trigger.
    Can anyone suggest how to do it?
    Thanks in advance,
    Annie

    Annie:
    Define the trigger and then delete the page process named 'Get PK'
    Varad

  • How to change the source system for just a datasource

    Hi,
    Our test/development BI system ( BI 7.0 Unicode ) is connected to our development system and to our test system, 1 BI system connected to 2 R/3 systems.
    During some time, the test system won't be available so all datasources that point to the test system must be connected to the development system. In RSA1 is not possible to change the source system in a datasource: RSDS 057
    'Creation of DataSources for SAP source system D30CLNT007 is not permitted' , same error trying to copy the datasource,.
    Any idea about how to proceed ?
    Regards,
    Joan

    Hi,
    If I try to repliclate metadata in the datasource, message RSAR 051 appears: 'error when opening an RFC connection'. This error is expected because the logical system pointed in the datasource does not exist.
    Is not possible to change the source system in datasource ( in RSA1 ) because the field is always greyed, also if I try to copy the datasource the message RSDS 057 appears.
    Any idea about how to proceed ?
    Regards,
    Joan

  • How to change the Source system from ONE DataSource?

    Hi,
    I'm trying to change a DataSource's source system (active with dtp and transfer rules), but it's not possible to  do it in change mode because the field 'Source Sytem' is not enabled. I know I can use the BDLS transaction but I understand that this is for change all Datasources and I only want to change one of all.
    Thanks for your help

    Hi Marcel,
    As I understand apart from file and web services all other data sources are replicated from underlying source system. BDLS transaction is used to change the source system but in case of system copy activity and it is necessary because the data sources points to old source system.
    In your case as I understand you will have to replicate the current data source directly from underlying source system and then build the rest of the flow. May I know how you have got this single data source for which the source system is different?
    Regards,
    Durgesh.

  • WRT54G router IP address is the same as my modem's IP address. how to change the routers IP address?

    The broadband modem got broken and the ISP changed it to a new modem. Now my problem is I cannot use the router when they changed the modem. The ISP won't provide support since they didn't provide me with the wireless router. I've read through the forum and found that I had to change my router's IP address. WRT54G router IP address is the same as my modem's IP address, 192.168.1.1. I already changed the local IP address of the router to 192.168.1.2, saved the setting, released and renew the ip address. Now, when I connected my internet modem cable to the router, I cannot connect to the internet. I am able to ping 192.168.1.2 but I cannot connect to the ping 192.168.1.1. Please help me do the proper setup.
    Thanks!

    Hello! I solved my problem but I find the solution so weird. After changing the routers IP address to 192.168.1.2, instead of plugging the modem cable on the Internet port of the router, I plugged it in one of the WAN ports. Presto, it worked. Even my wireless connection is also working.

  • How to change the dynamic IP address to Static IP Address in Solaris 10X86

    Hi,
    I have installed Solaris 10X86 in a VM.While installing Solaris I have enabled DHCP.So its created with dynamic IP Address.Now I want to change the dynamic IP address to static IP address.Please anyone can help me to sort out this problem.

    Hi,
    I have installed Solaris 10X86 in a VM.While installing Solaris I have enabled DHCP.So its created with dynamic IP Address.Now I want to change the dynamic IP address to static IP address.Please anyone can help me to sort out this problem.

  • How to change the name / IP address and domain name for BOE Server

    Hello,
    We want to change the name / IP address and domain name for BOE Server, please could you indicate the steps or procedure to follow?
    I need your help
    thank you

    If it's 3.1 just change them, shouldn't cause any issues if by domain name you are referring to changing the domain the computer belongs to. If you are changing your domain for AD authentication then you will may have to take quite a few steps if the old domain is going away. Let us know.
    Regards,
    Tim

  • How to change the source file of audio elements

    Hi,
    I am using adobe edge version 3 to add audio to a website.I use both .ogg and .mp3 files.
    Inside the _edge.js file the audio element has 2 sources (one for .ogg and one for .mp3)
                    id: 'audio_element_id',
                    type: 'audio',
                    tag: 'audio',
                    rect: ['0', '0','320px','45px','auto', 'auto'],
                    source: ['source_file.mp3','source_file4.ogg']
    I want to change the source file of the audio_element programatically......
    So i am using the following code inside edgeActions.js to change the source
    sym.$("audio_element_id")[0].src="new_source_file.mp3";
    But this will change the source of both(.mp3 and .ogg ) to  new_source_file.mp3
    I want to change the source induvidually. What should i do??
    Also I wanted to know what " [0] " stands for in " sym.$("my_audio_element")[0].play(); "
    Please give me an example of a situation wherein i have to change the value of [0].
    Thank you
    Nithin

    you should create a different directory for each dvd on your hard drive and put the files where they belong eg: dvd1, dvd2, dvd3
    then create 3 bins in your project manager called dvd1, dvd2, dvd3 and put the relevant files into the bins ( can import whole folders into each respective bin )
    OR rename your files using something like " renamer" before importing to premiere
    otherwise youll have a mess of a time trying to figure out whats what...maybe someone else has a better solution

  • How to change the emmbedded ip address in sip using nat

    i have traffic on a private ip range sending sip traffic that is being natted to another range on a cisco router. how do i get the nat router to change the ip address embedded in the sip to the nat address.

    Hi Daniele,
    Thanks. But this is already enabled.
    This is my present config and show ver.
    sh ver
    Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9_NPE-M), Version 15.0(1)M2, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2010 by Cisco Systems, Inc.
    Compiled Wed 10-Mar-10 22:27 by prod_rel_team
    ROM: System Bootstrap, Version 15.0(1r)M6, RELEASE SOFTWARE (fc1)
    NORF50IPT1 uptime is 1 day, 23 hours, 26 minutes
    System returned to ROM by reload at 11:21:52 MSD Sat Aug 20 2011
    System image file is "flash0:c1900-universalk9_npe-mz.SPA.150-1.M2.bin"
    Last reload type: Normal Reload
    Last reload reason: Reload Command
    interface GigabitEthernet0/0
    description link to Avaya PBX
    ip address 146.30.106.250 255.255.255.252
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    ip address 192.168.211.106 255.255.255.0
    ip accounting output-packets
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    ip nat service allow-multipart
    ip nat inside source static 192.168.1.10 192.168.211.106 route-map ipt
    access-list 1 permit 192.168.1.0 0.0.0.255
    route-map ipt permit 10
    match ip address 1
    here is the output from a debug ip nat sip:-
    *Aug 22 10:57:26 MSD: NAT: map match ipt
    *Aug 22 10:57:26 MSD: mapping pointer available mapping:0
    *Aug 22 10:57:26 MSD: NAT: New entry added to map hash table
    *Aug 22 10:57:26 MSD: NAT: i: tcp (192.168.1.10, 52435) -> (192.168.111.2, 5060)
    *Aug 22 10:57:26 MSD: NAT: created edit_context (192.168.1.10,52435) -> (192.168.111.2,5060)
    *Aug 22 10:57:26 MSD: NAT: s=192.168.1.10->192.168.211.106, d=192.168.111.2
    *Aug 22 10:57:26 MSD: NAT: o: tcp (192.168.111.2, 5060) -> (192.168.211.106, 52435)
    *Aug 22 10:57:26 MSD: NAT: s=192.168.111.2, d=192.168.211.106->192.168.1.10
    NORF50IPT1#
    *Aug 22 10:57:52 MSD: NAT: map match ipt
    *Aug 22 10:57:52 MSD: mapping pointer available mapping:0
    *Aug 22 10:57:52 MSD: NAT:refcount increased to entry in map hash table
    *Aug 22 10:57:52 MSD: NAT: i: tcp (192.168.1.10, 45661) -> (192.168.111.2, 5060)
    *Aug 22 10:57:52 MSD: NAT: created edit_context (192.168.1.10,45661) -> (192.168.111.2,5060)
    *Aug 22 10:57:52 MSD: NAT: s=192.168.1.10->192.168.211.106, d=192.168.111.2
    *Aug 22 10:57:52 MSD: NAT: o: tcp (192.168.111.2, 5060) -> (192.168.211.106, 45661)
    *Aug 22 10:57:52 MSD: NAT: s=192.168.111.2, d=192.168.211.106->192.168.1.10
    I cannot see it changing the embedded ip in the sip.

  • How to change the web service address of NetBeans generated WS client

    I am currently experimenting with web services using netbeans and Sun Application Server.
    Basically I am creating simple web services using net beans and then deploy them on the app server and then create another pfoject with web service reference to that web service to invoke the service.
    My problem is when a project is deliverd to the production site the the client applications web service reference will need to be configured to refer to the production web service address. But when I looked at the generated web service client code the address is hard coded.
    How can I change the address to the web service of a web service reference created in net beans either using some configuration file (without having to recompile the client) or at runtime.
    Thanks in advance

    bump...

  • How to see the Source IP Address of a client using ACE One-armed-mode to load balance HTTP proxy request

    I'm using an Ace 4710 Appliance deployed in One-Armed mode, using Source NAT to loadbalance HTTP request to a couple of Proxy servers.
    Everything is working fine, but the thing is that I can't see the Clients IP addresses on Proxy's logs, so I can't keep track of them.
    The Interfaces and Nat configs are:
    interface vlan 200
      description Server-Side-VLAN
      bridge-group 5
      nat-pool 5 10.1.1.5 10.1.1.5 netmask 255.255.255.0 pat
      service-policy input VIPS
    interface vlan 300
      description Client-Side-VLAN
      bridge-group 5
    interface bvi 5
      ip address 10.1.1.3 255.255.248.0
      description Client-Server-Virtual-Interface
    ip route 0.0.0.0 0.0.0.0 10.1.1.1
    and the policy map looks like this
    policy-map multi-match VIPS
      class Port80
        loadbalance vip inservice
        loadbalance policy Port80
        nat dynamic 5 vlan 200
    Resource assignment:
    sticky ip-netmask 255.255.255.255 address both RESOURCE-CLASS
      timeout 5
      serverfarm Service80
    Any suggestions will be appreciated,
    Thanks

    Hi Kanwal,
    Thanks for your quick reply,
    I've already tried this but it didn't work. The problem is that I don't manage the proxy servers so I rely on their skills to see the logs.
    The Proxies are Squid. Do you know if they need to do something else on the servers to see that field of the HTTP header?
    But I'll try again tomorrow and let you know how it goes.
    Thank you again.

Maybe you are looking for