Impact in adding VLANs to MST instances dynamically

I am wondering if it's viable to add and remove VLANs dynamically to MST instances. If so, I can make a good traffic balance. However, I read in CCO site that each time some VLAN is added, the MST database is reinitialized, but will it stop the traffic a little, for example ?
Thanks !
Cleber

Hi Cleber,
MST needs to ensure that there is a consistent vlan to instance mapping, else there would be a possibility of bridging loops (see example in the end). That's why the concept of region was introduced: a region is basically a group of switches with same vlan to instance mapping.
As a result, if you are changing the vlan to instance mapping on one switch, MST needs to reconverge because this switch just moved to a different region. The simple solution that was chosen in order to implement that was to restart the MST process from scratch as soon as you change the configuration. There might have been complex optimization, but considering that MST needs to reconverge anyway, they were not going to be very useful. This is basically an issue of MST, not of the implementation. The best work around I know of is to pre-provision vlans and instances in the MST configuration so that they are available when you need them.
Regards,
Francois
Loop example with inconsistent vlan to instance mapping:
Suppose you have two bridge A and B running two instances 1 an 2. A has two ports p1 and p2 connecting to two ports p1 and p2 on B. Instance 1 is blocking p1 on A, instance 2 is blocking p2 on B. Now suppose that vlan X is mapped to instance 2 on A but mapped to instance 1 on B -> vlan X has a permanent loop between A and B. MST prevents this issue by putting A and B in different region, and forcing all the vlans to be handle by a single instance (the CIST) between region.

Similar Messages

  • Adding a VLAN to MST

    Hi all,
    If I have a 6513 with two MST instances and I want to add a VLAN to instance one what is the best way? Does the 6513 have to be reloaded?
    Thanks

    Assuming that your current MST configuration is properly configured...
    set spantree mst {instance} vlan {vlan}
    set spantree mst config commit
    should be the required command syntax on both switches. A reset is not necessary.

  • Error creating process instance dynamically

    I'm creating a proces instance dynamically using the next statement: ProcessInstance.create
    That statement is invoked by an automatic task that is polling a queue for a message. once the message is retrieved the process is created.
    this process is failling in an environment whit Active Directory configured but is working fine in another one without Active Directory
    is there any workaround to fix this?
    thanks in advanced
    An exception occurred while executing a transaction. Details:
    An error occurred while accesing the database.
    Detail:SQL statement: 'unknown'
    Caused by: Connection closed
    fuego.transaction.DatabaseException: An error occurred while accesing the database.
    Detail:SQL statement: 'unknown'
         at fuego.server.persistence.jdbc.JdbcProcessInstancePersMgr.getNextInstanceIn(JdbcProcessInstancePersMgr.java:901)
         at fuego.server.persistence.Persistence.getNextInstanceIn(Persistence.java:405)
         at fuego.server.AbstractInstanceService.create(AbstractInstanceService.java:301)
         at fuego.server.execution.microactivity.BeginMicroActivity.createInstance(BeginMicroActivity.java:91)
         at fuego.server.AbstractProcessBean$51.execute(AbstractProcessBean.java:3662)
         at fuego.server.execution.DefaultEngineExecution$AtomicExecutionTA.runTransaction(DefaultEngineExecution.java:304)
         at fuego.transaction.TransactionAction.startNestedTransaction(TransactionAction.java:527)
         at fuego.transaction.TransactionAction.startTransaction(TransactionAction.java:548)
         at fuego.transaction.TransactionAction.start(TransactionAction.java:212)
         at fuego.server.execution.DefaultEngineExecution.executeImmediate(DefaultEngineExecution.java:123)
         at fuego.server.execution.EngineExecution.executeImmediate(EngineExecution.java:66)
         at fuego.server.AbstractProcessBean.internalCreateInstance(AbstractProcessBean.java:4320)
         at fuego.server.AbstractProcessBean._doCreateInstance(AbstractProcessBean.java:3670)
         at fuego.server.AbstractProcessBean.createInstance(AbstractProcessBean.java:667)
         at fuego.server.AbstractProcessBean.createInstance(AbstractProcessBean.java:746)
         at fuego.components.Process.createInstance(Process.java:106)
         at fuego.components.ProcessInstance.create(ProcessInstance.java:392)
         at fuego.components.ProcessInstance.create(ProcessInstance.java:503)
         at fuego.components.ProcessInstance.create(ProcessInstance.java:461)
         at system.DispatcherDeOrdenesProc.Default_3_0.Instance.CIL_leerColaAIA(Instance.xcdl:18)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:597)
         at fuego.server.execution.EngineExecutionContext.invokeMethodAsCil(EngineExecutionContext.java:1089)
         at fuego.server.execution.EngineExecutionContext.runCil(EngineExecutionContext.java:1289)
         at fuego.server.execution.GlobalAutomaticJMSListeningHelper.executeJmsListener(GlobalAutomaticJMSListeningHelper.java:94)
         at fuego.server.AbstractProcessBean$43.execute(AbstractProcessBean.java:3026)
         at fuego.server.execution.DefaultEngineExecution$AtomicExecutionTA.runTransaction(DefaultEngineExecution.java:304)
         at fuego.transaction.TransactionAction.startBaseTransaction(TransactionAction.java:470)
         at fuego.transaction.TransactionAction.startTransaction(TransactionAction.java:551)
         at fuego.transaction.TransactionAction.start(TransactionAction.java:212)
         at fuego.server.execution.DefaultEngineExecution.executeImmediate(DefaultEngineExecution.java:123)
         at fuego.server.execution.EngineExecution.executeImmediate(EngineExecution.java:66)
         at fuego.server.AbstractProcessBean.runGlobalJmsActivity(AbstractProcessBean.java:3032)
         at fuego.server.execution.GlobalJMSExecutor$1.run(GlobalJMSExecutor.java:126)
         at fuego.ejbengine.EJBProcessBean.executeTask(EJBProcessBean.java:149)
         at fuego.server.execution.GlobalJMSExecutor.execute(GlobalJMSExecutor.java:107)
         at fuego.ejbengine.EJBGlobalJMSExecutor.access$400(EJBGlobalJMSExecutor.java:43)
         at fuego.ejbengine.EJBGlobalJMSExecutor$JMSExecutorWorker.run(EJBGlobalJMSExecutor.java:213)
         at weblogic.work.j2ee.J2EEWorkManager$WorkWithListener.run(J2EEWorkManager.java:183)
         at weblogic.work.DaemonWorkThread.run(DaemonWorkThread.java:30)
    Caused by: java.sql.SQLException: Connection closed
         at weblogic.jdbc.wrapper.JTAConnection.getXAConn(JTAConnection.java:197)
         at weblogic.jdbc.wrapper.JTAConnection.checkConnection(JTAConnection.java:68)
         at weblogic.jdbc.wrapper.Connection.preInvocationHandler(Connection.java:93)
         at weblogic.jdbc.wrapper.Connection.prepareCall(Connection.java:527)
         at fuego.jdbc.FaultTolerantConnection.prepareCall(FaultTolerantConnection.java:388)
         at fuego.database.oracle.OracleDatabaseManager.getNextValForSequence(OracleDatabaseManager.java:137)
         at fuego.server.persistence.jdbc.JdbcProcessInstancePersMgr.getNextInstanceIn(JdbcProcessInstancePersMgr.java:898)
         at fuego.server.persistence.Persistence.getNextInstanceIn(Persistence.java:405)
         at fuego.server.AbstractInstanceService.create(AbstractInstanceService.java:301)
         at fuego.server.execution.microactivity.BeginMicroActivity.createInstance(BeginMicroActivity.java:95)
         at fuego.server.AbstractProcessBean$51.execute(AbstractProcessBean.java:3662)
         at fuego.server.execution.DefaultEngineExecution$AtomicExecutionTA.runTransaction(DefaultEngineExecution.java:304)
         at fuego.transaction.TransactionAction.startNestedTransaction(TransactionAction.java:527)
         at fuego.transaction.TransactionAction.startTransaction(TransactionAction.java:548)
         at fuego.transaction.TransactionAction.start(TransactionAction.java:213)
         at fuego.server.execution.DefaultEngineExecution.executeImmediate(DefaultEngineExecution.java:125)
         at fuego.server.execution.EngineExecution.executeImmediate(EngineExecution.java:66)
         at fuego.server.AbstractProcessBean.internalCreateInstance(AbstractProcessBean.java:4320)
         at fuego.server.AbstractProcessBean._doCreateInstance(AbstractProcessBean.java:3670)
         at fuego.server.AbstractProcessBean.createInstance(AbstractProcessBean.java:667)
         at fuego.server.AbstractProcessBean.createInstance(AbstractProcessBean.java:746)
         at fuego.components.Process.createInstance(Process.java:106)
         at fuego.components.ProcessInstance.create(ProcessInstance.java:392)
         at fuego.components.ProcessInstance.create(ProcessInstance.java:503)
         at fuego.components.ProcessInstance.create(ProcessInstance.java:461)
         at system.DispatcherDeOrdenesProc.Default_3_0.Instance.CIL_leerColaAIA(Instance.xcdl:18)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:597)
         at fuego.server.execution.EngineExecutionContext.invokeMethodAsCil(EngineExecutionContext.java:1089)
         at fuego.server.execution.EngineExecutionContext.runCil(EngineExecutionContext.java:1289)
         at fuego.server.execution.GlobalAutomaticJMSListeningHelper.executeJmsListener(GlobalAutomaticJMSListeningHelper.java:94)
         at fuego.server.AbstractProcessBean$43.execute(AbstractProcessBean.java:3026)
         at fuego.server.execution.DefaultEngineExecution$AtomicExecutionTA.runTransaction(DefaultEngineExecution.java:304)
         at fuego.transaction.TransactionAction.startBaseTransaction(TransactionAction.java:472)
         at fuego.transaction.TransactionAction.startTransaction(TransactionAction.java:551)
         at fuego.transaction.TransactionAction.start(TransactionAction.java:213)
         at fuego.server.execution.DefaultEngineExecution.executeImmediate(DefaultEngineExecution.java:125)
         ... 9 more

    Hi...
    I guess there is no problem with classpath. The program identifies the directory.xml But what happens is when the program executes, the directory.xml file gets corrupted by adding "=" . The corrupted file is pasted :
    <?xml=version="1.0" encoding="UTF-8"?>
    <?fuego=version="6.0.3" build="86775"?>
    <DirectoryConfiguration>=
    <id>default</id>=
    <description>Default=Directory Configuration</description>
    <admin>admin</admin>=
    <adminPass>&lt;encrypted&gt;gGocbn15UL8=</adminPass>
    <presets>=
    <preset=name="xobjects">
    <property=name="participant" value="admin"/>
    <property=name="participant_password" value="&lt;encrypted&gt;gGocbn15UL8="/>
    </preset>=
    So it doesn't recognizes the default id in the directory.xml. Is there any patch or fix available. I don't know why the file gets corrupted. Kindly response if anyone has faced similar problem.
    Regards
    Lin

  • Adding vlans to a trunk ...

    [1] What is the allowed time duration between the two switches if we have added the vlans on one end of the trunk
    and waiting to enter this on the other end of the trunk ?
    [2] I understand if the vlans on the trunk are not the same, then there will be a problem. What would be the problem be and the reasoning behind it.
    Thank you.
    -SN-

    I'll assume you are running transparent if you adding vlans on both ends . There is no time requirement other than you have to have the vlan that you manage the switch on both ends or otherwise you'll lock yourself out . If the vlans are not the same on both ends then the ones that are different will not be allowed across the trunk . The easiest way is to just allow everything initially then delete the vlans you don't need on the trunk one the link is up and you can manage the switch. If you are running client/server then you only have to make your changes on the server anyway.

  • Sending Instance dynamically to multiple participant.

    I have a situation where the count of receiving participants will very from 1 to 5.
    this.participant.next helps in sending instance dyanmically to a participant.
    My question was, How do I send the instance dynamically to multiple partipants.
    Please help

    First thing that comes to mind is to utilize a SPLIT-N JOIN.
    Put 1) an AUTOMATIC, and 2) the activity that needs to have multiple participants in between the SPLIT-N and the JOIN. In the code for the SPLIT, iterate over your variable that contains the counter of participants (intParticipantCount) and do the following:
    1) set another variable for the desired participant (varParticipant)
    2) clone the instance for as many particpants as you have.
    In the code of the automatic, put the "participant.next" code and use your varParticipant
    So if your process looked like the list below, and Activity 2 was the activity that needed to have a dynamic number of participants:
    1) begin
    2) activity 1
    3) activity 2 (has dynamic # of participants)
    4) activity 3
    5) end
    It would now look like:
    1) begin
    2) activity 1
    3) SPLIT-N
    4) Automatic (to set next participant)
    5) activity 2
    6) JOIN
    4) activity 3
    5) end
    All of this assumes that Activity 2 needs to be completed by EACH user. If this is not the case...for example if you want to assign Activity 2 to a dynamic list of users (1-5) but you only want 1 user of the dynamic list to complete the activity, then I have no proven or tested suggestion, but you could perhaps look into seeing if you can 1) create parametric roles at runtime and 2)modify the members of the parametric role during runtime. if this is possible, then at runtime you would create a new parametric role, add the users to it, and set the parametric value. But this approach is all theoretical. Not sure if you can actually do that.

  • We added an dialog abap instance to a system consisting of 3 DI and one CI

    We added an dialog abap instance to a system consisting of 3 DI and one CI.
    When trying to switch instance  from new instance in sm51 to old instance while being logged to an new instance directly  this is possible
    However when trying to switch instance in sm51 to new instance while being logged to an old instance  this is not possible.
    What could be the reason?

    jan,
    My first thought is whether the hostname of the new instance is availble to the old Dialog Instances (via the services file or DNS) ?
    Failing that, can you answer these questions...
    1) if you use SM51 to connect to an old instance from the new instance, can you then use SM51 to connect back to new instance ?
    2) When you access the new system from SM51, how does the logon fail ?
    invalid user / password ?
    Load balancing failure ?
    Connectivity failure ?
    You'll probably find the answer to your problem if you investigate down these three lines.  However, a more arcane cause could be the network topology...
    Are the instances on the same IP subnet ?
    Are the instances on the same domain or subdomain ?
    Check that there's nothing strange going on with the IP subnet mask.
    Good luck

  • What is the best way to add/delete a VLAN from a MST instance?

    Over several switches? Is there a single command you can issue from the root switch that propagates the change?Thanks

    No. Unfortunately there is no such mechanism defined by the MST spec. The manual configuration of the mst regions is actually the trick that makes the protocol relatively simple... but not very flexible I admit.
    If you are running CatOS however there is a way to achieve this: VTP3 will take care of propagating the MST configuration along the VTP domain.
    Else, you'll have to configure the switches one by one, which is going to be painful and will disturb your traffic.
    You can take this opportunity to plan a little bit for the future. What you can do is create in the MST configuration more instances than you need and map evenly all the vlans to them.
    Suppose you currently need 2 instances and 10 vlans and that you may require up to 10 instances in the future:
    - create 10 instances by mapping 400 vlans to each (well, of course map the 10 vlans you currently use to the two instances you currently need).
    - make sure that the vlans for the 8 instances you don't currently need are not created (here I mean not created in the VTP database).
    Our MST code is optimized so that an instance is not run unless there is at least one vlan that is mapped to it and that is active on one port in the switch (the only exception is instance 0 that always exists.)
    Thus, the current setup does not require more resources that if you only had configured two instances with 10 vlans. Now, if you need a new vlan in one of your two current instances, you have plenty to choose from. If you need some vlans with a different topology: just use one that is mapped to an usued instance. This way, you can at least quietly add/remove vlan without disrupting the traffic because you are not modifying the VTP configuration.
    Hope this helps,
    Francois

  • Adding VLAN to Po-Group and OSPF routing what is the correct way?

    Hi Community,
    I recently had an issue that brought down the links between a couple of switches...luckily this was done after hours and I did not save the config so was able to revert back.
    The basic scope of my project is:
    We are running out of IP's on the 192.168.1.0/24 sunbnet so wanted to create a seperate VLAN/Subnet  for physical workstations.
    He is what I orginally did;
    1) On our core switch; (Switch1) 
         Create the VLAN,
         VLAN interface,
         DHCP pool,
         excluded address'
    2) On second  switch (Switch 2)
         Add VLAN name, no interface
    3) I then updated the PO-group on Switch1 with new VLAN  (this brought down the link before I was able to finish my config)
        Therefore I was not able to complete the following:
              add vlan to spanning-tree or updated OSPF routing
    Here is what I assume to be the correct order?
    1) On Core Switch (Switch 1)
         Create VLAN
         VLAN interface
         DHCP pool
         excluded address'
         add vlan to spanning-tree
         add vlan (passive interface) and sunbet to OSPF routing
    2) On Switch 2
         Add vlan name/interfaces with no ip
    3) Update PO groups after the above has been configured
         Add new VLAN to Po-Group on Switch 2
         Add new VLAN to Po-Group on Switch 1
    4) Last steps
         Updated specific access ports with new VLAN and test
         upon completion of testing, update all other access ports connected ot workstations with new VLAN
    Questions:
    Did my links go down because I added new VLAN to Po-group BEFORE  updating spanning-tree and OSPF routing?
    Can anyone verify the order as outlined in the section "Here is what I assume to be the correct order"

    So the order in which to apply TASKS is correct?
    also just to clarify the following TASK  based on your comments.
    Step 4- Add new VLANs to OSPF as passive interface
    On Switch 1 (core)
    We have this line of code
    router ospf 100
    router-id 192.168.1.10
    log-adjacency-changes
    passive-interface Vlan10
    passive-interface Vlan30
    passive-interface Vlan50
    passive-interface Vlan500
    network 192.168.0.2 0.0.0.0 area 0
    network 192.168.1.10 0.0.0.0 area 0
    network 192.168.30.254 0.0.0.0 area 0
    network 192.168.33.254 0.0.0.0 area 0
    network 192.168.51.254 0.0.0.0 area 0
    network 192.168.99.5 0.0.0.0 area 0
    network 192.168.200.254 0.0.0.0 area 0
    TASK: OSPF - Add new VLANs(40 & 41) to OSPF as Passive Interface
    ******* Begin Here  *********
    config t
    router ospf 100
    passive-interface vlan40
    passive-interface vlan41
    !WE SHOULD ADD THIS LINE OF CODE
    network 192.168.40.254 0.0.0.0 area 0
    network 192.168.41.254 0.0.0.0 area 0
    ******* End Here  *********
    RESULT:
    router ospf 100
    router-id 192.168.1.10
    log-adjacency-changes
    passive-interface Vlan10
    passive-interface Vlan30
    passive-interface Vlan40
    passive-interface Vlan41
    passive-interface Vlan50
    passive-interface Vlan500
    network 192.168.0.2 0.0.0.0 area 0
    network 192.168.1.10 0.0.0.0 area 0
    network 192.168.30.254 0.0.0.0 area 0
    network 192.168.33.254 0.0.0.0 area 0
    network 192.168.40.254 0.0.0.0 area 0
    network 192.168.41.254 0.0.0.0 area 0
    network 192.168.51.254 0.0.0.0 area 0
    network 192.168.99.5 0.0.0.0 area 0
    network 192.168.200.254 0.0.0.0 area 0
    Better??
    Again thanks...your feedback have been a tremendous help!

  • Impact of adding new value fields in ongoing operating concern.

    Hi All,
    Want to know the steps of adding new value fields in the existing operating concern in COPA?
    What is the overall impact of addition of New Value fields in the running Operating Concern?
    How do we test the addition of new value fields?
    Is the addition of New Value fields to the running Operating Concern advisable?
    Your support and advice is highly anticipated and appreciated.
    Thanks & Regards
    9819528669

    HI,
    please search in SCN forum before you post:
    Re: Adding a ValueField to an existing Operating Concern?
    Best regards, Christian

  • Adding PHP pages, not showing dynamic content?

    Hi all,
    I'm new and hoping I don't get ripped apart for a question that seems simple. I've looked a lot though and can't seem to find an exact scenario like this. I recently took over a PHP site for a friend that was built in Dreamweaver CS3.
    There's a master page (main.php) that includes a header and footer and middle area of dynamic content. Thus, all of the pages appear like: http://www.SITENAME.com/main.php?mod=about (for the 'about' page) or www.SITENAME.com/main.php?mod=welcome (for the landing/home page), etc.
    In main.php, there's a section of: // Include Multiple Static Pages that looks like this:
    $mxiObj->IncludeStatic("about", "about.php");
    for every static page.
    All of this makes sense to me. Here's my problem:
    When adding a new page now, I can't get it to show any of the dynamic content on the live site. I just get the static header and footer to show.
    In the main.php file, there's this section:
    </div>
      <div id="mainContent">
        <p> 
          <?php
      $incFileName = $mxiObj->getCurrentInclude();
      if ($incFileName !== null)  {
        mxi_includes_start($incFileName);
        require(basename($incFileName)); // require the page content
        mxi_includes_end();
    ?></p>
    </div>
    that's supposed to pull in the dynamic content. It's doing this just fine on the older pages, but not on the ones I'm trying to build now.
    I guess I'm asking if there's some type of file in an 'includes' folder that I'm missing where I need to make sure the FileName is also listed (not just in the static section on main.php)? What's the mising link that will get this dynamic content to show up?
    Thanks for any help in advance and for reading this!

    The quickest way to add new pages is to
    copy the template (index.php) to a new document (newdoc.php or similar)
    remove the PHP stuff - stuff that is not required for the new content
    if there are inludes for the menu, header, footer or similar, then you can link those back into the document using standard includes
    add the new content to the newly created document
    This will give you a stand-alone document. At a later stage you can convert these documents into a DW-template system.

  • Adding a math amount to dynamic text

    Hi all,
    I am working on a key pad that has a clock, allows you to
    enter a time amount and then count down that amount or add seconds
    to it.
    Here is the file:
    Flash
    movie
    As you can see there are a few things that I have been unable
    to do due to my beginning skill level:
    1a) 2 :34 PM isnt really a functioning clock, its just text.
    While it doesn't need to actually work like a real clock, it should
    have the colin blinking, and when you press any of the 1 - 9
    numbers, it should clear away and present : 00, or : 0(number of
    pressed button).
    1b) How do I constrain the dynamic text box to only four
    numbers in the format of "xx : xx", where x is any number from 0 to
    9, then a space on either side of the colin. Numbers get added from
    the right x first and get pumped to the next placeholder. (dc : ba)
    2) Again, pressing OK doesnt really countdown anything, it
    just says "cooking'. Upon pressing OK, how to I tell the button to
    count down to zero whatever the number is in the dynamic text box?
    3) The add button is supposed to add 2 seconds to whatever
    number (except the clock) is displayed in the dynamic text box, but
    it simply places a 2 next to the numbers. If 1:04 is displayed,
    then pressed Add should equate 1:06, not 1:042
    Here is the code:
    btn1.theNumber.text = "1";
    btn2.theNumber.text = "2";
    btn3.theNumber.text = "3";
    btn4.theNumber.text = "4";
    btn5.theNumber.text = "5";
    btn6.theNumber.text = "6";
    btn7.theNumber.text = "7";
    btn8.theNumber.text = "8";
    btn9.theNumber.text = "9";
    btn0.theNumber.text = "0";
    okButton.theNumber.text = "OK";
    cancel.theNumber.text = "CANCEL";
    addmore.theNumber.text = "Add";
    theCode.text = "2 : 34";
    btn1.onPress = function () {
    theCode.text += "1";
    btn2.onPress = function () {
    theCode.text += "2";
    btn3.onPress = function () {
    theCode.text += "3";
    btn4.onPress = function () {
    theCode.text += "4";
    btn5.onPress = function () {
    theCode.text += "5";
    btn6.onPress = function () {
    theCode.text += "6";
    btn7.onPress = function () {
    theCode.text += "7";
    btn8.onPress = function () {
    theCode.text += "8";
    btn9.onPress = function () {
    theCode.text += "9";
    btn0.onPress = function () {
    theCode.text += "0";
    okButton.onPress = function () {
    theCode.text = "Cooking";
    cancel.onPress = function () {
    theCode.text = "2 : 34";
    addmore.onPress = function() {
    theCode.text = theCode.text + 2;

    Ok,
    Here is what I have been trying, seen below, following what
    Don mentioned. However, I get an error if I keep the " " around the
    0 in the last bit of code. And in reference to my first post, how
    do I expand the code to satisfy those questions. I'll keep trying!
    btn0.theNumber.text = "0";
    btn1.theNumber.text = "1";
    var numZero:Number = 0;
    var numOne:Number = 1;
    var numTwo:Number = 2;
    var numThree:Number = 3;
    var numFour:Number = 4;
    var numFive:Number = 5;
    var numSix:Number = 6;
    var numSeven:Number = 7;
    var numEight:Number = 8;
    var numNine:Number = 9;
    btn0.onPress = function () {
    theTime.text = numZero
    btn1.onPress = function () {
    theTime.text = numOne
    if(numZero <10){
    numZero = "0" + numZero
    **Error** Scene=Scene 1, layer=actions, frame=1:Line 27: Type
    mismatch in assignment statement: found String where Number is
    required.
    numZero = "0" + numZero
    Total ActionScript Errors: 1 Reported Errors: 1

  • How is the impact when a sql server cluster instance failover to a downlevel version node?

    Hi,
    I have a one instance two nodes sql 2012 cluster, node1's sql 2012 version is 11.0.5522, node2's sql 2012 version is 11.0.3000, node1 is active.
    When sql server failover from node1 to node2, it succeed. I want to konw if this downlevel failover  impact database (data or usage)?
    Many thanks.

    I would not say this as a correct configuration although you can do it. Downside is suppose node 1 which is on higer version has some bug fixed with patch when you failover to lower version that bug might re surface. I have never used nodes with different
    version nor i recommend.
    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it
    My Technet Articles

  • Impact of changing VLAN bandwidh if my physical port is 10G?

    My monitoring system is reporting that VLAN X is 100% utilization in my 6509. That VLAN is used to pass traffic between two 10G access ports in that VLAN X. It seems that by default the VLAN bandwidth is 1G, however i am passing more traffic than that in that 10G connection. Is it safe to just change the bandwidth to the VLAN without impact? I think it is but would like to know if someone has some experience with this.
    Thank you,
    Francisco.

    Hi,
    There should not be any issue by changing it accordingly to the actual speed of the interfaces. Typically the interface bandwidth command would be used to communicate the speed of the interface to Interior Gateway Routing Protocols (IGRP), so they would then calculate their metircs based on that value, the bandwidth value should be accurate, otherwise there would be cases where a routing protocol would rely on wrong values (please see below output) so would consider wrongly a path as equal as another and use them both equally. Please keep in mind also that the bandwidth command does not affect the actual speed of the interface. One more use of the bandwidth command would be in the adjustment of the initial retransmision parameters of tcp.
    Switch#sh run int f0/9 | in speed
     speed 10
    Switch#sh int f0/9 | in BW
      MTU 1500 bytes, BW 100000 Kbit, DLY 1000 usec,
    In this example, an IGRP would calculate its metric considering 100Mbps as the speed of the interface when the real speed is 10Mbps, that's because the bandwidth is set to 100000 Kb and it is the value that would be used by that IGRP.
    Regards,
    Aref

  • Nexus 5K adding vlans

    Hello,
    I have the task of adding a new vlan (56) to our existing N5K's v1000 and 6513 core trunks
    New vlans pop up frequently. My question is....
    Is there a "global" command to add vlan56 to the trunks? on the N5K's?
    I am trying to make this easier on me.
    Currently I add per port-channel/trunk
    Below is an output of 1 of my 4 N5K's...vlan56 needs to be added to all.        
    Thanks in advance!
    Port          Vlans Allowed on Trunk
    Eth1/1        1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Eth1/2        1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Eth1/5        5,10-11,13,16-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999
    Eth1/6        5,10-11,13,16-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999
    Eth1/7        5,10-11,13,16-20,23,25-32,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999
    Eth1/8        5,10-11,13,16-20,23,25-32,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999
    Eth1/33       1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Eth1/34       1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Eth1/43       30,33
    Eth1/45       1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Eth1/46       1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Eth1/47       1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Eth1/48       1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Eth2/1        3010
    Eth2/2        3010
    Po90          1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Po91          5,10-11,13,16-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999
    Po93          5,10-11,13,16-20,23,25-32,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999
    Po201         1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Po202         1,5,10-11,13,15-20,23,25-35,40-41,50-52,64,72,108,192,215,304-305,525,550,607,610,700,801,805-806,810-812,820,901-902,999,3010
    Po3010        3010
    Eth101/1/5    13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/6    13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/7    13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/8    13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/11   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/12   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/13   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/14   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/23   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/24   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/25   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/26   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/27   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/28   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/29   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/30   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/31   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth101/1/32   13,19,25-30,32,40-41,50,805-806,820,3010
    Eth103/1/5    13,19,25-30,32,40-41,50,805-806,820,3010
    Eth103/1/6    13,19,25-30,32,40-41,50,805-806,820,3010
    Eth103/1/7    13,19,25-30,32,40-41,50,805-806,820,3010
    Eth103/1/8    13,19,25-30,32,40-41,50,805-806,820,3010

    What Nexus OS are you running. If you are running 5.x you might want to think of using port-profiles which should make it easier for you. Here is an example.
    port-profile type ethernet test-profile
      switchport mode trunk
      switchport trunk allowed vlan 1-3
    interface Ethernet1/11
      inherit port-profile test-profile

  • CloudControl 12c: when adding cluster-database single instances are missing

    Hello ,
    I'e have installed the agent 12c on every single host of our RAC. When adding a database to CloudControl 12c just the RAC-instance gets discovered - but not the single database instances on each host.
    Due to this when clicking targets -> databases I just see the cluster-database - but not every single instance of the database.
    Compared to another RAC database this is totally different behaviour.
    Any help will be appreciated
    Rgds
    JH

    Hello ,
    maybe I should try to explain the issue a little bit clearer...
    We have one RAC database called PROD02. When clicking "targets -> databases" I see the following:
    PROD02 of type Cluster Database
    PROD021 of type Database Instance
    PROD022 of type Database Instance
    That's the way it shoudl be - that's the way I expected it...
    For the newly cofgured RAC database, called PREP02, it looks different when clicking "targets -> databases"
    PREP02 of type Cluster Database
    The single instances don't show up. Of course I see the single instances when clicking on "PREP02" under the item "Instances".
    Now I wonder why these two RAC databases are differently displayed when clicking "targets -> databases". When trying to add the single instances (clicking "Add" under "targets -> databases") and selecting then either "only on the host <hostname>" or "on all hosts in the cluster" no single instances are found or displayed...
    Rgds
    Jan

Maybe you are looking for

  • Rolling out ADE to Open Access Computers in libraries

    (In the UK). In Plymouth we are using Secure Electronic Delivery as the default to deliver access to documents provided by the British Library. Internet Explorer 7 (and this is also known with Firefox and other browsers) causes an ebook reader detect

  • Missing Mouse with new MP

    Has anyone else received there MP with a keyboard and no mouse? Not that I am a fan of the mini mouse but shouldn't it be in the top packaging or under the keyboard? Guess it's time to call apple care. Other wise the system is amazingly quite and fas

  • Exporting to jpeg with grayscale images on the page crashes Indesign

    Hi, I have noticed a bug in Indesign CS4. When I have grayscale psd images on a page the export to jpeg crashes. - R

  • Error while executing of Pre-Process EventHandler

    Hi, I have a pre-process event handler configure for "CREATE" and "MODIFY" operations which updates middle name of the user. The code gets triggered perfectly for "CREATE" operation and updates middle name attribute as expected. But when I update the

  • Can't install photoshop cs4 update for middle east

    I downloaed the trial of photoshop cs4 me from this site: http://www.winsoft-international.com. when I run the upadte i get this error: "Adobe photoshop cs4 11.0.1 - Adobe photoshop cs4 not installed" how can I fix this?