Java jvm server mode memory leak out of memory crash

Hi,
I am using java version "1.6.0_13" on a windows 2003 server.
I am running apache-tomcat-6.0.18 PermSize:256M HEAP:1G
If tomcat is started with java with client mode vm, the site works very well!
Requests are processed without problems and memory heap will stabilize on 500M.
I like to use the server mode. If I start the tomcat with server mode, then
the web application work better (30% faster), but memory heap will increase
increase more than the 500M about the 1G and then the tomcat process crash.
Questions:
A) Is normal that memory will increase? If client mode need 500M then 1G for
server mode is not enought? Should I increase the heap? How much?
B) Is a know problem? Is server option for windows not good supported?
I have double checked the problem. If I return to the client mode then the
tomcat will run without problem (excluding some software change problems)
No use of native code (JNI).
C) How to track better what happens in server mode? If there is a bug or is normal?
Please help me. Thanks in advance.

this problem may arise if u r using a windows 95 series of OS. after starting the dos window, go to that windows properties and increase the memory allocations to maximum, dont let it be at auto. I think this should help u

Similar Messages

  • SQL Server 2012- Memory Leak Issue

    Team,
    We are running a Mission Critical Application on SQL Server 2012 SP2(11.0.5058) which is configured on Always ON Synchronous mode. Offlate due to heavy development work, Application team have come up with stating memory issues. I have analysed all the areas
    and everything looks normal. Please suggest if we have to patch the latest CU4 for SQL Server 2012 SP2. 
    The checks were performed on the below areas:
    - Errorlog, System Logs - No errors reported.
    - There are close to 8 Databases hosted on the instances which are all configured for AlwaysON. SQL Server is running on VM Infrastructure and the total physical memory allocated is 96GB out of which SQL is capped for 92GB. 
    -The Page Life Expectancy is healthy and is showing a greater number. There are no Signal waits either or pending memory grants. 
    - The writes are more than reads for one of the databases which is flagged with application team. There are no blockings & Deadlocks.
    Please suggest me the future course of action and your inputs are much appreciated.
    Best Regards,
    Sharath 

    Actual issue is- Application team have reported a memory leak and their builds have significantly slowed down. They suspect that its Database memory leak. However I have verified from database end and gave the above inputs. 
    The AOAGs are good. I was looking for any pointers whether there are any bugs which is related to memory leaks in SQL Server 2012.  I know all of them are addressed with SQL Server 2012 SP2. 
    Application team has NO idea about SQL Server do they ? And to say SQL Server has memory leak you have to actually prove it did they showed any proof. Its common for application team to say SQL Server is leaking memory because they are unaware about fact
    by default SQL Server would take as much memory as possible and would release when SQLOS asks it to do so. This might give sign that it is leaking memory BUT IT IS NOT.
    As you already said AOAG is working fine so I am presuming there is nothing much to worry. To monitor memory usage in SQL Server 2012 you can use below counters
    SQL Server: Memory Manager-- Target Server Memory (KB)
    SQL Server: Memory Manager--Total Server Memory (KB)
    SQL Server: Memory Manager- Free Memory (KB)
    SQL Server: Memory Manager--Database Cache Memory (KB)
    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it
    My Technet Wiki Article
    MVP

  • Problem with PermGen memory (Java) - Tomcat Server - Business Object XI

    We have installed Business Objects XI on a W2003 Standard with SP2 (x86), using Tomcat as web server and MySQL as DBMS. The server has 4 GB of RAM and dual-core processor. From the beginning we have been given the memory problems of the Java virtual machine. The exception that occurs is of type "java.lang.OutOfMemoryError: PermGen space failure". We modify environment variables (JAVA_OPTS) -XX: PermSize = 256m and-XX: MaxPermSize = 512m and install the monitor LambdaProbe to see the use made of memory. We note that at no time was the PermGen memory indicated by these variables, continuing in that has a default 64MB. For this reason we decided to change the Tomcat 5.5 BO included in the version 6.0.20 and also updated Java to version 1.6.0_18-b07, and make deployment by wdeploy.bat file that comes with BusinessObjects (changing config.tomcat55 and tomcat55.xml). The deployment was successful and everything works, but as with the previous version of Java / Tomcat, shortly PermGen memory fills and returns to "hang". In this latest version of Tomcat installed as a service, do not use environment variables, use an application, "Configure Tomcat", which is a tab to pass parameters to the JVM. After looking at many sites, I have seen to be putting "-D" to pass the parameter. Currently this is my configuration:
    -Dcatalina.home = C: \ Program Files \ Apache Software Foundation \ Tomcat 6.0-Dcatalina.base = C: \ Program Files \ Apache Software Foundation \ Tomcat 6.0-Djava.endorsed.dirs = C : \ Program Files \ Apache Software Foundation \ Tomcat 6.0 \ endorsed-Djava.io.tmpdir = C: \ Program Files \ Apache Software Foundation \ Tomcat 6.0 \ temp-Djava.util.logging.manager = org.apache.juli . ClassLoaderLogManager-Djava.util.logging.config.file = C: \ Program Files \ Apache Software Foundation \ Tomcat 6.0 \ conf \ logging.properties-Dcom.sun.management.jmxremote-D-Xms2g-D-Xmx2g-D -XX: + UseConcMarkSweepGC-D-XX:-D PermSize = 256m-XX: MaxPermSize = 512m-Daf.configdir = C: / Program Files / Business Objects / Dashboard and Analytics 12.0-D-verbose: gc-D-XX : + PrintGCTimeStamps-D-XX: + PrintGCDetails
    I tried changing the values of-XX: PermSize and XX: MaxPermSize, and modifying the various policies of the Garbage Collector (-XX: + UseConcMarkSweepGC,-XX: + UseParNewGC,-XX: + UseParallelGC, ...), but nothing. Any idea how to get change the value of the report? Or how to solve this problem?
    Thank you!

    Victor,
    Is the Product you are using BusinessObjects Enterprise XI (Release 1)?
    With XIR2 and XI31, Tomcat 5.0 and Tomcat 5.5 are included with the software, and when installed with the BOE installer, you will get an application installed to the startmenu named "Tomcat Configuration".
    Using this "Tomcat Configuration" utility, there are several configuration options available.  On the JAVA tab, you will see the JAVA_OPTS that are set (These are prefixed with "-D") and also your initial and max memory sizes are listed at the bottom (Max 1024 by default in XI31).
    Here is the default setting for permsize in XI31 Tomcat:
    -XX:MaxPermSize=256M
    From your post, your issue might be the spaces in between your values (there should be no spaces, each "-" parameter on its own line).
    I would suggest starting Tomcat and reviewing your stdout.log file to review what options were set.
    Hope that helps
    -Brian

  • XSLTC not working in -server mode of JVM

    I am translating one of my request xml to response xml using SinglePropertyAvailabilityRQ.xsl. I am using XSLTC technique of transformation. This works perfectly when I am running it normal JVM mode. But when I run this in �-server� mode of JVM it gives �Stylesheet compilation error�. Attaching my program and request xml and xsl used for transformation. The transform(Node node, String xslFile) method does the actual transformation and TemplateObjectFactory class maintains compiled Templates.
    public class TemplateObjectFactory
    private static final NB4Logger logger =
    NB4Logger.getLogger(XMLUtility.class.getName());
    private static Hashtable htTemplates = new Hashtable();
    private static Templates translet = null;
    private static TransformerFactory tFactory = null;
    private static void init() throws Exception
    String key = "javax.xml.transform.TransformerFactory";
    String value = "org.apache.xalan.xsltc.trax.TransformerFactoryImpl";
    Properties props = System.getProperties();
    props.put(key, value);
    System.setProperties(props);
    try
    tFactory = TransformerFactory.newInstance();
    catch (TransformerFactoryConfigurationError e)
    throw new Exception(e);
    // The hashtable object should be available through out the life cycle of
    // web services application. Hence the Hashtable has been made a class
    // variable
    // Hashtable object is synchonized by default and hence no need to
    // check thread safe issues.
    // check if template object already exists in the hashtable
    // if exists return it or else create a new template object
    // store it in the hashtable and return it to the caller.
    * Method which returns Template objects
    * @param strRoot - XML Root tag
    * @return Templates - reference to a translet
    * @throws Exception
    public static Templates getTemplateObject(String strRoot) throws Exception
    try
    if (tFactory == null)
    if (logger.isDebugEnabled())
    logger.debug(
    "Transformer Factory object is null. Need to initialize it");
    init();
    else
    if (logger.isDebugEnabled())
    logger.debug("Transformer Factory object is not null.");
    if (htTemplates.containsKey(strRoot))
    // Template object already exists in hashtable
    translet = (Templates) htTemplates.get(strRoot);
    else
    // Template object does not exists in hashtable
    // Need to create new template object.
    // XSL stylesheet to create a translet as a Templates object.
    // translet = tFactory.newTemplates(new StreamSource(xslFile));
    translet = tFactory.newTemplates(new StreamSource(strRoot));
    // add the template object into hashtable
    htTemplates.put(strRoot, translet);
    catch (Exception e)
    logger.error("Exception Occured " + e.getMessage());
    throw new Exception(e);
    return translet;
    public static Node transform(Node node, String xslFile)
    throws WSApplicationException
    Node resultNode = null;
    //apply transform on this node
    try
    if (logger.isDebugEnabled())
    logger.debug("Inside XMLUtility.transform ");
    TransformerFactory tFactory = TransformerFactory.newInstance();
    if (tFactory.getFeature(DOMSource.FEATURE)
    && tFactory.getFeature(DOMResult.FEATURE))
    Templates translet =
    (Templates) TemplateObjectFactory.getTemplateObject(xslFile);
    if (translet == null)
    logger.error("Translet is null");
    throw new Exception("Translet is null");
    Transformer transformer = translet.newTransformer();
    DOMSource xmlDomSource = new DOMSource(node);
    if (logger.isDebugEnabled())
    logger.debug("Testing the input of transformer - node (see console)");
    if (transLogger.isDebugEnabled())
    transLogger.debug("before trasformation for : " + xslFile);
    writeToConsole(node);
    DOMResult domResult = new DOMResult();
    // Perform the transformation, placing the output in the DOMResult.
    transformer.transform(xmlDomSource, domResult);
    if (logger.isDebugEnabled())
    logger.debug(
    "Testing the Output of transformer - node (see console)");
    if (transLogger.isDebugEnabled())
    transLogger.debug("after trasformation for : " + xslFile);
    writeToConsole(node);
    resultNode = domResult.getNode();
    else
    throw new org.xml.sax.SAXNotSupportedException(
    "SAX processing not supported!");
    catch (TransformerException te)
    logger.error("Transformer Exception occured",te);
    throw new WSApplicationException(FrameworkErrorCodeConstants.eqstrTRANSFORMATION_EXCP,te.getMessage());
    catch (Exception e)
    logger.error("Exception occured",e);
    throw new WSApplicationException(FrameworkErrorCodeConstants.eqstrWS_APP_EXCP,e.getMessage());
    return resultNode;
    XSL IS:
    ======
    <?xml version="1.0" encoding="UTF-8"?>
    <xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:hotelml="http://www.xpegs.com/v2001Q3/HotelML">
         <xsl:output method="xml" encoding="UTF-8"/>
         <xsl:template match="/SinglePropertyAvailabilityRQ">
         <xsl:param name="corpinfo">CorpInfo</xsl:param>
         <xsl:param name="freqguest">FreqGuest</xsl:param>
         <xsl:param name="udsource"></xsl:param>
    <xsl:param name="uddestintion"></xsl:param>
              <hotelml:HotelML>
                   <xsl:variable name="V1" select="."/>
                   <hotelml:Head>
                        <hotelml:Process>
                             <xsl:variable name="V43834416_27497032" select="'/HotelML/Form/PropertyInformation'"/>
                             <xsl:attribute name="DataPath"><xsl:value-of select="$V43834416_27497032"/></xsl:attribute>
                             <xsl:variable name="V43834608_27497784" select="'TI_PropertyInformationV1_1'"/>
                             <xsl:attribute name="Function"><xsl:value-of select="$V43834608_27497784"/></xsl:attribute>
                             <xsl:for-each select="ProcessingDirectives">
                                  <xsl:for-each select="@Token">
                                       <xsl:attribute name="Token"><xsl:value-of select="."/></xsl:attribute>
                                  </xsl:for-each>
                             </xsl:for-each>
                        </hotelml:Process>
                        <hotelml:Route>
                        <xsl:attribute name="Source"><xsl:value-of select="$udsource"/></xsl:attribute>
                        <xsl:attribute name="Destination"><xsl:value-of select="$uddestintion"/></xsl:attribute>
                        </hotelml:Route>
                   </hotelml:Head>
                   <hotelml:Form>
                        <hotelml:PropertyInformation>
                             <xsl:for-each select="Property">
                                  <xsl:for-each select="@DataSet">
                                       <xsl:attribute name="DataSet"><xsl:value-of select="."/></xsl:attribute>
                                  </xsl:for-each>
                             </xsl:for-each>
                             <xsl:for-each select="Property">
                                  <xsl:variable name="V6" select="."/>
                                  <xsl:for-each select="@ChainCode">
                                       <xsl:variable name="V43835568_43898712" select="."/>
                                       <xsl:for-each select="$V6/@PropertyCode">
                                            <xsl:variable name="V43835568_43898568" select="."/>
                                            <xsl:variable name="V43835568_26210968" select="';'"/>
                                            <xsl:variable name="V43835568_23714840" select="concat($V43835568_43898712,$V43835568_26210968)"/>
                                            <xsl:variable name="V43835568_27496472" select="concat($V43835568_23714840,$V43835568_43898568)"/>
                                            <xsl:attribute name="PropertyCode"><xsl:value-of select="$V43835568_27496472"/></xsl:attribute>
                                       </xsl:for-each>
                                  </xsl:for-each>
                             </xsl:for-each>
                             <hotelml:PropertyRate>
                                  <xsl:for-each select="AvailabilitySearchCriteria">
                                       <xsl:for-each select="@MatchingQualifier">
                                            <xsl:variable name="V43835760_43899784" select="."/>
                                            <xsl:variable name="V43835760_27498472" select="'ExactAndPublic'"/>
                                            <xsl:variable name="V43835760_27499064" select="$V43835760_43899784 = $V43835760_27498472"/>
                                            <xsl:variable name="V43835760_27497856" select="'ExactAndPublic'"/>
                                            <xsl:variable name="V43835760_27563088">
                                                 <xsl:choose>
                                                      <xsl:when test="$V43835760_27499064">
                                                           <xsl:value-of select="$V43835760_43899784"/>
                                                      </xsl:when>
                                                      <xsl:otherwise>
                                                           <xsl:value-of select="$V43835760_27497856"/>
                                                      </xsl:otherwise>
                                                 </xsl:choose>
                                            </xsl:variable>
                                            <xsl:attribute name="MatchingQualifier"><xsl:value-of select="$V43835760_27563088"/></xsl:attribute>
                                       </xsl:for-each>
                                  </xsl:for-each>
                                  <xsl:for-each select="AvailabilitySearchCriteria">
                                       <xsl:for-each select="@NumberOfAdults">
                                            <xsl:attribute name="NumberOfAdults"><xsl:value-of select="."/></xsl:attribute>
                                       </xsl:for-each>
                                  </xsl:for-each>
                                  <xsl:for-each select="AvailabilitySearchCriteria">
                                       <xsl:for-each select="@NumberOfBeds">
                                            <xsl:attribute name="NumberOfBeds"><xsl:value-of select="."/></xsl:attribute>
                                       </xsl:for-each>
                                  </xsl:for-each>
                                  <xsl:for-each select="AvailabilitySearchCriteria">
                                       <xsl:for-each select="@NumberOfChildren">
                                            <xsl:attribute name="NumberOfChildren"><xsl:value-of select="."/></xsl:attribute>
                                       </xsl:for-each>
                                  </xsl:for-each>
                                  <xsl:for-each select="AvailabilitySearchCriteria">
                                       <xsl:for-each select="@NumberOfRooms">
                                            <xsl:attribute name="NumberOfRooms"><xsl:value-of select="."/></xsl:attribute>
                                       </xsl:for-each>
                                  </xsl:for-each>
                                  <hotelml:DateRange>
                                       <xsl:for-each select="DateRange">
                                            <xsl:for-each select="@ArrivalDate">
                                                 <xsl:variable name="V39113288_39096080" select="."/>
                                                 <xsl:variable name="V39113288_39659576" select="'-'"/>
                                                 <xsl:variable name="V39113288_39389216" select="'4'"/>
                                                 <xsl:variable name="V39113288_39219288" select="'1'"/>
                                                 <xsl:variable name="V39113288_39206792" select="'2'"/>
                                                 <xsl:variable name="V39113288_39206432" select="'4'"/>
                                                 <xsl:variable name="V39113288_39206288" select="'7'"/>
                                                 <xsl:variable name="V39113288_39223248" select="substring($V39113288_39096080,$V39113288_39206432,$V39113288_39206792)"/>
                                                 <xsl:variable name="V39113288_39213664" select="substring($V39113288_39096080,$V39113288_39206288,$V39113288_39389216)"/>
                                                 <xsl:variable name="V39113288_40407544" select="concat($V39113288_39213664,$V39113288_39659576)"/>
                                                 <xsl:variable name="V39113288_39227648" select="substring($V39113288_39096080,$V39113288_39219288,$V39113288_39206792)"/>
                                                 <xsl:variable name="V39113288_39754960" select="concat($V39113288_40407544,$V39113288_39227648)"/>
                                                 <xsl:variable name="V39113288_40050096" select="concat($V39113288_39754960,$V39113288_39659576)"/>
                                                 <xsl:variable name="VX1" select="concat($V39113288_40050096,$V39113288_39223248)"/>
                                                 <xsl:attribute name="InDate">
                                                      <xsl:value-of select="$VX1"/>
                                                 </xsl:attribute>
                                            </xsl:for-each>
                                       </xsl:for-each>
                                       <xsl:for-each select="DateRange">
                                            <xsl:for-each select="@DepartureDate">
                                                 <xsl:variable name="V39113480_39096272" select="."/>
                                                 <xsl:variable name="V39113480_40854384" select="'7'"/>
                                                 <xsl:variable name="V39113480_40819072" select="'1'"/>
                                                 <xsl:variable name="V39113480_40355560" select="'4'"/>
                                                 <xsl:variable name="V39113480_39729264" select="'-'"/>
                                                 <xsl:variable name="V39113480_39604688" select="'2'"/>
                                                 <xsl:variable name="V39113480_40211880" select="substring($V39113480_39096272,$V39113480_40854384,$V39113480_40355560)"/>
                                                 <xsl:variable name="V39113480_40972544" select="concat($V39113480_40211880,$V39113480_39729264)"/>
                                                 <xsl:variable name="V39113480_39498544" select="substring($V39113480_39096272,$V39113480_40355560,$V39113480_39604688)"/>
                                                 <xsl:variable name="V39113480_40211952" select="substring($V39113480_39096272,$V39113480_40819072,$V39113480_39604688)"/>
                                                 <xsl:variable name="V39113480_40924360" select="concat($V39113480_40972544,$V39113480_40211952)"/>
                                                 <xsl:variable name="V39113480_40057704" select="concat($V39113480_40924360,$V39113480_39729264)"/>
                                                 <xsl:variable name="V39113480_39469104" select="concat($V39113480_40057704,$V39113480_39498544)"/>
                                                 <xsl:attribute name="OutDate">
                                                      <xsl:value-of select="$V39113480_39469104"/>
                                                 </xsl:attribute>
                                            </xsl:for-each>
                                       </xsl:for-each>
                                  </hotelml:DateRange>
                             <xsl:for-each select="RatePlan">
                             <hotelml:RateSearch>
                                       <xsl:for-each select="@RatePlanCode">
                                                 <xsl:attribute name="RatePlanCode">
                                                      <xsl:value-of select="."/>
                                                 </xsl:attribute>
                                  </xsl:for-each>
                                            <xsl:for-each select="@RatePlanType">
                                                 <xsl:attribute name="RatePlanType">
                                                      <xsl:value-of select="."/>
                                                 </xsl:attribute>
                                            </xsl:for-each>      
                                       <xsl:if test="$V1/ClientFileIdentification/@ClientFileType[.!='']">
                                            <xsl:variable name="testcp" select="$V1/ClientFileIdentification/@ClientFileType"/>
                                            <xsl:if test="$corpinfo=$testcp">
                                            <hotelml:CorpInfo>
                                                 <xsl:for-each select="$V1/ClientFileIdentification">
                                                      <xsl:variable name="V26" select="."/>
                                                      <xsl:for-each select="@ClientFileType">
                                                      <xsl:variable name="V43837680_43899976" select="."/>
                                                      <xsl:if test="$corpinfo=$V43837680_43899976">
                                                           <xsl:for-each select="$V26/@ClientFileNumber">
                                                                <xsl:variable name="V43837680_43899000" select="."/>
                                                                <xsl:variable name="V43837680_42661680" select="'CorpInfo'"/>
                                                                <xsl:variable name="V43837680_42657544" select="$V43837680_43899976 = $V43837680_42661680"/>
                                                                <xsl:variable name="V43837680_43918784" select="''"/>
                                                                <xsl:variable name="V43837680_42658496">
                                                                     <xsl:choose>
                                                                          <xsl:when test="$V43837680_42657544">
                                                                               <xsl:value-of select="$V43837680_43899000"/>
                                                                          </xsl:when>
                                                                          <xsl:otherwise>
                                                                               <xsl:value-of select="$V43837680_43918784"/>
                                                                          </xsl:otherwise>
                                                                     </xsl:choose>
                                                                </xsl:variable>
                                                                <xsl:attribute name="Code"><xsl:value-of select="$V43837680_42658496"/></xsl:attribute>
                                                           </xsl:for-each>
                                                      </xsl:if>
                                                      </xsl:for-each>
                                                 </xsl:for-each>
                                            </hotelml:CorpInfo>
                                            </xsl:if>
                                            </xsl:if>
                                            <xsl:if test="$V1/ClientFileIdentification/@ClientFileType[.!='']">
                                            <xsl:variable name="testfr" select="$V1/ClientFileIdentification/@ClientFileType"/>
                                            <xsl:if test="$freqguest=$testfr">
                                            <hotelml:FreqGuest>
                                                 <xsl:for-each select="$V1/ClientFileIdentification">
                                                      <xsl:variable name="V29" select="."/>
                                                      <xsl:for-each select="@ClientFileType">
                                                      <xsl:variable name="V43837872_43899976" select="."/>
                                                      <xsl:if test="$freqguest=$V43837872_43899976">
                                                           <xsl:for-each select="$V29/@ClientFileNumber">
                                                                <xsl:variable name="V43837872_43899000" select="."/>
                                                                <xsl:variable name="V43837872_42659040" select="'FreqGuest'"/>
                                                                <xsl:variable name="V43837872_42660064" select="$V43837872_43899976 = $V43837872_42659040"/>
                                                                <xsl:variable name="V43837872_43918856" select="''"/>
                                                                <xsl:variable name="V43837872_42661136">
                                                                     <xsl:choose>
                                                                          <xsl:when test="$V43837872_42660064">
                                                                               <xsl:value-of select="$V43837872_43899000"/>
                                                                          </xsl:when>
                                                                          <xsl:otherwise>
                                                                               <xsl:value-of select="$V43837872_43918856"/>
                                                                          </xsl:otherwise>
                                                                     </xsl:choose>
                                                                </xsl:variable>
                                                                <xsl:attribute name="Code"><xsl:value-of select="$V43837872_42661136"/></xsl:attribute>
                                                           </xsl:for-each>
                                                           </xsl:if>
                                                      </xsl:for-each>
                                                 </xsl:for-each>
                                            </hotelml:FreqGuest>
                                            </xsl:if>
                                       </xsl:if>
                                  </hotelml:RateSearch>
                                  </xsl:for-each>
                             </hotelml:PropertyRate>
                        </hotelml:PropertyInformation>
                   </hotelml:Form>
              </hotelml:HotelML>
         </xsl:template>
    </xsl:stylesheet>
    Request XML is:
    =============
    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <SinglePropertyAvailabilityRQ Language="-1">
    <AvailabilitySearchCriteria AlternatePropertyFlag="False" NumberOfAdults="1" NumberOfChildren="1" NumberOfRooms="1"/>
    <Promotion PromotionCode=""/>
    <RatePlan/>
    <RatePlan RatePlanCode="Eco" RatePlanType="Standard"/>
    <RatePlan RatePlanCode="EQUR" RatePlanType="Standard"/>
    <ProcessingDirectives InstanceId="1" Token="1088400136957"/>
    <Property ChainCode="XX" PropertyCode="61309" PropertyCodeType="RV"/>
    <DateRange ArrivalDate="07/03/2004" DepartureDate="07/04/2004" NumberOfNights="1"/>
    <SuppressZeroRates Code="NO"/>
    </SinglePropertyAvailabilityRQ>

    JVM gives an Exception. I don't have the complete stack trace. But just have the message of the Exception.
    javax.xml.transform.TransformerConfigurationException: Could not compile stylesheet
    Soon I will paste the complete StackTrace.

  • How to start Jrockit as server mode using Tomcat jsvc (chroot)

    Hi,
    I was reading the product documentation and came across Jrockit defaulting as server mode? In the log file however, during startup there is no info on the VM mode - is there a way to get Jrockit VM to show? java -version does not output server mode either :-(.
    Currently testing Jrockit and may possibly move over from Sun :-).
    Thanks in advance!

    Thanks Henrik for explaining!
    After installing Jrockit 5.0_04 on one of our test machines, we keep getting random illegal memory access errors during stress testing:
    ===== BEGIN DUMP =============================================================
    JRockit dump produced after 0 days, 00:27:23 on Sun Feb 12 13:15:47 2006
    Additional information is available in:
    //jrockit.2901.dump
    No snapshot file (core dump) will be created because core dumps have been
    disabled. To enable core dumping, try "ulimit -c unlimited"
    before starting JRockit again.
    If you see this dump, please open a support case with BEA and
    supply as much information as you can on your system setup and
    the program you were running. You can also search for solutions
    to your problem at http://forums.bea.com in
    the forum jrockit.developer.interest.general.
    Error Message: Illegal memory access. [54]
    Signal info : si_signo=12, si_code=2 si_addr=0xc
    Version : BEA JRockit(R) R26.0.0-189-53463-1.5.0_04-20051122-2040-linux-ia32
    GC : System optimized over throughput (initial strategy singleparpar)
    : GC strategy for GC 0 was singleparpar
    : GC strategy for GC 1 was singleparpar
    : mmHeap->data = 0x20000000, mmHeap->top = 0x60000000
    : mmStartCompaction = 0x58000000, mmEndCompaction = 0x5c000000
    CPU : Intel Pentium 4 (HT) SSE SSE2 NetBurst EM64T
    Number CPUs : 4
    Tot Phys Mem : 2104639488 (2007 MB)
    OS version : Linux version 2.4.21-20.ELsmp ([email protected]) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-42)) #1 SMP Wed Aug 18 20:46:40 EDT 2004
    Thread System: NPTL
    State : JVM is running
    Command Line : -Xgcprio:throughput -Xms:1024m -Xmx:1024m -Xverbose:memory -Dcatalina.home=/usr/local/tomcat554 -Djava.io.tmpdir=/usr/local/tomcat554/temp -Djava.awt.headless=true -Djava.endorsed.dirs=/usr/local/tomcat554/common/endorsed -Dcatalina.base=/usr/local/tomcat554 -Duser.timezone=Asia/Taipei
    JAVA_HOME : /usr/java/jrockit-R26.0.0-jdk1.5.0_04
    java.home : /usr/java/jrockit-R26.0.0-jdk1.5.0_04/jre
    j.class.path : /usr/java/jrockit-R26.0.0-jdk1.5.0_04/lib/tools.jar:/usr/local/tomcat554/bin/commons-daemon.jar:/usr/local/tomcat554/bin/bootstrap.jar:/usr/local/tomcat554/bin/commons-logging-api.jar
    j.lib.path : /usr/java/jrockit-R26.0.0-jdk1.5.0_04/jre/lib/i386/jrockit:/usr/java/jrockit-R26.0.0-jdk1.5.0_04/jre/lib/i386
    C Heap : Good; no memory allocations have failed
    StackOverFlow: 0 StackOverFlowErrors have occured
    Registers (from ThreadContext: 0xaeeb1c / OS context: 0xaeebf8):
    eax = 00000001 ecx = b4e00010 edx = b4e00050 ebx = 00450e98
    esp = 00aeeee8 ebp = 00aeef1c esi = 00000000 edi = 004517c8
    es = 0000002b cs = 00000023 ss = 0000002b ds = 0000002b
    fs = 00000000 gs = 00000033
    eip = 0038db6d eflags = 00000206
    Stack:
    (* marks the word pointed to by the stack pointer)
    00aeeee8: 00000000* 00aeef00 b46f0c24 b46f0c24 b4e00058 007b2caa
    00aeef00: 004517c8 00000004 00000020 b4e00010 00450e98 b4e00010
    00aeef18: 00000001 00aeef38 0038ce7d b4e00010 00000019 00132f38
    00aeef30: b46f0c24 00000018 00aeef88 00121569 00000019 b46f0cd4
    00aeef48: 6000b630 08c47b4c 00000001 600a32a3 00aeef88 b46f0ac8
    00aeef60: 00aef2e8 00000000 b46f0cd4 0074905e 00aef018 600a3280
    00aeef78: 0012142b 0018b684 00aef3f0 00aef410 00aef3e8 0017e712
    00aeef90: b46f0c24 00aef414 00000000 0017e6b1 207d79f0 00aef3f0
    00aeefa8: 00aef410 00815cf8 b46f0c24 0100007f 00000000 00000000
    00aeefc0: 00000000 00000000 00000000 00000000 00000000 43090031
    00aeefd8: 62655742 54534554 652e3330 636f7270 2e646565 006d6f63
    00aeeff0: 61636f6c 736f686c 6f6c2e74 646c6163 69616d6f 6f6c006e
    00aef008: 686c6163 0074736f 00aeeff0 00aef006 00000000 007b6c54
    00aef020: 00aef0d8 600238b8 00aef068 0080a29e b46f0c24 6001a148
    00aef038: 6001bf60 00aef0bc 00aef0bc b46f0c24 6001bf60 007b5ffd
    00aef050: 00aef0bc b46f0c24 08c6d154 00000006 00000001 00000001
    00aef068: 00000001 00000000 6001bf60 00000000 00aef0c8 0080a430
    00aef080: b46f0c24 6001bf60 00aef0c8 0080a427 00aef0bc 00aef14c
    00aef098: 008159d0 00aef100 b46f0c24 b46f0ac8 00000001 b446a760
    00aef0b0: b446a7c8 00000000 00000000 08d1bf88 00aefd8c 00000000
    00aef0c8: 00aef108 0080ba13 b46f0c24 6001bf60 00000000 00000000
    00aef0e0: 00aef14c 008159d0 00000001 00aef100 b46f0c24 b46f0cd4
    00aef0f8: 00000000 00000000 00000000 00000000 00aef138 0080b5f8
    00aef110: b46f0c24 6001a154 6001bf60 00aef14c b46f0c24 b46f0ac8
    00aef128: 00000001 007b1998 b446a640 00000000 00aef168 007b2183
    00aef140: b46f0c24 6001a154 6001bf60 b46f0cd8 00aef1b8 00aef170
    00aef158: 00aef1f8 007b1d43 b46f0c24 b46f0ac8 00aef1f8 007b1ea2
    00aef170: b46f0c24 b46f0cd8 b46f0cd8 00aef1b4 0018b684 b46f0cd8
    00aef188: 00aef2a8 00000000 0018b684 b46f0cd8 00aef2a8 008056d0
    00aef1a0: 00000000 00000000 00000000 00000000 00aef1b8 00aef2e8
    00aef1b8: 00000000 00000001 00aef230 00000001 00aef2e8 6007500c
    00aef1d0: b46f0cd4 6148e9e0 00aef1f8 3ad702f0 00000810 3cff08d8
    00aef1e8: 00000810 08c57908 00aef210 0084a2de b65f3000 039fe11b
    00aef200: 08c57920 00000810 08c57920 00000810 00aef240 007b9f7c
    00aef218: b65f3000 039fe11b 3ad702f0 b46f0cd8 3cff08d8 0080cd4a
    00aef230: b46f0c24 3d1720c0 00000810 00000000 00aef270 007b9fec
    00aef248: 3cff08d8 60008690 00000000 00000001 08c57920 00000001
    00aef260: 00aef290 007b9f7c b65f3000 03a2e418 00aef2d0 007ba3e9
    00aef278: 60008690 00000810 08c57920 00000000 00aef2e8 007bc2bb
    00aef290: b46f0ad4 00000000 00aef2d8 007dc627 00400000 00000000
    00aef2a8: b46f0ac8 0040545f 00000000 00000000 00aef2f8 00187f74
    00aef2c0: 00000000 00000000 00000000 00000000 00000000 00000018
    00aef2d8: 00450e98 b4b8886c 00aef2e8 00217990 00450e98 b4b8886c
    00aef188: 00aef2a8 00000000 0018b684 b46f0cd8 00aef2a8 008056d0
    00aef1a0: 00000000 00000000 00000000 00000000 00aef1b8 00aef2e8
    00aef1b8: 00000000 00000001 00aef230 00000001 00aef2e8 6007500c
    00aef1d0: b46f0cd4 6148e9e0 00aef1f8 3ad702f0 00000810 3cff08d8
    00aef1e8: 00000810 08c57908 00aef210 0084a2de b65f3000 039fe11b
    00aef200: 08c57920 00000810 08c57920 00000810 00aef240 007b9f7c
    00aef218: b65f3000 039fe11b 3ad702f0 b46f0cd8 3cff08d8 0080cd4a
    00aef230: b46f0c24 3d1720c0 00000810 00000000 00aef270 007b9fec
    00aef248: 3cff08d8 60008690 00000000 00000001 08c57920 00000001
    00aef260: 00aef290 007b9f7c b65f3000 03a2e418 00aef2d0 007ba3e9
    00aef278: 60008690 00000810 08c57920 00000000 00aef2e8 007bc2bb
    00aef290: b46f0ad4 00000000 00aef2d8 007dc627 00400000 00000000
    00aef2a8: b46f0ac8 0040545f 00000000 00000000 00aef2f8 00187f74
    00aef2c0: 00000000 00000000 00000000 00000000 00000000 00000018
    00aef2d8: 00450e98 b4b8886c 00aef2e8 00217990 00450e98 b4b8886c
    00aef2f0: 00aef2f8 00217990 00aef308 0040545f 00331c39 0018b684
    00aef308: 00450e98 b4b8886c 00aef318 00217990 00450e98 b4b8886c
    00aef320: 00aef328 00217990 00aef338 0040545f 00331c39 0018b684
    00aef338: 00aef378 00187f74 b4b8886c 0018b684 00aef378 00187f1e
    00aef350: 00000000 3cff08f0 000000df 001882ea b4b8886c 00aef36c
    00aef368: 00000086 00af1bb0 00000000 00000000 00aef3a8 0081a428
    00aef380: 000000df 3cff08f0 00000086 00af1bb0 00000000 00aef3b0
    00aef398: 00000086 00000018 3fadc338 60091faa 207d7320 3fadc338
    00aef3b0: ffffffff 3fadc338 207d7320 6009e778 00000000 00000000
    00aef3c8: 0000000f 207d7348 3fadc320 00000000 00000000 00000000
    00aef3e0: 00000095 6009e689 3b4325d8 601899a1 b46f0c24 00aef410
    00aef3f8: 00aef414 60091f1f b4847cf0 6018999c b46f0cd4 00aef3f0
    00aef410: 207d79f0 3fadc320 b46f0ac8 3b4325d8 00000000 6018990a
    00aef428: 00000000 60189645 3b4325d9 3fadc320 00000000 00000000
    00aef440: 00aef428 207d79f0 b46f0ac8 3b4325d8 00000000 6018942b
    00aef458: 3fadc320 60096ad2 3b4325d8 3b4325d8 00000000 602a3d2d
    00aef470: 00000001 00000015 00000000 00000007 3fadc208 3fadc2a0
    00aef488: 3fadc2c8 00000000 00000000 00000000 00000007 210eaaf8
    00aef4a0: 00000000 00000000 00000000 3b432410 3fadc208 602a378f
    00aef4b8: 00000000 28dc6360 22c1cb48 22c1cad0 3b4325d8 00000000
    00aef4d0: 00000000 3fadb138 3fadb398 3b4325d8 3fadc208 60291ff3
    00aef4e8: 22c1cad0 22c1cb48 3b4325d8 28dc6360 3fadb398 3b432410
    00aef500: 3b432410 00000000 28dc6360 3fadb398 22c1cad0 60291975
    00aef518: 3b432411 3b432410 2294f138 602915e4 22c1cad0 2c815130
    00aef530: 00000000 00000000 00000000 3b432330 3b432410 28ae5b98
    00aef548: 22c1cd58 22c1cad0 22c1cb48 3b432330 2294f138 2c815130
    00aef560: b396a269 600a387a 28ae5b98 28ba7980 3b432410 60291115
    00aef578: 22c1cad0 22c1cb48 3b432330 2294f138 28ba7980 28ba7980
    00aef590: 3b432410 602910c9 22c1cad0 22c1cb48 3b432330 2294f138
    00aef5a8: 28ba7980 2294f138 22c1cd58 22c1cb48 3b432330 00000000
    00aef5c0: 2294f138 6029085c 22c1cad0 22c1cb48 3b432330 2294f138
    00aef5d8: 00000000 2141fb10 00000000 266580e0 00000003 2294f138
    00aef5f0: 21413680 00000000 00000000 00000000 00000000 00000000
    00aef608: 22c1cd58 28ba7980 22c1cad0 22c1cb48 3b432330 00000000
    00aef620: 00000000 00000000 3b432400 00000000 2951cc18 2c8150e0
    00aef638: 2b35b7b8 2a43d1d8 2b35b7b8 6028fd21 2294f138 6028fc15
    00aef650: 00aef638 2c814f98 2b35b7be 2b35b6f0 2c814f98 602a9c51
    00aef668: 2b35b6a1 2a43d1d8 00000000 602a9906 00aef660 2b35b6a1
    00aef680: 2b35b6a0 00000000 5e66e58f 00000109 2294f026 b46f0ac8
    00aef698: 266580e0 00000000 295227f0 2a43d1d8 2a43d198 602a965e
    00aef6b0: 295227f0 600920e3 2f3b1f38 2a43d1d8 2a43d198 6028d07b
    00aef6c8: 295227f0 602d89cb 00000000 00000001 00000001 2a43d1d8
    00aef6e0: 2a43d198 602d8038 2c8114d0 2a43d040 00000001 2a43d128
    Code:
    (* marks the word pointed to by the instruction pointer)
    0038da6c: 7e8b0d74 89f08908 c083107a 81b6eb08 01ffec7d 870f0000
    0038da84: 00000498 8bec4d8b e9c1f055 e84d8903 40ca748d 890c4e8b
    0038da9c: f139e44d c9853774 4d8b2b74 ec558be4 830c798b 01040a4c
    0038dab4: 08e8938d 55390000 0c7e89f0 74087789 e4458b07 04044883
    0038dacc: ebe4458b 241489a5 000957e8 f0458b00 8948c083 7d8bdc45
    0038dae4: dc4d8bf0 8954578b ca39e455 0091840f 768d0000 27bc8d00
    0038dafc: 00000000 8be4458b 508b0448 f8e1830c ffec7d81 77000001
    0038db14: dc553b09 03a0840f 4d3b0000 f0758bec 89dc7d8b 7a895456
    0038db2c: 6d840f08 81000003 0001fff9 d3870f00 89000002 f04d8bcf
    0038db44: 8d03efc1 8b40f954 f9890872 b81fe183 00000001 4d8be0d3
    0038db5c: 05ffc1f0 48b98409 8b000004 5789e47d 0c7e890c* 8954418b
    0038db74: 7a890877 dc7d8b08 39e44589 79850ff8 81ffffff 01ffec7d
    0038db8c: 23760000 8bf04d8b 748de855 4e8b40d1 89f1390c 0f74e44d
    0038dba4: 8b087e8b 7739ec75 da830f04 ff000001 458be845 e87d8bf0
    0038dbbc: 1fe86583 eac1fa89 4db60f05 f8748de8 90bc8b40 00000448
    0038dbd4: e0c1d089 d47d8908 000001bf 8be7d300 c983ec4d e04d8901
    0038dbec: 01f04d8b d84589c8 77d47d3b 75ff8507 00768d30 00d84581
    0038dc04: 42000001 0f03fa83 0000f187 f0458b00 4890b48b 85000004
    0038dc1c: d47589f6 758bde74 0001bfd8 c6830000 d47d8540 b48d1875
    0038dc34: 00000026 27bc8d00 00000000 c683ff01 d47d8508 4e8bf674
    0038dc4c: 89f1390c 1e75e44d d6f7fe89 21f0458b 758bd475 8bff01e4
    0038dc64: c683d44d 908c8908 00000448 458b82eb ec558be4 8304488b
    Loaded modules:
    (* denotes the module causing the exception)
    [JRockit] Platform error is: Permission denied (13)
    [JRockit] WARNING: readlink failed in symiGetCurrentExecutableFileName
    08048000-0804d5db (null)
    0055c000-0055de23 /lib/libdl.so.2
    0031c000-0044d5ef */lib/tls/libc.so.6
    002eb000-002ffc8b /lib/ld-linux.so.2
    00665000-0066bec7 /lib/libnss_compat.so.2
    006ad000-006be0db /lib/libnsl.so.1
    00c7e000-00c85f03 /lib/libnss_nis.so.2
    00fef000-00ff92cf /lib/libnss_files.so.2
    006c2000-008e2427 /usr/java/jrockit-R26.0.0-jdk1.5.0_04/jre/lib/i386/jrockit/libjvm.so
    00211000-0021d8d1 /lib/tls/libpthread.so.0
    00a84000-00aa4e5f /lib/tls/libm.so.6
    00111000-001311f7 /usr/java/jrockit-R26.0.0-jdk1.5.0_04/jre/lib/i386/libjava.so
    00faf000-00fb97bb /usr/java/jrockit-R26.0.0-jdk1.5.0_04/jre/lib/i386/libverify.so
    00c07000-00c0cf13 /usr/java/jrockit-R26.0.0-jdk1.5.0_04/jre/lib/i386/native_threads/libhpi.so
    0017a000-0018a4f8 /usr/java/jrockit-R26.0.0-jdk1.5.0_04/jre/lib/i386/libnet.so
    0018c000-0018f133 /lib/libnss_dns.so.2
    00f61000-00f6f3ff /lib/libresolv.so.2
    "http-80-Processor4" id=55 idx=0x24 tid=2959 lastJavaFrame=0xaef400
    Stack 0: start=0xacc000, end=0xaf2000, guards=0xad1000 (ok), forbidden=0xacf000
    Thread Stack Trace:
    [JRockit] Platform error is: Permission denied (13)
    [JRockit] WARNING: readlink failed in symiGetCurrentExecutableFileName
    at intmalloc+365(interp.c)@0x38db6d
    [JRockit] Platform error is: Permission denied (13)
    [JRockit] WARNING: readlink failed in symiGetCurrentExecutableFileName
    at __libc_malloc+141()@0x38ce7d
    [JRockit] Platform error is: Permission denied (13)
    [JRockit] WARNING: readlink failed in symiGetCurrentExecutableFileName
    at <unknown>(???.c)@0x121569
    [JRockit] Platform error is: Permission denied (13)
    Additional information is available in:
    //jrockit.2901.dump
    No snapshot file (core dump) will be created because core dumps have been
    disabled. To enable core dumping, try "ulimit -c unlimited"
    before starting JRockit again.
    If you see this dump, please open a support case with BEA and
    supply as much information as you can on your system setup and
    the program you were running. You can also search for solutions
    to your problem at http://forums.bea.com in
    the forum jrockit.developer.interest.general.
    Extended, platform specific info:
    libc release: 2.3.2-stable
    Elf headers:
    libc ehdrs: EI: 7f454c46010101000000000000000000 ET: 3 EM: 3 V: 1 ENTRY: 00015880 PHOFF: 00000034 SHOFF: 0017e714 EF: 0x0 HS: 52 PS: 32 PHN; 9 SS: 40 SHN: 61 STIDX: 60
    libpthread ehdrs: EI: 7f454c46010101000000000000000000 ET: 3 EM: 3 V: 1 ENTRY: 00004710 PHOFF: 00000034 SHOFF: 00017800 EF: 0x0 HS: 52 PS: 32 PHN; 8 SS: 40 SHN: 34 STIDX: 33
    libjvm ehdrs: EI: 7f454c46010101000000000000000000 ET: 3 EM: 3 V: 1 ENTRY: 0004dd60 PHOFF: 00000034 SHOFF: 00280c74 EF: 0x0 HS: 52 PS: 32 PHN; 3 SS: 40 SHN: 20 STIDX: 17
    ===== END DUMP ===============================================================
    Any ideas what may be causing the illegal memory access? Any help is much appreciated!
    Thanks,
    Steve

  • UnmarshalException while using prop  java.rmi.server.ignoreStubClasses=true

    I have created a test program to check the behaviour of setting the java.rmi.server.ignoreStubClasses property to true on the server side and not setting this flag on the client side.
    This requirement is due to updation of an already running system, with stubs to a new version without stubs, without shutting down the system.
    The files used by me are given below.
    File Hello.java
    package example.hello;
    import java.rmi.Remote;
    import java.rmi.RemoteException;
    public interface Hello extends Remote {
    String sayHello() throws RemoteException;
    File Server.java
    package example.hello;
    import java.rmi.registry.LocateRegistry;
    import java.rmi.registry.Registry;
    import java.rmi.server.UnicastRemoteObject;
    public class Server implements Hello {
    public Server() {}
    public String sayHello() {
    return "Hello, world!";
    public static void main(String args[]) {
    try {
    LocateRegistry.createRegistry(1099);
    Server obj = new Server();
    Hello stub = (Hello) UnicastRemoteObject.exportObject(obj, 0);
    // Bind the remote object's stub in the registry
    Registry registry = LocateRegistry.getRegistry();
    registry.bind("Hello", stub);
    System.err.println("Server ready");
    catch (Exception e)
    System.err.println("Server exception: " + e.toString());
    e.printStackTrace();
    File Client.java
    package example.hello;
    import java.rmi.registry.LocateRegistry;
    import java.rmi.registry.Registry;
    public class Client {
    private Client() {}
    public static void main(String[] args) {
    String host = (args.length < 1) ? null : args[0];
    try {
    Registry registry = LocateRegistry.getRegistry(host);
    Hello stub = (Hello) registry.lookup("Hello");
    String response = stub.sayHello();
    System.out.println("response: " + response);
    } catch (Exception e) {
    System.err.println("Client exception: " + e.toString());
    e.printStackTrace();
    First I run file Server.java using the following script (server.bat)
    java -Djava.rmi.server.ignoreStubClasses=true -classpath .; example.hello.Server
    pause
    Then the client is run using the following script (client.bat)
    java -classpath .; example.hello.Client 132.186.96.210
    pause
    While running the client, the following exception is obtained.
    Client exception: java.rmi.ServerException: RemoteException occurred in server thread; nested except
    java.rmi.UnmarshalException: error unmarshalling call header; nested exception is:
    java.rmi.UnmarshalException: skeleton class not found but required for client version
    java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
    java.rmi.UnmarshalException: error unmarshalling call header; nested exception is:
    java.rmi.UnmarshalException: skeleton class not found but required for client version
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:325)
    at sun.rmi.transport.Transport$1.run(Transport.java:153)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
    at java.lang.Thread.run(Thread.java:595)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
    at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:343)
    at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown Source)
    at example.hello.Client.main(Client.java:52)
    Caused by: java.rmi.UnmarshalException: error unmarshalling call header; nested exception is:
    java.rmi.UnmarshalException: skeleton class not found but required for client version
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:250)
    at sun.rmi.transport.Transport$1.run(Transport.java:153)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.rmi.UnmarshalException: skeleton class not found but required for client version
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:243)
    ... 6 more
    I am not able to figure out why this thing is happening, If i also set the property java.rmi.server.ignoreStubClasses=true on the client side everything goes fine. But this I can't do. I can't set the property on the client side as the system is up and already running.
    I am using JDK version 1.5.0_06. Same exception comes under JDK 6.0
    Any help will be highly appreciated.

    I think this is a bug. When you exported the Registry from your server JVM it was also exported with java.rmi.server.ignoreStubClasses=true, but the Registry bootstrap at the client requires the 1.1 stub protocol for compatiblity reasons so you got this error. I would report this on the Bug Parade.
    You could get around it by setting java.rmi.server.ignoreStubClasses after exporting the Registry.
    BTW java.rmi.server.ignoreStubClasses isn't supposed to do anything at the client whether true or false so you can cut your testing space in half.

  • Jco Connection works on Single server mode, but not over network?

    Hello,
    Error - com.sap.dictionary.runtime.DdException: 'XXXXXX' not properly defined! Unable to create Metadata connection for Dictionary Provider. Either the logical System Name 'XXXXXX' has not been properly defined in the System Landscape Directory, or you are not using a MsgServerDestination (AppServerDestinations are not permitted for Metadata connections
    This is the error at one of the remote machines. The JCo Connection works on the J2EE host system (while testing and pinging under the Single Server mode.)
    I believe this error will be rectified if I upgrade to SPS7, but we have certain other considerations that restrict us from doing that.
    Could someone please point out the exact location thats responsible for this if possible and maybe I could just upgrade that part and clear this?
    Thanks

    Hi,
    you should consider three  things if your java instance is on network.
    1. SLD ( check if java instance is listed on SLD and test the connection from portal to SLD.
    2. You need an entry in the services files of both the Java and ABAP servers as such:
    sapms<SID>  3600/tcp
    Remember to always have a blank line at the bottom of the services file!
    3. try to add the certificate in portal.
    if you can provide with the exact error message it would be easy to help.
    Kind regards,
    vamsi.

  • Sun Java Application Server 9

    Hi,
    I noticed that Sun Java Application Server 9 has a platform edition available.
    (In the Application Server section of the site it appears that latest version with an enterprise release is version 8.1.)
    Does anyone know if an enterprise edition is available for version 9? If not yet available, is there a timeline for an enterprise release?

    The Platform edition is intended to be run as a single JVM and lacks high availability and cluster
    support. The Enterprise edition has full support for clustering, high availabiilty, fail-over, and
    load-balancing. You can try out these features by using our Glassfish V2 release.
    9 PE would not be supported as an upgrade within any Java Enterprise System release,
    since a PE release does not contain all the features of an EE release. Once SJS AS 9 EE
    is released it will be included in a future rev of the Java Enterprise System.
    --ken                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       

  • Sun Java Web Server 6.1SP4 deadlock, stops responding

    Hi, i have a java web app on a Java Web SErver 6.1SP4 and when there are a lot of users the web server hangs, it stops responing. After a while (from 2 to 15 minutes) it start responding again. This serves neither dinamic nor static content. CPU usage is 100%. Just stoping and restarting the web server instance it works properly (even with the same or greater number of clients).
    Reading many posts some one wrote to use pstack to see whats happening. I did it, but i can't interpret results (i think there is a deadlock but don't know if thats true and how to resolve it).
    Any hint will be appreciated
    There are a lot of blocks like this:
    ----------------- lwp# 3468 / thread# 3468 --------------------
    fe11f950 lwp_mutex_lock (918c18)
    fd692384 __1cNObjectMonitorGenter26MpnGThread__v_ (5000, 525c, 5000, 50dc, 4800, 4af0) + 2d8
    fd6324d4 __1cSObjectSynchronizerKfast_enter6FnGHandle_pnJBasicLock_pnGThread__v_ (e104f604, e104f77c, 831ff50, 0, 35d654, fd6328ec) + 68
    fd632954 __1cQinstanceRefKlassZacquire_pending_list_lock6FpnJBasicLock__v_ (e104f77c, fd970000, e7330000, 4491d4, fd61bc2c, 0) + 78
    fd63167c __1cPVM_GC_OperationNdoit_prologue6M_i_ (e104f764, 4400, fd970000, 2cdc0, 4a6268, 1) + 38
    fd62e0b0 __1cIVMThreadHexecute6FpnMVM_Operation__v_ (e104f764, 80e9b0, 0, 0, 1, 0) + 90
    fd52c2a4 __1cbCTwoGenerationCollectorPolicyRmem_allocate_work6MIii_pnIHeapWord__ (2e368, fd9c29ec, fd9c297c, fd931a26, 4800, 4998) + 160
    fd522940 __1cNinstanceKlassRallocate_instance6MpnGThread__pnPinstanceOopDesc__ (f3c09020, 831ff50, 81e33e0, 4000, 4178, 0) + 180
    fd7b7744 __1cQjava_lang_StringQbasic_create_oop6FpnQtypeArrayOopDesc_ipnGThread__pnHoopDesc__ (f0a5e910, 0, 831ff50, 0, 1, 1) + a8
    fd63228c jni_NewStringUTF (831ffe4, 605b9c8, fd587824, 80e9f8, 4800, 4998) + b8
    fdafdefc __1cKNSJavaUtilQsetStringElement6FpnHJNIEnv__pnN_jobjectArray_Ipkc_v_ (831ffe4, ace7e4, 2, 605b9c8, 4, 605b828) + 34
    fdb068dc __1cONSAPIConnectorOgetRequestInfo6MpnHJNIEnv__pnN_jobjectArray_4pnK_jintArray__v_ (e104fabc, 831ffe4, ace7e4, ace7e0, ace7dc, 4) + 9c
    fdb042e4 __1cONSAPIConnectorHservice6MpnRJ2EEVirtualServer__i_ (e104fabc, ea9560, 8, 84b9464, 6d137e0, ace7dc) + 260
    fdb02734 service_j2ee (3c1c0, 84b97f0, 84b9868, 0, fdb11d57, 132414) + 40
    ff1cf994 __1cNfunc_exec_str6FpnKFuncStruct_pnGpblock_pnHSession_pnHRequest__i_ (668, 3c1c0, 84b97f0, 84b9868, 0, 0) + 248
    ff1d0db4 INTobject_execute (77308, 84b97f0, 84b9868, 0, 37ff8, 80d290) + 5e8
    ff1d5de4 INTservact_service (84b97f0, 84b9868, ff2e7b58, 0, 0, ff2e7b30) + 4d8
    ff1d64f4 INTservact_handle_processed (84b97f0, 84b9868, 20, 2, 605bee0, 76858) + 158
    ff218a9c __1cLHttpRequestUUnacceleratedRespond6Mpc_v_ (84b9750, ff2e7b7c, 2f48, 1bb, 84b9868, 84b97f0) + 3c8
    ff21818c __1cLHttpRequestNHandleRequest6MpnGnetbuf__i_ (84b9750, 6059290, 605b3f0, 605b3d8, 2000, 60592f0) + 62c
    ff216588 __1cNDaemonSessionDrun6M_v_ (84b9348, 2000, ff2ed7bc, 0, 0, ff2ed774) + 17c
    ff106dec ThreadMain (84b9348, 84fcef0, 3, 0, 1, 4b8) + 24
    fedd0028 ptroot (84fcef0, 0, 0, 0, 20000, fede8d70) + d0
    fe165c94 lwpstart (0, 0, 0, 0, 0, 0)

    hi
    sorry for the delayed response.
    well, the problem that you are trying to run into is very common when your server is getting good amount of load and uses large amount of servlet/jsp web applications running.
    here is a url that you might find it a useful read
    http://java.sun.com/docs/hotspot/gc1.4.2/index.html#4.%20Types%20of%20Collectors|outline
    if you do not want to take this trouble reading this document and want a quick solution, you do can do couple of things:
    - first understand how to size the heap
    http://java.sun.com/docs/hotspot/gc1.4.2/index.html#3.%20Sizing%20the%20Generations|outline
    - understand that the system is paused because jvm is busy doing garbage collection before allowing the web server to continue.
    - this can be avoided by properly tuning the jvm to how you think the server should behave. unfortunately, there is no miracle one one line to fix this issue
    - by careful and decent analysis of your system, you can tune your jvm properly that it can scale very well without any glitches.
    though, you will need to take the pain to learn the garbage collection acronyms and see what's best suited for you.
    - first, you want to know what is happening inside the jvm before you proceed to optimize . you can do this by adding this option
    -verbose:gc -XX:+PrintGCDetails
    How to add this option in the server.xml , is by doing something like
    start admin server -> manager your server -> click Java tab
    -> click on JVM Option in the left side
    -> Add this JVM option -verbose:gc -XX:+PrintGCDetails
    -> restart the server
    -> note, you do NOT want to leave the above option in the production environment as this will tremendously slow your application and this is meant to be only for development purposes.
    - if your server is a multi processor server (has more than 1 CPU) and you want less pause time, you can typically try adding this jvm option to your server and restarting it.
    -XX:+UseParNewGC -XX:+CMSParallelRemarkEnabled
    here are few other short cut , jvm options that you also try in your devleopment environment before going to production.
    Server application(Like Web Server 6.1) running alone on a large multi-processor server with 4gb of physical memory.
    #java -server -XX:+AggressiveHeap
    Two applications running on a large multi-processor server with 4gb of physical memory. Each java application instance is allocated a part of total system memory by an explicit specification of the maximum and minimum heap sizes.
    #java -server -XX:+AggressiveHeap -Xms1024m -Xmx1024m
    (again, do your research before you use this option in the production environment)

  • DHCP Server is not passing out DHCP Leases

    I can't seem to figure out why DHCP server is not passing out DHCP lease a client?
    Also I can't seem to figure out why NVI0 interface is UP? I have setup another box similarly and NVI0 is down on that and the DHCP server is working fine on that too. Strange!
    I am working on CISCO 881 VPN Router...Please have a look at it and let me know. Thanks
    Here is the configuration in the box...
    sh run
    Building configuration...
    Current configuration : 6543 bytes
    ! Last configuration change at 17:09:54 CST Fri Sep 14 2012 by XXXXX
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname XXXXX
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    aaa new-model
    aaa authentication login default local
    aaa authentication login vpn_xauth_ml_1 local
    aaa authentication login sslvpn local
    aaa authorization network vpn_group_ml_1 local
    aaa session-id common
    memory-size iomem 10
    clock timezone CSTime -6
    clock summer-time CST recurring
    crypto pki trustpoint TP-self-signed-3079619067
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3079619067
    revocation-check none
    rsakeypair TP-self-signed-3079619067
    crypto pki certificate chain TP-self-signed-3079619067
    certificate self-signed 01
      30820252 308201BB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 33303739 36313930 3637301E 170D3132 30393134 31393231
      32375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 30373936
      31393036 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100993C D622004B F3AEA1E5 81106C28 36EC52D0 5435ABC3 8912095F 3641168A
      B67D97AF AEB43CF3 00A00EB5 702FA355 9F58EBEF F42294DC 0E32CF40 E17D372A
      3BC36401 55EDBA5C 910B7A51 89D709A8 7EAB3FF0 E4C99D34 CBE3F316 069C0E16
      BC284055 35E3D762 463DABF6 852C4E7A D2EF45A4 21F08689 4DF17870 9E2A6C27
      1BFB0203 010001A3 7A307830 0F060355 1D130101 FF040530 030101FF 30250603
      551D1104 1E301C82 1A506F70 6C617276 696C6C65 2E796F75 72646F6D 61696E2E
      636F6D30 1F060355 1D230418 30168014 64EA4CAE 2029E4C2 702584C6 B5732464
      5C9DA38A 301D0603 551D0E04 16041464 EA4CAE20 29E4C270 2584C6B5 7324645C
      9DA38A30 0D06092A 864886F7 0D010104 05000381 81006C27 96E06B83 04DBDA81
      EEB0AF35 84ED370E A8C9694E F9B9326D 69CB1043 9C396D7B 760D252F 4881926D
      878E434F 9AFC3E6D A5BF43F2 E619D6EC F45C039A 5FFB478F A99F7EE5 274E37D5
      11976FDE 823FD1A9 700203E5 67A329B3 F4CF45F0 245757C8 E2349276 B13414D1
      017616FA 38A40BA8 42545AC5 C7676D21 29E4F491 CADB
            quit
    ip source-route
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 192.168.1.1 192.168.100.101
    ip dhcp excluded-address 192.168.1.254
    ip dhcp pool ccp-pool
       import all
       network 10.10.10.0 255.255.255.248
       default-router 10.10.10.1
       lease 0 2
    ip dhcp pool Internal_Network
       network 192.168.1.0 255.255.255.0
       dns-server 192.168.100.254
       default-router 192.168.1.254
    ip cef
    ip domain name yourdomain.com
    ip name-server 192.168.100.254
    no ipv6 cef
    license udi pid CISCO881-K9 sn FTX1604828T
    username XXXXX privilege 15 secret 5 $1$QEcR$96cmvs/h/.05G6BnorcWG/
    username XXXXX secret 5 $1$PQQ1$3.Vin0i/2uZ/KD0xEJ8GC.
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp policy 2
    encr 3des
    hash md5
    authentication pre-share
    group 2
    crypto isakmp client configuration group YYYYYYY
    key XXXXX_XXXXX_XXXXX
    pool VPN-Pool
    acl VPN-Access-List
    crypto isakmp profile vpn-isakmp-profile-1
       match identity group YYYYYYY
       client authentication list vpn_xauth_ml_1
       isakmp authorization list vpn_group_ml_1
       client configuration address respond
       virtual-template 2
    crypto ipsec transform-set encrypt-method-1 esp-3des esp-sha-hmac
    crypto ipsec profile VPN-Profile-1
    set transform-set encrypt-method-1
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    description WAN_INTERFACE
    ip address 192.168.100.3 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface Virtual-Template2 type tunnel
    ip unnumbered FastEthernet0
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VPN-Profile-1
    interface Vlan1
    description VLAN1_INTERFACE
    ip address 192.168.1.254 255.255.255.0
    no ip redirects
    no ip unreachables
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    ip local pool VPN-Pool 192.168.1.151 192.168.1.200
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 100 interface FastEthernet4 overload
    ip nat inside source static tcp 192.168.1.100 21 192.168.100.3 21 extendable
    ip nat inside source static tcp 192.168.1.100 80 192.168.100.3 80 extendable
    ip route 0.0.0.0 0.0.0.0 192.168.100.254
    ip access-list extended VPN-Access-List
    permit ip 192.168.1.0 0.0.0.255 any
    permit tcp host A.B.C.D host 192.168.1.100 eq ftp
    permit tcp host A1.B1.C1.D1 host 192.168.1.100 eq ftp
    permit tcp host A2.B2.C2.D2 host 192.168.1.100 eq ftp
    permit tcp 192.168.1.0 0.0.0.255 host 192.168.1.100 eq ftp
    permit tcp host A3.B3.C3.D3 host 192.168.1.100 eq ftp
    permit tcp any host 192.168.1.100 eq XXX
    access-list 23 permit 10.10.10.0 0.0.0.7
    access-list 23 permit 192.168.1.0 0.0.0.255
    access-list 100 permit ip 192.168.1.0 0.0.0.255 any
    no cdp run
    control-plane
    banner exec ^C
    % Password expiration warning.
    Cisco Configuration Professional (Cisco CP) is installed on this device
    and it provides the default username "cisco" for  one-time use. If you have
    already used the username "cisco" to login to the router and your IOS image
    supports the "one-time" user option, then this username has already expired.
    You will not be able to login to the router with this username after you exit
    this session.
    It is strongly suggested that you create a new username with a privilege level
    of 15 using the following command.
    username <myuser> privilege 15 secret 0 <mypassword>
    Replace <myuser> and <mypassword> with the username and password you
    want to use.
    ^C
    banner motd ^C XXXXX-XXXXX VPN Router ^C
    line con 0
    exec-timeout 30 0
    logging synchronous
    no modem enable
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    password 7 124A50424A5E5550
    transport input telnet ssh
    scheduler max-task-time 5000
    end

    Hi Jennifer,
    I have gotten it resolved. Per your suggestion, I have turned on debug ip dhcp events and found that POOL EMPTY message. After little research, I found out that I have made a mistake in my excluded-address range.
    I have had it as 
    ip dhcp excluded-address 192.168.1.1 192.168.100.101
    It should have been
    ip dhcp excluded-address 192.168.1.1 192.168.1.101.
    It was a typo.
    Thank you for the suggestion.
    Srini

  • Java Connector Server - run as service on Windows

    Hi
    For whatever reason, I'm not able to install the java Connector Server as a service on my Windows server.
    It does give a successful message upon connectorserver.bat /install, but it does not show up.
    I can run and use it fine with the command connectorserver.bat /run
    Also, the .Net version installs fine as a service.
    Any ideas out there?
    - Lars

    Update in this one.
    I got it installed as a service (it was a user rights problem). Now the problem is that it won't start.
    It gives me the error:
    +[173 javajni.c] [error] %1 is not a valid Win32 application.+
    +[898 prunsrv.c] [error] Failed creating java c:\Oracle\Java\jdk1.7.0_10\jre\bin\server\jvm.dll+
    +[1132 prunsrv.c] [error] ServiceStart returned 1+
    In dire need of help, as it would be impossible to keep running this connectorserver with the /run parameter. :)
    Some additional information:
    OS: MS Win Server 2008 R2
    System: 64-bit
    Java-version: JDK1.7.0_10
    Edited by: lloberg on Jan 18, 2013 1:36 AM

  • MBean classloading in Sun Java Application Server 9.0

    Hi,
    I am having a classloading issue when attempting to register my custom MBeans within the Sun Java Application Server 9.0 environment.
    The instructions say I can put either my classes or a Jar archive in domain_dir/applications/mbeans. When I put just the class files there it works fine. However, when I attempt to Jar those same class files (properly I might add) and put that Jar there it fails to find the mbean classes.
    Does anyone know anything about this?
    Thanks for any help.

    Hi Kedar,
    Thanks for the reply. Yes, I finally figured it out.
    The custom MBeans seem to work well for the most part though I don't know for sure if I'm using them in the way they were really intended.
    Basically, I want to run 'services' on my application server for the lifetime of the server. I want these 'services' to maintain things like runtime caching of information over time that is not persisted in a DB but needs to be kept around in active memory to be used at a later time, but only while the application server is up and running.
    Another thing I would like to do is have them receive JMS notifications directly, but I seem to be having trouble when subscribing as a consumer within my custom MBean. The topic thread on that is here:
    http://forum.java.sun.com/thread.jspa?threadID=5153124&tstart=0

  • Sun Java Application Server 9.0 and 9.1 - High CPU PROCENTAGE 100%

    Hi,
    I have problem with sun java application Server running after few days during watching a logs from web admin suddenly the application server takes 100% cpu and keeps this procentage - I have to manually close the server process.
    The server running on Windows Server 2003.
    Anyone have any idea to sovle the problem?

    Hi Kedar,
    Thanks for the reply. Yes, I finally figured it out.
    The custom MBeans seem to work well for the most part though I don't know for sure if I'm using them in the way they were really intended.
    Basically, I want to run 'services' on my application server for the lifetime of the server. I want these 'services' to maintain things like runtime caching of information over time that is not persisted in a DB but needs to be kept around in active memory to be used at a later time, but only while the application server is up and running.
    Another thing I would like to do is have them receive JMS notifications directly, but I seem to be having trouble when subscribing as a consumer within my custom MBean. The topic thread on that is here:
    http://forum.java.sun.com/thread.jspa?threadID=5153124&tstart=0

  • "Unable to establish server mode." When connecting to MSMDPUMP.DLL using SSL

     SQL Server Developer's edition 2014
    This is the same issue as was reported with 2012 but there is no service pack to fix it. 
    See link:
    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/9e0d6937-00b9-44f8-a08b-f8305b0e2045/unable-to-connect-to-sql-server-2012-analysis-services-from-management-studio?forum=sqlanalysisservices
    Message details:
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.SupportedServers.IsIMBIServer(SqlOlapConnectionInfoBase connectionInfo)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.SupportedServers.GetHierarchyBuilder(SqlOlapConnectionInfoBase connectionInfo)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorerControl.GetObjectBuilder(SqlOlapConnectionInfoBase ci)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorerControl.BuildDataModel(SqlOlapConnectionInfoBase ci)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorerControl.GetHierarchy(SqlOlapConnectionInfoBase ci, String displayName)
       at Microsoft.SqlServer.Management.SqlStudio.Explorer.ObjectExplorerService.ConnectToServer(UIConnectionInfo connectionInfo, IDbConnection liveConnection, Boolean validateConnection)

    Hi Dqzz,
    According to your description, you encounter the "Unable to establish server mode" error. Right?
    In Analysis Services, this issue has been reported and it has been fixed in the later services pack. Please see: SSMS
    raises "Unable to establish server mode" error if SSAS encounters errors during startup. However, it also can be related to running out of memory issue which will cause this error. Please refer to a blog below:
    https://cwebbbi.wordpress.com/2012/05/28/unable-to-establish-server-mode-error-in-ssms/
    If you have any question, please feel free to ask.
    Simon Hou
    TechNet Community Support

  • Installation Problem Sun Java App Server 8.2 PE

    Hello! every body Please help me to get out of this Monster :(
    For last 2 day i m trying to install Sun Java Application Server 8.2 PE. Installing & uninstalling Dozens of time.
    The Installation halted at *51% at Uncompressing sun-as-jsr88-dm.jar*
    I have searched the SDN forums at done every thing provided on the forum but in vain. So please help me i m using Win XP SP2

    `Hello!!!
    Any body there!!
    Such a big forum any body please help me i want to install the server.

Maybe you are looking for

  • How to access files stored in a portal

    Hi All, I have a file stored in the root directory ..somewhere in root/portalapps/myfile.csv This is an xl file ... I want to read the contents of this file and write it on the screen.. even though there is data in my file but i am not being able to

  • SocketExceptions in petStore demo

    Hi, I installed WL6.0 beta yesterday and I tried to run the PetStore demo. It runs well, I am able to get to different pages, but it is very slow. Checking the server DOS window, I noticed a lot of Socket Exceptions, and I assume one reason the appli

  • Non-admin help

    Due to all of the virus rumors going around, I decided to start using a non-admin account on my computer (just to be on the safe side). So I am wondering what the EASIEST way is to bring all of the files that I have--mp3s, applications, documents, et

  • How to install window manager: awesome ? package not found

    hello, i have installed arch linux from: archlinux-2010.05-core-dual.iso. Base installation. i made a system update # pakman -Syu # packman -S base-devel [comunity] is enabled in /etc/pacman.conf but if i try # pakman -S awesome i get error: 'awesome

  • .mov-files don't play well

    Since my friend upgraded his iMac he can't play .mov-files recorded earlier on his older Mac. The picture is good but there isn't any sound. He updated to the latest version of QuickTime 7 (Standard version). The same CD plays well on my Mac-G4 with