Kodo.jdbc.AutoIncrementConstraints doesn't seem to do anything

I have an app_user table and related entity with an auto-increment
primary key (on MySQL), and a user_role table and related entity with a
FK pointing to the user PK. Both entities are using application
identity. The problem is that the user_role record is written out with a
null value for the FK pointing to the app_user table.
I've set
kodo.jdbc.AutoIncrementConstraints: true
both in the kodo.properties file used for enhancing, and in the
properties use for runtime user (which are fed to JDBCConfigurationImpl
via the fromProperties() method). However, the flag simply seems to do
nothing whether it's set or not...
The user is first created, then the role is added, then either calling
makePersistent or attachCopy has exactly the same effect, the user and
the role are written out, but the role has a null fk... Right now
there's no not-null constraint on the fk, but I believe it would be
triggered if ti existed.
Can anybody confirm that this should work ok?
package.jdo:
<class name="User" objectid-class="com.xxx.dexter.slice.dao.id.UserId">
<extension vendor-name="kodo" key="detachable" value="true"/>
<field name="id" primary-key="true">
</field>
<field name="roles">
<collection element-type="UserRole"/>
<!-- delete all userroles when the user is deleted -->
<extension vendor-name="kodo" key="element-dependent"
value="true"/>
<!-- specify the field that owns this two-sided relation -->
<extension vendor-name="kodo" key="inverse-owner" value="user"/>
</field>
</class>
<class name="UserRole"
objectid-class="com.xxx.dexter.slice.dao.id.UserRoleId">
<extension vendor-name="kodo" key="detachable" value="true"/>
<field name="id" primary-key="true">
</field>
<field name="user">
</field>
</class>
package.mapping:
<class name="User">
<jdbc-class-map type="base" table="app_user"/>
<field name="id" primary-key="true">
<jdbc-field-map type="value" column="user_id"/>
</field>
<field name="roles">
<jdbc-field-map type="one-many" table="user_role"
ref-column.user_id="user_id"/>
</field>
</class>
<class name="UserRole">
<jdbc-class-map type="base" table="user_role"/>
<field name="id" primary-key="true">
<jdbc-field-map type="value" column="id"/>
</field>
<field name="user">
<jdbc-field-map type="one-one" column.user_id="user_id"/>
</field>
</class>
Regards,
Colin

Please ignore the message below. While I was properly using the
jdbc-auto-increment vendor extension for some other tables, it was
somehow left out on these two. Adding it resolved the problem.
Colin Sampaleanu wrote:
I have an app_user table and related entity with an auto-increment
primary key (on MySQL), and a user_role table and related entity with a
FK pointing to the user PK. Both entities are using application
identity. The problem is that the user_role record is written out with a
null value for the FK pointing to the app_user table.
I've set
kodo.jdbc.AutoIncrementConstraints: true
both in the kodo.properties file used for enhancing, and in the
properties use for runtime user (which are fed to JDBCConfigurationImpl
via the fromProperties() method). However, the flag simply seems to do
nothing whether it's set or not...
The user is first created, then the role is added, then either calling
makePersistent or attachCopy has exactly the same effect, the user and
the role are written out, but the role has a null fk... Right now
there's no not-null constraint on the fk, but I believe it would be
triggered if ti existed.
Can anybody confirm that this should work ok?
package.jdo:
<class name="User" objectid-class="com.xxx.dexter.slice.dao.id.UserId">
<extension vendor-name="kodo" key="detachable" value="true"/>
<field name="id" primary-key="true">
</field>
<field name="roles">
<collection element-type="UserRole"/>
<!-- delete all userroles when the user is deleted -->
<extension vendor-name="kodo" key="element-dependent"
value="true"/>
<!-- specify the field that owns this two-sided relation -->
<extension vendor-name="kodo" key="inverse-owner" value="user"/>
</field>
</class>
<class name="UserRole"
objectid-class="com.xxx.dexter.slice.dao.id.UserRoleId">
<extension vendor-name="kodo" key="detachable" value="true"/>
<field name="id" primary-key="true">
</field>
<field name="user">
</field>
</class>
package.mapping:
<class name="User">
<jdbc-class-map type="base" table="app_user"/>
<field name="id" primary-key="true">
<jdbc-field-map type="value" column="user_id"/>
</field>
<field name="roles">
<jdbc-field-map type="one-many" table="user_role"
ref-column.user_id="user_id"/>
</field>
</class>
<class name="UserRole">
<jdbc-class-map type="base" table="user_role"/>
<field name="id" primary-key="true">
<jdbc-field-map type="value" column="id"/>
</field>
<field name="user">
<jdbc-field-map type="one-one" column.user_id="user_id"/>
</field>
</class>
Regards,
Colin

Similar Messages

  • When I open my RAW files in Photoshop CC they are grainy and the JPEGS are not. What is going on? It doesn't seem to have anything to do with my CACHE levels either.

    When I open my RAW files in Photoshop CC they are grainy and the JPEGS are not. What is going on? It doesn't seem to have anything to do with my CACHE levels either.

    BOILERPLATE TEXT:
    Note that this is boilerplate text.
    If you give complete and detailed information about your setup and the issue at hand,
    such as your platform (Mac or Win),
    exact versions of your OS, of Photoshop (not just "CS6", but something like CS6v.13.0.6) and of Bridge,
    your settings in Photoshop > Preference > Performance
    the type of file you were working on,
    machine specs, such as total installed RAM, scratch file HDs, total available HD space, video card specs, including total VRAM installed,
    what troubleshooting steps you have taken so far,
    what error message(s) you receive,
    if having issues opening raw files also the exact camera make and model that generated them,
    if you're having printing issues, indicate the exact make and model of your printer, paper size, image dimensions in pixels (so many pixels wide by so many pixels high). if going through a RIP, specify that too.
    A screen shot of your settings or of the image could be very helpful too,
    etc.,
    someone may be able to help you (not necessarily this poster, who is not a Windows user).
    Please read this FAQ for advice on how to ask your questions correctly for quicker and better answers:
    http://forums.adobe.com/thread/419981?tstart=0
    Thanks!

  • I have white eyes on my pictures and there doesn't seem to be anything to correct this problem (only a red eye button).

    Just wanted to mention that I have the newest ios 6.0.1 software update on my 4s phone and now all my pictures have "white eye".  There doesn't seem to be anything to correct this problem (only a red eye button).

    ....tough croud!
    https://discussions.apple.com/thread/2495024?start=0&tstart=0
    http://thebeginnerslens.com/iphone-photography/white-eye-photos-iphone-4-led-fla sh-apples-biggest-camera-blunder.html

  • Disk Utility-Permissions Repair doesn't seem to repair anything

    I have recently installed Leopard, and so far I haven't had any serious issues. However, I used the 'Repair Permissions' function in Disk Utility today, and it doesn't seem to have repaired anything.
    As a rule, I run 'Repair Permissions' two times in a row, just in case it missed anything the first time around. When I ran it a second time, everything that it had supposedly fixed on the first run was showing up the second time.
    Is there any reason that permissions repair wouldn't be making the necessary changes? If so, how can I fix it. Any ideas would be appreciated. Thank you.

    Hi DJ EeeKay
    In the following article there is a list of messages that you can safely ignore:
    http://support.apple.com/kb/TS1448?
    Note: that it was +Last Modified: April 17, 2009+ and I've noticed a few more after the last round of updates.
    Dennis
    Message was edited by: den.thed
    Also note that if you uncheck "Show details" you will no longer see the messages.

  • IMac doesn't seem to save anything

    Hi all,
    I recently had my iMac sent off for a new HD install. Once I got it back, I restored as much as I could from my back up. But, now no passwords / details get saved across the Mac.
    i.e My signature won't save in Mail - if I create one and then close mail down, when I open it back up it's gone. And when I save usernames and passwords in applications such as Espresso app or Sequel Pro, again when I close them and go back to them, they're all gone and I have to reenter them again.
    The weird thing is, all the user info is stored in my Keychain, it just isn't syncing it to the app or saving it and heavens knows what's going on with mail and why my signature won't save.
    I have tried repairing permissions and that didn't seem to fix anything, so any help from anyone would be brilliant,
    Thank you!

    Back up all data. Don't continue unless you're sure you can restore from a backup, even if you're unable to log in.
    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.
    Step 1
    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. To do that, unlock the preference pane using the credentials of an administrator, check the box marked Allow user to administer this computer, then reboot. You can demote the problem account back to standard status when this step has been completed.
    Triple-click the following line to select it. Copy the selected text to the Clipboard (command-C):
    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:staff ~ $_ ; sudo chmod -R u+rwX ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null
    Launch the Terminal application in any of the following ways:
    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)
    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.
    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.
    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning to be careful. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.
    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.
    Step 2 (optional)
    Step 1 should give you usable permissions in your home folder. This step will restore special attributes set by OS X on some user folders to protect them from unintended deletion or renaming. You can skip this step if you don't consider that protection to be necessary, and if everything is working as expected after step 1.
    Boot into Recovery by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.
    When the OS X Utilities screen appears, select
    Utilities ▹ Terminal
    from the menu bar. A Terminal window will open.
    In the Terminal window, type this:
    res
    Press the tab key. The partial command you typed will automatically be completed to this:
    resetpassword
    Press return. A Reset Password window will open. You’re not  going to reset a password.
    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.
    Select your username from the menu labeled Select the user account if not already selected.
    Under Reset Home Directory Permissions and ACLs, click the Reset button.
    Select
     ▹ Restart
    from the menu bar.

  • I see "Enrollment Settings" under device groups but it doesn't seem to do anything.  Is that normal?

    Hello, first time poster.
    I'm new to most things apple aside from basic use of ipads and iphones.  I was put in charge of the ipads for my school district and after some research and effort, I've gotten a mac server (on mavericks) up and running.
    I have setup an MDM, gotten the token, gotten the VPP, etc...
    Everything is working as it seems to be working.  But...
    In Device groups, under settings for a device group I see "Enrollment Settings" with things like "prompt user to enroll device" and "Supervise (IOS only)".  So I added a device to a new group, reset the device in question and nothing.  The settings appeared to do nothing.  Is that normal or am I missing something?

    Which version of Server.app?  3.1.2?
    Verifty local DNS services.  Invalid DNS causes other OS X Server components to have issues.  You'll need DNS on your local network somewhere, whether that's served by OS X Server, or another DNS server doesn't matter.
    Launch Terminal.app from Applications > Utilities and issue the following harmless, diagnostic command:
    sudo changeip -checkhostname
    That'll require an administrative password for the sudo, might generate a one-time message about the use of sudo, and will then display some configuration information and then an indication that no changes are required, or that there are network or DNS issues.  If you're not in .local or .arpa, that'll usually give you a good view of your local network configuration.
    The device has to be enrolled with Profile Manager server.   How you do that depends on how you want to manage your devices.   There are various overviews of how this stuff works too, if you're getting started: here is one video.

  • Batch Monitor shows no progress - qmaster doesn't seem to process anything

    I've been using this iMac since my company bought it a year ago and haven't had trouble with compressor until earlier this week when it just stopped working - no error message no crash - its just doesn't process jobs. I haven't updated anything or added any weird software of which I'm aware. Unfortunately I don't have a time machine back up to return to. We have the extended apple care and I haven't reformatted and reinstalled everything yet, I'm desperately trying to avoid that as I've already had to do it once in the past few months and it put me back at least a week of productivity as it took several days to get everything reinstalled. The same is true for taking it to the local apple specialist - took them a week last time I dropped a computer off there.
    Whether its a file that I'm opening in compressor or a project I'm exporting from final cut I can wait for 20 hours and no progress is made I've done a great deal of searching on these as well as other online forums and taken lots of advice given to other people with similar problems and nothing seems to work here's what i've tried in a rough order:
    Checking for Updates
    Resetting back ground processes
    Deleting preferences (for compresser et al)
    turning sharing on/turning sharing off
    starting qmaster using terminal
    restarting qmaster using terminal
    checking qmaster's settings using terminal and setting 'rendering' and processing to 'on'
    Reinstalling compressor,qmaster,qadministrator and batch monitor using Pacifist
    When Reinstalling I never click the box to share processing on a network
    I've tried starting jobs with it disconnected from my office LAN
    I've tried Everything on the compressor troubleshooting basics page including deleting all files associate with compressor, qmaster, qadmin and even motion and reinstalling them.
    after each reinstall I always update compressor as it wont even start in snow leopard without updating
    I've checked in activity monitor - qmaster is running just fine, it appears.
    If anyone has any more suggestions as to things that could be done, please offer them.

    try these initial things:
    • check the QMASTER logs in /var/logs (or simply use the /applications/utilities/CONSOLE.app). IF its failing or stalled there WILL be a reason for it.
    • look for QMASTER crashes logs...... you maybe not be able to red the dump but there will be a common thing in there somewhere...
    • stalled?: maybe sitting in the ACTIVE QUEUE with PROCESSING, but doing nothing.. maybe one of the services has failed. I se an EMAIL address up in the compressor to tell if anything broke. works great!
    • stalled?: maybe your set up the cluster maybe expecting MANAGED SERVICEs and you cluster is not SETup for that.lots of these things.
    anyway, have a look in the console logs and post your stuff. Happy to help you with it.
    I have found the latest qmaster and compressor with FCS3 is very good.
    LAstly, I have had the ODD thing that utilises PERIAN plugins etc t sit and do nothing. PErian ends up dumping.. anyway all this can be worked around.
    w

  • QOS Policy gets Policy hits but doesn't seem to do anything when put to the test

    I have been trying to implement a policy that prioritizes certain types of of traffic over another namyly Lync Voice Traffic, Cisco CAPWAP traffic from controllers to AP's, and Citrix ICA Traffic. 
    I do recieve policy hits but when I load the connection up with say copying a file the policy seems to not work. This is on a 1921 router. 
    I will include the config as I may be doing somthing wrong.
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    aaa new-model
    aaa authentication login default group radius local
    aaa authorization exec default group radius local
    aaa session-id common
    ip cef
    ip domain name pmp.local
    no ipv6 cef
    multilink bundle-name authenticated
    username XXXXXXXXXXXXXXXXXXXX
    ip ssh time-out 60
    ip ssh version 2
    class-map match-any CAPWAP
     match access-group 104
    class-map match-any LYNC
     match access-group 103
    class-map match-any CITRIX
     match protocol citrix
     match access-group 110
    policy-map OUTBOUND
     class LYNC
      priority percent 25
     class CITRIX
      priority percent 50
     class CAPWAP
      priority percent 20
     class class-default
      shape average 20000000
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    interface GigabitEthernet0/0
     no ip address
     duplex auto
     speed auto
    interface GigabitEthernet0/0.1
     description LAN Facing
     encapsulation dot1Q 1 native
     ip address 172.16.27.254 255.255.255.0
     ip helper-address 10.128.4.48
     ip helper-address 10.128.4.20
     ip helper-address 172.16.27.79
     no ip redirects
     ip flow ingress
    interface GigabitEthernet0/0.5
     encapsulation dot1Q 5
     ip address 172.16.127.254 255.255.255.0
     ip helper-address 10.128.4.48
     no ip redirects
     ip flow ingress
    interface GigabitEthernet0/0.50
     description ITTestVlan Interface
     encapsulation dot1Q 50
    interface GigabitEthernet0/1
    description PointToPoint
    bandwidth 20480
    ip address 10.0.27.254 255.255.255.0
     no ip redirects
     ip flow ingress
     duplex full
     speed 100
     service-policy output OUTBOUND
    router eigrp 10
     network 10.0.27.0 0.0.0.255
     network 172.16.27.0 0.0.0.255
     network 172.16.127.0 0.0.0.255
    ip forward-protocol nd
    ip forward-protocol udp 4011
    ip forward-protocol udp bootps
    no ip http server
    ip http access-class 23
    ip http authentication aaa login-authentication default
    ip http authentication aaa exec-authorization default
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 1000
    ip route 0.0.0.0 0.0.0.0 172.16.27.253 200
    access-list 23 permit 10.0.27.0 0.0.0.255
    access-list 23 permit 172.16.0.0 0.0.0.255
    access-list 23 permit 172.16.27.0 0.0.0.255
    access-list 23 permit 172.16.127.0 0.0.0.255
    access-list 103 remark LYNC-Priorisation
    access-list 103 permit tcp any any eq 3389
    access-list 104 remark CAPWAP-Priority
    access-list 104 permit udp any eq 5246 any
    access-list 104 permit udp any any eq 5246
    access-list 104 permit udp any eq 5247 any
    access-list 104 permit udp any any eq 5247
    access-list 110 remark Citrix-Priorisation
    access-list 110 permit tcp any eq 2598 any
    access-list 110 permit tcp any any eq 2598
    access-list 110 permit tcp any eq 1494 any
    access-list 110 permit tcp any any eq 1494
    snmp-server enable traps entity-sensor threshold
    radius-server host 10.128.4.20 key XXXXXXXXXXXXXXXXXXXXXXXXXX
    control-plane

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    So what do you have, a 100 Mbps Ethernet hand-off with a 20 Mbps bandwidth cap?
    If so, you want to shape for your logical bandwidth cap and then priorize, as desired, in a child policy.
    BTW, you normally don't use LLQ for other than very time critical traffic, e.g. VoIP bearer, and Cisco recommends you don't allocate more than a third of your bandwidth to LLQ.
    I would suggest you just shape for your 20 Mbps and try FQ for all traffic.
    e.g.
    policy-map Sample
    class class-default
    shape average 20000000
    fair-queue
    NB: I'm unsure whether FQ will apply to the shaped traffic, if not:
    policy-map SampleParent
    class class-default
    shape average 20000000
    service-policy SampleChild
    policy-map SampleChild
    class class-default
    fair-queue
    NB: SampleChild is where/how you would provide a custom policy for your shaped traffic.
    PS:
    BTW, you apply the policy with the shaper to the interface.

  • Firefox keeps saying it has an update, to 35.0.1 available, but when I update, it doesn't seem to do anything, so keeps telling me to update HELP

    It seems to upload, and says changes will be complete when Firefox restarts, but then apparently, it never updates.

    Hello AdriftinSitka, please try to download and install firefox, do the next steps:
    1. Download a copy of the latest firefox from http://www.mozilla.org/en-US/firefox/all.html (full dmg package)
    2. '''Trash''' the current Firefox application to do a clean install.
    3. Install the version that you have downloaded.
    Do not select to remove your personal data, your profile data is stored elsewhere in the [http://kb.mozillazine.org/Profile_folder_-_Firefox#Mac Firefox Profile Folder], so you won't lose your bookmarks or other personal data.
    see also: [https://support.mozilla.org/kb/how-download-and-install-firefox-mac Installing Firefox on Mac]
    thank you

  • HT201317 I have a different set of photos for photo stream on each of my computers, and icloud doesn't seem to do anything? Am I doing something wrong?

    Wondering why my icloud seems to do nothing..... I am so tired of using my itunes apple id and my old mobile me id that they keep asking for

    I'm working on Twilight Zone right now. I'd like to have a different image for each episode: the broken glasses from "Time Enough at Last", or the gigantic alien from "To Serve Man"; i.e., an image that will reflect the content of THAT episode. Then, for the grid view, where you simply see the show names of all the shows you have (TZ Season 1, Season 2, etc.), I'd like the generalized 'box cover' image to display. I've tried right-clicking on the SHOW in the grid view, and then pasting an image into the "Artwork" box on the Info tab. I've then used the "Set Poster Frame" function (as outlined in the help section you cited in your reply) to choose a specific image from a specific episode. But iTunes won't retain my choices - it either shows the box cover image for all the episodes, or show the 'Poster Frame' from whichever episode I happened to first perform that function on. Thank you for your help.

  • HT1539 I put in the code to get game of thrones season 2, says it's downloading. yet the downloader is empty and doesn't seem to download anything. I got to game of thrones page in itunes and it's asking for money to download the episodes. what is going o

    I used my code to get my season 2 of game of thrones on itunes.  I got a message stating I successfully redeemed my code and my season is downloading...
    Yet there is nothing in my downloader and when I go to game of thrones season 2 to download episode it is asking for money.  What did I do wrong?

    See Empty/corrupt library after upgrade/crash.
    tt2

  • How do I check my spelling, it doesn't seem to do anything

    The spell check does not light up for me to click on it..and I can't also click on the spell check to work before sending emails.

    When you first open a new Write message the 'Spelling' option on Composition Toolbar will be greyed out. This is normal.
    When you start to compose some text, the 'Spelling' option becomes black and is operational.
    However, you may need to set up some options.
    '''Is a dictionary enabled?'''
    'Tools' > 'Addons' OR 'Menu icon' > 'Addons'
    click on the last icon on left side - hover over tooltip says 'Dictionaries'
    You might need to enable a dictionary.
    '''Set options on how spellcheck is to work:'''
    Tools > Options > Composition > Spelling tab
    OR
    Menu icon > Options >Options > Composition > Spelling tab
    Select the options:
    * Check spelling before sending
    * Enable spell check as you type
    * Select Language,
    there is also a 'download more dictionaries' link if required.
    Click on OK
    '''Additional Info that may be useful.'''
    '''Installing Dictionary:'''
    After using the 'download more dictionaries' in Options.
    Or this link:
    * https://addons.mozilla.org/en-US/thunderbird/language-tools/
    After downloading the dictionary to your computer.
    In Thunderbird:
    * Tools > Addons
    * Clickon gear wheel icon and select 'Install addon from file'
    * locate the dictionary xpi file you downloaded and click on 'Open'
    '''Enabling all toolbars:'''
    If you would like to see all the toolbars to make life easier.
    Click on 3 bar menu icon and hover over Options - select all the toolbars.
    See image below as aid.

  • When I open firefox 3.6.13, a program called mixer.exe also opens, but it just sits there on the taskbar and doesn't seem to do anything. Mixer.exe is not on my list of add-ons. It uses 872k of memory. What is it? Is it supposed to be there?

    mixer.exe uses 872k of memory according to task manager.
    It shows up on the taskbar whenever I open firefox 3.6.13. It has an icon of a little rectangle with two white arrows attached to the side of the rectangle pointing inward. When I left click or right click on the Mixer icon on the taskbar, nothing happens. What is this mixer.exe? It isn't listed as one of my add-ons.
    Thank you.

    From the Firefox help files;<BR><BR>
    Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

  • I am having problems submitting forms. I have a MacBook Air and have been using adobe reader 11.0.10 to open them but it doesn't seem to send anything when I click submit.

    Thankyou

    Hi henrocktenrock,
    Does the same form work on any other machine?
    Was it working fine before you updated Reader?
    Would it be possible to share the form with me so that I can have a look.
    Regards,
    Rave

  • Calendar search doesn't seem to find anything more than a year old

    How do we request Apple to enhance calendar search to include all items?

    http://www.apple.com/feedback/iphone.html

Maybe you are looking for

  • Inventory Value in a Plant by vendor

    hi Guys : Client requirement is to have inventory position( Unrestricted + Blocked Stock) by vendor in plant @ given point of time. we have MB5L--List of stock values by material and Plant but won't give us the breakup by vendor? Thanks Sweth

  • Desktop Manager cable use disables Wireless reconciliation

    When I am using Desktop Manager software for media connection and so on.  Although I did have the organiser synchronisation set up for Outlook tasks, contacts and notes, we do our e-mail and calendar sync. using the BES wirelessly.  However, when I c

  • How to move the vertical scrollbar ?

    Hi How can I move a vertical scrollbar in the HTML page to a desired position.The position is actually a list tag element.?

  • Used disc 1 to install in win 7 machine

    I accidentally used disc 1 (vista) to install PPE10 in win7 pc.  Any harm done?

  • Icloud mail - out again

    Ever since MobileMe became iCloud, we've had all-too-frequent outages of iCloud mail. I wasn't happy with iCloud before...this makes me MORE incensed.