LAN messenger?

Hi, I'm given the assignment to build a networking application for a Local Area Network. Of course I am going to use TCP, but I'm not sure how I am going to constrain the communication withing the LAN. Should the admin input at the server some kind of network address, or could I use the address range starting from 192.168.0.0 where I can accept connections?

How can I configure my network? I just would like to accept connections only from clients that are in the LAN, and avoid connections from other clients.
One possible scheme I thought is that the administrator inputs the net address (say 227.130.22.0/24. This way the server will only accept connections from addresses between 227.130.22.0 and 227.130.22.255. But I'm not sure if this the only way.

Similar Messages

  • Lan messenger for Solaris 10 for Sparc server

    Hi
    Is there any Lan messenger for Solaris 10 for Sparc which can be run on Thin client using sunray 3.1.
    Clients need to use messenger using their thin clients.
    help in this regard will be highly appreciated
    Regards
    Thanks

    is there a client for YM phone on Solaris??
    I use Yahoo phone as my only phone and Win XP somehow refuses to work even after 4 re-installations and does not even show my network adapter. So, if I can find sth to work with Yahoo phone Solaris will be the only OS I need.
    BTW the nge0 works fine on Solaris and I am posting this from opensolaris.
    thanks everybody.

  • Private messaging...in a messenger

    hi friends...
    i am developing a lan messenger currently......but i am facing a problem...i hav developed the conference type messenger till now..means in one window all users online can send theie messages...now i want to go for sending the private messages....
    i hav used hashtable to display the ppl online in jlist....now i want to send private mesages to the users online....but donno which is the perfect way to approch it....pls help me here....after clicking the name on the list...the window for private messaging should be opened...at the both users end...how 2 approch it...

    user510497,
    Yes, an enterprise bean can have private methods.
    Good Luck,
    Avi.

  • Scroll bar remains up

    hi all
    i have developed a lan messenger to be installed in an organization.
    it works fine except for the fact that when u start chating and the display area gets full the scroll bar remains up and u have to pull it down every time u want to see the new lines entered, although it should be the reverse. please suggest me how can i make the scroll bar slide down as more text is entered.

    Simple :p
    use a function like this every time that the pane is increased
    public void actualizaBarra(){
    outputPane.getVerticalScrollBar().setValue(outputPane.getVerticalScrollBar().getMaximum());
    }This function set the scrollBar at the max value.
    In my case the scrollPane is called outputPane.

  • Threads getting "stuck" at a readLine()

    basically, i'm just finishing up a LAN messenger program and there's one last detail i can't fix up... since the program should be able to send and receive packets (messages) concurrently, i have one thread sending packets and another receiving them... i thought this would work because this way the program wont block when there's nothing to receive or send, but it still does... i think it's waiting for input in the sending thread, ie. readLine(), because when i hit enter, a bunch of messages come through... so, is there a way that i can get it not to block on the readLine()... thanks a lot.
    oh, and i've already tried to sleep() and suspend() the sending thread for quick periods, still a no go... thanks again.

    ok, i think i may have put 2 and 2 together last night. now i realized that every messenger program i've ever used has had 2 seperate boxes for text, one on the top which shows what the other person (and yourself) has written, and one on the bottom where you write your actual messages... i think that's it! that you can't print to the screen when waiting on a readLine(), so you print the incoming messages to another text box! now, i know nothing of GUIs or frames or anything like that, so i'm going to have to figure out how to make a program with two boxes for text and pick that i want the incoming messages to print to the top box... i think that may be a lot easier said than done though. if any of you know how, it'd be awesome if you could point me in the right direction. oh, and SUCH a rookie question, now that i'm using jdk i don't know how to execute my programs anymore, i tried going to the directory with the .java and .class files in it and typing at the prompt java Messy.java and i get an error java.lang.NoClassDefFound Error: Messy/java
    i know you're all still laughing, but i'd really appreciate help, i set CLASSPATH=c:/program files/ready to program/ (which is the dir of the .java and .class) and i also just typed set CLASSPATH= (because i was already in the dir) and it still said the same thing... thanks a lot people.

  • Java Messaging.....

    Hey guys..i've created a LAN messenger in Java and i'm done with the GUI and network connectivity part....the only thing i'm left with is the message sending and receiving(chatting part) and i'm really confused.....how to start with that...i mean which API should i use..i've read some article on SUN FORUMS.... most of them says use JMS (Java Messaging Service) API...

    That would be a security exception, right?

  • IP messenger in cisco lan

    Hi ,
    I want to block the IP Messenger in my university campus. I have multiple VLAN.
    I have large LAN environment with cisco 2960 and cisco 3750 series switches. 

    georgemc wrote:
    DrClap wrote:
    How did you convert "DNS" into "JNDI"?Easy. Reverse the order of D and N, then split S into J and I. I is the 9th letter of the alphabet, J is the 10th, and S is the 19th. 10 + 9 is 19. Bookend ND with that, and Bob's yer uncleAnd since from your perspective, the above was written by "I", and since capital "I" looks like a number one, we see that 9 for I and 10 for J with 1 added becomes 9 and 11, which proves that you were responsible for the 9/11 attacks. And since your name is George, and an M is an upsidedown W and C is a play on "See", which you thought nobody ever would, you must be Dubya. Ergo, the attacks were a conspiracy at the highest levels of government, QED.

  • Lan Based Messenger.

    I want to develop a LAN based messneger, which can be used by
    the employees in an office to communicate with each other,
    send files etc.
    Please tell me how to go about it -- what classes to use,where
    to start from etc. as I don't know much about network programming
    in Java.I hope it is possible
    If possible, suggest some good book on Network Programming In Java
    Thank You,
    Girish.

    Yes, it is a something that java can handle very well and there are probably lots of practical resources right here, some of which I have seen, though, as you don't seem to be familiar with java.net, then you may find ot tough going - however, I assume you know something about IO in java.
    Java doesn't really support link-level data link protocols such as Ethernet, but has good support for IP broadcast, multicast and there is support for UDP, which is higher up the protocol stack and probably your best option.
    Thats a start - check out the things that are in bold her to get you going. It should be an excellent project and I feel you will find very good support here when you get stuck for something like this.
    Good luck with it!

  • One more iChat and Yahoo Messenger question

    I have been PC user for years, but I only recently saw the light...
    I have a MacBook Pro recently updated with Lion.  I have everything updated.  So, I am trying to communicate with a friend through iChat using Yahoo Messenger.  He has a brand new PC.
    I can log into iChat using my Yahoo Messenger account.  He can do the same.  But, even though we can see each other on our Buddy List, and we can text each other, the option "Invite to video chat" is grayed out for me.  If he tries to invite me to video response, but I get no notice.
    If I have Yahoo Messenger running at the same time, it takes control, and iChat shows me offline.  If I turn Yahoo Messenger off, I still have no option to video chat.
    I have been through the pages here, but I do not have the experience I had with PC.  So, going through and deleting files in a Mac is a little indemidating for me.  Can someone welcome me to the fold and walk me through any tips you can think of that may fix my problem?  Remember, little baby steps...
    If not, thanks for reading,
    Patrick

    Hi,
    There is no "FIx" as such.
    All the major IM services that do Video somewhere along the line use different protocols in the connection process or in the actually Video Feed.
    iChat uses a Process called Session Initiation Protocol. (SIP)
    It does not matter if you have an AIM Buddy list ((One with an AIM valid ID as Lgin details) or a Jabber one or a Yahoo one or even if you enable th Bonjour one if you have other Macs on your LAN it will use this Protocol.
    This Protocol is compatible with the AIM Application on PCs
    There is a thrdr Party App called Trillian which in it's Pro Version can also Video with iChat.
    The other side of the coin is that it will only Video to other iChat Users that have Google/Jabber or Yahoo Names.
    By the same token Google run a Jabber Server
    Jabber servers use a process called Jingle to do Video
    Google however have altered their version and it is not that compatible with other Jabber apss that can Video chat
    This includes Google's Standalone App called Google Talk (PC Only), the Browser Plug-ins it produces for  Macs (Intels only) and PC and the Chat Option on their Web Pages
    Yahoo uses a straight Web Feed for Video and STUN for the Audio chat along side.
    STUN is close to SIP but not close enough to allow Audio Connections..
    NOTE
    iChat has had the Ability to Text chat to any Jabber Buddy including GoogleTalk ones since iChat 3
    iChat 3 was nearly 6 years ago and no Jabber Video ability has bee added to the app in all that time.
    Any changes are not going to be "in the next Update"
    10:39 PM      Saturday; August 6, 2011
    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb( 10.6.8)
     Mac OS X (10.6.8),
    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • RV016 with 3 WAN Connections - Windows Messenger Intermittent problems.

    I have a RV016 Router with 3 internet DSL conections.
    Firmware version : 3.0.0.1-tm (Jun 6 2008 20:17:06)
    LAN IP :  192.168.11.254  /24
    WAN1 IP :  192.168.1.253  /24
    WAN2 IP :  192.168.2.253  /24
    WAN3 IP : 192.168.3.253   /24
    MODE: Gateway.
    Windows Messenger continually connects and disconnects. This behavior is permanent
    I only have problems with Messengers (all releases), web page access is correct.
    I check bandwith saturation and It's ok, I use less than 50% of each DSL.
    I configured the correct size of MTU for each DSL and the problem continues.
    Is there any way to set priority to this service?
    Is there any way to check if the "load balance mode" affect this kind of connections?
    I appreciate any idea.

    Changing the DSL connections to bridge mode is part one of the solution.  When they weren't in bridge mode, they were also acting as gateways/routers, probably also doing NAT.
    Now that they are in bridge mode, the rv016 has control of the connections and the routing.  Now that it has control, you can make the appropriate changes.
    I ran into a similar issue as yours when I had an rv082 at one of my businesses.  I had to access the state's web site to file sales taxes online.  But their system detected when my router used a different WAN connection than the one I logged in on, so it would kick me off each time the router used both WAN connections.  I could enable only one WAN connection each time I used their system (which would also work in your case with messenger), but that wasn't a real solution.
    For you the solution will be a port trigger range.  (For me the solution was to bind that destination site to a WAN connection.)  Go to Setup-->Forwarding in the rv016 web management.  You will see a section for port triggering at the bottom.  Here's a link to a site that goes more into detail on the ports that need to have triggers on them:
    http://www.electrictoolbox.com/article/networking/open-firewall-msn-icq/
    I don't have messenger setup, so I don't know the ports off-hand. This setup should allow any system connected (just as they are now) to properly use messenger.
    Let me know if you need any more help.

  • Audioconference  with PC in a LAN

    Hi there,
    i have an audioconferencing JMF application that works between PCs if i know their IPs, but ...
    when i try to connect between a PC in a LAN that conects to Internet through on a router, i don�t know its IP. I just known router's IP, and it doesn't work.
    I solved the problem modifying configuration of the router, basically with NAPT, but this is not good, because users usually can not access to the router.
    Any suggestions?? I think Messenger and Netmeeting use a code to scan free ports or anything else.
    Thanks in advance

    Hi trilcejf,
    Did u find any solution any workaround? I am also facing the same problem.
    Priya

  • Msn and gaming through LAN

    Hi I am having trouble getting certain programs to work through a LAN. I am connected to my friends Mac Pro via an ethernet cable and he is then connected to the modem. Through this connection it will allow me to access the internet through safari however it will not let me connect to msn messenger or world of warcraft. What I was wandering was is there anyway to configure it to let me do this? I've read various forums but all of them just use lots of rough abbreviations and no step by step instructions on what to do. I also couldn't find anywhere with this exact problem. If anyone could tell me it would be a big help.

    Hi there Moppy, and Welcome to the Discussions!
    Try turning off the Firewalls on both for a start...
    System Preferences>Sharing Control Panel>firewall Tab, then click on the Stop button to allow all incoming ports to be used.

  • Connecting to Messenger Applications using Belkin router

    Hi. I can't seem to log into my MSN for mac, or other messenger services using my Belkin router. As a experiment, I joined my neighbours wireless connection and I could connect to MSN. My problem comes when trying to log into it using my router. Can anyone help? Your help would be greatly appreciated.

    I have the exact same problem and have tried contacting Belkin with this problem but making them understand I was using an iMac was difficult enough!
    These are the steps they gave me to rectify the problem but unfortunately they didn't work for me so I have taken some screen shots and am waiting on their reply. I feel I may have to resort to taking the router back to PC World!
    Making sense of the first bit was pretty tricky but I guess that choosing MSN Messenger from the drop down menu in 'Virtual Servers' and adjusting the 'LAN Port" & "public port' seems to be the right way (I think).
    To resolve the issue,please open below mentioned ports for MSN messenger on the router home page:
    6891-6900 Type TCP.
    1863 Type TCP and UDP.
    5190 Type UDP.
    6901 Type UDP and TCP.
    -Please open the Internet Explorer and in the address bar type in "192.168.2.1" and Enter.
    -Leave the password blank and click on "submit”.
    -Click on "Virtual server" under the "Firewall".
    -Enter the port numbers under "LAN Port" & "public port".
    -Enter the IP address of this computer under the "LAN IP Address".
    -Check the "Enable" box and click on "Set".
    Or
    If the version number is 2000 for F5D7632 the follow the below instruction:
    1) Open an Internet explorer window.
    2) On the address bar type in 192.168.2.1 and hit Enter.
    3) Leave the password blank and click on submit.
    4) Click on Virtual servers under Firewall section.
    5) Click on New Entry.
    6) Enter the IP address of the computer under Local Host.
    7) Click on New user-defined service.
    8) Enter the port number and click on Ok.
    Step:2) Please follow the below instruction to enable the NAT and UPNP feature on the router :
    - Log on to the router web interface at http://192.168.2.1
    - By default, the password is blank.
    - Click on System setting under "Utilities".
    - Change the UPNP to "ON".
    - Change the NAT to "ON".
    - Click on Apply changes

  • Query about Nokia Messenging Always On

    I have Nokia Messenging installed on my X6 with the access point on Internet.  My first priority in my wireless LAN which is fine but out of it's range it'll switch to my pay as you go internet access which is priority two.  This is normal.  My query is, does it cost me money having the access point open or is it just when I'm receiving/sending data?   I'm on a Vodafone PAYG tarriff.

    The flash being stuck on is generally a sign that the phone has been damaged either by a drop, water or other form of moisture.
    You should take it to a Nokia care centre for inspection as there are no settings that can turn it off.
    www.nokia.com/repair

  • 866VAE - cant acces web pages from LAN

    Hi everyone,
    im fighting with Cisco 866VAE-K9 for few days. I have got ADSL2+ line in Cisco, i can ping anything from router (like 8.8.8.8 or www.google.com), test of connection in CCP runs successfully, but i cant acces web pages from LAN computers. From LAN i can ping to any IP adress in internet (like 8.8.8.8), but i cant ping or access domain names of web pages (like www.google.com). I know there is probably something wrong in my config, but after 2 days of googling i cant find where the problem is. Can anybody help?
    Here is my running config:
    Building configuration...
    Current configuration : 8181 bytes
    ! Last configuration change at 11:31:15 UTC Fri Mar 6 2015 by admin
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname cisco_866vae
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    enable secret 5 xx
    enable password xx
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local 
    aaa session-id common
    wan mode dsl
    ip port-map user-protocol--1 port tcp 3500
    ip name-server 8.8.8.8
    ip cef
    no ipv6 cef
    parameter-map type protocol-info yahoo-servers
     server name scs.msg.yahoo.com
     server name scsa.msg.yahoo.com
     server name scsb.msg.yahoo.com
     server name scsc.msg.yahoo.com
     server name scsd.msg.yahoo.com
     server name cs16.msg.dcn.yahoo.com
     server name cs19.msg.dcn.yahoo.com
     server name cs42.msg.dcn.yahoo.com
     server name cs53.msg.dcn.yahoo.com
     server name cs54.msg.dcn.yahoo.com
     server name ads1.vip.scd.yahoo.com
     server name radio1.launch.vip.dal.yahoo.com
     server name in1.msg.vip.re2.yahoo.com
     server name data1.my.vip.sc5.yahoo.com
     server name address1.pim.vip.mud.yahoo.com
     server name edit.messenger.yahoo.com
     server name messenger.yahoo.com
     server name http.pager.yahoo.com
     server name privacy.yahoo.com
     server name csa.yahoo.com
     server name csb.yahoo.com
     server name csc.yahoo.com
    parameter-map type protocol-info msn-servers
     server name messenger.hotmail.com
     server name gateway.messenger.hotmail.com
     server name webmessenger.msn.com
    parameter-map type protocol-info aol-servers
     server name login.oscar.aol.com
     server name toc.oscar.aol.com
     server name oam-d09a.blue.aol.com
    crypto pki trustpoint TP-self-signed-2886901321
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2886901321
     revocation-check none
     rsakeypair TP-self-signed-2886901321
    crypto pki certificate chain TP-self-signed-2886901321
     certificate self-signed 01
    controller VDSL 0
    class-map type inspect match-any SDM_BOOTPC
     match access-group name SDM_BOOTPC
    class-map type inspect match-any ccp-cls-protocol-p2p
     match protocol edonkey signature
     match protocol gnutella signature
     match protocol kazaa2 signature
     match protocol fasttrack signature
     match protocol bittorrent signature
    class-map type inspect match-all ccp-cls--1
     match access-group name all
    class-map type inspect match-all ccp-cls--2
     match access-group name all1
    class-map type inspect match-any ccp-cls-protocol-im
     match protocol ymsgr yahoo-servers
     match protocol msnmsgr msn-servers
     match protocol aol aol-servers
    class-map type inspect match-any SDM_SSH
     match access-group name SDM_SSH
    class-map type inspect match-any SDM_HTTPS
     match access-group name SDM_HTTPS
    class-map type inspect match-all SDM_GRE
     match access-group name SDM_GRE
    class-map type inspect match-any SDM_SHELL
     match access-group name SDM_SHELL
    class-map type inspect match-any sdm-cls-access
     match class-map SDM_HTTPS
     match class-map SDM_SSH
     match class-map SDM_SHELL
    class-map type inspect match-all sdm-access
     match class-map sdm-cls-access
     match access-group 101
    policy-map type inspect ccp-policy-ccp-cls--1
     class type inspect ccp-cls--1
      pass
     class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--2
     class type inspect ccp-cls--2
      pass
     class class-default
      drop
    zone security out
    zone security in
    zone-pair security sdm-zp-in-out source in destination out
     service-policy type inspect ccp-policy-ccp-cls--1
    zone-pair security sdm-zp-out-in source out destination in
     service-policy type inspect ccp-policy-ccp-cls--2
    interface Loopback0
     ip address 192.168.100.1 255.255.255.0
     zone-member security in
    interface ATM0
     no ip address
     no atm ilmi-keepalive
    interface ATM0.1 point-to-point
     pvc 8/48 
      oam-pvc manage
      pppoe-client dial-pool-number 1
    interface Ethernet0
     description $ETH-WAN$
     no ip address
     shutdown
     pppoe-client dial-pool-number 2
    interface FastEthernet0
     no ip address
    interface FastEthernet1
     no ip address
    interface FastEthernet2
     no ip address
    interface FastEthernet3
     no ip address
    interface GigabitEthernet0
     no ip address
    interface GigabitEthernet1
     description $ETH-WAN$$FW_OUTSIDE$
     ip address dhcp client-id GigabitEthernet1
     ip tcp adjust-mss 1412
     shutdown
     duplex auto
     speed auto
    interface Vlan1
     description $FW_INSIDE$
     ip address 192.168.7.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     zone-member security in
     ip tcp adjust-mss 1412
    interface Dialer1
     no ip address
    interface Dialer2
     description $FW_OUTSIDE$
     ip address negotiated
     ip mtu 1452
     ip nat outside
     ip virtual-reassembly in
     zone-member security out
     encapsulation ppp
     dialer pool 1
     dialer-group 3
     ppp authentication chap pap callin
     ppp chap hostname o2
     ppp chap password 0 o2
     ppp pap sent-username o2 password 0 o2
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat source list 101 interface Dialer2 overload
    ip nat inside source static tcp 192.168.7.39 3500 interface Dialer2 3500
    ip nat inside source list 101 interface Dialer2 overload
    ip nat inside source route-map MAP_ACL interface Dialer2 overload
    ip route 0.0.0.0 0.0.0.0 Dialer2 permanent
    ip route 192.168.2.0 255.255.255.0 192.168.7.3 permanent
    ip access-list extended NAT_ACL
     deny   ip 192.168.0.0 0.0.0.255 192.168.0.0 0.0.255.255
     permit ip 192.168.0.0 0.0.0.255 any
    ip access-list extended SDM_BOOTPC
     remark CCP_ACL Category=0
     permit udp any any eq bootpc
    ip access-list extended SDM_GRE
     remark CCP_ACL Category=1
     permit gre any any
    ip access-list extended SDM_HTTPS
     remark CCP_ACL Category=1
     permit tcp any any eq 443
    ip access-list extended SDM_SHELL
     remark CCP_ACL Category=1
     permit tcp any any eq cmd
    ip access-list extended SDM_SSH
     remark CCP_ACL Category=1
     permit tcp any any eq 22
    ip access-list extended all
     remark CCP_ACL Category=128
     permit ip any any
    ip access-list extended all1
     remark CCP_ACL Category=128
     permit ip any any
    access-list 2 remark CCP_ACL Category=2
    access-list 2 permit 192.168.7.0 0.0.0.255
    access-list 101 remark CCP_ACL Category=128
    access-list 101 permit ip any any
    access-list 101 permit udp any any eq domain
    access-list 101 permit udp any eq domain any
    dialer-list 1 protocol ip permit
    dialer-list 2 protocol ip permit
    dialer-list 3 protocol ip permit
    mac-address-table aging-time 15
    route-map MAP_ACL permit 10
    line con 0
     no modem enable
    line aux 0
    line vty 0 4
     exec-timeout 40 0
     password xxxxxxx
     transport input telnet ssh
     transport output telnet ssh
    scheduler allocate 60000 1000
    end

    Hi,
    I would be happy to help but I have one question first: Your configuration contains a lot of cruft generated from SDM/CCP and I am not sure if any of that is really required by you. Do you believe you would be fine with having this entire configuration trimmed down and do just what's supposed to do (routing and NAT), and we had security measures added in later? Just by the way, I do not believe you need the zone-based firewall. In your simple setup with just a few inside/outside interfaces, it does not add any real value apart from making the configuration virtually unreadable. We can easily do the same with IP Inspect.
    Best regards,
    Peter

Maybe you are looking for