Load balancing across multiple application servers not working with JCo RFC

We have a problem where inbound messages to the Mapping Runtime engine (ABAP -> J2EE) are not load balanced over application servers. However, load balancing does take place across server nodes within one application server.
Our system comprises of the following:
Central Instance (2 X server nodes)
Database Instance
2 X Dialog Instances (with 2 X server nodes each)
The 1st application server that starts is usually the one that is used for inbound messaging.
We have looked at the sap gateway configuration and have tried various options without much luck:
i.e.: local gateways vs. one central gateway, load balancing type by changing parameter gw/reg_lb_level, see: http://help.sap.com/saphelp_nw70/helpdata/EN/bb/9f12f24b9b11d189750000e8322d00/frameset.htm
Here are our release levels:
SAP_ABA     700     0012     SAPKA70012
SAP_BASIS     700     0012     SAPKB70012
PI_BASIS     2005_1_700     0012     SAPKIPYJ7C
ST-PI     2005_1_700     0005     SAPKITLQI5
SAP_BW     700     0013     SAPKW70013
ST-A/PI     01J_BCO700     0000          -
Any help would be greatly appreciated.
Many thanks

Tim
Did you follow the guide here:
How to Scale Up SAP Exchange Infrastructure 3.0  
Learn what the most likely scaled system architecture looks like, and read about a step by step procedure to install additional dialog instances. The guide also walks you through additional configuration steps and the application of Support Package Stacks.
https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/c3d9d710-0d01-0010-7486-9a51ab92b927
We followed this guide for XI3.0 and PI7.0 and works successfully!

Similar Messages

  • Load balancing across multiple machines

    I am looking for assistance in configuring Tuxedo to perform load balancing across
    multiple machines. I have successfully performed load balancing for a service
    across different servers hosted on one machine but not to another server that's
    hosted on a different machine.
    Any assistance in this matter is greatly appreciated.

    Hello, Christina.
    Load balancing with multiple machines is a little bit different than
    in the same machine. One of the important resource in this kind
    of application is network bandwidth, so tuxedo tries to keep the
    traffic among the machines as low as possible. So, it only
    balance the load (call services in other machine) in case all the
    services are busy in the machine where they are call.
    I mean, if you have workstation clients attached only to one
    machine, then tuxedo will call services in this machine untill
    all servers are busy.
    If you want load balancing, try to put one WSL in each machine,
    and the corresponding configuration in your WSC ( with the | to
    make tuxedo randomly choose one or the other) or spread your
    native clients among all the machines.
    And so, be carefull with the routing!
    Ramón Gordillo
    "Christina" <[email protected]> wrote:
    >
    I am looking for assistance in configuring Tuxedo to perform load balancing
    across
    multiple machines. I have successfully performed load balancing for a
    service
    across different servers hosted on one machine but not to another server
    that's
    hosted on a different machine.
    Any assistance in this matter is greatly appreciated.

  • I bought the Keynote app for my MacBook, but when I open the application and try to install it, I get an error message saying that the application will not work with my MacBook. What gives? And, can I please request a refund? ($19.99 = a week's groceries)

    I bought the Keynote app for my MacBook, but when I open the application and try to install it, I get an error message saying that the application will not work with my MacBook. What gives? And, can I please request a refund? ($19.99 = a week's groceries).
    Thank you for your help! - I did try looking for all available specs about Keynote on the Apple iTunes website, and found nothing that could help me. HELP!

    1
    Close all iWork applications
    2
    Uninstall Keynote; this must be done with an application remover tool to delete the installation properly. Appcleaner is known to work correctly for this purpose, it is free and can be downloaded from here: Appcleaner Download
    3
    empty the trash
    4
    shutdown the Mac and restart. After the start up chime, hold down the shift key until the apple logo appears
    let the Mac complete the start up procedure completely, it will take longer than usual as the hard drive is being repaired
    5
    Reinstall Keynote by logging into the Mac App Store using download / install

  • Mail application will not work with latest version mac 4.5

    mail application will not work with latest version mac 4.5

    You can get Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

  • Load balancing across 4 web servers in same datacentre - advice please

    Hi All
    Im looking for some advice please
    The apps team have asked me about load balancing across some servers but im not that well up on it for applications
    Basically we have 4 apache web servers with about 2000 clients connecting to them, they would like to load balance connections to all these servers, they all need the same DNS name etc.
    what load balancing methods would I need for this, I believe they run on Linux
    Would I need some sort of device, or can the servers run some software that can do this, how would it work? and how would load balancing be achieved here?
    cheers

    Carl,
    What you have mentioned sounds very straightforward then everything should go well.
    The ACE is a load balancer which takes a load balancing decisions based on different matching methods like matching virtual address, url, source address, etc then once the load balance decision has been taken then the ACE will load balance the traffic based on the load balance method which you have configured (if you do not configure anything then it will use the default which is "round robin"), then it will send the traffic to the servers which it has available and finally the client should get the content.
    If you want to get some details about the load balancing methods here you have them:
    http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/overview.html#wp1000976
    For ACE deployments the most common designs are the following.
    Bridge Mode
    One Arm Mode
    Routed Mode
    Here you have a link for Bridge Mode and a sample for that:
    http://docwiki.cisco.com/wiki/Basic_Load_Balancing_Using_Bridged_Mode_on_the_Cisco_Application_Control_Engine_Configuration_Example
    Here you have a link for One Arm Mode and a sample for that:
    http://docwiki.cisco.com/wiki/Basic_Load_Balancing_Using_One_Arm_Mode_with_Source_NAT_on_the_Cisco_Application_Control_Engine_Configuration_Example
    Here you have a link for Routed Mode and a sample for that:
    http://docwiki.cisco.com/wiki/Basic_Load_Balancing_Using_Routed_Mode_on_the_Cisco_Application_Control_Engine_Configuration_Example
    Then as you could see in all those links you may end up having a configuration like this:
    interface vlan 40
      description "Default gateway of real servers"
      ip address 192.168.1.1 255.255.255.0
      service-policy input remote-access
      no shutdown
    ip route 0.0.0.0 0.0.0.0 172.16.1.1
    class-map match-all slb-vip
      2 match virtual-address 172.16.1.100 any
    policy-map multi-match client-vips
      class slb-vip
        loadbalance vip inservice
        loadbalance policy slb
    policy-map type loadbalance http first-match slb
      class class-default
        serverfarm web
    serverfarm host web
      rserver lnx1
        inservice
      rserver lnx2
        inservice
      rserver lnx3
        inservice
    rserver host lnx1
      ip address 192.168.1.11
      inservice
    rserver host lnx2
      ip address 192.168.1.12
      inservice
    rserver host lnx3
      ip address 192.168.1.13
      inservice
    Please mark it if it answered you question then other users can use it as reference in the future.
    Hope this helps!
    Jorge

  • Load balancing across multiple paths to Internet

    Hello,
    I have a 2821 router. Currently, I have two bonded T-1 circuits to the Internet.
    I would like to add a DSL circuit to augment the T1s. I would also like to load balance across all of the circuits. Currently, IOS performs inherent load balancing for the T1 circuits. The DSL circuit is from a different provider than the T1s.
    The T1s are coming from a local ISP that runs no routing protocols within their infrastructure. (They run static routes and rely on the upstream provider for BGP.) The DSL provider is a national telecom carrier.
    What is the best way to perform load balancing for this scenario?

    Here is the answer (sort of) for anyone reading this post with the same question:
    No matter which way I choose to do it, the trick is to have the local ISP subnet advertised via BGP through both pipes. The national telecom DSL provider will not advertise a /20 subnet down a DSL pipe. (Ahh, why not? =:)
    Had the secondary pipe been a T-1,T-3, or other traditional pipe, I could have used a load balancer like a BigIP, or FatPipe device or possibly CEF within the IOS.
    Case closed. Thanks to everyone that took a look.
    Doug.

  • Application is not working with mouse

    Dear All,
    We have a strange issue in the our application (Oracle form) in the one of our client machine.
    Some times the forms are not able to work with the mouse but is able to work with the keyboard. After one or two machine restart its again working. When the issue occur we can able to work in other applications using mouse.
    Our Applications server is in Other country and client are accessing from India.
    This occurs for some user and not for all.
    Application server Version          10.1.2.0.2.
    Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit
    Java Plug-in version 1.6.0_31 .
    Please any info will help us lot.

    Thank you for the quick replies Michael Ferrante and HamidHelal.
    But since its occurring for some users (perticulary indian users) and some times. And also its occurring in production environment not in development environment.
    Even the java control panel is not working with mouse.
    For other country customers everything working fine.
    So its difficult for me to apply the patch with these uncertainties.
    Checking with fresh java installation and let you know the status.
    Thanks.

  • MY WHATSAPP HAUTELOOK FACEBOOK APPLICATIONS ARE NOT WORKING WITH THE NEW UPDATE iOS 7 ITS DRIVING ME CRAZY! HOW CAN I FIX IT?

    I DOWNLOADED THE NEW UPDATED VERSION FOR THE IPHONE !!!
    AND MY APPLICATIONS ARE NOT WORKING AT ALL
    WHENEVER I ENTER TO WHATSAPP A MESSAGE POPS UP FROM NOWHERE SAYING SOMETHING ABOOUT PUSH UP NOTIFICATION!!
    AND THAT I SHOULD CONNECT IT TO ITUNES, THEN I CONNECT IT TO ITUNES AND ITUNES IS NOT LETTING ME SIGN IN WITH MY APPLE ID ITUNES IS NOT WORKING/!!!
    ALSO WHENEVER I OPEN HAUTELOOK APP ON THE IPHONE IS FREEZING MY PHONE WITH THE PUSH UP NOTIFICATION WINDOW, AND I CLICK OK AND IT STILL APPEARS OVER AND OVER AGAIN
    PLZ HELP ME!!!!!!!!!!!!!!!!!!!!!

    If you do not have enough space, then you would have to free up more space.
    You can also update via itunes on your computer.

  • 7.10 installation server, load balancing and multiple installation servers

    Hi
    In the 7.10 GUI installation server, there is no Load balancing option anamore, also there seems to be no option to easily clone the installation server from within the nwsapsetupadmin.exe program.
    If having MANY users at one location, and needing more than one installation server to accomodate the frontend installations, do you need to do this "manually" now ? grouping users and and the logon script directing different user groups to different sapgui installation servers ?
    what about creating multiple installation servers easily, is it possible to simply copy the installation server directory (c:\sapinst f.ex.) to another file server, share the directory and configure the DS and IS services (if needed) ??
    will configured packages and "on end install" scripts and such be copied too to the new installation server ?
    I need to easily create installation servers in 15 countries, this is the reason for my question...

    Hi Kim Sonny,
    hope you're doing fine
    Regarding your question:
    The "Load Balancing" was more a fail-over service and wasn't intended to use for several locations like in your case.
    So the easiest way to do this is to setup one installation server and copy the files to the other servers. On the new Installation servers you only have to setup the service again and that's it.
    Cheers,
    Martin

  • OSPF load balancing across multiple port channels

    I have googled/searched for this everywhere but haven't been able to find a solution. Forgive me if I leave something out but I will try to convey all relevant information. Hopefully someone can provide some insight and many thanks in advance.
    I have three switches (A, B, and C) that are all running OSPF and LACP port channelling among themselves on a production network. Each port channel interface contains two physical interfaces and trunks a single vlan (so a vlan connecting each switch over a port channel). OSPF is running on each vlan interface.
    Switch A - ME3600
    Switch B - 3550
    Switch C - 3560G
    This is just a small part of a much larger topology. This part forms a triangle, if you will, where A is the source and C is the destination. A and C connect directly via a port channel and are OSPF neighbors. A and B connect directly via a port channel and are OSPF neighbors. B and C connect directly via a port channel and are OSPF neighbors. Currently, all traffic from A to C traverses B. I would like to load balance traffic sourced from A with a destination of C on the direct link and on the links through B. If all traffic is passed through B, traffic is evenly split on the two interfaces on the port channel. If all traffic is pushed onto the direct A-C link, traffic is evenly balanced on the two interfaces on that port channel. If OSPF load balancing is configured on the two vlans from A (so A-C and A-B), the traffic is divided to each port channel but only one port on each port channel is utilized while the other one passes nothing. So half of each port channel remains unused. The port channel on B-C continues to load balance, evenly splitting the traffic received from half of the port channel from A.
    A and C port channel load balancing is configured for src-dst-ip. B is a 3550 and does not have this option, so it is set to src-mac.
    Relevant configuration:
    Switch A:
    interface Port-channel1
    description Link to B
     port-type nni
     switchport trunk allowed vlan 11
     switchport mode trunk
    interface Vlan11
     ip address x.x.x.134 255.255.255.254
    interface Port-channel3
    description Link to C
     port-type nni
     switchport trunk allowed vlan 10
     switchport mode trunk
    interface Vlan10
     ip address x.x.x.152 255.255.255.254
    Switch B:
    interface Port-channel1
     description Link to A
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 11
     switchport mode trunk
    interface Vlan11
     ip address x.x.x.135 255.255.255.254
    interface Port-channel2
     description Link to C
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 12
     switchport mode trunk
    interface Vlan12
     ip address x.x.x.186 255.255.255.254
    Switch C:
    interface Port-channel1
     description Link to B
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 12
     switchport mode trunk
    interface Vlan12
     ip address x.x.x.187 255.255.255.254
    interface Port-channel3
     description Link to A
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 10
     switchport mode trunk
    interface Vlan10
     ip address x.x.x.153 255.255.255.254

    This is more FYI. 10.82.4.0/24 is a subnet on switch C. The path to it is split across vlans 10 and 11 but once it hits the port channel interfaces only one side of each is chosen. I'd like to avoid creating more vlan interfaces but right now that appears to be the only way to load balance equally across the four interfaces out of switch A.
    ME3600#sh ip route 10.82.4.0
    Routing entry for 10.82.4.0/24
      Known via "ospf 1", distance 110, metric 154, type extern 1
      Last update from x.x.x.153 on Vlan10, 01:20:46 ago
      Routing Descriptor Blocks:
        x.x.x.153, from 10.82.15.1, 01:20:46 ago, via Vlan10
          Route metric is 154, traffic share count is 1
      * x.x.x.135, from 10.82.15.1, 01:20:46 ago, via Vlan11
          Route metric is 154, traffic share count is 1
    ME3600#sh ip cef 10.82.4.0
    10.82.4.0/24
      nexthop x.x.x.135 Vlan11
      nexthop x.x.x.153 Vlan10
    ME3600#sh ip cef 10.82.4.0 internal       
    10.82.4.0/24, epoch 0, RIB[I], refcount 5, per-destination sharing
    sources: RIB 
    ifnums:
    Vlan10(1157): x.x.x.153
    Vlan11(1192): x.x.x.135
    path 093DBC20, path list 0937412C, share 1/1, type attached nexthop, for IPv4
    nexthop x.x.x.135 Vlan11, adjacency IP adj out of Vlan11, addr x.x.x.135 08EE7560
    path 093DC204, path list 0937412C, share 1/1, type attached nexthop, for IPv4
    nexthop x.x.x.153 Vlan10, adjacency IP adj out of Vlan10, addr x.x.x.153 093A4E60
    output chain:
    loadinfo 088225C0, per-session, 2 choices, flags 0003, 88 locks
    flags: Per-session, for-rx-IPv4
    16 hash buckets             
    < 0 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 1 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 2 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 3 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 4 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 5 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 6 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 7 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 8 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 9 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    <10 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    <11 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    <12 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    <13 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    <14 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    <15 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    Subblocks:                                                                                  
    None

  • Load Balancing across Multiple DMZ's

    Can you split one Css11503 across two separate DMZ's securely. I have a group of server that are currently being load balanced in one DMZ I now have a requirement to Load balance another set of server in another DMZ is it possible spilt the CSS across two DMZ's and still maintain a high level of Security

    You need a separate CSS for each interface of the firewall.
    If you use the same CSS for 2 DMZ, traffic inter DMZ will be routed by CSS and will bypass the firewall.
    Gilles.

  • Application installer not working with PC Suit App...

    I have a Nokia E60 and Windows XP SP2. After installing PC Suite 6.82.96.4 I try to open the App. installer but it opens and closes inmediately (blinks) but do not work. I try to do the installation through the File manager, and I can see and open the Nokia browser, phone memory etc, but whenever I try to install, the following message is shown Nokia Application Installer has encountered a problem and needs to close. We are sorry for the inconvenience. Detail is: Error signature AppName: applicationinstaller.exe AppVer: 6.82.96.4 ModName: unknown ModVer: 0.0.0.0 Offset: 90909090 It also shows that there is an error report that I cannot find C:\DOCUME~1\rodrigm3\LOCALS~1\Temp\9e61_appcompat.txt Could you please help me to fix the problem? thanks a lot

    Regarding my problem, I attach the log file generated in the error report in case it can help to the Nokia support (or anybody able to help...) It should have to be a PC config problem, as I am totally able to install application with the same version of PC Suite in other colleagues PCs Thanks for your support....
    Attachments:
    42cb_appcompat.txt ‏63 KB

  • Application Alias not working with Global Single Sig on

    I have a intranet applications, with login against https://login.oracle.com that is working fine. However, when I try to use the Application Alias, defined on Applications Attributes, it's not working, redirecting to an invalid page:
    https://htmldb.oraclecorp.com/pls/htmldb/-PORTAL_SSO-
    How can I make this work, I mean, using alias, instead of applications number?
    Thanks in advance,
    Andre Silveira

    Andre,
    Assuming your application's ID is 9999 and its alias is AAAA, you may be finding that a request like f?p=9999 and f?p=AAAA produce the same results, those you described. When using SSO as the authentication scheme, it's necessary to provide the page ID or page alias in the URL also, e.g, f?p=AAAA:PPPP or f?p=AAAA:1.
    Scott

  • C3 - Multiple Selection is not working with pencil...

    Hello Guys,
    Pencil key is not working for multiple selection while ctrl key is working.
    Can any1 guide me how to do muliple selection......

    There was an issue with messaging in the original software on the C3, so make sure that you are up-to-date. To check your software version try *#0000#
    Latest software release for Nokia C3-00 is 08.63
    Your service provider may not have the latest nokia version available, but make sure you have the most recent you can get.
    Menu > Settings > Phone> Phone Updates > Downl. phone software

  • Application services not working with MS Word 2004

    for some reason, application services with MS Word 2004 no longer work with Leopard for me (all grayed out). I would appreciate any advice
    thanks,
    bill

    Bill
    Because Word 2004 doesn't support Services. Firefox is another app that doesn't.
    Regards
    TD

Maybe you are looking for

  • File to Multiple Idocs, Error: Tag MESSAGE1 found instead of tag IDOC BEGIN

    Hi, I have configured my file to multiple idocs scenario using the following blog - /people/claus.wallacher/blog/2006/06/29/message-splitting-using-the-graphical-mapping-tool Now when i try to execute this scenario it is scenario it is giving me the

  • Trying to open Places freezes Aperture

    I am not able to open Places. Each time I click the icon I get the color wheel of death, after a while I have to Force Quit the program. There are about 6000 photos contained in Aperture, but almost 90% of that number is stored on a separate HDD and

  • Java Compiler API Status?

    Does anyone know what the current status of JSR 199: Java Compiler API is? (http://www.jcp.org/en/jsr/detail?id=199) To me it seems the inclusion in JDK 1.5 was silently dropped. I have not found the smallest bit of information, though.

  • Using the "Convert higher bit rate songs to 128 kbps AAC" feature...

    I recently discovered the "Convert higher bit rate songs to 128 kbps AAC" feature and used it to copy my entire 70 GB music library to my 64GB iPad. The music library now occupies only 45 GB. Awesome!!! Unfortunately, the whole process took well over

  • Offline applications with Flex?

    On the Data Services wiki page, under the heading "Enabling the Next Generation of RIA" -> OCC subheading, it says "Flex Data Services manages the communication between the application and the server, even if the application is not reliably online. M