Lost reference of main controller within popup

Dear all,
Within my application, I need to launch a popup to display some datas by using some attributes of my main controller. But when I launch the popupcontroller, I'm not able to retrieve the reference to my main controller inside the do_request of the popupcontroller. Does someone have a clue on it? Thanks..

Hi William,
when a popup is opened the controller which renders it will not have a reference to any other controllers because it is a complete new controller which was not created by a parent controller (you are opening the popup via javascript, right?).
So you have three options:
1)like Sergio suggested create an class with public static attributes which can be accessed from both controllers.
2)Create an application class because every controller has automatically a reference to this class (search for application class in the forum there are lots of hints how to do it). 
3)Transfer information to the popup controller so that it can read the data which it should display by itself. For example call the popup like this: materialpopup.do?displaymaterialnumber=12345
regards
Thomas
Message was edited by: Thomas Ritter

Similar Messages

  • How to use application class reference in the controller methods of BSP

    Hi,
    I have created a bsp application and also created an application class and assigned it to the application class. In the application class, I have created attribute TEXT type string(public and instance parameter).
    In the controller let's say main.do, I am trying to give a value to to the text by adding the following code.
    application->text = 'test'.
    I am getting syntax error saying field 'text' is unknown. It is not contained in one of the specified tables nor defined by DATA statement. 
    Please can someone let me know how to use the application class in the coding with an example. I couldn't find how exactly this has to be reference. Please help.
    Best regards
    Siva

    Hi,
    if you are having main controller and sub-controller then you may need to use below coding to use application class reference.
    *Data declaration
      DATA:  obj_cntrl        TYPE REF TO cl_bsp_controller2,
             obj_sub_cntrl   TYPE REF TO z_cl_sub_cntl,
             application TYPE REF TO z_cl_application.
    *Get the controller
      CALL METHOD obj_main_cntrl->get_controller   "obj_main_cntrl is the object of main controller
        EXPORTING
          controller_id       = 'SUB'   "Controller ID
        RECEIVING
          controller_instance = obj_cntrl  .
      obj_sub_cntrl ?= obj_cntrl  .
      application ?= obj_sub_cntrl ->application.
    or simply use below code in your controller method.
      application ?= me->application.
    Thnaks,
    Chandra

  • Cisco 877w -Configuration of subinterfaces and main interface within the same bridge group is not permitted

    Hi,
    I have another problem - after upgrade ios wirelles connection not work.
    After reload i have :
    Configuration of subinterfaces and main interface
    within the same bridge group is not permitted
    STP: Unable to get the port parameters.
    Please configure the bridge group on this interface first.
    Please configure the bridge group on this interface first.
    Please configure the bridge group on this interface first.
    SETUP: new interface NVI0 placed in "shutdown" state
    my old configuration work propertly in the old software, but after update i have notificatio.
    Old thread:
    https://supportforums.cisco.com/discussion/12379491/cisco-877w-no-wireless-connection
    my current sh run:
    version 12.4 
    no service pad 
    service tcp-keepalives-in 
    service tcp-keepalives-out 
    service timestamps debug datetime msec localtime 
    service timestamps log datetime msec localtime 
    service password-encryption 
    hostname cisco 
    boot-start-marker 
    boot system flash:c870-advipservicesk9-mz.124-24.T6.bin 
    boot-end-marker 
    logging message-counter syslog 
    logging buffered 4096 informational 
    enable secret 5 $1$eCNp$rWuBfZ/cexnwnkm7L447s. 
    aaa new-model 
    aaa session-id common 
    dot11 syslog 
    dot11 ssid ciscowifi 
     vlan 1 
     authentication open 
     authentication key-management wpa 
     guest-mode 
     wpa-psk ascii 7 050D031D26595D0617 
    dot11 wpa handshake timeout 500 
    ip source-route 
    no ip dhcp use vrf connected 
    ip dhcp excluded-address 192.168.56.1 
    ip dhcp pool CLIENT 
       import all 
       network 192.168.56.0 255.255.255.0 
       default-router 192.168.56.1 
       dns-server 8.8.8.8 194.204.159.1 194.204.152.34 
       lease 0 2 
    ip cef 
    no ip domain lookup 
    no ipv6 cef 
    multilink bundle-name authenticated 
    username marek password 7 00121A0908500A 
    archive 
     log config 
      hidekeys 
    ip tcp path-mtu-discovery 
    bridge irb 
    interface ATM0 
     description Polaczenie ADSL do ISP$ES_WAN$ 
     no ip address 
     no atm ilmi-keepalive 
     pvc 0/35 
      encapsulation aal5mux ppp dialer 
      dialer pool-member 1 
     hold-queue 224 in 
    interface FastEthernet0 
     description Edzia 
    interface FastEthernet1 
     description dom 
    interface FastEthernet2 
     description Dziadek 
    interface FastEthernet3 
    interface Dot11Radio0 
     no ip address 
     no ip redirects 
     ip local-proxy-arp 
     ip nat inside 
     ip virtual-reassembly 
     no dot11 extension aironet 
     encryption vlan 1 mode ciphers tkip 
     encryption mode ciphers aes-ccm tkip 
     broadcast-key change 3600 
     ssid ciscowifi 
     speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0 
     station-role root 
     world-mode dot11d country AU indoor 
     no cdp enable 
     bridge-group 1 
     bridge-group 1 subscriber-loop-control 
     bridge-group 1 spanning-disabled 
     bridge-group 1 block-unknown-source 
     no bridge-group 1 source-learning 
     no bridge-group 1 unicast-flooding 
    interface Dot11Radio0.1 
     description ciscowifi 
     encapsulation dot1Q 1 native 
     no cdp enable 
    interface Vlan1 
     no ip address 
     bridge-group 1 
    interface Dialer0 
     description Interfejs dzwoniacy 
     ip address negotiated 
     ip nat outside 
     ip virtual-reassembly 
     encapsulation ppp 
     dialer pool 1 
     dialer-group 1 
     ppp chap hostname [email protected] 
     ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxx 
    interface BVI1 
     description Polaczenie dla sieci LAN 
     ip address 192.168.56.1 255.255.255.0 
     ip nat inside 
     ip virtual-reassembly 
    no ip forward-protocol nd 
    ip route 0.0.0.0 0.0.0.0 Dialer0 
    no ip http server 
    no ip http secure-server 
    ip nat inside source list 100 interface Dialer0 overload 
    ip nat inside source static tcp 192.168.56.10 80 interface Dialer0 80 
    ip nat inside source static tcp 192.168.56.10 22 interface Dialer0 22 
    logging trap debugging 
    logging 192.168.56.10 
    access-list 100 permit ip 192.168.56.0 0.0.0.255 any 
    access-list 100 deny   ip any any 
    no cdp run 
    snmp-server community ciskacz RO 
    snmp-server chassis-id ciskacz 
    control-plane 
    bridge 1 protocol ieee 
    bridge 1 route ip 
    line con 0 
     no modem enable 
    line aux 0 
    line vty 0 4 
     exec-timeout 0 0 
     transport preferred ssh 
     transport input ssh 
    scheduler max-task-time 5000 
    end 
    please help - thanks!

    Hello Marek,
    I suppose you are not planning to do any kinds of advanced config using several VLANs and multiple SSIDs so let's just make your configuration simple and working.
    In short, you need to remove all references to VLAN 1 and to any subinterfaces possibly related to the VLAN 1. This means in particular (follow these steps in sequence):
    Remove the Dot11Radio0.1 subinterface entirely
    In the Dot11Radio0 section, remove the encryption vlan 1 mode ciphers tkip command
    In the dot11 ssid ciscowifi section, remove the vlan 1 command
    After performing these steps, make sure that the ssid ciscowifi and encryption mode commands are still present in the Dot11Radio0 configuration, and if not, reenter them.
    Best regards,
    Peter

  • How can i reference a MIME object within a correspondence format through...

    how can i reference a MIME object within a correspondence format through TX oofo or se71?
    Hi, I need to put a MIME object within a correspondence's format that i've already done through Tx oofo. My problem is, that i don't know exactly how can i make the reference of that MIME object in the format? and What structure type do i have to use in order to make appear the MIME object in my correspondence's format? Does anybody can help me with this?   
    Regards    Hector

    Frank,
    I tried to find some examples/samples on how to create CollectionModel for a table component but not successful.
    Can you clarify the following ?
    1. "CollectionModel" is referenced only by af:table attributes "value", "selectedRowKeys" and "selectionListener".
    The rest of af:table attributes such as "rows", "fetchSize" used to reference the iterator binding in the binding container via the EL expression "#{bindings.VOIteratorBinding.xxx} .
    What should I replace that EL expression with?
    2. I heck out the bean method to create the CollectionModel as following, is it close to what you mean?
    public void initBusinessDataDashboardView() {
    OperationBinding operation = BeanUtils.getOperationBinding("getPanelBusinessData");
    Map params = operation.getParamsMap();
    Key panelKey = getPanelInfoView().getKey();
    params.put("panelKey", panelKey);
    params.put("maximizedView", false);
    panelView = (ViewObject)operation.execute();
    // Heck code to create CollectionModel
    RowSet rowSet = panelView.getRowSet();
    ArrayList rowList = new ArrayList();
    while (rowSet.hasNext()) {
    rowList.add(rowSet.next());
    model = new ChildPropertyTreeModel(rowList, null);
    // To be used to set up af:table value, selectRowKeys, selectionListener via EL expr #{backingBeanScope.MyBean.model.xxx}
    public CollectionModel getModel() {
    return model;
    Am I on the right track?
    Edited by: Pricilla on May 4, 2010 2:20 PM

  • Delivery without reference for stock transfer within the same plant 311

    Dear all,
    I need to create a delivery without reference for stock transfer within the same plant, movement 311,  i.e. just from 1 storage location to another storage location.
    I tried to use VL01NO with delivery type UL.
    Now my question is how can I assign a receiving plant for a customer?
    I can't do the MIGO or MB1B document because I need the delivery document (packing list, forms, Texts,...).
    It's possible this option???
    Thank you very much.

    Hi,
    What is the item category you are assigning while doing VL01NO?  Check the schedule line category for that item category assignment.  That Schedule line category has an option for one step GI.  There you can assign 311 or create a separate item category and schedule line category and in that SC assign 311. 
    Thanks
    Krish.

  • BAPI's for creation of sub Contract with reference to main contract

    Hi,
    Can any body tell me the available bapi for the creation zlsl contract with reference to main contract zgsl
    Regards
    Rajkumar

    1.Logistics--Materials Management--Purchasing ---Purchase Requisition --Follow-on functions --- Assign and Process
    2.ME57
    3.Select the Assigned Purchase Requisitions checkbox if you also want to see requisitions already assigned, and choose Execute.
    4.On the Assign and Process Purchase Requisitions screen, select the requisition lines for your material.
    5.Choose Assign Manually if the info record already exists.
    6.On the pop-up Assign Source of Supply Manually dialog box, make the following entries:
    Agreement     46XXXXX            Agmt item     10          
    7.Choose Assign Source of Supply.
    For assign the source of supply, you can also choose Assign Automatically (only if not already assigned by MRP due to existing source list). If more than one source exists, select the contract in the Source Overview for Purchase Requisition 100XXXXX window and confirm with Enter.
    When assigning a source, make sure to select the contract.
    8.Choose Save.
    9.Select the line item, and then choose Assignments Overview (SHIFT+F5).
    10.On the Assign and Process Requisitions: Overview of Assignments screen, select the line below Vendor (you can only select one at a time), then choose Process Assignment.
    11.On the Process Assignment: Create PO window, check and make sure the Order Type (NB), Purchasing Group and Purch. Organization fields then choose Continue (Enter) to confirm.
    12.On the Create Purchase Order screen, select the requisition in the Document Overview section and choose Adopt in the left part of the Document Overview screen.
    13.Choose Save.

  • DGCserver messages in log... "Tried to renew lease on lost reference"

    Hi,
              I am running weblogic server 6.1 and get the following messages
              ####<Jan 30, 2002 2:36:55 PM CST> <Info> <DGCserver> <MBarton> <myserver> <ExecuteThread: '12' for queue: 'default'> <> <> <000000> <Tried to renew lease on lost reference: '706'>
              I have seen in the newsgroup that this was a problem previously in version 4.5.1
              any help would be appreciated.
              best regards,
              Mickey
              

              This shouldn't cause any problems. Does it? We will turn off these info messages.
              Cheers,
              -- Prasad
              Mickey Barton <[email protected]> wrote:
              >Hi,
              >I am running weblogic server 6.1 and get the following messages
              >
              >####<Jan 30, 2002 2:36:55 PM CST> <Info> <DGCserver> <MBarton> <myserver>
              ><ExecuteThread: '12' for queue: 'default'> <> <> <000000> <Tried to
              >renew lease on lost reference: '706'>
              >
              >I have seen in the newsgroup that this was a problem previously in version
              >4.5.1
              >
              >any help would be appreciated.
              >
              >best regards,
              >Mickey
              

  • Lost reference in cluster

              Our app is deployed as cluster (two instances), recently we saw some errors as
              below. What's the cause of it, is it critical? Since it's labeled as 'info", should
              we just ignore it?
              Thanks in advance.
              ####<Apr 7, 2003 4:39:33 PM GMT+00:00> <Info> <DGCserver> <our url address> <m0034-instance1>
              <ExecuteThread: '34' for queue: 'default'> <> <> <000000> <tried to renew lease
              for 1 lost reference(s).>
              ####<Apr 7, 2003 4:40:32 PM GMT+00:00> <Info> <DGCserver> <our url address> <m0034-instance1>
              <ExecuteThread: '34' for queue: 'default'> <> <> <000000> <tried to renew lease
              for 1 lost reference(s).>
              

              Our app is deployed as cluster (two instances), recently we saw some errors as
              below. What's the cause of it, is it critical? Since it's labeled as 'info", should
              we just ignore it?
              Thanks in advance.
              ####<Apr 7, 2003 4:39:33 PM GMT+00:00> <Info> <DGCserver> <our url address> <m0034-instance1>
              <ExecuteThread: '34' for queue: 'default'> <> <> <000000> <tried to renew lease
              for 1 lost reference(s).>
              ####<Apr 7, 2003 4:40:32 PM GMT+00:00> <Info> <DGCserver> <our url address> <m0034-instance1>
              <ExecuteThread: '34' for queue: 'default'> <> <> <000000> <tried to renew lease
              for 1 lost reference(s).>
              

  • Tried to renew lease for lost reference

    Hi
    Oracle sessions get stuck on parsing all sessions accessing the same object wait
    on "library cache pin".
    We found one session coming from jdbc client waiting on "SQLNET message from client"
    and holding all the rest sessions.
    When we kill this session the problem resolves.
    Following the port holding session with netstat, lsof and so on back to the jdbc
    client side on different machine we only see error message connected to the same
    port saying "tried to renew lease for lost reference". Our assumption is that
    oracle lost connection with the client while locking a DB object when was doing
    parsing and thus locked all sessions that wanted to access same object.
    Did anybody encounter the same problem? How was resolved?
    Thanks.

    "Rich Kolkmeier" <[email protected]> wrote in message
    news:3a366798$[email protected]..
    In testing the cluster failover capability, I disconnected the
    network cable from one of the servers I was running in a cluster.
    The system failed over properly. When I reattached the network
    cable, the system added the server back into the cluster. However,
    I continue to get the following message:
    Tue Dec 12 17:34:51 GMT 2000:<I> <DGCserver> tried to renew lease
    for 1 lost references
    (s).
    What is the cause of this message? What needs to be done to clean
    up the cluster?Rich,
    This message is printed when one WebLogic kernel tries to renew a lease for
    an remote object from another WebLogic which has already been collected. It
    makes sense that this might happen in the failure scenario you describe.
    When the network is disconnected DGC lease renewals can't be sent and the
    kernel exporting the object may therefore believe that the object is no
    longer in use and collect it. When the network is re-established the remote
    objects may be gone.
    However the fact that you are seeing this message printed repeatedly is
    troubling. You may want to contact [email protected] with the
    description you provided here along with the following additional
    information.
    Are you seeing this message on the client or server? If on the server is it
    on the server that was disconnected or on one of the other servers? What
    version (including service packs) of WebLogic are you running?
    Regards,
    Adam Messinger

  • Tried to renew lease on lost reference

    Hi all,
    Can anyone pls help me with the following issue?
    I have encountered the following message.
    <ExecuteThread: '3' for queue: 'default'> <> <> <000000> <Tried to renew lease
    on lost reference: '388'>
    After a while, the following message will appear.
    <ExecuteThread: '15' for queue: 'default'> <> <> <000000> <Unsolicited error response
    for: '-1'>
    This shows the threads in the server are all used up.
    I will like to know the cause for the first message to appear and how to prevent
    it. Whenever this message appears, it is telling us the server is going to hang
    soon. We have no idea how to fix this problem. Can anyone help? Thanks.

    I know the "tried to renew lease..." message you were getting was just some INFO
    message that the server sent out. I believe this message has been surpressed
    in Weblogic 6.1 SP3.
    Not sure if the other message is part of that. I've been running with the service
    pack for so long that I don't remember. :)
    "apple" <[email protected]> wrote:
    >
    Hi all,
    Can anyone pls help me with the following issue?
    I have encountered the following message.
    <ExecuteThread: '3' for queue: 'default'> <> <> <000000> <Tried to renew
    lease
    on lost reference: '388'>
    After a while, the following message will appear.
    <ExecuteThread: '15' for queue: 'default'> <> <> <000000> <Unsolicited
    error response
    for: '-1'>
    This shows the threads in the server are all used up.
    I will like to know the cause for the first message to appear and how
    to prevent
    it. Whenever this message appears, it is telling us the server is going
    to hang
    soon. We have no idea how to fix this problem. Can anyone help? Thanks.

  • Tried to renew lease on lost reference in logs.

              I am using Weblogic 6.1 SP1 with 2 cluster configuration. I am seeing a lot of
              "Tried to renew lease on lost reference" msgs in my logs. These msgs seems to
              be logged almost every minute.
              I would like to know what does this msg mean and how would I elimiate this msg
              from my logs.
              Any help will be appreciated.
              Thanks
              Albert
              

    I am relatively sure it has to do with RMI and distributed "garbage
              collection", so it may be related to some of your replicated JNDI entries.
              The other question is what is causing the problem in the first place. Are
              your servers under intense load or are the exec threads getting saturated
              (whether or not the other resources like CPU are saturated)?
              As far as the low-level RMI implementation, I know that Weblogic has its own
              implementation for significant portions of RMI, but I don't know much about
              the implementation, so it is hard to guess. You may be able to get some
              additional pointers from Prasad Peddada[[email protected]].
              Peace,
              Cameron Purdy
              Tangosol Inc.
              Tangosol Coherence: Clustered Coherent Cache for J2EE
              Information at http://www.tangosol.com/
              "Albert" <[email protected]> wrote in message
              news:[email protected]...
              >
              > Cameron,
              >
              > My application doesn't have any EJB's. It is a JSP/Servlet/Oracle based
              application.
              > Do you think of anything in this context.
              >
              > Thanks
              > Albert
              >
              > "Cameron Purdy" <[email protected]> wrote:
              > >Do you use stateful session EJBs? Make sure you remove them when done.
              > >
              > >Peace,
              > >
              > >--
              > >Cameron Purdy
              > >Tangosol Inc.
              > >Tangosol Coherence: Clustered Coherent Cache for J2EE
              > >Information at http://www.tangosol.com/
              > >
              > >
              > >"Albert" <[email protected]> wrote in message
              > >news:[email protected]...
              > >>
              > >> I am using Weblogic 6.1 SP1 with 2 cluster configuration. I am seeing
              > >a
              > >lot of
              > >> "Tried to renew lease on lost reference" msgs in my logs. These msgs
              > >seems
              > >to
              > >> be logged almost every minute.
              > >> I would like to know what does this msg mean and how would I elimiate
              > >this
              > >msg
              > >> from my logs.
              > >> Any help will be appreciated.
              > >>
              > >> Thanks
              > >> Albert
              > >>
              > >
              > >
              >
              

  • How to pass control from main controller to sub controller?

    Hi Experts,
    I have created one controller named "available.do" by which I am calling a view "available.htm". On that view I am showing one Button which says Check Availability. On clicking of this button it shows another view "list.htm". But it is showing new view and old view on same page.
    Second I want to add one button on second view "list.htm" which should perform some function. I don't know how I can achieve this functionality?
    Someone has suggested me that for this I have to create sub controller...but i don't know much about it as I am new in BSP.
    Kindly tell me and paste code so that I can solve my both problems.
    <<Text removed>>
    Thanks in Anticipation,
    Virendra Kedia
    Edited by: Matt on Oct 15, 2011 7:25 AM

    Hi,
    I guess you might have below coding in DO_INIT method,
    me->view_main = 'main.htm'.   "Where VIEW_MAIN is the attribute in you main controller of type STRING.
    you should have below coding in DO_REQUEST of main controller.
    DATA: main TYPE REF TO if_bsp_page.
      me->dispatch_input( ).
    *Create main view.
      main = create_view( view_name = me->view_main ).
    *Set desgin attribute.
      main->set_attribute( name = 'design' value = application->design ).
    *Call main page views.
      call_view( main ).
    *Activate  Sub -controller.
      controller_set_active( controller_id = 'sub_cntrl' active = lc_active ). 
      l_cntl_inst ?= get_controller( controller_id = lv_cntl_id ).  "DATA: l_cntl_inst TYPE REF TO cl_bsp_controller.
    *Call sub-controller.
      call_controller( l_cntl_inst ).
    Please check with this.
    Thanks,
    Chandra

  • Ambiguous reference to Main

    I built a custom control based off Canvas, when I try to drop it into my Main.mxml code I get this cryptic error:
    Ambiguous reference to Main. [Generated code (use -keep to save): Path: Main-generated.as, Line: 1110, Column: 10]                               
    I’ve googled the error and everything on it seems to suggest that it is caused when you have two functions with the same name in the same namespace and Flex doesn’t know which one you mean, but I’ve renamed all my variables/functions in the custom class to really cryptic names to eliminate this possibility. I've also seen this error reported for classes that have properties with different access modifiers on their getter vs. setter but all my gets/sets are public. This is really driving me crazy, any help appreciated

    Can you post any of your code? Or any of the generated code?

  • Main Controller Id

    I have in a BSP application several controllers, despite I have one of them as the "Main" controller(the application starts from there) any of the others have been defined as subcontrollers in DO_INIT method of "Main", how can I get the Id of the other controllers?.

    Ruben, you'll have to forgive us we don't seem to be understanding what it is your asking.
    header_ctr ?= create_controller(
            controller_name  = 'header.do'
            controller_id    = 'hd' ). 
    <bsp:call comp_id = "hd"         
               url     = "header.do" />
    In both cases the controller is called "hd", in your main controller you call dispatch_input() in your DO_REQUEST then in each controller you can process the data available under DO_REQUESTR or DO_HANDLE_EVENT. If the data is from a subcontroller and is an inputfield called "sid" then it would be available with the name "hd_sid" as the subcontroller name is appended to the front of the form element name then you just get the value of that form element.
    So now that we've all shot around in the dark how about you given us a bit more info on what you are trying to do and then we can get more specific.

  • [svn:cairngorm3:] 17872: Popup: Exposed set accessor of open for view state usage and fixed bug when closing from model within popup .

    Revision: 17872
    Revision: 17872
    Author:   [email protected]
    Date:     2010-09-27 08:04:40 -0700 (Mon, 27 Sep 2010)
    Log Message:
    Popup: Exposed set accessor of open for view state usage and fixed bug when closing from model within popup. http://www.spicefactory.org/forum/viewtopic.php?p=3932. Added new sample to show model and view state interactions.
    Modified Paths:
        cairngorm3/trunk/libraries/Popup/src/com/adobe/cairngorm/popup/PopUpBase.as
        cairngorm3/trunk/libraries/Popup/src/com/adobe/cairngorm/popup/PopUpFactory.as
        cairngorm3/trunk/libraries/Popup/src/com/adobe/cairngorm/popup/PopUpWrapper.as
        cairngorm3/trunk/libraries/PopupTest/.actionScriptProperties
        cairngorm3/trunk/libraries/PopupTest/src/samples/MyPopup.mxml
        cairngorm3/trunk/libraries/PopupTest/src/samples/PopUpPM.as
    Added Paths:
        cairngorm3/trunk/libraries/PopupTest/src/PopUpModelExample.mxml
        cairngorm3/trunk/libraries/PopupTest/src/samples/MyPopupWithModel.mxml

    Lots to be excited about. BUT...Just updated to 8.1 on one of my computers to test it out...
    Sadly, the following issue is NOT fixed for me. Is it with new projects only?  I haven't started a new project on 8.1 I've only opened an old project but the issue that I'm referring to which involves also a delay/freeze of anywhere from a few seconds to a MINUTE while the render bar goes from yellow to red and then back to yellow is still there. Boo.
    On the list above...
    Switching between sequences can turn the render bar red.
    This issue is incredibly easy to replicate. I really do hope it gets fixed. Here are the steps:
    1) Create two sequences with multiple short clips (the more clips the better)
    2) Make sure GPU acceleration is enabled.
    3) Add warp stabilizer to the clips in both sequences. Again, the more clips the longer the delay/freeze will be as the render bar goes from YELLOW to RED and then eventually back to YELLOW again.
    4) Hit SAVE.
    5) Now, toggle between sequences. You'll hit a short delay with a few clips stabilized and a LONG delay with lots stabilized. In my case this delay is around a full minute. The render bar will go from YELLOW to RED and then back to yellow...eventually.
    6) Toggle back to the original sequence and the delay occurs again.
    7) Once you've toggled between sequences and have gone through this delay, that's it, there is no longer a delay...UNTIL...(and here's the big kicker)...until the project is SAVED again. After that the issue returns when you toggle between sequences. Both saving manually and AUTOSAVING cause this issue. No way around it except not editing with GPU acceleration.
    Not sure what the issue is...caching issue when saving maybe? Either way, it stinks and it's still there in 8.1. Big bummer.
    Again, lots to be excited about with this release but I really was hopefully this specific issue was resolved.
    Sigh.

Maybe you are looking for