Multiple webservices in 1servlet context

Hi,
I have approx 8 jcds in a project.
1 connectivity map with 1 external ws/soap external system, which is linked to all the jcds.
Deployed ok - no errors at all.
However, it seems that i cannot call 7 of the web services. The last one (alphabettically, and im assuming last one deployed) is the only one i can call, the others do not seem to be recognized.
The WSDLs are created fine, but when called, the logical host does not recognize the operation.
Does this mean that i will have to create another 7 external soap/http systems and have 7 different servlet contexts, or am i missing something really simple here?
Weemort

1 "New Web Service" JCD exposed as a web service = 1 SOAP Server Exernal. Each JCD is an independent web service with its own "servlet context". Servlet context is set in teh SOAP Server external ergo each JCD needs a distinct external to be a distinct service.
Why not use a multi-operation WSDL to create an eInsight-based service implementation is you need a single servlet context for multiple pieces of funcitonality?

Similar Messages

  • Transaction Locking during multiple Webservice - persistent webs sessions

    Hi All,<br>
    <br>
    Yesterday evening we had a discussion concerning ESA architecture. We want to create (web)services for accessing the SAP business objects (using XI) and use these (web)services via visual composer, webdynpro or custom java development.<br>
    <br>
    It does not seem a big problem to perform creations and reads of transaction, but when we want to change objects, we saw some problems concerning locking/commiting and rollbacks.<br>
    <br>
    From our GUI we would like to be able to go in edit mode and from that moment on, the transaction should be locked. We then want to change certain parameters and commit only when we push the save button.<br>
    <br>
    We can invoke a webservice wich tries to lock the transaction, but at the moment the XI scenario is completed (=the lock is created), the program at SAP side (=proxy in our case) is also finished and the lock is automaticly removed. How can we do locking, when using webservices via XI?<br>
    <br>
    The problem of the rollback and commit we can partially solve by putting more logic in the GUI, but we don't want to do that. How can we do a change of a business object and remember this change without doing a commit on the SAP system.... . Same problem for the rollback.<br>
    <br>
    Is there a away to keep a session "alive" during multiple webservice calls or to simulate it? Every webservice invokation happens in a different context...isn't it?<br>
    <br>
    <br>
    <b>Just to make it a bit more clear.</b><br>
    <br>
    Suppose we create 6 service related to the business object bupa (business partner).<br>
    - read<br>
    - change<br>
    - commit<br>
    - rollback<br>
    - lock<br>
    - unlock.<br>
    <br>
    We create a GUI which uses these services.<br>
    <br>
    <b>Step1:</b> we want to see bupa in detail, so the read webservice is called and the retrieved details are shown in the GUI<br>
    <b>Step2:</b> we want to go in edit mode, so the lock webservice is called to lock the bupa. The bupa should stay locked, untill the unlock is called. Here occurs the problem. The webservice lock is called, XI will trigger the proxy on the SAP system. This proxy will lock the bupa. As soon as the proxy-program is completed, the bupa lock will automaticly be removed ... . We want to keep this lock!<br>
    <b>Step3:</b> we change the bupa using the change webservice. Only the user who locked the bupa should be able to change it.<br>
    Problem concerning the locking occurs: standard we don't know who locked the bupa (this is done by the generic RFC user, configured in sm59). Should we pass some kind of GUID towards the proxy and build some additional logic to know which end-user in fact locked it... . Using the userid isn't sufficient, because a user could logon multiple time simultanously.<br>
    <br>
    Another problem is that we want to change the bupa, without having to do a commit yet.De commit should be called only when pushing the save button. When the proxy is ended and we did not do a commit, the changes are lost normally ... .<br>
    <br>
    What we in fact want to do is Simulate the bsp behaviour.<br>
    <b>Step4:</b>We want to perform a save of the things we changed or a reset. This means the commit or rollback webservice is called.<br>
    <b>Step5:</b> We want to unlock the bupa by calling the unlock webservice.<br>
    <br>
    <br>
    Please give me your comments.<br>
    <br>
    Kind regards<br>
    Joris<br>
    <br>
    Note: Transaction Locking during multiple Webservice "sessions".
    Message was edited by:
            Joris Verberckmoes

    There are multiple strategies how to resolve this. They require that the last change time is available in the changed object, and also that the client keeps the value of the change time when it read the data.
    1. First one wins
    Immediately before posting the changes, the current change time is read from the server. In case it is different from the client buffer, then the client changes are discarted.
    Example:
    1. Client A reads data
    2. Client B reads data
    3. Client B changes its buffer
    4. Client B checks if server change time has changed (result is no)
    5. Client B writes his changes to the server
    6. Client A changes its buffer
    7. Client A checks if server change time has changed (result is yes)
    8. Client A discarts its changes
    2. Last one wins
    Easy. Client just writes his changes to the server, overwriting any changes that might have occured since it read the data.
    Example:
    1. Client A reads data
    2. Client B reads data
    3. Client B changes its buffer
    4. Client B writes his changes to the server
    5. Client A changes its buffer
    6. Client A writes its changes to the server -> changes from client B are lost
    3. Everybody wins
    Most complicated. In case of concurrent changes, the client is responsible for merging his changes with the changes from other clients and to resolve any conflicts.
    Example:
    1. Client A reads data
    2. Client B reads data
    3. Client B changes its buffer
    4. Client B checks if server change time has changed (result is no)
    5. Client B writes his changes to the server
    6. Client A changes its buffer
    7. Client A checks if server change time has changed (result is yes)
    8. Client A merges its changes with changes from client B
    9. Client A writes his changes to the server
    "Last one wins" is definitely not water-proof. But even with the other strategies, data can potentially get lost in the short timeframe when the change time is checked and the actual update.
    To make it more secure, server support is required. E.g. the client could pass the change time from its read access to the server. The server can then reliably reject the update if the change data has been updated in beetween by another client.

  • Multiple Subinterfaces on same context.

    Hi,
    I'm having a difficult time finding examples where there is a multi-context ASA using multiple subinterfaces under the contexts. I'm running 5585-X SSP-10 in my network.
    We have a license for 20 contexts, currently only using a quarter of those context. Issue is, the way they set this up was only one subinterface per context, and that's how they want to keep.
    I'm already charged with adding three new vlans to our firewall for migrating some devices off our old network to our new one. Issue is if we keep doing that we're going to burn through all these contexts in no time.
    I'm assuming you can have multiple vlans going to the same context with multiple subinterfaces. That being said, I would assume you can block the traffic from two vlans on the same context from each other.
    Can anyone link me to some configuration examples for multiple subinterfaces, and an example of what the access rules on the same context might look like for two vlans with different subnets?
    Thanks.

    I feel you are overthinking this. If you have setup an ASA interface before then setting up subinterfaces in a context is not much different (other than having to allocate the interface to that given context)  Then you configure the interface on the context as you would any other interface.
    Your configuration would look like this:
    changeto system
    interface Gig0/0
    no shut
    int Gig0/0.1
    vlan 10
    ing Gig0/0.2
    vlan 20
    context A
    allocate-interface Gig0/0.1 - Gig0/0.2
    changeto context A
    interface G0/0.1
    security-level 100
    nameif inside
    ip add 10.10.10.1 255.255.255.0
    interface G0/0.2
    security-level 0
    nameif outside
    access-list TEST-ACL permit ip 10.10.10.0 255.255.255.0 any
    access-list TEST-ACL2 permit ip any host 10.10.10.10
    access-group TEST-ACL in interface inside
    access-group TEST-ACL2 in interface outside
    Please remember to select a correct answer and rate helpful posts

  • How to set multiple values in one context-attribute

    Hi all,
    Anybody knows a possibility to set multiple Values to a context-attribute?
    I know it how to get it with the following code:
    String break[]= request.getParameterValues("break");
    Now I want to do something like:
    request.setParameterValues(break[no]);
    where no is a counter in a loop.
    With the Method setAttribute(), I overwrite the previous inserted value.
    Thanx
    Robert

    I have not explizit declared break as an array.
    It is the Context- Attribute I want to send. I thaught that I can use it as an array in the same way I can do it when I send Data from an HTML- Form (with multiple values) to an servlet.
    I don't know how to declare the Attribute explizit as an array.
    that it is you wanted to know?
    I think my main problem is to get an array from the servlet to the jsp. Is there an other possibility (other than via Context-Attributes) to do that?
    thanx
    robert

  • How to maintain EOIO for JMS to multiple webservices scenario

    Hi,
    I have a requirement that
    how to maintain EOIO for JMS to multiple webservices scenario.
    JMS queue has multiple messages, each message has to be sent to either of 2 receivers.
    How to maintain EOIO in case, when there are 2 receivers.
    Regards
    Sekhar

    Hi,
    since messages are split between 2 webservices receivers, each would have its own SOAP adapter.
    So if order of messages in the JMS queues is M1, M2, M3 and M4 . There is a field based on which split happens.
    Say, if M1 and M3 have to go Webservice1 (will have its own mapping)
    and M2 and M4 have to go Webservice2. (will have its own mapping)
    we'll have two receivers in the receiver determination and hence two Interface determinations.
    The result should be
    M1 delivered to Webservice1
    M2 delivered to Webservice2
    M3 delivered to Webservice1
    M4 delivered to Webservice2
    How will we maintain EOIO in this case?
    Regards,
    Balaji.M

  • Multiple Webservices

    Hi,
    How to add multiple webservices in a Single Ear file.
    My Requirement:
    I Have a ear which have different EJB jars for different modules.
    Now I want to publish different EJB modules as webservice.
    If I am right , now only one service can be published from
    one Ear. How to make my other modules also published as webservice
    from same EAR.
    regards
    Boney Jose

    Hello,
    Manoj has an example of packaging multiple web services [1]. See if
    this example helps.
    HTH,
    Bruce
    [1]
    http://manojc.com/?sample12
    Boney Jose wrote:
    >
    Hi,
    How to add multiple webservices in a Single Ear file.
    My Requirement:
    I Have a ear which have different EJB jars for different modules.
    Now I want to publish different EJB modules as webservice.
    If I am right , now only one service can be published from
    one Ear. How to make my other modules also published as webservice
    from same EAR.
    regards
    Boney Jose

  • Session between multiple Webservice calls from PI7.0

    Hello XI SDNers,
    I am unable to overcome my Webservice session problem using SOAP (Axis) adapter. My scenario is as follows:
    I am calling a external Webservice deployed in Axis webservice engine from PI7.0, during my first call:  I call synchronous "Login" webservice and I became the response "User is Logged in"
    during my second synchronous call "GetItem", the webservice returns "The user doesn't have valid session". The two synchronous calls are executed from same scenario one after another!
    I lost my session after the "Login". Is there any way in PI 7.0 to maintain the session?
    Note: I tried the same scenario using XML SPY SOAP client, it is working!!!  it is maintaining the session between multiple webservice calls.
    Is there any suggestions to overcome this problem?
    Thanks and regards,
    Satish.

    Hi Satish,
       We are working on the same sort of scenarios, where we have to call more than one webservice in a sequential fashion using the same session id details.
        What we did was we built new xsds adding session details node using the webserive request and response xsds. And we are maintaining a sessions table which contains session id and  status fields in PI. So we send webservice request with the session id details. We wrote an UDF to get the session details from PI and set the status field as busy so that no other request uses the same session details.
       Webserive response again contains the sessions details which can be used for the next webservice request.
      Finally after all the calls set back the status to Active in PI table.
    Webservice Calls From a User Defined Function
    /people/bhavesh.kantilal/blog/2006/11/20/webservice-calls-from-a-user-defined-function
    Hope this helps.
    Thanks,
    Vijaya.

  • How to do single sign on for multiple webservices in flex application

    Hi Experts,
    I have created a flex application and using few webservices in that application. When I run the application its asking logon details for each and every webservice I used. However I want to do single sign On without providing logon details for each and every webservice.Please suggest me.
    Thanks and advance.

    Hi,
    if yout projects are deployed in their own Java EE context root then you have multiple applications, though logically you count them as one. Use OSSO or Oracle SSO (where OSSO should be fine since all deployments share the same instance)
    Frank

  • Regarding webservice adding to context of component controller

    Hi All,
           I have imported a webservice model and i am creating a data link between
    data model and component controller.why should i link Request Node(i,e Request_CustSessionWSViDocument_CustRetAll) to context of component controller why not response object(Response_CustSessionWSViDocument_CustRetAll).
           I want a clear picture regarding Request Node object and Response Object Node.Actually I want to know what resides in Request Node and in Response Node of a webservice model
    Thanks & Regards,
    saleem

    These classes are simply proxy classes for the web services.
    They reprsent request and response to the web service.
    For each method in web service there will be some parameter and return type. The request represent the paramaters and response represent the return type for the web service (or simply say method exposed as web service)
    Web Dynpro through context allows to you easily map the request,response in form on context nodes. You have to fill the request node.Then execute the web service. The result is stored in response node.
    This is good wiki to learn about AWS Model:
    https://wiki.sdn.sap.com/wiki/display/WDJava/FAQ-Models-AdaptiveWebService
    Regards
    Ashwani Kr Sharma

  • Multiple Webservice calling

    Hi All,
    How to call more than one webservice from a Flex Panel ?
    I have multiple cmbobox that values are listing from different webservices.
    When I get one combobox values, other combos are not getting....
    please give me a solution for recover from this problem...
    Thanks
    Tuoj

       private function call_webservices():void
          post_submit_ip_to_iad_service.send();
          post_submit_ip_to_ani_service.send();
        <mx:HTTPService id="post_submit1"
          url="??"
          method="POST"
          result="result_handler1(event)"
          fault="fault_handler(event)">
        </mx:HTTPService>
        <mx:HTTPService id="post_submit2"
          url="??"
          method="POST"
          result="result_handler2(event)"
          fault="fault_handler(event)">
        </mx:HTTPService>
        <mx:Button label="Submit" click="call_webservices();"/>

  • Call multiple Webservices

    We have a report to be built using webservices,
    I got the key columns in the report using webservice_1, few of the columns to be derived using webserive_2 like by passing lookupcode to get the description.
    now my question how to invoke webserivece_2 for each record?
    Any clue.

    This is a prime use case for BPEL, as integrating multiple web services is exactly what it's meant to do. You could then call the new BPEL-based web service from APEX.
    Tyler

  • Multiple Webservices in Xcelsius

    I'm pulling in data from a number of different SQL servers etc. and I want to create a webservice or services that will pull the different sections of data into separate worksheets in Xcelsius. I have Xcelsius Engage 2008 (not Server or Enterprise). Can I do this or do I have to have Server to bring in more than one lump of data?

    I'm using Engage as well.
    While Xcelsius engage allows you to only make one direct connection to a web service there is another way.
    You can connect your excel model to many web services if you use the xml mapping functionality in excel.    These mappings are imported to your Xcelsius model along with anything else in your excel model.
    Once you imported you will find that the multiple web service connections are still active. 
    The only compromise is that there seems to be less flexiblity when attempting to use input parameters with the web service  (Excel doesn't seem to have a method to let you supply input to a web service.)

  • How to combine multiple webservices into one WSDL file

    Gurus,
    I have 4 four webservices(ws1,ws2,ws3 & ws4) defined in XI. Normally in XI when we define webservice ,WSDL file will be generated for each interface. Now I have 4 related interfaces, so 4 WSDL files will generated. Suppose if I have 100 webservices then 100 WSDL files need to be generated & need to send to other party to consume our services, which is very tedious task & to track also. So is it possible to combine related webservices into one WSDL file? Your inputs will be highly appreciated.
    Regards,
    Santhosh

    Hi,
             Instead of trying to combine the interfaces, you can try to define your interface mapping with 4 sender interfaces with in one interface mapping . I think this may give you the result you are expecting.
                      If you want entire content to be in one interface , then, define single interface which can accomadate, all message ocntent of all 4 interfaces.Means your sender message to contain the 4 datatypes internally.
    Regards,
    Reyaz

  • Client consuming multiple webservices that have shared classes

    My Java client application is accessing two webservices (ServiceA and ServiceB). Both of these webservices us a shared class (CoolRect). I use wscompile to generate stub files for these webservices. When I try to use CoolRect, it gives an "ambiguous" error. Basically I must declare my CoolRect like:
    ServiceA.CoolRect rectA;
    ServiceB.CoolRect rectB;
    The problem is that I cannot assign one to the other:
    rectA = serviceA.getCoolRect();
    rectB = rectA;
    This generates an "incompatible types" error. These are identical classes from common source base used by the webservices. Is there some way to get wscompile to generate stubs so this isn't a problem? All solutions appreciated. Thanks

    Hi Javier...
    Thanks for helping out, though I didn't see any change after applying the configs you suggested.
    The changed config contains the following:
    access-list local_redistribute_out standard permit 172.31.255.0 255.255.255.0
    route-map local_redistribute_out permit 10
    match ip address local_redistribute_out
    router ospf 1000
    router-id 192.168.210.1
    network 10.21.0.0 255.255.0.0 area 1
    network 192.168.210.0 255.255.255.252 area 0
    area 1
    log-adj-changes
    redistribute static subnets route-map local_redistribute_out
    crypto dynamic-map VPN_SOFTWARE_CLIENT 10 set transform-set ESP-AES-256-SHA
    crypto dynamic-map VPN_SOFTWARE_CLIENT 10 set security-association lifetime seconds 288000
    crypto dynamic-map VPN_SOFTWARE_CLIENT 10 set reverse-route
    crypto map EXTERNAL_MAP 1 ipsec-isakmp dynamic VPN_SOFTWARE_CLIENT
    I can confirm the following:
    ASA# ping 10.21.9.42
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.21.9.42, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    After doing the capture, the show capture capin indicated 0 packets captured, 0 packets shown.
    My pertinent local routing table entries contain:
    $ netstat -rn |grep utun0
    default            utun0              UCSI            2        0   utun0
    10.21/16           172.31.255.7       UGSc            0       13   utun0
    172.31.255.7       172.31.255.7       UH              3        0   utun0
    172.31.255.255     utun0              UHW3Ii          0       56   utun0     12
    192.168.210        172.31.255.7       UGSc            1       11   utun0
    216.185.64.6       utun0              UHW3Ii          0      586   utun0    140
    I hope you see something in here that can help.
    Thanks.
    Ken.

  • Multiple war with same context root

    Dear all,
    I would like to know if it's possible to have several war in an EAR file with a same context root?
    I know that it is possible to have several war but I don't know if it's possible to share the same context root.
    The problem here is that the application on which we work is provided by another company, hence we have an original EAR containing the company war as well as the company EJB. As new versions of the application are delivered to us quite frequently, it's impossible to store the code developped by us in the EAR, as it is replaced in each delivery.
    Concerning our custom code, it is not a problem as we develop this code in a separated project which is included as a jar in the APP-INF/lib directory of the EAR file.
    But concerning the war it's an other problem. Indeed, we develop custom JSFs pages or javascript. These files are placed in the application war file which changes for each delivery.
    Thus, we would like to create an other war file which will contain all our custom pages and javascripts in order to be able, in each delivery, to fully replace the other war containing the company pages and javascripts. This would allow us to save time each time a new delivery is done.
    The important thing would be to keep the same context root for the two wars, enabling transparency for the application.
    Thanks for your help,
    Citrouille57

    Hello,
    this is possible in IBM Websphere via custom extension: http://publib.boulder.ibm.com/infocenter/wasinfo/v6r0/index.jsp?topic=/com.ibm.websphere.base.doc/info/aes/ae/tprs_sharing_data.html
    I don't know if it's possible somewhere else.
    k.

Maybe you are looking for

  • How do I use Airport Express to extend my current network.

    I am now using an Airport Extreme and want to use my old Airport Express to extend my network. How do I do this? Thanks!

  • How to get serial number of prepaid membership card

    I BOUGHT A 12- MONTH PREPAID MEMBERSHIP TWO DAYS AGO, BUT I CAN'T GET MY SERIAL NUMBER

  • Problems with the tag error-page in web.xml

    hi all, here is my code in my web.xml: <error-page> <exception-type>java.sql.SQLException</exception-type> <location>/ex.html</location> </error-page> it seems not to work, because my JavaBean where its the code to connect to my database and execute

  • MSi GT683 Resolution

    I have MSi gt683, i can't find 1600x900 in display resolution, can you guy's help me. 

  • Sales order IDOC process

    Hi Guys I need the ALE/IDoc entire process to receive sales order master data from clients Also IDoc using BADI when a sales order is created please help, I have not worked with IDOCS before. Points will be rewarded Thanks in advanced Regards