Need help for asynchr. scenario between 4.6c and XI

Hi,
I need some help with this.  We are running 4.6c and now I need to talk to XI 3.0 asynchronously.
I have a situation where I need to send data to an external application.
So: R/3(4.6c) -> XI -> external application (the application is not in our landscape).
It's not required for now to get an answer back from the external application so what are my options?
I want to build my solution around that I will eventually get a response back to be real time but
for now, the FTP adapter should work fine.  PCK will be implimented in the future to make it real time.
Just for a test, I tried:
R/3 -- (RFC Adapter) --> XI --> File adapter ...   but it's crashing in R/3 since R/3 is expecting
a response back.  If I setup two receivers in XI (one being R/3 and the other the file adapter, then it's crashing in XI saying since I cannot have two receivers for a synchronist request.)
I was looking to use an ABAP proxy but from what I'm reading, it cannot be used in 4.6c.
So what are my options? Is it only trough an IDoc that I can communicate out of R/3 to XI if my request don't required a response back?
Thanks
Yves

Hi Yves.
For a 4.6 R/3 system the only possible options are the RFC adapter and the Idoc adapter.
The Idoc adapter is used for async processing (no reponse)
The RFC adapter is used for sync processeing (and will therefore always expect a respons message)
The File adapter also onlu supports async (no response) processing.
There are two ways to solve your problem:
1. Create a Idoc to file scenario
2. Use the sync to async bridge
On help.sap.com you can fing documentation on this scenario:
http://help.sap.com/saphelp_nw04/helpdata/en/83/d2a84028c9e469e10000000a1550b0/frameset.htm
Best regards,
Alwin

Similar Messages

  • RE : need assistance for the BAPI between Web methods and SAP

    *Hi All,*
    *I need help regarding the integaration between webmethods and SAP by using BAPI_PROJ_MAINTAIN.*
    *Details:*
    *From webmethods side they are maintaining 2 fields called Region and Sub region with parent and child hirearchy*
    *From SAP side we are maintaining the only one field called subregion.*
    *Need clarification:*
    *can we map field : subregion from webmethods to field : subregion in SAP without maintaing any parent and child hierarchy?*
    *Any imapact will be there on SAP system like Data loss and mismatch of the existing fields.*
    Thanks & Regards
    Raju M
    9944531233

    Between webpages is quite simple.  It sounds like your Xacute Query template and BLS are configured to receive the properties, so make sure the web page containing your applet uses an irpt extension and then add the following lines within your applet tags to receive the tokens for the query:
    <PARAM NAME="Param.1" VALUE="{LowRange}">
    <PARAM NAME="Param.2" VALUE="{HighRange}">
    Then call your page with a URL like:  ...Page.irpt?LowRange=0&HighRange=100
    If you look at the web page examples in the Module Library template downloads here on SDN you'll see examples like this, as well as others.

  • Need help for JTextPane as JTree node renderer and styling in JTextPane!!!

    hello,
    I have a tree which is loading from database. And in renderer i am using JTextPane. I am putting huge text around 500 words in each node. And this Text is formatting using StyledDocument in JTextPane.
    My problem is tree is taking very long time for loading because of this styleddocument. and also size and space of nodes are not proper. how can i solve this issue.
    here is my renderer code.
    public class TraditionalViewTreeRenderer  implements  TreeCellRenderer
            private JPanel jpRubricName;
            private JTextPane lblRubricName;
            private DefaultTreeCellRenderer defaultRenderer = new DefaultTreeCellRenderer();
            private Color backgroundSelectionColor;
            private Color backgroundNonSelectionColor;
            private FontMetrics fontMetrics;
            public TraditionalViewTreeRenderer(){
                jpRubricName=new JPanel();
                lblRubricName = new JTextPane();
                jpRubricName.add(lblRubricName);
                backgroundSelectionColor    = defaultRenderer.getBackgroundSelectionColor();
                backgroundNonSelectionColor = defaultRenderer.getBackgroundNonSelectionColor();
            @Override
            public Component getTreeCellRendererComponent(JTree tree, Object value,boolean selected,boolean expanded, boolean leaf, int row,boolean hasFocus){
                Component returnVal=null;
                if(value!=null && value instanceof DefaultMutableTreeNode){  
                    Object userObj = ((DefaultMutableTreeNode)value).getUserObject();
                    if(userObj instanceof RubricNode){
                        try {
                            RubricNode node = (RubricNode) userObj;
                            if(node!=null && !node.getRubricName().equalsIgnoreCase("")){
                                if(node.getRemedyList()!=null){
                                    lblRubricName.setText("");
                                    highlightContent(lblRubricName,node.getRemedyList(),node);
    //                                fontMetrics = lblRubricName.getFontMetrics(lblRubricName.getFont());
    //                                int prefHit = fontMetrics.getHeight() * node.getRemedyList().toString().length();
    //                                if(prefHit!=tree.getRowHeight()){
    //                                    lblRubricName.setPreferredSize(new Dimension(Short.MAX_VALUE,prefHit   ) );
    lblRubricName.setPreferredSize(new Dimension(900,getContentHeight(node.getRemedyList().toString())   ) );
                            if (selected) {
                              jpRubricName.setBackground(backgroundSelectionColor);
                            } else {
                              jpRubricName.setBackground(backgroundNonSelectionColor);
                            lblRubricName.validate();
                            jpRubricName.validate();
                            returnVal = jpRubricName;
                            tree.expandRow(row);
                        } catch (Exception ex) {
                            Logger.getLogger(RepertoryTradView.class.getName()).log(Level.SEVERE, null, ex);
    //            if(returnVal==null){
    //                returnVal = defaultRenderer.getTreeCellRendererComponent(tree, value, leaf, expanded, leaf, row, hasFocus);
                return returnVal;
        private void highlightContent(JTextPane comp,List l,RubricNode rubric) throws BadLocationException{
            for(int i=l.size()-1;i>=0;i--){
                comp.getStyledDocument().insertString(0, "., ", ((Remedy)l.get(i)).getRemedyStyle());
                comp.getStyledDocument().insertString(0, l.get(i).toString(), ((Remedy)l.get(i)).getRemedyStyle());
            if(l.size()>0){
                comp.getStyledDocument().insertString(0,rubric.getRubricName()+":",rubric.getRubricStyle());
            }else{
                comp.getStyledDocument().insertString(0,rubric.getRubricName(),rubric.getRubricStyle());
        } Remedy List is the list of 300-500 words..
    see above .. n suggest me something.
    My problem is about the size and spacing of each tree node and insertString() of styled document which is taking huge time to load.

    Main performance issue there is comp.getStyledDocument().insertString(...) calls.
    Each time you call this your comp which listens model updates layout.
    Instead of using the same Document create a new instance of the Document (e.g. by kit.createDefaultDocument()). Pass the newly created document in the method to insert all the content and after the insert completed call comp.setDocument(newDocInstance)
    Also check this http://java-sl.com/JEditorPanePerformance.html

  • Need help for a scenario

    Hi all,
    There are 6 DSOs .Let them be A1,A2,B1,B2,C1,C2.
    I need data union of 2 dsos.
    Means union of A1,A2  and union of B1,B2 and union of C1,C2.A1
    Then I need common records(JOIN) of three sets.All the fields in A1,A2 are not the same.There will be small differences.
    Can anyone suggest the possible ways to approach this scenario.

    Hi,
    You can create 3 DSOs to get the union from two - two DSOs. Meaning your A1 and A2 will feed DSO D1, B1 and B2 will feed DSO D2, similarly C1 and C2 will feed DSO D3. This way you will get Unions in D1, D2 and D3.
    Now to get common data (Joins) from these three DSOs, create an InfoSet based on D1, D2 and D3. This will give you intersection of D1, D2, and D3.
    Hope it helps.
    Regards,
    Yogesh.

  • 100% Noob - Need Help for basic setup of Cisco 2504 and 1600 AP

    Hello,
    I am completely noob in (cisco) networking.
    I have to setup a basic but secure wireless network.
    I have a cisco 2504 and 2 APs 1600 + a random switch
    I have 4 ports on the controller.
    I want to keep the 1st port on the network for the controller management, plug my internet box on the 3rd port, and my switch on the 4th port. Then the AP will be on the switch.
    I am able to make something working when everythings are plugged on the switch, plugged in the first port (default management port).But this is not what I want.
    First thing, Is that possible ?
    1st port : office network
    2nd port : empty
    3rd port : Internet Box
    4th port : Switch + all APs
    Then, if that is possible, how should i configure the controller to make that work ? I am completely lost in the menus.
    I dont need a perfect configuration, just something simple and working.
    1 SSID, 10 DHCP addresses, block wireless users trying  to go on the office network.
    If anyone could help my doing that, It would be very nice.
    Thank you.

    You basically need two SSIDs one for corporate users and second for guests .check the link with  step by step config and brief details .
    http://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-vlan/70937-guest-internal-wlan.html

  • Need help for flash builder

    i need help for flash builder 4 and papervison 3d. I need to create a slider with it ranges of value from 10 to 50 to adjust the camera values for the camera.fov and also need to create it for the yaw of the object from 0 to 360. I try to look for any slider event and classes in this program but cant find any, btw, i need to use the AS only project file.
    here is my codes:
    can you please tell me how i should modify the codes?
    package
        import flash.display.BitmapData;
        import flash.display.Sprite;
        import flash.events.Event;
        import org.papervision3d.materials.BitmapFileMaterial;
        import org.papervision3d.materials.BitmapMaterial;
        import org.papervision3d.objects.primitives.Sphere;
        import org.papervision3d.view.BasicView;
        [SWF (width="800", height="600", backgroundColor="0x000000",frameRate="30")]
        public class EarthBitmap extends BasicView
            private var sphere:Sphere;
            public function EarthBitmap()
                super(800 , 600);
                var earthmaterial:BitmapFileMaterial = new BitmapFileMaterial("../assets/Earth.jpg");
                sphere = new Sphere(earthmaterial,100,20,18);
                camera.fov = 25;
                scene.addChild(sphere);
                addEventListener(Event.ENTER_FRAME,rotateSphere);
            public function rotateSphere(evt:Event):void
                sphere.yaw(0.2);
                singleRender();

    Turn the click handler into a full on separate function. Then store all the views in an array and use Math.rand() to randomly choose one.
    Something like this:
    <fx:Script>
         <![CDATA[
              var questionsArray:Array = {question2,question3,question5,questionRed,questionGeography};
              function buttonClickHandler(event:MouseEvent){
                   var randomProblem:int = Math.floor(Math.random()*(questionsArray.length));     //generates a random integer between 0 and the total number of questions in the array (arrays are 0-based)
                   navigator.pushView(questionsArray[randomProblem]);
         ]]>
    </fx:Script>
    <s:Button id="randomProblemButton" label="Next Problem" click="buttonClickHandler(event)" />
    Haven't tested that, but something along that line should work

  • Need help for publishing web intelligence document (universe) into InfoView

    Post Author: mirage
    CA Forum: Publishing
    Hello all,
    I need help for publishing web intelligence document (universe) into InfoView.
    can't find this information in Business Objects Designer's Guide and in Business Objects Administrator Guide.
    Can somebody give short instructions how can I do it?
    Regards, Slava

    If the change between the 2 types of data has to happen dynamically during run time them
    1. Use 2 dataproviders
         a. Current
         b. Historic
    2. Merge the 2 dimensions
    3. Use Webi variable to switch between the measure of the current and historic universe
    Ex  if [year] < 2010 then historic.[expense] else current.[expense]
    Hope this helps,
    Divya

  • Need help for Transfer PO

    need help for Transfer PO.
    i need help for to transfer PO from one season to onther season. pleas ehelp me how to proceed and how 2 approach the process.
    if any code is there please provide  me

    follow the link
    it may help you
    MM SCENARIO
    https://www.sdn.sap.com/irj/sdn/advancedsearch?cat=sdn_all&query=abapcodetotransferpurchaseorder&adv=true&sdn_author_name=&sdn_allusernamesofthread=&sdn_category=&sdn_forum=&sdn_updated_on_comparator=GE&sdn_updated_on=&sortby=cm_rnd_rankvalue
    reward if helpful
    Edited by: sharad narayan on Apr 8, 2008 3:16 PM

  • I need help syncing my contacts between Outlook and iPhone using iTunes. I followed the steps given and ended up with just email addresses showing in my contacts even though I have phone numbers and snail mail in my Outlook Contacts. Using  Windows 7

    I need help syncing my contacts between Outlook and iPhone using iTunes. I used the knowldge document and set it up to transfer my Outlook contacts to the iphone using itunes.
    In contacts on the iphone I only see the email addresses.
    Yet in Outlook I have email, snail mail and phone numbers.
    I followed the knowledge document from iphone.
    I did it once, didn't work so deleted all the contacts from the phone and tried again. Same result. I have a PC using Windows 7 64 bit.

    You can't access an Exchange account via ActiveSync with the Address Book and iCal on your Mac.
    You can access a MM account with Outlook on your PC at work and keep your MM email account server stored mailboxes synced between your PC at work, your iPhone, and the MM "cloud". Not sure about syncing MM contact info and calendar events with Outlook at the same time with an Exchange account.
    This will not provide for syncing your Exchange account contact info and calendar events with the Addresss Book and iCal on your Mac because the accounts are separate.
    You can access an Exchange account and a MM account at the same time with the iPhone's mail client, and sync contact info and calendar events over the air with both accounts at the same time. You can view combined contact info or separately for each account, and the same for calendar events.

  • I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    http://www.apple.com/support/itunes/contact/

  • Need help for Format HD

    Hi I need Help for Formating HD so Wat Key need hold on start up for format HD I apprciated you Help

    Jesus:
    Formatting, Partitioning Erasing a Hard Disk Drive
    Warning! This procedure will destroy all data on your Hard Disk Drive. Be sure you have an up-to-date, tested backup of at least your Users folder and any third party applications you do not want to re-install before attempting this procedure.
    • With computer shut down insert install disk in optical drive.
    • Hit Power button and immediately after chime hold down the "C" key.
    • Select language
    • Go to the Utilities menu (Tiger) Installer menu (Panther & earlier) and launch Disk Utility.
    • Select your HDD (manufacturer ID) in left side bar.
    • Select Partition tab in main panel. (You are about to create a single partition volume.)
    • _Where available_ +Click on Options button+
    +• Select Apple Partition Map (PPC Macs) or GUID Partition Table (Intel Macs)+
    +• Click OK+
    • Select number of partitions in pull-down menu above Volume diagram.
    (Note 1: One partition is normally preferable for an internal HDD.)
    • Type in name in Name field (usually Macintosh HD)
    • Select Volume Format as Mac OS Extended (Journaled)
    • Click Partition button at bottom of panel.
    • Select Erase tab
    • Select the sub-volume (indented) under Manufacturer ID (usually Macintosh HD).
    • Check to be sure your Volume Name and Volume Format are correct.
    • Click Erase button
    • Quit Disk Utility.
    cornelius

  • Need help for my requirement...

    Need help for my requirement...
    Hello Experts,
    I have report where users can input the company, housebank, account ID and posting date.
    Now in one column of my report named 'Cash in Bank', I need to get all postings from cash
    accounts with GL code ending in '0'. Now, I know that I can get the amounts in BSIS/BSAS
    but how do I link it with the proper bank and account?
    For example:
                       Cash in Bank
    Bank A
      Account ID 1     1,000,000
      Account ID 2     25,000,000
    Hope you can help me guys. Thank you and take care!

    hi Viraylab,
    each house bank you can find in table T012, in T012K you'll find the bank accounts to the housebank, the G/L account will be in T012K-HKONT.
    hope this helps
    ec

  • Need help for importing oracle 10G dump into 9i database

    hi, Someone help me to import oracle 10G dump into 9i database. I'm studying oracle . Im using oracle 10G developer suite(downloaded from oracle) and oracle 9i database. I saw some threads tat we can't import the higher version dumps into lower version database. But i'm badly need help for importing the dump...
    or
    someone please tell me the site to download oracle 9i Developer suite as i can't find it in oracle site...

    I didnt testet it to import a dump out of a 10g instance into a 9i instance if this export has been done using a 10g environment.
    But it is possible to perform an export with a 9i environment against a 10g instance.
    I am just testing this with a 9.2.0.8 environment against a 10.2.0.4.0 instance and is working so far.
    The system raises an EXP-00008 / ORA-37002 error after exporting the data segments (exporting post-schema procedural objects and actions).
    I am not sure if it is possible to perform an import to a 9i instance with this dump but maybe worth to give it a try.
    It should potentially be possible to export at least 9i compatible objects/segments with this approach.
    However, I have my doubts if this stunt is supported by oracle ...
    Message was edited by:
    user434854

  • Need Help for Nokia 6500 slide

    Hi all I'm A new Guy here ,
    But I do really need help for hard reset my phone
    I already try *#7073# But It doesn't work ,
    If Anybody know to make a hard reset please help

    rwss wrote:
    I'v got te same problem with my 6500 Slide, is there a button combination that we have to press
    to hard reset the 6500 Slide?!
    How does the 6500 slide hard reset?
    That's simple.
    All you have to do is:
    From MENU goto SETTINGS, When there scroll down and select 'Restore Factory Setting'.
    There are two options in there:
    "Restore Settings only"
    and
    "Restore all"
    Select "Restore All"
    When done the phone will delete every thing on the Phone memory(C:\)(contacts,picture,messages etc)
    and also restore phone to its original settings and will restart.
    This proceedure is mostly common on S40 phone.
    Hope this explain and solve the problem.

  • Need help for access list problem

    Cisco 2901 ISR
    I need help for my configuration.... although it is working fine but it is not secured cause everybody can access the internet
    I want to deny this IP range and permit only TMG server to have internet connection. My DHCP server is the 4500 switch.
    Anybody can help?
             DENY       10.25.0.1 – 10.25.0.255
                              10.25.1.1 – 10.25.1.255
    Permit only 1 host for Internet
                    10.25.7.136  255.255.255.192 ------ TMG Server
    Using access-list.
    ( Current configuration  )
    object-group network IP
    description Block_IP
    range 10.25.0.2 10.25.0.255
    range 10.25.1.2 10.25.1.255
    interface GigabitEthernet0/0
    ip address 192.168.2.3 255.255.255.0
    ip nat inside
    ip virtual-reassembly in max-fragments 64 max-reassemblies 256
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    description ### ADSL WAN Interface ###
    no ip address
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    interface Dialer1
    description ### ADSL WAN Dialer ###
    ip address negotiated
    ip mtu 1492
    ip nat outside
    no ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxxx password 7 xxxxxxxxx
    ip nat inside source list 101 interface Dialer1 overload
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 10.25.0.0 255.255.0.0 192.168.2.1
    access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    access-list 105 deny   ip object-group IP any
    From the 4500 Catalyst switch
    ( Current Configuration )
    interface GigabitEthernet0/48
    no switchport
    ip address 192.168.2.1 255.255.255.0 interface GigabitEthernet2/42
    ip route 0.0.0.0 0.0.0.0 192.168.2.3

    Hello,
    Host will can't get internet connection
    I remove this configuration......         access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    and change the configuration ....      ip access-list extended 101
                                                                5 permit ip host 10.25.7.136 any
    In this case I will allow only host 10.25.7.136 but it isn't work.
    No internet connection from the TMG Server.

Maybe you are looking for

  • Press ready PDF from Pages (CMYK + Distiller)

    Sorry for the odd title but i wanted to get as much information in there as possible. I am in the process of switching printing companies for the support propaganda that i use to promote my artwork. I make one of a kind pieces of furniture. In the pa

  • Package working fine in SSDT but not in integration services catalog or sql job

    Hi All we have created a package which contains Project parameter , when we tried to run the package in SSDT it is working fine . we deployed the project to sql server and we want to  test the package .  we executed the package ( for testing purpose

  • Difficulty in querying a form

    hii all i have a form on which i have a customer_name field it is a non database field i am getting the value of the customer_name field from customer id . but the customer _id field is not on the form i want to query the form based on the customer n

  • Loading amount field of length 22,9

    Hi, My requirement is to load an amount field with length 22 and 9 decimal places. If it is possible then how ? Thanks in Advance

  • Music Selection On TV

    I have the 60GB iPod Photo with the requisite A/V cables for viewing on my TV. Does anyone know if there's a way to get the b current music selection to appear on the TV screen Thanks!