Need help for connection problem

When I try to run JdbcCheckup.java, I get following problem:
password: tiger
database(a TNSNAME entry): myhost:1521:orcl
Connecting to the database...Connecting...
Exception in thread "main" java.sql.SQLException: Io exception: The Network Adap
ter could not establish the connection
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:114)
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:156)
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:269)
at oracle.jdbc.driver.OracleConnection.<init>(OracleConnection.java:212)
at oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.ja
va:251)
at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:224)
at java.sql.DriverManager.getConnection(Compiled Code)
at java.sql.DriverManager.getConnection(DriverManager.java:137)
at JdbcCheckup.main(Compiled Code)
I'm very appreciated for everybody's help
null

This example can be run without specifying a TNSNAME connection string, as the oci8 jdbc driver will default to the localhost. OR - Specifying the only the TNSNAME is required, i.e. edit %ORACLE_HOME%\network\ADMIN\TNSNAMES.ORA file and locate the XXXXX.WORLD entry in the file. This is the TNSNAME entry referred to.
Try re-running this as follows (with no TNSNAME entry at all):
%ORACLE_HOME%\jdbc\demo\samples\oci8\basic-samples> java JdbcCheckup
Please enter information to test connection to the database
user: system
password: manager
database (a TNSNAME entry):
Connecting to the database...Connecting...
connected.
Hello World
Your JDBC installation is correct.
null

Similar Messages

  • Need Help for connectivity USB Cable Nokia 5800 ca...

    Hi All,
    I really need help to solve my problems. I just bought nokia 5800 XM last week. I already installed the CD software in my windows XP, but it seems that PC cannot recognize the USB cables. I have plug in an unplugged... At firstime it detects my nokia 5800 XM, but when I open PC suite or OVI, it doesn't connect the USB cables into PC. I already install and uninstall The OVI suite but it is still the same, when I try it in OVI suite to detect my phones, it doesn't react.... I also have download from Nokia website to install manually Nokia USB cable driver for my  cable type CA-101... it seems nothing works here... tell me what should I do? I don't think that the USB cable I bought is fake, it has original guarantee..... please desperately need help! Anybody? 

    When you plug the phone into the computer, ON THE PHONE it should ask you which mode to connect in, and you should select "PC Suite" mode.  Does this happen?
    Ravi

  • Need help for connecting internet in solaris 10

    Hello ,
    I am new to Sunsolaris, recently i installed solaris 10 in my HP laptop. In my lap vista is the host and i installed Virtual box 3.0. Inside virtual box i installed solaris. My problem is not able to connect to internet. Iam using a wireless modem for connecting internet which is configured in vista. Solaris is not identifying wireless modem. Virtual box host adaptor is the ethernet iam using. I want to connect solaris to vista and access the internet( i have a guest open suse Linux in my lap, this is able to connect to internet through vista) can anybody give me a solution to get internet in solaris(ie through vista)
    Biju

    Hi,
    What is the gateway used by Solaris. Please send the result of ifconfig -a on the Sun OS.
    Sunil.

  • Need help for connecting Ms Acces with java Swing in Mac OS

    Hi all,
    i need to connect to Ms Access in MAc os through my java swing program.
    Is it possible for accessing Ms access through dsn in Mac OS.
    If Possible which driver shall i use for Establishing Connection with MS Access in Mac OS.
    Suggestion is needed urgently.
    Can anybody help me out regarding this..
    Thanks in advance.
    Regards,
    sreand

    if I don't find a better solution I'll try your 2nd option but what do you mean by "combo" update?
    My understanding is to simply insert the OS 10.5 installation CD, reinstall the OS and the just keep updating it via the OS SSoftware update panel and stop untill I see the scary Java 8 update. Is that what you meant?
    While you can do it that way, the combo update picks up operating system updates through a collection of releases. When dealing with operating system upgrades, I've found using the combo updates to be more reliable than Software Update, as sometimes Software Update doesn't apply updates correctly, and weird things can happen. Doesn't happen often though, thankfully.
    So the OS X 10.5.5 Combo update contains all updates between 10.5.0 and 10.5. The 10.5.8 combo update contains the updates from 10.5 thru 10.8. Here are the updates:
    10.5 combo update: http://support.apple.com/kb/DL692
    10.8 combo update: http://support.apple.com/kb/DL866
    If you go down the combo path, repair permissions before and after doing each update. Then do Software Update for any other non-OS X updates, and don't apply the Java Update 8.

  • I need Help for Connect To DB2 with JDBC

    I'd like to know why I Have this problem.
    The DB2 v 5.10 is in a IBM OS/390
    I know the IP, PORt, DBNAME and I'd like to connect to DB2 with my windows XP using JDCB from IBM.
    I use JDBC Universal for DB2 type 4.
    Class.forName("com.ibm.db2.jcc.DB2Driver");
    Url = "jdbc:db2://IP:PORT/BDNAME";
    DriverManager.getConnection.... (url, user, pass)..
    If I execute this, I have next problem
    SQL state = null
    Error code = -4499
    There is no available conversion for the source code page, 1208, to the target code page, "". DB2ConnectionCorrelator: null
    Why is this?
    Finally, the web application will running in a AIX IBM with machine, It could be that this machine (aix) can connect with the IBM OS/390 with JDBC for iBM?
    Thankss!!!

    Check how you configured the IP on the laptop and computers, assigned by router with DHCP feature enabled? Or configure manually? If it's assigned by wireless router, then make sure you assign big enough IP range in DHCP setting. Take a look on using ping to troubleshoot network and wireless router configuration articles to help you more..

  • Need help for sound problem in Compaq Presario cq40-142tu

    i am using cq40-142tu and I am downgrading it from Vista to Windows XP Service Pack 3, got everything working except the audio (IDT High Definition Audio Codec).i installed UAA and it work fine, Unfortunately, IDT Def Audio gone after rebooting. can anyone help??

    v3614 sound gone 
     03-21-2010 01:35 AM
    hi, my laptop just sent to hp service center to maintain few weeks ago.. coz of laptop cannot on...
    now i'm facing another problem after laptop has been sent back to me that the audio sound was disappear automatically...
    starting is just need to restart the laptop then sound will come back... but this time even getting few times restart... still didn't have sound..
    at control panel audio sound.. it's just write that "no audio sound"..
    device manager i have check there is no miss driver for audio sound.
    i have try to install the software from the support driver... cannot install and ERROR..
    Another things i found out that.. the laptop is using for conenxant audio sound.. when the laptop didnt have any sound.. the control panel and device manager din have conenxant audio sound device... seems like the software was disappear...
    i have post the same problem.. but din have any reply...
    our problem is same... now no more sound pop out again even after few times to restart the windows....

  • Need help for connecting in an RSA authentication agent

    i am not sure if this is the right place but i was hoping i am lucky enough for someone with knowledge about rsa or somebody who has experience in developing security pages.
    my problem is something like this, simple, how do i connect to an RSA Authentication Agent, or RSA Authentication Manager.
    i was hoping you could paste an answer or paste an web address of a forum.
    this kind of question is very rare in forums, so i don't really have much choice. any relevant answers are appreciated...
    thank you

    Hi,
    What is the gateway used by Solaris. Please send the result of ifconfig -a on the Sun OS.
    Sunil.

  • Need Help for Battery Problem!!!

    Hi! Everybody.
    After leaving my iBook G4 for a few week, The battery is getting worse. The problem is when i fully charged the battery and it shown 100% on the battery icon, there was only one light and flashing on the back of the battery and the computer can run normally only 15 minutes. Are there any solution or suggestions before i buy a new battery?

    Probably not. I'm having the same issue.
    Reset PMU
    Recalibrate battery
    Run coconut battery or istat widget to check health.
    Save some coin.
    KJ

  • Need help for JApplet problems

    Moderator please delete this topic- I've managed to solve my problems, ironically.
    Edited by: CyberNetic on Feb 3, 2008 4:02 AM

    Well you need to uninstall the audigy drivers then boot into bios enable onboard sound again. Boot to OS uninstall Nvidia "AUDIO" driver reboot back to bios and disable onboard sound, Boot To OS and reinstall the audigy card.  Just becasue that onboard sound is disabled in bios does not mean anything when windows doing that just disables the hardware part not the software (drivers).  You can uninstall drivers easy in Device manager

  • Need help for a problem with Wacom Bamboo Pen tablet and LR5

    When using the advanced spor removal tool in LR5 using the pen of a Bamboo tablet it only goes in straight lines and reacts very sluggish!
    When I use finger input on the same tablet (usingit then as a touchpad), the tool behaves normally and very responsive. If I go in any direction or try to paint an area it just follow and updates instanlty.
    Is it an LR5 bug or problem with the pen tablet drives?!
    I'm running a core i7 Thinkpad, 8 gigs of RAM.. Windows 8.1 Pro..

    Have you read that?
    http://forum.wacom.eu/viewtopic.php?f=10&t=14722

  • By. i need help for photoshop connective...from 2 days ave a problem of connective.thank you

    by i need help for my photoshop connective..if you ceck problem please.

    Does your Cloud subscription properly show on your account page?
    If you have more than one email, are you sure you are using the correct Adobe ID?
    https://www.adobe.com/account.html for subscriptions on your Adobe page
    If yes
    Some general information for a Cloud subscription
    Cloud programs do not use serial numbers... you log in to your paid Cloud account to download & install & activate... you MAY need to log out of the Cloud and restart your computer and log back in to the Cloud for things to work
    Log out of your Cloud account... Restart your computer... Log in to your paid Cloud account
    -Sign in help http://helpx.adobe.com/x-productkb/policy-pricing/account-password-sign-faq.html
    -http://helpx.adobe.com/creative-cloud/kb/sign-in-out-creative-cloud-desktop-app.html
    -http://helpx.adobe.com/x-productkb/policy-pricing/activation-network-issues.html
    -http://helpx.adobe.com/creative-suite/kb/trial--1-launch.html
    -ID help https://helpx.adobe.com/contact.html?step=ZNA_id-signing_stillNeedHelp
    If no
    This is an open forum, not Adobe support... you need Adobe staff to help
    Adobe contact information - http://helpx.adobe.com/contact.html
    -Select your product and what you need help with
    -Click on the blue box "Still need help? Contact us"

  • Pls i need help for this simple problem. i appreciate if somebody would share thier ideas..

    pls i need help for this simple problem of my palm os zire 72. pls share your ideas with me.... i tried to connect my palm os zire72 in my  desktop computer using my usb cable but i can't see it in my computer.. my palm has no problem and it works well. the only problem is that, my  desktop computer can't find my palm when i tried to connect it using usb cable. is thier any certain driver or installer needed for it so that i can view my files in my palm using the computer. where i can download its driver? is there somebody can help me for this problem? just email me pls at [email protected] i really accept any suggestions for this problem. thanks for your help...

    If you are using Windows Vista go to All Programs/Palm and click on the folder and select Hot Sync Manager and then try to sync with the USB cable. If you are using the Windows XP go to Start/Programs/Palm/Hot Sync Manager and then try to sync. If you don’t have the palm folder at all on your PC you have to install it. Here is the link http://kb.palm.com/wps/portal/kb/common/article/33219_en.html that version 4.2.1 will be working for your device Zire 72.

  • I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    http://www.apple.com/support/itunes/contact/

  • Need help for access list problem

    Cisco 2901 ISR
    I need help for my configuration.... although it is working fine but it is not secured cause everybody can access the internet
    I want to deny this IP range and permit only TMG server to have internet connection. My DHCP server is the 4500 switch.
    Anybody can help?
             DENY       10.25.0.1 – 10.25.0.255
                              10.25.1.1 – 10.25.1.255
    Permit only 1 host for Internet
                    10.25.7.136  255.255.255.192 ------ TMG Server
    Using access-list.
    ( Current configuration  )
    object-group network IP
    description Block_IP
    range 10.25.0.2 10.25.0.255
    range 10.25.1.2 10.25.1.255
    interface GigabitEthernet0/0
    ip address 192.168.2.3 255.255.255.0
    ip nat inside
    ip virtual-reassembly in max-fragments 64 max-reassemblies 256
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    description ### ADSL WAN Interface ###
    no ip address
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    interface Dialer1
    description ### ADSL WAN Dialer ###
    ip address negotiated
    ip mtu 1492
    ip nat outside
    no ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxxx password 7 xxxxxxxxx
    ip nat inside source list 101 interface Dialer1 overload
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 10.25.0.0 255.255.0.0 192.168.2.1
    access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    access-list 105 deny   ip object-group IP any
    From the 4500 Catalyst switch
    ( Current Configuration )
    interface GigabitEthernet0/48
    no switchport
    ip address 192.168.2.1 255.255.255.0 interface GigabitEthernet2/42
    ip route 0.0.0.0 0.0.0.0 192.168.2.3

    Hello,
    Host will can't get internet connection
    I remove this configuration......         access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    and change the configuration ....      ip access-list extended 101
                                                                5 permit ip host 10.25.7.136 any
    In this case I will allow only host 10.25.7.136 but it isn't work.
    No internet connection from the TMG Server.

  • Need help for flash builder

    i need help for flash builder 4 and papervison 3d. I need to create a slider with it ranges of value from 10 to 50 to adjust the camera values for the camera.fov and also need to create it for the yaw of the object from 0 to 360. I try to look for any slider event and classes in this program but cant find any, btw, i need to use the AS only project file.
    here is my codes:
    can you please tell me how i should modify the codes?
    package
        import flash.display.BitmapData;
        import flash.display.Sprite;
        import flash.events.Event;
        import org.papervision3d.materials.BitmapFileMaterial;
        import org.papervision3d.materials.BitmapMaterial;
        import org.papervision3d.objects.primitives.Sphere;
        import org.papervision3d.view.BasicView;
        [SWF (width="800", height="600", backgroundColor="0x000000",frameRate="30")]
        public class EarthBitmap extends BasicView
            private var sphere:Sphere;
            public function EarthBitmap()
                super(800 , 600);
                var earthmaterial:BitmapFileMaterial = new BitmapFileMaterial("../assets/Earth.jpg");
                sphere = new Sphere(earthmaterial,100,20,18);
                camera.fov = 25;
                scene.addChild(sphere);
                addEventListener(Event.ENTER_FRAME,rotateSphere);
            public function rotateSphere(evt:Event):void
                sphere.yaw(0.2);
                singleRender();

    Turn the click handler into a full on separate function. Then store all the views in an array and use Math.rand() to randomly choose one.
    Something like this:
    <fx:Script>
         <![CDATA[
              var questionsArray:Array = {question2,question3,question5,questionRed,questionGeography};
              function buttonClickHandler(event:MouseEvent){
                   var randomProblem:int = Math.floor(Math.random()*(questionsArray.length));     //generates a random integer between 0 and the total number of questions in the array (arrays are 0-based)
                   navigator.pushView(questionsArray[randomProblem]);
         ]]>
    </fx:Script>
    <s:Button id="randomProblemButton" label="Next Problem" click="buttonClickHandler(event)" />
    Haven't tested that, but something along that line should work

Maybe you are looking for

  • MacBook Pro Sound Card issue

    Hello everyone, I own a Early June 2011 15" MacBook Pro to assist me in my work as an audio engineer. In spite of some Airoport card/cable issues the MacBook is doing it's job better than I could've wished for, but at the moment (just a couple of mon

  • Creating windows cluster after Oracle single instance installation

    Hi, I have installed and created Oracle 11g R1 single instance server. The database also created on the server. Microsoft windows 2003 enterprise was not cluster during the said installation. Now, the requirement has changed and as per new architectu

  • How to stop safari opening a new tab which relates to inappropriate viewing

    When I'm in safari a new tab opens to reveal an awful **** site, why is this happening and how can I stop it? I've had my iPad for 18 months and this has only just started to happen.

  • WLDF Console Extension

    I'm trying to view the pre-packaged JVM Runtim View from the GUI WLDF console in WLS 10 and while I can see the charts and verify that the time are updating, there is no data. I am basically looking at empty charts with updating refresh times. Is the

  • Clean installed lion--now missing find my mac guest login

    Like the title says.  I clean installed lion and now the guest account for the find my mac feature is gone.  How do I get it back?  All I have at the login screen now is just my acct. .     My icloud acct. is activated.   Thanks