Need help Multithread server

hello all.,
i need a help..,
i wanna build a program that read from a socket, from a multiple client.., and a client can send multiple message..,
when a client send a message, the system will proccess it, while the system proccess it can retrieve another request from the client..,
i'm new at multithread socket programming,
so what should i use..?,
should i use server socket, or serversocket channel..???,
help me..,
regards..,
odoyie

You could have a look at the examples which come with the JDK under sample/nio/server
Or you could look at my example [http://www.freshvanilla.org:8080/display/essence/Essence+Remote+Method+Invocation]

Similar Messages

  • Need Help Writing Server side to submit form via API

    Hey
    I need help writing a serverside application to submit
    information via API to a separate server.
    I have a client that uses constant contact for email
    campaigns. We want to add to her website a form taht submits the
    information needed to subscribe to her email list, to constant
    contact via API.
    FORM.asp :: (i got this one under control)
    name
    email
    and submits to serverside.asp
    SERVERSIDE.ASP
    In serverside.asp i need to have
    the API URL
    (https://api.constantcontact.com/0.1/API_AddSiteVisitor.jsp)
    username (of the constant contact account)
    password (of the constant contact account)
    name (submited from form.asp)
    email (submitted from form.asp)
    redirect URL (confirm.asp)
    Can anyone help get me going in the right direction?
    i have tried several things i found on the net and just cant
    get anyone to work correctly.
    One main issue i keep having is that if i get it to submit to
    the API url correctly - i get a success code, it doesnt redirect to
    the page i am trying to redirect to.
    ASP or ASP.NET code would be find.
    THANKS
    sam

    > This does require server side programming.
    > if you dont know what that is, then you dont know the
    answer to my question. I
    > know what i need to do - i just dont know HOW to do it.
    If you are submitting a form to a script on a remote server,
    and letting
    that script load content to the browser, YOU have no control
    over what it
    loads UNLESS there is some command you can send it that it
    will understand.
    No amount of ASP on your server is going to change what the
    remote script
    does.
    http://www.constantcontact.com/services/api/index.jsp
    they only allow their customers to see the instructions for
    the API so i
    can't search to see IF there is a redirect you can send with
    the form info.
    But posts on their support board say that there is.
    Alan
    Adobe Community Expert, dreamweaver
    http://www.adobe.com/communities/experts/

  • Need performance! - Need help with Server Architecture for SSAS on Azure VM

    I would like to build 100% Azure VM base solution. We can install as many as needed.
    I have large amount data in DW. (100GB-1000GB)
    I would like to provide PowerView reports in SharePoints.
    I would like to have report data be as real time as possible. (Min data is updated once in 2 hours)
    These are requirements:
    -SharePoint 2013
    -PowerView
    -SSAS OLAP Cube
    -SQL Server DW&Staging DB (Currently DW&Staging on same server)
    I need help specially what can be done with SSAS to meet requirements? Should be installed to own application server? Possible to install multiple SSAS? SSRS needs own server?
    I appreciate also links to server topology diagrams.
    Kenny_I

    I assume you mean 100GB-1000GB (not 1000TB) right?
    For Sharepoint I would refer to the sizing guide for diagrams and sizing:
    http://technet.microsoft.com/en-us/library/ff758647(v=office.15).aspx
    SSRS (and Power View) will run in the SharePoint farm on a SharePoint app server potentially with other SharePoint services.
    I would definitely put SSAS on a dedicated server for a cube that size. Depending on how well your data compresses, there may not be a VM in Azure with enough RAM to put your model into a Tabular SSAS model. I would prototype it with a subset of data to see
    how well it compresses. You can always use a Multidimensional model as a fallback.
    Depending on how much processing the SSAS model impacts user queries (since it is happening during the day) you could build an SSAS processing server and a separate SSAS query server and run the XMLA Synchronize command to copy the cube incrementally from processing
    to query servers.
    Does that help?
    http://artisconsulting.com/Blogs/GregGalloway

  • Need help with server for Microsoft Exchange

    Okay. My college uses Microsoft Outlook and I wanted to be able to check it from my phone.
    So I am trying to use microsoft exchange.
    but I don't know what to put in the server part.
    I don't get step three
    3.Your iPhone (or iPod touch) will now try to locate your Exchange server using Microsoft's Autodiscovery service. If the server cannot be located, the screen below is shown. Enter your front-end Exchange server's complete address in the Server field. Contact your Exchange server administrator if you are unsure of the address.
    any help or being pushed in the right direction would be greatly apperciated!!

    Your college IT people would have to have "enabled" iPhone connections to their Exchange servers, it's quite possible they have not done that. In either case, contact your college IT people to determine if they even allow this and, if they do, the Exchange server info you need to enter. They are the key.

  • Need Help: Apache Server

    I have an online game, and I needed a webserver for it. I asked around, people said that apache was good, and so I downloaded it. I have it in front of me, but I'm quite lost as to what I'm actually supposed to do to these files to reach my goal.
    I was wondering if one of you out there knew of a very helpful tutorial, or if someone might actually be able to help me personally. Right now I have the client on an ftp server, so people have to download that, then play my game. My only goal is to set up this server so that it will allow players to just click on a link on a website and the client load up for them.
    Thanks for any help. My AIM screen name is ReptileKing234 My MSN handle is [email protected]
    ReptileKing234
    A voice of reason in a world gone mad

    There are different related systems here.
    The Apache server is a static http server which can redirect requests to active web servers. Mostly, though, it's designed to serve fixed html pages
    To do dynamic html generation you need something called a "servlet engine". The older one is called Apache JServe which is solid, but limited and no longer actively supported. The newer one is Jakarta Tomcat see http://jakarta.apache.org. There's a lot of online documention on that site. Tomcat can be used on it's own or with requests relayed through the apache server.

  • Need Help: TS130 Server and Windows Server 2008 R2 64 Bit Problems

    I have 2 TS 130 Lenovo Servers with Xeon 3.2 Ghz CPUs and 16GB of memory. Installing ANY version of Windows 64 Bit after a couple of reboots will cause the system to blue screen. Once it blue screens it is impossible to get back into Windows.
    Get this. Installing ANY version of Windows 32 bit works just fine on either machine. I have swapped out ram, hard drives, raid on raid off, updated BIOS etc and the same exact issue on both machines. I have swapped out media thinking maybe it was just a bad disk, but after 3 copies of Server 2008 R2 64 and 2 copies of Windows 7 Ultimate 64 and 3 copies of Windows 7 Professional 64 bit and THEN the same problem occurring over and over on BOTH servers.. well needless to say I am pulling mu hair out. These are ALL OEM copies by the way not burned copies.
    I called Lenovo Thinkserver support as we are a partner, and their only suggestion was changing some legacy settings in the BIOS which of course has done nothing. I have changed every setting in the BIOS that I feel it could possibly be and still no joy.
    Thinking it MAY have been a video problem, I have even went so far as to add new video cards to both machines and the problem still exists on both machines. All drivers are latest versions, and I am getting tired of getting everything setup, and then BAM BSOD.. I have been a tech for 25 years, and I have NEVER seen this issue on any machine ever.. 
    As far as the BSODs, one time it will be the language pack error, next time something else, and the next time something else.. no way to nail down the problem.
    I KNOW its a machine error, especially when 32 bit runs fine on either machine, but what it is I have no clue.
    I am hopeful someone here has had the same issue and can tell me what they may have done to solve the problem. It is absolutely driving me up the wall....
    Thanks in advance for ANY help or suggestions.
    Mike at Mitek Computers

    Never mind.. FINALLY found the problem. Even though I swapped out media etc as far as Server 2008 went, I always used the same COA key.. guess what... English media and Japanese key.... snafu on our OEM vendors end I suppose.
    Anyway I was issued a new product/virtual key through Microsoft and it resolved the issue.... stupidest thing I ever saw...
    Mike at Mitek

  • Newbie need help installing server

    Hi Guys
    After a few years of working with Windows based servers and PC’s we have decided to introduce macs into the workplace. They are quite happily working on the windows network at the moment with little problems. But we want to have the macs on a separate network that is purely mac based, so we bought a mac mini server with snow leopard server I’ve been playing around and I’ve cracked DNS, DHCP and firewall. But my main problem is configuring the server to accept email and send email. Does anyone have any suggestions where to start and what i should be looking at, or if there are any good videos or guides about?
    Cheers
    Paul

    Kinda of sorted the problem now but i will post new issue in mail section
    Cheers

  • Need Help with Server Software

    I will be upgrading an old iMac G5 to Leopard, but I would like to know if I can upgrade that to the server software later on in the future if I decide to do so. I would like to use the server software for our office, but I've never used it....
    thanks

    I will be upgrading an old iMac G5 to Leopard, but I would like to know if I can upgrade that to the server software later on in the future if I decide to do so.
    Yes; future Mac OS X Server versions may not work on your computer, but version 10.5 will.
    (35667)

  • Need help with server / client data

    i have a java server that sends strings to a client
    when i use telnet it works fine
    but with a java client it only recieves one line and then disconects
    any ideas?

    post the client and the server code plz

  • This morning i tried to restore my ipod and it said:"the ipod "ipod cannot be restored at this time because the ipod software update server could not be contacted or is temporarily unavalible." i have no idea what to do and i need help

    this morning i tried to restore my ipod and it said:"the ipod "ipod cannot be restored at this time because the ipod software update server could not be contacted or is temporarily unavalible." i have no idea what to do and i need help.

    Update Server
    Try:
    - Powering off and then back on your router.
    - iTunes for Windows: iTunes cannot contact the iPhone, iPad, or iPod software update server
    - Change the DNS to either Google's or Open DNS servers
    Public DNS — Google Developers
    OpenDNS IP Addresses
    - For one user uninstalling/reinstalling iTunes resolved the problem
    - Try on another computer/network
    - Wait if it is an Apple problem

  • I need helping!!! configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.

    I need helping configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.
    I have attempted to configure rdp access but it does not seem to be working for me Could I please ask someone to help me modify my current configuration to allow this? Please do step by step as I could use all the help I could get.
    I need to allow the following IP addresses to have RDP access to my server:
    66.237.238.193-66.237.238.222
    69.195.249.177-69.195.249.190
    69.65.80.240-69.65.80.249
    My external WAN server info is - 99.89.69.333
    The internal IP address of my server is - 192.168.6.2
    The other server shows up as 99.89.69.334 but is working fine.
    I already added one server for Static route and RDP but when I try to put in same commands it doesnt allow me to for this new one. Please take a look at my configuration file and give me the commands i need in order to put this through. Also please tell me if there are any bad/conflicting entries.
    THE FOLLOWING IS MY CONFIGURATION FILE
    Also I have modified IP information so that its not the ACTUAL ip info for my server/network etc... lol for security reasons of course
    Also the bolded lines are the modifications I made but that arent working.
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password DowJbZ7jrm5Nkm5B encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.6.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 99.89.69.233 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group network EMRMC
    network-object 10.1.2.0 255.255.255.0
    network-object 192.168.10.0 255.255.255.0
    network-object 192.168.11.0 255.255.255.0
    network-object 172.16.0.0 255.255.0.0
    network-object 192.168.9.0 255.255.255.0
    object-group service RDP tcp
    description RDP
    port-object eq 3389
    object-group service GMED tcp
    description GMED
    port-object eq 3390
    object-group service MarsAccess tcp
    description MarsAccess
    port-object range pcanywhere-data 5632
    object-group service MarsFTP tcp
    description MarsFTP
    port-object range ftp-data ftp
    object-group service MarsSupportAppls tcp
    description MarsSupportAppls
    port-object eq 1972
    object-group service MarsUpdatePort tcp
    description MarsUpdatePort
    port-object eq 7835
    object-group service NM1503 tcp
    description NM1503
    port-object eq 1503
    object-group service NM1720 tcp
    description NM1720
    port-object eq h323
    object-group service NM1731 tcp
    description NM1731
    port-object eq 1731
    object-group service NM389 tcp
    description NM389
    port-object eq ldap
    object-group service NM522 tcp
    description NM522
    port-object eq 522
    object-group service SSL tcp
    description SSL
    port-object eq https
    object-group service rdp tcp
    port-object eq 3389
    access-list outside_1_cryptomap extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 192.168.0.0 255.255.0.0
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-data
    access-list outside_access_in extended permit udp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-status
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ftp
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ldap
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq h323
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq telnet
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq www
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group SSL
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM522
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM1731
    access-list outside_access_in extended permit tcp 173.197.144.48 255.255.255.248 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp any interface outside eq 3389
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333 object-group rdp
    access-list outside_access_in extended permit tcp any host 99.89.69.333 object-group rdp
    access-list out_in extended permit tcp any host 192.168.6.2 eq 3389
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp 99.89.69.334 3389 192.168.6.1 3389 netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 99.89.69.338 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable
    http 192.168.6.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 68.156.148.5
    crypto map outside_map 1 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 1
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    tunnel-group 68.156.148.5 type ipsec-l2l
    tunnel-group 68.156.148.5 ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:f47dfb2cf91833f0366ff572eafefb1d
    : end
    ciscoasa(config-network)#

    Unclear what did not work.  In your original post you include said some commands were added but don't work:
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    and later you state you add another command that gets an error:
    static (inside,outside) tcp 99.89.69.333 3389 192.168.6.2 3389 netmask 255.255.255.255
    You also stated that 99.89.69.333 (actually 99.89.69.233, guessing from the rest of your config and other posts) is your WAN IP address.
    The first static statement matches Cisco's documentation, which states that a static statement must use the 'interface' directive when you are trying to do static PAT utilizing the IP address of the interface.  Since 99.89.69.333 is the assigned IP address of your WAN interface, that may explain why the second statement fails.
    Any reason why you are using static PAT (including the port number 3389) instead of just skipping that directive?  Static PAT usually makes sense when you need to change the TCP port number.  In your example, you are not changing the TCP port 3389.

  • HT201210 i need help!??? i just tried to update my ipod and now its making me restore it on itunes and it wont complete the restoring process. Its giving the warning that the updated software server couldn't be reached. Can anybody help????

    i need help!??? i just tried to update my ipod and now its making me restore it on itunes and it wont complete the restoring process. Its giving the warning that the updated software server couldn't be reached. Can anybody help????

    Update Server
    Try:
    - Powering off and then back on your router.
    - iTunes for Windows: iTunes cannot contact the iPhone, iPad, or iPod software update server
    - Change the DNS to either Google's or Open DNS servers
    Public DNS — Google Developers
    OpenDNS IP Addresses
    - Try on another computer/network
    - Wait if it is an Apple problem

  • I'm new to SQL Server Integration Services and I need help on how to begin learning SSIS. Is there any training for it besides msdn?

    I'm new to SQL Server Integration Services and I need help on how to begin learning SSIS. Is there any training for it besides msdn?

    Check this thread where people have already given their suggestion on learning SSIS
    http://social.msdn.microsoft.com/Forums/sqlserver/en-US/f2cc1cf3-204d-454a-a189-47df87a3aa23/i-want-to-learn-ssis?forum=sqlintegrationservices
    I would suggest to go for You tube videos (type learn SSIS or begin SSIS step by step) you will get lot of good tutorials to start with.
    Happy Learning!!
    If this post answers your query, please click "Mark As Answer" or "Vote as Helpful".

  • I need help authenticating my outgoing server settings in setting up my work email on my Galaxy S5.  It says unable to authenticate or connect to server and I even called helpdesk at my email support and they tried every possible port (80, 25, 3535 or 465

    I need help authenticating my outgoing server settings in setting up my work email on my Galaxy S5.  It says unable to authenticate or connect to server and I even called helpdesk at my email support and they tried every possible port (80, 25, 3535 or 465 SSL) and none of them work. Please help!

    You will need to get the required info to create/access the account with an email client from your school.
    Are you currently accessing the account with an email client on your computer - if you have a Mac with the Mail.app, or if you have a PC with Outlook Express, etc.? If so, you can get the required account settings there.

  • HELP !!!!!!! i new to OS X Server and need help setting up WINS (in DHCP)

    i Need help on how to setup the WINS part of DHCP
    can any one help ?
    what should my settings be for ?
    WINS/NBNS PRIMARY SERVER:
    WINS/NBNS SECONDARY SERVER:
    NBDD SERVER:
    NBT NODE TYPE:
    netBIOS SCOPE ID:
    i have DNS, SMB, AFP, Open Directory all setup
    just dont get WINS
    kinda old school isnt it ?
    so if some one could help i would be thankful \
    Jono.

    thanks sorry for the "noob" question,
    i am having one problem with windows computers not showing up in finder & on the windows computer the OS X Server wont show up when you go to map a driver. or in vista the "networking" place. but you can type in the IP address of the server and it will find it.
    all the computers are getting DNS and DHCP from the server but i cant figure out what happening.
    there only one server and its OS X leopard 10.5.6
    is this because WINS ? or some thing else
    and sorry for asking i don't really like asking.
    but thanks for the help. ir im being to much of a "noob" just dont reply haha
    Jono.

Maybe you are looking for

  • Query..For...Invoice..and..A/R creditmemo..

    I wann a Query for Total Invoice amount for a particular custmer as well as A/R credit memo Total amount (EX if an custmer having 10 invoice and 5 a/r credit memo's i want sum of the 10 invoce amount as well as a/r credit memo total ). Thanks & Regar

  • Solaris 10 x86 Jumpstart Server

    I have setup everything just like in this document: http://docs.sun.com/app/docs/doc/817-5506/6mkv6kia5?a=view The client machine that I am trying to jumpstart connects fine, shows" 38800" as the prompt and then just stops. After running "snoop" on t

  • Screen control in VA01

    Hi Gurus, I want to include screen control while creating a Sales Order through recording. Basically my requirement is that I have to create a Sales Order through an Idoc which I can achieve by BDC recording, but I want to include a check stating tha

  • System landscape for  DMS Repository in KM

    Hi All, When I create a System Landscape for DMS Repository in KM which sytem template I should choose?Should I choose 'SAP system using dedicated application server' or anything else?

  • Making an editable copy of IRS Instruction worksheets

    I want to make a PDF file out of a single page worksheet from IRS Instructions on Form 4562 and then turn that PDF file into an Excel or Word document from which I can add or remove text.  Is that possible?