Next N Interface

I need to query a database and display above the returned
query results in sets of 10, and have a Next n records interface
like the following:
Now displaying 20 -30 of N Records
<< Previous 1
2 3 4 Next>>
Does anyone know how to do this, or have sample code that
they can post?

It would probably easier to just call this custom tag and let
it handle the
heavy lifting for you.
http://www.olimpo.ch/tmt/tag/querynav/
Bryan Ashcraft (remove brain to reply)
Web Application Developer
Wright Medical Technologies, Inc.
=============================
Macromedia Certified Dreamweaver Developer
Adobe Community Expert (DW) ::
http://www.adobe.com/communities/experts/
"pnugent" <[email protected]> wrote in message
news:e6pnd6$ir3$[email protected]..
>I need to query a database and display above the returned
query results in
>sets
> of 10, and have a Next n records interface like the
following:
>
> Now displaying 20 -30 of N Records
>
> << Previous 1
2 3 4 Next>>
>
> Does anyone know how to do this, or have sample code
that they can post?
>
>

Similar Messages

  • Next n records interfaces

    am having a problem with my next_n records interface.
    I have a query for my index page, so when you click on a
    lettter the appropriate artists are shown....
    see here
    http://www.musicexplained.co.uk/index.cfm
    the query depends on a url variable.
    <cfquery name="results"
    datasource="#APPLICATION.DataSource#">
    SELECT *
    FROM artist_art
    WHERE bandname_art like '#url.firstletter#%'
    </cfquery>
    i am now setting up a next records interface, so you can
    easily browse through the artists who begin with a for example,
    this interface is also dependant on an URL variable....<cfset
    startrownext>
    however, when I click on the next button, see here
    http://www.musicexplained.co.uk/index_list_1.cfm?firstletter=a
    i lose the variable which is powering the index in the first
    place..
    is there anyway round this?
    regards

    Put this near the top of index_list_1.cfm:
    <CFPARAM name="URL.firstletter" type="regex"
    pattern="[a-zA-Z]" default="a">
    <CFPARAM name="URL.startrownext" type="integer"
    default="1">
    Then in all of your pagination links, also include the
    firstletter parameter again:
    <CFOUTPUT>
    <a
    href="#CGI.SCRIPT_NAME#?firstletter=#URL.firstletter#&startrownext=1">First</a>
    <a
    href="#CGI.SCRIPT_NAME#?firstletter=#URL.firstletter#&startrownext=#URL.startrownext
    + 10#">Next</a>
    etc., etc.
    </CFOUTPUT>

  • How to force traffic though a chosen interface in Windows 8.1?

    Windows 8.1 seems to be able to detect dead routes and picks up the default gateway or next best route for routing.
    I have a requirement where I want traffic for specific destinations to "always" go through the Interface that I pick and if that interface is not providing a path from some reason then I want the communication to fail instead of switching to the
    next best interface.
    How do I achieve this? I already tried EnableICMPRedirect and DeadGWDetectDefault registry settings and disabling Auto Metric on the interface through which I want to route this traffic.
    Any clues would help.
    Thanks
    GW

    With PowerShell you should be able to view the applicable routes and modify them accordingly to alter this behavior:
    # you can determine your adapters with
    Get-NetAdapter
    -IncludeHidden
    # then you can see what routes are associated with what adapter interface (lets assume your wifi interface is 4 and your loopback is 1)
    Get-NetRoute
    -AddressFamily IPv4
    # you will get your specific interface index, destination prefix, nexthop and the routemetric
    # you can then set a specific route policy using:
    New-NetRoute
    -DestinationPrefix "200.200.200.200/32"
    -InterfaceIndex 1
    -RouteMetric 256
    New-NetRoute
    -DestinationPrefix "200.200.200.200/32"
    -InterfaceIndex 4
    -NextHop 10.1.1.1
    -RouteMetric 0
    # you can modify the configuration with:
    Set-NetRoute
    -DestinationPrefix "200.200.200.200/32"
    -InterfaceIndex 4
    -NextHop 192.168.10.1
    -RouteMetric 0
    # finally, you can remove the specific route or all the routes with:
    Remove-NetRoute
    -DestinationPrefix "200.200.200.200/32"
    -InterfaceIndex 1
    -Confirm:$false
    Remove-NetRoute
    -DestinationPrefix "200.200.200.200/32"
    -Confirm:$false

  • Audio interface for 24" iMac - conflict between firewire 400 and 800?

    So, what I have now:
    2.8ghz iMac, latest model, newest firmware, running OS 10.4.11, connected to an M-Audio Ozonic Firewire 400 interface, and I was hoping to run said interface while ALSO connecting a firewire 800 hard drive for samples, or for recording to.
    Alas, as soon as I turn on the firewire 800 drive, a model sold by Other World Computing and containing an Oxford chipset, all audio stops on the Ozonic keyboard and is replaced by clicks and pops. The only way I've found to get the audio back is with a complete restart of the system, with the firewire 800 drive OFF.
    For those of you who aren't familiar with the M-Audio device, it's a small keyboard and firewire audio interface in one unit. Perhaps not the highest quality, but my Powerbook G4 1.67 with firewire 800 CAN run both the Ozonic and the firewire 800 drive at the same time. With no interruption in sound playback.
    I did some research and discovered that in the iMac I bought, the two firewire channels, 400 and 800, appear to be on the same PCI E bus, and perhaps will NEVER work together.
    Is that right? I thought the whole point of firewire was how it's able to negotiate such communications and work seamlessly with other firewire devices. I know, I know, I'm living in dreamland, it's just sad that a much older Apple product (my PPC notebook), can do something a brand new model cannot. Sigh.
    Any advice? Any chance 10.5 fixes this?
    If not, should my next audio interface be USB 2.0? Any thoughts from the Audio pros out there (besides 'you bought the wrong machine) would be great.

    Sorry I can't help with your specific query as I have never used that Audio hardware.
    I am a video man myself and went for the 24" 2.8Ghz iMac as i believe the Firewire 400 and 800 Buses are seperate. I know on older iMacs and even the MacPro the FW800 and 400 buses were on the same bus and when connecting a firewire video camera to the FW400 bus, the 800 would lower it's speed to 400 to accomodate or in some cases would lose the connection all together.
    I currently have a FW800 Hard drive connected to the FW800 port and a video deck in the FW400 port and they both run at full speed 800/400 respectively.
    This leads me to believe Apple have fixed the Firewire sharing problem.
    I know it's no help but just though I would share my experience with the Firewire on the new iMac.

  • Failed to get DHCP response on interface "Marking interface dirty"

    Dears
    i have WLC 5508 showing the below Logs , which prevent the users from connecting to the SSIDs , also its disconnecting the associted users
    DHCP Socket Task: Jul 11 09:54:08.992: %SIM-3-DHCP_SERVER_NO_REPLY: sim_interface.c:1039 Failed to get DHCP response on interface 'interface-02'. Marking interface dirty.
    *mmListen: Jul 11 09:54:08.638: %MM-3-INVALID_PKT_RECVD: mm_listen.c:7671 Received an invalid packet from 10.21.1.25. Source member:0.0.0.0. source member unknown.
    it shows 3 to 4 times durring 1 hour ,        
    any idea about the problem , and what exactly Dirty interface means ??

    looks like you could be using interface group.
    (WLC) >show interface group detailed
    Interface marked with * indicates DHCP dirty interface.
    whenever the existing interface goes dirty does the client tries the next available interface for dhcp.
    The idea of Interface Groups is that you can have a WLAN utilize multiple interfaces/VLANs/Subnets/DHCP Pools, either for load balancing. At its heart it is purely round robin or based on hash generated using mac address(it depends on the wlc code), but should a client connect in on a certain interface and not be able to complete the DHCP process we mark it as dirty for 30 minutes.  During those 30 minutes we basically remove that Interface from the Interface Group as it won't be selected for use.

  • Purpose of Interface controller

    Hi,
    What is the purpose of Interface controller in webdynpro?

    hi
    Interface Controllers
    Interface Controller
    One Web Dynpro Component may declare the use of another Web Dynpro Component to form a “Parent-Child” usage relationship. In such cases, the only point of interaction between the parent and child components is the functionality found in the child’s interface controller.
    There is a usage declaration arrow pointing from the component controller to a child component. Notice that the arrow joins the child component at the top right-hand corner. This is the location of the child’s interface controller.
    At no time does the Web Dynpro Runtime interact with a component’s interface controller. It is only ever used to form a Parent-Child relationship between two Web Dynpro Components.
    SAP strongly recommends that no application coding be written directly into the methods of the interface controller. Instead, the public methods of the interface controller should simply delegate their functionality to a method of the same name in the component controller. This will greatly reduce the conversion task required when upgrading to the next release
    Interface View Controller
    The visual interface of a Web Dynpro component is supplied via the Interface View. This behaves much like a UI element in so much that it can be embedded into the view layout of a parent view as a single, reusable entity.
    Once the interface view of the child component has been embedded into a view layout belonging to the parent component, the parent component then has programmatic access to the visual interface of the child component through the child’s interface view controller.
    you can also see more details in this link
    http://help.sap.com/saphelp_nw04/helpdata/en/9c/a5863f455f3417e10000000a114084/frameset.htm
    Regards
    Chandran S

  • Unable to add vrf to Vlan interface

    Running 3750 in stack Version 15.0(2)SE2
    I am geting error when trying to add vrf vlan int
    switch(config)#interface Vlan101
    switch(config-if)#ip vrf forwarding dummy
    % CEF table 0x6 does not exist (Vlan101).
    switch(config-if)#^Z
    Please help

    Yes Cef is by default on the switch i believe
    switch#sh ip cef
    Prefix               Next Hop             Interface
    0.0.0.0/0            10.34.68.1           FastEthernet0
    0.0.0.0/8            drop
    0.0.0.0/32           receive
    10.34.68.0/24        attached             FastEthernet0
    10.34.68.0/32        receive              FastEthernet0
    10.34.68.1/32        attached             FastEthernet0
    10.34.68.2/32        attached             FastEthernet0
    10.34.68.11/32       attached             FastEthernet0
    10.34.68.13/32       attached             FastEthernet0
    10.34.68.14/32       attached             FastEthernet0
    10.34.68.15/32       receive              FastEthernet0
    10.34.68.255/32      receive              FastEthernet0
    10.145.172.0/32      receive              Virtual3
    127.0.0.0/8          drop
    224.0.0.0/4          drop
    224.0.0.0/24         receive
    240.0.0.0/4          drop
    255.255.255.255/32   receive

  • Cdp neighbor IP address & Vlan interfaces

    Hi,
    No problem here, but I got curious after noticing an unexpected IP address in cdp neighborhood output.
    We use Vlan999 for management vlan. Usually I see a Vlan999 ip address in cdp neighbors. Today, instead, I see a Vlan2 ip address for one of our 4506's. (cdp neighbor command executed on a 3550. connection between 3550 and 4506 is trunk.)
    I look around some more, discover that most switches only have Vlan999 configured. The unusual switch has many vlans configured, starting with Vlan2 (Vlan1 is shutdown).
    (And that makes sense. We have 5 sites. This 4506, with native IOS, is site core at a small site - all other site cores are 6509 with CatOS/IOS.)
    So, it appears to me that CDP sees the IP address of the lowest interface it finds at the other end of a trunk.
    Is that correct?

    If it's straight L2 device, then this is true since there is no other interface but the "management interface". but on platforms like 3550 or any other platfrom that is L3 capable and where it has multiple interface vlans, it will send the interface vlan with the lowest interface vlan number in the CDP information. After, all the interfaces are in effect the "management interface", you cannot expect it to send all those information on all of those interfaces, it has to chose one. If the lowest interface vlan is shut down it will send the next lowest interface vlan. so, this is normal for a trunk port. Now, if it's an access port the ip address showing for the neighbor will be the ip address of the interface vlan for that vlan.

  • How to find all routes that are going out an interface in IOS-XR.

    Hi all,
    So if I have the following set up in IOS:
    interface GigabitEthernet7/0/0.265
    encapsulation dot1Q 265
    ip vrf forwarding test
    ip address 1.1.1.1 255.255.255.252
    ip verify unicast reverse-path
    end
    ip route vrf Apollo 2.2.2.0 255.255.255.248 1.1.1.2
    I can see all the routes that are going out the interface using show ip cef command:
    ios-router#show ip cef vrf test GigabitEthernet7/0/0.265
    2.2.2.0/29
      nexthop 1.1.1.2 GigabitEthernet7/0/0.265
    1.1.1.0/30
      attached to GigabitEthernet7/0/0.265
    1.1.1.2/32
      attached to GigabitEthernet7/0/0.265
    In case of IOS-XR (ASR9K 4.3.2 or 4.3.1) the same setup and command shows only
    attached routes:
    router static
    vrf test
      address-family ipv4 unicast
       2.2.2.0/29 1.1.1.2
    RP/0/RSP0/CPU0:TST_riga-sb7-pe-asr9#show cef vrf test bundle-ether2.265
    Prefix              Next Hop            Interface
    1.1.1.0/30          attached            Bundle-Ether2.2220333
    1.1.1.0/32          broadcast           Bundle-Ether2.2220333
    1.1.1.1/32          receive             Bundle-Ether2.2220333
    1.1.1.2/32          1.1.1.2             Bundle-Ether2.2220333
    1.1.1.3/32          broadcast           Bundle-Ether2.2220333
    Is there any command to see all the routes that are going out an interface without complicated parsing
    of the configuration, recursive show cef commands etc.?

    You can accomplish this with the "show route" command.  Here is an example:
    P/0/RSP1/CPU0:ASR9006-E#sh route next-hop tenGigE 0/3/0/2
    Tue Oct  8 15:34:58.046 UTC
    Codes: C - connected, S - static, R - RIP, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
           U - per-user static route, o - ODR, L - local, G  - DAGR
           A - access/subscriber, - FRR Backup path
    Gateway of last resort is 172.18.87.1 to network 0.0.0.0
    D    10.95.248.1/32 [90/128512] via 10.129.56.210, 4d00h, TenGigE0/3/0/2
    C    10.129.56.208/30 is directly connected, 4d00h, TenGigE0/3/0/2
    L    10.129.56.209/32 is directly connected, 4d00h, TenGigE0/3/0/2
    O    10.242.142.240/30 [110/20] via 10.129.56.210, 3d11h, TenGigE0/3/0/2
                           [110/20] via 10.129.56.214, 3d11h, TenGigE0/3/0/3
    D    192.168.1.16/32 [90/128512] via 10.129.56.210, 4d00h, TenGigE0/3/0/2
    D    192.168.20.39/32 [90/128512] via 10.129.56.210, 4d00h, TenGigE0/3/0/2
    RP/0/RSP1/CPU0:ASR9006-E#
    Thanks,
    Bryan

  • How can I rename buttons in dialog popup ?

    Hello.
    I want rename buttons "OK", "Cancel" with my names in popups.
    I create new values in domen WDR_POPUP_BUTTON_KIND
    Next enhance interface IF_WD_WINDOW with new attributes:
    CO_BUTTON_CP type WDR_POPUP_BUTTON_KIND
    But i have problem in CL_WDR_INTERNAL_WINDOW->IF_WD_WINDOW~SET_BUTTON_KIND:
      case me->buttons-button_kind.
        when co_buttons_abortretryignore.
          wa_button-button      = co_button_abort.
          wa_button-button_text = cl_wdr_texts=>get_text( '201' ).
          wa_button-tooltip     = cl_wdr_texts=>get_text( '201' ).
          wa_button-is_enabled  = abap_true.
    This code show only predefined type of buttons can use. 
    How can I rename buttons in dialog popup ?

    When you subscribe to button event  you can rename the button
    * Popup
      DATA lo_window_manager TYPE REF TO if_wd_window_manager.
      DATA lo_api_component  TYPE REF TO if_wd_component.
      DATA lo_window         TYPE REF TO if_wd_window.
      lo_api_component  = wd_comp_controller->wd_get_api( ).
      lo_window_manager = lo_api_component->get_window_manager( ).
      lo_window         = lo_window_manager->create_window(
        window_name          = 'W_POPUP'
        message_display_mode = if_wd_window=>co_msg_display_mode_selected
        button_kind          = if_wd_window=>co_buttons_ok
        message_type         = if_wd_window=>co_msg_type_none
        default_button       = if_wd_window=>co_button_ok
      DATA:  l_api TYPE REF TO if_wd_view_controller.
      l_api = wd_this->wd_get_api( ).
    " subscribe to button event
      lo_window->subscribe_to_button_event(
                   button            = if_wd_window=>co_button_ok
                   BUTTON_TEXT       = u2018Approveu2019 " renaming the button text
                   action_name       = 'ON_OK_POPUP'
                   action_view       = l_api
                   is_default_button = abap_true ).
      lo_window->open( ).
    Radhika

  • Problem with JTextArea or is it my code, Help!!!

    Hi,
    I am going crazy. I am sending a message to a JTextArea and I get some very wierd things happening? I really need help because this is driving me crazy. Please see the following code to see my annotations for the problems. Has anyone else experienced problems with this component?
    Thanks,
    Steve
    // THIS IS THE CLASS THAT HANDLES ALL OF THE WORK
    public class UpdateDataFields implements ActionListener {     // 400
         JTextArea msg;
         JPanel frameForCardPane;
         CardLayout cardPane;
         TestQuestionPanel fromRadio;
         public UpdateDataFields( JTextArea msgout ) {     // 100
              msg = msgout;
          }       // 100
         public void actionPerformed(ActionEvent evt) {     // 200
              String command = evt.getActionCommand();
              String reset = "Test of reset.";
              try{
                   if (command.equals("TestMe")){     // 300
                        msg.append("\nSuccessful");
                        Interface.changeCards();
                        }     // 300
              catch(Exception e){
                   e.printStackTrace();
              try{
                   if (command.equals("ButtonA")){     // 300
    // WHEN I CALL BOTH OF THE FOLLOWING METHODS THE DISPLAY WORKS
    // BUT THE CHANGECARDS METHOD DOES NOT WORK.  WHEN I COMMENT OUT
    // THE CALL TO THE DISPLAYMESSAGE METHOD THEN THE CHANGECARDS WORKS
    // FINE.  PLEASE THE INTERFACE CLASS NEXT.
                        Interface.changeCards();
                        Interface.displayMessage("test of xyz");
                        }     // 300
              catch(Exception e){
                   e.printStackTrace();
         }     // 200
    }     // 400
    // END OF UPDATEDATAFIELS  END END END
    public class Interface extends JFrame {     // 300
         static JPanel frameForCardPane;
         static CardLayout cardPane;
         static JTextArea msgout;
         TestQuestionPanel radio;
         Interface () {     // 100
              super("This is a JFrame");
            setSize(800, 400);  // width, height
            setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
              // set-up card layout
              cardPane = new CardLayout();
              frameForCardPane = new JPanel();     // for CardLayout
              frameForCardPane.setLayout(cardPane);     // set the layout to cardPane = CardLayout
              TestQuestionPanel cardOne = new TestQuestionPanel("ABC", "DEF", msgout, radio);
              TestQuestionPanel cardTwo = new TestQuestionPanel("GHI", "JKL", msgout, radio);
              frameForCardPane.add(cardOne, "first");
              frameForCardPane.add(cardTwo, "second");
              // end set-up card layout
              // set-up main pane
              // declare components
              msgout = new JTextArea( 8, 40 );
              ButtonPanel commandButtons = new ButtonPanel(msgout);
              JPanel pane = new JPanel();
              pane.setLayout(new GridLayout(2, 4, 5, 15));             pane.setBorder(BorderFactory.createEmptyBorder(30, 20, 10, 30));
              pane.add(frameForCardPane);
                 pane.add( new JScrollPane(msgout));
                 pane.add(commandButtons);
              msgout.append("Successful");
              setContentPane(pane);
              setVisible(true);
         }     // 100
    // HERE ARE THE METHODS THAT SHOULD HANDLE THE UPDATING
         static void changeCards() {     // 200
                   cardPane.next(frameForCardPane);
                   System.out.println("Calling methods works!");
         }     // 200
         static void displayMessage(String test) {     // 200
                   String reset = "Test of reset.";
                   String passMessage = test;
                   cardPane.next(frameForCardPane);
                   System.out.println("Calling methods works!");
                   msgout.append("\n"+ test);
         }     // 200
    }     // 300

    Hi,
    I instantiate it in this class. Does that change your opinion or the advice you gave me? Please help!
    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    class CardLayoutQuestionsv2 {
        public static void main(String[] arguments) {
            JFrame frame = new Interface();
            frame.show();
    }

  • Vlan not active in a domain, how can be changed it?

    Hello everybody,
    I have a port-channel connecting 2 Catalyst 6509 working as a trunk with next configuration:
    interface Port-channel1
     description INTERCONEX
     switchport
     switchport trunk encapsulation dot1q
     switchport mode trunk
     no ip address
     mls qos trust dscp
    end
    From this configuration, it is supposed all vlans are passing by the trunk, but when I check the etherchannel better:
    CENTRAL-1#sh inter port-channel 1 trunk
    Port          Mode         Encapsulation  Status        Native vlan
    Po1           on           802.1q         trunking      1
    Port          Vlans allowed on trunk
    Po1           1-4094
    Port          Vlans allowed and active in management domain
    Po1           1,3-5,7-11,15,20-25,49-50,70,100,115,132,147,168,208,215-217,225
    Port          Vlans in spanning tree forwarding state and not pruned
    Po1           1,3-5,7-11,15,20-25,49-50,70,100,115,132,147,168,208,215-217,225
    vlan 10 seems not to be active, although it is in fact. Traffic is being routed to this vlan and it appears as active in a "show vlan brief".
    I have tried to forcé the vlan 10 to be configured in the trunk with a "switchport trunk allowed vlan add 10" and "switchport trunk allowed vlan all", but it does not change, it does not make any difference.
    Could anybody help me with this?
    Thank you very much.
    ***************************29/04/14
    Hi guys,
    I can't answer to your replies, it is not allowed for me to do it (that is why I am changing my question). Well, I have rated pompeychimes' answer as correct as it is. I have not noticed that indeed vlan 10 is included. I have mismatched this as I had some problems with this vlan. Sorry for the mistake. This is not a problem. I did not realize.
    Dbloom, yes, there are several ports on this vlan in the "sh vlan br" and it appears as active (simply I have mismatched with the output of "sh int port-channel 1 trunk", maybe a bit swamped with the original problem which was other).
    One question:
    When you rate an answer as correct, is it possible to answer replies? For me, the space to do it, appears as grey and it is not permitted to enter any text. I attach an image as it appears.
    Thank you for being so quick in your replies!!!!

    Looks like its forwarding from your output...
    Port          Vlans in spanning tree forwarding state and not pruned
    Po1           1,3-5,7-11,15,20-25,49-50,70,100,115,132,147,168,208,215-217,225
    Maybe i misunderstood the question?

  • Not working multitopology ISIS with IOS and IOS-XR

    Hi everyone,
    I've gon a problem setting up IPv6 routing with ISIS in the test network. There are four routers connected as shown on the image. 
    I've got problems setting up IPv6 routing in this topology. I tried single topology and multitopology ISIS. Neither of them works properly. Single topology simple does not come up when IPv6 is configured in ISIS. Multitopology yet comes up but uyields only working IPv4 roting. I can see that IPv6 ISIS RIB is buit by the routers, but it is not copied into the main routing table.
    That's what I get in the multitopology mode:
    All neignors are up. 
    R2#show isis neighbors
    Tag null:
    System Id      Type Interface   IP Address      State Holdtime Circuit Id
    R7             L1   Et0/2       2.2.27.7        UP    7        R7.04            
    R8             L1   Et0/1       2.2.28.8        UP    9        R8.03            
    R9             L1   Et0/0       2.2.29.9        UP    7        R9.01 
    Database in consistent on all four routers
    R2#show isis database
    Tag null:
    IS-IS Level-1 Link State Database:
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R2.00-00            * 0x0000001C   0x21DD        727               0/0/0
    R7.00-00              0x00000011   0xF6EF        866               0/0/0
    R7.04-00              0x00000007   0x5CD2        1117              0/0/0
    R8.00-00              0x0000000B   0xD2EA        941               0/0/0
    R8.01-00              0x00000006   0xF0C3        878               0/0/0
    R8.03-00              0x00000006   0x7E39        805               0/0/0
    R9.00-00              0x0000000B   0x4071        817               0/0/0
    R9.01-00              0x00000006   0x8D2A        783               0/0/0
    R9.03-00              0x00000006   0xE3CC        840               0/0/0
    ISIS IPv6 RIB contains only local prefixes
    R2#show isis ipv6 rib
    IS-IS IPv6 process , local RIB
      2002:2:2::7/128
      2002:2:2:27::/64
      2002:2:2:78::/64
      2002:2:2:79::/64
    IPv6 topology is not complete as if R8 and R9 were not in database
    R2#show isis ipv6 topology 
    Tag null:
    IS-IS TID 2 paths to level-1 routers
    System Id            Metric     Next-Hop             Interface   SNPA
    R2                   --
    R7                   10         R7                   Et0/2       0202.5a00.b120
    R8                   **
    R9                   **
    A closer look at isis database:
    R2#show isis database detail
    Tag null:
    IS-IS Level-1 Link State Database:
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R2.00-00            * 0x0000001D   0x1FDE        1004              0/0/0
      Area Address: 47.0002
      Topology:     IPv4 (0x0)
                    IPv6 (0x2)
      NLPID:        0xCC 0x8E
      Hostname: R2
      IP Address:   2.2.0.2
      Metric: 10         IP 2.2.0.2/32
      Metric: 10         IP 2.2.29.0/24
      Metric: 10         IP 2.2.28.0/24
      Metric: 10         IP 2.2.27.0/24
      IPv6 Address: 2002:2:2::2
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:29::/64
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:28::/64
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:27::/64
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2::2/128
      Metric: 10         IS-Extended R7.04
      Metric: 10         IS-Extended R8.03
      Metric: 10         IS-Extended R9.01
      Metric: 10         IS (MT-IPv6) R7.04
      Metric: 10         IS (MT-IPv6) R8.03
      Metric: 10         IS (MT-IPv6) R9.01
    R7.00-00              0x00000012   0xF4F0        1187              0/0/0
      Area Address: 47.0002
      Topology:     IPv4 (0x0)
                    IPv6 (0x2)
      NLPID:        0xCC 0x8E
      Hostname: R7
      IP Address:   2.2.0.7
      Metric: 10         IP 2.2.0.7/32
      Metric: 10         IP 2.2.78.0/24
      Metric: 10         IP 2.2.79.0/24
      Metric: 10         IP 2.2.27.0/24
      IPv6 Address: 2002:2:2::7
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:78::/64
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:79::/64
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:27::/64
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2::7/128
      Metric: 10         IS-Extended R7.04
      Metric: 10         IS-Extended R8.01
      Metric: 10         IS-Extended R9.03
      Metric: 10         IS (MT-IPv6) R7.04
      Metric: 10         IS (MT-IPv6) R8.01
      Metric: 10         IS (MT-IPv6) R9.03
    R7.04-00              0x00000007   0x5CD2        640               0/0/0
      Metric: 0          IS-Extended R7.00
      Metric: 0          IS-Extended R2.00
    R8.00-00              0x0000000B   0xD2EA        464               0/0/0
      Area Address: 47.0002
      NLPID:        0xCC 0x8E
      Topology:     IPv4 (0x0)
                    IPv6 (0x2)
      Hostname: R8
      IP Address:   2.2.0.8
      IPv6 Address: 2002:2:2::8
      Metric: 10         IS-Extended R8.01
      Metric: 10         IS-Extended R8.03
      Metric: 10         IP 2.2.0.8/32
      Metric: 10         IP 2.2.28.0/24
      Metric: 10         IP 2.2.78.0/24
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2::8/128
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:28::/64
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:78::/64
    R8.01-00              0x00000007   0xEEC4        1155              0/0/0
      Metric: 0          IS-Extended R8.00
      Metric: 0          IS-Extended R7.00
    R8.03-00              0x00000006   0x7E39        328               0/0/0
      Metric: 0          IS-Extended R8.00
      Metric: 0          IS-Extended R2.00
    R9.00-00              0x0000000C   0x3E72        1035              0/0/0
      Area Address: 47.0002
      NLPID:        0xCC 0x8E
      Topology:     IPv4 (0x0)
                    IPv6 (0x2)
      Hostname: R9
      IP Address:   2.2.0.9
      IPv6 Address: 2002:2:2::9
      Metric: 10         IS-Extended R9.01
      Metric: 10         IS-Extended R9.03
      Metric: 10         IP 2.2.0.9/32
      Metric: 10         IP 2.2.29.0/24
      Metric: 10         IP 2.2.79.0/24
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2::9/128
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:29::/64
      Metric: 10         IPv6 (MT-IPv6) 2002:2:2:79::/64
    R9.01-00              0x00000007   0x8B2B        1048              0/0/0
      Metric: 0          IS-Extended R9.00
      Metric: 0          IS-Extended R2.00
    R9.03-00              0x00000007   0xE1CD        1091              0/0/0
      Metric: 0          IS-Extended R9.00
      Metric: 0          IS-Extended R7.00
    I don't understand the following: Why R8 doesn't consider itself attached to Pseudonodes R8.01 and R8.03 in IPv6 topology? The same question about R9 and Pseudonodes R9.01 and R9.03 in IPv6 topology. R7 and R2 consider themselves as attached to Pseudonode R7.04, although R7.04 doesn't look much different from the rest of the Pseudonode LSPs in the database. This fact still doesn't allow them to calculate a correct RIB.
    Am I missing something?
    Configs of the devices is below:
    ######R2########
    service timestamps debug datetime msec
    service timestamps log datetime msec
    hostname R2
    boot-start-marker
    boot-end-marker
    vrf definition ABC
     rd 2:2
     address-family ipv4
     route-target export 2:2
     route-target import 2:2
     route-target import 1002:2
     exit-address-family
    no aaa new-model
    clock timezone PST 0
    ip source-route
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    multilink bundle-name authenticated
    mpls label protocol ldp
    interface Loopback0
     ip address 2.2.0.2 255.255.255.255
     ip router isis
     ipv6 address 2002:2:2::2/128
     ipv6 router isis
    interface Ethernet0/0
     ip address 2.2.29.2 255.255.255.0
     ip router isis
     ipv6 address 2002:2:2:29::2/64
     ipv6 router isis
     mpls ip
    interface Ethernet0/1
     ip address 2.2.28.2 255.255.255.0
     ip router isis
     ipv6 address 2002:2:2:28::2/64
     ipv6 router isis
     mpls ip
    interface Ethernet0/2
     ip address 2.2.27.2 255.255.255.0
     ip router isis
     ipv6 address 2002:2:2:27::2/64
     ipv6 router isis
     mpls ip
    interface Ethernet0/3
     no ip address
     shutdown
    interface Ethernet1/0
     vrf forwarding ABC
     ip address 172.2.142.2 255.255.255.0
    interface Ethernet1/1
     no ip address
     shutdown
    interface Ethernet1/2
     no ip address
     shutdown
    interface Ethernet1/3
     no ip address
     shutdown
    router isis
     net 47.0002.0000.0000.0002.00
     is-type level-1
     metric-style wide
     address-family ipv6
      multi-topology
     exit-address-family
    router rip
     version 2
     address-family ipv4 vrf ABC
      redistribute bgp 2 metric 1
      network 172.2.0.0
      no auto-summary
      version 2
     exit-address-family
    router bgp 2
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 2.2.0.9 remote-as 2
     neighbor 2.2.0.9 update-source Loopback0
     address-family ipv4
      no synchronization
      network 2.2.0.2 mask 255.255.255.255
      neighbor 2.2.0.9 activate
      neighbor 2.2.0.9 send-community
      no auto-summary
     exit-address-family
     address-family vpnv4
      neighbor 2.2.0.9 activate
      neighbor 2.2.0.9 send-community extended
      neighbor 2.2.0.9 next-hop-self
     exit-address-family
     address-family ipv4 vrf ABC
      no synchronization
      redistribute rip
     exit-address-family
    no ip http server
    mpls ldp router-id Loopback0
    control-plane
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
    line aux 0
    line vty 0 4
     login
    end
    ######R7########
    service timestamps debug datetime msec
    service timestamps log datetime msec
    hostname R7
    boot-start-marker
    boot-end-marker
    vrf definition ABC
     rd 2:2
     address-family ipv4
     route-target export 2:2
     route-target import 2:2
     route-target import 1002:2
     exit-address-family
    no aaa new-model
    clock timezone PST 0
    ip source-route
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    multilink bundle-name authenticated
    mpls label protocol ldp
    interface Loopback0
     ip address 2.2.0.7 255.255.255.255
     ip router isis
     ipv6 address 2002:2:2::7/128
     ipv6 router isis
    interface Ethernet0/0
     ip address 2.2.78.7 255.255.255.0
     ip router isis
     ipv6 address 2002:2:2:78::7/64
     ipv6 router isis
     mpls ip
    interface Ethernet0/1
     ip address 2.2.79.7 255.255.255.0
     ip router isis
     ipv6 address 2002:2:2:79::7/64
     ipv6 router isis
     mpls ip
    interface Ethernet0/2
     ip address 2.2.27.7 255.255.255.0
     ip router isis
     ipv6 address 2002:2:2:27::7/64
     ipv6 router isis
     mpls ip
    interface Ethernet0/3
     no ip address
     shutdown
    interface Ethernet1/0
     vrf forwarding ABC
     ip address 172.2.17.7 255.255.255.0
    interface Ethernet1/1
     no ip address
     shutdown
    interface Ethernet1/2
     no ip address
     shutdown
    interface Ethernet1/3
     no ip address
     shutdown
    interface Serial2/0
     no ip address
     no fair-queue
     serial restart-delay 0
    interface Serial2/1
     no ip address
     shutdown
     serial restart-delay 0
    interface Serial2/2
     no ip address
     shutdown
     serial restart-delay 0
    interface Serial2/3
     no ip address
     shutdown
     serial restart-delay 0
    router ospf 100 vrf ABC
     log-adjacency-changes
     redistribute bgp 2 subnets
     network 172.2.0.0 0.0.255.255 area 0
    router isis
     net 47.0002.0000.0000.0007.00
     is-type level-1
     metric-style wide
     address-family ipv6
      multi-topology
     exit-address-family
    router bgp 2
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 2.2.0.9 remote-as 2
     neighbor 2.2.0.9 update-source Loopback0
     neighbor 2002:2:2::9 remote-as 2
     neighbor 2002:2:2::9 update-source Loopback0
     address-family ipv4
      no synchronization
      network 2.2.0.7 mask 255.255.255.255
      neighbor 2.2.0.9 activate
      neighbor 2.2.0.9 send-community
      no auto-summary
     exit-address-family
     address-family vpnv4
      neighbor 2.2.0.9 activate
      neighbor 2.2.0.9 send-community extended
     exit-address-family
     address-family ipv6
      no synchronization
      network 2002:2:2::7/128
      neighbor 2002:2:2::9 activate
     exit-address-family
     address-family ipv4 vrf ABC
      no synchronization
      redistribute ospf 100 vrf ABC
     exit-address-family
    no ip http server
    mpls ldp router-id Loopback0
    control-plane
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
    line aux 0
    line vty 0 4
     login
    end
    ######R9########
    hostname R9
    telnet vrf default ipv4 server max-servers 100
    username student
     group root-lr
     secret 5 $1$FJX6$23S1vUlkI7nuRNSFMWR8N0
    aaa authentication login default local
    cdp
    vrf ABC
     address-family ipv4 unicast
      import route-target
       2:2
       1002:2
      export route-target
       2:2
    control-plane
     management-plane
      out-of-band
       interface MgmtEth0/0/CPU0/0
        allow Telnet
    interface Loopback0
     ipv4 address 2.2.0.9 255.255.255.255
     ipv6 address 2002:2:2::9/128
    interface MgmtEth0/0/CPU0/0
     ipv4 address 10.0.8.129 255.255.255.0
    interface GigabitEthernet0/2/1/0
     description uplink SW4
    interface GigabitEthernet0/2/1/1
     description uplink R2, R5
    interface GigabitEthernet0/2/1/1.29
     description - VLAN 29 (R2)
     ipv4 address 2.2.29.9 255.255.255.0
     ipv6 address 2002:2:2:29::9/64
     dot1q vlan 29
    interface GigabitEthernet0/2/1/1.59
     description - VLAN 59 (R5)
     vrf ABC
     ipv4 address 172.2.59.9 255.255.255.0
     dot1q vlan 59
    interface GigabitEthernet0/2/1/2
     description uplink R6, R7
    interface GigabitEthernet0/2/1/2.69
     description - VLAN 69 (R6)
     ipv4 address 2.2.69.9 255.255.255.0
     ipv6 address 2002:2:2:69::9/64
     dot1q vlan 69
    interface GigabitEthernet0/2/1/2.79
     description - VLAN 79 (R7)
     ipv4 address 2.2.79.9 255.255.255.0
     ipv6 address 2002:2:2:79::9/64
     dot1q vlan 79
    interface GigabitEthernet0/2/1/3
     shutdown
    interface GigabitEthernet0/2/1/4
     shutdown
    interface POS0/2/0/0
     shutdown
    interface POS0/2/0/1
     shutdown
    interface POS0/2/0/2
     shutdown
    interface POS0/2/0/3
     shutdown
    route-policy default_policy_pass_all
      pass
    end-policy
    router static
     address-family ipv4 unicast
      2.2.69.6/32 GigabitEthernet0/2/1/2.69
    router isis abc
     is-type level-1
     net 47.0002.0000.0000.0009.00
     address-family ipv4 unicast
      metric-style wide
     interface Loopback0
      address-family ipv4 unicast
      address-family ipv6 unicast
     interface GigabitEthernet0/2/1/1.29
      address-family ipv4 unicast
      address-family ipv6 unicast
     interface GigabitEthernet0/2/1/2.79
      address-family ipv4 unicast
      address-family ipv6 unicast
    router bgp 2
     address-family ipv4 unicast
      network 2.2.0.9/32
     address-family vpnv4 unicast
     address-family ipv6 unicast
      network 2002:2:2::9/128
     address-family vpnv6 unicast
     neighbor 2.2.0.2
      remote-as 2
      update-source Loopback0
      address-family ipv4 unicast
       next-hop-self
      address-family vpnv4 unicast
       route-reflector-client
     neighbor 2.2.0.7
      remote-as 2
      update-source Loopback0
      address-family ipv4 unicast
       next-hop-self
      address-family vpnv4 unicast
       route-reflector-client
       next-hop-self
      address-family ipv6 unicast
       next-hop-self
      address-family vpnv6 unicast
       next-hop-self
     neighbor 2.2.0.8
      remote-as 2
      update-source Loopback0
      address-family ipv4 unicast
       next-hop-self
      address-family vpnv4 unicast
       route-reflector-client
       next-hop-self
     neighbor 2.2.69.6
      remote-as 1002
      address-family ipv4 unicast
       route-policy default_policy_pass_all in
       route-policy default_policy_pass_all out
      address-family vpnv4 unicast
       route-policy default_policy_pass_all in
       route-policy default_policy_pass_all out
     neighbor 2002:2:2::7
      remote-as 2
      update-source Loopback0
      address-family ipv6 unicast
       next-hop-self
     neighbor 2002:2:2:69::6
      remote-as 1002
      address-family ipv6 unicast
       route-policy default_policy_pass_all in
       route-policy default_policy_pass_all out
     vrf ABC
      rd 2:2
      address-family ipv4 unicast
       redistribute eigrp 100
    mpls ldp
     router-id 2.2.0.9
     interface GigabitEthernet0/2/1/1.29
     interface GigabitEthernet0/2/1/2.79
    router eigrp 100
     vrf ABC
      address-family ipv4
       default-metric 100000 10 250 1 1500
       autonomous-system 100
       redistribute bgp 2
       interface GigabitEthernet0/2/0/1.59
       interface GigabitEthernet0/2/1/1.59
    end
    ######R8########
    hostname R8
    telnet vrf default ipv4 server max-servers 100
    username student
     group root-lr
     secret 5 $1$Y39m$k.fAmjkI6OEFDmiIfSkGt1
    aaa authentication login default local
    cdp
    vrf ABC
     address-family ipv4 unicast
      import route-target
       2:2
       1002:2
      export route-target
       2:2
    control-plane
     management-plane
      out-of-band
       interface MgmtEth0/0/CPU0/0
        allow Telnet
    interface Loopback0
     ipv4 address 2.2.0.8 255.255.255.255
     ipv6 address 2002:2:2::8/128
    interface MgmtEth0/0/CPU0/0
     ipv4 address 10.0.8.128 255.255.255.0
    interface GigabitEthernet0/2/1/0
     description uplink SW3
    interface GigabitEthernet0/2/1/1
     description uplink R3, R7
    interface GigabitEthernet0/2/1/1.38
     description - VLAN 38 (R3)
     vrf ABC
     ipv4 address 172.2.38.8 255.255.255.0
     dot1q vlan 38
    interface GigabitEthernet0/2/1/1.78
     description - VLAN 78 (R7)
     ipv4 address 2.2.78.8 255.255.255.0
     ipv6 address 2002:2:2:78::8/64
     dot1q vlan 78
    interface GigabitEthernet0/2/1/2
     description uplink R2, R15
    interface GigabitEthernet0/2/1/2.28
     description - VLAN 28 (R2)
     ipv4 address 2.2.28.8 255.255.255.0
     ipv6 address 2002:2:2:28::8/64
     dot1q vlan 28
    interface GigabitEthernet0/2/1/2.158
     description - VLAN 158 (R15)
     dot1q vlan 158
    route-policy default_policy_pass_all
      pass
    end-policy
    router isis abc
     is-type level-1
     net 47.0002.0000.0000.0008.00
     address-family ipv4 unicast
      metric-style wide
     interface Loopback0
      address-family ipv4 unicast
      address-family ipv6 unicast
     interface GigabitEthernet0/2/1/1.78
      address-family ipv4 unicast
      address-family ipv6 unicast
     interface GigabitEthernet0/2/1/2.28
      address-family ipv4 unicast
      address-family ipv6 unicast
    router bgp 2
     address-family ipv4 unicast
      network 2.2.0.8/32
     address-family vpnv4 unicast
     neighbor 2.2.0.9
      remote-as 2
      update-source Loopback0
      address-family ipv4 unicast
       next-hop-self
      address-family vpnv4 unicast
     vrf ABC
      rd 2:2
      address-family ipv4 unicast
       network 172.2.38.0/24
       allocate-label all
      neighbor 172.2.38.3
       remote-as 123
       address-family ipv4 unicast
        route-policy default_policy_pass_all in
        route-policy default_policy_pass_all out
        as-override
        send-extended-community-ebgp
    mpls ldp
     router-id 2.2.0.8
     interface GigabitEthernet0/2/1/1.78
     interface GigabitEthernet0/2/1/2.28
    end
    RP/0/0/CPU0:R8#

    Hello,
    Can you check on XR that you have option of enabling metric-style wide under ipv6 address-family.I'm not sure but i suppose you will also need to configure metric-style wide under ipv6 address-family as you are using multi-topology .IOS default run single topology and XR run default multi-topology.only need to be sure that you are running same topology and metric-style same on all router,in transition process like from multi to single or changing metric-style you can use "metric-style transition" option..
    Regards,
    Ashish

  • How to omit component's coordinates in xml serialisation

    Hi colleagues,
    my application uses XMLEncoder to serialize JPanel component (it's coordinates). The generated XML is like this:
    <object class="MyJPanel">
    <void property="bounds">
    <object class="java.awt.Rectangle">
    <int>28</int>
    <int>93</int>
    <int>227</int>
    <int>162</int>
    </object>
    </void>
    </object>
    Coordinates are measured in pixels. It is problem for me. I need to serialize component's coordinates in some screen independent measurement. E.g. in milimeters. I can add properties for bounds representation of the components in milimeters. But I do know, how to OMIT default bounds pixels serialization. I.e. I would like to receive serialization like this:
    <object class="sk.gnome.sf9.Block">
    <void property="widthInMilimeters">
    <double>100</double>
    </void>
    <void property="heightInMilimeters">
    < double >130</double >
    </void>
    </object>
    I did some experiments with extending the SimpleBeanInfo class, but nothing was successful. Can anybody give some advice?

    Hi,
    If you wish to change the Default serialization behaviour then you have to override the read and write methods provided when you implemented Serializable.
    So for example I have my own version of a hashTable which I override the readObject and writeObject methods,,, take a look at the JPanel source to see how it saves and restores the object. If no behaviour is defined then assume that EVERY global object/primitive which is not "transient" is being saved.
    //** Serializable interface, write
    private synchronized void writeObject(ObjectOutputStream lOOS) throws IOException
         // Write out the threshold and loadfactor
         lOOS.defaultWriteObject();
         // Write out length, count of elements and then the key/value objects
         lOOS.writeInt(table.length);
         lOOS.writeInt(size);
         for (int lCount = table.length - 1; lCount >= 0; lCount--)
         DataRListEntry lEntry = table[lCount];
         while (lEntry != null)
              lOOS.writeObject(lEntry.value);
              lEntry = lEntry.next;
    //** Serializable interface, read
    private void readObject(ObjectInputStream lOIS) throws IOException, ClassNotFoundException
         // Read in the threshold and loadfactor
         lOIS.defaultReadObject();
         // Read the original length of the array and number of elements
         int lLength = lOIS.readInt();
         int lSize = lOIS.readInt();
         // Compute new size with a bit of room 5% to grow but
         int lTable = (int)(lSize * loadFactor) + (lSize / 20) + 3;
         if (lTable > lSize && (lTable & 1) == 0) lTable--;
         if (lLength > 0 && lTable > lLength) lTable = lLength;
         table = new DataRListEntry[lTable];
         size = 0;
         // Read the number of elements and then all the key/value objects
         for (; lSize > 0; lSize--)
         Object value = lOIS.readObject();
         put(value);
    }

  • DataGrid limit on amount of records or data?

    Hi.
    Im using flex with a hibernate backend.
    I have tables in a db that Id like to show using Datagrid.
    I have done tests and found that there is a limit to the
    number of
    records shown in the datagrid.
    Is this a limitation of the datagrid?
    How do I get around this?
    I currently am able to show around 5000 records.
    When I have tables of say 10000 or 100000 records, how do I
    show them?
    Thanks.
    Kind regards.
    Luke.

    Wow! That's a lot of records on one grid. You are going to
    want to start paging your data.
    The short answer is only pass in as many records as you can
    reasonably View in your grid. Cache the rest on the server in a
    queue waiting for retrieval.
    When the user scrolls down close to the last record (say
    within 25 records from the end of the loaded records) you can be
    removing a chunk of records from the top of the dataprovider and
    moving them into a shared object or other storage for easy
    retrieval and at the same time downloading more records from the
    queue cached on the server.
    Not the HOW portion of how you do that depends greatly on the
    technology you use on the server and unfortunately I have no
    experience with Hibernate. Sorry. Still as long as you know how to
    cache a query on the server it should not be too hard. Think of it
    like an automated Next N interface for your grid.
    Much faster load times also as you are never sending fewer
    records to your grid at any one time.

Maybe you are looking for