O/R mapping and datastore identity

Hi all,
we are currently trying to map an existing database schema to JDO. We have
not been able to map "correctly" to the existing schema in two
different cases. Any input that you may have to us on this is highly
appreciated.
Inheritance with indicators
In one part of the model, we use a single character indicator to
distinguish between which concrete class is to be instantiated. We
thus have a table A with columns:
type varchar2(1)
id number(10)
Other tables relate to this table. Some tables can only relate to some
types. To ensure that the relational model
expresses the correct constraints about which objects can relate to
one another, all our foreign keys include both the type and the
id. Still, the id is taken from a sequence and should be considered
datastore identity.
When mapping this to Kodo JDO, we cannot make (type,id) the primary
key and have datastore identity. We have had to compromise and use
just the id as the primary key (which is in fact unique "by
convention"). This in turn means that we cannot use (type,id) as the
reference from other tables (e.g. B), since a lookup from A to B then
includes the A table in the SQL fired just to get the correct type.
Are we missing something here? I would assume that this would be a
normal problem if using datastore identity and flat inheritance
mapping. And in fact, Kodo must know the value of the type for any A
object, since it has the instance and can simply relate the class to
the type through the metadata (however, this only partly solves the
problem). Is there a workaround we can use? Can we extend the primary
key/reference support to support this ourselves?
Sub-objects
In another part of our model, we have a table C where each record can
have a number of records in a table D:
C:
id number(10)
D:
id number(10)
Cid number(10) (references C.id)
In the database, the primary key for D is (id, Cid). id is drawn from
a sequence and is thus unique "by convention". Other tables relate to
D through (id, Cid), thus we will need a unique index on this.
Again, we have had to make id the primary key of D and let all
relations to it only join on the id field when doing the mapping.
We are reluctant to introduce new indexes in the database since this
will be harmful to our import performance.
Is there a workaround for this, or are we simply not doing this
correctly??

Inheritance with indicators
---------------------------If the type column is part of the primary key, I would suggest using application
identity. You can use extensions like sequence-assigned to still have the id
value auto-assigned.
Sub-objects
-----------Again, I would use application identity.

Similar Messages

  • Exposing pk field in Datastore Identity

    Hi all,
    I was wondering what people's views are on the following -
    Datastore Identity hides the identity value of objects but there are
    cetainly cases where it would be very useful to obtain the PK id as it is in
    the database. My concrete example is we are currently migrating an
    application from "legacy" JDBC to JDO and several areas currently require us
    to convert JDO id classes/strings to simple integer ids and back again (at
    least temporarily until the migration is complete).
    Is it definitely "against the rules" to expose the primary key column in the
    database table as a simple property of the bean? So long as the application
    ensures this id is read-only (no public injector method) can this work?
    Thanks in advance,
    Simon

    While it may work, I don't think its any less vendor-specific than using
    a MyJDOHelper class which can break the String down/casting it to
    ObjectIds.Id, and far less prone to something weird going on.
    The other alternative is to use Application Identity which inherently
    exposes PK fields to whatever you desire.
    Simon Horne wrote:
    ah, but could I actually avoid this vendor specific parsing by exposing the
    id field and mapping it through jdo?
    Simon
    "Stephen Kim" <[email protected]> wrote in message
    news:b403bg$c0l$[email protected]..
    While not necessarily the most vendor neutral (since you need tocast/parse the oid object), there is nothing inherently wrong with that
    method... just be aware of when the identity value is assigned (e.g.
    jdoPostLoad (), makePersistent (), etc..)
    On Mon, 03 Mar 2003 10:17:02 +0000, Simon Horne wrote:
    Hi all,
    I was wondering what people's views are on the following -
    Datastore Identity hides the identity value of objects but there are
    cetainly cases where it would be very useful to obtain the PK id as it
    is in
    the database. My concrete example is we are currently migrating an
    application from "legacy" JDBC to JDO and several areas currentlyrequire us
    to convert JDO id classes/strings to simple integer ids and back again(at
    least temporarily until the migration is complete).
    Is it definitely "against the rules" to expose the primary key column inthe
    database table as a simple property of the bean? So long as theapplication
    ensures this id is read-only (no public injector method) can this work?
    Thanks in advance,
    Simon--
    Stephen Kim
    [email protected]
    SolarMetric, Inc.
    http://www.solarmetric.com
    Stephen Kim
    [email protected]
    SolarMetric, Inc.
    http://www.solarmetric.com

  • Using Crypto Maps and IPsec Static VTI's on the same router

    Is it possible to configure both crypto maps and IPsec static VTI's on the same router? What platforms have this capability? What IOS version do I need?

    Yes you can and as far as I know I dont think there is a hardware dependency.
    VTI mode 'tunnel mode ipsec ipv4' was added in 12.3(14)T.
    If you are mixing tunnel protection and crypto map ensure you use iskmp profiles to differentiate somehow that the tunnel IPSec connection is not prcessed on the crypto map!
    Here is a rough example (fine tune it as needed):
    crypto keyring key1
      pre-shared-key address 1.1.1.1 key test123
    crypto keyring key2
      pre-shared-key address 7.7.7.7 key test777
    crypto isakmp profile vpn1
       keyring key1
       match identity address 1.1.1.1 255.255.255.255
    crypto isakmp profile vpn2
       keyring key2
       match identity address 7.7.7.7 255.255.255.255
    crypto ipsec transform-set test esp-des esp-sha-hmac
    crypto IPsec profile vpn-tunnel
    set transform-set test
    set isakmp-profile vpn1
    crypto map mymap 1 ipsec-isakmp
    set transform-set test
    set peer 7.7.7.7
    set isakmp-profile vpn2
    match address 177
    interface Tunnel0
    ip address 10.0.51.217 255.255.255.0
    tunnel source 2.2.2.2
    tunnel destination 1.1.1.1
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile vpn-tunnel
    interface Ethernet4
    ip add 2.2.2.2 255.255.255.0
    crypto map mymap
    Regards,
    Uwe

  • Diff b/w msg mapping and interface mapping

    hi
      i have some doubt's:
       1. diff b/w msg mapping and interface mapping
       2. What is product in SLD? usually who creates the product,technical,business system??
    thx in advance..

    hI Smartsoft General User  ,
    The following r excellent websites on mapping which differentiate msg mapping and interface mapping in detail:
    Excellent PDF Document on Mapping
    http://help.sap.com/bp_bpmv130/Documentation/Operation/MappingXI30.pdf
    Mapping Development with the ABAP Workbench
    http://help.sap.com/saphelp_nw04/helpdata/en/10/5abb2d9df242f6a62e22e027a6c382/content.htm
    ABAP Mappings
    http://help.sap.com/saphelp_nw04/helpdata/en/ba/e18b1a0fc14f1faf884ae50cece51b/content.htm
    how to create a flat file out of an IDoc-XML by means of an ABAP mapping program and the J2EE File Adapter.
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/46759682-0401-0010-1791-bd1972bc0b8a
    How to Use ABAP Mapping in XI 3.0
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/e3ead790-0201-0010-64bb-9e4d67a466b4
    These r excellent websites in SLD:
    How To…Handle the SLD for SAP XI
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/9e76e511-0d01-0010-5c9d-9f768d644808
    How To…Handle Caches in SAP XI 3.0
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/1a69ea11-0d01-0010-fa80-b47a79301290
    http://www.sap-press.de/download/dateien/751/sap_press_exchange_infra_engl.pdf
    cheers!
    gyanaraj
    ****Pls reward points if u find this helpful

  • What is the diffrence between  map and map.entry in core java

    what is the diffrence between map and map.entry in core java . where it will be use ful. any one give one example plz.

    A Map contains Map.Entry's
    e.g.
            Map map = new LinkedHashMap(8);
            map.put(new Integer(1), "one");
            map.put(new Integer(2), "two");
            final Iterator iterator = map.entrySet().iterator();
            while (iterator.hasNext()) {
                Map.Entry entry = (Map.Entry) iterator.next();
                System.out.println("key=" + entry.getKey() + ", value=" + entry.getValue());
            }

  • Ovi maps and Nokia Maps

    I have recently downloaded the ovi maps update for free navigation on my 5800 however now I seem to have 2 programs in my installed apps menu, Ovi maps and Nokia maps. This is causing me some problems as my phones built in memory is now completely full and I am unable to do some things as I have ran out of on phone memory space. Which one is the main map software? And also can I uninstall one? If not then can it be installed on a MSD card and if yes how?

    As far as I can determine Ovi maps is the mapping software (program) which installs to C (phone memory) and Nokia maps is the map data that you have loaded which I believe are installed to E (mass memory).
    I can confirm that you do need both installed.
    The problem as far as I can see is that the previous maps versions 3.01 is built into the current firmware (v20 for N97 - not sure for 5800) and installing maps 3.03 does not remove or overwrite the earlier version so you end up with both versions installed and thus the extra memory footprint.
    This will remain a problem until a newer firmware is released which will hopefully have maps 3.03 (or later depending when next firmware is released) thus reducing the extra 9 megs or so used.
    Hope this answers your question
    Message Edited by rider5512 on 29-Jan-2010 05:16 AM
    Rider5512

  • What is the best product for network mapping and monitoring? I am an inexperienced user). Mac 10.9.2 laptop

    I have lots of questions, but the gist is that I want to know the best product, preferably from the app store, that I can use for network mapping mapping and monitoring.
    I want to get their mac address or other police trackable etc info so I can use my computer safely.
    I am also being cyberbullied.
    I try just using ethernet but still get intruded on, for instance, messages that "other devices are using my ip address". The only other device I own is an iPod that I keep sahut off plus wifi turned off then.
    (NOTE:  You can skip the rest of this message if you want. It regards hacking attempts etc,  a little out of the scope of discussion, perhaps).
    Also a home intrusion where computer was thoroughly hacked with router(s) set up "very very close to me," according to Apple.
    Also, hackers get into my Facebook and gmail and yahoo mail, really,  no matter what I try to do on my computer and how many times I change passwords it does no good.
    Also,  The ip addresses for google and the one in syste preferences and the one looking up my ip address on ip chicken always gets three different results.
    More worrisome it that hackers got into my Wells Fargo account a week after the intrusion even though I changed all account #'s and pw plus notified bank. They also broke into paypal using my new account numbers.
    Also, stuff like Facetime pops up on my computer without my clicking on it even though I'm using ethernet to connect. I've given up on Time Capsule because I'm told that's how the hackers hacked my computer so thoroughly duriung the intrusion.
    Thanks.

    Aubry,
    why don't you send your sequences straight to Compressor first, encode your movies as MPEG 2 and AC3 audio and import all assets in DVD studio PRO?
    G.

  • Google maps and google help not loading anymore! help!

    Google maps and google help aren't loading since I've updated firefox. Works in Chrome no problem. Tried everything listed here: https://support.mozilla.com/en-US/kb/Error%20loading%20web%20sites, re-installed flash, cleared cache, etc... what am I missing?

    Anyone have any ideas?

  • How to remove stocks, weather,clock, notes, reminders, youtube, game center calc, voice memos,calendar, maps, and stocks? As a person who blew 300 bucks I think I should have a choice if I want to remove this crap but can't figure out how.

    How to remove stocks, weather,clock, notes, reminders, youtube, game center calc, voice memos,calendar, maps, and stocks? As a person who blew 300 bucks I think I should have a choice if I want to remove this crap but can't figure out how.
    any help would make me happy. As it stands now from looking on the web it can't be deleted but making sure before i return this ipod touch. I wan't a clean item the way I wan't it and not how they want it. Like I do not need Itunes and App Store on this ipod because I use my computer only to shop, So many things i like out of the ipod and I am sure lots more people also would like a cleaner ipod/phone or what ever.
    from looking at what I never use I see a total of 14 app's I not want taking up space and my screen.
    yup with the 5.0 came another stupid icon i not like. ( Newsstand )

    yes i moved them into a folder, but I not want them at all on my screen. Guess I return this and pick up a
    Zune HD
    less app's on that then ipod touch. thank you for the responce.

  • I am looking for a map app that will allow me to place pins where my clients offices are on a map and keep them save every time I open the app. Does anyone out there know of an app that will do this?

    I am looking for a map app that will allow me to place pins where my clients offices are on a map and keep them save every time I open the app. Does anyone out there know of an app that will do this?

    "Motion 5" is your friend.
    Michael Wohl has a nice 15 video series (free) about Motion 5 at http://www.macprovideo.com/tutorial/motion5101-overview-and-workflow-guide (right side)
    This is a "teaser" series to sell his tutorials but it is really good. Just saw it yesterday for the first time.
    While all you want is just to place pins, realize that Motion has so much more. All kinds of effects and they can be really customized. Maybe put their street address, contact name, and phone number by the pin?
    Motion 5: cheap at $49.99 (just got my download two days ago)
    Motion 5: Support Community athttps://discussions.apple.com/community/professional_applications/motion_5
    If you're using the map for, say, deliveries, and use an iPad, what you could do is have a general map of the area imported into Motion, create the pins and whatever, then save (share?) it to the iPad.
    Disclaimer: I have virtually no relationship with anything connected with this tutorial product, developer, or anything.

  • Problem with context mapping and data flow in a FPM application

    Hi All,
    I am trying to develop an ESS application using FPM. For the same, the requirement is to see the history of an employee in the second view.
    The first view has got just the overview information and the second one has got the detail. So, the records or the fields are the same on both the views.
    As per the FPM guidelines, the Model is residing in the Fc component and the respective Vc components are using the model data accordingly.
    I am executing the model in the Fc component calling the executable method in the interfaceController of the first view and then trying to display the output data of the BAPI in the first view which provides the overview information.This is working fine.
    But when i am trying to map the same output node to the Table UI for the second view, the record size is coming zero and thus no information is available.
    For the above issue, I am again executing the RFC in the InterfaceController of the second view to populate the records, which is incorrect as it is already executed and the data is available for the first view.
    I request you to let me know the correct approach to Context mapping and data flow when using FPM-roadmap. Is their any standard method or approach available to deal with such requirements? Please let me know.
    Thanks in advance.
    Regards
    DK

    Hi Idhaya,
    I model node is available in Fc and the Fc interface controller is being used in the first Vc and the second Vc.
    So the idea is, as the executable method is generated in the Fc, so i have created a custom method to call the executable method in Fc, where the input parameter is getting passed and this custom method is finally getting called is the first Vc.
    So , now my first Vc is ready to call the custom method in Fc and execute the RFC. Once the RFC is executed, the nodes in the Fc should get populated which is the ideal case.
    And as the Fc is used as a component in the second Vc, the same node is available to the UI elements.
    But, when I check the record size for the output node, it is always zero, for the second Vc.
    Regards
    DK

  • Nokia Map and Drive+ Beta on Lumina 920 Feedback

    So I took my new phone down to MD/DC area in the last few days and here are a few things that I would like to post as my feedback on what would be nice to have, fixes, etc.  [I used both my new Lumia 920 and my wife's Samsung Galaxy Note 2 as comparsion).
    1. Highest priority for me is that the routes from Here.net need to be able to sync down to the phone.  Nothing more is more important then this because when you have a custom route that you want to use (for example, to route around high traffic or potential high traffic areas).
    2. Extremely disappointed that a new road in MD (MD 200) was not used by the Drive+ and didn't even show up on the map on my Lumia 920 while it was used and did show up on Google map.  This road is a toll road and is over a year old already.  [And yes, I have enabled toll road in the navigation as well as selected 'faster route' as the routing to use under smart routing].  I cannot stressed how disappointed I am to not see Nokia Map have this route at all.
    3. Allow route changes on the Nokia Drive+ app.  As good as pre-planned trip and using Here.net, there are just tmes that it's much better to allow us to change the route based on latest condition.
    4. Never once did I see ANY traffic updates at all on both the Map and Drive+ Beta.  When it does shows on my wife's Google's Map/Navigation.
    5. I love that under Drive+, it tells you which lane to get into ahead of when you need to make a turn or merge onto another way. However, the flip side of that is that there's no way to know which road you're currently on.  This is probably more important for when you're in an area with a lot of highway/local way intersections.  Also, it would be great if it also will display the next major 'road' that you will be getting onto.
    So far I'm happy with some of the functionality and disappointed in some of Nokia Map and Drive+ and I have about a week left to decide to either stay with WP9 and Nokia or do I want to switch back to Android and Google Map.

    hi there,
    As this is a user to user forum only, if you wish to leave feedback with Nokia regarding their products and services, you can do so directly by clicking the Nokia Support link at the bottom of this page.

  • Multi-Mapping and Message Split using BPM

    Hi All,
    Could anyone pls let me know clearly how message mapping can be done for this weblog
    /people/sudharshan.aravamudan/blog/2005/12/01/illustration-of-multi-mapping-and-message-split-using-bpm-in-sap-exchange-infrastructure
    Thanks,
    Ram

    Hi,
    When you are doing Message mapping after adding the Messaget types for source and target messages. You can click on the "" button in the target message and add one more tab. You can go to Message tab as shown in the 5th image and click "" button to add one more message type. Then do the mapping as usual.
    <b>Based on the value of the element(name), the node of input(details)should be directed to one of the two message types</b>
    Here in this blog it is done based on the Name.
    You need to use IFTHENELSE boolean function and do the mapping.
    Thanks,
    Prakash

  • File to file with out message mapping and using variable substitution

    Hi,
    Can any one send me a scenario where we can have file to file scenario with out message mapping and where i can use variable substitution.
    As of now i am using integrate configurations where i cant use variable substitution as the message does not reflect in integration engine. I need to populate time stamp between <filename><timestamp>.txt.pgp
    I am as of now using configuration scenario.
    The time stamp always writes before the last file extension.
    Let me know your thoughts?
    Thanks,
    Chandra.

    Hi Chandra,
    u can use the Variable substitution even without IR contents also(Mapping....).
    in the receiver communication channel just specify the path u want to access for a value...
    eg: filename                             payload:mt_name,1,records,1,name,1
    and in th file name give it as %filename%.txt... or vt ever ur requirement
    Babu

  • I can't resync and uninstall Identity Synchronization for Windows 1.0

    Hi, every body.
    I downloaded and installed Identity Synchronization for Windows 1.0 on Solaris 8.
    But I can't execute idsync resync comannd. The below error message is output on console,
    # ./idsync resync -h crow.bird.soft.hitachi.co.jp -p 3890 -D cn=manager -w managersecret -q netscape -s dc=bird,dc=soft,dc=hitachi,dc=co,dc=jp
    Exception in thread "main" java.lang.NoClassDefFoundError
    at com.sun.directory.wps.registry.model.dao.LDAPConfigurationRegistryDAO.initializeEncryptor(LDAPConfigurationRegistryDAO.java:756)
    at com.sun.directory.wps.registry.model.dao.LDAPConfigurationRegistryDAO.open(LDAPConfigurationRegistryDAO.java:721)
    at com.sun.directory.wps.registry.util.BasicRegistryFacade.openRegistry(BasicRegistryFacade.java:120)
    at com.sun.directory.wps.registry.util.BasicRegistryFacade.openRegistry(BasicRegistryFacade.java:211)
    at com.sun.directory.wps.ui.model.PSWConfigurationFacade.openRegistry(PSWConfigurationFacade.java:1126)
    at com.sun.directory.wps.ui.model.PSWConfigurationFacade.openRegistry(PSWConfigurationFacade.java:1114)
    at com.sun.directory.wps.ui.cli.CRCLIProgram.getConfigurationFacade(CRCLIProgram.java:64)
    at com.sun.directory.wps.ui.cli.RefreshUsers.execute(RefreshUsers.java:283)
    at com.sun.directory.wps.ui.cli.ResyncUsers.<init>(ResyncUsers.java:54)
    at com.sun.directory.wps.ui.cli.IdSyncProgram.execute(IdSyncProgram.java:94)
    at com.sun.directory.wps.ui.cli.IdSyncProgram.<init>(IdSyncProgram.java:129)
    at com.sun.directory.wps.ui.cli.IdSyncProgram.main(IdSyncProgram.java:135)
    And I can't execute runUnInstaller.sh too becasu same error messages in logs/cli/error.log file.
    Both error outputs same message "org/apache/xerces/utils/Base64" in log files, so I think CLASSPATH is wrong.
    In runUninstaller.sh, below jar file name are written -classpath arguments.
    /usr/share/lib/mps/jss3.jar
    /usr/sfw/share/lib/xerces-200.jar
    These Are settings correct?
    If these settings are wrong, resync is set by same wrong settings in binary code?
    Please tell me how to resync and to uninstall Identity Synchronization for Windows 1.0.

    I mistakes log file name.
    I wrote:
    And I can't execute runUnInstaller.sh too becasu same error messages in logs/cli/error.log file.But runUnsitaller.sh outputs to /var/sadm/install/logs/Uninstall-xxxxxxx.log.
    logs/cli directory is where idsync command outpus error.log and audit.log.
    Sorry.

Maybe you are looking for

  • ADF wont work with custom LoginModule! Question for Mr. Nimphius!

    ive setup login module as shown in: http://www.oracle.com/technology/products/jdev/howtos/10g/jaassec/index.htm code: actionContext.getHttpServletRequest().isUserInRole("Administrators") works! but i also want this code to work in ADF: appmod.getSess

  • It seems I cannot use Sky Go even if I use Firefox. The only one that works is IE 11.

    I was using Google Chrome, but it seems they do not support Silverlight which Sky Go use. I was told that Firefox would work. It doesn't. The only one that works is Internet Explorer 11, which is very slooow. Why can't I use Firefox to view Sky Go?

  • JSP compilation: code too large on SP14

    Hello, I developed EP application based on JSPDynPage on SP13 with big jsp file. This application was running on SP13 without problem. Later, we upgraded to SP14 and application logged exception: "code too large" when compiling jsp. I tried to devide

  • Import photos from cd

    I am trying to import a group of photos to iphoto 11 from a cd.  I have tried the click and drag method and have tried File/Import to Library and nothing happens either time.  Am I doing something wrong? Thank you for any help!

  • Working on IDOC OUTBOUND FOR Vendor Master and Customer Master

    Hi Group, I need to create IDOC's for Vendor master and customer master using ALE. Whenever they create vendor/customer or changes to vendor/customer should create IDOC's. Can anyone please help me out how to proceed? I know that we can use CREMAS/DE