Offline data with mobile service - How to limit data download

Hi to all,
I have to manage offline data with mobile service.
I have a table with a lot of data but I would like to download data range by range,
let say 100 records for time.
Is it possible to do this with PullAsyn method?
I noticed that I'm not able to use skip function at the query parameter in the PullAsync method.
Infact if I try to use it in the query 
await mytable.PullAsync("mykey",mytable.Where(r => r.userid == iUserId).Skip(iSkip).Take(iTake));
I receive this error:
Incremental pull query must not have skip or top specified
Any help is appreciated.
Thanks
Daniele

Right now, the implementation of PullAsync() in the .NET SDK, will always try to continue paging until the end. So this will download the initial range, but then continue on with everything after as well (updating skip until no more records are found)
So you would be better off (probably) in letting the inc sync logic handle the paging for you. 
To come up with an appropriate workaround, what issue are you running into letting inc sync fetch all the pages sequentially in the background?

Similar Messages

  • Need some help getting started with Mobility Services Engine

    Someone has ordered several 3602 access points, a 5508 controller, and a MSE 3310 for one of our remote locations. The access points and controller are in place and are working fine (we use lightweight APs at many other locations), but I'm not sure how to approach the MSE. I've gone through the set up, and it's onsite, on the network, and I've added it to our WCS server. It's got a 2000 user context-aware services license. But I'm not sure where to go from here. It doesn't seem to actually be doing much of anything. Is there some quick start guide as to where to go from this point? The wireless users are mostly mini netbooks and iPads.

    Well, I'm no expert, but I did spend the night...
    Ok.  In the WCS on the Services tab, Mobility Services, your MSE is recognized and reachable with matching SW Versions.
    So, on the home tab, ContextAware tab, you see your MSE and it is showing Zero's  for data in most if not all fields?
    Back to the Services tab, Synchronize Services...  is this empty?
    The MSE can only 'SEE' what you tell it to 'LOOK' at.  That is, buildings and floor areas.  I haven't tried just a building.
    Check the left hand box for all the floor areas of interest.  Scroll to the bottom an slect 'Change MSE Assignment"
    select which (of the many or the one) MSE you wish to have monitor the area.  Check the 'CAS' box and save.
    Up on the upper levt is a Synchronization block..  push the Synchronize button and sit back..
    All MSE data is presented only to the WCS (or Pi).
    Good Luck
    David

  • Android Release APK does not work with Mobile Service in Android Studio

    I am using Android Studio and i have not been able to get a working release apk. What should my build file look like? Is there anything special that i need to do? The debug works fine but the release never works. Are there any code changes that need to be
    made? Do i need to log into azure on the mobile device? Do I need to copy the signed certificate to the device also? Any assistance or suggestion is welcome. Below is a copy of the build file:
    apply plugin: 'com.android.application'
    android {
    compileSdkVersion 19
    buildToolsVersion "21.1.2"
    defaultConfig {
    applicationId "com.example.ttferryschedule"
    minSdkVersion 9
    targetSdkVersion 19
    buildTypes {
    release {
    minifyEnabled true
    proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-project.txt'
    dependencies {
    compile 'com.android.support:support-v4:19.1.0'
    compile 'com.google.code.gson:gson:2.2.2'
    compile 'com.android.support:appcompat-v7:19.1.0'
    compile files('libs/mobileservices-1.1.5.jar')
    compile files('libs/mobileservices-1.1.5-javadoc.jar')
    compile files('libs/mobileservices-1.1.5-sources.jar')
    compile 'com.google.android.gms:play-services:6.5.87'

    Hi,
    I would recommend going with the 2.0 Beta SDK since you are working with Android Studio. The changes from 1.1.5 to 2.0 are documented at http://azure.microsoft.com/blog/2014/08/04/futures-support-and-breaking-changes-in-azure-mobile-services-android-sdk/ and http://azure.microsoft.com/blog/2014/08/07/offline-support-in-azure-mobile-services-android-sdk/ (offline
    specific). And we are in the process of publishing the beta SDK to an android repo so it's easily dependable.
    Please let me know if you have any further questions.
    Best,
    Mimi

  • I have a G60 laptop with Vista. How can I get download to install on new hard drive? FT468UA

    Hard drive is in Chinese I want to change it to English. Or reinstall Vista on a nother hard drive.

    Sorry, there is no download of Vista install. You have to make a Recovery Disc set to reinstall Vista. However your copy is licensed for Chinese (I assume) so that is what you will get with a reinstall.
    Creating Recovery Media
    Windows Vista
    ******Clicking the Thumbs-Up button is a way to say -Thanks!.******
    **Click Accept as Solution on a Reply that solves your issue to help others**

  • I bought an album on itunes of my ipod touch 4. I don't know why but the album is deleted of my ipod and it isn't on itunes of my computer. With my computer, how can I re-download my album without having to buying it again???

    read my question. also, I don't know why but I cant click on "achat" or purchase on itunes store...  

    It can take a day or even two sometimes before the transaction is processed. Paypal is then the first to inform you by email and later it is Apple. I have a credit card in my Paypal account which means that I don't have to put money into Paypal.
    And if the purchase is not billed at all, no problem at all I guess.

  • HT4623 do i need to use this program if i have t mobile service but an apple i phone

    I have an apple i phone with t mobile service how do i access my apps

    Tap the app on the home screen to use it.

  • Service Instances VLAN limit or IOS bug ?

    Hi,
    I've a big problem with a service instance VLAN limit , I can't add more than N characters inside the command "encapsulation dot1q".
    This is the platform: 
    CISCO7606-S
    CARD: ES+
    IOS: c7600s72033-advipservices-mz.122-33.SRD8.bin
    And this is the example:
    interface GigabitEthernet3/3
    service instance 300 ethernet
    encapsulation dot1q 502,506,508,513,517-518,528,532,535,548,
    555-556,577,608,611-613,637,662,664,667,673,688,702,840,848,851,862,876,887,895,922,934
    After the VLAN 934 the router does't add more VLAN and if you try to add another one the command is accepted, no errors appear, but if you check again the show run of the interface..nothing changed!
    I tried to load the startup configuration from tftp  and reboot but no luck..the only workaround that i've found is to join the vlan effectively reducing the number of characters.
    I think that could be an IOS bug, but can't find any evidence of this theory...
    Have you ever faced this kind of problem? 
    Thanks and Regards
    Roberto

    Well I think it's just a bug, because I just copy all my rules (policy-map,class-maps,ACLs), change they names(add 1 at the end)(router change their ID's I suppose), and point this to my zone-pair security and it works fine!
    class-map type inspect match-all DMZ310_TO_INTERNET_PASS1
    match access-group name DMZ310_TO_INTERNET_PASS1
    class-map type inspect match-all DMZ310->INTERNET_INSP_COMB1
    match access-group name DMZ310_TO_INTERNET_INSPECT1
    match class-map DMZ310->INT_INSPECTION_PROTOCOLS1
    class-map type inspect match-any DMZ310->INT_INSPECTION_PROTOCOLS1
    description ---=============
    match protocol tcp
    match protocol icmp
    match protocol dns
    match protocol user-nashssh
    match protocol http
    match protocol udp
    policy-map type inspect DMZ310->INTERNET_POLICY1
    class type inspect DMZ310_TO_INTERNET_PASS1
      pass
    class type inspect DMZ310->INTERNET_INSP_COMB1
      inspect
    class class-default
      drop
    zone security INTERNET
    zone security DMZ310
    zone-pair security DMZ310->INTERNET source DMZ310 destination INTERNET
    service-policy type inspect DMZ310->INTERNET_POLICY1
    interface GigabitEthernet0/1.310
    encapsulation dot1Q 310
    ip address 1.1.1.2 255.255.255.128
    ip nat outside
    ip virtual-reassembly in
    zone-member security DMZ310
    standby 3 ip 1.1.1.1
    standby 3 priority 15
    standby 3 preempt
    ip policy route-map BGP-DEFAULT-ROUTE
    service-policy input POLICE_DMZ310_IN
    service-policy output POLICE_DMZ310_OUT
    interface GigabitEthernet0/1.301
    description -=ISP=-
    encapsulation dot1Q 301
    ip address 2.2.2.2 255.255.255.252
    ip flow ingress
    ip nat outside
    ip virtual-reassembly in
    zone-member security INTERNET
    ip access-list extended DMZ310_TO_INTERNET_INSPECT1
    permit icmp host 1.1.1.5 any
    permit ip host 1.1.1.5 any
    deny   ip any any

  • I have an iphone 3G 16GB 4.2.1 - i moved back to canada and got telus mobile service. they cant get phone working because cellular data network tab/button is not on my phone. How do i get it on there

    i have an iphone 3G 16GB 4.2.1 - i moved back to canada and got telus mobile service. they cant get phone working because cellular data network tab/button is not on my phone. How do i get it on there

    OK. T-Mobile is NOT owned by AT&T... yet... The deal hasn't gone through yet. T-Mobie's US network is not compatible with the iPhone. Lots of things don't work right. There is not, and never has been an unlocked 3G sold in the US. Don't know where the phone originated, but more than likely it was in the US. If that's the case, the phone has been hacked/jailbroken to get it to work.
    Have you tried doing a restore or restoring the phone as new? I have to warn you, if you do so and the phone is hacked/jailbroken, it will re-lock to AT&T and will become unusalbe.  I think your best bet right now might be to save yourself a lot of grief and just upgrade to new phone from a legitimate source.
    I would never even consider buying an iPhone on ebay. 99% or more are hacked, jailbroken and/or stolen.

  • Using offline data sync in Mobile Services

    Hi All,
    I am working on offline data sync in Mobile Services . Followed the below URL
    http://azure.microsoft.com/en-gb/documentation/articles/mobile-services-windows-store-dotnet-get-started-offline-data/#enable-offline-app
    Have an issue at store.DefineTable<TodoItem>();
    when i run the method i am getting any exception as 
    System.ArgumentException was unhandled by user code
      HResult=-2147024809
      Message=An item with the same key has already been added.
      Source=mscorlib
      StackTrace:
           at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
           at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
           at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement](IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer)
           at System.Linq.Enumerable.ToDictionary[TSource,TKey](IEnumerable`1 source, Func`2 keySelector, IEqualityComparer`1 comparer)
           at Microsoft.WindowsAzure.MobileServices.SQLiteStore.MobileServiceSQLiteStore.DefineTable(String tableName, JObject item)
           at Microsoft.WindowsAzure.MobileServices.SQLiteStore.MobileServiceSQLiteStoreExtensions.DefineTable[T](MobileServiceSQLiteStore store, MobileServiceJsonSerializerSettings settings)
           at Microsoft.WindowsAzure.MobileServices.SQLiteStore.MobileServiceSQLiteStoreExtensions.DefineTable[T](MobileServiceSQLiteStore store)
      private async Task InitLocalStoreAsync()
        if (!App.MobileService.SyncContext.IsInitialized)
            var store = new MobileServiceSQLiteStore("localstore.db");
            store.DefineTable<TodoItem>();
            await App.MobileService.SyncContext.InitializeAsync(store);
        await SyncAsync();
    Need help.
    Thanks,
    Sai.

    Hi,
    The Azure Mobile Services forum is here:
    https://social.msdn.microsoft.com/Forums/en-US/home?forum=azuremobile&filter=alltypes&sort=lastpostdesc
    Don't retire TechNet! -
    (Don't give up yet - 13,225+ strong and growing)

  • Offline data synchronization in azure mobile services on windows server 2008

    Hi,
    I have a class library which insert data into tables in azure mobile services on windows server 2008 OS for windows universal C# platform. I am trying to insert data using offline data synchronization.
    I had installed SQLite runtime for windows 8.1 and windows phone 8.1, but unable to add reference 'SQLite for Windows Runtime(Windows8.1)'.
    Please guide me whether windows server 2008 OS supports offline data synchronization in azure mobile services.
    Thank you.

    I also have a Windows Server 2012 R2 system using Azure Backup, and I don't have the problem. However, you probably noticed that you use a different Azure Backup installation download for Windows Server 2008 R2 vs. Windows Server 2012 R2. Although both
    show the same Microsoft Azure Recovery Services Agent version 2.0.8692.0 installed, my Windows Server 2012 R2 also lists Microsoft Azure Backup for Windows Server Essentials version 6.2.9805.9 installed as well. It could be the case the my problem with the
    CATALOG FAILURE 0x80131500 errors is something specific to the version of Azure Backup installed on my Windows 2008 R2 servers.
    Trilon, Inc.

  • How can I create a query with web service data control?

    I need to create a query with web service data control, in WSDL, it's query operation, there is a parameter message with the possible query criteria and a return message contains the results. I googled, but cannot find anything on the query with web service. I cannot find a "Named Criteria" in web service data control like normal data control. In Shay's blog, I saw the topics on update with web service data control. How can I create a query with web service data control? Thanks.

    Hi,
    This might help
    *054.     Search form using ADF WS Data Control and Complex input types*
    http://www.oracle.com/technetwork/developer-tools/adf/learnmore/index-101235.html

  • How can i download old settings with firefox sync ? i formatted my computer thinking that the data will be restore on login , but it's only letting my sync firefox with mobile device , can someonr please help my ?

    how can i download old settings with firefox sync ? i formatted my computer thinking that the data will be restore on login , but it's only letting my sync firefox with mobile device , can someonr please help my ?

    '''Did you backup whatever bookmarks you did have on the computer ? '''
    Remember any restoring of bookmarks overwrites whatever he current set is, and you may not want to loose them.
    Even if up until now you have not made any backups of Desktop bookmarks Firefox will have backed up some of them into sets of daily bookmark backups. Once you have backed up your current set you could look at what it has by restoring those bookmarks, you may find one of those sets is fairly complete.
    By the way if you look at the profile files and folders that you should now have on the desktop you should see it contains a bookmarks backup folder, the size of the files within should indicate whether they contain anything.
    You need to go into the bookmarks library and try the restore option. Backup each set that you look at if it has anything of use in it, before trying the next set. With look one of those will be a fairly complete set of bookmarks.
    * USE '''Show All Bookmarks -> Import and Backup -> Restore '''
    ** see [[Restore bookmarks from backup or move them to another computer#w_restoring-from-backups]]_restoring-from-backups
    I do not use Firefox on mobiles, but before you try anything further you do need to backup the desktop bookmarks and learn what existing backups you have. Unless you master that you are in continual danger of overwriting and loosing bookmarks.
    Presumably you have already found this listing of help articles for mobiles
    * [/products/mobile/bookmarks]

  • I want to use the internet on my ipone but it says that i am not subscribed to a mobile dater service how can i fix this

    i want to use the internet on my ipone4 but it says that im not subscribed to a mobile dater service how can i fix this

    Subscribe to a mobile data service.
    Call your provider and make sure you have a data package.

  • Complex Data in Mobile Services?

    I'm trying to learn Azure Mobile Services, and feel like I must be missing something. I've gone through the tutorials, and they all seem a little too trivial to be helpful.
    I have a data model that, by traditional standards, isn't all that complicated, but seems to be for Mobile Services.  It's a reasonably straight-forward relational data model.  Whereas this is something that I would normally have designed in Entity
    Framework, I'm trying to follow the "Mobile Services methodology".  I was able to create the data model in code reasonably easily, with all the classes inheriting from Microsoft.WindowsAzure.Mobile.Service.EntityData.  It seems a bit
    of a step backward not to have something like the Entity Framework data model designer, but I got through it.  The database appears to get created correctly in Azure.  So far so good.
    Now I want to consume the mobile service in a client.  This is where my frustration starts.  Whereas in the past there were RIA Services or a WSDL to provide the data model of the service (i.e. essentially code-gen the proxy), it appears that I
    have to code everything on the client by hand again!  Is that true?!  From what I can tell, I can't even share the code between the server and the client.  Am I missing something?
    Then, after I write a LOT of essentially duplicate code, I give it a try and find out that there is simply no support for navigation properties (i.e. foreign keys, etc.).  I have to code all of that myself, likely using an automapper.  Once again
    I say:  am I missing something?
    Please tell me there's a better way, because right now this all feels like numerous steps backward!
    Thanks!
    Brad.

    You are right that there is less functionality as compared to RIA Services: this is by design. The Mobile Services tables endpoint and the client SDK are designed to be as simple as possible. This keeps your mobile client logic simple, and makes it easier
    to build a cross-platform app. For instance, if you were building a native iOS and Android client, there's no way to get around the code duplication.
    However, connecting to the tables endpoint is very easy using the SDK, and then you just use LINQ to run queries on your service. You can also use offline data sync to cache the data locally, and even update it while you are offline and sync changes later.
    (This is another case where the simple data model is a big advantage.) Plus, there's no codegen to bloat your client app. The only thing you need to manage is the table name, but this is an API that doesn't tend to change often (usually only additions).
    For a more complex example of Mobile Services, see our Field Engineer solution accelerator, which is a full-fledged app:
    https://code.msdn.microsoft.com/windowsapps/Field-Engineer-501df99d
    You're right that you can't share code for your model classes between client and server, other than copy and paste. :)  There's another good reason for this: the backend adds several system columns that are needed for things such as offline sync
    and conflict handling. So, you have to inherit from EntityData (or IEntityData), whereas the client has no such requirement. This can actually give you a lot of flexibility. however. For instance, maybe you only want 5 database columns, and there are 20 in
    your model. You can create different models on the client and backend to handle this.
    We don't support foreign keys, which definitely makes things harder. Unfortunately, supporting relationships would mean the full complexity of RIA Services on all 5 of our client platforms, which just wasn't feasible.
    As you noted, you can use Automapper, or, if your relationships are mostly 1-to-many, you can use database views and modify those directly. They can also be synced. If this works for your data model, it can also really simplify your client code, since you
    only need very simple queries on the client. For an example of this, please see my posts in this forum thread:
    https://social.msdn.microsoft.com/Forums/azure/en-US/4c056373-d5cf-4ca6-9f00-f152d2b01372/best-practice-for-syncing-related-tables-in-offline-mode?forum=azuremobile
    I totally agree with you that not having support for relationships makes the developer's life much harder, particularly if the model is not a good fit with automapper. But on the other hand, you get offline data sync for free, which would otherwise be a
    lot of work to implement.
    In order to determine if Mobile Services is the right fit for your project, you should look at all the features in the client SDK and estimate how much work it would be to do it all yourself. If you don't need most of the features, it's possible that you
    can just use Web API and all the features of Entity Framework. However, if you need things like offline data sync, login, or push notifications, the SDK can be a time saver.

  • Anyone know how to contact anyone in Verizon headquarters?  Since I'm not getting anywhere with Customer Service

    I'd like to express how unsatisfied we have been with Verizon on an issue that has been ongoing now since March 14, 2014.  It involves an upgrade on one of our lines.  After all these months, phone call with customer service, Tech support, and visits to a Verizon stores, I would hope that there are ample notation on our acct but since I've had to explain the situation on a bi-weekly time frame, I would assume that no one has documented any contacts.
    We've been with Verizon for few yrs now and I have always been very satisfied with Verizon who, up until now , always provided excellent customer service in their knowledge, concern, and customer satisfaction.  But I have to say, every positive outlook I've had with your company has been wiped clean with the worst service we have received in the last few months.
    We upgraded my daughter's phone on 03-14-14 with a Samsung Galaxy Mini from an Iphone 4s.  Within 24 hrs, the phone failed.  After 2 visits to a Verizon store the next day which took 6 hrs, we still had to return the next day to speak to a manager.  The 2 stores advised us to make a CLAIM on the defective phone thru our insurance plan with Verizon.  A CLAIM on a 24 hr old phone!!  A 3rd visit with a manager finally convinced him to replace the phone with another new phone at the store.  Within 2 weeks - issues began to occur with the replacement phone.  Several visits more, several calls more with Customer Service, several calls more with tech support which adds up to soooo many of our time taken up to simple have temporary "fixes" is outrageous.  If I billed Verizon for my time, perhaps the situation would have been resolved more quickly.  Each visit lasts approx 2 hrs, each phone call approx 1-1 1/2 hrs.  We are talking at least 2x a month for the course of 5 1/2 months.  Plus the time it takes to get the phone back to where she needs it - contacts, apps, internet. 
    Not once were we offered a new phone or replace the phone.  Not until today.  Replace the phone with the same phone that my daughter has grown to hate.  So basically a 3rd phone - same phone.  She is not interested in this phone any longer.  She dealt with this phone model for far too long.
    Today we were offered to replace the phone with same phone, or pay for a refurbished Iphone 4.  So basically she would be going back to her original Iphone 4s before the upgraded WITH a cost.  So her upgrade was wasted, we'd paid over $200 for a defective phone, and would need to pay for an even older model Iphone 4 and have to pay for it.  Why wasn't she offered a different phone within those 30 days after the upgrade and 6 visits? 
    Every rep at the stores, every rep in tech support would provide a different reason for the issue.  Finally, tech support advised not to download apps.  WHAT GOOD IS A SMARTPHONE IF YOU CAN'T HAVE APPS???  We are talking about a 20 yrs college student who attends school in another state.  Do you know the trouble she has to go thru to visit a store? To find 2 hrs between being a full time student with 2 jobs to sit on the phone with a tech support or go to a Verizon store?  Once-ok  Twice-maybe  BUT for 5 months?
    She's not eligible for an upgrade.  She will be stuck with a phone that she had grown to hate.  And I with customer service which I've grown to hate. 
    Finally, The Edge.  Trying to find a way to make my daughter happy, I spoke with 4 representative today about the Edge.  Each rep gave me 4 different information.  1st rep advised Edge phone could not be used on another line so I could not use a line eligible for the Edge and give that phone to my daughter since she isn't eligible for the Edge.   2nd rep advised that although new phone thru edge must be used by same number that it was eligible for, we could use the current phone o that line for my daughter.  My son currently has an Iphone 5 and is eligible for the Edge early upgrade.  He would not have to return his Iphone 5 so my daughter could use it.  However, all the lines would have to go to the More Everything Plan and share the Data between all our phone lines.  3rd rep advised the cost would almost double from our current $358 to go to the More Everything Plan so suggested to have 2 accounts vs just 1.  4th rep advised not every line needs to go the More Everything Plan, we could not keep the current phone, and my daughter could get a replacement phone but same phone or made exception to offer the Edge early upgrade to my daughter but only after we go thru the replacement program because the phone we send to Verizon has to be in good working order/no defects. 
    After 5 1/2 months, it is now Verizon that is indicating that we have a defective phone and can't accept it thru the Edge program or we would get billed approx $299 for a defective phone.  After 5 1/2 months of me calling in about a defective phone that not one rep replaced because they "fixed" the problem ( by the way, a temporary fix is not fixing, if it was fixed I would have made those calls today or writing this email), I am now being told her phone is defective.  She advised to get a replacement phone first, return the old phone, activate the new phone, then call in to get the Edge early upgrade.  So my daughter would have to do all this, plus add contacts back, apps and whatever else she needs to use her phone just to turn around a couple weeks later and do it all over again with the new phone thru the Edge program.  Once again, we are the ones having to be inconvenienced and go thru all these steps.  Did I mention she is going to be studying abroad in Italy beginning Nov?  So the idea of having to wait 2-3 weeks for a new phone and having only a week or 2 to test the phone to make sure it's working properly before she's out of the country doesn't sound appealing to me.  Verizon has made us have a defective phone for 5 months advising it's in good working order after each and every "fix" but Verizon will not accept that phone if returned in the same condition as a phone in good working condition.  Do you see the irony in that? 
    I have reached my limit and after 5 yrs of my brother in law trying to convince us to switch to AT&T where he works in their Corporate Office, I can honestly say I will not be sad to leave Verizon.  Especially when one of your reps simply provided me with the contract end dates to provide to AT&T because they offered to buy out our contract.  No effort in customer retention what so ever.  That was a phone call on Thursday. 
    And yes, one of your tech reps tried to convince me of all the hassle it would be to switch and time AT&T would take to buy out our contracts but honestly it was the pot calling the kettle.  I am not in the position to discuss hassle and time after 5 months of getting that with Verizon.  Did I mention it's my brother in law so we would be getting special treatment and no out of pocket expenses to switch.  It was my loyalty and satisfaction with Verizon that has kept me from switching all these years.  Something Verizon clearly does not appreciate. 
    So can you guess where I am with confidence that your customer service department is knowledgable about the plans/offers?  Where I am that I can trust what I'm being told?
    I know this email is confusing and really hard to understand...perhaps now you will know how i've been feeling--lost and confused with all the mis-information, with a hit and miss phone, and out of time with all the 1 1/2 hr to 2 hrs EACH wasted on this issue. 
    On top of all this, I can't even find out how to file a complaint with anyone higher up than Customer Service. 

    Jneklason wrote:
    ~snip~
    I know this email is confusing and really hard to understand...perhaps now you will know how i've been feeling--lost and confused with all the mis-information, with a hit and miss phone, and out of time with all the 1 1/2 hr to 2 hrs EACH wasted on this issue.
    On top of all this, I can't even find out how to file a complaint with anyone higher up than Customer Service.
    I hate to tell you this, but you didn't write an email. You wrote a discussion post on the Verizon Wireless Community forum which is a public peer to peer forum. Unfortunately since you didn't mark your post as a question, the VZW reps that roam this community won't ever see your post. Before you re-post it, don't. Duplicate posts get removed from the community.
    I see there were several missteps both by the reps and yourself in your post. First you should have insisted on returning the phone within the 14 day return policy period. Second which Samsung Galaxy mini model did you purchase? The S3 mini or the S4 mini? Did you do any research prior to deciding on this device. The reps at that time deflected the easiest course of action, by trying to get you to replace the phone under insurance instead of returning the phone. The Early Edge payment option requires the current phone on the line using the early Edge must be returned to Verizon Wireless. Did you once considered going to a third party site like Swappa to purchase a gently used device for your daughter?

Maybe you are looking for

  • IBook and external HDD - Advice needed

    Hi all, I am using an old G3 white dual USB iBook with OS X 10.2.8. The backlight cable broke a year ago, and I finally worked up the nerve to replace it myself...and while I'm in there, I'd like to drop in a new 120GB Seagate hard drive to replace t

  • Acrobat XI Pro & Mac OS X 10.7.5

    I have Mac OS X 10.7.5 and I'm about to try installing a trial version of XI Pro - but the download instructions suggest that it will only work with Mac OS X v10.6.8, v10.7.4, or v10.8 - is that right??  Also I use firefox not safari yet the download

  • Flash error messages

    I'm using Flash .SWFs that incorporate the Flash zoom and pan component. When I import the .SWF into Captivate, I get an error message (Error #2044: Unhandled ioError:. text=Error #2035: URL Not Found. URL: file:///C:\Documents and Settings\Desktop\T

  • Airport Express Total Frustration

    I'm totally frustrated. I've had my Airport Express for about 3 months. I used it a lot at the beginning, and everything worked fine, but I haven't used it for a while. Now that I'm back trying to use it.... ...It can't be found by iTunes and it can'

  • Do you have to activate each Apple TV FOR WatchESPN, HBOgo & Disney

    I have three (3) Apple TV's in my house and want to activate them for ESPN, HBO, Disney and DisneyXD.  Will I have to activate each unit or once one is activated are all three activated?? Please let me know? Thanks Jason