PID Troubles on a Flow controller???

Hello,
I'm having trouble using PID control on an flow valve that requires a 0-12VDC power source.  My setup includes an Agilent 34970A with a mulitfunctional module to output power to a Kepco power supply which ouputs power to the flow controller.  The only way I can get PID to work is if I use a very small Gain such as (0.2), an Integral Time of (-.49) and a Derivative Time of (.005). It seems to dial in the flow meter within 2-3 minutes but it doesn’t seem right to put a negative value in for the Integral Time though??   I'm wondering if it has something to do with the hysteresis of the flow meter. Have you guys heard of anything like this happening with PID on a control valve?  Please let me know.
Thanks,  Jeff
Flow controller manf:  Teknocraft~Standard proportional control valve.
http://www.teknocraft.com/pdfs/proporvalve1.pdf
Solved!
Go to Solution.

Hi
I am trying to write a simple code on Having a Loop control on a flowmeter. I wrote 2 codes one involving a P control and one Involving a Differnce in the set Point to the Actual output.
The idea is to control a flowmeter based on the pressure of flow . The Pressure measurement gives a Voltage output and the valve need a Current input so i need to control flow using desired Voltage output. But my code with the P control doesn not function as desired. ANd the code which uses just a differnce in a loop seems to work fine but for the fact that it never touches the desired value . it keeps oscilatting around the desired set point.
Could anyone help me set right the P Control ?
Attachments:
PID_Air_actual.vi ‏49 KB
PID_Air_Diffenrce.vi ‏54 KB

Similar Messages

  • Process MAD.EXE (PID=1932). All Domain Controller Servers in use are not responding:

    Process MAD.EXE (PID=1932). Topology discovery failed, error 0x80040a02 (DSC_E_NO_SUITABLE_CDC).
    Look up the Lightweight Directory Access Protocol (LDAP) error code specified in the event description. To do this, use Microsoft Knowledge Base article 218185, "Microsoft LDAP Error Codes." Use the information in that article to learn more about
    the cause and resolution to this error. Use the Ping or PathPing command-line tools to test network connectivity to local domain controllers.
    Process MAD.EXE (PID=1932). All Domain Controller Servers in use are not responding: 
    DC02.targetiletisim.local 
    DC01.targetiletisim.local 
    Process MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=1148). Topology discovery failed, error 0x80040a02 (DSC_E_NO_SUITABLE_CDC). Look up the Lightweight Directory Access Protocol (LDAP) error code specified in the event description. To do this, use Microsoft Knowledge
    Base article 218185, "Microsoft LDAP Error Codes." Use the information in that article to learn more about the cause and resolution to this error. Use the Ping or PathPing command-line tools to test network connectivity to local domain controllers.
    pls help me :(

    Hi,
    Please use dcdiag and nltest to test the connectivity.
    BTW, have you disabled ipv6 on Exchange Server.
    Thanks,
    Simon Wu
    TechNet Community Support

  • Page flow controller - instance variable thread safe?

    I have page flow controller that is a subclass of org.apache.beehive.netui.pageflow.PageFlowController runing weblogic 921. The essence of my question is: is instance variable of page flow controller thread safe?
    Here are the details. I have an instance variable “status” that stores the status of the patient, which is stored in the request. It sets the status with after the patient status is retrieved from database. The set method is not synchronized.
    This works fine during normal test. But it failed during load test. Does a page flow controller instance shared among different requests? If so, how can I store the status for each request?
    Thanks,
    G T

    Hello
    You seem to put your question on the wrong forum
    Oracle Beehive and Apache Beehive are two different products...
    Have a look on http://beehive.apache.org
    Cheers
    Fred

  • Connect to MKS Alta 1480 Device Net Mass Flow Controller

    I have a MKS Alta 1480 mass flow controller (MFC), MFC Manual, Labview 8.2 and NI PCI-CAN card.  I know have the MFC wired correctly because I can operate it using another program on the PC that used the deviceNet interface.  I want to talk to it via Labview.   Everything looks OK using measurement explorer.  I have the NI-DNET pallet.  I know the MACID.  I have downloaded the EDS from the manufacturer.
    Here is what I am lacking:  A general clue about the DeviceNet interface.  Is there any example code out there that could get me started?  Are there any tutorials on how to figure out the Dnet protocol?  I am used to serial devices command--> response.  I don't know anything about Class, Object, attirbutes.
    Thanks,
    Joe
    Solved!
    Go to Solution.

    Joe, you can read MFC Flow value from S-Analog Sensor Object.
    Class Id 49 (0x31), Instance Id 1 (0x01), Attribute Id 6
    (0x06)
    The default Data Type is Integer and Data Units is counts
    If you want read from assembly object, you will
    have establish polled IO connection, then use Read DeviceNet IO.vi to read
    flow.
    Attachments:
    MFC Integer Flow.png ‏4 KB

  • Mks mass flow controller​s only giving 2 sig. figs. over deviceNet and labview

    We can only read  2 digits (before the decimal point) on an MKS deviceNet mass flow controller using Labview 2013.  Does anyone know a solution to increase the resolution on this device?  We should be able to read 3 digits past the decimal point.

    Hi David,
    Could you also specify the type of mass flow controller device?
    According to our engineer, we had the APIs to set the attributes of DeviceNet device, but the specific type of the device is required. Attached is the document of some device type. You could turn to page 75 to see there the S-Analog Sensor Object Attributes::FlowDataType could be Get/Set.
    Attachments:
    1485A-1480A-185A-180Aman.pdf ‏964 KB

  • Mass flow controller

    hello,
    does anyone have or know of a vi that can be used to read and display mass flow of a gas?
    i have a mass flow controller(MFC) and it reads the gas flowing thru a pipe (or a tube, forexample). i want to be able to take the readings or signals from the MFC and display it on the front panel.
    does anyone have something(VI) of the sought that i can maybe modify to do what i'm trying to do?
    thanks
    -r

    A lot of MFC's have an analog out denoting the "is" value of the mass flow.
    Connecting this analog out (from the MFC) to an analog in of a DAQ card will allow you to record the values.
    This is an easy thing to do (If your MFC has a simple analog out), so I'm not sure if you'll find ready-made functions for it.
    Shane.
    Using LV 6.1 and 8.2.1 on W2k (SP4) and WXP (SP2)

  • Producing a voltage that coresponds to a setpoint for a mass flow controller​.

    Hello,
    I have a mass flow controller that requires a voltage output signal from my DAQmx board (SCB-68) to maintain a setpoint.  This set point is a voltage that corresponds to the desired flow rate.  I have produced a scale for this linear controller but I do not know how to use it.
    I know how to create a vi that reads a voltage input, I can also write one that sends the same voltage input back throught the output.  I can not write one that sends a constant voltage output corresponding to a flow rate.
    Could somebody help me out with this?
    Dan

    Hello,
    First, tp upload code (or any document) it is quite easy, just select the file, by clicking the "browse" button... see image below (I'm sorry it's all in french... 'cause I am french ! "Parcourir" means more or less "Browse" ) :
    About your app, well adding a channel doesn't require to duplicate the whole code... Developper are always trying to do things with the less code possible . Check VI attached and tell me if it matches your needs.
    Message Edité par TiTou le 03-23-200601:26 PM
    When my feet touch the ground each morning the devil thinks "bloody hell... He's up again!"
    Attachments:
    Gen 2 Volt.vi ‏98 KB
    Clipboard01.png ‏14 KB

  • How to implement autotuning pid in labview in flow control process????

    I tried the same way as Example available in LabVIEW..... that is general auto PID simulator... But that didn't worked out for me.....

    The 'General Auto PID Simulator.vi' example uses the technique "PID Relay" feedback where it tries to calculate the PID values based on the relay feedback, but using the PID also in the loop:
    (http://zone.ni.com/reference/en-XX/help/370401H-01/lvpidmain/pidrelay_alg/)
    This technique works, but it requires initial PID parameters that will make the relay setpoint stable and it is able to obtain the results you are expecting.
    Now, for flow control, you can try the most classic techniques. Please use other shipping examples that start with "autotuning" and in special this:
    C:\Program Files (x86)\National Instruments\LabVIEW 2013\examples\control\PID\Autotuning PID Online.vi
    In this VI, you can choose other techniques like open-loop step response, closed-loop step response and the original 'relay feedback' where it doesn't have a PID inside the estimation loop.
    Anyway, here you have more information about those techniques http://zone.ni.com/reference/en-XX/help/370401H-01/TOC4.htm.
    One more thing: keep in mind that depending on the plant parameters, a PID could not be suited for your application and a more complex controller need to be developed.
    Hope this can help you...
    Barp - Control and Simulation Group - LabVIEW R&D - National Instruments

  • PWM PID loop on 7344 motion controller

    I need to control motion by PWM, with the help of 7344 motion controller.Please verify if it possible or not, and how can I do it.Please provide me(if it possible)any example of solution of this problem.

    Hello,
    The onboard PID circuitry can only be utilized with servos and closed loop steppers. You can write your own PID loop in software using the PWM functions and the Read Encoder Position.flx. This should work pretty well for low loop rates (since it's implemented in sw). I don't think there are any examples of it available but it should be pretty straight forward.
    Regards,
    Yusuf C.
    Applications Engineering
    National Instruments

  • Negative feedback control needed for gas flow controller

    I'm an engineering student, and we're working on a design project that requires steady oxygen and nitrogen flow. We're using flow controllers to maintain a constant pressure. I need a LabVIEW VI that will sample the pressure at certain intervals and then, if there are variations, return the value to the desired pressure. I don't know that much about LabVIEW, so does anyone have suggestions on how I could do this? I don't need DAQ help now because that will be added later. Just suggestions on how to keep the value constant. Thanks!

    a PID control loop should do it
    There is a pid example that ships with LabVIEW. Search the LabVIEW examples for PID.

  • Can i use instance variables in page flow controller with out restriction?

    I am using instance variable in pageflow controller.
    1) Will it give any problem if concurrent users are accessing that controller class?
    2) How many controller objects will be created if multiple users (Say 10 users) accessing same controller class?
    Thanks.

    1) Will it give any problem if concurrent users are accessing that controller class? Pageflows are pere user session, different users wont cause it problems. however a single user can cause problems by using open new tab on a link etc(or back button or refresh on browser, problems with using state in a stateless protocol) . A bigger problem is that since a pageflow is indirect in session, using private variables in pageflow increases your session footprint and in a cluster , if replicated, your network trafiic as well. Using state also causes problem in HTTP , a stateless protocol,. Highly not recommended (unless you have no other choice)
    2) How many controller objects will be created if multiple users (Say 10 users) accessing same controller class? 10. assuming the portlet is used once only. If you use the same portlet in multiple pages , then you have that many.
    Edited by: deepshet on Feb 27, 2010 12:10 PM

  • Mass Flow Controller PS-54D

    i am currently working on the device PS-54D Mass Low Controller. I am suppose to create and interface on Labview 7.0 to control the device. However, in the reference book of the device, there isn't any codes given for me to control the device. So i am wondering if you all have the codes that i need to write a program for this device.
    Thank You.

    Hi tyl,
    What interface does the PS-54D Mass Low Controller use?  GPIB or serial?  There are some basic examples in LabVIEW to get you started with simple communication, and most instruments respond to commands like *IDN?, but you will need to speak with the manufactuer of the PS-54D to get a listing of function references for this particular device.  Good luck!
    Regards,
    Anna M.
    National Instruments

  • Mass Flow Controller Driver

    Hi,
    I have a Brooks 5850E MFC and a HART driver for it that used with LabView which I downloaded from NI.com. What hardware connection does this driver use to communicate LabView with the device (MFC)?
       Thanks

    Sorry but I think you as the user should know what hardware connection your device uses.

  • RT Host VI does not communicate with FPGA VI with PID Discrete controller

    Hi. I am using LV 7.1 RT with PXI 7831R. While developing an application with a PID controller in the FPGA vi, I have run into the following problem:
    1.   After a successful FPGA compile, the code runs directly on the FPGA device and the PID controller works fine.
    2. After I switch to the RT and run the host vi, it shows no activity from the FPGA vi. I look at the while loop count of the FPGA (indicator named 'FPGA-count' in the snaps below)) and it shows 'zero'. I have refreshed the FPGA vi reference but to no avail.
    3. If i take out the PID related stuff from the FPGA vi, then the Host vi to FPGA communication works.
    I have attached snaps of a simplified version of the fpga and RT vi's. If anyone can help, that would be greatly appreciated.
    I also read that the PID control toolkit needs to be installed. It is installed on the host computer and shows in Automation explorer under LV 7.1. Does it need to be installed on the remote machine that is the RT controller as well. if so, then how to do that.
    Thanks
    Attachments:
    RT-frt panel.JPG ‏38 KB
    fpga-block.jpg ‏39 KB
    RT-block.JPG ‏35 KB

    It seems like the FPGA is not running for some reason when you are running the RT VI. Without having the actual VIs to look at I can only make a few guesses why.
    On the Open FPGA VI Reference make sure the option is set to Open and Run, not just Open. Right click on the node to check this option.
    On the RT VI, make sure that stop-FPGA is False before you start.
    On the FPGA VI, make sure that the default value for stop-FPGA is set to False.
    In the RT VI check the error cluster passed to the loop to make sure that there are not errors and the FPGA VI is actually running.
    If you are using the PID function on the FPGA, you do not need any additional SW installed on the RT controller. If you are using the PID function in LV RT then you do need to install the PID toolkit on the RT controller. This is done from MAX (Measurement and Automation Explorer) using the Install Software option for the controller.
    Christian Loew, CLA
    Principal Systems Engineer, National Instruments
    Please tip your answer providers with kudos.
    Any attached Code is provided As Is. It has not been tested or validated as a product, for use in a deployed application or system,
    or for use in hazardous environments. You assume all risks for use of the Code and use of the Code is subject
    to the Sample Code License Terms which can be found at: http://ni.com/samplecodelicense

  • Trouble with my T1's and E1's in the lab - please help.... :-)

    I'm working through my CCIE Voice/Collaboration training materials and am just about finished with the physical construction of the lab.  At this time I'm just going to install a new T1 card into my BR1 router and I'm trying to get my T1 to HQ (HQ router) and my E1 to BR2 (Branch2 router) up and running.  I am enclosing the "show run", "show isdn status" and "show e1/t1 controller" outputs.  I am using a 2801 for my HQ router, a 2851 for my PSTN/IP-WAN router, and a 2811 for my BR2 router.
    I am using a T1 cable RJ-48C/RJ-48C.  I'm embarassed to say it - but I don't have a cable tester at the time.  I lended my backup out to a friend and my primary one is not working.  I'm also not 100% sure that I'm using the correct cable.  I have VWIC2-2MFT-T1/E1 cards in my routers and I have a 2851 (PSTN router) setup to give connectivity via the T1's to HQ and BR1 and E1 connectivity to BR2.  I have taken the liberty of attaching my configs, as mentioned I don't think I have cable issues because this is the case with all my cables.
    Main issue, in the "show isdn stat" the layer 1 status is "deactivated" and when I do a shut/no shut the status goes to "shutdown" and doesn't come back up despite my efforts to enable the interface.  The only way to fix it is to reboot the router.  I've got to be missing something - I just want to get my T1's and E1 up for my CCIE Lab.  I'm building my lab based on the CCIE Voice specification and have the ability to get it modified eventually to fit the CCIE Collaboration lab.
    ***PLEASE go easy on me - I'm sure there is a fundamental configuration item or concept I'm not thinking about so I'm preparing to look like a fool - but that's okay....it's part of learning.  :-)  ***
    Any help would be so much appreciated.  All configs are pasted below.......
    ==========================================================
    =================START OF BR2 CONFIG=======================
    BR2_RTR#show controllers e1
    E1 0/0/0 is down.
      Applique type is Channelized E1 - balanced
      Transmitter is sending remote alarm.
      Receiver has loss of signal.
      alarm-trigger is not set
      Version info Firmware: 20100222, FPGA: 13, spm_count = 0
      Framing is CRC4, Line Code is HDB3, Clock Source is Line.
      Data in current interval (895 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 895 Unavail Secs
      Total Data (last 24 hours)
         0 Line Code Violations, 0 Path Code Violations,
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
    BR2_RTR#show isdn stat
    Global ISDN Switchtype = primary-net5
    ISDN Serial0/0/0:15 interface
            dsl 0, interface ISDN Switchtype = primary-net5
        Layer 1 Status:
            DEACTIVATED
        Layer 2 Status:
            TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        Layer 3 Status:
            0 Active Layer 3 Call(s)
        Active dsl 0 CCBs = 0
        The Free Channel Mask:  0x00000000
        Number of L2 Discards = 0, L2 Session ID = 0
        Total Allocated ISDN CCBs = 0
    BR2_RTR#show inventory
    NAME: "2811 chassis", DESCR: "2811 chassis"
    PID: CISCO2811         , VID: V06 , SN: FTX1328A0D3
    NAME: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 0", DESCR: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1"
    PID: VWIC2-1MFT-T1/E1  , VID: V01 , SN: FOC11271UAU
    NAME: "WAN Interface Card - Serial 2T on Slot 0 SubSlot 1", DESCR: "WAN Interface Card - Serial 2T"
    PID: WIC-2T            , VID: V01, SN: 35759031
    NAME: "PVDMII DSP SIMM with three DSPs on Slot 0 SubSlot 5", DESCR: "PVDMII DSP SIMM with three DSPs"
    PID: PVDM2-48          , VID: V01 , SN: FOC12221GJE
    NAME: "AIM Service Engine 0", DESCR: "AIM Service Engine"
    PID: AIM-CUE           , VID: V03 , SN: FOC11505K9D
    NAME: "16 Port 10BaseT/100BaseTX EtherSwitch on Slot 1", DESCR: "16 Port 10BaseT/100BaseTX EtherSwitch"
    PID: NM-16ESW=         , VID: 1.0, SN: FOC09245Q0H
    NAME: "Power daughter card for 16 port EtherSwitch NM on Slot 1 SubSlot 0", DESCR: "Power daughter card for 16 port EtherSwitch NM"
    PID:                     , VID: 1.0, SN: FOC09243VGH
    NAME: "Gigabit(1000BaseT) module for EtherSwitch NM on Slot 1 SubSlot 1", DESCR: "Gigabit(1000BaseT) module for EtherSwitch NM"
    PID:                     , VID: 1.0, SN: FOC092034R1
    BR2_RTR#
    BR2_RTR#
    BR2_RTR#
    BR2_RTR#
    BR2_RTR#
    BR2_RTR#show run
    Building configuration...
    Current configuration : 9148 bytes
    ! No configuration change since last restart
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname BR2_RTR
    boot-start-marker
    boot-end-marker
    card type e1 0 0
    enable secret 5 $1$kYuC$TYARPnIw8mjqiVM3CqM15.
    no aaa new-model
    clock timezone CET 1 0
    clock summer-time CET recurring 1 Sun Apr 1:00 last Sun Oct 1:00
    network-clock-participate wic 0
    dot11 syslog
    ip source-route
    ip cef
    ip dhcp excluded-address 192.168.30.1 192.168.30.49
    ip dhcp excluded-address 192.168.30.70 192.168.30.254
    ip dhcp pool PHONES
    network 192.168.30.0 255.255.255.0
    default-router 192.168.30.1
    option 150 ip 3.3.3.3
    no ip domain lookup
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-net5
    voice service voip
    allow-connections sip to sip
    sip
      bind control source-interface Loopback0
      bind media source-interface Loopback0
      registrar server expires max 600 min 60
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g729r8
    voice class h323 1
      h225 timeout tcp establish 3
    voice register global
    mode cme
    source-address 3.3.3.3 port 5060
    max-dn 20
    max-pool 10
    load 7960-7940 P0S3-08-6-00
    authenticate register
    tftp-path flash:
    create profile sync 1684632613172238
    voice register dn  1
    number 3005
    name BR2_Phone3
    voice register dn  2
    number 3006
    name BR2_Phone4
    voice register template  1
    no conference enable
    voice register dialplan 1
    type 7940-7960-others
    pattern 1 3...
    pattern 2 999
    voice register pool  1
    id mac 0008.E31B.7CD4
    type 7960
    number 1 dn 1
    template 1
    dtmf-relay sip-notify
    username 3005 password cisco
    description 3214-3005
    codec g711ulaw
    voice translation-rule 1
    rule 1 /^\(3...$\)/ /3214\1/
    voice translation-rule 2
    rule 1 /^32143/ /3/
    rule 2 /^\+3432143/ /3/
    voice translation-rule 3000
    rule 1 /^3000/ /1002/
    voice translation-profile 3000
    translate called 3000
    voice translation-profile 4digitDNIS
    translate called 2
    voice translation-profile 8digitANI
    translate calling 1
    voice-card 0
    crypto pki token default removal timeout 0
    license udi pid CISCO2811 sn FTX1328A0D3
    redundancy
    controller E1 0/0/0
    pri-group timeslots 1-3,16
    interface Loopback0
    ip address 3.3.3.3 255.255.255.255
    h323-gateway voip bind srcaddr 3.3.3.3
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    interface Service-Engine0/0
    no ip address
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    interface FastEthernet0/1.21
    description BR2-PHONES(RTR on a stick)
    encapsulation dot1Q 21
    ip address 192.168.30.1 255.255.255.0
    interface FastEthernet0/1.22
    description BR2-DATA(RTR on a stick)
    encapsulation dot1Q 22
    ip address 192.168.31.1 255.255.255.0
    interface Serial0/0/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    isdn bchan-number-order ascending
    isdn outgoing display-ie
    no cdp enable
    interface Serial0/1/0
    no ip address
    shutdown
    clock rate 2000000
    interface Serial0/1/1
    description BR2-RTR_IP-WAN
    no ip address
    encapsulation frame-relay IETF
    no fair-queue
    frame-relay lmi-type ansi
    interface Serial0/1/1.1 point-to-point
    ip address 10.1.1.2 255.255.255.128
    frame-relay interface-dlci 301
    interface FastEthernet1/0
    description BR2-PHONE1
    switchport mode trunk
    switchport voice vlan 40
    no ip address
    spanning-tree portfast
    interface FastEthernet1/1
    description BR2-PHONE2
    switchport mode trunk
    switchport voice vlan 40
    no ip address
    spanning-tree portfast
    interface FastEthernet1/2
    no ip address
    interface FastEthernet1/3
    no ip address
    interface FastEthernet1/4
    no ip address
    interface FastEthernet1/5
    no ip address
    interface FastEthernet1/6
    no ip address
    interface FastEthernet1/7
    no ip address
    interface FastEthernet1/8
    no ip address
    interface FastEthernet1/9
    no ip address
    interface FastEthernet1/10
    no ip address
    interface FastEthernet1/11
    no ip address
    interface FastEthernet1/12
    no ip address
    interface FastEthernet1/13
    no ip address
    interface FastEthernet1/14
    no ip address
    interface FastEthernet1/15
    no ip address
    interface GigabitEthernet1/0
    no ip address
    interface Vlan1
    no ip address
    interface Vlan30
    description PHONES-VLAN-FOR-LAYER3-SWITCHING
    no ip address
    shutdown
    interface Vlan31
    description DATA-VLAN-FOR-LAYER3-SWITCHING
    no ip address
    shutdown
    router ospf 1
    network 3.3.3.3 0.0.0.0 area 0
    network 10.1.1.0 0.0.0.255 area 0
    network 192.168.30.0 0.0.0.255 area 0
    network 192.168.31.0 0.0.0.255 area 0
    network 192.168.0.0 0.0.255.255 area 0
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    ip http path flash:/GUI
    ip route 192.168.100.0 255.255.255.0 10.1.1.1
    tftp-server flash:Desktops/320x212x12/CampusNight.png
    tftp-server flash:Desktops/320x212x12/CiscoFountain.png
    tftp-server flash:Desktops/320x212x12/MorroRock.png
    tftp-server flash:Desktops/320x212x12/NantucketFlowers.png
    tftp-server flash:Desktops/320x212x12/TN-CampusNight.png
    tftp-server flash:Desktops/320x212x12/TN-CiscoFountain.png
    tftp-server flash:Desktops/320x212x12/TN-Fountain.png
    tftp-server flash:Desktops/320x212x12/TN-MorroRock.png
    tftp-server flash:Desktops/320x212x12/TN-NantucketFlowers.png
    tftp-server flash:Desktops/320x212x12/Fountain.png
    tftp-server flash:Desktops/320x212x12/CiscoLogo.png
    tftp-server flash:Desktops/320x212x12/TN-CiscoLogo.png
    tftp-server flash:Desktops/320x212x12/List.xml
    tftp-server flash:Desktops/320x216x16/List.xml
    tftp-server flash:Desktops/320x212x16/List.xml
    tftp-server flash:ringtones/Analog1.raw
    tftp-server flash:ringtones/Analog2.raw
    tftp-server flash:ringtones/AreYouThere.raw
    tftp-server flash:ringtones/AreYouThereF.raw
    tftp-server flash:ringtones/Bass.raw
    tftp-server flash:ringtones/CallBack.raw
    tftp-server flash:ringtones/Chime.raw
    tftp-server flash:ringtones/Classic1.raw
    tftp-server flash:ringtones/Classic2.raw
    tftp-server flash:ringtones/ClockShop.raw
    tftp-server flash:ringtones/DistinctiveRingList.xml
    tftp-server flash:ringtones/Drums1.raw
    tftp-server flash:ringtones/Drums2.raw
    tftp-server flash:ringtones/FilmScore.raw
    tftp-server flash:ringtones/HarpSynth.raw
    tftp-server flash:ringtones/Jamaica.raw
    tftp-server flash:ringtones/KotoEffect.raw
    tftp-server flash:ringtones/MusicBox.raw
    tftp-server flash:ringtones/Piano1.raw
    tftp-server flash:ringtones/Piano2.raw
    tftp-server flash:ringtones/Pop.raw
    tftp-server flash:ringtones/Pulse1.raw
    tftp-server flash:ringtones/Ring1.raw
    tftp-server flash:ringtones/Ring2.raw
    tftp-server flash:ringtones/Ring3.raw
    tftp-server flash:ringtones/Ring4.raw
    tftp-server flash:ringtones/Ring5.raw
    tftp-server flash:ringtones/Ring6.raw
    tftp-server flash:ringtones/Ring7.raw
    tftp-server flash:ringtones/RingList.xml
    tftp-server flash:ringtones/Sax1.raw
    tftp-server flash:ringtones/Sax2.raw
    tftp-server flash:ringtones/Vibe.raw
    tftp-server flash:PHONE/7940-7960/P0S3-08-6-00.loads alias P0S3-08-6-00.loads
    tftp-server flash:PHONE/7940-7960/P0S3-08-6-00.sb2 alias P0S3-08-6-00.sb2
    tftp-server flash:PHONE/7940-7960/P0S3-08-6-00.bin alias P0S3-08-6-00.bin
    tftp-server flash:PHONE/7940-7960/P0S3-08-6-00.sbn alias P0S3-08-6-00.sbn
    control-plane
    voice-port 0/0/0:15
    translation-profile outgoing 4digitDNIS
    mgcp profile default
    dial-peer voice 999 pots
    translation-profile outgoing 8digitANI
    destination-pattern 999
    port 0/0/0:15
    forward-digits 3
    dial-peer voice 1 voip
    incoming called-number .
    dial-peer voice 901134 pots
    destination-pattern 901134T
    port 0/0/0:15
    dial-peer voice 3000 voip
    translation-profile outgoing 3000
    destination-pattern 3000
    session target ipv4:192.168.15.23
    voice-class codec 1
    voice-class h323 1
    telephony-service
    no auto-reg-ephone
    max-ephones 10
    max-dn 20
    ip source-address 3.3.3.3 port 2000
    network-locale ES
    time-format 24
    date-format dd-mm-yy
    max-conferences 8 gain -6
    web admin system name admin password cisco
    dn-webedit
    transfer-system full-consult
    create cnf-files version-stamp 7960 Jan 23 2014 05:43:52
    ephone-template  1
    softkeys connected  Hold Select Trnsfer Endcall HLog Park
    ephone-dn  1
    number 3001
    name BR2_Phone1
    ephone-dn  2
    number 3002
    name BR2_Phone2
    ephone  1
    device-security-mode none
    description 3214-3001
    mac-address 0008.A3FD.3A32
    ephone-template 1
    max-calls-per-button 5
    busy-trigger-per-button 3
    type 7960
    button  1:1
    ephone  2
    device-security-mode none
    description 3214-3002
    mac-address 0017.E0C6.E232
    ephone-template 1
    max-calls-per-button 5
    busy-trigger-per-button 3
    type 7961
    button  1:2
    banner motd ^CBR2 ROUTER CUCME/CUE^C
    line con 0
    password cisco
    logging synchronous
    login
    line aux 0
    line 194
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
    password cisco
    login
    transport input all
    line vty 5 15
    password cisco
    login
    transport input all
    scheduler allocate 20000 1000
    ntp server 172.30.1.2
    end
    ===========END OF BR2 CONFIG=================
    ===========START OF HQ CONFIG================
    HQ-RTR#show inventory
    NAME: "chassis", DESCR: "2801 chassis"
    PID: CISCO2801         , VID: V02 , SN: FTX1016Y07Z
    NAME: "motherboard", DESCR: "C2801 Motherboard with 2 Fast Ethernet"
    PID: CISCO2801         , VID: V02 , SN: FOC10140N6M
    NAME: "WIC/VIC 2", DESCR: "Two port T1 voice interface daughtercard"
    PID: VWIC-2MFT-T1=     , VID: 1.0, SN: 32867042
    NAME: "WIC/VIC/HWIC 3", DESCR: "WAN Interface Card - Serial 2T"
    PID: WIC-2T=           , VID: 1.0, SN: 32195023
    NAME: "PVDM 0", DESCR: "PVDMII DSP SIMM with three DSPs"
    PID: PVDM2-48          , VID: V01 , SN: FOC132935YB
    HQ-RTR#
    HQ-RTR#show controllers t1
    T1 0/2/0 is down.
      Applique type is Channelized T1
      Cablelength is long gain36 0db
      Transmitter is sending remote alarm.
      Receiver has loss of signal.
      alarm-trigger is not set
      Soaking time: 3, Clearance time: 10
      AIS State:Clear  LOS State:Clear  LOF State:Clear
      Version info Firmware: 20090113, FPGA: 20, spm_count = 0
      Framing is ESF, Line Code is B8ZS, Clock Source is Line.
      CRC Threshold is 320. Reported from firmware  is 320.
      Data in current interval (709 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 709 Unavail Secs
      Total Data (last 24 hours)
         0 Line Code Violations, 0 Path Code Violations,
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
    T1 0/2/1 is down.
      Applique type is Channelized T1
      Cablelength is long gain36 0db
      Transmitter is sending remote alarm.
      Receiver has loss of signal.
      alarm-trigger is not set
      Soaking time: 3, Clearance time: 10
      AIS State:Clear  LOS State:Clear  LOF State:Clear
      Version info Firmware: 20090113, FPGA: 20, spm_count = 0
      Framing is ESF, Line Code is B8ZS, Clock Source is Line.
      CRC Threshold is 320. Reported from firmware  is 320.
      Data in current interval (709 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 709 Unavail Secs
      Total Data (last 24 hours)
         0 Line Code Violations, 0 Path Code Violations,
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
    HQ-RTR#show isdn stat
    Global ISDN Switchtype = primary-ni
    ISDN Serial0/2/0:23 interface
            dsl 0, interface ISDN Switchtype = primary-ni
        Layer 1 Status:
            DEACTIVATED
        Layer 2 Status:
            TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        Layer 3 Status:
            0 Active Layer 3 Call(s)
        Active dsl 0 CCBs = 0
        The Free Channel Mask:  0x00000000
        Number of L2 Discards = 0, L2 Session ID = 0
        Total Allocated ISDN CCBs = 0
    HQ-RTR#
    HQ-RTR#show run
    Building configuration...
    Current configuration : 6734 bytes
    ! Last configuration change at 02:32:03 UTC Tue Feb 4 2014
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname HQ-RTR
    boot-start-marker
    boot-end-marker
    logging buffered 512000 informational
    enable secret 5 $1$K8GP$JbYRetpgnaxvy2wnjrPDW/
    no aaa new-model
    network-clock-participate wic 2
    dot11 syslog
    ip source-route
    ip dhcp excluded-address 192.168.11.1 192.168.11.10
    ip dhcp excluded-address 192.168.12.1 192.168.12.10
    ip dhcp excluded-address 192.168.13.1 192.168.13.10
    ip dhcp excluded-address 192.168.14.1 192.168.14.10
    ip dhcp excluded-address 192.168.16.1 192.168.16.10
    ip dhcp excluded-address 192.168.17.1 192.168.17.10
    ip dhcp pool HQ-BR1-Pool
    import all
    network 192.168.11.0 255.255.255.0
    option 150 ip 10.10.210.10
    default-router 192.168.11.1
    domain-name proctorlabs.com
    dns-server 8.8.4.4 8.8.8.8
    lease 8
    ip dhcp pool BR2-Pool
    import all
    network 192.168.12.0 255.255.255.0
    option 150 ip 10.10.202.1
    default-router 192.168.12.1
    domain-name proctorlabs.com
    dns-server 8.8.4.4 8.8.8.8
    lease 8
    ip dhcp pool PSTN-Pool
    import all
    network 192.168.13.0 255.255.255.0
    option 150 ip 10.10.100.2
    default-router 192.168.13.1
    domain-name proctorlabs.com
    dns-server 8.8.4.4 8.8.8.8
    lease 8
    ip dhcp pool Laptop-Pool
    import all
    network 192.168.14.0 255.255.255.0
    default-router 192.168.14.1
    domain-name proctorlabs.com
    dns-server 8.8.4.4 8.8.8.8
    lease 8
    ip dhcp pool WIRELESS-HOME
    import all
    network 192.168.16.0 255.255.255.0
    default-router 192.168.16.1
    dns-server 8.8.8.8 4.2.2.2
    domain-name proctorlabs.com
    lease 8
    ip cef
    no ip domain lookup
    ip domain name proctorlabs.com
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-ni
    voice service voip
    sip
      bind control source-interface Loopback0
      bind media source-interface Loopback0
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g729r8
    voice-card 0
    crypto pki token default removal timeout 0
    license udi pid CISCO2801 sn FTX1016Y07Z
    archive
    log config
      hidekeys
    controller T1 0/2/0
    pri-group timeslots 1-3,24
    controller T1 0/2/1
    interface Loopback0
    ip address 1.1.1.1 255.255.255.255
    interface FastEthernet0/0
    description (Outside Public Interface)
    ip address dhcp
    ip access-group FW-IN in
    no ip unreachables
    ip mtu 1300
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    no cdp enable
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    interface FastEthernet0/1.11
    description (Inside Private Interface)
    encapsulation dot1Q 11
    ip address 192.168.11.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/1.12
    description (Inside Private Interface)
    encapsulation dot1Q 12
    ip address 192.168.12.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/1.13
    description (Inside Private Interface)
    encapsulation dot1Q 13
    ip address 192.168.13.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/1.14
    description (Inside Private Interface)
    encapsulation dot1Q 14
    ip address 192.168.14.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/1.15
    description LAB-SERVERS
    encapsulation dot1Q 15
    ip address 192.168.15.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/1.16
    description WIRELESS-HOME
    encapsulation dot1Q 16
    ip address 192.168.16.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/1.17
    description LAB-HQ-PHONES
    encapsulation dot1Q 17
    ip address 192.168.17.1 255.255.255.0
    ip helper-address 192.168.15.22
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/1.18
    description LAB-HQ-DATA
    encapsulation dot1Q 18
    ip address 192.168.18.1 255.255.255.0
    ip helper-address 192.168.15.22
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/1.501
    description PSTN-RTR_MGMT-NETWORK
    encapsulation dot1Q 501
    ip address 172.30.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface Serial0/2/0:23
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn incoming-voice voice
    isdn outgoing display-ie
    no cdp enable
    interface Serial0/3/0
    description HQ-RTR_IP-WAN
    no ip address
    encapsulation frame-relay IETF
    no fair-queue
    frame-relay lmi-type ansi
    interface Serial0/3/0.1 point-to-point
    ip address 10.1.1.1 255.255.255.128
    ip ospf mtu-ignore
    snmp trap link-status
    frame-relay interface-dlci 103
    interface Serial0/3/0.2 point-to-point
    ip address 10.1.1.129 255.255.255.128
    ip ospf mtu-ignore
    snmp trap link-status
    frame-relay interface-dlci 102
    interface Serial0/3/1
    no ip address
    shutdown
    clock rate 2000000
    router ospf 1
    network 1.1.1.1 0.0.0.0 area 0
    network 10.1.1.0 0.0.0.255 area 0
    network 172.30.1.0 0.0.0.3 area 0
    network 192.168.0.0 0.0.255.255 area 0
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list 101 interface FastEthernet0/0 overload
    ip route 0.0.0.0 0.0.0.0 10.0.0.1 254
    ip route 192.168.100.0 255.255.255.0 172.30.1.2
    ip route 0.0.0.0 0.0.0.0 dhcp
    access-list 101 deny   ip 192.168.0.0 0.0.255.255 10.10.0.0 0.0.255.255
    access-list 101 permit ip 192.168.0.0 0.0.255.255 any
    access-list 102 permit udp any any eq bootps
    access-list 102 permit udp any any eq bootpc
    access-list 102 permit udp any eq bootpc any
    access-list 102 permit udp any eq bootps any
    disable-eadi
    control-plane
    voice-port 0/2/0:23
    mgcp fax t38 ecm
    mgcp profile default
    dial-peer voice 91212 pots
    description PSTN-CALLS-TO-NYC-AREA-CODE
    destination-pattern 91212T
    port 0/2/0:23
    forward-digits all
    dial-peer voice 1 pots
    description INCOMING-DIAL-PEER_PSTN
    incoming called-number .
    direct-inward-dial
    port 0/2/0:23
    dial-peer voice 1000 voip
    destination-pattern 2123941...
    session protocol sipv2
    session target ipv4:192.168.15.23
    incoming called-number .
    voice-class codec 1
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 1001 voip
    preference 1
    destination-pattern 2123941...
    session protocol sipv2
    session target ipv4:192.168.15.22
    incoming called-number .
    voice-class codec 1
    dtmf-relay rtp-nte
    no vad
    sip-ua
    retry invite 2
    timers trying 300
    line con 0
    password cisco
    logging synchronous
    login
    line aux 0
    line vty 0 4
    exec-timeout 30 0
    privilege level 15
    password cisco
    logging synchronous
    login
    transport input telnet ssh
    line vty 5 15
    exec-timeout 30 0
    privilege level 15
    password cisco
    logging synchronous
    login
    transport input telnet ssh
    scheduler allocate 20000 1000
    end
    HQ-RTR#
    =============END OF HQ CONFIG=============
    =======START OF PSTN-IP-WAN_RTR CONFIG=========
    PSTN_IP-WAN_RTR#show inventory
    NAME: "2851 chassis", DESCR: "2851 chassis"
    PID: CISCO2851         , VID: V01 , SN: FTX0922A1E7
    NAME: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 0", DESCR: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1"
    PID: VWIC2-2MFT-T1/E1  , VID: V01 , SN: FOC11063UF9
    NAME: "WAN Interface Card - Serial 2T on Slot 0 SubSlot 1", DESCR: "WAN Interface Card - Serial 2T"
    PID: WIC-2T      , VID: V01, SN: 35845606
    NAME: "Two port T1 voice interface daughtercard on Slot 0 SubSlot 2", DESCR: "Two port T1 voice interface daughtercard"
    PID: VWIC-2MFT-T1=     , VID: 1.0, SN: 29803060
    NAME: "WAN Interface Card - Serial 2T on Slot 0 SubSlot 3", DESCR: "WAN Interface Card - Serial 2T"
    PID: WIC-2T=           , VID: 1.0, SN: 23188546
    NAME: "PVDMII DSP SIMM with Two DSPs on Slot 0 SubSlot 4", DESCR: "PVDMII DSP SIMM with Two DSPs"
    PID: PVDM2-32          , VID: V01 , SN: FOC12045356
    PSTN_IP-WAN_RTR#show controllers t1
    T1 0/2/0 is down.
      Applique type is Channelized T1
      Cablelength is long gain36 0db
      Description: HQ_T1
      Transmitter is sending remote alarm.
      Receiver has loss of signal.
      alarm-trigger is not set
      Soaking time: 3, Clearance time: 10
      AIS State:Clear  LOS State:Clear  LOF State:Clear
      Version info Firmware: 20071129, FPGA: 20, spm_count = 0
      Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
      CRC Threshold is 320. Reported from firmware  is 320.
      Data in current interval (852 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 852 Unavail Secs
      Total Data (last 24 hours)
         0 Line Code Violations, 0 Path Code Violations,
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
    T1 0/2/1 is down.
      Applique type is Channelized T1
      Cablelength is long gain36 0db
      Description: BR1_T1
      Transmitter is sending remote alarm.
      Receiver has loss of signal.
      alarm-trigger is not set
      Soaking time: 3, Clearance time: 10
      AIS State:Clear  LOS State:Clear  LOF State:Clear
      Version info Firmware: 20071129, FPGA: 20, spm_count = 0
      Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
      CRC Threshold is 320. Reported from firmware  is 320.
      Data in current interval (854 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 854 Unavail Secs
      Total Data (last 24 hours)
         0 Line Code Violations, 0 Path Code Violations,
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
    PSTN_IP-WAN_RTR#show controllers e1
    E1 0/0/0 is down.
      Applique type is Channelized E1 - balanced
      Cablelength is Unknown
      Description: BR2_E1
      Transmitter is sending remote alarm.
      Receiver has loss of signal.
      alarm-trigger is not set
      Version info Firmware: 20071011, FPGA: 13, spm_count = 0
      Framing is CRC4, Line Code is HDB3, Clock Source is Internal.
      Data in current interval (862 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 862 Unavail Secs
      Total Data (last 24 hours)
         0 Line Code Violations, 0 Path Code Violations,
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
    E1 0/0/1 is down.
      Applique type is Channelized E1 - balanced
      Cablelength is Unknown
      Transmitter is sending remote alarm.
      Receiver has loss of signal.
      alarm-trigger is not set
      Version info Firmware: 20071011, FPGA: 13, spm_count = 0
      Framing is CRC4, Line Code is HDB3, Clock Source is Internal.
      Data in current interval (864 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 864 Unavail Secs
      Total Data (last 24 hours)
         0 Line Code Violations, 0 Path Code Violations,
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
    PSTN_IP-WAN_RTR#
    PSTN_IP-WAN_RTR#
    PSTN_IP-WAN_RTR#show isdn status
    Global ISDN Switchtype = primary-net5
    ISDN Serial0/0/0:15 interface
            ******* Network side configuration *******
            dsl 0, interface ISDN Switchtype = primary-net5
        Layer 1 Status:
            DEACTIVATED
        Layer 2 Status:
            TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        Layer 3 Status:
            0 Active Layer 3 Call(s)
        Active dsl 0 CCBs = 0
        The Free Channel Mask:  0x00000000
        Number of L2 Discards = 0, L2 Session ID = 0
    ISDN Serial0/0/1:15 interface
            ******* Network side configuration *******
            dsl 1, interface ISDN Switchtype = primary-net5
        Layer 1 Status:
            DEACTIVATED
        Layer 2 Status:
            TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        Layer 3 Status:
            0 Active Layer 3 Call(s)
        Active dsl 1 CCBs = 0
        The Free Channel Mask:  0x00000000
        Number of L2 Discards = 0, L2 Session ID = 0
    ISDN Serial0/2/0:23 interface
            ******* Network side configuration *******
            dsl 2, interface ISDN Switchtype = primary-ni
        Layer 1 Status:
            DEACTIVATED
        Layer 2 Status:
            TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        Layer 3 Status:
            0 Active Layer 3 Call(s)
        Active dsl 2 CCBs = 0
        The Free Channel Mask:  0x00000000
        Number of L2 Discards = 0, L2 Session ID = 0
    ISDN Serial0/2/1:23 interface
            ******* Network side configuration *******
            dsl 3, interface ISDN Switchtype = primary-ni
        Layer 1 Status:
            DEACTIVATED
        Layer 2 Status:
            TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        Layer 3 Status:
            0 Active Layer 3 Call(s)
        Active dsl 3 CCBs = 0
        The Free Channel Mask:  0x00000000
        Number of L2 Discards = 0, L2 Session ID = 0
        Total Allocated ISDN CCBs = 0
    PSTN_IP-WAN_RTR#
    PSTN_IP-WAN_RTR#show run
    Building configuration...
    Current configuration : 6518 bytes
    ! Last configuration change at 23:02:02 CST Tue Feb 4 2014
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname PSTN_IP-WAN_RTR
    boot-start-marker
    boot-end-marker
    card type e1 0 0
    logging message-counter syslog
    enable secret 5 $1$rLlG$MPPST59p5rs0FfXu8OXp1.
    no aaa new-model
    clock timezone CST -6
    clock summer-time CDT recurring
    network-clock-participate wic 0
    network-clock-participate wic 2
    dot11 syslog
    ip source-route
    ip cef
    ip dhcp excluded-address 192.168.100.1 192.168.100.10
    ip dhcp pool PSTN-PHONE
       network 192.168.100.0 255.255.255.0
       default-router 192.168.100.1
       option 150 ip 192.168.100.1
    no ip domain lookup
    no ipv6 cef
    multilink bundle-name authenticated
    frame-relay switching
    isdn switch-type primary-net5
    voice translation-rule 1
    rule 1 /^011\(.*\)/ /\1/
    rule 2 /^1\(.*\)/ /&/
    rule 3 /^00\(.*\)/ /\1/
    rule 4 /^617\(.*\)/ /1&/
    rule 5 /^212\(.*\)/ /1&/
    voice translation-rule 2
    rule 1 /^617/ /1&/
    rule 2 /^212/ /1&/
    voice translation-rule 3
    rule 1 /^212/ /1&/
    rule 2 /^34/ /&/
    voice translation-rule 4
    rule 1 /^617/ /1&/
    rule 2 /^34/ /&/
    voice translation-profile BR1-OUT
    translate calling 3
    voice translation-profile BR2-OUT
    translate calling 2
    voice translation-profile HQ-OUT
    translate calling 4
    voice translation-profile PSTN-IN
    translate called 1
    voice-card 0
    crypto pki token default removal timeout 0
    archive
    log config
      hidekeys
    controller E1 0/0/0
    clock source internal
    pri-group timeslots 1-3,16
    description BR2_E1
    controller E1 0/0/1
    clock source internal
    pri-group timeslots 1-3,16
    controller T1 0/2/0
    clock source internal
    pri-group timeslots 1-3,24
    description HQ_T1
    controller T1 0/2/1
    clock source internal
    pri-group timeslots 1-3,24
    description BR1_T1
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/0.13
    description PSTN-PHONE_LAN
    encapsulation dot1Q 13
    ip address 192.168.100.1 255.255.255.0
    interface GigabitEthernet0/1
    description MGMT-CONNECTION-via-WIFI
    ip address 172.30.1.2 255.255.255.0
    duplex auto
    speed auto
    interface Serial0/0/0:15
    description BR2-PSTN-CONNECTION
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    interface Serial0/0/1:15
    description BR2-PSTN-CONNECTION
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    interface Serial0/1/0
    description FR_to_BR2-RTR
    no ip address
    encapsulation frame-relay IETF
    clock rate 64000
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 301 interface Serial0/3/0 103
    interface Serial0/1/1
    no ip address
    shutdown
    clock rate 2000000
    interface Serial0/2/0:23
    description HQ-PSTN-CONNECTION
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    interface Serial0/2/1:23
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    interface Serial0/3/0
    description FR_to_HQ-RTR_point-to-point-BR1andBR2
    no ip address
    encapsulation frame-relay IETF
    clock rate 64000
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 102 interface Serial0/3/1 201
    frame-relay route 103 interface Serial0/1/0 301
    interface Serial0/3/1
    description FR_to_BR1-RTR-to-HQ-RTR
    no ip address
    encapsulation frame-relay IETF
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 201 interface Serial0/3/0 102
    ip forward-protocol nd
    ip route 1.1.1.1 255.255.255.255 172.30.1.1
    ip route 2.2.2.2 255.255.255.255 172.30.1.1
    ip route 3.3.3.3 255.255.255.255 172.30.1.1
    ip route 10.1.1.0 255.255.255.0 172.30.1.1
    ip route 192.168.14.0 255.255.255.0 172.30.1.1
    ip route 192.168.15.0 255.255.255.0 172.30.1.1
    ip route 192.168.16.0 255.255.255.0 172.30.1.1
    ip route 192.168.17.0 255.255.255.0 172.30.1.1
    ip route 192.168.20.0 255.255.255.0 172.30.1.1
    ip route 192.168.21.0 255.255.255.0 172.30.1.1
    ip route 192.168.30.0 255.255.255.0 172.30.1.1
    ip route 192.168.31.0 255.255.255.0 172.30.1.1
    no ip http server
    no ip http secure-server
    tftp-server flash:P0030801SR02.bin
    tftp-server flash:P0030801SR02.loads
    tftp-server flash:P0030801SR02.sb2
    tftp-server flash:P0030801SR02.sbn
    tftp-server P0030801SR02.txt
    control-plane
    voice-port 0/0/0:15
    voice-port 0/2/0:23
    voice-port 0/0/1:15
    voice-port 0/2/1:23
    ccm-manager fax protocol cisco
    mgcp fax t38 ecm
    dial-peer voice 1 pots
    incoming called-number .
    direct-inward-dial
    dial-peer voice 10 pots
    description HQ-NATIONAL-CALLS-DIAL-PEER
    destination-pattern 2123941...
    port 0/2/0:23
    forward-digits all
    dial-peer voice 20 pots
    description BR1-NATIONAL-CALLS-DIAL-PEER
    destination-pattern 6178632...
    port 0/2/1:23
    forward-digits all
    dial-peer voice 30 pots
    description BR2-NATIONAL-CALLS-DIAL-PEER
    destination-pattern 32143...
    port 0/0/0:15
    forward-digits all
    dial-peer voice 31 pots
    description BR2-INTL-CALLS-DIAL-PEER
    destination-pattern 3432143...
    port 0/0/0:15
    forward-digits all
    telephony-service
    em logout 0:0 0:0 0:0
    max-ephones 2
    max-dn 10
    ip source-address 192.168.100.1 port 2000
    load 7960-7940 P00303020214
    keepalive 10
    max-conferences 4 gain -6
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    ephone-dn  1
    number 12123945001
    label +8087812321
    description NYC
    name NYC-PSTN
    ephone-dn  2
    number 16178635001
    label 911+999
    description BOSTON
    name BOSTON-PSTN
    ephone-dn  3
    number 32145001
    label 18005551234
    description SPAIN
    name SPAIN-PSTN
    ephone-dn  4
    number 3432145002
    description SPAIN
    name SPAIN-PSTN-INTL
    ephone-dn  5
    number 5005
    label 7812321
    description 7812321
    ephone-dn  6
    number 5006
    label x5005
    description OFFICE PHONE
    ephone  1
    device-security-mode none
    mac-address 0008.A3FD.39FF
    type 7960
    button  1:1 2:2 3:3 4:4
    button  5:5
    banner motd ^CC PSTN-IP-WAN ROUTER ^C
    line con 0
    password cisco
    logging synchronous
    login
    line aux 0
    line vty 0 4
    password cisco
    login
    transport input all
    line vty 5 15
    password cisco
    login
    transport input all
    scheduler allocate 20000 1000
    ntp master
    end
    PSTN_IP-WAN_RTR#

    I have went ahead and re-enabled the voice-ports just because I left that out of my original output.  See below.....
    Do you think I ordered 3 factory made T1 cables from BlackBox and ALL of them came back to me bad?  Or perhaps they might not have made them as cross over cables......hmm...any other suggestions?
    BR2_RTR(config)#voice-port 0/0/0:15
    BR2_RTR(config-voiceport)#no shut
    BR2_RTR(config-voiceport)#do sh voice port summ
    BR2_RTR(config-voiceport)#do sh voice port summ
                                               IN       OUT
    PORT            CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
    =============== == ============ ===== ==== ======== ======== ==
    0/0/0:15        01  isdn-voice  up    down none     none     y
    0/0/0:15        02  isdn-voice  up    down none     none     y
    0/0/0:15        03  isdn-voice  up    down none     none     y
    50/0/1          1      efxs     up    dorm on-hook  idle     y
    50/0/2          1      efxs     up    dorm on-hook  idle     y
    PWR FAILOVER PORT        PSTN FAILOVER PORT
    =================        ==================
    HQ-RTR(config)#voice-port 0/2/0:23
    HQ-RTR(config-voiceport)#no shut
    HQ-RTR(config-voiceport)#
    HQ-RTR(config-voiceport)#
    HQ-RTR(config-voiceport)#do sh voice port summ
                                               IN       OUT
    PORT            CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
    =============== == ============ ===== ==== ======== ======== ==
    0/2/0:23        01  isdn-voice  up    down none     none     y
    0/2/0:23        02  isdn-voice  up    down none     none     y
    0/2/0:23        03  isdn-voice  up    down none     none     y
    PWR FAILOVER PORT        PSTN FAILOVER PORT
    =================        ==================
    PSTN_IP-WAN_RTR#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    PSTN_IP-WAN_RTR(config)#voice-p
    PSTN_IP-WAN_RTR(config)#voice-port 0/0/0:15
    PSTN_IP-WAN_RTR(config-voiceport)#no shut
    PSTN_IP-WAN_RTR(config-voiceport)#exit
    PSTN_IP-WAN_RTR(config)#voice-por
    PSTN_IP-WAN_RTR(config)#voice-port 0/2/0:23
    PSTN_IP-WAN_RTR(config-voiceport)#no shut
    PSTN_IP-WAN_RTR(config-voiceport)#exit
    PSTN_IP-WAN_RTR(config)#voice-por
    PSTN_IP-WAN_RTR(config)#voice-port 0/0/1:15
    PSTN_IP-WAN_RTR(config-voiceport)#no shut
    PSTN_IP-WAN_RTR(config-voiceport)#exit
    PSTN_IP-WAN_RTR(config)#voice-port 0/2/1:23
    PSTN_IP-WAN_RTR(config-voiceport)#no shut
    PSTN_IP-WAN_RTR(config-voiceport)#exit
    PSTN_IP-WAN_RTR(config)#
    PSTN_IP-WAN_RTR(config)#
    PSTN_IP-WAN_RTR(config)#
    PSTN_IP-WAN_RTR(config)#do sh voice port summ
                                               IN       OUT
    PORT            CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
    =============== == ============ ===== ==== ======== ======== ==
    0/0/0:15        01  isdn-voice  up    dorm none     none     y
    0/0/0:15        02  isdn-voice  up    dorm none     none     y
    0/0/0:15        03  isdn-voice  up    dorm none     none     y
    0/2/0:23        01  isdn-voice  up    dorm none     none     y
    0/2/0:23        02  isdn-voice  up    dorm none     none     y
    0/2/0:23        03  isdn-voice  up    dorm none     none     y
    0/0/1:15        01  isdn-voice  up    dorm none     none     y
    0/0/1:15        02  isdn-voice  up    dorm none     none     y
    0/0/1:15        03  isdn-voice  up    dorm none     none     y
    0/2/1:23        01  isdn-voice  up    dorm none     none     y
    0/2/1:23        02  isdn-voice  up    dorm none     none     y
    0/2/1:23        03  isdn-voice  up    dorm none     none     y
    50/0/1          1      efxs     up    dorm on-hook  idle     y
    50/0/2          1      efxs     up    dorm on-hook  idle     y
    50/0/3          1      efxs     up    dorm on-hook  idle     y
    50/0/4          1      efxs     up    dorm on-hook  idle     y
    50/0/5          1      efxs     up    dorm on-hook  idle     y
    50/0/6          1      efxs     up    up   on-hook  idle     y
    PWR FAILOVER PORT        PSTN FAILOVER PORT
    =================        ==================
    PSTN_IP-WAN_RTR(config)#

Maybe you are looking for

  • Is mac mini worth the price

    i am thinking of get a mac mini in the near future i am wondering if it is worth the 599 canadian and i have a old monitor that uses vga and i have usb keyboard and usb mouse that are designed for windows and desktop pc

  • Sql Server Configuration is Not Displayed!!

    hi all,  i am using SQL server 2008. i have sysadmin permission in server level, also i have administrator privilege from the windows security. i am getting the below error when i am trying to see SQL server services in sql server configuration manag

  • Smartform into PDF and store in folder of  application server

    Hi Gurus,      I have to solve this issue please help meu2026 1.Convert Smartform into PDF and store in folder of  application server 2.print the PDF stored in folder(Application Server) automatically Please give suggestion for the above.. Moderator

  • Video stutter, etc with Adobe Premiere Elements 8

    Have had the the program for few days, and actually was excited about using it.  I have Windows Vista.  The video that I am trying import is on a Western Digital storage.  The playback in the work area is stutteringm fuzzy and not clear.  I am bangin

  • Mac mini won't boot after accidental loss of power during firmware upgrade

    i accidentally hit the power switch on the wall during an upgrade (might even have been a firmware upgrade, I didn't really look at what was going on).  Anyway, now it hangs on the silver Apple logo screen with a spinny wheel on reboot.  It's only 3