Port-Channel Issue: SP-5-CANNOT_BUNDLE_LACP

I'm having an issue with the port-channel coming up. Right now it's "down down". I'm not really sure why. All other port-channels on the 6500's in VSS work fine. This one seems to be giving me an issue though.
-Both interfaces that are using this port-channel are "up up".
-I've done "shut's, no shut's" on all interfaces involved.
sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
        M - not in use, no aggregation due to minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        d - default port
Po4(SD)         LACP      Gi1/1/4(I)     Gi2/1/4(I)  
interface Port-channel4
switchport
switchport access vlan (vlan number)
switchport mode access
load-interval 30
flowcontrol receive desired
spanning-tree portfast edge
end
interface GigabitEthernet1/1/4
switchport
switchport access vlan   (vlan number)
switchport mode access
load-interval 30
flowcontrol receive desired
spanning-tree portfast edge
channel-protocol lacp
channel-group 4 mode active
end
interface GigabitEthernet2/1/4
switchport
switchport access vlan  (vlan number)
switchport mode access
load-interval 30
flowcontrol receive desired
spanning-tree portfast edge
channel-protocol lacp
channel-group 4 mode active
end
sh log
149886: Jul  3 15:20:34 CDT: %EC-SW1_SP-5-CANNOT_BUNDLE_LACP: Gi2/1/4 is not compatible with aggregators in channel 4 and cannot attach to them (flow control receive of Gi2/1/4 is desired, Gi1/1/4 is on)
149887: Jul  3 15:20:35 CDT: %EC-SW2_SPSTBY-5-CANNOT_BUNDLE_LACP: Gi2/1/4 is not compatible with aggregators in channel 4 and cannot attach to them (flow control receive of Gi2/1/4 is desired, Gi1/1/4 is on)
Thank you for your help.

HI Mark,
1. Can you please check your ethernet card ...where this port channel connected..on the server.
    may be there are 2 different card.
2. from cisco websites:
Error Message
Explanation
This port has different port attributes than other ports within the port channel.
Recommended Action
Match the port attributes to that of the port channel.
Regards
Please rate if it helps.
Match the port attributes to that of the port channel.This port has different port attributes than other ports within the port channel.
EC-5-CANNOT_BUNDLE_LACP: [char] is not compatible with aggregators in
channel [dec] and cannot attach to them ([char])

Similar Messages

  • Port-channel issue with FI-N7k using rate-mode share

    Hi Dears,
    I'm trying to using port-channel between Fabric Interconnect (FI) and N7K. in N7K use rate-mode share and LACP but the port-channel in N7K was suspended.
    I was trying :
    1. I using non dedicated port in Nexus 7010.
          - rate-mode share
          - channel-group 1 mode active
          - switchport mode trunk
    when i using this option, the port-channel in Nexus 7010 was suspended
    2. I using non dedicated port in Nexus 7010
         - rate-mode share
         - channel group 1 mode on
         - switchport mode trunk
    when i using this option, the port-channel in Nexus 7010 was came up, but in Fabric interconnect was failed.
    3. I using dedicated port in Nexus 7010
         - rate-mode share
         - channel group 1 mode active
         - switchport mode trunk
    when i using this option, the port-channel in Nexus 7010 was suspended
    4. I using dedicated port in Nexus 7010
         - rate-mode dedicated
         - channel group 1 mode active
         - switchport mode trunk
    when i using this option, the port-channel in Nexus 7010 was came up and running well.
    is any other way to configure port-channel in N7K with rate-mode share and LACP ?
    or it's some of limitation in port-channel when using rate-mode share at N7K ?
    nb: fabric interconnect only support LACP and cannot be configurable.
    regards,
    Berwin H

    HI Mark,
    1. Can you please check your ethernet card ...where this port channel connected..on the server.
        may be there are 2 different card.
    2. from cisco websites:
    Error Message
    Explanation
    This port has different port attributes than other ports within the port channel.
    Recommended Action
    Match the port attributes to that of the port channel.
    Regards
    Please rate if it helps.
    Match the port attributes to that of the port channel.This port has different port attributes than other ports within the port channel.
    EC-5-CANNOT_BUNDLE_LACP: [char] is not compatible with aggregators in
    channel [dec] and cannot attach to them ([char])

  • Port Channel Issue on Cisco 2960s-24ts

    Hi All
    Last week at a customer site we installed a 2nd 2960s 24 port switch to form a stack using flexstack cables, and the switch stack is working as expected as I can see a master switch and 2nd switch as a member.
    For redundancy / resilience we decided to use port 24 on each switch over copper for trunk uplinks to our core switch. The issue that we're having is I can't ping the switch management address. I can however see the address in the arp table and the edge switch is visible when I run show cdp nei. As a work around I've shutdown one of the ports to the downlink from core to edge in order to ping the management address of the switch which is in vlan 1. I'd like to get the port-channel working on both sides for resilience.
    ANY HELP IS APPRECIATED...
    Core switch is a WS-C3750G-24TS-1U running software version  C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(25r)SEE4, C3750 Software (C3750-IPBASE-M)
    Edge switch is a WS-C2960S-24TS-L running software version C2960S Boot Loader (C2960S-HBOOT-M) Version 12.2(53r)SE,C2960S Software (C2960S-UNIVERSALK9-M)
    The config on the edge switch which goes to the core is :
    interface GigabitEthernet1/0/24
     description *****
     switchport mode trunk
     channel-group 6 mode on
    end
    interface GigabitEthernet2/0/24
     description *****
     switchport mode trunk
     channel-group 6 mode on
    end
    interface Port-channel6
     description ******
     switchport mode trunk
    end
    The config on the downlink ports from the core to the edge:
    interface GigabitEthernet1/0/20
     description Edge
     switchport trunk encapsulation dot1q
     switchport mode trunk
     channel-group 20 mode on
    end
    interface GigabitEthernet2/0/20
     description Edge
     switchport trunk encapsulation dot1q
     switchport mode trunk
     shutdown
     channel-group 20 mode on
    end
    interface Port-channel20
     description Edge
     switchport trunk encapsulation dot1q
     switchport mode trunk
    end

    when using channel-group # on mode you must make sure the ports are on same duplex and speed setting
    what happens when you use active mode?

  • Port-channel issue over Ciena DWDM

    Hi all, 
    I'm currently working on an issue encountered on a DC. 
    We currently use 2 3750 stacks (1 in each DC), connected with a Po. 
    We use dark fiber between each DC, so we have a Ciena DWDM transponder on each side. 
    The problem is that, if we have an issue on the inter-DC fiber, the Ciena interface on the 3750 side is still up. Using LACP on the Po, the issue can be detected in about 3 X 30 sec = 90 sec. 
    Before the issue is detected by LACP, the impacted port-channel interface is still used by the Po, which can cause big issues. 
    I thought use an EEM applet in order to monitor the CDP neighbor on each interface, and exclude the interface from the Po till the CDP neighbor is down, but the CDP timers are even bigger (180 sec hold-time). 
    Is there any way to address this problem, other than UDLD ? 
    In our others DC, we have two NX7K on each side, and we are able to use LACP with fast-rate, but this is not available on 3750... 
    Thank you very much ! 

    the best way to use pair of transponders on each side in protection group.

  • Port channel issue in ASA

    We have two Cisco ASA 55XX Firewalls and both are in HA (Active/Standy). Two ports from each Firewall is connecting two ports of Nexus 5K Switch and running port channel between Firewall & Nexus Switch and port-channel is UP. And Switches having back to back connection with allowed all VLAN trunk port.
    FW01 ----------------- SW01 (Two ports with Port channel)
    FW02 ----------------- SW02 (Two ports with Port channel)
    I have VLAN 10 with IP Subnet 10.10.10.0/28
    SW01 : 10.10.10.2
    SW02 : 10.10.10.3
    HSRP IP : 10.10.10.1
    FWs :  10.10.10.4 & 10.10.10.5
    Firewall Default Gateway : 10.10.10.1
    Problem : I am not able Ping Firewall IPs from Nexus Switches. When I checked ARP table in Nexus Switch; I have observed that Firealls two IPs having same MAC address; when I checked that MAC address in the Firewall; that MAC address is Port channel interface MAC address.
    This is issue (two IPs learing same MAC address) from ASA.
    How to fix this issue ?
    Thanks
    Venkat

    Hi,
    What version of IOS are you running on the ASAs?
    see table-12-3 in this link:
    http://www.cisco.com/c/en/us/td/docs/security/asa/asa84/configuration/guide/asa_84_cli_config/interface_start.html
    Also, since the 4500x are in VSS mode, you need to bundle one link from each switch and use LACP.
    HTH

  • Port-Channel issue between UCS FI and MDS 9222i switch

    Hi
    I have a problem between UCS FI and MDS switch port-channel. When MDS-A is powered down the port-channel fails but UCS blade vHBA does not detect the failure of the port-chanel on UCS-FI and leaves the vHBA online. However, if there is no port-channel between FI-->MDS it works fine.
    UCS version   
    System version: 2.0(2q)
    FI - Cisco UCS 6248 Series Fabric Interconnect ("O2 32X10GE/Modular Universal Platform Supervisor")
    Software
      BIOS:      version 3.5.0
      loader:    version N/A
      kickstart: version 5.0(3)N2(2.02q)
      system:    version 5.0(3)N2(2.02q)
      power-seq: Module 1: version v1.0
                 Module 3: version v2.0
      uC:        version v1.2.0.1
      SFP uC:    Module 1: v1.0.0.0
    MDS 9222i
    Software
      BIOS:      version 1.0.19
      loader:    version N/A
      kickstart: version 5.0(8)
      system:    version 5.0(8)
    Here is the config from MDS switch
    Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port
                      Mode   Trunk                          Mode  Speed  Channel
                             Mode                                 (Gbps)
    fc1/1      103    auto   on      trunking         swl    TF      4    10
    fc1/2      103    auto   on      trunking         swl    TF      4    10
    fc1/9      103    auto   on      trunking         swl    TF      4    10
    fc1/10     103    auto   on      trunking         swl    TF      4    10
    This is from FI.
    Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port
                      Mode   Trunk                          Mode  Speed  Channel
                             Mode                                 (Gbps)
    fc1/29     103    NP     on      trunking         swl    TNP     4    103
    fc1/30     103    NP     on      trunking         swl    TNP     4    103
    fc1/31     103    NP     on      trunking         swl    TNP     4    103
    fc1/32     103    NP     on      trunking         swl    TNP     4    103
    Any thoughts on this?

    Sultan,
    This is a recently found issue and is fixed in UCSM 2.0.3a version .
    http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCua88227
    which got duped to  CSCtz21585
    It happens only when following conditions are met
    FI in End host mode
    FC uplinks are configured for portchannel + trunking
    Certain link event failures ( such abrupt power loss by upstream MDS switch )
    Padma

  • Port channel issue

    Hello 
    I need help plz , i have 2X stacking Cisco core switch 3850 and access switches 2960X over the floors. I did the configuration but port channel still down , kindly check the below config:-
    3850
    interface Port-channel1
     switchport mode trunk
    inter gi1/0/1
    switchport trunk allowed vlan 85,90,95
     switchport mode trunk
     channel-group 1 mode active
    inter gi1/0/2
    switchport trunk allowed vlan 85,90,95
     switchport mode trunk
     channel-group 1 mode active
    2960
    interface Port-channel1
     switchport mode trunk
    inter Tengi1/0/1
    switchport trunk allowed vlan 85,90,95
     switchport mode trunk
     channel-group 1 mode active
    inter Tengi2/0/1
    switchport trunk allowed vlan 85,90,95
     switchport mode trunk
     channel-group 1 mode active
    The goal that i have access switch should connect to my two core switches using two uplinks and i need to merge the uplinks speed.
    Any idea

    Hello
    Kindly find the below 
    Core_switch#show etherchannel summary
    Number of channel-groups in use: 6
    Number of aggregators:           6
    Group  Port-channel  Protocol    Ports
    ------+-------------+-----------+-----------------------------------------------
    3      Po3(SD)         LACP      Gi1/0/5(I)  Gi2/0/5(I)
    ACCESS_Floor_3#show etherchannel summary
    Number of channel-groups in use: 1
    Number of aggregators:           1
    Group  Port-channel  Protocol    Ports
    ------+-------------+-----------+-----------------------------------------------
    3      Po3(SD)         LACP      Te1/0/1(D)  Te2/0/1(D)
    I need to connect my stack switches which located on 1st floor to core switch using two uplinks one uplink teng1/0/1 to 1st core port 1/0/5 in stack and other uplink 2/0/1 to 2nd core on the stack port. 2/0/5.
    thanks

  • Port-channel issues

    We installed a CISCO 6509e with 2 Sup 720 blades in one building that is about 600m from our corporate HQs.  We have a CISC 4507 with 2 Sup 6-E with 10G.  We have them connected with fiber using 10g gbic LMR optics in the 10g ports of the sup blades.  The link comes up.  We moved it to a trunk and set up port channeling.  The link will come up as a trunk but the port channel is not coming up.  We are at a bit of a loss, we have several closets through the 2 buildings and we utilize port channeling on all of our switches.  Below are the interfaces for the 2 interfaces and port channels, we had hoped to add more interfaces to this port channel but we are on hold until we can determine the reason for the port channel not coming up.
    6509E
    interface Port-channel4
     switchport
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface TenGigabitEthernet5/4
     description B2B 10G
     switchport
     switchport trunk encapsulation dot1q
     switchport mode trunk
     channel-group 4 mode auto
    GigabitEthernet5/3     unassigned      YES manual down                  down    
    TenGigabitEthernet5/4  unassigned      YES unset  up                    up  
     Port-channel4          unassigned      YES unset  down                  down 
    4507
    interface Port-channel8
     switchport
     switchport mode trunk
    interface TenGigabitEthernet1/1
     description CORE-TO-CORE
     switchport mode trunk
     channel-group 8 mode desirable
    TenGigabitEthernet1/1  unassigned      YES unset  up                    up  
    Port-channel8          unassigned      YES unset  down                  down 

    The physical port-channel configuration don't match.  4500 is "desirable" while the 6500 is "auto".

  • Port channel failure / lacp_switch_get_new_agg_id: secondary l3 agg are not supported

    hi,
    hope that someone can help.
    I ran into port channel issue when trying to add 4 port Quantum Dxi server into a port channel in 3750 stack.
    Configs looks ok:
    interface Port-channel6
    description qdx-server
    switchport access vlan 3
    switchport mode access
    spanning-tree portfast
    spanning-tree bpduguard enable
    end
    all four ports configured as follows
    interface GigabitEthernet1/0/7 , 1/0/5 , 2/0/7 and 2/0/8
    description qdx-server-ethx
    switchport access vlan 3
    switchport mode access
    spanning-tree portfast
    spanning-tree bpduguard enable
    channel-protocol lacp
    channel-group 6 mode active
    end
    all ports joined the channel except Gi 1/0/5 - it got suspended once joined the port channel
    From the debug I got the following:
    Dec 16 13:36:43.082 GMT: FEC: lacp_switch_get_new_agg_id: secondary l3 agg are not supported Po6
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_agc_compatable: comparing GC values of Gi1/0/5 Gi1/0/7 flag = 1 1
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_port_attrib_diff: compare LACP modes for Gi1/0/5
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_port_attrib_diff: Gi1/0/5 Gi1/0/7 same
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_agc_compatable: GC values are compatable
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_restart_if_needed(1): Gi1/0/5 in list
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_invoke_port_down: Gi1/0/5
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_invoke_port_up: Gi1/0/5
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_agc_compatable: comparing GC values of Gi1/0/5 Gi1/0/7 flag = 1 1
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_port_attrib_diff: compare LACP modes for Gi1/0/5
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_port_attrib_diff: Gi1/0/5 Gi1/0/7 same
    Dec 16 13:36:46.823 GMT: FEC: pagp_switch_agc_compatable: GC values are compatable
    Dec 16 13:36:46.823 GMT: FEC: lacp_switch_calculate_oper_key: oper_key for port Gi1/0/5 is 0x6
    Dec 16 13:36:46.982 GMT: FEC: lacp_switch_get_first_agg_id_from_admin_oper_keys: found aggregator Po6 for admin_key [0x6] and oper_key [0x6]
    Dec 16 13:36:46.982 GMT: FEC: lacp_switch_is_aggregator_valid: aggregator Po6 is still valid
    Dec 16 13:36:46.982 GMT: FEC: lacp_switch_get_first_associated_port_from_agg_id: found port Gi2/0/8 associated to Po6
    Dec 16 13:36:46.982 GMT: FEC: lacp_switch_is_aggregator_valid: aggregator Po6 is still valid
    Dec 16 13:36:46.982 GMT: FEC: lacp_switch_get_next_agg_id_from_admin_oper_keys: aggregator next to Po6 not found for admin_key [0x6] and oper_key [0x6]
    Dec 16 13:36:46.982 GMT: FEC: lacp_switch_get_new_agg_id: secondary l3 agg are not supported Po6
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_agc_compatable: comparing GC values of Gi1/0/5 Gi1/0/7 flag = 1 1
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_port_attrib_diff: compare LACP modes for Gi1/0/5
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_port_attrib_diff: Gi1/0/5 Gi1/0/7 same
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_agc_compatable: GC values are compatable
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_restart_if_needed(1): Gi1/0/5 in list
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_invoke_port_down: Gi1/0/5
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_invoke_port_up: Gi1/0/5
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_agc_compatable: comparing GC values of Gi1/0/5 Gi1/0/7 flag = 1 1
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_port_attrib_diff: compare LACP modes for Gi1/0/5
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_port_attrib_diff: Gi1/0/5 Gi1/0/7 same
    Dec 16 13:36:56.830 GMT: FEC: pagp_switch_agc_compatable: GC values are compatable
    Dec 16 13:36:56.838 GMT: FEC: lacp_switch_calculate_oper_key: oper_key for port Gi1/0/5 is 0x6
    Dec 16 13:36:56.880 GMT: FEC: lacp_switch_get_first_agg_id_from_admin_oper_keys: found aggregator Po6 for admin_key [0x6] and oper_key [0x6]
    Dec 16 13:36:56.880 GMT: FEC: lacp_switch_is_aggregator_valid: aggregator Po6 is still valid
    Dec 16 13:36:56.880 GMT: FEC: lacp_switch_get_first_associated_port_from_agg_id: found port Gi2/0/8 associated to Po6
    Dec 16 13:36:56.880 GMT: FEC: lacp_switch_is_aggregator_valid: aggregator Po6 is still valid
    Dec 16 13:36:56.880 GMT: FEC: lacp_switch_get_next_agg_id_from_admin_oper_keys: aggregator next to Po6 not found for admin_key [0x6] and oper_key [0x6]
    Dec 16 13:36:56.880 GMT: FEC: lacp_switch_get_new_agg_id: secondary l3 agg are not supported Po6
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_agc_compatable: comparing GC values of Gi1/0/5 Gi1/0/7 flag = 1 1
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_port_attrib_diff: compare LACP modes for Gi1/0/5
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_port_attrib_diff: Gi1/0/5 Gi1/0/7 same
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_agc_compatable: GC values are compatable
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_restart_if_needed(1): Gi1/0/5 in list
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_invoke_port_down: Gi1/0/5
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_invoke_port_up: Gi1/0/5
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_agc_compatable: comparing GC values of Gi1/0/5 Gi1/0/7 flag = 1 1
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_port_attrib_diff: compare LACP modes for Gi1/0/5
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_port_attrib_diff: Gi1/0/5 Gi1/0/7 same
    Dec 16 13:37:06.837 GMT: FEC: pagp_switch_agc_compatable: GC values are compatable
    Dec 16 13:37:06.837 GMT: FEC: lacp_switch_calculate_oper_key: oper_key for port Gi1/0/5 is 0x6
    Dec 16 13:37:07.080 GMT: FEC: lacp_switch_get_first_agg_id_from_admin_oper_keys: found aggregator Po6 for admin_key [0x6] and oper_key [0x6]
    Dec 16 13:37:07.080 GMT: FEC: lacp_switch_is_aggregator_valid: aggregator Po6 is still valid
    Checked and compared the config from another server, all looks OK.. I tried to search the error message in bold, but can't find any.
    Can anyone shed a light?
    Many thanks.

    we have the same issue with asa5525 and 3750E etherchannel.
    The same error
    lacp_switch_get_new_agg_id: secondary l3 agg are not supported on the SWITCH side
    we are using LACP active from noth sides

  • 7200/7301 MTU issue on Port-Channel

    Hi guys,
    I have an issue with MTU on port-channel :
    When I create a port-channel interface, I can set MTU to 1530 max
    When I configure an interface in this port-channel, I can set port-channel MTU to 9216 max.
    But when I reload, "mtu 9216" command is rejected and port-channel MTU is set to 1500 :
     mtu 9216
            ^
    % Invalid input detected at '^' marker.
    %Interface MTU set to channel-group MTU 1500.
    IOS version is 12.4(25g)
    Thank you so much.

    Hi guys,
    I have an issue with MTU on port-channel :
    When I create a port-channel interface, I can set MTU to 1530 max
    When I configure an interface in this port-channel, I can set port-channel MTU to 9216 max.
    But when I reload, "mtu 9216" command is rejected and port-channel MTU is set to 1500 :
     mtu 9216
            ^
    % Invalid input detected at '^' marker.
    %Interface MTU set to channel-group MTU 1500.
    IOS version is 12.4(25g)
    Thank you so much.

  • 3750-2960 Vlans Issue via Port Channel

    Im trying to get all my vlans to pass thru to my 2960 user level switches, from my 3750 stack.
    Each one of my 2960 stack is connected to my 3750 via port channel. Here is my port setup.
    I have Vlans 1,210,214,216,220,306,406 on my 3750 stack. I cannot see those vlans on my 2960 stack. Why is that? What am I missing from the config?
    Thanks...
    3750 ports:
    interface GigabitEthernet1/0/41
    description Uplink to ETHSW03
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 7 mode active
    interface GigabitEthernet1/0/42
    description Uplink to ETHSW03
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 7 mode active
    interface Port-channel7
    description Uplink to ETHSW03
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    Here are my 2960 ports setup:
    interface GigabitEthernet1/0/47
    description Uplink to CORE01
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 1 mode active
    interface GigabitEthernet1/0/48
    description Uplink to CORE01
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 1 mode active
    interface Port-channel1
    description Uplink to CORE01
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop

    I have 1 stack of 3750, connected with flex technology.
    I have 3 stacks of 4-2960s, connected with flex technology.
    Then, each 2960 stack is connected to my 3750 stack via port channels (gig ports x2).
    Now, this is a second office site. We are connected to our datacenter via private ethernet line, and thats where most of our vlans and servers reside.
    Output from 3750
    P-DB-CORE01#sh vtp status
    VTP Version capable             : 1 to 3
    VTP version running             : 1
    VTP Domain Name                 : NULL
    VTP Pruning Mode                : Disabled
    VTP Traps Generation            : Disabled
    Device ID                       : 6c41.6a9c.a280
    Configuration last modified by 10.2.20.1 at 3-3-93 23:43:55
    Feature VLAN:
    VTP Operating Mode                : Transparent
    Maximum VLANs supported locally   : 1005
    Number of existing VLANs          : 19
    Configuration Revision            : 0
    MD5 digest                        : 0x3D 0x05 0x4D 0x8C 0x31 0x07 0x34 0xDA
                                        0x2F 0x60 0xE8 0x24 0xA6 0x27 0x59 0x24
    Output from 2960
    P-ETHSW03-20.4#sh vtp status
    VTP Version capable             : 1 to 3
    VTP version running             : 1
    VTP Domain Name                 : NULL
    VTP Pruning Mode                : Disabled
    VTP Traps Generation            : Disabled
    Device ID                       : c07b.bcb2.9a80
    Configuration last modified by 10.2.20.2 at 1-3-14 13:02:15
    Local updater ID is 10.2.20.4 on interface Vl1 (lowest numbered VLAN interface found)
    Feature VLAN:
    VTP Operating Mode                : Server
    Maximum VLANs supported locally   : 255
    Number of existing VLANs          : 7
    Configuration Revision            : 5
    MD5 digest                        : 0x89 0x91 0xBA 0xE3 0x12 0x1B 0xDB 0x1D
                                        0x75 0x43 0x7F 0x8D 0x62 0x5A 0x09 0x70

  • Interfaces in port-channel keep err-disabling because of keepalives

    Below is the current portchannel that I am having problems with.  The interfaces on Switch A keep going into an error disabled state because they receive their own loopback.  Cisco says to disable keepalives and that it will fix the problem, but I do not like the idea of disabling keepalives.  Has anyone found a solution other than disabling keepalives?  Notice that ios's are different, but am not convinced that this is the issue.  Also one is PoE and the other isn't.  Lastly, i found this article "Keepalives are sent on all interfaces by default in Cisco IOS Software Release 12.1EA-based software. In Cisco IOS Software Release 12.2SE-based software and later, keepalives are not sent by default on fiber and uplink interfaces".  I would think trunked interfaces in a port-channel would be uplink interfaces and if this is true, it should be sending out keepalives anyway since i am running the 12.2SE based ios.  Thanks for whatever input you may have.
    Switch A
    C3750E Boot Loader (C3750X-HBOOT-M) Version 12.2(53r)SE2, RELEASE SOFTWARE (fc1)
    System image file is "flash:/c3750e-universalk9-mz.122-55.SE3/c3750e-universalk9-mz.122-55.SE3.bin"
    cisco WS-C3750X-48P
    Port-channels in the group:
    Port-channel: Po52
    Age of the Port-channel   = 219d:04h:32m:49s
    Logical slot/port   = 10/39          Number of ports = 4
    GC                  = 0x00000000      HotStandBy port = null
    Port state          = Port-channel Ag-Inuse
    Protocol            =    -
    Port security       = Disabled
    Ports in the Port-channel:
    Index   Load   Port     EC state        No of bits
    ------+------+------+------------------+-----------
      0     00     Gi1/0/35 On                 0
      0     00     Gi1/0/36 On                 0
      0     00     Gi2/0/45 On                 0
      0     00     Gi2/0/46 On                 0
    %ETHCNTR-3-LOOP_BACK_DETECTED: Loop-back detected on GigabitEthernet1/0/35.
    %PM-4-ERR_DISABLE: loopback error detected on Gi1/0/35, putting Gi1/0/35 in err-disable state
    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/35, changed state to down
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel39, changed state to down
    %LINK-3-UPDOWN: Interface Port-channel39, changed state to down
    Switch B
    C3750E Boot Loader (C3750X-HBOOT-M) Version 12.2(53r)SE2, RELEASE SOFTWARE (fc1)
    System image file is "flash:/c3750e-universalk9-mz.122-58.SE2/c3750e-universalk9-mz.122-58.SE2.bin"
    cisco WS-C3750X-48
    Port-channels in the group:
    Port-channel: Po52
    Age of the Port-channel   = 443d:18h:43m:06s
    Logical slot/port   = 10/39          Number of ports = 4
    GC                  = 0x00000000      HotStandBy port = null
    Port state          = Port-channel Ag-Inuse
    Protocol            =    -
    Port security       = Disabled
    Ports in the Port-channel:
    Index   Load   Port     EC state        No of bits
    ------+------+------+------------------+-----------
      0     00     Gi1/0/35 On                 0
      0     00     Gi1/0/36 On                 0
      0     00     Gi1/0/45 On                 0
      0     00     Gi1/0/46 On                 0

    PER CISCO
    Symptom:
    An interface on a Catalyst switch is errordisabled after detecting a loopback.
    Mar 7 03:20:40: %ETHCNTR-3-LOOP_BACK_DETECTED: Loop-back detected on
    GigabitEthernet0/2. The port is forced to linkdown.
    Mar 7 03:20:42: %LINK-5-CHANGED: Interface GigabitEthernet0/2, changed state
    to administratively down
    Mar 7 03:20:43: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    GigabitEthernet0/2, changed state to down
    Conditions:
    This might be seen on a Catalyst 2940, 2950, 2950-LRE, 2955, 2970, 3550, 3560
    or 3750 switch running 12.1EA or 12.2SE based code.
    Workaround:
    Disable keepalives by using the no keepalive interface command. This
    will prevent the port from being errdisabled, but it does not resolve the root
    cause of the problem. Please see section below for more information.
    Additional Information:
    The problem occurs because the keepalive packet is looped back to the port that
    sent the keepalive. There is a loop in the network. Although disabling the
    keepalive will prevent the interface from being errdisabled, it will not remove
    the loop.
    The problem is aggravated if there are a large number of Topology Change
    Notifications on the network. When a switch receives a BPDU with the Topology
    Change bit set, the switch will fast age the MAC Address table. When this
    happens, the number of flooded packets increases because the MAC Address table
    is empty.

  • Nexus 7010 port-channel to ESXi host running on Dell 910 and 810

    Was wondering has anyone had any experience with configuring a port-channel going back to ESXi host. My basic config is below. My issue is with what to put in the spanning-tree port type. Do I use normal, edge, network, or edge trunk?? Yes I have read most of the documentation out there but am just a lil confused. I just wanna be right.
    Also if anyone has any suggestions for the Vswitch config as well that would be much appreciated.
    int PO 201
    desc 01_6-1
    switchport mode trunk
      switchport access vlan 99
      switchport trunk native vlan 777
      switchport trunk allowed vlan 220,300,310,320-321,350,390-391
      switchport trunk allowed vlan add 420,777
      spanning-tree port type normal (what should go here)
      speed auto
      medium p2p
      no shutdown
    int e8/11
    desc 01_6-1
    channel-group 201 force
    int e10/11
    desc 01_6-1
    channel-group 201 force
    Thanks Guys

    Short answer: You could use spanning tree port type edge (trunk; if it's going to be a trunk). The vswitch isn't really a switch, it doesn't participate in spanning tree, so it's fine to make it an edge port.
    In my experience, many VMware guys don't like port channels as much as the other more host-centric NIC teaming methods. I think this has to do with ESX having a less than stellar implementation of etherchannel/LACP early on.

  • WLC LAG Mode and Port Channel

    So I was reading the controller best practices and got this:
    When you use LAG, the controller relies on the switch for the load balancing decisions on traffic that come from the network. It expects that traffic that belongs to an AP always enters on the same port. Use only ip-src or ip-src ip-dst load balancing options in the switch EtherChannel configuration. Some switch models might use unsupported load balancing mechanisms by default, so it is important to verify.
    This is how to verify the EtherChannel load balancing mechanism:
    switch#show etherchannel load-balance
    EtherChannel Load-Balancing Configuration:
    src-dst-ip
    EtherChannel Load-Balancing Addresses Used Per-Protocol:
    Non-IP: Source XOR Destination MAC address
    IPv4: Source XOR Destination IP address
    IPv6: Source XOR Destination IP address
    This is how to change the switch configuration (IOS):
    switch(config)#port-channel load-balance src-dst-ip
    Now Cisco switches by default will do src-mac.  If I make this change obviously this would be a global change.  I don't believe it should cause any performance issues but wanted to get some expert opinions on this.  Switches my controller will be connected to will also have two routers connected as well via Port Channel.
    I'm trying to understand the reasoning behind this.

    I've never seen that command cause any issues in any deployment I've worked on.
    HTH,
    Steve

  • Nexus 1000v - port-channel "refresh"

    Hi All,
    My question is, does anyone have any information on this 1000v command:
    Nexus-1000v(config)# port-channel internal device-id table refresh
    I am looking for a way for the port-channel interface to be automatically removed from the 1000v once the VEM has been deleted, currently the port-channel interface does not disappear when the VEM has been removed. This seems to be causing problems once the same VEM is re-added later on. Ports are getting sent into quarantine states and ending up in invalid states (eg. NoPortProfile state when there is actually a port-profile attached).
    Anyway, if anyone can explain the above command or tell me how to find out more, it would be great, I can't find it documented anywhere and the context-sensitive help in the NXOS is vague at best.

    Brendan,
    I don't have much information on that command, but I do know it wont remove any unused port channels.  They have to be manually deleted if they're no longer needed.
    The port Channel ID will remain even after a VEM is removed in case the assigned VEM comes back.  When a VEM is decommisioned permanently, I'll do a "no vem x" to also remove the Host entry for that VEM from the VSM.  This way the module slot # can be re-assigned to the next new VEM inserted.  After adding/removing VEMs just do a "show port-channel summary" to see any unused Port Channel IDs, and delete them.  It's a quick & painless task.
    I would hope this wouldn't be a common issue - how often are you deleting/removing VEMs?
    Regards,
    Robert

Maybe you are looking for