Problem in communicating with ports

dear friend,
i have written code for listing ports.
code is listed below
import java.io.InputStream;
import java.io.OutputStream;
import java.util.Enumeration;
import java.util.Formatter;
import org.smslib.helper.CommPortIdentifier;
import org.smslib.helper.SerialPort;
import javax.comm.*;
public class CommTest
     private static final String NODEVICE_FOUND = " no device found";
     private final static Formatter _formatter = new Formatter(System.out);
     static CommPortIdentifier portId;
     static Enumeration<CommPortIdentifier> portList;
     static int bauds[] = { 9600, 14400, 19200, 28800, 33600, 38400, 56000, 57600, 115200 };
     * Wrapper around {@link CommPortIdentifier#getPortIdentifiers()} to be
     * avoid unchecked warnings.
     @SuppressWarnings("unchecked")
     private static Enumeration<CommPortIdentifier> getCleanPortIdentifiers()
          return CommPortIdentifier.getPortIdentifiers();
     public static void main(String[] args)
          System.out.println("\nSearching for devices...");
          portList = getCleanPortIdentifiers();
          while (portList.hasMoreElements())
               portId = portList.nextElement();
               if (portId.getPortType() == CommPortIdentifier.PORT_SERIAL)
                    _formatter.format("%nFound port: %-5s%n", portId.getName());
                    for (int i = 0; i < bauds.length; i++)
                         SerialPort serialPort = null;
                         _formatter.format("       Trying at %6d...", bauds);
                         try
                              InputStream inStream;
                              OutputStream outStream;
                              int c;
                              String response;
                              serialPort = portId.open("SMSLibCommTester", 1971);
                              serialPort.setFlowControlMode(SerialPort.FLOWCONTROL_RTSCTS_IN);
                              serialPort.setSerialPortParams(bauds[i], SerialPort.DATABITS_8, SerialPort.STOPBITS_1, SerialPort.PARITY_NONE);
                              inStream = serialPort.getInputStream();
                              outStream = serialPort.getOutputStream();
                              serialPort.enableReceiveTimeout(1000);
                              c = inStream.read();
                              while (c != -1)
                                   c = inStream.read();
                              outStream.write('A');
                              outStream.write('T');
                              outStream.write('\r');
                              Thread.sleep(1000);
                              response = "";
                              c = inStream.read();
                              while (c != -1)
                                   response += (char) c;
                                   c = inStream.read();
                              if (response.indexOf("OK") >= 0)
                                   try
                                        System.out.print(" Getting Info...");
                                        outStream.write('A');
                                        outStream.write('T');
                                        outStream.write('+');
                                        outStream.write('C');
                                        outStream.write('G');
                                        outStream.write('M');
                                        outStream.write('M');
                                        outStream.write('\r');
                                        response = "";
                                        c = inStream.read();
                                        while (c != -1)
                                             response += (char) c;
                                             c = inStream.read();
                                        System.out.println(" Found: " + response.replaceAll("\\s+OK\\s+", "").replaceAll("\n", "").replaceAll("\r", ""));
                                   catch (Exception e)
                                        System.out.println(_NO_DEVICE_FOUND);
                              else
                                   System.out.println(_NO_DEVICE_FOUND);
                         catch (Exception e)
                              System.out.print(_NO_DEVICE_FOUND);
                              Throwable cause = e;
                              while (cause.getCause() != null)
                                   cause = cause.getCause();
                              System.out.println(" (" + cause.getMessage() + ")");
                         finally
                              if (serialPort != null)
                                   serialPort.close();
          System.out.println("\nTest complete.");
the error i am getting is
Caught java.lang.ClassNotFoundException: com.sun.comm.Win32Driver while loading driver com.sun.comm.Win32Driver
Error loading SolarisSerial: java.lang.UnsatisfiedLinkError: no SolarisSerialParallel in java.library.path
Test complete.
Caught java.lang.UnsatisfiedLinkError: com.sun.comm.SolarisDriver.readRegistrySerial(Ljava/util/Vector;Ljava/lang/String;)I while loading driver com.sun.comm.SolarisDriver
*1*) i don't know what is this?
i have downloaded java comm 20-win32.zip and done the necessary things as told in the manual.
actually i am trying to send sms in between pc and mobile using smslib.
but i am facing lot of errors.
code is this to send msg from pc to mobile
SendMessage.java - Sample application.
// This application shows you the basic procedure for sending messages.
// You will find how to send synchronous and asynchronous messages.
// For asynchronous dispatch, the example application sets a callback
// notification, to see what's happened with messages.
package examples.modem;
import org.smslib.IOutboundMessageNotification;
import org.smslib.Library;
import org.smslib.OutboundMessage;
import org.smslib.Service;
import org.smslib.modem.SerialModemGateway;
public class SendMessage
     public void doIt() throws Exception
          Service srv;
          OutboundMessage msg;
          OutboundNotification outboundNotification = new OutboundNotification();
          System.out.println("Example: Send message from a serial gsm modem.");
          System.out.println(Library.getLibraryDescription());
          System.out.println("Version: " + Library.getLibraryVersion());
          srv = new Service();
          SerialModemGateway gateway = new SerialModemGateway("modem.com1", "COM1", 57600, "Nokia", "6310i");
          gateway.setInbound(true);
          gateway.setOutbound(true);
          gateway.setSimPin("0000");
          srv.setOutboundNotification(outboundNotification);
          srv.addGateway(gateway);
          srv.startService();
          System.out.println();
          System.out.println("Modem Information:");
          System.out.println(" Manufacturer: " + gateway.getManufacturer());
          System.out.println(" Model: " + gateway.getModel());
          System.out.println(" Serial No: " + gateway.getSerialNo());
          System.out.println(" SIM IMSI: " + gateway.getImsi());
          System.out.println(" Signal Level: " + gateway.getSignalLevel() + "%");
          System.out.println(" Battery Level: " + gateway.getBatteryLevel() + "%");
          System.out.println();
          // Send a message synchronously.
          msg = new OutboundMessage("+306948494037", "Hello from SMSLib!");
          srv.sendMessage(msg);
          System.out.println(msg);
          // Or, send out a WAP SI message.
          //OutboundWapSIMessage wapMsg = new OutboundWapSIMessage("+306948494037", new URL("https://mail.google.com/"), "Visit GMail now!");
          //srv.sendMessage(wapMsg);
          //System.out.println(wapMsg);
          // You can also queue some asynchronous messages to see how the callbacks
          // are called...
          //msg = new OutboundMessage("+309999999999", "Wrong number!");
          //msg.setPriority(OutboundMessage.Priorities.LOW);
          //srv.queueMessage(msg, gateway.getGatewayId());
          //msg = new OutboundMessage("+308888888888", "Wrong number!");
          //msg.setPriority(OutboundMessage.Priorities.HIGH);
          //srv.queueMessage(msg, gateway.getGatewayId());
          System.out.println("Now Sleeping - Hit <enter> to terminate.");
          System.in.read();
          srv.stopService();
     public class OutboundNotification implements IOutboundMessageNotification
          public void process(String gatewayId, OutboundMessage msg)
               System.out.println("Outbound handler called from Gateway: " + gatewayId);
               System.out.println(msg);
     public static void main(String args[])
          SendMessage app = new SendMessage();
          try
               app.doIt();
          catch (Exception e)
               e.printStackTrace();
error i am getting is
Caught java.lang.ClassNotFoundException: com.sun.comm.Win32Driver while loading driver com.sun.comm.Win32Driver
org.smslib.GatewayException: Comm library exception: java.lang.reflect.InvocationTargetException
at org.smslib.modem.SerialModemDriver.connectPort(SerialModemDriver.java:93)
at org.smslib.modem.AModemDriver.connect(AModemDriver.java:110)
at org.smslib.modem.ModemGateway.startGateway(ModemGateway.java:126)
at org.smslib.Service$1Starter.run(Service.java:222)
*2*) i cannot understand what is this.i have done as per the installation page in SMSLib. can you please help me
****** one more important thing is that i have not connected any cable to the ports.
thanks in regards
Edited by: arunachu on Nov 5, 2008 3:58 AM

Hi friends..i need solution for this .
i use org.smslib.*; for messge sending .
i done it in same code in windows machine . but i had some prob in linux machine
it showing this kind of error . in run time ..
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7
check_group_uucp(): error testing lock file creation Error details:Permission deniedcheck_lock_status: No permission to create lock file.
please see: How can I use Lock Files with rxtx? in INSTALL
check_group_uucp(): error testing lock file creation Error details:Permission deniedcheck_lock_status: No permission to create lock file.
please see: How can I use Lock Files with rxtx? in INSTALL
check_group_uucp(): error testing lock file creation Error details:Permission deniedcheck_lock_status: No permission to create lock file.
please see: How can I use Lock Files with rxtx? in INSTALL
check_group_uucp(): error testing lock file creation Error details:Permission deniedcheck_lock_status: No permission to create lock file.
please see: How can I use Lock Files with rxtx? in INSTALL
check_group_uucp(): error testing lock file creation Error details:Permission deniedcheck_lock_status: No permission to create lock file.
please see: How can I use Lock Files with rxtx? in INSTALL
org.smslib.GatewayException: Comm library exception: java.lang.RuntimeException: gnu.io.NoSuchPortException
at org.smslib.modem.SerialModemDriver.connectPort(SerialModemDriver.java:92)
at org.smslib.modem.AModemDriver.connect(AModemDriver.java:110)
at org.smslib.modem.ModemGateway.startGateway(ModemGateway.java:126)
at org.smslib.Service$1Starter.run(Service.java:222)
Thanks to Advance ..
Merry X-mas

Similar Messages

  • Problem of communication with compactrio

    Hello,
    I am working with a compactrio 9014 and labview 8.5
    I have a problem of communication with my compactrio. I acquire sound with NI 9215 and transmit points from the fpga VI to the VI on the real time target at a rate of 10Khz. On the VI on the RT I have two loops, one determinisic running at a speed of 10Khz (0.1ms) (in this loop I will do my signal processing) and one non-deterministic running much slower (20ms) to communicate data to my computer. To communicate data to my PC, I used shared variable.
    The problem is that if I run the VI_RT, I loose immidiately the connection. I think that is because the VI is taking up all of the execution time of the
    processor and is starving out the communication loop that is used to
    send data back to my PC.
    Because of this problem, I try to configure my compactrio to automatically run on startup of my cRIO. So I follow the steps I have read in another message in the forum posted by MattP
    To make your application (RT host VI and FPGA VI) run automatically on startup of your cRIO, you will need to do the following:
    1.  Download the FPGA VI to the flash memory on your cRIO.  If
    using LabVIEW 8, right-click on the VI in the Project Explorer Window
    and select Download VI or Attributes to Flash Memory...
    2.  Build an executable out of the RT VI.  Under your RT target 
    in the Project Explorer, right-click on Build Specifications and select
    New>>Real-Time Application.  Select the source files necessary
    for your application and any support files to be included.  Click Build.
    3.. After building the RT Application, you will find its entry
    under the Build Specifications folder in your project.  Right-click on
    the application and choose Set as startup.  Right-click again and
    choose Deploy, which will download the application to your cRIO.
    With  this procedure, I thougt that I can  run my  loop faster  because I  don't have the RT VI open on my desktop  (PC), so the PC don't have to synchronise the VI. But when I startup my compactrio, I loose connection with the target...
    So, what is wrong with my project?  Is it possible to run a loop at 10kHz on the real time processor and communicate in the same time (but every 20ms) data to my PC. Can someone explain me the right procedure to do that at this frequencies?
    I have attached my project and hope that someone can help me.
    Attachments:
    Communication.zip ‏658 KB

    Hello,
    The method you use in your application to transfer the data from the FPGA to
    the RT Host use the Front Panel Interactive Communication that write/read the
    control/indicators of the FPGA VI. This method provides also risk of Race
    Condition and use uP resources.
    To avoid errors in data caused by race conditions and use less processor resources, 
    I suggest you to rewrite this part of your application with the method 
    DMA transfer from FPGA to Host.
    You will find some good tutorial at the following address.
    What
    is the Best Method For Synchronizing a LabVIEW FPGA and a Host Interface VI?
    Best Regards,
    Nick_CH

  • Problem while communicating with ECU through NI USB CAN

    Hello sir,
    I want to communicate with ECU through NI USB CAN interface while i tried to communicate with ECU it gives timeout error. here i am using CCP version 1.0, ECU toolkit 2.1.4 and NI CAN 2.7.2 .if you have any problem that communicates with ECU using CCP version 1.0 Please attach it.
    Thanks and Regards,
    Madhan

    So for the fifth time you start a new thread about the same problem!
    If you don't get any response to your threads, it could be because you are not giving a lot information about your problem.You could start with giving the vi you have problem with, so that we can see what you are doing.
    You also need to give any error code and a description on that you have done, in details!
    You also had one response in one of the other threads, it is polite to make an answer when someone is replying to you.
    [email protected] wrote:
    Hello sir,
    I want to communicate with ECU through NI USB CAN interface while i tried to communicate with ECU it gives timeout error. here i am using CCP version 1.0, ECU toolkit 2.1.4 and NI CAN 2.7.2 .if you have any problem that communicates with ECU using CCP version 1.0 Please attach it.
    Thanks and Regards,
    Madhan
    That makes no sense, where have you copied that from ?

  • OEM Problem in Communicating with Listener

    Dear all,
    for some reason, my OEM is corrupted and when it's enabled, it messes up with the listener. I concluded the problem lies in OEM rather than in the listener since I can establish connection between SQLdeveloper and the server via the listener without any problem.
    I have instance named INARA, host named FIREFLY.SNOWDROP.COM, and listener named ORACLE_LISTENER.
    I closed SQLdeveloper application and its listener and started OEM first to pinpoint the problem. After I started OEM, the Management Service log emoms.log dumped:
    2011-06-15 11:55:12,203 [HTTPThreadGroup-2] WARN  jdbc.ConnectionCache _getConnection.353 - Got a fatal exeption when getting a connection; Error code = 17002; Cleaning up cache and retrying
    2011-06-15 11:55:12,204 [HTTPThreadGroup-2] ERROR conn.ConnectionService verifyRepositoryEx.891 - Invalid Connection Pool. ERROR = Io exception: The Network Adapter could not establish the connection
    2011-06-15 11:55:12,205 [EMUI_11_55_12_/console/aboutApplication] ERROR svlt.PageHandler handleRequest.639 - java.lang.IllegalStateException: Response has already been committed
    java.lang.IllegalStateException: Response has already been committed
         at com.evermind.server.http.EvermindHttpServletResponse.resetBuffer(EvermindHttpServletResponse.java:1892)
         at com.evermind.server.http.ServletRequestDispatcher.unprivileged_forward(ServletRequestDispatcher.java:249)
         at com.evermind.server.http.ServletRequestDispatcher.access$100(ServletRequestDispatcher.java:51)
         at com.evermind.server.http.ServletRequestDispatcher$2.oc4jRun(ServletRequestDispatcher.java:193)
         at oracle.oc4j.security.OC4JSecurity.doPrivileged(OC4JSecurity.java:284)
         at com.evermind.server.http.ServletRequestDispatcher.forward(ServletRequestDispatcher.java:198)
         at oracle.sysman.emSDK.svlt.PageHandler.render(PageHandler.java:1113)
         at oracle.sysman.emSDK.svlt.PageHandler.myRender(PageHandler.java:1173)
         at oracle.sysman.emSDK.svlt.PageHandler.handleRequest(PageHandler.java:597)
         at oracle.sysman.emSDK.svlt.EMServlet.myDoGet(EMServlet.java:787)
         at oracle.sysman.emSDK.svlt.EMServlet.doGet(EMServlet.java:343)
         at oracle.sysman.eml.app.Console.doGet(Console.java:157)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
         at com.evermind.server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:64)
         at oracle.sysman.eml.app.EMRepLoginFilter.doFilter(EMRepLoginFilter.java:107)
         at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:15)
         at oracle.sysman.db.adm.inst.HandleRepDownFilter.doFilter(HandleRepDownFilter.java:146)
         at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:17)
         at oracle.sysman.eml.app.BrowserVersionFilter.doFilter(BrowserVersionFilter.java:122)
         at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:17)
         at oracle.sysman.emSDK.svlt.EMRedirectFilter.doFilter(EMRedirectFilter.java:102)
         at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:17)
         at oracle.sysman.eml.app.ContextInitFilter.doFilter(ContextInitFilter.java:327)
         at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:621)
         at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:370)
         at com.evermind.server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:871)
         at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:453)
         at com.evermind.server.http.HttpRequestHandler.serveOneRequest(HttpRequestHandler.java:221)
         at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:122)
         at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:111)
         at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260)
         at oracle.oc4j.network.ServerSocketAcceptHandler.procClientSocket(ServerSocketAcceptHandler.java:234)
         at oracle.oc4j.network.ServerSocketAcceptHandler.access$700(ServerSocketAcceptHandler.java:29)
         at oracle.oc4j.network.ServerSocketAcceptHandler$AcceptHandlerHorse.run(ServerSocketAcceptHandler.java:879)
         at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:303)
         at java.lang.Thread.run(Thread.java:595) also the Management Agent trace file emagent.trc dumped:
    SQL = "                                                                   OCISessionGet"...
    LOGIN = dbsnmp/<PW>@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=firefly.snowdrop.com)(PORT=1521))(CONNECT_DATA=(SID=inara)))
    2011-06-15 11:57:05,914 Thread-4147767632 ERROR vpxoci: ORA-12541: TNS:no listener
    2011-06-15 11:57:05,914 Thread-4147767632 WARN  vpxoci: Login 0x67fd70 failed, error=ORA-12541: TNS:no listener
    2011-06-15 11:57:05,914 Thread-4147767632 WARN  TargetManager: Exception in computing dynamic properties of {inara.snowdrop.com, oracle_database },GetDbBlockSize::ORA-12541: TNS:no listener
    2011-06-15 11:57:05,916 Thread-4138318160 ERROR TargetManager: nmeetm.c : Target inara.snowdrop.com has a failed critical dynamic property
    2011-06-15 11:57:05,918 Thread-4138318160 WARN  upload: Upload manager has no Failure script: disabled
    2011-06-15 11:57:05,918 Thread-4138318160 WARN  upload: Amount of upload data will be recalculated due to reload.enabling collections and regenerating metadata.
    2011-06-15 11:57:05,918 Thread-4138318160 WARN  TargetManager: Regenerating all Metadata
    2011-06-15 11:57:05,983 Thread-4138318160 WARN  upload: Truncating value of "SHORT_NAME" from "Average Synchronous Single-Block Read Latency (ms)" to "Average Synchronous Single-Block Read La"
    2011-06-15 11:57:05,983 Thread-4138318160 WARN  upload: Truncating value of "SHORT_NAME" from "Average Synchronous Single-Block Read Latency (ms)" to "Average Synchronous Single-Block Read La"
    2011-06-15 11:57:06,080 Thread-4138318160 WARN  upload: Truncating value of "COLUMN_LABEL" from "Total messages processed per queue per subscriber per minute in the last interval" to "Total messages processed per queue per subscriber per minute in "
    2011-06-15 11:57:06,080 Thread-4138318160 WARN  upload: Truncating value of "COLUMN_LABEL" from "Total messages received per queue per subscriber per minute in the last interval" to "Total messages received per queue per subscriber per minute in t"
    2011-06-15 11:57:06,080 Thread-4138318160 WARN  upload: Truncating value of "COLUMN_LABEL" from "Messages processed per queue (%) per subscriber per minute in the last interval" to "Messages processed per queue (%) per subscriber per minute in th"
    2011-06-15 11:57:06,080 Thread-4138318160 WARN  upload: Truncating value of "COLUMN_LABEL" from "Age of the first message in persistent queue per subscriber (seconds)" to "Age of the first message in persistent queue per subscriber (sec"
    2011-06-15 11:57:06,081 Thread-4138318160 WARN  upload: Truncating value of "COLUMN_LABEL" from "Age of the first message in the buffered queue per queue (seconds)" to "Age of the first message in the buffered queue per queue (second"
    2011-06-15 11:57:06,096 Thread-4138318160 WARN  collector: enable collector
    2011-06-15 11:57:06,100 Thread-4138318160 WARN  collector: Regenerating all DefaultColls
    2011-06-15 11:57:07,145 Thread-4147767632 ERROR upload: Exceeded max. amount of upload data: 314 files, 346.533864 MB Data. 89.74% of disk used. Disabling collections.
    2011-06-15 11:57:07,145 Thread-4147767632 WARN  collector: Disable collector
    2011-06-15 11:57:08,237 Thread-4147767632 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:57:08,337 Thread-4147767632 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:57:38,442 Thread-4147767632 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:57:38,545 Thread-4147767632 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:58:08,732 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:58:08,835 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:58:38,952 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:58:39,055 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:59:09,157 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:59:09,260 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:59:39,364 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:59:39,465 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository
    2011-06-15 11:59:58,595 Thread-4154857808 ERROR command: nmejcn: received no status header from repository at https://firefly.snowdrop.com:5500/em/upload/Looked like OEM had some errors and warnings after it got initiated but I don't know what they meant.
    After OEM is successfully started, at least according to the emtcl command, I started listener ORACLE_LISTENER. At this point I performed loopback test using NET manager on the server, and it took forever so I aborted it. The database at this point was still open and running without problem though. TNSPING took 157080 msc to return OK value, on the other hand lsnrctl status ORACLE_STATUS was stalled.
    So looking at emagent.trc after listener was initiated:
    2011-06-15 12:02:10,306 Thread-4138318160 WARN  ssl: <nmehlssl.c:nmehlssl_readcb>: nmehl_read_sock timed out, rsf = -5, setting read timeout flag
    2011-06-15 12:02:10,306 Thread-4138318160 WARN  ssl.io: fd=6: nmehlssl_read, nzos_Read error = 28862 readTimed Out = 1
    2011-06-15 12:02:10,306 Thread-4138318160 WARN  http: <nmehl.c>:<nmehl_readline>: nmehlssl_read() timed out
    2011-06-15 12:02:10,306 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Error in request response. code = 400. text =
    2011-06-15 12:02:40,433 Thread-4138318160 WARN  ssl: <nmehlssl.c:nmehlssl_readcb>: nmehl_read_sock timed out, rsf = -5, setting read timeout flag
    2011-06-15 12:02:40,433 Thread-4138318160 WARN  ssl.io: fd=6: nmehlssl_read, nzos_Read error = 28862 readTimed Out = 1
    2011-06-15 12:02:40,433 Thread-4138318160 WARN  http: <nmehl.c>:<nmehl_readline>: nmehlssl_read() timed out
    2011-06-15 12:02:40,433 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Error in request response. code = 400. text =
    2011-06-15 12:03:40,570 Thread-4138318160 WARN  ssl: <nmehlssl.c:nmehlssl_readcb>: nmehl_read_sock timed out, rsf = -5, setting read timeout flag
    2011-06-15 12:03:40,570 Thread-4138318160 WARN  ssl.io: fd=6: nmehlssl_read, nzos_Read error = 28862 readTimed Out = 1
    2011-06-15 12:03:40,570 Thread-4138318160 WARN  http: <nmehl.c>:<nmehl_readline>: nmehlssl_read() timed out
    2011-06-15 12:03:40,570 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Error in request response. code = 400. text =
    2011-06-15 12:04:10,704 Thread-4138318160 WARN  ssl: <nmehlssl.c:nmehlssl_readcb>: nmehl_read_sock timed out, rsf = -5, setting read timeout flag
    2011-06-15 12:04:10,704 Thread-4138318160 WARN  ssl.io: fd=6: nmehlssl_read, nzos_Read error = 28862 readTimed Out = 1
    2011-06-15 12:04:10,704 Thread-4138318160 WARN  http: <nmehl.c>:<nmehl_readline>: nmehlssl_read() timed out
    2011-06-15 12:04:10,704 Thread-4138318160 ERROR pingManager: nmepm_pingReposURL: Error in request response. code = 400. text = also emoms.trc
    2011-06-15 12:05:26,159 [HTTPThreadGroup-6] WARN  jdbc.ConnectionCache _getConnection.353 - Got a fatal exeption when getting a connection; Error code = 17002; Cleaning up cache and retrying
    2011-06-15 12:05:29,774 [HTTPThreadGroup-5] WARN  jdbc.ConnectionCache _getConnection.352 - Io exception: Socket read timed out
    java.sql.SQLException: Io exception: Socket read timed out
         at oracle.jdbc.driver.SQLStateMapping.newSQLException(SQLStateMapping.java:77)
         at oracle.jdbc.driver.DatabaseError.newSQLException(DatabaseError.java:111)
         at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:174)
         at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:230)
         at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:501)
         at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:436)
         at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:621)
         at oracle.jdbc.driver.T4CConnection.<init>(T4CConnection.java:203)
         at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:34)
         at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:492)
         at oracle.jdbc.pool.OracleDataSource.getPhysicalConnection(OracleDataSource.java:386)
         at oracle.jdbc.pool.OracleDataSource.getConnection(OracleDataSource.java:276)
         at oracle.jdbc.pool.OracleConnectionPoolDataSource.getPhysicalConnection(OracleConnectionPoolDataSource.java:212)
         at oracle.jdbc.pool.OracleConnectionPoolDataSource.getPooledConnection(OracleConnectionPoolDataSource.java:140)
         at oracle.jdbc.pool.OracleImplicitConnectionCache.makeCacheConnection(OracleImplicitConnectionCache.java:1752)
         at oracle.jdbc.pool.OracleImplicitConnectionCache.makeOneConnection(OracleImplicitConnectionCache.java:644)
         at oracle.jdbc.pool.OracleImplicitConnectionCache.getCacheConnection(OracleImplicitConnectionCache.java:592)
         at oracle.jdbc.pool.OracleImplicitConnectionCache.getConnection(OracleImplicitConnectionCache.java:460)
         at oracle.jdbc.pool.OracleDataSource.getConnection(OracleDataSource.java:544)
         at oracle.jdbc.pool.OracleDataSource.getConnection(OracleDataSource.java:480)
         at oracle.sysman.util.jdbc.ConnectionCache._getConnection(ConnectionCache.java:336)
         at oracle.sysman.util.jdbc.ConnectionCache._getConnection(ConnectionCache.java:322)
         at oracle.sysman.util.jdbc.ConnectionCache.getUnwrappedConnection(ConnectionCache.java:575)
         at oracle.sysman.emSDK.svc.conn.FGAConnectionCache.getFGAConnection(FGAConnectionCache.java:207)
         at oracle.sysman.emSDK.svc.conn.ConnectionService.getPrivateConnection(ConnectionService.java:1138)
         at oracle.sysman.emSDK.svc.conn.ConnectionService.getPrivateConnection(ConnectionService.java:1172)
         at oracle.sysman.emdrep.receiver.OMSHandshake.getParameterFromDB(OMSHandshake.java:570)
         at oracle.sysman.emdrep.receiver.OMSHandshake.getMaxAgentCompatVer(OMSHandshake.java:552)
         at oracle.sysman.emdrep.receiver.OMSHandshake.handshake(OMSHandshake.java:1033)
         at oracle.sysman.emdrep.receiver.OMSHandshake.handshake(OMSHandshake.java:836)
         at oracle.sysman.emdrep.receiver.FxferRecv.doGet(FxferRecv.java:598)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
         at com.evermind.server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:64)
         at oracle.sysman.eml.app.ContextInitFilter.doFilter(ContextInitFilter.java:327)
         at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:623)
         at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:370)
         at com.evermind.server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:871)
         at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:453)
         at com.evermind.server.http.HttpRequestHandler.serveOneRequest(HttpRequestHandler.java:221)
         at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:122)
         at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:111)
         at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260)
         at oracle.oc4j.network.ServerSocketAcceptHandler.procClientSocket(ServerSocketAcceptHandler.java:234)
         at oracle.oc4j.network.ServerSocketAcceptHandler.access$700(ServerSocketAcceptHandler.java:29)
         at oracle.oc4j.network.ServerSocketAcceptHandler$AcceptHandlerHorse.run(ServerSocketAcceptHandler.java:879)
         at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:303)
         at java.lang.Thread.run(Thread.java:595)
    2011-06-15 12:05:29,775 [HTTPThreadGroup-5] WARN  jdbc.ConnectionCache _getConnection.353 - Got a fatal exeption when getting a connection; Error code = 17002; Cleaning up cache and retryinglastly, ORACLE_LISTENER log said:
    15-JUN-2011 12:16:38 * <unknown connect data> * (ADDRESS=(PROTOCOL=tcp)(HOST=192.168.1.5)(PORT=18844)) * establish * <unknown sid> * 12525
    TNS-12525: TNS:listener has not received client's request in time allowed
    TNS-12535: TNS:operation timed out
      TNS-12606: TNS: Application timeout occurred
    15-JUN-2011 12:16:38 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=oracle))(SERVICE_NAME=inara.snowdrop.com)) * (ADDRESS=(PROTOCOL=tcp)(HOST=192.168.1.5)(PORT=18842)) * establish * inara.snowdrop.com * 0
    15-JUN-2011 12:16:38 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=oracle))(SERVICE_NAME=inara.snowdrop.com)) * (ADDRESS=(PROTOCOL=tcp)(HOST=192.168.1.5)(PORT=18838)) * establish * inara.snowdrop.com * 0
    15-JUN-2011 12:16:38 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=oracle))(SERVICE_NAME=inara.snowdrop.com)) * (ADDRESS=(PROTOCOL=tcp)(HOST=192.168.1.5)(PORT=18833)) * establish * inara.snowdrop.com * 0
    15-JUN-2011 12:16:38 * service_update * inara * 0
    15-JUN-2011 12:16:38 * service_update * inara * 0
    15-JUN-2011 12:16:38 * service_update * inara * 0At this point some part of the NET services was corrupted caused by OEM corruption, but I didn't know what caused of it. The NET services with its listener can work normally after I stopped OEM and forced killed the listener and restarted it normally.
    Any idea how to troubleshoot the problem from this point?
    regards,
    Val

    Hi SyBrand,
    sorry if you got impression that I'm ignoring pointers that you gave me. I assure you that I'm trying to use the pointers that everyone gave to me and I really appreciate it.
    I'm still learning how to get familiar with the database, read the log file, troubleshoot the problems, and get familiar the whole concept, that's why most of the time I receive wrong message from everyone, most often I detect them incorrectly.
    Ok, so far what I understand is I have a database resides in the server, a client, and a listener. The client, in this case, OEM is connecting to the server via listener. In my listener.ora configuration, there are 2 listener configuration, LISTENER and ORACLE_LISTENER. In the client side whose description is in tnsnames.ora it has inara as client service name, which should be matched with available listener either with LISTENER or ORACLE_LISTENER.
    one of the log file that says connecting to 192.168.1.5 is because it implicitly translated firefly into its ip address which is 192.168.1.5.
    Also I double check both files as you suggested before listener.ora
    # listener.ora Network Configuration File: /usr/local/oracle/product/11.2.0/dbhome_1/network/admin/listener.ora
    # Generated by Oracle configuration tools.
    ORACLE_LISTENER =
      (DESCRIPTION_LIST =
        (DESCRIPTION =
          (ADDRESS = (PROTOCOL = TCP)(HOST = firefly.snowdrop.com)(PORT = 1521))
    LISTENER =
      (DESCRIPTION_LIST =
        (DESCRIPTION =
          (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
          (ADDRESS = (PROTOCOL = TCP)(HOST = firefly.snowdrop.com)(PORT = 1521))
    ADR_BASE_LISTENER = /usr/local/oracle
    ADR_BASE_ORACLE_LISTENER = /usr/local/oracletnsnames.ora
    # tnsnames.ora Network Configuration File: /usr/local/oracle/product/11.2.0/dbhome_1/network/admin/tnsnames.ora
    # Generated by Oracle configuration tools.
    INARA =
      (DESCRIPTION =
        (ADDRESS = (PROTOCOL = TCP)(HOST = firefly.snowdrop.com)(PORT = 1521))
        (CONNECT_DATA =
          (SERVER = DEDICATED)
          (SERVICE_NAME = inara.snowdrop.com)
    LISTENER_ORCL =
      (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))
    ORCL =
      (DESCRIPTION =
        (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))
        (CONNECT_DATA =
          (SERVER = DEDICATED)
          (SERVICE_NAME = orcl.snowdrop.com)
    LISTENER_OCA11G =
      (ADDRESS_LIST =
        (ADDRESS = (PROTOCOL = TCP)(HOST = firefly.snowdrop.com)(PORT = 1521))
        (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))
      )service inara in tnsnames.ora is consistent with LISTENER or ORACLE_LISTENER.
    How can I associate local service name inara with OEM client? BTW OEM client and database reside in the same host firefly.
    Edited by: Valerie Debonair on Jun 17, 2011 4:23 AM

  • Problem about Communication with Bluetooth

    Hi all!
    I want to use a PC host to communicate with a mobile phone with Bluetooth technology. In details, the mobile phone wanting to know some informaiton about "news of today" firstly send a message to my PC, then my PC have to response with a reply message to that client mobile phone. It seems that I should use Java programming with J2SE to control the communication through Serial Port. Is it right? I want to overview some Java sample code about this topic so that I'm able to know the general manipulation. Thanks very much! : )

    Hi,
    Under J2ME you can use the JSR82 but only for compiling and then port the application on the mobile device. The source is not implemented.
    There is free APIs java that you can use www.javabluetooth.org
    Let me know if it works with you, I am going to begin next week...
    Sihem ;)

  • Communicating with ports

    I have a question about developing code that can communicate to a port and therefore someting in the outside world. I see tutorials for doing this for various things but I don't understand how they know what to assign for different "packets" that they create when sending out data or receiving data, for example: (from IBM's "intro to gps"...),
    byte[] request = new byte[6];
    request[0] = 0x10; // DLE
    request[1] = (byte) 0xfe; // Packet Id
    request[2] = 0x00; // size of packet payload (there is none!)
    request[3] = (byte) (0x100 - request[1]); // checksum
    request[4] = 0x10; // DLE
    request[5] = 0x03; // ETX
    try
    os.write(request);
    os.flush();
    I can kind of grasp the concept of creating a "packet", but how does one get the information so they know what to assign to each section of the packet like:
    request[0] = 0x10 or something of that nature. What are the methods someone has to take in order to successfully "communicate" to another device, regardless of what that device is?

    (Try that again with the italics correct.)
    I have a question about developing code that can
    communicate to a port and therefore someting in the
    outside world. I see tutorials for doing this for
    various things but I don't understand how they know
    what to assign for different "packets" that they
    create when sending out data or receiving data, for
    example: (from IBM's "intro to gps"...),This is a protocol. From www.geek.com....
    Protocol - This is the behavior that computers must follow in order to understand one another. Think of it as a language. If two computers don't use the same network protocol, then they cannot communicate.
    Notice in the above it doesn't say anything about sockets, IP, TCP/IP or even really networks (network is provided as an example only.)
    As the definition says a protocol specifies how the computers communicate. What you want to know is the definition for the protocol. The definition, should tell you what all the values are. Unfortunately not all protocols are complete.
    The definition will be a document that you get from...somewhere. And the somewhere is hard to say. For internet protocols you can find definitions in RFCs from www.ietf.org. Other protocol documents come from other places - and some of those places you will have to pay money to get the document.
    I can kind of grasp the concept of creating a "packet", Keep in mind that if this protocol moves over an TCP/IP (or IP) protocol that that means it is a protocol on top of another protocol. And IP and TCP/IP both have packets (they are protocols within protocols) and so the protocol that you are looking at will be on top of the other one.

  • Long string problem while communicating with DLL

    Hi
    In our project, we encountered problems about passing strings longer than 255 characters while the SAP system communicates with a dll method.
    We do not want to use file operations as the intermediary layer. Is there a way to handle this situation other than a file-related solution?
    Thanks & Regards...
    *--Serdar <a href="https://www.sdn.sap.com:443http://www.sdn.sap.comhttp://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.sdn.businesscard.sdnbusinesscard?u=qbk%2bsag%2bjiw%3d">[ BC ]</a>

    Hi
    Sorry for answering late. The dll is created via VB. At the ABAP side, a type having length greater than 255 or the string type gives error. This seems to be a restriction of OLE interface?
    Thanks...
    *--Serdar <a href="https://www.sdn.sap.com:443http://www.sdn.sap.comhttp://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.sdn.businesscard.sdnbusinesscard?u=qbk%2bsag%2bjiw%3d">[ BC ]</a>

  • Problem when communicating with postgres

    Hi everyone,
    i have got a problem when i am trying to communicate with postgres.
    i am calling a bean in which i have methods for insertion. for ur convinience i here provide the class.
    package Harish;
    import java.sql.*;
    import java.util.*;
    import java.lang.*;
    public class Exception_IP_List
         Connection con;
         Statement st;
         //Constructor
         public void Exception_IP_List()
         //Getting the Connection with the database
         public Connection getConnection()
              try {
                   Class.forName("org.postgresql.Driver");
                   con = DriverManager.getConnection("jdbc:postgresql://localhost/CF","postgres"," ");
                   System.out.println("Connection Created");
                   st = con.createStatement();
                   System.out.println("Statement Created");
              }catch(Exception e){
                   e.printStackTrace();
              }finally{
                   return con;
         } //end of getting connection with database
         //Inserting the exception IP details into the database
         public int insertExceptionIPList(String ipAddress)
    int insert = 0;
              try {
                   getConnection();
                   String sql = "INSERT INTO exception_ip_list (ip_Address)"
                                            + " VALUES (?)";
                   PreparedStatement pstmt = con.prepareStatement(sql);
                   pstmt.setString(1, ipAddress);
                   insert = pstmt.executeUpdate();
                   System.out.println("Insert " +insert);
                   /*if there is any insertion in this table the table
                        Update will be updated as well
                   if(insert > 0)
                        String sql1 = "update Update set Status='yes' where code='100' ";
                        Statement st1 = con.createStatement();
                        st1.executeUpdate(sql1);
              } catch(Exception e){
                   System.out.println(e);
              }finally{
                   return insert;
         }//end of inserting class
              //Closing Connection to Database
         public void closeConnection()
              try{
                   con.close();
                   System.out.println("Connection closed");
              }catch(Exception e){
                   e.printStackTrace();
         //Main Method for Exception_ip_list Class
         public static void main(String args[])
              Exception_IP_List exiplist = new Exception_IP_List();     
              //exiplist.getConnection();
              //exiplist.insertExceptionIPList("192.168.1.150");
              //System.out.println("data successfully inserteD");
              //exiplist.deleteExceptionIPList("191.11.22.33");
              //System.out.println("Item Deleted");
              //exiplist.getExceptionIPList();
              //exiplist.closeConnection();
    following is the jsp files to access the method insertExceptionIPList
    <%@ page language="java"%>
    <html>
    <head>
    <title>
    </title>
    </head>
    <body>
    <form name="exiplist" method="post" action="test1.jsp">
         <input type="text" name="ip"><br>
         <input type="submit" name="SUBMIT" value="SUBMIT">
    </form>
    </body>
    </html>
    <%@ page language="java" import="java.sql.*, Harish.*" %>
    <jsp:useBean id="exiplist" scope="page" class="Harish.Exception_IP_List" />
    <%=request.getParameter("ip")%><br>
    Inserted: <% int i = exiplist.insertExceptionIPList(request.getParameter("ip")) %>
    i am really confused, what is the mistake i made? .
    please help and its urgent. thanks
    harish.

    Hello Harish,
    I was introduced to databases at university with postgres. I now use SQL Server 7.
    Anyway, what is the problem exactly - which exceptions are being thrown?
    I have to admit, these forums don't present code very well and it makes it more confusing to read.
    What are you inserting into your database - what is the context of your application ?
    I did notice your constructor will be treated like a method. It does not matter in this case as it doesnt do anything, but you can't have void or any return type in your constructor - it has implicit instructions to return an instance of this class when it is called. If it is empty, omit it altogether.
    I understand you getConnection() method.
    I've never used the prepared statement:
    String sql = "INSERT INTO exception_ip_list (ip_Address)" + " VALUES (?)";
    PreparedStatement pstmt = con.prepareStatement(sql);
    pstmt.setString(1, ipAddress);I assume the '?' in the sql string gets replaced with 'ipAddress' parameter variable? Are you sure 1 is the correct number - I know sql counts from 1 but java counts from 0.
    You have created statement st and haven't used it, but later created st1 ?
    For your JSP's, try
    test0.jsp
    <%@ page language="java"%> <!-- this is not needed -->
    <html>
    <head>
    <title>
    </title>
    </head>
    <body>
    <form name="exiplist" method="post" action="test1.jsp">
    <input type="text" name="ip"><br>
    <input type="submit" name="SUBMIT" value="SUBMIT">
    </form>
    </body>
    </html>
    test1.jsp
    <%@ page language="java" import="java.sql.*, Harish.*" %> <!-- this is not needed -->
    <jsp:useBean id="exiplist" scope="page" class="Harish.Exception_IP_List" />
    <html>
    <body>
    <%=request.getParameter("ip")%><br>
    Inserted: <% int i = exiplist.insertExceptionIPList(request.getParameter("ip")); out.print(i); %>
    </body>
    </html>
    Please let me know how this works,
    Darren B

  • Problem with communicating with server https.

    I am in Los Cabos and experiencing problem to add account on my iPad. I use my existing apple ID and password but I receive this message: Verification Error. There is a problem in communicating with the server HTTPS. Can some help me please?

    Did you find anything on this? I'm facing the same issue... Thank you

  • Design problem: RS232 communication

    Hi,
    I have a design problem for communication with a device via RS232. Since I'm normally a C++ programmer I might just look at the problem from a wrong angle and hope for some hints how to do it in LabVIEW.
    The scenario:
    A device is communicating with the PC via RS232. The device permanently sends data packets. At the same time, commands can be sent to the device and it returns replies. Data packets and reply packets are arbitrarily mixed, i.e. after sending a command there could be a couple of date packets before the reply comes back but the packets can be distinguished by an identifier.
    At least one, ideally several VIs should communicate with the device. Commands should be sent by pressing buttons and the incoming data should be parsed (the packets contain mutliple data streams) and shown on graphs or saved to files.
    My initial idea:
    Coming from C++ I wanted to build a class for the communication that permanently reads the incoming data and splits it to reply and data packets. This class would then have a function to send out a command and would return the reply or a timeout and it would be possible to register and unregister listeners (I wanted to use queues for this) for the various data streams.
    The problems I ran into:
    There were a couple but the two most pressing problems were: how could I communicate with the constantly running sample VI (e.g. to stop sampling) and how could I propagate changes to the class to it (e.g. new listeners). Since it is not returning I don't see a good way to implement it as in instance funcion (i.e. pass it the object). I could probably not let the sample function run continously but call it periodically from outside. However I planned to implement the class as a singleton, so it could be used parallely from different VIs.
    Is there a best practice for a case like this?
    I'm glad about any hints or ideas.
    Thanks,
    Tobias

    tfritz wrote:
    Hi,
    thanks. Since almost the same thing was suggested to me in a German forum I guess this is really common practice (using one VI with different methods controlled by a queue). It still seems a little "unnatural" for me but my biggest concern (bad interface description) was shattered by the suggestion in the link you sent me to wrap these functions with wrapper VIs, thus caller VIs won't have to deal with the call-by-queue-mechanism. This might also be easier to port to a different implementation later. However I still see the danger that the continously running VI could easily become bloated. 
    It also requires me to change the way I have looked at VIs until now. In our course they told us that VIs are basically functions. Using this design patterns, the VI becomes more of a module, really (Like a C module implemented in a C-Source file). But I will try it. It sounds as if it could work.
    I will still look into the OOP solutions a little more, though. Do I understand you correctly that you wouldn't recommend using LVOOP because it's still buggy? What about dqGOOP for example? This sounds like it could do what I need (however it doesn't seem to implement things like polymorphism, late binding and inheritance so I don't quite see what's so OOP about it. It seems more like programming with structures in C.)
    I don't know if LVOOP is buggy or not.  I think early on it was buggy and things have improved in recent versions. I have read that it doesn't have all the features that you would have in OOP like C.  I wouldn't recommend it only because I'm not familiar with it at all.  I can't recommend something that I'm not comfortable with.  If you go that route, plan on spending time in these forums and in LAVA to reading up on what others have done.  I haven't hard of dqGOOP.
    But back to your suggestion. I still have a couple of questions:
    - How do you return values from the module? Would you use a queue for that as well?
    - Where would the parameter queue be held (created and passed to the VI)
     I would store all of these in a functional global variable.  This is the VI that stores data in shift registers.  Ben's action engine nugget is an advancement on that.  This allows for both the calling VI and the parallel running subVI to get and set the data as needed.  It runs quickly so neither process should be forced to wait while the other  VI is doing its thing.
    - My VI has to be constantly sampling and this shouldn't be interrupted too long by other functions as adding a listener. However both functionalities have to access the same kind of data. Is there an easy way to parallelize this? Would the sampling be a case in the case diagram that's always used if no command was sent to the VI or would it somehow run parallely?   Yes.  There are a couple of ways of doing this.  One would be for the dequeue to have a timeout function.  In the event the dequeue times out, you run the code that is doing the acquisition.  I think a better method is that the code that does the acquisition enqueues its own command again to the end of the queue.  Let's say that is command A.  So when case A finishes, it enqueues A, which seeds itself to run again.  So if nothing else comes into the queue, it just executes A , A, A, A.  But let's say another section of code needs to do something such as command B.  It will slip B into the queue while A is executing.  So you would A, B, then A again, because A would get slipped back into the queue when the first A finishes, but B has already been put in while the first A was running.
    - Would it be possible to make the VI reentrant and in this way use it simultaneously on different COM ports (using different parameter queues as well)? I'm not sure if I will need this but it would be neat if it could work.
    I think you could do this.  It may be a case where the VI is saved as a template  (.vit) and you initiate it multiple times.  I haven't needed to do this before, so I'm afraid I can't provide any details or useful tips. 
    Well, I will fool around some more. Thanks so much for your help. This is kind of exciting since the concepts are quite new for me. Btw, is there something like an academic theory (computer science) for LabVIEW? I came across functional languages in university but data flow languages are still a new concept for me.
    Tobias
    tfritz wrote:
    Another question about the "dynamically starting" of the VI:
    How is the path handled? Is it guaranteed that it always takes the VI from the project or does it just search for the first VI by that name it finds in the file structure? Does this still work when building an .exe from the project? What happens if the VI is already running? Can you test for this?
    While I'm at it: is there a way to stop LabVIEW from searching for subVIs it can't find when openin a VI? This resulted in very unexpected behaviour sometimes where it would find the VI somewhere else (with the same name but maybe an older version).
    In my case, I just had the path hardcoded.  It is my only instance, I'm not planning on moving the VI's.  If you don't have the path, it will take a VI by that name if it's in memory.  If it isn't in memory, it starts searching relative to the calling VI's path.  One thing I know, if you are dealing with relative paths, a subVI has a different relative path in an .exe as opposed to the development environment.  The name of the .exe becomes a folder.  So in development, if your sub VI is mySubVI.vi.  In an executable, its path is MyExe.exe\MySubVI.vi
    For all of this, I recommend searching the forums to get more details.
    If it is searching for a VI, you can hit ignore.  But of course you'd have to do it before it finds it.  When you are dealing with versioning issues, I recommend making a backup copy of the entire directory structure elsewhere.  Some location where it shouldn't stumble across it.

  • Safari cannot open the page ~ The error was: "There was a problem communicating with the web proxy server (HTTP)

    Help!  I was cruzing along just fine and went out tonight only to receive the message above:
    Cannot open Page
    Safari cannot open the page
    The error was: "There was a problem communicating with the web proxy server (HTTP)."
    I have had all the Apple iPhone phone.  Have never encountered anything like this. 
    All systems are GO as soon as I log on to wifi. 
    Can anyone help, please. 

    I am also fixed.  I also loaded Onavo, but that was the other day ... this is what I did with the help of online chat with AT&T ...
    I went to:
    Settings
    Wifi
    I selected the network I was working on by hitting the blue arrow located on right side
    At the detail page of that network I scolled down to the bottom to find HTTP Proxy boxes
    I was on Off and changed it to Auto and it worked! 
    I was soo jazzed!!
    Instructions said if it was already on AUTO, to change it to Manual and make your Port = 80 but I didn't have to do that!
    YIPPIE!!  I'm a new man!!
    Go to settings -----> WI-FI  -----> select the network you're using  ------> hit the blue arrow located on the right-side of the network name (ie: show details of that network), this takes you to another page.  
    --------> at the bottom of the page you'll see "HTTP Proxy" boxes (located below the "renew lease" button) ---------------> change the proxy to AUTO.   Note: if you're already at AUTO, change it to "Manual" and make your Port = 80.

  • Sir i am using datasocket read ,i am communicating with java but my problem is that bcz im using while loop to see if value has changed my labview consumes all the processors time ,sir i want a event like thing so that while loop is not in continuous loop

    sir i have given lot of effort but i am not able to solve my problem either with notifiers or with occurence fn,probably i do not know how to use these synchronisation tools.

    sir i am using datasocket read ,i am communicating with java but my problem is that bcz im using while loop to see if value has changed my labview consumes all the processors time ,sir i want a event like thing so that while loop is not in continuous loopHi Sam,
    I want to pass along a couple of tips that will get you more and better response on this list.
    1) There is an un-written rule that says more "stars" is better than just one star. Giving a one star rating will probably eliminate that responder from individuals that are willing to anser your question.
    2) If someone gives you an answer that meets your needs, reply to that answer and say that it worked.
    3) If someone suggests that you look at an example, DO IT! LV comes with a wonderful set of examples that demonstate almost all of the core functionality of LV. Familiarity with all of the LV examples will get you through about 80% of the Certified LabVIEW Developer exam.
    4) If you have a question first search the examples for something tha
    t may help you. If you can not find an example that is exactly what you want, find one that is close and post a question along the lines of "I want to do something similar to example X, how can I modify it to do Y".
    5) Some of the greatest LabVIEW minds offer there services and advice for free on this exchange. If you treat them good, they can get you through almost every challenge that can be encountered in LV.
    6) If English is not your native language, post your question in the language you favor. There is probably someone around that can help. "We're big, we're bad, we're international!"
    Trying to help,
    Welcome to the forum!
    Ben
    Ben Rayner
    I am currently active on.. MainStream Preppers
    Rayner's Ridge is under construction

  • HELP!! asa 5505 8.4(5) problem with port forwarding-smtp

    Hi I am having a big problem with port forwarding on my asa. I am trying to forward smtp through the asa  to my mail server.
    my mail server ip is 10.0.0.2 and my outside interface is 80.80.80.80 , the ASA is setup with pppoe (I get internet access no problem and that seems fine)
    When I run a trace i get "(ACL-Drop) - flow is deied by configured rule"
    below is my config file , any help would be appreciated
    Result of the command: "show running-config"
    : Saved
    ASA Version 8.4(5)
    hostname ciscoasa
    domain-name domain.local
    enable password mXa5sNUu4rCZ.t5y encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group ISPDsl
    ip address 80.80.80.80 255.255.255.255 pppoe setroute
    ftp mode passive
    dns server-group DefaultDNS
    domain-name domain.local
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Server_SMTP
    host 10.0.0.2
    access-list outside_access_in extended permit tcp any object server_SMTP eq smtp
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
    nat (inside,outside) dynamic interface
    object network server_SMTP
    nat (inside,outside) static interface service tcp smtp smtp
    nat (inside,outside) after-auto source dynamic any interface
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 10.0.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    telnet timeout 5
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    vpdn group ISP request dialout pppoe
    vpdn group ISP localname [email protected]
    vpdn group ISP ppp authentication chap
    vpdn username [email protected] password *****
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:c5570d7ddffd46c528a76e515e65f366
    : end

    Hi Jennifer
    I have removed that nat line as suggested but still no joy.
    here is my current config
    Result of the command: "show running-config"
    : Saved
    ASA Version 8.4(5)
    hostname ciscoasa
    domain-name domain.local
    enable password mXa5sNUu4rCZ.t5y encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group ISP
    ip address 80.80.80.80 255.255.255.255 pppoe setroute
    ftp mode passive
    dns server-group DefaultDNS
    domain-name domain.local
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Server_Mail
    host 10.0.0.2
    access-list outside_access_in extended permit tcp any object Server_Mail eq smtp
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
    nat (inside,outside) dynamic interface
    object network Server_Mail
    nat (inside,outside) static interface service tcp smtp smtp
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 10.0.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    telnet timeout 5
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    vpdn group ISP request dialout pppoe
    vpdn group ISP localname [email protected]
    vpdn group ISP ppp authentication chap
    vpdn username [email protected] password *****
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:f3bd954d1f9499595aab4f9da8c15795
    : end
    also here is the packet trace
    and my acl
    Thanks

  • I get an error message when trying to install windows 7 on my macbook pro. The message says "windows has encountered a problem communicating with a device connected to your computer. I don't have anything connected to my computer. How do I fix this?

    I'm trying to install windows 7 on my macbook pro. I went through the process of bootcamp telling it to install windows 7. Once the windows boot manager started an error message came up. The error message says " windows has encountered a problem communicating with a device connected to your computer. I don't have a usb connected to my computer. I  am using windows 7 professional install disc. I  can't figure out what i am doing wrong. The same message keeps coming up over and over. Am I doing something wrong or is it something else?

    Well, shucks, i just spent almost 30 minutes trying to find your model user guide to explain it better, I guess they never got around to making it.....
    I would just borrow another Windows disk and try installing it again and if it does it again then you might take it to an Apple Store and see if one of the "Genius' " can figure it out.
    Make sure your internet is enabled and click on your blank desktop and at the top of your screen is a Help menu option, enter PRAM and it should give you a list of things relating to Pram. It may take a few seconds to list anything as it has to connect to Apples severs first. It should list the things you may have to fill back in when your done.
    "P-ram" stores some common information that is used in the background, your date, time, startup disk, etc, that you don't have to re-fill when you restart, it's a little different for each computer.

  • There is a problem communicating with the printer.

    I have a Lexmark Interpret S405. I am using a MBP laptop with WiFi, running 10.5.8. I have a cabled (non-wifi) Linsys router. I am using an Airport Express.
    I was finally able to get the WiFi light on the Lexmark to be static green after reinstalling the Lexmark WiFi setup and reconfiguring my Airport settings so that both the computer and printer see each other.
    In fact, I even updated the driver from Lexmark's Web site last night and I watched the WiFi light on the printer blink green indicating that the installation of the driver update was being communicated to the printer.
    However, when I print, it opens the print window and says first "Looking for S300-S400", then it says "Printer is now online". Then after about 10 seconds, I get this error: "There is a problem communicating with the printer. Make sure the printer is powered on and connected to the computer. Delete or hold the job and try again."
    I've exhausted Lexmark's technical databases and couldn't find the answer here.
    I've read that one possible solution was to delete all the printers from the "Print & Fax" system preferences window and re-add. That didn't work.
    Lexmark says for: The printer communicating on a network; however, the printer is not responsive. Possible causes could be:
    1. Your printer is associated with a network, router, or access point, but it is not your network.
    2. A software process is blocked by a system security firewall preventing network communication.
    3. You are logged into Virtual Private Network (VPN).
    4. You are connected to a network but have decided to switch to a USB connection.
    I don't have a VPN and have removed the USB cable, then restarted both printer and computer, and deleted printers in Sys Prefs, restarted, and still no solution.
    I can print directly via USB cable, but want to print wirelessly.
    Lexmark also says to enter my PIN (which I have pulled out from the print menu screen on the printer) in the System. That tells me a lot...
    Network settings on the print window on the printer also tell me Signal strength is 5 (excellent) and that I am on the network my airport is on.
    Message was edited by: Macman17

    I bet this is too late but...
    Are you trying to print through the airport express wirelessly or the built in wireless of the lexmark? If you want to use the airport express, there is no need to mess with the wireless printing on the lexmark at all. The airport express will be easy to set up, all the wireless setups through the printers are a pain.

Maybe you are looking for