Problem in Port Binding

Hi,
I am new to java networking. I have doubt about port binding. My machines are something like this. I tried simple applet which is binding port in downloaded machine
machine 1 - Webserver.
machine 2- Applet downloaded and binds port(8555).
machine 3- Test machine.
I gave all permission to machine 2, when i try to access machine 2 port(8555) through machine 1, there is no problem, but when want to access machine 2-8555 through machine 3 there is Access Control exception.
Thanks.

Is the permission included in the AccessControlException?
Have you tried a policy like:
grant {
     permission java.security.AllPermission;
};

Similar Messages

  • HELP!! asa 5505 8.4(5) problem with port forwarding-smtp

    Hi I am having a big problem with port forwarding on my asa. I am trying to forward smtp through the asa  to my mail server.
    my mail server ip is 10.0.0.2 and my outside interface is 80.80.80.80 , the ASA is setup with pppoe (I get internet access no problem and that seems fine)
    When I run a trace i get "(ACL-Drop) - flow is deied by configured rule"
    below is my config file , any help would be appreciated
    Result of the command: "show running-config"
    : Saved
    ASA Version 8.4(5)
    hostname ciscoasa
    domain-name domain.local
    enable password mXa5sNUu4rCZ.t5y encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group ISPDsl
    ip address 80.80.80.80 255.255.255.255 pppoe setroute
    ftp mode passive
    dns server-group DefaultDNS
    domain-name domain.local
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Server_SMTP
    host 10.0.0.2
    access-list outside_access_in extended permit tcp any object server_SMTP eq smtp
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
    nat (inside,outside) dynamic interface
    object network server_SMTP
    nat (inside,outside) static interface service tcp smtp smtp
    nat (inside,outside) after-auto source dynamic any interface
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 10.0.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    telnet timeout 5
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    vpdn group ISP request dialout pppoe
    vpdn group ISP localname [email protected]
    vpdn group ISP ppp authentication chap
    vpdn username [email protected] password *****
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:c5570d7ddffd46c528a76e515e65f366
    : end

    Hi Jennifer
    I have removed that nat line as suggested but still no joy.
    here is my current config
    Result of the command: "show running-config"
    : Saved
    ASA Version 8.4(5)
    hostname ciscoasa
    domain-name domain.local
    enable password mXa5sNUu4rCZ.t5y encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group ISP
    ip address 80.80.80.80 255.255.255.255 pppoe setroute
    ftp mode passive
    dns server-group DefaultDNS
    domain-name domain.local
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Server_Mail
    host 10.0.0.2
    access-list outside_access_in extended permit tcp any object Server_Mail eq smtp
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
    nat (inside,outside) dynamic interface
    object network Server_Mail
    nat (inside,outside) static interface service tcp smtp smtp
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 10.0.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    telnet timeout 5
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    vpdn group ISP request dialout pppoe
    vpdn group ISP localname [email protected]
    vpdn group ISP ppp authentication chap
    vpdn username [email protected] password *****
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:f3bd954d1f9499595aab4f9da8c15795
    : end
    also here is the packet trace
    and my acl
    Thanks

  • I've been having a problem forwarding ports in my router...

    I've been having a problem forwarding ports in my router WRT160N I enable the ports I want to use for my applications, just after clicking save settings I go back to my port's forwarding section and I don't see any application I add being saved. Please help, thanks.
    Message Edited by AudioSoft on 04-09-2008 05:31 PM

    Might be possible that it will take time to save the settings ... so once you click save settings wait for few seconds ...
    Also if it not working ... disable all firewall on the computer & then try to configure the router ...

  • Link Problem with port 2 in WLC 4402

    Hi,
    I have a problem with port 2 in Wireless Lan Controler 4402. The problem is that the distribution port 2 of the WLC not link with the switch (3750). We receive the WLC and we follow the autostart wizard and we enable LAG. The wizard finish, I restart the system and all works fine. The two distribution ports of WLC, 1 and 2 appears UP and the LAG works correctly. After this we upgrade the firmware of the WLC to the version AIR-WLC4400-k9-6-0-182-0.aes and we restart the system again but at this time port 2 does not link and port 1 link OK. We do not know the reason why port 2 doesn´t link? Could you help me ?
    Thank in advance.
    Regards.

    Does it properly refuse authentication ? Or does the login page stop appearing or something ?
    There was a bug with the webauth dying under heavy load, regardless of number of identical accounts used.
    One good way for you to check would be, when problem occurs, to create a second backup guest user and see if that would start working. If it doesn't, the account is not the problem.
    I'm not aware of any maximum of usage of the same account.
    Which 4.2 exactly are you running ?

  • No port binding available with 11.1.1.8 business services

    I am creating DBAdapter services in jdev and then trying to create Business Services in OEPE. I was using the 11.1.1.4 with no issues, but had to upgrade so the server and dev tools were in sync for easy deployment.
    Basically when you select the WSDL in the business service it does not see the port binding so you can't complete the creation of the service. It appears the new version does not import things correctly. In the previous version it referenced the WSDL but the new import WSDL looks nothing a like the previous version. I have a fair amount of experience doing this so I am kinda scratching my head as to the deltas and it not recognizing the port binding in the wsdl. Not sure if I need to upgrade jdev 10 11.1.1.6 as I am using 11.1.1.5.
    Any help would be appreciated.

    I found what the issue is but not sure what the fix is. I selected a sequence when on the last step of the wizard and that is causing issues with the wsdl file. If I remove that things work correctly
    Edited by: sjackson on Mar 11, 2012 1:46 AM

  • Problem with Port Forwarding in WRT320N

    Good day.
    I have a web-server and Internet-radio translator to local network of my provider. And I found a problem with Port Forwarding. I'm trying to setup 80 & 8000 ports to forward. And it's working but only for Internet, without provider's local network. My web-server isn't accessible in local network and radio-translator too. 
    So is it possible to forward ports absolutely - for any type of connections? 
    P.S. DMZ is working like Port Forwarding.

    If you ask questions you have to mention that you have an PPTP connection to the internet and another network directly on the internet port. Otherwise noone will really understand your question as it is a very unusual setup.
    Your setup is not one really supported by the router. You are lucky that it works but don't expect too much. Port forwarding only the internet connection. If you use PPTP the network on the internet port is basically hidden. Using that local network on the internet port is not supported.
    The DMZ host is the IP address to which all ports are forwarded to which are not forwarded otherwise. The same restriction applies here.
    I would recommend to ask your ISP which router they recommend for their internet connection. I think most/all Linksys routers and many other brand's consumer routers won't really support a setup like yours...

  • The problem of the binding a UIcomponent ...

    Hi.here
    The problem of the binding a UIcomponent I met.
    there are some codes of the login.jsp:
    <h:form>
    userName:<h:inputText id="userid" binding="#{Login.userid}" required="true"></h:inputText>
    password<h:inputSecret id="password" binding="#{Login.password}" required="true"></h:inputSecret><br>
    <h:commandButton value="’ñŒð" action="#{Login.Login_Checked}"></h:commandButton>
    </h:form>
    -----------faces-config.xml--------------------------
    <managed-property>
    <property-name>userid</property-name>
    <property-class>javax.faces.component.html.HtmlInputText</property-class>
    <value>userid</value>
    </managed-property>
    <managed-property>
    <property-name>password</property-name>
    <property-class>javax.faces.component.html.HtmlInputSecret</property-class>
    <value/>
    </managed-property>
    When I was running the page,the Exeption came out! As following:
    javax.servlet.ServletException: Error performing conversion of value userid of type class java.lang.String to type class javax.faces.component.html.HtmlInputText for managed bean Login._
    javax.faces.webapp.FacesServlet.service(FacesServlet.java:249)_
    Can you help me?

    I hava do ii as you say . Now I give you the javaBean code:
    package com.jsfdemo;
    import javax.faces.component.html.HtmlInputSecret;
    import javax.faces.component.html.HtmlInputText;
    * @author Administrator
    public class Login {
         private HtmlInputText userid;
         private HtmlInputSecret password;
         public Login() {
         public HtmlInputText getUserid() {
              return userid;
         public void setUserid(HtmlInputText userid) {
              this.userid = userid;
         public HtmlInputSecret getPassword() {
              return password;
         public void setPassword(HtmlInputSecret password) {
              this.password = password;
         public String Login_Checked()
    *          try{*
    *               if(userid.getValue().equals("myeclipse")&& password.getValue().equals("myeclipse"))*
    *               return "success";*
    *          else*
    *               return "failure";*
    *          catch(NullPointerException e)*
    *               System.out.println("exception: " + e.getMessage());*
    *               return "failure";*
    Is it this?

  • SRW2024 (Port Binding)

    Hi all,
    I've recently purchase an 24-port 10/100/1000 Gigabit Switch SRW2024. Any body please help me how to configure port binding with mac-address in SRW2024.
    Regards,

    Please elaborate your inquiry, I believe that there's no exact port binding features from this switch. Please correct me if I am wrong about this. But if you want Port Mirroring or Port Trunking you can just visit www.linksysbycisco.com/kb for more information about it.

  • Load repository without (TCP/IP) port binding?

    Hello all,
    According to the MDM100 course, it is possible to load repositories without port binding (for port flip-over). But how do I do this?
    When I try to erase the port number of the (unloaded) repository, a message informs me that a port number between 2000 and 9999 is required.
    Is this option gone in SP05?
    Kind regards,
    Dennis klemann

    Hi Charan,
    You're right for typical use, but I'm working on a high availability scenario. Basically, it should be possible to load a slave repository without port binding. In case the master repository fails, the slave can immediately take over (by assigning the port of the master), at least in read-only mode - but better than nothing and external applications don't have to be reconfigured.
    When the master repository is up again, it can take over the port.
    For bigger installations, a clustering system is probably better suited, though...
    Kind regards,
    Dennis

  • Problems of Port Configuration while upgrading from 4.0B to ERP 6

    Hi all,
        We are upgrading a system from 4.0B to ERP 6. Will there will be any problems from port configuration side? If any please tell what they might be.
    thankyou.

    Hello,
    We have upgraded from 4.6C to ECC6.0 and did not have any port config issues.
    Things to look for:
      - RFC destinations, do they still work
      - directories used in File type ports, are they still there (they should be)
    Hope this helps a bit
    Regards
    Greg Kern

  • Problem on ADF binding with BPEL process composed as web service

    I have an ADF page which has its own EO, AM and VO (view1), after I created a web service data control for an existing BPEL process and a command button for it, I found in the binding section, the view1 doesn't contain all its table column attributes, all it has is some attributes such as attributeDef, currentRow, error etc. Can you please let me know what is missing here? What I'm trying to do is bind table attributes to BPEL input variables and call the BPEL process.
    Thanks
    Tony

    Hi,
    if you deployed this to OC4J, open EM
    http://server:port/em
    and get to the Web service. You can execute it from here to see if generally this is working, or if you have a proxy problem only
    Frank

  • Composite schema for Oracle send port - Binding Issue

    Hi this is my composite schema has 2 operations : the first is a generated view that has filter and column tags and the second one is a SQLEXECUTE operation. my problem is I think with the Binding of the composite schema.
    this is the schema:
    <?xml version="1.0" encoding="utf-16"?>
    <xs:schema xmlns="http://Comverse.ConcertoSyncSST.QueryOracleComposite" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" xmlns:ns1="http://Comverse.ConcertoSyncSST.MaxDateQuerySQLEXECUTE" xmlns:ns0="http://Comverse.ConcertoSyncSST.OracleDBBindingAPPS.View.CNS_CONCERTO_PROJECTS" targetNamespace="http://Comverse.ConcertoSyncSST.QueryOracleComposite" xmlns:xs="http://www.w3.org/2001/XMLSchema">
    <xs:import schemaLocation=".\MaxDateQuerySQLEXECUTE.xsd" namespace="http://Comverse.ConcertoSyncSST.MaxDateQuerySQLEXECUTE" />
    <xs:import schemaLocation=".\OracleDBBindingAPPS.View.CNS_CONCERTO_PROJECTS.xsd" namespace="http://Comverse.ConcertoSyncSST.OracleDBBindingAPPS.View.CNS_CONCERTO_PROJECTS" />
    <xs:annotation>
    <xs:appinfo>
    <b:references>
    <b:reference targetNamespace="http://Microsoft.LobServices.OracleDB/2007/03" />
    <b:reference targetNamespace="http://schemas.microsoft.com/2003/10/Serialization/Arrays" />
    <b:reference targetNamespace="http://Comverse.ConcertoSyncSST.OracleDBBindingAPPS.View.CNS_CONCERTO_PROJECTS" />
    <b:reference targetNamespace="http://Comverse.ConcertoSyncSST.MaxDateQuerySQLEXECUTE" />
    </b:references>
    </xs:appinfo>
    </xs:annotation>
    <xs:element name="Send">
    <xs:annotation>
    <xs:appinfo>
    <b:properties>
    <b:property distinguished="true" xpath="/*[local-name()='Send' and namespace-uri()='http://Comverse.ConcertoSyncSST.QueryOracleComposite']/*[local-name()='Select' and namespace-uri()='http://Comverse.ConcertoSyncSST.OracleDBBindingAPPS.View.CNS_CONCERTO_PROJECTS']/*[local-name()='COLUMN_NAMES' and namespace-uri()='http://Comverse.ConcertoSyncSST.OracleDBBindingAPPS.View.CNS_CONCERTO_PROJECTS']" />
    <b:property distinguished="true" xpath="/*[local-name()='Send' and namespace-uri()='http://Comverse.ConcertoSyncSST.QueryOracleComposite']/*[local-name()='Select' and namespace-uri()='http://Comverse.ConcertoSyncSST.OracleDBBindingAPPS.View.CNS_CONCERTO_PROJECTS']/*[local-name()='FILTER' and namespace-uri()='http://Comverse.ConcertoSyncSST.OracleDBBindingAPPS.View.CNS_CONCERTO_PROJECTS']" />
    <b:property distinguished="true" xpath="/*[local-name()='Send' and namespace-uri()='http://Comverse.ConcertoSyncSST.QueryOracleComposite']/*[local-name()='SQLEXECUTE' and namespace-uri()='http://Comverse.ConcertoSyncSST.MaxDateQuerySQLEXECUTE']/*[local-name()='SQLSTATEMENT' and namespace-uri()='http://Comverse.ConcertoSyncSST.MaxDateQuerySQLEXECUTE']" />
    </b:properties>
    </xs:appinfo>
    </xs:annotation>
    <xs:complexType>
    <xs:sequence>
    <xs:element ref="ns0:Select" />
    <xs:element ref="ns1:SQLEXECUTE" />
    </xs:sequence>
    </xs:complexType>
    </xs:element>
    <xs:element name="Receive">
    <xs:complexType>
    <xs:sequence>
    <xs:element ref="ns0:SelectResponse" />
    <xs:element ref="ns1:SQLEXECUTEResponse" />
    </xs:sequence>
    </xs:complexType>
    </xs:element>
    </xs:schema>
    and this is the error received :
    A message sent to adapter "WCF-Custom" on send port "WcfSendPort_OracleDBBinding_APPS_View_CNS_CONCERTO_PROJECTS_Custom" with URI "oracledb://test11i/" is suspended. 
     Error details: Microsoft.ServiceModel.Channels.Common.MetadataException: Argument ngAPPS.View.CNS_CONCERTO_PROJECTS/Select is invalid.
    Server stack trace: 
       at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at System.ServiceModel.Channels.ServiceChannel.SendAsyncResult.End(SendAsyncResult result)
       at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
       at System.ServiceModel.Channels.ServiceChannel.EndRequest(IAsyncResult result)
    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at System.ServiceModel.Channels.IRequestChannel.EndRequest(IAsyncResult result)
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfClient`2.RequestCallback(IAsyncResult result) 
     MessageId:  {29E348F3-BA09-43E8-A8A2-AB499DD856C4}
     InstanceID: {82378FAC-9C2E-4D5B-ACB6-18C479A58F3A}
    any suggestions?

    Hi Yotam,
    Do you have Select statement in your Procedure used for SQLEXECUTE? Using "SET NOCOUNT OFF" in your procedure might work for you.
    If this answers your question please mark as answer. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

  • OC4J port binding issue

    This thread is in OC4J/J2EE forum, but it feels like it could be an Redhat AS2.1 port handling issue, so I'm copying here...
    I'm having some problems with OC4J standalone. Starting and stopping OC4J gives error:
    "Error starting HTTP-Server: Address already in use"
    and sometimes "Error starting ORMI-Server. Unable to bind socket: Address already in use
    and almost always "Error starting JMS-Server: Unable to bind socket: Address already in use
    Starting and stopping a few times usually results in a successful restart, but this is intermittent success and not predictable. Reallocating with a different port numbers means successful start fist time, but then it follows the same pattern.
    This is OC4J standalone 9.0.3 pure java deployed on Linux RHAS 2.1...
    Java version is 1.3.1.1_02-b02
    My start and stop scripts look like this :
    startoc4j.csh
    #!/bin/csh
    java -Xmx100m -Xms100m -Dscm.logon=true -jar oc4j.jar -userThreads &
    stopoc4j.csh
    #!/bin/csh
    java -jar admin.jar ormi://localhost:50501 admin ias_admin1 -shutdown
    Has anyone seen this before? Is there a standard start / stop script for OC4J standalone on UNIX that I can use?
    Thanks,
    Mark

    This was found to be a JRE on Linux bug. Solution was to upgrade to Javasoft 1.4.1...

  • I have problem usb ports in my macbook

    I have a MAC BOOK  INTEL Core 2 duo .My usb ports not works. I tried reset PRAM, SMC reset. I removed the battery. And nothing work.
    Please Help

    I have the same problem with my USB ports (with a white Macbook). zapping the pram did nothing. Anyone have an idea why this happening or how to fix it?

  • Re-send with more information on  Modem installation problem- list port fail in admintools

    Background:
    If admintool can set serial I could have set it with a click.
    The error is "list port fail in "
    I have following many example including Celeste (stokey.com), I am totally lost with her instruction. I am a new-hand in SUN SOLARIS 8 INTEL. NEED good guidance and helping to set up an external Zoom 56 K modem on com 1.
    ==============================================================
    I was suspect a lot of work from internet is a copy of another.
    ===============================================================
    #sacdm -l t ttymon
    get:
    zsmon ttymon - 0 ENBALE /usr/lib/saf/ttymon
    #pmadm -l
    get:
    no service defined.
    There is no cua * under /dev
    These is nothing under /dev/term
    I have a number of error with the following script and I can screen-print and copy and then paste here.
    There are problem with the cua and term/$port.
    SO please help and guide.
    sunlearner.
    #!/sbin/sh
    # add_modem shell script. Must be run as root from bourne shell
    # Change these parameters as needed for your particular needs.
    # PARAMETER MEANING
    # PORT Port you want to set up. "a" or "b"
    # TTYSPEED Speed setting, from /etc/ttydefs
    # LOGINMSG The login message which will be displayed.
    # -p zsmon PMTAG, name of this port monitor
    # -s ttya SVCTAG, modem is on ttya. you may want ttyb
    # -d /dev/term/$PORT Actual port device.
    # -l contty5H Ttylabel, defined in /etc/ttydefs file. (speed
    # setting. contty5H=19200 baud)
    # -b Flag for bidirectional port use
    # -S n Turn software carrier off (modem supplies
    # hardware carrier detect signal)
    # "dial in/out on serial port" This is a comment you'll see on pmadm -l
    LOGINMSG="Always be nice to your sysadm. You may now login. "
    # set PORT = either a or b
    PORT="a"
    # choose your speed setting. See /etc/ttydefs for more, or build your
    # own from the examples in the rest of this article.
    # contty5H = 19200bps, 7 bits even parity, as supplied by Sun
    # conttyH = 9600bps, 7 bits even parity, as supplied by Sun
    TTYSPEED="contty5H"
    # change ownership of outgoing side of port to user uucp, group tty.
    # change ownership of incoming side of port to user root, group tty.
    chown uucp /dev/cua/$PORT; chgrp tty /dev/cua/$PORT
    chown root /dev/term/$PORT; chgrp tty /dev/term/$PORT
    # Remove any existing port monitor on this port.
    # You can ignore any error messages from this next command.
    # If you see the message "Invalid request, ttya does not exist under zsmon",
    # You may be trying to remove a port monitor which does not exist.
    /usr/sbin/pmadm -r -p zsmon -s tty$PORT
    # Create the new port monitor
    /usr/sbin/pmadm -a -p zsmon -s tty$PORT -i root \
    -v `/usr/sbin/ttyadm -V` -fu -m "`/usr/sbin/ttyadm \
    -p "$LOGINMSG" -d /dev/term/$PORT -s /usr/bin/login -l $TTYSPEED -b \
    -S n -m ldterm,ttcompat`" -y "dial in/out on serial port"
    ############ end of add_modem script ###################################

    The lack of /dev/cua etc is worrying - apparently there is an ACPI
    bug with certain BIOSes which means certain device nodes are not created (often floppy, printer, serial). Turning off ACPI in the BIOS if this option exists on your HW, followed by a reconfiguration boot (b -r) should help. When you have the device nodes in place, the guidance from Stokeley should work - you might also check the
    archives of the solarisonintel list at www.egroups.com

Maybe you are looking for