Problem in rotating and moving image at the same time

the problem is that im making a car game(2D) in which u have upper view of car.
i have make the car rotate bt problem is that i canot move it forward or backward correctly
.wen i move it forward or backward i goes wrong...
nd another problem is that i cannot both rotate and move the car at same time
example if i press both up nd right arrow keys i doesnt move nd rotate..
nd also plz tell me the accelerate nd reverse method so i can speedup my car like other car games
here is the code
import java.awt.*;
import java.awt.event.*;
import javax.swing.*;
import java.awt.geom.*;
import java.applet.*;
import java.net.URL;
public class RaceGame extends JComponent
static int x=560;
static int y=410;
static int currentAngle=0;
static double hspeed,vspeed;
static int carspeed=1;
Image car;
//int angle=car.getAngle();
Image getImage(String filename)
URL url = getClass().getResource(filename);
ImageIcon icon = new ImageIcon(url);
return icon.getImage();
//Rectangle2D.Float rect=new Rectangle2D.Float(x,y,30,30);
//Rectangle rect=new Rectangle(x,y,30,30);
public RaceGame()
car=getImage("car1.jpeg");
public void CreateBase()
JFrame frame=new JFrame("Dare2Race");
frame.setBounds(70,30,650,500);
frame.setVisible(true);
frame.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
Container c=frame.getContentPane();
c.add(new RaceGame());
frame.addKeyListener(new adapter());
c.setBackground(Color.BLACK);
//JLabel finish=new JLabel("FINISH");
//c.add(finish);
public void rotate()
currentAngle+=1;
if(currentAngle>=360)
currentAngle=0;
repaint();
public void paint(Graphics g)
super.paint(g);
Graphics2D g2d=(Graphics2D)g;
AffineTransform origXform=g2d.getTransform();
AffineTransform newXform=(AffineTransform)(origXform.clone());
newXform.rotate(Math.toRadians(currentAngle),x,y);
g2d.setTransform(newXform);
g2d.drawImage(car,x,y,this);
g2d.setTransform(origXform);
g.setColor(Color.WHITE);
g.drawLine(640,380,420,380);
g.drawLine(640,460,320,460);
g.drawLine(420,380,420,300);
g.drawLine(320,460,320,380);
g.drawLine(420,300,125,300);
g.drawLine(320,380,230,380);
g.drawLine(230,380,230,460);
g.drawLine(230,460,2,460);
g.drawLine(125,300,125,370);
g.drawLine(125,370,105,370);
g.drawLine(2,460,2,180);
g.drawLine(105,370,105,300);
g.drawLine(2,180,450,180);
g.drawLine(105,300,105,250);
g.drawLine(105,250,550,250);
g.drawLine(550,250,550,20);
g.drawLine(550,20,275,20);
g.drawLine(450,180,450,100);
g.drawLine(450,100,360,100);
g.drawLine(360,100,360,160);
g.drawLine(360,160,10,160);
g.drawLine(10,160,10,30);
g.drawLine(275,20,275,90);
g.drawLine(275,90,110,90);
g.drawLine(110,90,110,30);
repaint();
class adapter extends KeyAdapter
public void keyPressed(KeyEvent e)
switch(e.getKeyCode())
case KeyEvent.VK_LEFT:
currentAngle--;
repaint();
break;
case KeyEvent.VK_RIGHT:
currentAngle++;
repaint();
break;
case KeyEvent.VK_UP:
carspeed++;
hspeed=((double)carspeed)*Math.cos(currentAngle);
vspeed=((double)carspeed)*Math.sin(currentAngle);
x = x - (int) hspeed;
y = y - (int) vspeed;
repaint();
break;
case KeyEvent.VK_DOWN:
carspeed--;
hspeed=((double)carspeed)*Math.cos(currentAngle);
vspeed=((double)carspeed)*Math.sin(currentAngle);
x = x + (int)hspeed;
y = y + (int)vspeed;
repaint();
break;
public static void main(String[]args)
RaceGame race=new RaceGame();
race.CreateBase();
//race.setDoubleBuffered(true);
}

the problem is that im making a car game(2D) in which u have upper view of car.
i have make the car rotate bt problem is that i canot move it forward or backward correctly
.wen i move it forward or backward i goes wrong...
nd another problem is that i cannot both rotate and move the car at same time
example if i press both up nd right arrow keys i doesnt move nd rotate..
nd also plz tell me the accelerate nd reverse method so i can speedup my car like other car games
plz help me
here is the code
import java.awt.*;
import java.awt.event.*;
import javax.swing.*;
import java.awt.geom.*;
import java.applet.*;
import java.net.URL;
public class RaceGame extends JComponent
static int x=560;
static int  y=410;
static int currentAngle=0;
static double hspeed,vspeed;
static  int carspeed=1;
Image car;
//int angle=car.getAngle();
Image getImage(String filename)
URL url = getClass().getResource(filename);
ImageIcon  icon = new ImageIcon(url);   
return icon.getImage();
//Rectangle2D.Float rect=new Rectangle2D.Float(x,y,30,30);
//Rectangle rect=new Rectangle(x,y,30,30);
public RaceGame()
car=getImage("car1.jpeg");
public void CreateBase()
JFrame frame=new JFrame("Dare2Race");
frame.setBounds(70,30,650,500);
frame.setVisible(true);
frame.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
Container c=frame.getContentPane();
c.add(new RaceGame());
frame.addKeyListener(new adapter());
c.setBackground(Color.BLACK);
//JLabel finish=new JLabel("FINISH");
//c.add(finish);
public void rotate()
currentAngle+=1;
if(currentAngle>=360)
currentAngle=0;
repaint();
public void paint(Graphics g)
super.paint(g);
Graphics2D g2d=(Graphics2D)g;
AffineTransform origXform=g2d.getTransform();
AffineTransform newXform=(AffineTransform)(origXform.clone());
newXform.rotate(Math.toRadians(currentAngle),x,y);
g2d.setTransform(newXform);
g2d.drawImage(car,x,y,this);
g2d.setTransform(origXform);
g.setColor(Color.WHITE);
g.drawLine(640,380,420,380);
g.drawLine(640,460,320,460);
g.drawLine(420,380,420,300);
g.drawLine(320,460,320,380);
g.drawLine(420,300,125,300);
g.drawLine(320,380,230,380);
g.drawLine(230,380,230,460);
g.drawLine(230,460,2,460);
g.drawLine(125,300,125,370);
g.drawLine(125,370,105,370);
g.drawLine(2,460,2,180);
g.drawLine(105,370,105,300);
g.drawLine(2,180,450,180);
g.drawLine(105,300,105,250);
g.drawLine(105,250,550,250);
g.drawLine(550,250,550,20);
g.drawLine(550,20,275,20);
g.drawLine(450,180,450,100);
g.drawLine(450,100,360,100);
g.drawLine(360,100,360,160);
g.drawLine(360,160,10,160);
g.drawLine(10,160,10,30);
g.drawLine(275,20,275,90);
g.drawLine(275,90,110,90);
g.drawLine(110,90,110,30);
repaint();
class adapter extends KeyAdapter
public void keyPressed(KeyEvent e)
  switch(e.getKeyCode())
    case KeyEvent.VK_LEFT:
    currentAngle--;
    repaint();
    break;
    case KeyEvent.VK_RIGHT:
    currentAngle++;
    repaint();
    break;
    case KeyEvent.VK_UP:
    carspeed++;
    hspeed=((double)carspeed)*Math.cos(currentAngle);
    vspeed=((double)carspeed)*Math.sin(currentAngle);
    x = x - (int) hspeed;
    y = y - (int) vspeed;
    repaint();
    break;
    case KeyEvent.VK_DOWN:
    carspeed--;
    hspeed=((double)carspeed)*Math.cos(currentAngle);
    vspeed=((double)carspeed)*Math.sin(currentAngle);
    x = x + (int)hspeed;
    y = y + (int)vspeed;
    repaint();
    break;
public static void main(String[]args)
RaceGame race=new RaceGame();
race.CreateBase();
//race.setDoubleBuffered(true);
}and there is no compile time error in this code
the only error that occurs when u write java RaceGame is because of the car image which compiler doesnt found and throughs exception if u place any image in ur bin folder adn name it car.jpg it wont generate error

Similar Messages

  • Problem running DMVPN and IPSec VPN at the same time

    I have a hub-spoke VPN network: 2 hub routers are 7206 VXR and remote routers are 2800. Each hub router has had number of point-to-point IPSec+GRE tunnels configured and running with remote sites. I'm now adding DMVPN between each hub router and a few other remote sites. The DMVPN is running fine between hub and spokes, but somehow it caused all the eixsting point-to-point IPSec tunnels drop. Here are some details:
    1) Hub DMVPN config:
    crypto isakmp key MYKEY address 12.12.12.12
    crypto ipsec profile DMVPN
    set transform-set DM
    interface Tunnel1
    ip address 192.168.1.1 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp map multicast dynamic
    ip nhrp network-id 1
    ip nhrp holdtime 600
    tunnel source G0/0
    tunnel mode gre multipoint
    tunnel protection ipsec profile DMVPN
    router eigrp 1
    no passive-interface Tunnel1
    2) Spoke DMVPN config:
    crypto ipsec profile DMVPN
    set transform-set DM
    crypto isakmp key MYKEY address 14.14.14.14
    interface Tunnel1
    ip address 192.168.1.2 255.255.255.0
    ip mtu 1400
    ip nhrp map 192.168.1.1 14.14.14.14
    ip nhrp map multicast 14.14.14.14
    ip nhrp network-id 1
    ip nhrp holdtime 600
    ip nhrp nhs 192.168.1.1
    tunnel source G0/0
    tunnel destination 14.14.14.14
    tunnel protection ipsec profile DMVPN
    3) When DMVPN is up, hub router existing IPSec tunnels are shown ISAKMP failure.
    Hub# show crypto isakmp sa
    14.14.14.14     20.20.20.20 MM_NO_STATE       1508    0 ACTIVE (deleted)
    4) After I shut down interface Tunnel1, existing IPSec tunnels are coming back. ISAKMP SA shows QM_IDLE state.
    Have anyone seen similar issues between DMVPN and traditional point-to-point IPSec+GRE tunnels on the same router?
    Thanks a lot

    I have a hub-spoke VPN network: 2 hub routers are 7206 VXR and remote routers are 2800. Each hub router has had number of point-to-point IPSec+GRE tunnels configured and running with remote sites. I'm now adding DMVPN between each hub router and a few other remote sites. The DMVPN is running fine between hub and spokes, but somehow it caused all the eixsting point-to-point IPSec tunnels drop. Here are some details:
    1) Hub DMVPN config:
    crypto isakmp key MYKEY address 12.12.12.12
    crypto ipsec profile DMVPN
    set transform-set DM
    interface Tunnel1
    ip address 192.168.1.1 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp map multicast dynamic
    ip nhrp network-id 1
    ip nhrp holdtime 600
    tunnel source G0/0
    tunnel mode gre multipoint
    tunnel protection ipsec profile DMVPN
    router eigrp 1
    no passive-interface Tunnel1
    2) Spoke DMVPN config:
    crypto ipsec profile DMVPN
    set transform-set DM
    crypto isakmp key MYKEY address 14.14.14.14
    interface Tunnel1
    ip address 192.168.1.2 255.255.255.0
    ip mtu 1400
    ip nhrp map 192.168.1.1 14.14.14.14
    ip nhrp map multicast 14.14.14.14
    ip nhrp network-id 1
    ip nhrp holdtime 600
    ip nhrp nhs 192.168.1.1
    tunnel source G0/0
    tunnel destination 14.14.14.14
    tunnel protection ipsec profile DMVPN
    3) When DMVPN is up, hub router existing IPSec tunnels are shown ISAKMP failure.
    Hub# show crypto isakmp sa
    14.14.14.14     20.20.20.20 MM_NO_STATE       1508    0 ACTIVE (deleted)
    4) After I shut down interface Tunnel1, existing IPSec tunnels are coming back. ISAKMP SA shows QM_IDLE state.
    Have anyone seen similar issues between DMVPN and traditional point-to-point IPSec+GRE tunnels on the same router?
    Thanks a lot

  • How  to fade groups of images or multiple images at the same time?

    I am creating a flash infographic, and want to fade images I have imported from Illustrator that are grouped. I would like to know how  to fade these groups and multiple images at the same time.
    Thanks!

    Use TweenMax for this.
    the syntax is like this:
    var arrayOfDisplayObjects:Array = new Array();
    //with arrayOfDisplayObjects.push(DisplayObject)
    //you can put any DisplayObject in the Array and when you want to fade them call this
    TweenMax.allTo(arrayOfDisplayObjects,1, { autoAlpha:0} );
    //to fade them in 1 second to alpha=0 and when reaching the zero make them invisible (to save processing power)

  • Bash script: Rotate your wallpaper and SLiM theme at the same time

    EDIT;
    I've decided I should really thank Cerebral for his help with writing this script; this thank you should have been here from the get go.
    After writing:
    #!/usr/bin
    echo "Hello World!"
    I wrote a script to rotate my fluxbox background and SLiM theme at the same time, so I could have a contiuously changing background and still have a smooth transition from SLiM to fluxbox.  (It just looks so much cooler when both have matching backgrounds).  By the time you finish reading it, and configuring your box so it will work, you will probably have decided you could have writtin your own, better script to do the same thing.  But, on the off chance anybody finds use for it, here it is:
    (this should be obvious, but: don't run this script without at least reading the comments)
    #!/bin/bash
    #this is a script to rotate a number of backgrounds
    #to be shared by the fluxbox desktop and SLiM login manager.
    #it is the first meaningful script I've written. It may be
    #freely distributed and used with the understanding that you are
    #using it at your own risk.
    #Before running this script you need to check that your SLiM
    #themes are installed to the path /usr/share/slim/themes, which
    #is the defulat path for installation in Arch. Here are some
    #other things you need to set up:
    #1. create (if you don't have it) the directory /usr/share/wallpapers
    #2. create a wallpaper in /usr/share/wallpapers called 'dummy' by copying
    #you current wallpaper to that filename
    #3. set your window manager to display the wallpaper 'dummy', this works fine
    #using a style overlay in fluxbox, I haven't tested it with any other window
    #manager, but I don't see why this would cause a problem.
    #4. create a directory /usr/share/slim/themes/current, you can copy one of
    #your slim themes into that directory if you want. (this will prevent you
    #from seeing some error messages the first time you run the script)
    #5. define the names of the themes you want to rotate, in order for this
    #script to work, you must name them "themeNUMBER", where NUMBER is replaced
    #by an integer. Your themes must be numbered consecutively, start with 1
    # that is:
    #theme1 , theme2, theme3, etc. , theme305
    #If you don't number consecutively, this script will not run properly. You
    #must also define the total number of themes as "rotate_number"
    #6. Check if the script runs, if it does, you should change /etc/slim.conf to
    #use the theme "current"
    #7. This theme will now rotate your SLiM theme and wallpaper in such a way as
    #to make them match each other. Note that SLiM will not let you change themes
    #"on the fly", (as of July 6, 2008), so changes will not be apparent unless you
    #restart SLiM. I run the script before I run slim in my etc/rc.local local
    #script, so each time I reboot I get different wallpaper / login background.
    #Fred Drueck 2008
    #Define here all themes to be rotated and the total number of
    #themes to rotate:
    rotate_number=9
    theme1=/usr/share/slim/themes/default
    theme2=/usr/share/slim/themes/lake
    theme3=/usr/share/slim/themes/lunar
    theme4=/usr/share/slim/themes/flower2
    theme5=/usr/share/slim/themes/the-light
    theme6=/usr/share/slim/themes/mindlock
    theme7=/usr/share/slim/themes/parallel-dimensions
    theme8=/usr/share/slim/themes/wave
    theme9=/usr/share/slim/themes/fingerprint
    #check you are running this script as super-user:
    if [ $(id -u) != "0" ]; then
    echo "You must be the superuser to run this script" >&2
    exit 1
    fi
    echo "rotating themes"
    #figure out which theme is currently set, then name it as the variable
    #"last theme number", otherwise set last theme number as 0
    if [ -f /usr/share/slim/themes/current/current_theme_number ]
    then
    echo "checking current theme"
    cd /usr/share/slim/themes/current/
    eval last_theme_number=$(cat /usr/share/slim/themes/current/current_theme_number)
    echo $last_theme_number
    else
    echo "no theme is currently set, using theme 1"
    last_theme_number=0
    echo $1 > /usr/share/slim/themes/current/current_theme_number
    fi
    #set the new theme number
    eval new_theme_number=$(($(($last_theme_number % $rotate_number))+1))
    #select the new theme
    placeholder=theme
    eval new_theme=\$$placeholder$new_theme_number
    echo $new_theme
    #now clean out the "current" theme where I keep the current
    #theme for slim
    rm /usr/share/slim/themes/current/background*
    rm /usr/share/slim/themes/current/panel*
    rm /usr/share/slim/themes/current/slim.theme
    #the wildcards are there since the themes use jpg and png files
    cp $new_theme/background* /usr/share/slim/themes/current
    cp $new_theme/panel* /usr/share/slim/themes/current
    cp $new_theme/slim.theme /usr/share/slim/themes/current
    #increase the theme number, but first clear the old file
    rm /usr/share/slim/themes/current/current_theme_number
    echo $new_theme_number > /usr/share/slim/themes/current/current_theme_number
    #copy over the dummy wallpaper in "/usr/share/wallpapers" (with the theme
    #background file
    cp $new_theme/background* /usr/share/wallpapers/dummy
    exit 0
    Last edited by pseudonomous (2008-07-07 21:59:42)

    oh i forgot to mention... its rotating while moving. i.e. is doesn't have to stop rotate and then continue back to origin.

  • Problem connecting Firewire device and external HD at the same time

    Hi. I'm attempting to record digital audio through a Presonus Firepod A/D interface via a Firewire 400 to 800 cable connected to one of the Firewire 800 ports on a mid-2010 Mac Pro running Snow Leopard.
    The problem is that if I have an external HD connected to one of the other Firewire 800 ports on the computer and powered on at the same time, the connection to the Presonus Firewire device is not recognized by the Mac Pro. Not only that, performance of the Mac Pro is affected adversely and System Profiler is unable to list any Firewire devices. If I turn the external HD off, the Presonus device is recognized and listed in System Profiler and the machine runs fine. I'm able to connect two external hard drives via separate Firewire 800 ports on the Mac Pro and both drives mount w/ no problem. It's only when I try to connect one of the external HDs and the Presonus audio device at the same time that the problem occurs.
    I used this same arrangement on a PowerMac G5 running Tiger w/ no problems whatsoever. If the 400 to 800 cable is bad, I would think it wouldn't work at all, but it does when only the Presonus Firepod is connected and powered on. Any ideas?

    Have done more research and apparently this is not an uncommon problem: overloading the Firewire bus when connecting an audio device along with an additional device like an external hard drive. As I understand it now, audio signal is a bandwidth hog and the solution is to get a Firewire PCIe card which will have its own independent Firewire bus and which I'll use exclusively for my audio device.

  • How to export an album and keep images in the same order in elements 11 mac

    I made an album of my trip to Australia (lots of pictures) and changed the order of the images (not the same as shooting order) and when I export the images in the album to a folder or memorystick, the images are copied to that place but I lost the album order of the images.
    How can I prevent that, without having to renumber al 500 images separatly?
    Gr Jos

    Thanks for the tip, Michel
    It worked like a charm…
    cheers Jos
    Op 28 okt. 2013, om 18:49 heeft MichelBParis <[email protected]> het volgende geschreven:
    Re: How to export an album and keep images in the same order in elements 11 mac
    created by MichelBParis in Photoshop Elements - View the full discussion
    JosU a écrit:
    I made an album of my trip to Australia (lots of pictures) and changed the order of the images (not the same as shooting order) and when I export the images in the album to a folder or memorystick, the images are copied to that place but I lost the album order of the images.
    How can I prevent that, without having to renumber al 500 images separatly?
    Gr Jos
    The order in album is only kept in the organizer database, so the only way not to lose that order is to rename files.
    If you are using the 'export' function, select your album in custom order, select all photos and in the dialog, choose to rename with a common base name.
    Please note that the Adobe Forums do not accept email attachments. If you want to embed a screen image in your message please visit the thread in the forum to embed the image at http://forums.adobe.com/message/5794538#5794538
    Replies to this message go to everyone subscribed to this thread, not directly to the person who posted the message. To post a reply, either reply to this email or visit the message page: http://forums.adobe.com/message/5794538#5794538
    To unsubscribe from this thread, please visit the message page at http://forums.adobe.com/message/5794538#5794538. In the Actions box on the right, click the Stop Email Notifications link.
    Start a new discussion in Photoshop Elements at Adobe Community
    For more information about maintaining your forum email notifications please go to http://forums.adobe.com/message/2936746#2936746.

  • Code needed for "putting waveform graphs and 8bit images in the same window by Windraw"

    Hi Micheal, please sent the code example for my question:"putting waveform graphs and 8bit images in the same window by Windraw" , thanks.

    You can start from here ...
    Hope that helps,
    Michael
    Attachments:
    tester.vi ‏97 KB

  • Putting waveform graphs and 8bit images in the same window by Windraw

    How to put waveform graphs and 8bit images in the same window by Windraw VI?

    Use "Invoke Method: Get Image" to get a pic of your waveform graph/chart. Then combine this pic with your 8bit image using the IMAQ tools (IMAQ ImagetoImage). If you need an example send an e-mail again ...
    Michael

  • HT201263 When my Ipod touch is in autolock I can only restart the device holding the sleep/wake button and home button at the same time for 10 seconds.  While in auto-lock it is using battery power and will do so until the battery is drained.  Whats wrong

    When my Ipod touch is in autolock I can only restart the device holding the sleep/wake button and home button at the same time for 10 seconds.  While in auto-lock it is using battery power and will do so until the battery is drained.  Whats wrong?

    - Try a reset. Nothing is lost:
    Reset iPod touch: Hold down the On/Off button and the Home button at the same time for at
    least ten seconds, until the Apple logo appears
    - Connect the iPod to your computer and try to restore via iTunes. Try placing in Recovery mode if necessary to restore.
    - If you can't turn the iPod completely off, let the batter fully drain. After charging for at lerast anhour try again
    - If still not successful time for an appointment at the Genius Bar of an Apple store since it appears you have a hardware problem.

  • Two images at the same time

    Hi!
    I'm new into FCE and I would like to ask for some help. Can I work with two images at the same time? I mean, Can I superimpose two images to make one? How can I do it?
    Maybe this is something easy, but I'm just starting,
    thanks in advance for your answers
    Message was edited by: angelcotallo

    Yes, you can. You can put one clip on top of the other in the timeline. You can make both clips visible by reducing the opposite of the clip or top, or by scaling back the clips so they are smaller. You can reduce the opacity and scale of the clips in the viewer by opening the clips from the timeline into the viewer. You can also scale the images directly in the canvas when it is in Image+Wireframe mode.

  • I have an ipod 2 generation, but it wont charger or turn on. i try pressing the power and home button at the same time but it still wouldnt work. what else should i try to do?

    One day I was going to download music from my laptop to my ipod, I was able to download all the songs I wanted but later when I try to charger my ipod it wouldn't let me. The next day I bought a new charger but it still didn't charger. I try pressing the power And home button at the same time but it still wouldn't turn on or charger.

    Try:                                               
    - iOS: Not responding or does not turn on           
    - Also try DFU mode after try recovery mode
    How to put iPod touch / iPhone into DFU mode « Karthik's scribblings
    - If not successful and you can't fully turn the iOS device fully off, let the battery fully drain. After charging for an least an hour try the above again.
    - Try another cable              
    - Try on another computer                                                       
    - If still not successful that usually indicates a hardware problem and an appointment at the Genius Bar of an Apple store is in order.
      Apple Retail Store - Genius Bar                              

  • 10.3 and 8.1 at the same time

    I'm trying to run 10.3 and 8.1 at the same time and have had no luck so far.
    I have:
    installed 10.3 in a new directory, C:\bea103
    I'm running 8.1 in the default C:\bea
    changed the point base ports in 8.1
    changed the http/https ports in 8.1 to 8001/8002
    any ideas on what else I should do?
    I can start on or the other. When 10.3 is running 8.1 outputs the following to the console (Class paths have been chopped for length and the start command edited for legibility):
    JAVA Memory arguments: -Xms96m -Xmx256m
    WLS Start Mode=Development
    CLASSPATH=;<Cut for length>
    PATH=<Cut for length>
    * To start WebLogic Server, use a username and *
    * password assigned to an admin-level user. For *
    * server administration, use the WebLogic Server *
    * console at http:\\hostname:port\console *
    starting weblogic with Java version:
    Error [2] in bind() call!
    err:: No such file or directory
    Socket transport failed to init.
    Transport dt_socket failed to initialize, rc = -1.
    ERROR: No transports initialized
    Starting WLS with line:
    C:\bea\JROCKI~1\bin\java
         -jrockit
         -Xdebug
         -Xnoagent
         -Xrunjdwp:transport=dt_socket,address=8453,server=y,suspend=n
         -Djava.compiler=NONE
         -Xms96m
         -Xmx256m
         -Xverify:none
         -ea
         -da:com.bea...
         -da:javelin...
         -da:weblogic...
         -Dplatform.home=C:\bea\WEBLOG~1
         -Dwls.home=C:\bea\WEBLOG~1\server
         -Dwli.home=C:\bea\WEBLOG~1\integration
         -Dlog4j.configuration=file:C:\bea\WEBLOG~1\common\lib\workshopLogCfg.xml
         -Dweblogic.management.discover=true
         -Dweblogic.ProductionModeEnabled=
         -Dejbruntime.database=pointbase44
         -Dweblogic.security.SSL.ignoreHostnameVerify=false
         -Dwlw.iterativeDev=true
         -Dwlw.testConsole=true
         -Dwlw.logErrorsToConsole=true
         -Dweblogic.Name=portalServer
         -Djava.security.policy=C:\bea\WEBLOG~1\server\lib\weblogic.policy weblogic.Server
    Error [2] in bind() call!
    err:: No such file or directory
    Socket transport failed to init.
    Transport dt_socket failed to initialize, rc = -1.
    ERROR: No transports initialized
    Stopping the Weblogic Workshop debugger...
    === Debugging ===
    This window is necessary for debugging code using WebLogic Workshop
    Debugger Stopped.
    Stopping Pointbase server...
    Pointbase server stopped.
    Here is the console output when 8.1 is running and I try and start 10.3 (edited as above):
    JAVA Memory arguments: -Xms512m -Xmx1024m -XX:CompileThreshold=8000 -XX:PermSize=256m -XX:MaxPermSize=512m -XX:MaxPermSize=160m -XX:MaxPermSize=192m
    WLS Start Mode=Development
    CLASSPATH=;<Cut for length>
    PATH=<Cut for length>
    * To start WebLogic Server, use a username and *
    * password assigned to an admin-level user. For *
    * server administration, use the WebLogic Server *
    * console at http:\\hostname:port\console *
    starting weblogic with Java version:
    Cleaning up license and uid files
    Starting Autonomy with CONTENT_SEARCH_OPTION = full
    Autonomy Distributed Search Handler engine started.
    FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
    ERROR: transport error 202: bind failed: Address already in use
    ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
    JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:690]
    Starting WLS with line:
    C:\bea103\JDK160~1\bin\java
         -client
         -Xdebug
         -Xnoagent
         -Xrunjdwp:transport=dt_socket,address=8453,server=y,suspend=n
         -Djava.compiler=NONE
         -Xms512m
         -Xmx1024m
         -XX:CompileThreshold=8000
         -XX:PermSize=256m
         -XX:MaxPermSize=512m
         -XX:MaxPermSize=160m
         -XX:MaxPermSize=192m
         -Xverify:none
         -da:org.apache.xmlbeans...
         -ea
         -da:com.bea...
         -da:javelin...
         -da:weblogic...
         -ea:com.bea.wli...
         -ea:com.bea.broker...
         -ea:com.bea.sbconsole...
         -Dplatform.home=C:\bea103\WLSERV~1.3
         -Dwls.home=C:\bea103\WLSERV~1.3\server
         -Dweblogic.home=C:\bea103\WLSERV~1.3\server
         -Xmx1024m
         -Dcom.sun.xml.namespace.QName.useCompatibleSerialVersionUID=1.0
         -Daldsp.home=C:\bea103\odsi_10.3
         -Djavax.xml.soap.MessageFactory=weblogic.xml.saaj.MessageFactoryImpl
         -Dweblogic.wsee.bind.suppressDeployErrorMessage=true
         -Dweblogic.wsee.skip.async.response=true
         -Dwcb.properties.url="file:///c|/bea103/user_projects/domains/WCB_Developer_Domain/app
         -parms/"
         -Dlog4j.configuration=file:C:\bea103\USER_P~1\domains\WCB_DE~1\apacheLog4jCfg.xml
         -Dweblogic.management.discover=true
         -Dwlw.iterativeDev=true
         -Dwlw.testConsole=true
         -Dwlw.logErrorsToConsole=true
         -Dweblogic.ext.dirs=C:\bea103\patch_wlw1030\profiles\default\sysext_manifest_classpath;C:\bea103\patch_wls1030\profiles\default\sysext_manifest_classpath;C:\bea103\patch_wlp1030\profiles\default\sysext_manifest_classpath;C:\bea103\patch_wli1030\profiles\default\sysext_manifest_classpath;C:\bea103\patch_cie670\profiles\default\sysext_manifest_classpath;C:\bea103\patch_alsb1030\profiles\default\sysext_manifest_classpath;C:\bea103\patch_aldsp1030\profiles\default\sysext_manifest_classpath;C:\bea103\wlportal_10.3\p13n\lib\system;C:\bea103\wlportal_10.3\light
         -portal\lib\system;C:\bea103\wlportal_10.3\light
         -portal\lib\system;C:\bea103\wlportal_10.3\light
         -portal\lib\system;C:\bea103\wlportal_10.3\portal\lib\system;C:\bea103\wlportal_10.3\info
         -mgmt\lib\system;C:\bea103\wlportal_10.3\analytics\lib\system;C:\bea103\wlportal_10.3\apps\lib\system;C:\bea103\wlportal_10.3\info
         -mgmt\deprecated\lib\system;C:\bea103\wlportal_10.3\content
         -mgmt\lib\system
         -Dweblogic.alternateTypesDirectory=C:\bea103\wlportal_10.3\portal\lib\security
         -Dweblogic.Name=AdminServer
         -Djava.security.policy=C:\bea103\WLSERV~1.3\server\lib\weblogic.policy weblogic.Server
    FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
    ERROR: transport error 202: bind failed: Address already in use
    ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
    JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:690]
    Stopping PointBase server...
    PointBase server stopped.
    \Windows was unexpected at this time.
    So I'm stuck, can any one point me to some documentation or anything at all to get me moving forward on this?
    Thanks
    John

    Hi
    Did you change this 8453 to someother value for one of the domains. This looks like a Pointbase DB Debug Port. First change main pointbase db port and then change this debug port value also in setDomainEnv.cmd file.
    HTH
    Ravi Jegga

  • Is it possible to output to div monitor and s-video at the same time?

    I'm editing video and want to see the broadcast results on the fly (ie monitor and tv side by side, same image onscreen). Is it possible to output to div monitor and s-video at the same time? Maybe thru a splitter cable. I'm concerned about resolution issues.

    This is not possible with a mini.

  • I am having trouble with my iPad, i can start it, but the iPad does not work. i tried to use the power and home button at the same time, the apple logo appears, but the iPad does not work. What am I suppose to do?

    I am having trouble with my iPad, i can start it, but the iPad does not work. i tried to use the power and home button at the same time, the apple logo appears, but the iPad does not work. What am I suppose to do?

    After the Apple logo appears, what happens then? Can you hear any sounds or if you tap on the screen, does it seem like apps can open or are you just seeing a black screen? You might have a hardware problem, but you can try restoring the software and see what happens.
    Read this in its entirety before you do anything. Make sure you read the sections at the end about using recovery mode.
    iTunes: Restoring iOS software - Support - Apple

  • My iphone 4 locked up for several hours. i then tried to reset by holding down the home button and power button at the same time for 10 seconds and then the home button for 10 seconds. it is now completely black. what do i do? couldnt restore it in iTunes

    My iphone 4 locked up for several hours. i then tried to reset by holding down the home button and power button at the same time for 10 seconds and then the home button for 10 seconds. it is now completely black. what do i do? couldnt restore it in iTunes. Has anyone had this problem? Help!

    Same thing happened to me today. I wasn't even using the phone for the past 6 hours and suddenly I can't connect to the internet, none of my internet apps would work - nothing. I tried to call AT&T from the iphone and it locked up - couldn't turn it off, change to the home screen - nada - brick.
    Did the Home/Power button thing and that worked but this I've only had this phone for about 4 weeks and it's locked up more times than my 3GS did the whole two years I had it! Ridiculous

Maybe you are looking for

  • Po Migo Miro tables

    Dear Gurus Pls tell me what are the tables that are effected ( data flow to which tables) during the creation of purchase order, goods recpt and invoice verification thanks in advance Regards John

  • Conflict between oracle 8 and oracle 11

    Hi, I'm having a problem installing oracle 8 and oracle 11 homes at the same time. It looks like the system can only recognize one of the homes. I have 2 different applications running in the same computer. One of them uses oracle 11 and the other or

  • Problem to measure 0% and 100% duty cycle of a PWM.

    Hi, I am using counters of USB-6341 to measure duty cycle of PWM just by following the example 'Meas Duty Cycle-Buffered-Finite.vi'. It works almost all the time. However, when the duty cycle of a input pwm is 0 or 100%, the DAQ can't read anything,

  • CJS-00084  SQL Statement or Script failed. Error Message: Executable

    Hello Hello I am facing one problem at the time of installing 4.7 IDES can you please guide me on that. Do I need to reinstall system ageing or it can be sort it out in this stage. ERROR AT THE TIME OF INSTALLING SAP 4.7 IDES ARE 1. CJS-00084  SQL St

  • Connect oracle db server from differenet machine

    Hello expert, here is my simple scenario: computer1 --- oracle 9i database server computer2 --- perl script I want to user perl (on computer2) connect oracle database(on computer1), how can I implement this? Thanks a lot, Grace