Problem to migrate a non-global zone to a different machine.

Hi, recently, I had try to migrate a non-global zone to a different machine but it’s doesn’t work.
1. First, this is the structure of my machine with my non-global zone:
host1# uname -a
SunOS testsolaris 5.11 snv_101b i86pc i386 i86pc
host1# zfs list
NAME USED AVAIL REFER MOUNTPOINT
big-zone 1.71G 1.64G 20K /big-zone
big-zone/export 1.71G 1.64G 22K /big-zone/export
big-zone/export/big-zone 1.67G 1.64G 21K /big-zone/export/big-zon e
big-zone/export/big-zone/ROOT 1.67G 1.64G 18K legacy
big-zone/export/big-zone/ROOT/zbe 1.67G 1.64G 1.66G legacy
big-zone/export/zonetest 41.8M 1.64G 21K /big-zone/export/zonetes t
big-zone/export/zonetest/ROOT 41.8M 1.64G 18K legacy
big-zone/export/zonetest/ROOT/zbe 41.8M 1.64G 1.66G /big-zone/export/zonetes t/root
rpool 8.35G 7.28G 72K /rpool
rpool/ROOT 6.86G 7.28G 18K legacy
rpool/ROOT/opensolaris 6.86G 7.28G 6.73G /
rpool/dump 575M 7.28G 575M -
rpool/export 375M 7.28G 21K /export
rpool/export/home 18K 7.28G 18K /export/home
rpool/export/small-zone 375M 7.28G 21K /export/small-zone
rpool/export/small-zone/ROOT 375M 7.28G 18K legacy
rpool/export/small-zone/ROOT/zbe 375M 7.28G 375M legacy
rpool/swap 575M 7.78G 56.8M -
2. In second, I had detach my non-global zone “zonetest” whit this commands :
host1# zoneadm –z zonetest halt
host1# zoneadm –z zonetest detach
3. In third, I had move my zonepath to my new host.
host1# cd /big-zone/export
host1# tar cf zonetest.tar zonetest
host1# sftp jay@new-host
host1# put zonetest.tar
Uploading ….
host1# quit
4. Unpack my .tar file
host2# cd /big-zone/export
host2# tar xf zonetest.tar
So, after this, I think that my zonepath is transfert to my new host.
This is the structure of my new host :
jay@alien:~$ uname -a
SunOS alien 5.11 snv_101b i86pc i386 i86pc Solaris
jay@alien:~$ zfs list
NAME USED AVAIL REFER MOUNTPOINT
rpool 18.3G 73.3G 72K /rpool
rpool/ROOT 2.98G 73.3G 18K legacy
rpool/ROOT/opensolaris 2.98G 73.3G 2.85G /
rpool/dump 1023M 73.3G 1023M -
rpool/export 13.3G 73.3G 19K /export
rpool/export/home 13.3G 73.3G 19K /export/home
rpool/export/home/jay 13.3G 73.3G 13.3G /export/home/jay
rpool/swap 1023M 73.9G 321M -
zdata 10.7G 80.8G 9.65G /zdata
zdata/zones 1.08G 80.8G 18K /zdata/zones
zdata/zones/zonetest 1.08G 80.8G 1.08G /big-zone/export/
*I have a mountpoint to /big-zone/export
5. I had try to configure my zone on my new host and I receive and error message:
host2# zonecfg -z zonetest
zonetest: No such zone configured
Use 'create' to begin configuring a new zone.
zonecfg:zonetest> create -a /big-zone/export/zonetest
invalid path to detached zone
zonecfg:zonetest>

And my new big-zone (on the second host) show this in the /big-zone/export/zonetest folder :
jay@alien:/zdata/zones# zfs list
NAME USED AVAIL REFER MOUNTPOINT
rpool 23.5G 68.0G 72K /rpool
rpool/ROOT 6.31G 68.0G 18K legacy
rpool/ROOT/opensolaris 6.31G 68.0G 6.18G /
rpool/dump 1023M 68.0G 1023M -
rpool/export 15.2G 68.0G 19K /export
rpool/export/home 15.2G 68.0G 19K /export/home
rpool/export/home/jay 15.2G 68.0G 15.2G /export/home/jay
rpool/swap 1023M 68.6G 361M -
zdata 11.6G 79.9G 10.7G /zdata
zdata/zones 921M 79.9G 18K /zdata/zones
zdata/zones/web 921M 79.9G 21K /zdata/zones/web
zdata/zones/web/ROOT 921M 79.9G 18K legacy
zdata/zones/web/ROOT/zbe 921M 79.9G 921M legacy
zdata/zones/zonetest             54K  79.9G    18K  /big-zone/export/zonetest
zdata/zones/zonetest/ROOT 36K 79.9G 18K legacy
zdata/zones/zonetest/ROOT/zbe 18K 79.9G 18K legacy
jay@alien:/zdata/zones/zonetest# pwd
/zdata/zones/zonetest
jay@alien:/zdata/zones/zonetest# ls -ls
total 6
3 drwxr-xr-x 2 root sys 2 Feb 8 2009 dev
3 drwxr-xr-x 16 root root 19 Feb 8 2009 root
jay@alien:/zdata/zones/zonetest# cd root
jay@alien:/zdata/zones/zonetest/root# ls -ls
total 52902
1 lrwxrwxrwx 1 root root 9 Feb 1 20:29 bin -> ./usr/bin
3 drwxr-xr-x 13 root sys 15 Feb 8 2009 dev
11 drwxr-xr-x 55 root sys 168 Feb 8 2009 etc
3 dr-xr-xr-x 2 root root 2 Jan 22 16:26 home
15 drwxr-xr-x 9 root bin 241 Feb 4 2009 lib
3 drwxr-xr-x 2 root sys 2 Jan 22 16:23 mnt
3 dr-xr-xr-x 2 root root 2 Jan 22 16:26 net
3 drwxr-xr-x 4 root sys 4 Jan 24 15:26 opt
3 dr-xr-xr-x 2 root root 2 Jan 22 16:23 proc
3 drwx------ 3 root root 7 Feb 6 2009 root
5 drwxr-xr-x 2 root sys 47 Jan 22 16:24 sbin
3 drwxr-xr-x 4 root root 4 Jan 22 16:23 system
3 drwxrwxrwt 2 root sys 2 Feb 8 2009 tmp
5 drwxr-xr-x 30 root sys 42 Feb 6 2009 usr
3 drwxr-xr-x 32 root sys 32 Feb 6 2009 var
52835 -rw-r--r-- 1 root root 42882560 Jan 22 16:35 webmin-1.441.pkg
jay@alien:/zdata/zones/zonetest/root#
I think my problem is there ...
jay@alien:/big-zone/export/zonetest# pwd
/big-zone/export/zonetest
jay@alien:/big-zone/export/zonetest# ls -ls
total 8
2 ---------- 1 root root 114 Dec 31 1969 @LongLink
3 drwxr-xr-x 2 root root 2 Feb 1 21:10 root
3 drwx------ 4 root root 4 Feb 1 21:10 zonetest
jay@alien:/big-zone/export/zonetest# cd zonetest/
jay@alien:/big-zone/export/zonetest/zonetest# ls -ls
total 6
3 drwxr-xr-x 2 root sys 2 Feb 8 2009 dev
3 drwxr-xr-x 4 root root 5 Feb 1 21:10 root
jay@alien:/big-zone/export/zonetest/zonetest# cd root
jay@alien:/big-zone/export/zonetest/zonetest/root# ls -ls
total 7
1 lrwxrwxrwx 1 root root 9 Feb 1 21:10 bin -> ./usr/bin
3 drwxr-xr-x 4 root root 4 Jan 22 16:23 system
3 drwxr-xr-x 23 root sys 28 Feb 1 21:11 usr
I think I have a problem with my zfs mountpoint but I don't how to resolve this.
Edited by: jaymachine on Feb 26, 2009 6:16 PM

Similar Messages

  • PHP in Solaris 10 and Non-Global Zones: Problem of performance?

    Hi friends
    We are feeling a poor performance with applications developed with PHP in Solaris 10, with non-global and global zones, while Intel platform (Xeon and Pentium), performance is very good. Difference between both platforms is about 200% aprox, one second in Intel to 9, 12 or 20 seconds in Solaris depending of model.
    Our tests were developed in:
    1. SF T2000 server Solaris 10 global zone
    2. SF T2000 server Solaris 10 non-global zone
    3. SF280R server Solaris 10 non-global zone
    4. V240 server with 1 GB memory, 1*US III-i 1.0 GHz and Solaris 9 (really this version for test and comparisons)
    5. V240 server with 8GB memory, 2*US III-i 1.5Ghz and Solaris 9 (really this version for test and comparisons too)
    Intel platforms were:
    1. Intel Pentium 4 2GHz 2GB memory, Linux Fedora and PHP 4.4.4
    2. Intel Xeon 2 core, 2.33GHz 2GB memory, Linux Fedora and PHP 4.4.3
    Versions of products are:
    1. Solaris 9 or Solaris 10
    2. PHP 4.4.7 downloaded from http://www.php.net/downloads.php
    3. Apache 2.0.59
    4. MySQL 4.1.15-log
    Our php compilation and installation were:
    ./configure --prefix=/usr/local/php-4.4.7 \
    --with-pear \
    --with-openssl=/usr/local/ssl \
    --with-gettext \
    --with-ldap=/usr/local \
    --with-iconv \
    --enable-ftp \
    --with-dom \
    --with-mime-magic \
    --enable-mbstring \
    --with-zlib \
    --enable-track-vars \
    --enable-sigchild \
    --disable-ctype \
    --disable-overload \
    --disable-tokenizer \
    --disable-posix \
    --with-gd \
    --with-apxs2=/usr/local/apache2.0.53/bin/apxs \
    --with-mysql  \
    --with-pgsql \
    --with-oci8=/oracle/product/9.2.0 \
    --with-oracle=/oracle/product/9.2.0  \
    --with-png-dir=/usr/local \
    --with-zlib-dir=/usr/local \
    --with-freetype-dir=/usr/local \
    --with-jpeg-dir=/usr/local
    make
    make install
    Questions:
    Is there any problem of PHP with SunFire T2000 servers or 64-bits platforms?
    Is there any flag of PHP would be use to compilarion PHP in 64-bits or multithread?
    I wait for any comments or suggestions about our problem with PHP compilation and performance in Solaris 10. Thanks a lot.
    Sergio.

    I presume you compiled php on the Sun server, was this done using gcc or the Sun One C compiler.
    If the latter then you can also use the flag: --enable-nonportable-atomics when you run configure                                                                                                                                                                                                                                                                                                                                                                                                   

  • Problem with exporting devices to non-global zone

    Hi,
    I've problem with exporting devices to my solaris zones (i try do add support to mount /dev/lofi/* in my non-global zone).
    A create cfg for my zone.
    Here it is:
    $ zonecfg -z sapdev info
    zonename: sapdev
    zonepath: /export/home/zones/sapdev
    brand: native
    autoboot: true
    bootargs:
    pool:
    limitpriv: default,sys_time
    scheduling-class:
    ip-type: shared
    fs:
    dir: /sap
    special: /dev/dsk/c1t44d0s0
    raw: /dev/rdsk/c1t44d0s0
    type: ufs
    options: []
    net:
    address: 194.29.128.45
    physical: ce0
    device
    match: /dev/lofi/1
    device
    match: /dev/rlofi/1
    device
    match: /dev/lofi/2
    device
    match: /dev/rlofi/2
    attr:
    name: comment
    type: string
    value: "This is SAP developement zone"
    global# lofiadm
    Block Device File
    /dev/lofi/1 /root/SAP_DB2_9_LUW.iso
    /dev/lofi/2 /usr/tmp/fsfile
    I reboot the non-global zone, even reboot global-zone, and after that, in sapdev zone, there is no /dev/*lofi/* files.
    What i do wrong? Maybe I reduce my sol 10 u4 sparc instalation too much.
    Can anybody help me?
    Thanks for help,
    Marek

    I experienced the same problem on my system Sol 10 08/07.
    Normally, when the zone enters the READY state during boot, it's zoneadmd will run devfsadm -z <zone>. In my understanding this is to create the necessary device files in ZONEPATH/dev.
    This worked well until recently. Now only the directories are still created.
    It seems as if devfsadm -z is broken. Somebody should issue a call to sun.
    As a workaround you can easily copy the device files into the zone. It is important not to copy the symbolic link but the target.
    # cp /dev/lofi/1 ZONEPATH/dev/lofi
    Hope this helps,
    Konstantin Gremliza

  • Non-global zone installation problem

    I have created a non-global zone sqa45-zone as follows:
    zonecfg -z sqa45-zone
    zonecfg:sqa45-zone> info
    zonepath: /export/home/zones/sqa45-zone
    autoboot: false
    pool:
    inherit-pkg-dir:
    dir: /lib
    inherit-pkg-dir:
    dir: /platform
    inherit-pkg-dir:
    dir: /sbin
    inherit-pkg-dir:
    dir: /usr
    net:
    address: 10.4.105.105
    physical: bge0
    zonecfg:sqa45-zone> exit
    When I try to install the zone, this is the error message I see.
    sqa45# zoneadm -z sqa45-zone install
    could not verify net address=10.4.105.105 physical=bge0: No such device or address
    zoneadm: zone sqa45-zone failed to verify
    sqa45#
    I'm not sure how I can correct this. Any help is appreciated.
    Thanks.

    You havent specified a netmask.
    That might be causing it.
    You can specifiy it as address=10.4.105.105/24 or by a separate netmask entry.

  • LDOMs or Non Global Zones

    I am thinking migrating many machines to our yet unused T5-2 boxes.  One of the consultants suggested, using LDOMS. However, there will be at least 4 different Oracle DBs  running in the boxes.  I am not sure which is the best way to go?  Also even after reading the documents, I could not figure out whether you can have LDOMS (VM for Sparc) and Non-Global Zones side by side over Solaris 11.2?  Also, being a 16 core machine, using LDOM, I would lose 2 core I was told.  Views would be helpful for my understanding. 
    Regards
    SC-BBK

    Hello
    I suggest you to read this doc too, there are plenty of way to do a setup with ldoms, and you can achieve a really good redundancy for net and vdisk.
    http://www.oracle.com/technetwork/server-storage/vm/ovmsparc-best-practices-2334546.pdf
    Primary domain can run sol11.2 and guest sol10 without any problem, but the sol10 release has to be supported on that T5.
    You can have in sol11.2 NGZ in solaris 10 too.
    It is more than VMWare... into any guest ldom running sol11.2, you can have non global zones, for sol10, sol11.2 and kz-zones.  You can assign HW to each domain if you want dynameically, cpu, mem, disks .. all is explained in the admin manual  http://docs.oracle.com/cd/E38405_01/html/E38406/index.html
    Regards
    Eze

  • How to know global zone in case non global zone is hung

    ....I have nongloabazone1,nongloabazone1,nongloabazone2,nongloabazone3...
    i am working on nongloabazone1 ..
    suppose i am giving remote support ...
    if my nongloabazone1 is hung ..i need to know the global zone on which this nongloabazone1 is installed and reboot from there ...if my nongloabazone1 is hung i cannot apply #arp -a and check it out by trial and error method and know the global zone....
    in this case how can i reboot the nongloabazone1 .....i have the same question in case of Ldoms also..............
    Thanks in Advance.......

    Hi.
    It's not clear what means "non global zone is hung".
    In case it realy hangs you can't do anythins in this zone.
    1) In case you have access to global zone. You can get list all zones running on this host:
    zoneadm list -cv
    For reboot local zone from global zone just need: zoneadm -z <zone_name> reboot
    2) Zones not support live migration. So after zone started it can not change global zone.
    Create script that put global zone name in file. When need - just read content of this file.
    This file can be created from global zone when start (or create/move) local zone.
    In case zone migration is not quickly operation, just create file (or database) for list what zone started on which host.
    For LDOM it look wery same.
    Regards.

  • Unable to add a device (e.g. /dev/cua0) to a non-global zone

    Hi,
    I've installed solaris 10u4 on a x86 machine with the latest patches, installed with the smpatch utility
    The history:
    I've installed solaris 10u3 without any patches, a quite minimum installation; I 've created a non-global zone, added a zfs dataset, added networking, add one serial device (/dev/cua0); installed hylafax from blastwave in the created zone using the attached modem on /dev/cua0, all was working fine, except some sendmail issues. Due to issues with samba, which I needed on this machine, I've tried to update the machine, after ending up in dependency hell, due the minimum installation, I gave up. I did a fresh install of solaris 10u4 instead also with latest patches applied with the smpatch utility, the I've created a new zone and want to add the device /dev/cua0 like in the s10u3 installation, but the device doesn't appear in the non-global zone, so I've installed hylafax in the global-zone temporary.
    The question, any ideas or workarrounds to bring the async device into a non-global zone again ?
    I'm not a newbie in nix like systems (several years with BSD and GNU/Linux), but for solaris I would classify myself as a newbie ;-)
    thanks in advance.

    Hmm. If that didn't work, then it's possible you're running into a different problem.
    But I checked again and this is the one I was thinking of. Toward the bottom, some patches are referenced. I suppose they won't hurt, but I'm worried you're seeing something related to the 'cua' device rather than the general problem of device creation.
    http://www.opensolaris.org/jive/thread.jspa?messageID=171187
    Darren

  • Non-global zone in "shutting_down" state.. Hung in this state

    Hi.. My server is running in Sol10. It has got two non-global zones hosted in it in which the database is running.
    There was some complain from the database team that they were not able to login to the server. When I checked, it the status of the local zones were fine. But when tried to "# zlogin" to them, it got hung. So i tried to " # zlogin -S <zone_name>" and i was able to login in the failsafe mode but not able to execute any command in it. Any command from "uptime", "zfs list", gets hung and i had to forcefully logout.
    So I tried to halt the non-global zones first and then boot it. But here, it got stuck in "shutting_down" state.
    When tried to kill the processes of the non-global zones using "kill -9", it failed to kill the processes.
    so I rebooted the global zone which fixed the issue. But then, 10 days later, the same issue came up.
    I followed the same steps to fix the issue but i'm afraid this issue might come up again since i think rebooting the global zone server is a temporary fix.
    I logged a call with Oracle Support for this, but the server looks fine from the explorer output that was provided.
    Has anyone faced this same problem? What can i do to fix this issue permanantly?

    If you encounter the issue again in future, please get a system crash dump by panicing the global zone. This will allow us (support) to review the crash dump and understand why the zone failed to shut down. It will have been waiting on a resource and without the dump there's simply no way to know what or why.
    IIRC we recently (with the past month) did a putback of a bug (which I can't find the ID of right now) whereby if a zone doesn't hang on the way down we'll fork a new instance of the zone and leave the old refs in their hung state. So it's worth ensuring that you're running the latest Patchset.

  • Non-Global Zone Routing

    I have a V20z running a global zone on an IANA private network of 172.30.0.x and nic bge0
    I also have a non-global zone on a public IP of 207.246.20.169 and nic bge1.
    I am unable to ping from one zone to the next via a gateway. Normally the global zone would use a standard gateway for that network and my public network would also use a standard gateway for that network.
    What appears to be happening is that despite what is in my /etc/defaultrouter the zone itself is the gateway.
    For example, to ping something from either zone which would require the gateway results in:
    ICMP Host Unreachable from gateway 'zone name' (zone ip address)
    What I want to happen is that the global zone honors the gateway that is normally used in this network and the non-global zone uses/honors the gateway that is normally used in that network.
    It doesn't seem to matter if I have the normal internal gateway in my /etc/defaultrouter or if I have the normal public gateway in /etc/defaultrouter or if I have both in /etc/defaultrouter (all in the global zone of course).
    Do I need to use routed to achieve this? Am I missing something here?

    I hammered the problem out by adding a static route in the global zone:
    route add 172.30.0.0 207.246.20.161
    Where 207.246.20.161 is my gateway on the public side.
    I slapped this into an /etc/init.d script in the global zone and ran it from /etc/rc2.d like the article below suggests:
    http://www.sun.com/bigadmin/content/submitted/persistent_routing.html

  • Non-global zone networking

    I've created a non-global zone with a pair of anet devices. I plan to do IPMP inside the non-global zone to manage interface redundancy. The anet config is rather simple -- I have a net0 and net1 whose lower-link's are net2 and net3 respectively.
    Inside the zone, it looks like everything is ready to go. My two VNICs are up.
    zone# dladm show-link
    LINK CLASS MTU STATE OVER
    net0 vnic 1500 up ?
    net1 vnic 1500 up ?
    So I try to plumb them (if I can still use that term).
    zone# ipadm create-ip net0
    zone# ipadm create-ip net1
    zone# ipadm show-if
    IFNAME CLASS STATE ACTIVE OVER
    lo0 loopback ok yes --
    net0 ip down no --
    net1 ip down no --
    That's strange -- why are they not up?
    zone# ifconfig net0 up; ifconfig net1 up
    zone# ipadm show-if
    IFNAME CLASS STATE ACTIVE OVER
    lo0 loopback ok yes --
    net0 ip ok yes --
    net1 ip ok yes --
    Aaah. Much better. Now I can get on with my life.
    # ipadm create-ipmp -i net0 -i net1 ipmp0
    # ipadm create-addr -T static -a 192.168.1.104/24 ipmp0/v4
    So my quesion is why did I have to resort to running an ifconfig up on these interfaces? ifconfig is dead to me -- or so I'd like to think. :)
    What is the "right" way to deal with this problem?

    Figured this out.
    The issue was that I had just done a zlogin to the zone after it was built (which was 3 weeks ago). I had completely forgotten that I had not yet completed the system configuration so the svc:/milestone/config:default service was offline, along with it's many dependancies.
    Basically I manually configured the network information before I had told the system config that I was going to do so.
    Strange behaviour -- but that's what happens when you don't follow order of operation.

  • Add device cdrom non global zone

    Hi All ,
    how to add device cdrom to non global zone ?
    many thanks

    Hi David,
    Does your judgement that "you can definitely use a lofs mount to make /usr/local available inside the four zones" hold when /usr/local is an NFS mount in the global zone? James indicated that his /usr/local was an NFS mount, but I don't know if you targeted that specifically, or if you were just responding to the general case.
    I have not had any success in performing lofs mounts of NFS mounts and making them visible in a local zone. I don't have any problems making a lofs mount of a NFS mount work in the global zone, I just can't NFS mount anything in the global zone and make it accessible in a local zone.
    See http://www.opensolaris.org/jive/thread.jspa?threadID=2181&tstart=0 for a full description of what I tried and what happened. The short result is that when I try, accessing that directory in the local zone gives "I/O error" for file operations and "Not owner" for df.
    Thanks,
    Dab

  • Oracle 11.2 in Solaris 10 non-global zone?

    When I try to install in a non-global zone in Solaris 10, the installer system check fails; I think this problem is well-known, but I can't find the guidance notes any more. The generic documentation isn't much help, I'm afraid. This is what I get from the system check, all round:
    Expected Value: n/a
    Actual Value: n/a
    Not long ago I had a link to some notes that addressed thisproblem specifically, but I can't find them any more, unfortunately - does anybody here know?

    Check Oracle® Database Installation Guide 10g Release 2 (10.2) for Solaris Operating System.

  • After installing 137137-09 patch OK in global zone, bad in non global zone

    Hi all,
    scratching my head with this one.
    Installed 137137-09 fine on Sun Fire V210. Machine has one non global zone running a proxy server (nothing very exciting there!). non global zone has a local filesystem attached, but don't think this is the issue (on my test V210 I created the same sort of filesystem and was unable to replicate the problem :( ).
    So 137137-09 is fine in the global zone (I had the non global zone halted when patch installed) it is also installed in the non global zone (ie, when zone boots it says it's at rev 137137-09 via uname) in the patch log in the non global zone I get this:
    PKG=SUNWust2.v
    Original package not installed.
    pkgadd: ERROR: ERROR: unable to get zone brand: zonecfg_get_brand: No such zone configured
    This appears to be an attempt to install the same architecture and
    version of a package which is already installed. This installation
    will attempt to overwrite this package.
    /usr/local/zones/cotchin/lu/dev/.SUNW_patches_1000109009-1847556-000000d3e42faa84/137137-09/FJSVcpcu/install/checkinstall: /usr/local/zones/cotchin/lu/dev/.SUNW_patches_1000109009-1847556-000000d3e42faa84/137137-09/FJSVcpcu/install/checkinstall: cannot open
    pkgadd: ERROR: checkinstall script did not complete successfully
    Dryrun complete.
    No changes were made to the system.
    I'm not sure if the branding error is causing the checkinstall postpatch script error or if they are not related. There doesn't seem to be any obvious permissions problems that I can find. I have checked that all the pkg and patch patches are up to date on the system. Searching on the brand error gives me a link to a problem with 127127-11, but that was installed on the system before the local zone was created and all the other seemingly appropriate patches (eg: 119254) are all up to date or at a higher revision than recommended.
    I see the same problem on a M5000 which has two non global zones on it.
    Both machines had the Solaris 10 50/08 update bundle applied when it came out,a nd have had recommended patch sets applied at regular intervals since.
    This issue only came to light when trying the latest bundles with 138888-01/02 in it, and those fail to install on the global zones because the non global zone install dies claiming 137137-09 is not installed (which is plainly wrong).
    I've tried to recreate this on a test server but unfortunately everything works as it should, even though the test server has a similar history in terms of patches and original setup to the others.
    I'm planning to try to detatch the non global zone and try an attach -u to see if it will update the patches properly, but I'm not holding out much hope on that one (I need to wait for a mainteiance window when I can take the zone down in a couple of days).
    Any ideas?

    Well, I am following up to my own post it seems I have determined what is causing the problem, or at least situations where the problem can be reproduced which I have been able to do on my test system.
    It seems that if the zone container's zonepath is in /usr (eg: /usr/zones, /usr/local/zones, or some other path under /usr) the patchadd of 137137-09 will fail with the log similar to posted above, and this will stop further kernel patches (eg: 138888-02) being added.
    The test system had everything patched to current and searching the web I can't find any other instances of this being an issue, but I have reproduced this problem on my test machine (which worked OK because it's test zones were in a filesystem mounted as /zones). When I used zoneadd -z <zonename> move to a zone in /usr/local and applied 137137-09 the same problem came up.
    Not sure what is causing this issue.. I imagine it might have to do with some sort of confusion with the patch utilities and the read-only loopback filesystems in the sparse root zone but I can't bs sure.
    Maybe someone at sun will see this and figure out what the deal is :)
    When I moved my test zone back to /zones the patch applied perfectly so it's definitely having it in /usr or /usr/local (I tried both locations, even though they are seperate ufs filesystems on my test server).
    Oh I am running DiskSuite to mirror filesystems on my V210's which may or may not have anything to do with it.
    Hope this helps someone in the future at least!

  • Always install applications into non-global zones?

    I am planning on taking full advantage of Containers and Zones as I migrate servers and applications to Solaris 10. During this migration process, I believe that I will have a need to initially just run just one application on a server. I fear that if I do this in the global zone I will lose flexibility down the road for future projects and workloads. So, should I consider always installing applications in a non-global zone and never install applications in the global zone? This would keep the global zone as the controller of the non-global zones and ensure that I can always add more non-global zones later without having to worry about what is running in the global zone.
    Are there any thoughts or comments on this topic?

    Yes we've found it's best to run the applications in non-global zones. Here are a few benefits, basically we only put an application in the global zone if it requires it (like Oracle RAC). Note non-RAC instances of Oracle will run in a non-global zone just fine.
    Reasons to put applications in non-global zones
    o Increased security (self contained environment)
    o Increased flexibility for provisioning resources (CPU, memory, etc) when/if we decide to run multiple applications on the same hardware
    o Increased flexibility in starting up temporary environments to debug issues in parallel to the primary environment (i.e. in another non-global zone on the same server)
    o Works well with Sun Cluster (i.e. we cluster the non-global zones so that they can run across several hosts)
    o Improved trouble shooting and performance diagnosis as the applications are isolated to a non-global zone
    o Simplified environment for the application admins as the environment can be fine tuned for their needs (i.e. only let them see what they need)
    o Disaster recovery is much faster for a non-global zone

  • Jdk 1.6 + solaris 10 (global + non global zones)

    How to execute or fetch jdk1.6 in global zone when it is installed in the non global zone of solaris 10?
    kindly explain in step-by-step procedure
    thanks,
    Samojit

    I have a similar problem with pkgadd. When installing an auditing application we get the following error:
    “pkagadd: ERROR: unable to make temporary directory </var/tmp//installtEaBs/install9_aG1u>
    No changes were made to the system.”
    This is a package that is being installed remotely using an automated process and the package does install using the pkgadd command on the server. The automation has produced the same or a similar error on several servers while producing no errors and successfully installing on others. We cannot duplicate the error across the board. The packge has been reviewed and has been found to have no errors, the automation process has been evaluated and has done successful jobs on other Solaris 10 servers since failing on the ones with this error. The exact same automated job produces successful and unsuccessful jobs on various servers.
    There are 2 patch levels that we have identified 118833-26 and 118833-30. Both the 26 and 30 versions have had successful and unsuccessful installations of the SE agent. There are various subnets involved and all of them have had successful and unsuccessful installations of the SE agent.
    If anyone out there has run into this problem before please help me out. This installation is automated on many Solaris 10 servers, and is successful on about 2 out of 3. It is of course the failed jobs that I have to focus on, until we can get it resolved.

Maybe you are looking for

  • Derby db named query causes parse error when using derby db MONTH function

    Hi all! I'm trying to create an application using the persistance api and beans binding. I have created my database and entity classes. My problem is creating a named query that uses some of the functionality from the derby database (which is embedde

  • IPad - Digital Magazines, converting PDFs to RGB.

    Hello everybody, I happen to be setting up a workflow for some printed magazines in italy, that launched digital editions of the magazines online (Classic browsers but also iPad app). Basically they need their prepress pdfs to be published on an onli

  • IPhoto 6 ATE my photos!

    I am on the verge of tears... My iPhoto was all messed up, with two libraries that were somehow created back when I had by G4 (maybe due to an update?) and so I was trying to make a new (third) library that would hold all my photos by using option+la

  • Excel running within IBM FSR Disables Smartview addin

    Is anyone using smartview within IBM Cognos FSR? We are experiencing frequent errors when Excel Disables the HFM addin. It does nto happen when running excel outside of FSR.

  • Can LR 5.2 be configured to save edits to disk?

    I would really like to be able to save edited photos to disk, i.e., overwrite the original.  I know this is a breach of some universal law, but I would LOVE to be able to make changes in Develop mode in LR, then overwrite the original file on disk.