Problem when applying new renderer

Hi, I am new to JSF, just I am trying to change the rederer for the JSF components, so I am
trying to add Richfaces renderers. I don't know whether I am applying correct or not but thing
I am sure some where I am doing mistake thats why I came here to introduce my problem.
The richfaces renderer class is not able to applying for JSF selectonemenu. So plz help me
<render-kit>
<renderer>
<component-family>javax.faces.component.html.HtmlSelectOneMenu</component-family>
<renderer-type>selectOneMenu</renderer-type>
<renderer-class>org.richfaces.renderkit.html.ComboBoxRenderer</renderer-class>
</renderer>
</render-kit>
<render-kit>
<renderer>
<component-family>javax.faces.component.UISelectOne</component-family>
<renderer-type>selectOneMenu</renderer-type>
<renderer-class>org.richfaces.renderkit.html.ComboBoxRenderer</renderer-class>
</renderer>
</render-kit>

Why are you doing this? Why not just use the components provided by the RichFaces component set that are already associated with those Renderers?

Similar Messages

  • Strange problem when opening new message.

    I have a rather annoying problem when I open a newly received SMS from a particular contact (lets call him Bill).
    When I open the new message from Bill, either by swiping to unlock or touching a banner message at the top of the screen. Instead to being shown the message itself, I will automatically be taken to the 'start new message' screen with none of our message history (i.e. as if I am starting to type an entirely new message to Bill)
    I can then cancel this and return to myself and Bill's normal message stream.
    Any ideas how to get around this annoyance? Thank you.

    I think you have 2 ways to go here. Figure out what html is from wherever weblogic gets it, meaning you have to delve into the docs, snoop
    around in directories and find what it must be sending (This is going to be unavoidable if you are going to change what weblogic is doing.
    Sooner or later you have to try to figure out where it gets this stuff from)
    or
    you can experimentally snoop on your url with a tool like wget or curl. These are fundamental web tools.
    The latter is always a useful thing to be able to do. (you need to formulate a query to get the content-type).
    Whoever managed to get weblogic to serve any files in the first place probably can figure this out.

  • VIS fails when apply new patch

    Hi all
    I have problem in accessing VIS after applying new patch to it.
    I use 11.5.8 VIS and apply AD mini-pack H (2673262), FND mini-pack G (2655277) , OA Framework 5.7H patch (2771817) and OA Framework 5.7H Rollup Patch V4 and make proper post install step.
    But i still met problems, first I can not access VIS ...after use auto config, i can get in...but I can ot open the form properly...it always tell me form connection fail...error message is like xxx:9002 fail...java.connection.exceptiom....
    At the same time, I notice the web page change a lot after applying patches above...
    Any idea about my problems?
    Regards

    Hi,
    Please go through each step of pre-req and post-req of patch OA Framework 5.7H patch (2771817).
    You can log-in and test your web application using http://mars.gotransit.com:8000/OA_HTML/jsp/fnd/aoljtest.jsp
    Thanks,
    Paresh Vakil

  • Problem when apply SAP Bundle Patch for 10.2.0.5

    Hi,
    We are trying to apply SAP Bundle Patch (SBP) SAP_102052_201102_SOL64.zip and SAP_102052_201103_SOL64.zip using MOPatch utility. Both MOPatch and OPatch utility have been updated with the latest download from SAP. When applying patch for SAP_102052_201102, most patches went through except for one patch that requires OPatch to be version 10.2.0.5.0. The OPatch version downloaded from SAP is 10.2.0.4.9. Even the OPatch delievered together in the SAP_102052_201102_SOL64.zip file is 10.2.0.4.9.
    Below are extract of the opatch log file for this patch:
    INFO:ApplySession applying interim patch '10248542' to OH '/oracle/DEV/102_64'
    INFO:Starting to apply patch to local system at Wed Mar 23 10:49:25 SGT 2011
    SEVERE:OUI-67073:ApplySession failed: ApplySession failed to prepare the system.
    Patch 10248542 requires OPatch version 10.2.0.5.0.
    The OPatch version being used (10.2.0.4.9) doesn't meet the minimum version required by the patch(es). Please download latest OPatch from My Oracle Support.
    INFO:System intact, OPatch will not attempt to restore the system
    INFO:Finishing ApplySession at Wed Mar 23 10:49:25 SGT 2011
    INFO:Total time spent waiting for user-input is 0 seconds.  Finish at Wed Mar 23 10:49:25 SGT 2011
    INFO:Stack Description: java.lang.RuntimeException: ApplySession failed to prepare the system.
    Patch 10248542 requires OPatch version 10.2.0.5.0.
    The OPatch version being used (10.2.0.4.9) doesn't meet the minimum version required by the patch(es). Please download latest OPatch from My Oracle Support.
    Help appreciated.
    Regards,
    Lim

    Hi,
    I went to
    http://service.sap.com/oracle-download
    then
    Oracle 10.2.0.5
    then
    OPatch
    The file I can see there is generic for ALL operating systems and the name is:
    OPatch_10205_Generic_v0.zip
    it seems that the version is 10.2.0.5, not  10.2.0.4.9 as you mentioned.
    I have downladed it and look at the README:
    Patch summary:
    README file for OPatch 10.2.0.5.0, the Oracle Interim Patching Tool.
    I'm not installing it, but it seems that the version is not the same as yours.
    Is this the one you have downloaded?
    Have you installed it properly? => may be you are running an older one

  • Having problems when adding new Curency value field + currency field.

    I need to add a new Currency field (CURR, length 15, 2 decimal places) plus the Currency field itself to a view. 
    I'm really struggerling. I have looked at the existing SAP fields in the Component workbench and I have to admit I can not see how a field is linked/related to the currency itself. Is this link established purlely at the disctionary level?.
    Has anyone added their own Z field value  and Z currency field before. I can create both fields and display them, but what I can not work out is how I related them within the component workbench, or is this done from the dictionary?.
    Any help would be greatly appreciated.
    I should have been able to look at an existing SAP example and work out how it's done, but so far I can not see/determine how this is achieved, even though someone has mentioned that it's controlled via the GET_I_field method. Looking at this method I was expecting to see some mention of both the Currency value field and the Currency field. But as I don't see these confusion reigns.
    Jason

    That's correct, but am I right in thinking that you can't actually create the currency key field itself?.
    I am aware that currency value fields can be created which reference a currency key field, but can see nothing that allows me to create a currency key field to be referenced.
    I hope that makes sense.
    Also, I have amended the structure, changing my value fields from Decimal 15,2 to Currency 15,2  and have created a new currency key field in the structure and referenced this from the Currency value field.
    Witin the Component/view/context node I can see this new currency key field, but it appears as STRUCT.fieldlabel whereas my currency value field appears in the context node as EXT.fieldlabel, because it was created in the AET.
    My problem is that when attempting to add the currency key field onto the screen I don't have it to select from within the list of structures/attributes. All the others attributes in the context node seem to be there, except the new currency key field/attribute.
    The attribute has a SET_fieldlabel, GET_fieldlabel, GET_M_Fieldlabel and a GET_I_Fieldlabel, which I believe is all that should be required.
    Does anyone know what my problem could be?.
    Jason

  • Redaction problem - when applied, boxes are created on all other pages

    We are redacting PDFs converted from PowerPoint. When we apply redactions, a block of color the same size and location of each redaction appears on every page. There is no background on the documents. I created redactions of different colors, and those different colors showed up on all pages when the redactions were applied.
    We can find no explanation or fix. A workaround is to make the redaction color white which blends into our document but we want to not have the blocks show up. There is a forum question from 2012 with this question but no answer.

    We are having the same problem as well. It does appear to be document specific and is reproducible. Could someone kindly look into this?

  • JTree selection problem when using custom renderer and editor

    Hello:
    I created a JTree with custom renderer and editor.
    The customization makes JCheckBox to be the component
    responsible for editing and rendering.
    The problem is that when I click on the node with the checkbox
    the JTree selection model does not get updated.
    Without customizations of the editor and renderer the MouseEvent would be fired and BasicTreeUI$MouseHandler.mousePressed() method would call
    the selectPathForEvent() method which would be responsible for updating
    the selection model. At the same time if I attach a mouse listener to the JTree (customized) I see the events when clicking on the nodes. It seems like the MouseEvent gets lost and somehow as a result of which the selection model does not get updated.
    Am I missing something?
    Thanks
    Alexander

    You probably forgot to call super.getTreeCellRendererComponent(...) at the beginning of your getTreeCellRendererComponent(...) method in your custom renderer.
    Or maybe in the getTreeCellEditorComponent(...) of the TreeCellEditor...

  • Problem when open new window...

    Hi,
    I have a flash website and one problem with it.
    When I push on a button, it has to open new window.
    thumb1.onPress = function(){
    getURL("
    http://...............as.html",
    "_blank");
    But I want that the opened window will be no resizable, no
    location, no menubar, no scrollbar, no status, no toolbar, no
    fullscreen. Can actionscript do this?

    Hi, Motiejuss!
    You can use the getURL to call a JS function.
    Just like
    getURL("javascript:window.open('
    http://...as.htm', 'foo', 'width=400
    height=400');");
    But the best is to use ExternalInterface, in Flash 8.
    Bye,
    CaioToOn!

  • Problems when applying patch 142807-02 on clean DSEE 6.3.1

    Hello,
    I just installed DSEE 6.3.1 (patching from 6.0) and I was going to apply the security patch for NSS and SASL (142807-02)
    as mentioned in the releasenotes.
    However when i followed the instructions:
    # cd 142807-02/SunOS_i86pc/delivery/
    # ./Install /opt/SUNWdsee
    I got alot of errors from the cp command inside the install-script:
    ....(alot more)...
    cp: cannot create /opt/SUNWdsee/dsee6/private/lib/libplc4.so: No such file or directory
    cp: cannot create /opt/SUNWdsee/dsee6/private/lib/libjss4.so: No such file or directory
    cp: cannot create /opt/SUNWdsee/dsee6/private/lib/sasl2/libsasl.so: No such file or directory
    ...(alot more)...
    In the end it worked without errors if I manually created the following directories:
    # mkdir /opt/SUNWdsee/dsee6/private
    # mkdir /opt/SUNWdsee/dsee6/private/include
    # mkdir /opt/SUNWdsee/dsee6/private/include/obsolete
    # mkdir /opt/SUNWdsee/dsee6/private/lib
    # mkdir /opt/SUNWdsee/dsee6/private/lib/sasl2
    My server instance seems to start fine after this, but it seems kindof wrong that I need to create
    these directories manually.
    Is there any problem doing this? what is causing this?
    My OS installation is Solaris 10 x86 64-bit (Update 7).
    Regards,
    Tobbe

    142807-02 covers 2 Sun Alerts:
    - 273350: http://sunsolve.sun.com/search/document.do?assetkey=1-66-273350-1 (fixed by NSS 3.12.5)
    - 259148: http://sunsolve.sun.com/search/document.do?assetkey=1-66-259148-1 (fixed by SASL 2.19_20090601)
    You will find patch numbers for native delivery of DSEE in the description of these 2 Sun Alerts.
    Carole

  • Help!!! Problem when uploading new ipod touch software

    Hi, really hoping someone can help!
    I connected my ipod to itunes and it asked me if i wanted to download new software for ipod touch so i did, then when it finished downloading it automatically started updating my ipod but before it finished i got an error message saying something like could not upload new software on ipod. i clicked ok and my ipod disappeared from the display list on itunes
    now my ipod isn't showing in itunes despite being connected via USB and it won't do anything, i just have a screen with a picture of a usb and an arrow pointing to the itunes icon.
    i have absolutely no idea what to do now, please help!

    Try another pc,The latest updades 3.3 did a lot of damage to my ipod simmilar to yours.I connected it to another pc then did a restore then went back to the original pc where my music is,be weary of that update.good luck.

  • Starting problem when using new domain

    Hi all,
    I just start trying wl6.0. My problem described as belows:
    I start the default domain 'myDomain'and that created a new domain,
    say 'testDomain' using the admin console. Then, I stop 'myDomain'
    and start the 'testDomain'. The following error occured, it saying
    that the file 'fileRelam.properties' is not present. Then i try
    copy the file 'fileRelam.properties' from myDomain to testDomain
    but still not work, it said autheication error. Do any one know
    how to solve my problem?
    Thanks.
    <2001/3/8 &#19978;&#21320;10&#26178;13&#20998;53&#31186;> <Emergency>
    <Server> <Unable to initialize the server: 'Fatal initialization
    excep
    tion Throwable: java.lang.IllegalAccessError: weblogic.security.acl.internal.FileRealmException:
    Source file not found: .\config\testDomain\fileRealm.properties
    - with nested exception:
    [java.io.FileNotFoundException: .\config\testDomain\fileRealm.properties
    (The system cannot find the file specified)]
    java.lang.IllegalAccessError: weblogic.security.acl.internal.FileRealmException:
    Source file not found: .\config\testDomain\fileRealm.properties
    - with nested exception:
    [java.io.FileNotFoundException: .\config\testDomain\fileRealm.properties
    (The system cannot find the file specified)]
    at weblogic.security.acl.Realm.getRealm(Realm.java:91)
    at weblogic.security.acl.Realm.getRealm(Realm.java:62)
    at weblogic.security.SecurityService.initializeRealm(SecurityService.java:258)
    at weblogic.security.SecurityService.initialize(SecurityService.java:123)
    at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:343)
    at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:169)
    at weblogic.Server.main(Server.java:35)'>

    Problem solved! Thanks all.

  • Problem when applying a custom stamp, it shows on my document on the screen but when I print it, the stamp is not there.

    I have my pdf open, I created a custom stamp.  Applied the stamp to the document and I see it.  Save my document and then do either a print preview or print it and the stamp is not showing!  This method of applying stamps used to work but something has changed.  I thought it even worked when using Acrobat Standard X but can't be sure.  Really need help as even documents I created previously with stamps applied and I have proof that they printed with the stamp, won't print with the stamp on it.  Thank you.

    You don't even need to use a third party tool.
    Open the JavaScript Console (Control+J)
    Type the text string below in the JavaScript Console and hit Control+Return key.
    this.flattenPages();
    It will flatten all of the annotations and fields within the document to ensure that all the comments and stamps print.

  • Problem when installing new cpu physics VM 3.0.3

    Hello everyone, we have a server VM 3.0.3 in a Fujitsu RX300 S7, have
    installed a new processor, and although apparently all is well from
    the manager can see that it is Server VM fails to boot, and we cannot
    access to the virtual machines.
    Anyone know because this happens?
    Thanks a lot.

    Hello, what is the message when do you start VM?
    The health of the OVM Server is OK?
    Regards,
    David Saes

  • Problem when creating new resource in CMSXDB

    We installed the CMSXDB sample succesfully.
    We can create new users, create new folders; but when adding a documnt (resource) to a folder we get following error.
    For an external document:
    oracle.otnsamples.cmsxdb.exception.CMSAccessException: IOException in FileUploadUitlsjava.io.IOException: java.sql.SQLException: Invalid argument(s) in call
         at oracle.otnsamples.cmsxdb.useraction.FileUploadUtils.(FileUploadUtils.java:89)
         at oracle.otnsamples.cmsxdb.useraction.DataUtils.resource(DataUtils.java:885)
         at NewResource.jspService(_NewResource.java:73)
         at com.orionserver.http.OrionHttpJspPage.service(OrionHttpJspPage.java:56)
    If we try the other option (creation on the fly); we get following error:
    oracle.otnsamples.cmsxdb.exception.CMSAccessException: SQLException in createresource in resource method of DataUtils : java.sql.SQLException: SQLException in getCLOB : java.sql.SQLException: Invalid argument(s) in call
         at oracle.otnsamples.cmsxdb.useraction.DataUtils.resource(DataUtils.java:1109)
         at NewResource.jspService(_NewResource.java:73)
         at com.orionserver.http.OrionHttpJspPage.service(OrionHttpJspPage.java:56)
         at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java:317)
         at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java:465)
         at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java:379) ...
    Do you have any idea what can be the cause for this error?

    Hi Mark,
    The details of the properties that you have to set in Connection.properties file
    List of properties to be altered (Mandatory)
    DBWebURL=http://incq234a.idc.oracle.com:8080
    The HTTP url where the xdb servlet engine is running
    Format : http://<hostname_where_db_is_installed>:8080
    siteRootPath=/tmp/testsite
    The absolute path under which the files will be generated, once a file is sent for externalization and approved by cmsadmin.
    The file will be generated under ConnParams.siteRoot/<resource_path>.<content_type>
    example: /tmp/testsite/cmshome/news/headlines.html
    List of properties to be altered( Optional )
    [ we recommend that the default values be used and these properties not be altered ]
    DataSourceName=jdbc/CmsdbDS
    Name of the datasource, that was entered in J2EE_HOME/config/data-sources.xml
    DBUsername=cmsadmin
    DBPassword=cmsadmin
    [ if any of the below properties are modified, then the corresponding changes have to done in xdbconfig.xml ]
    CMSServletContextRoot=/OTNCMSServlet
    The context root where the OTNCMSServlet can be accessed. It will be appended with the DBWebURL.i.e
    http://localhost:8080/OTNCMSServlet
    Once the servlet is deployed to XDB and the xdbconfig.xml file updated with the servlet entry. The Servlet can be accessed from the above URL
    TransServletContextRoot =/transformservlet
    The context root where the TransformServlet can be accessed. It will be appended with the DBWebURL.i.e
    http://localhost:8080/transformservlet
    SearchServletContextRoot =/searchservlet
    The context root where the SearchServlet can be accessed. It will be appended with the DBWebURL.i.e
    http://localhost:8080/searchservlet
    We are looking into the resource creation issue, pls update us on wheather you are using the right values for these properties. If you were using any incorrect property values, update it and try deploying and running the app again.
    Regards
    Elango.

  • Problem when applying IPSEC to DMVPN

    Hi i have some trouble with DMVPN
    i configured NHRP between  a HUB and  aSPOKE:
                   HUB
                 tu0  tu1
                   |     |
                    ISP
                      |
                  tu0,tu1
                 SPOKE
    the HUB has two physical interfaces and two logical interfaces.
    The SPOKE has one physical interface and two logical interfaces.
    in configured NHRP correctly, the tunnels  are  detected in the HUB and the SPOKE.
    when i add the profile IPSEC to the intefaces i lose tunnel1.
    SPOKE1#sh ip nhrp
    10.1.1.4/32 via 10.1.1.4, Tunnel0 created 02:22:01, never expire
      Type: static, Flags: authoritative used
      NBMA address: 190.1.1.1
    10.2.2.4/32 via 10.2.2.4, Tunnel1 created 02:18:21, never expire
      Type: static, Flags: authoritative used
      NBMA address: 190.1.2.1
    SPOKE1#debug ip nhrp
    tunnel0
    *Mar  1 03:50:09.399: NHRP: Attempting to send packet via DEST 10.1.1.4
    *Mar  1 03:50:09.399: NHRP: Encapsulation succeeded.  Tunnel IP addr 190.1.1.1
    *Mar  1 03:50:09.399: NHRP: Send Registration Request via Tunnel0 vrf 0, packet size: 82
    *Mar  1 03:50:09.403:       src: 10.1.1.1, dst: 10.1.1.4
    *Mar  1 03:50:09.403: NHRP: 82 bytes out Tunnel0
    *Mar  1 03:50:09.519: NHRP: Receive Registration Reply via Tunnel0 vrf 0, packet size: 102
    *Mar  1 03:50:09.519: NHRP: netid_in = 0, to_us = 1
    tunnel 1
    *Mar  1 03:50:30.575: NHRP: Attempting to send packet via DEST 10.2.2.4
    *Mar  1 03:50:30.575: NHRP: Encapsulation succeeded.  Tunnel IP addr 190.1.2.1
    *Mar  1 03:50:30.575: NHRP: Send Registration Request via Tunnel1 vrf 0, packet size: 82
    *Mar  1 03:50:30.579:       src: 10.2.2.1, dst: 10.2.2.4
    *Mar  1 03:50:30.579: NHRP: 82 bytes out Tunnel1
    *Mar  1 03:50:30.579: NHRP: Resetting retransmit due to hold-timer for 10.2.2.4
    no reply from the HUB.
    HUB#sh ip nhrp
    10.1.1.1/32 via 10.1.1.1, Tunnel0 created 00:05:05, expire 00:08:29
      Type: dynamic, Flags: authoritative unique registered
      NBMA address: 191.1.1.11
    just tunnel0 is there !
    i have also this on the HUB :
    *Mar  1 03:58:54.519: %CRYPTO-6-IKMP_MODE_FAILURE: Processing of Quick mode failed with peer at 191.1.1.11 (physical adress of  SPOKE1)
    configs :
    HUB :
    crypto isakmp policy 10
    encr aes
    hash md5
    authentication pre-share
    group 2
    crypto isakmp key techservices address 0.0.0.0 0.0.0.0
    crypto ipsec transform-set AES_MD5 esp-aes esp-md5-hmac
    crypto ipsec profile DMVPN
    set transform-set AES_MD5
    interface Tunnel0
    bandwidth 10000
    ip address 10.1.1.4 255.255.255.0
    no ip redirects
    ip mtu 1400
    no ip next-hop-self eigrp 123
    ip nhrp authentication dmvpn1
    ip nhrp map multicast dynamic
    ip nhrp network-id 123
    no ip split-horizon eigrp 123
    tunnel source FastEthernet0/0
    tunnel mode gre multipoint
    tunnel key 123
    tunnel protection ipsec profile DMVPN
    interface Tunnel1
    bandwidth 10000
    ip address 10.2.2.4 255.255.255.0
    no ip redirects
    ip mtu 1400
    no ip next-hop-self eigrp 124
    ip nhrp authentication dmvpn2
    ip nhrp map multicast dynamic
    ip nhrp network-id 124
    no ip split-horizon eigrp 124
    tunnel source FastEthernet1/0
    tunnel mode gre multipoint
    tunnel key 124
    tunnel protection ipsec profile DMVPN
    router eigrp 123
    network 10.1.1.0 0.0.0.255
    network 172.16.4.0 0.0.0.255
    no auto-summary
    router eigrp 124
    network 10.2.2.0 0.0.0.255
    network 172.16.4.0 0.0.0.255
    no auto-summary
    SPOKE1:
    crypto isakmp policy 10
    encr aes
    hash md5
    authentication pre-share
    group 2
    crypto isakmp key techservices address 0.0.0.0 0.0.0.0
    crypto ipsec transform-set AES_MD5 esp-aes esp-md5-hmac
    crypto ipsec profile DMVPN
    set transform-set AES_MD5
    interface Tunnel0
    bandwidth 10000
    ip address 10.1.1.1 255.255.255.0
    ip mtu 1400
    ip nhrp authentication dmvpn1
    ip nhrp map multicast 190.1.1.1
    ip nhrp map 10.1.1.4 190.1.1.1
    ip nhrp network-id 123
    ip nhrp holdtime 600
    ip nhrp nhs 10.1.1.4
    ip nhrp registration timeout 300
    tunnel source FastEthernet0/0
    tunnel mode gre multipoint
    tunnel key 123
    tunnel protection ipsec profile DMVPN
    interface Tunnel1
    bandwidth 10000
    ip address 10.2.2.1 255.255.255.0
    ip mtu 1400
    ip nhrp authentication dmvpn2
    ip nhrp map multicast 190.1.2.1
    ip nhrp map 10.2.2.4 190.1.2.1
    ip nhrp network-id 124
    ip nhrp holdtime 600
    ip nhrp nhs 10.2.2.4
    ip nhrp registration timeout 300
    tunnel source FastEthernet0/0
    tunnel mode gre multipoint
    tunnel key 124
    tunnel protection ipsec profile DMVPN
    router eigrp 123
    network 10.1.1.0 0.0.0.255
    network 172.16.1.0 0.0.0.255
    no auto-summary
    router eigrp 124
    network 10.2.2.0 0.0.0.255
    network 172.16.1.0 0.0.0.255
    no auto-summary
    regards

    but when i add an other SPOKE there is a problem :
                              HUB
                              |    |
    SPOKE1___ ISP__SPOKE2
    HUB:
    crypto isakmp policy 10
    encr aes
    hash md5
    authentication pre-share
    group 2
    crypto isakmp key cisco address 0.0.0.0 0.0.0.0
    crypto ipsec transform-set AES_MD5 esp-aes esp-md5-hmac
    crypto ipsec profile DMVPN
    set transform-set AES_MD5
    interface Tunnel0
    bandwidth 1000
    ip address 10.1.1.4 255.255.255.0
    no ip redirects
    ip mtu 1400
    no ip next-hop-self eigrp 123
    ip nhrp authentication dmvpn1
    ip nhrp map multicast dynamic
    ip nhrp network-id 123
    no ip split-horizon eigrp 123
    tunnel source FastEthernet0/0
    tunnel mode gre multipoint
    tunnel key 123
    tunnel protection ipsec profile DMVPN
    interface Tunnel1
    bandwidth 1000
    ip address 10.2.2.4 255.255.255.0
    no ip redirects
    ip mtu 1400
    no ip next-hop-self eigrp 124
    ip nhrp authentication dmvpn2
    ip nhrp map multicast dynamic
    ip nhrp network-id 124
    no ip split-horizon eigrp 124
    tunnel source FastEthernet1/0
    tunnel mode gre multipoint
    tunnel key 124
    tunnel protection ipsec profile DMVPN
    router eigrp 123
    network 10.1.1.0 0.0.0.255
    network 172.16.4.0 0.0.0.255
    no auto-summary
    router eigrp 124
    network 10.2.2.0 0.0.0.255
    network 172.16.4.0 0.0.0.255
    no auto-summary
    SPOKE1 :
    crypto isakmp policy 10
    encr aes
    hash md5
    authentication pre-share
    group 2
    crypto isakmp key cisco address 0.0.0.0 0.0.0.0
    crypto ipsec transform-set AES_MD5 esp-aes esp-md5-hmac
    crypto ipsec profile DMVPN
    set transform-set AES_MD5
    interface Tunnel0
    bandwidth 1000
    ip address 10.1.1.1 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp authentication dmvpn1
    ip nhrp map multicast 190.1.1.1
    ip nhrp map 10.1.1.4 190.1.1.1
    ip nhrp network-id 123
    ip nhrp holdtime 600
    ip nhrp nhs 10.1.1.4
    ip nhrp registration timeout 300
    tunnel source FastEthernet0/0
    tunnel mode gre multipoint
    tunnel key 123
    tunnel protection ipsec profile DMVPN shared
    interface Tunnel1
    bandwidth 1000
    ip address 10.2.2.1 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp authentication dmvpn2
    ip nhrp map multicast 190.1.2.1
    ip nhrp map 10.2.2.4 190.1.2.1
    ip nhrp network-id 124
    ip nhrp holdtime 600
    ip nhrp nhs 10.2.2.4
    ip nhrp registration timeout 300
    tunnel source FastEthernet0/0
    tunnel mode gre multipoint
    tunnel key 124
    tunnel protection ipsec profile DMVPN shared
    router eigrp 123
    network 10.1.1.0 0.0.0.255
    network 172.16.1.0 0.0.0.255
    no auto-summary
    router eigrp 124
    network 10.2.2.0 0.0.0.255
    network 172.16.1.0 0.0.0.255
    no auto-summary
    SPOKE2 :
    crypto isakmp policy 10
    encr aes
    hash md5
    authentication pre-share
    group 2
    crypto isakmp key cisco address 0.0.0.0 0.0.0.0
    crypto ipsec transform-set AES_MD5 esp-aes esp-md5-hmac
    crypto ipsec profile DMVPN
    set transform-set AES_MD5
    interface Tunnel0
    bandwidth 1000
    ip address 10.1.1.2 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp authentication dmvpn1
    ip nhrp map multicast 190.1.1.1
    ip nhrp map 10.1.1.4 190.1.1.1
    ip nhrp network-id 123
    ip nhrp holdtime 600
    ip nhrp nhs 10.1.1.4
    ip nhrp registration timeout 300
    tunnel source FastEthernet0/0
    tunnel mode gre multipoint
    tunnel key 123
    tunnel protection ipsec profile DMVPN shared
    interface Tunnel1
    bandwidth 1000
    ip address 10.2.2.2 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp authentication dmvpn2
    ip nhrp map multicast 190.1.2.1
    ip nhrp map 10.2.2.4 190.1.2.1
    ip nhrp network-id 124
    ip nhrp holdtime 600
    ip nhrp nhs 10.2.2.4
    ip nhrp registration timeout 300
    tunnel source FastEthernet0/0
    tunnel mode gre multipoint
    tunnel key 124
    tunnel protection ipsec profile DMVPN shared
    router eigrp 123
    network 10.1.1.0 0.0.0.255
    network 172.16.2.0 0.0.0.255
    no auto-summary
    router eigrp 124
    network 10.2.2.0 0.0.0.255
    network 172.16.2.0 0.0.0.255
    no auto-summary
    HUB:
    HUB#sh ip nhrp
    10.1.1.1/32 via 10.1.1.1, Tunnel0 created 00:15:17, expire 00:09:21
      Type: dynamic, Flags: authoritative unique registered
      NBMA address: 191.1.1.11
    10.1.1.2/32 via 10.1.1.2, Tunnel0 created 00:12:09, expire 00:07:50
      Type: dynamic, Flags: authoritative unique registered
      NBMA address: 191.1.1.12
    10.2.2.1/32, Tunnel1 created 00:02:57, expire 00:00:07
      Type: incomplete, Flags: negative
      Cache hits: 7
    10.2.2.2/32 via 10.2.2.2, Tunnel1 created 00:12:00, expire 00:07:58
      Type: dynamic, Flags: authoritative unique registered
      NBMA address: 191.1.1.12
    HUB can't have the NBMA adress for 10.2.2.1 for SPOKE1
    HUB#ping 10.2.2.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds:
    Success rate is 0 percent (0/5)
    *Mar  1 00:45:18.431: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1 netid-out 124
    *Mar  1 00:45:18.435: NHRP: Checking for delayed event 0.0.0.0/10.2.2.1 on list (Tunnel1).
    *Mar  1 00:45:18.435: NHRP: No node found..
    *Mar  1 00:45:07.131: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1 netid-out 124
    *Mar  1 00:45:07.131: NHRP: Checking for delayed event 0.0.0.0/10.2.2.1 on list (Tunnel1).
    *Mar  1 00:48:30.759: NHRP: Checking for delayed event 0.0.0.0/10.2.2.1 on list (Tunnel1).
    *Mar  1 00:48:30.763: NHRP: No node found.
    *Mar  1 00:48:30.763: NHRP: Attempting to send packet via DEST 10.2.2.1
    *Mar  1 00:48:30.767: NHRP: Send Resolution Request via Tunnel1 vrf 0, packet size: 82
    *Mar  1 00:48:30.771:       src: 10.2.2.4, dst: 10.2.2.1
    *Mar  1 00:48:30.771: NHRP: Encapsulation failed for destination 10.2.2.1 out Tunnel1
    SPOKE1#
    *Mar  1 00:53:38.695: NHRP: Setting retrans delay to 64 for nhs  dst 10.2.2.4
    *Mar  1 00:53:38.699: NHRP: Attempting to send packet via DEST 10.2.2.4
    *Mar  1 00:53:38.699: NHRP: Encapsulation succeeded.  Tunnel IP addr 190.1.2.1
    *Mar  1 00:53:38.703: NHRP: Send Registration Request via Tunnel1 vrf 0, packet size: 82
    *Mar  1 00:53:38.711:       src: 10.2.2.1, dst: 10.2.2.4
    *Mar  1 00:53:38.715: NHRP: 82 bytes out Tunnel1
    no reply from the HUB
    SPOKE1#ping 10.2.2.4
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.2.2.4, timeout is 2 seconds:
    Success rate is 0 percent (0/5)
    the SPOKE can't reach 10.2.2.4
    after a few time :
    HUB#sh ip nhrp
    10.1.1.1/32 via 10.1.1.1, Tunnel0 created 00:25:03, expire 00:09:35
      Type: dynamic, Flags: authoritative unique registered used
      NBMA address: 191.1.1.11
    10.1.1.2/32 via 10.1.1.2, Tunnel0 created 00:21:55, expire 00:08:03
      Type: dynamic, Flags: authoritative unique registered
      NBMA address: 191.1.1.12
    10.2.2.2/32 via 10.2.2.2, Tunnel1 created 00:21:47, expire 00:08:12
      Type: dynamic, Flags: authoritative unique registered
      NBMA address: 191.1.1.12
    only 3 tunnels

Maybe you are looking for

  • Zen 4 imaging pmap and transaction server errors

    Hi, I am running Zen4 ir7 on a netware 65 sp5 server and trying to run use pxe at the workstation to get images to upload from new workstations. I am running into an error when pxe loads and gives me the following two messages No response from portma

  • ALV - o/p logic - for Qty segregation

    Hi This Report is for Semifinished product's system status.  (radio buttons - with & w/o serial no.) W/o serial no. o/p is --> Material    -    Total Qty    -   Qty in store   - Qty in Elctronics  - Qty in Mechanical - Delivered Qty SPDEW  -       5 

  • Line item has incorrect Dr/Cr indicator for remaining amount

    Hi all, When I tried  to clear the vendor payment in T.Code F-44, there are some exchange rate differences.So I used GL account to  the difference amount for the automatic posting. And also already defined the GL account in OBA1, under key KDF. But t

  • Sql Query to replace the square bracket and the whole text inside with a single charecter

    Hi All, I  have a question. I am using Sql Server 2012. I have a  situation where i need to replace the entire text and the square bracket with a single charecter. Eg:->  I have atext    san[123456dd]text i just wanted to replace all teh text inside

  • Holding 3 and 2 will not boot in 32 bit mode

    Hello. I need to boot in 32 bit mode to run Cisco VPN Client on my Macbook Air (version 10.7.4). This worked earlier this week but I've now tried for 3 days probably 20 plus time and cannot get it to take.  Is there another way to boot in 32 bit mode