Problem with getServletContext().getRequestDispatcher(....).forward()

We are using the latest SJSWS 7.0U8, but have the following problem:
During GET requests, getServletContext().getRequestDispatcher(....).forward(req,resp) works fine. But if the client issues a HEAD request, the servlet crashes with a ClassCastException. This bug was known for older versions of Tomcat but is fixed there. Maybe the fix could be applied to SJSWS internal catilina engine, too?
Are there any idea to walk around that problem, but let HEAD request still produce the correct headers for such a request(file size,...)?
[17/Feb/2010:19:39:28] failure ( 9211): for host a.b.c.d trying to HEAD /xxxxx, service-j2ee reports: StandardWrapperValve[xxx]: PWC1406: Servlet.service() for servlet xxx threw exception
java.lang.ClassCastExceptionNo stack trace is logged, but some time in the past i printed a complete stack trace in a catch block and the reason for that is:
The default HEAD handler in the servlet uses NoBodyResponse to wrap the original ServletResponse. The code of forward() later tries to cast this response object to a standard HttpServetResponse, what it is not. Tomcat/Jetty have a fix for it (I do not know the bug number).
This happens now very often, as newer browsers like Chrome sometimes issue HEAD requests during page display (not sure why).

Some more infos about the problem (the root cause is in the HttServlet.NoBodyResponse implementation in the Servlet Spec):
[https://issues.apache.org/bugzilla/show_bug.cgi?id=22290]
Some investigations about this (NoBodyResponse should extend HttpServletResponseWrapper and not Object): [http://closingbraces.net/2006/12/31/httpservletissues/], [http://closingbraces.net/2007/01/29/httpservletissuesfollowup/]
That is a similar stack trace I get (I get it with catilina classes, but same root cause): [http://markmail.org/message/pbdcbav6y2vlzbfc] or ClassCastException in weblogic.servlet.internal.ServletResponseImpl
Edited by: thetaphi on Feb 17, 2010 11:34 AM

Similar Messages

  • Problem with Port Range Forwarding WRV54G

    I have configured my WRV54G to do the following, in this order, on the Port Range Forwarding page of the router:
    1. Forward port 3389 to LAN Static IP x.x.x.100, a desktop PC. I have confirmed this works, a port scan shows this port is open and I can remote desktop into x.x.x.100
    2. Forward port 443 to LAN Static IP x.x.x.101. I have confirmed this works, a port scan shows this port is open I can VPN to an SSL concentrator at x.x.x.101
    3. Forward port 3390 to LAN Static IP x.x.x.102, a desktop PC. THIS DOES NOT WORK. A port scan shows that this port is not open. I have configured the remote desktop host at x.x.x.102 to use port 3390. Netstat shows that x.x.x.3390 is listening on this port. I can remote desktop to x.x.x.102 from inside the LAN, no problem, so it's not an issue with the PX configuration.
    So, then I switched the order of the port forwarding instructions, in this order, as follows:
    1. Forward port 3389 to LAN Static IP x.x.x.100, a desktop PC. I have confirmed this works, a port scan shows this port is open and I can remote desktop into x.x.x.100
    2. Forward port 3390 to LAN Static IP x.x.x.102, a desktop PC. I have confirmed this
    works, a port scan shows this port is open and I can remote desktop into x.x.x.102
    3. Forward port 443 to LAN Static IP x.x.x.101. THIS DOES NOT WORK. Port scan shows this port is not open.
    It looks like the WRV54G is only recognizing the first two entries in the Port Range Forwarding table and IGNORING the third entry. HELP??!!
    I have the latest firmware installed: v2.39.2e
    Anyone have a solution? Thanks in advance!
    Message Edited by crescendi on 07-19-2008 11:53 AM

    Are you still using the DHCP server range of  x.x.x.100  through  x.x.x.149 ?   If so, then your problem may be that you are using illegal fixed LAN IP addresses.
    With Linksys routers, any fixed LAN IP address must be outside the DHCP server range, and it cannot end in 0, 1, or 255.
    I would suggest that you fix the illegal addresses, then see if that resolves your problem.
    Here is the full set of rules for using fixed LAN IP addresses:
    With Linksys routers, a fixed (static) LAN IP addresses must be assigned in the device that is using the address. So you need to enter the fixed address in the computer or printer, not in the router.
    When using a Linksys router, any fixed LAN IP address must be outside the DHCP server range (typically 192.168.1.100 thru 192.168.1.149), and it cannot end in 0, 1, or 255.
    Therefore any fixed LAN IP address would normally need to be in the range of
    192.168.1.2 thru 192.168.1.99 or
    192.168.1.150 thru 192.168.1.254
    assuming you are still using the default DHCP server range.
    Also, in the computer, when you set up a static LAN IP address, you would need to set the "Subnet mask" to 255.255.255.0 and the "Default Gateway" to 192.168.1.1 and "DNS server" to 192.168.1.1
    It is also important that no two devices on your network be set to the same static LAN IP address.

  • Problem with opening/port forwarding some ports but not others

    I read the Faq and the first few pages of the forums but couldnt find anything.
    I am using the Port Forwarding (WRT54G, Firmware 4.20.7) to my network camera to try to open up ports 80, 554, 5556 and 5558.
    Using the network toolbox at Blackcode.com I then check the ports to see if they are open.
    Port 554 seems to be open. Port 80, 5556 and 5558 do not appear to be open.
    I am using the correct external IP address (I can toggle port 554 open and closed and test that). Toggling Blocking Anon Internet Requests Of/Off makes no difference to the result.
    I have checked with my ISP and they dont claim to block those ports.
    Any thoughts on what this could be? Is there a way to test if its my ISP? If it is my ISP, is there a workaround?
    Thanks for any help.

    Are you sure the camera does listen on those port at the time you did this tests? Are those ports open inside your LAN, too?
    5556 and 5558 look like RTP ports which may only be active after the channels have been established through RTSP.
    Forwarding of port 80 is known to be an issue on various routers as the router allocates port 80 for the web interface. Sometimes it helps to change the remote management port on the router from 80 to 8080 or something else. You may even have to enable remote management to get this active.
    If this does not work you have to reconfigure port 80 on your server to a different port if possible.
    Message Edited by gv on 08-21-2007 12:28 AM

  • Problem with balance carry forward business rule and automatic adjustments

    Hi All,
    I faced with issue when run BCF business rule and consolidation process. According sap courses BPC440 members with A(automatic adjustments) type should carry forward automatically, and I(imputable), M (adjustments) members should carry forwarded by bcf business rule.
    When I set up my BCF business rule I use property "Category_for_ope" in Category dimension. But this rule not work properly, then I use notes:
    1784365 - Category_for_ope property should not effect Consolidation.
    1902677 - The property category_for_ope shall work for consolidation
    After applying those notes, system work as I aspect. After i run consolidation first time system carry forward my automatic adjustment from Category "Expected" to "PLAN_Y0" and this is correct!!!. But when i run consolidation process second and third time system duplicated automatic adjustments in Category "PLAN_Y0".
    Someone can help me with this Issue?
    And sorry for my english

    Hi,
    Can you try as follows :
    *RUN_PROGRAM COPYOPENING
    CATEGORY = %C_CATEGORY_SET%
    CURRENCY = %RPTCURRENCY_SET%
    TID_RA = %TIME_SET%
    *ENDRUN_PROGRAM
    hope it helps...
    regards,
    Raju

  • Problem with Desktop redirector forwarding messages

    In my office 5 of us use the desktop redirector , and it stopped working last Saturday so I fairly sure the problem is with our SPAM filtering or exchange etc the problem is everyone I talk to seems clueless,
    In out look I see all the BB messages now have the subject as Spam: Spam: RIM_bca28a80-e9c0-11d1-87fe-00600811c6a2 , from [email protected] , and I can still send messages from blackberry, so any suggestions as to how I track down what is responsible for identifying these messages as spam ?
    Thanks

    Hi rosspce and welcome to the BlackBerry Support Community Forums!
    The altered subject line is what's causing your problem.  The BlackBerry Desktop Redirector looks for the specific subject line of RIM_bca28a80-e9c0-11d1-87fe-00600811c6a2, so when "Spam" is added to the subject line, it is not recognized and thus not processed.
    It is typical of some spam filters to alter the subject line to make for easy filtering of messages.  You would have to consult whoever is administering the spam filter and make sure these messages are not marked as spam.
    -CptS
    Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp
    Be sure to click Kudos! for those who have helped you.Click Solution? for posts that have solved your issue(s)!

  • Problem with Server proxy forward

    Hi all,
    i had server working last night with forward proxy running.
    This morning I have shutdown the machine and updated the RAM to 8GB.
    Re-booted the server, and now even though under web -enable forward proxy is selected & the Server has got web http proxy enabled to port 80 and the servers IP address, safari fails to open page as it cannot connect to the prxy server !!
    I cannot see any errors and I can ping the IP address as I am trying safari on the server where the proxy is running.
    I have tried port scan on the server and port 80 is not showing.
    How can I be certain the proxy is running and how can I troubleshoot this.
    I have tried enabling and disabling and re-booting with no success.
    Now stuck.

    ok been googling and have tried:
    netstat -na | grep LISTEN
    => there is no port 80 on which the server is listening... so that is why the proxy is not working. however how do i restart this port as a re-boot does not do it.
    I have also setup proxy on a older 10.5 Server and port 80 is working.
    So i know its not my config, and I put the original RAM back it and it was the same !!
    Port 80 is not listening - how do I restart it?

  • WRT160Nv2-Problem with Single Port forward to multiple servers with same internal port numbers.

    On my network I have 3 systems that I've set up as RDP hosts.  And need to get to all three of them externally.  So I'm trying to do the following single port forwarding.
    RDP 1   Forward 4000 to port 3389 for 192.168.1.11
    RDP 2   Forward 4001 to port 3389 for 192.168.1.12
    RDP 3   Forward 4002 to port 3389 for 192.168.1.14
    When I hit "Save Changes" I get the error "Port range already exists".  So it's good that it won't let me overlap ports generally, but at the same time, I'm trying to send them to different IP address.  There should be no overlap in this case.  Please advise
    I'm trying this on the WRT160Nv2 with firmware 2.0.02, which I had just bought this weekend.

    kevj,
      Thanks for your suggestion.  I have now upgraded the firmware to 2.0.03 build 7.  But I am still seeing the error message
    As I mentioned previously, I'm trying to single port forward to multiple machines in the following way:
    Machine 1:   Forward 4000 to port 3389 for 192.168.1.11
    Machine 2:   Forward 4001 to port 3389 for 192.168.1.12
    Machine 3:   Forward 4002 to port 3389 for 192.168.1.14
    The error appears to be generated by the fact that 3389 is selected for multiple external port numbers, but the same internal port number.  The router I believe isn't taking into account that the similar internal port numbers aren't taking into account the different internal ip address I'm trying to send this to.
    This would be a standard sort of practice for running a live HTTP server on one machine, and a new beta HTTP server behind the router on a secondary machine on the same internal port, but different external port numbers for test purposes from the outside.
    Please advise
    Thank you.

  • Problems with schroll fast forward in audiobooks.

    When I scroll fast foward on my iPod Classic in a audiobook, and I want to move to a place in the book equalent with 14 hours, it will allow me to reach p.ex. 14:05:00 but when I press the play botton it wil start at 13:15:17. I have to add that i have two iPod Classic and the same fhenomen happens to bouth. When I put in audiobooks that are longer than ca. 13 hours the iPod estmates that the book is 786houers long(time left of the audiobook when I start). Is something wrong with software?
    Can anybody clever iPod person help me solve this problem?

    No - sorry you cannot do that.

  • Problems with SMTP port forwarding on ASA 5505

    Cannot telnet to port 25 to test for SMTP traffic.  Packet trace indicates that the packet is dropped by the implicit rule, but I have tried an access rule specifically for SMTP, and the trace appears to skip the rule and drop the packet when it hits the implicit default drop rule.  Can anyone help?  Here is my configuration:
    ASA Version 8.2(5)
    hostname XXXXXXXXXXXXXXXXX
    enable pXXXXXXXXXXXXXXXXXXXXX encrypted
    passwd XXXXXXXXXXXXXXXXXX encrypted
    names
    name XXX.XXX.XXX.74 DNI-HOST1
    name XXX.XXX.XXX.184 DNI-HOST2
    name 192.168.1.2 Server
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address XXX.XXX.XXX.130 255.255.255.248
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    object-group service rdp tcp
    port-object eq 3389
    access-list INBOUND extended permit icmp any any time-exceeded
    access-list INBOUND extended permit icmp any any echo-reply inactive
    access-list INBOUND extended permit icmp any any
    access-list INBOUND extended permit tcp any any eq smtp
    access-list INBOUND extended permit tcp any any eq https
    access-list INBOUND extended permit tcp any eq 3389 any object-group rdp
    pager lines 24
    logging enable
    logging buffered warnings
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 192.168.1.0 255.255.255.0
    static (inside,outside) tcp interface smtp Server smtp netmask 255.255.255.255
    access-group INBOUND in interface outside
    route outside 0.0.0.0 0.0.0.0 XXX.XXX.XXX.129 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    http DNI-HOST2 255.255.255.255 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca [REDACTED]
      quit
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh 206.190.255.0 255.255.255.0 outside
    ssh DNI-HOST2 255.255.255.255 outside
    ssh DNI-HOST1 255.255.255.255 outside
    ssh timeout 5
    console timeout 0
    management-access inside
    threat-detection basic-threat
    threat-detection statistics access-list
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    webvpn
    username Administrator password XXXXXXXXXXXXXXXXXXXX encrypted
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    : end

    Thanks.  I made the suggested changes, here are the results of packer-tracer:
    ASA# packet-tracer input outside tcp 1.2.3.4 1234 XXX.XXX.XXX.130 25
    Phase: 1
    Type: UN-NAT
    Subtype: static
    Result: ALLOW
    Config:
    static (inside,outside) tcp interface smtp Server smtp netmask 255.255.255.255
      match tcp inside host Server eq 25 outside any
        static translation to XXX.XXX.XXX.130/25
        translate_hits = 0, untranslate_hits = 3
    Additional Information:
    NAT divert to egress interface inside
    Untranslate XXX.XXX.XXX.130/25 to Server/25 using netmask 255.255.255.255
    Phase: 2
    Type: ACCESS-LIST
    Subtype: log
    Result: ALLOW
    Config:
    access-group INBOUND in interface outside
    access-list INBOUND extended permit tcp any host XXX.XXX.XXX.130 eq smtp
    Additional Information:
    Phase: 3
    Type: IP-OPTIONS
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 4
    Type: INSPECT
    Subtype: inspect-smtp
    Result: ALLOW
    Config:
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect esmtp _default_esmtp_map
    service-policy global_policy global
    Additional Information:
    Phase: 5
    Type: HOST-LIMIT
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 6
    Type: NAT
    Subtype: rpf-check
    Result: ALLOW
    Config:
    static (inside,outside) tcp interface smtp Server smtp netmask 255.255.255.255
      match tcp inside host Server eq 25 outside any
        static translation to XXX.XXX.XXX.130/25
        translate_hits = 0, untranslate_hits = 3
    Additional Information:
    Phase: 7
    Type: NAT
    Subtype: host-limits
    Result: ALLOW
    Config:
    static (inside,outside) tcp interface smtp Server smtp netmask 255.255.255.255
      match tcp inside host Server eq 25 outside any
        static translation to XXX.XXX.XXX.130/25
        translate_hits = 0, untranslate_hits = 3
    Additional Information:
    Phase: 8
    Type: IP-OPTIONS
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 9
    Type: FLOW-CREATION
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    New flow created with id 24392, packet dispatched to next module
    Result:
    input-interface: outside
    input-status: up
    input-line-status: up
    output-interface: inside
    output-status: up
    output-line-status: up
    Action: allow
    I'm not all that experienced with translating these results, but on the surface, it appears to be passing traffic.  However, I still cannt telnet to the public IP using port 25.  I am using Putty as my telnet client and it doesn't generate an error.  At no time am I able to interact with the prompt in the putty window. The putty window just closes abruptly after about 10 seconds.  Does the line in Phase 7 containing 'untranslate_hits=3' have anything to do with my issue?
    Here is the new config:
    NUGENT-ASA# show run
    : Saved
    ASA Version 8.2(5)
    hostname NUGENT-ASA
    enable password XXXXXXXXXXXXXXXXXXXX encrypted
    passwd XXXXXXXXXXXXXXXXXX encrypted
    names
    name XXX.XXX.XXX.74 DNI-HOST1
    name XXX.XXX.XXX.184 DNI-HOST2
    name 192.168.1.2 Server
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address XXX.XXX.XXX.130 255.255.255.248
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    object-group service rdp tcp
    port-object eq 3389
    access-list INBOUND extended permit icmp any any time-exceeded
    access-list INBOUND extended permit icmp any any echo-reply inactive
    access-list INBOUND extended permit icmp any any
    access-list INBOUND extended permit tcp any host XXX.XXX.XXX.130 eq smtp
    pager lines 24
    logging enable
    logging buffered warnings
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 192.168.1.0 255.255.255.0
    static (inside,outside) tcp interface smtp Server smtp netmask 255.255.255.255
    static (outside,inside) tcp interface smtp Server smtp netmask 255.255.255.255
    access-group INBOUND in interface outside
    route outside 0.0.0.0 0.0.0.0 XXX.XXX.XXX.129 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    http DNI-HOST2 255.255.255.255 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca [REDACTED]
      quit
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh 206.190.255.0 255.255.255.0 outside
    ssh DNI-HOST2 255.255.255.255 outside
    ssh DNI-HOST1 255.255.255.255 outside
    ssh timeout 5
    console timeout 0
    management-access inside
    dhcpd dns 8.8.8.8 4.2.2.2
    dhcpd address 192.168.1.100-192.168.1.131 inside
    dhcpd dns 8.8.8.8 4.2.2.2 interface inside
    threat-detection basic-threat
    threat-detection statistics access-list
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    webvpn
    username Administrator password XXXXXXXXXXXXXXXXXXXXXXX encrypted
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:XXXXXXXXXXXXXXXXXXXXXXXXXXX
    : end

  • WL6.1sp3 problem with getServletContext?

              I have just installed WL6.1sp3 and tried to move a web application from Tomcat
              4.02 to WebLogic. When I access a jsp, I get the following compile error indicating
              that it does not recognize the getServletContext method.
              Can anyone tell me why this is happening and how I can fix this?
              E:\WRS\WEB-INF\_tmp_war_WRS\jsp_servlet\__wrslogin.java:101: cannot resolve symbol
              symbol : method getServletContext ()
              location: class jsp_servlet.__wrslogin
              String wrsDBLogin = getServletContext().getInitParameter("wrsDBLogin");
              //[ /WRSLogin.jsp; Line: 12]
              Thanks,
              Chris
              

    AFAIK there is no getServletContext() method in javax.servlet.Servlet.
              change your JSP to
              String wrsDBLogin =
              getServletConfig().getServletContext().getInitParameter("wrsDBLogin");
              or
              String wrsDBLogin = application.getInitParameter("wrsDBLogin");
              "Chris L" <[email protected]> wrote in message
              news:[email protected]..
              >
              > I have just installed WL6.1sp3 and tried to move a web application from
              Tomcat
              > 4.02 to WebLogic. When I access a jsp, I get the following compile error
              indicating
              > that it does not recognize the getServletContext method.
              >
              > Can anyone tell me why this is happening and how I can fix this?
              >
              > E:\WRS\WEB-INF\_tmp_war_WRS\jsp_servlet\__wrslogin.java:101: cannot
              resolve symbol
              > symbol : method getServletContext ()
              > location: class jsp_servlet.__wrslogin
              > String wrsDBLogin =
              getServletContext().getInitParameter("wrsDBLogin");
              > //[ /WRSLogin.jsp; Line: 12]
              >
              >
              >
              > Thanks,
              >
              > Chris
              Dimitri
              

  • Problem with forward method of jsp

    am having problem with the requestDispatcher.forward method in my jsp + wml , the forward method gets executed but the new page is not displayed in the wap browser,
    code snippet
    small.jsp
    <?xml version="1.0"?>
    <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN" "http://www.wapforum.org/DTD/wml_1.1.xml">
    <%@ page language="java" %>
    <%@ page contentType="text/vnd.wap.wml; charset=UTF-8" %>
    <%@ page import="java.lang.*,java.io.*,java.util.*,java.util.Vector,java.util.Properties "%>
    <%
    System.out.println("in small");
    RequestDispatcher rd = request.getRequestDispatcher("small1.jsp");
    rd.forward(request,response);
    %>
    small1.jsp
    <?xml version="1.0"?>
    <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN" "http://www.wapforum.org/DTD/wml_1.1.xml">
    <%@ page language="java" autoFlush="false"%>
    <%@ page contentType="text/vnd.wap.wml; charset=UTF-8" %>
    <%@ page import="java.net.*,java.lang.*,java.io.*,java.util.*,java.util.Vector,java.util .Properties"%>
    <%
    String sm = "small1";
    System.out.println("in small1");
    %>
    <wml>
    <card id="two">
    <p>
    <small><%=sm%></small>
    </p>
    </card>
    </wml>
    i get the following output in the log
    in small
    in small1
    but i dont get to see the small1.jsp' content , also the response.sendRedirect method works fine ,,
    pls give me the soln
    Thnk u in advance

    thank u very for the repl this is the message which i get in the nokia wap browser...
    cannot load small1.jsp(HTTP Error 500 Server Error)
    and i use IBM WebSphere as the web server....
    and i have found that using response.reset in the small2.jsp overcomes this problem but the card title and the anchor tag is not displayed !!!!
    what could be this problem?

  • Problems with call forwarding setup

    I just got an iPhone and it's great, except for one annoying problem with the call forwarding behavior.
    With my old RAZR phone (also on AT&T) I had two choices when turning on forwarding, "forward immediately" or "forward when unavailable". I used the second choice and had forwarding turned on all the time. Calls would go to the cell phone first but then forward to my home number if I was on another call or didn't answer after a couple of rings. That behavior is important because I want all voice messages in the same place, on my answering machine at home, regardless of whether my cell or home number was called (so I want to deliberately bypass AT&T's voicemail system).
    However the iPhone seems to only have the "immediately" behavior, which means I don't have a chance to answer a call on the iPhone before it forwards, and the iPhone doesn't even log it as a missed call. The forwarding setup is stored in AT&T's system so it seems like the capability should be there regardless of the type of phone, and this is just an arbitrary user-interface restriction with the iPhone. Anyone know how to work around this and get the "forward when unavailable" behavior?

    Jason -
    Thanks, this did the trick. The instructions under the section for "former AT&T Wireless customers" worked perfectly (perhaps because I am actually a former AT&T Wireless customer; I've had the number for almost 6 years, since before the merger with Cingular). Anyway, I dial 61xxxxxxxxxx# (xxx = the number to forward to), make the call, and a confirmation message appears on the screen; now the forwarding is working just the way I like it.
    Thanks again!
    Bob

  • .getRequestDispatcher("/").forward question

    I am not sure why I am getting this error.
    java.lang.IllegalStateException at org.apache.catalina.connector.ResponseFacade.getWriter(ResponseFacade.java:159)
    from the code.
    this.getServletConfig().getServletContext().getRequestDispatcher("/").forward(request,response);
    Can anyone help? Has anyone seen this before ?
    I am not calling getOutputStream manually on the same request.

    Typically an IllegalStateException in a case like this is because something has already been written to the response. For example,
    if the response state was set, if a writer was retrieved, etc.
    Look for these and see if one of them is the problem.

  • Problem with carry forwad

    Hi,
    I have a problem with the carry forward business rule.
    I use a consolidation application and I have checked the dimension requirements against the online help and this document http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/c000fc27-8a64-2c10-f289-ed7985b4a6d4?quicklink=index&overridelayout=true and it all is set up as per the documents.
    The script I use to call the business rule is
    *RUN_PROGRAM COPYOPENING
    CATEGORY = %CATEGORY_SET%
    CURRENCY = %CONSOLVIEW_SET%
    TID_RA = %TIME_SET%
    OTHER = [ENTITY=%ENTITY_SET%]
    *ENDRUN_PROGRAM
    The error message I get from the system is
    RUN_LOGIC: Datenquelle in der Anwendung LEGAL nicht gefunden fehlgeschlagen
    which translates as
    RUN_LOGIC Datasource not found in application LEGAL
    I have also tried to define a specific datasource in the script by running it like this
    *RUN_PROGRAM COPYOPENING
    CATEGORY = %CATEGORY_SET%
    CURRENCY = %CONSOLVIEW_SET%
    TID_RA = %TIME_SET%
    DATASRC = LOAD
    OTHER = [ENTITY=%ENTITY_SET%]
    *ENDRUN_PROGRAM
    This generated the same error.
    Thanks for your help.

    Your first script logic was probably fine, but it sounds like there is something wrong with your application. Is it possible that one of the following is the case?:
    1. You don't have a datasource dimension in your LEGAL application, or you have a dimension that you have called DATASRC but it is not a datasource type dimension.
    2. Your datasource dimension doesn't have property DATASRC_TYPE or another required property defined.
    3. Your datasource dimension doesn't have a member with the required DATASRC_TYPE property value.
    In addition to the instructions you link to, the help is pretty decent: [http://help.sap.com/saphelp_bpc75_nw/helpdata/en/c1/28639f8d964561b3f6f9d459a6f312/frameset.htm]
    Ethan

  • Problem with getRequestDispatcher()

    Hi,
    I am trying to use my servlet to redirect the client to the previous page. The servlet is one that is used by so many JSP Pages in the application. I used a java beans inside (please don't laugh) the servlet to capture the page so then pass it to the getRequestDispatcher() as shown below in the code snipet.
    RequestDispatcher dispatcher =
    getServletContext().getRequestDispatcher(ttipsBeans.getpgeNameAddr());
         dispatcher.forward(request, response);
    Problem is: It doesn't work. It brings the client back to the same page. How can I achieve this?
    Thanks
    Joseph

    Thanks for your prompt response. That is exactly what I did with the other servlets that are called by EXACTLY ONE jsp page. Let me illustrate the problem with this scenario. Let's say I have userForm.jsp, travel.jsp, booking.jsp and vacation.jsp pages. Now all these jsp pages must use the userForm.jsp to collect user info. userForm.jsp on the other hand must call myServlet.class to send data to the database. Upon completion of its task it must redirect the client to EITHER travel.jsp, booking.jsp or vacation.jsp depending on which one invoked userForm.jsp. That is the reason why I used java beans to "remember" which page invoked userForm.jsp.

Maybe you are looking for

  • Processor and Graphics Card Upgrade For HP ProBook 4445s

    Hey guys, I wanted to ask that  I have a HP4445s with the A6 4400m processor and don't find it enough to play games. The processor is a little bit slow and the graphics are kind of horrible for a gamer. I feel like upgrading to a new processor. The o

  • What is the difference between Classic and Extended Withholding Tax

    Hi, Can some please tell me what is the difference between Classic Withholding and Extended Withholding Tax. How can I look at the Withholding Tax deducted from a particular invoice? Number Guaranteed. Thanks.

  • Triggering output upon GR in inbound delivery

    Hi all, I want to trigger HU label as soon as i do GR on inbound delivery and on (ii)GI on outbound delivery. For this i set condition records in VV61 and then i assign requirement 1(Delivery GI posted) in SPRO->LOGISTICS GENERAL->HANDLING UNIT MANAG

  • Permissions with NAS

    In the office, we have 2 iMacs - both running 10.5.7 and a NAS drive (Western Digital MyBook World Edition). We both connect to the drive as the Guest user - but when we try to transfer documents to the NAS we can't access each others file. Not ideal

  • BackgroundAlpha to 0 in flash cs6

    I am trying to load a Starling(stage3d) game.swf into a non Starling wrapper.swf.  I can get the game.swf to load and from trace commands can see that it's there but I can't see it visually. From what I understand the stage3d is behind the background