Programmatically subnet

is there a way to programmatically retrieve TCP/IP infomration...IP address, subnet mask, gateway. Basically all the info that you get with the ipconfig command, but without using the Command screen?

You can avoid the window pop-up by wiring a True constant to the run minimized input. I'm attaching a VI in LV7 that uses system exec to programtically set the IP Address, mask, and gateway. A coworker wrote this. It only works on Win2K and XP though.
I don't have any real good tips on searching the MS web site except doing a search of both Support Home and MSDN (Microsoft Developer Network).
Attachments:
Change_Windows_IPconfig.vi ‏45 KB

Similar Messages

  • Programmat​ically changing the TCP/IP address of Windows Vista / 7 / 8

    Hi there!
    I'm pretty new to LabVIEW (started 2 months ago) and still have a long way ahead of me, so please forgive me if anything that I ask is too basic.
    I'm trying to change the IP properties of the PC via LabVIEW for some bigger software I'm working on.
    I can easily do it in Windows XP using the System Exec function to call cmd.exe and then use netsh commands, as previously explained for example here:
    https://forums.ni.com/t5/LabVIEW/Programmatically-​changing-the-IP-address-of-Win-XP/m-p/410533/highl​...
    https://forums.ni.com/t5/LabVIEW/Change-IP-number-​and-Subnet-mask-with-LabView/m-p/407536/highlight/​...
    http://forums.ni.com/t5/LabVIEW/How-to-change-the-​TCP-IP-settings-of-the-LAN-connection-from-LV/m-p/​...
    http://forums.ni.com/t5/LabVIEW/Change-the-compute​r-IP-address-in-LabVIEW/m-p/167481?query.id=108803​... ...
    But then, since I want to run my software in Windows 7 (& by extension to any Windows OS), I have a problem: netsh asks for elevated rights.
    So, the next problem is: how do I run cmd.exe (or any other programm?, by extension) as administrator (from LabVIEW)?. Note that I'm using an account with admin rights. But I would prefer not having to disable the User Account Control configuration, and I don't want to force the user to any interaction (clicking in pop-ups, or right-clicking in anything), I want it to be as automatized as possible.
    I did a bit of research and couldn't find anyway to do it, neither any command to run with cmd, so the two similar solutions that came to my mind are very rudimentary and kind of dirty:
    Use DLLs to make LabVIEW press the keys necessary to open cmd running as admin via key shortcuts (using a variation of https://decibel.ni.com/content/docs/DOC-29563 and the key shortcuts from here: http://www.howtogeek.com/howto/windows-vista/run-a​-command-as-administrator-from-the-windows-vista-r​...). Here, I open the Window menu (with LWIN), properly writes "cmd", and then uses CTRL+SHIFT+ENTER ok... but then the User Account Control appears and LabView keeps doing the commands (I want ALT+Y or LEFT & then ENTER)... without affecting to the UAC! If I make LabVIEW wait a bit and manually close the UAC I succesfully have the command prompt... but LabVIEW is still incapable of write the text that I'm giving it to him (the netsh commands). LabVIEW runs the software, but it's like the UAC & the command prompt are running in a higher? level and are not affected by LV. If I do the same over a .txt I succesfuly have the intended text. Any ideas about this?
    Create a link to cmd.exe and change the properties to "Run as administrator", then use System Exec to call the link, expecting to open a command prompt with elevated rights, and then write the netsh commands either with DLLs (that might not work according to my first solution) or using the "standard input" of System Exec? (not sure if this is possible). But then System Exec gives me an error (code 2) when trying to execute the .lnk and so the command prompt does not open. The error code stands for "Error 2 occurred at an unidentified location. Possible reason(s): LabVIEW: Memory is full." Any idea about how to solve this?
    The conclusion is that I'm stuck with two possible solutions none of them working.
    Maybe there's a more simple solution that I didn't think about?
    Solutions to these problems?
    Any different proposals?
    Thanks in advance for any tip or help!
    Note: I titled the thread as Windows Vista, 7 & 8 since I assume all of them asks for admin rights when changing IPs. In case there are other people with the same problem, altough right now I'm only using XP & 7.
    Alejandro Asensio, CLAD

    First question: Why do you have to change OS properties via a custom application? I know such requirements can exist (sigh...) but nevertheless it seems a little bit weird to me ;-)
    OK, now an idea:
    Run cmd.exe via task scheduler. Here is a how to do it: http://maximumpcguides.com/windows-vista/run-a-pro​gram-with-administrative-privileges-without-uac-pr​...

  • Multiple NICs, same subnet

    I am building a test device requiring 6 IP addresses on the same subnet, unique 4th octets (xxx.xxx.xxx.101,102,103,...).  I am using 6 pxi 8231 NICs., 8108 controller, and 1045 PXI chaasis.  MAX will allow the target to configure 3 channels with an odd 4th octet, using 255.255.255.254.  The even IP addresses are disabled with the message one device per subnet.  The mask 255.255.255.255 is defined as an invalid mask by MAX.  Are there any suggestions to resolve this?  Can it be done using a hub or switch and a single card  (NIC)by tricking up the mask (255.255.255.0)?  I have also attempted this programmatically but could not confirm the IP addresses that have been set on the NICS
    Thanks,
    Phil.

    The use of the 255.255.255.254 was recommended by the NI engineer who is attempting to help me resolve this problem.  I have attempted to use several masks without success.  I understand the mask is currently inhibiting my ability to load the even ip addresses. 

  • Why is the first address on a subnet reserved?

    Based on subnetting, the "all 1s" or last address in a subnet is the broadcast address.  Why is the "all 0s" or first address reserved?  About all I can find on the web is that "way back in time" it was also a broadcast address of some type.  Is there current programmatic reasons, or just convention to reserve the first address of a subnet?  Is there something I can see with a wireshark trace?  I happen to run into a situation recently where a host was in fact using the resevered first address both on net and across the router, apparently without issues.  Links to documentation appreciated.  Thanks.

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    I'll try again - maybe this time I'll be helpful.
    Beginning with very early RFCs, all zeros was recommended to represent "this".  So an IP address with an all-zeros host bits, such as this Class C, 192.168.1.0 would mean "this network", 192.168.1.
    Hosts were not to be assigned all zeros as a host number so they wouldn't be confused with a (sub)network number.  I.e., if you use 192.168.1.0 as either a source or destination IP it could have special meaning (just as the all ones host is used for broadcasts).  As far as I can tell, little if anything used this special designation (except for some old Unix implementations that could use all zeros as the broadcast address).
    However, with RFC 3021, allowing for /31s for P2P links, the all zeros and all one host bits denote hosts.  This RFC does has some interesting things to say about how all zero host IPs should be treated:
    (h)  { , , 0 }
             Subnetwork number.  SHOULD NOT be used as a source address,
             except when the originator is one of the endpoints of a point-
             to-point link with a 31-bit mask.  For other types of links, a
             packet with such a destination SHOULD be silently discarded.
             If these packets are not silently discarded, they MUST be treated
             as IP broadcasts [RFC1812].
    (f)  { , , 0 }
             Subnetwork number.  SHOULD NOT be used as a source address,
             except when the originator is one of the endpoints of a point-
             to-point link with a 31-bit mask.  For other types of links, a
             packet with such a destination SHOULD be silently discarded.
             If these packets are not silently discarded, they MUST be
             treated as IP broadcasts.
          (2) SHOULD silently discard on receipt (i.e., do not even deliver
          to applications in the router) any packet addressed to 0.0.0.0 or
          { , 0 }.  If these packets are not silently
          discarded, they MUST be treated as IP broadcasts (see Section
          [5.3.5]).  There MAY be a configuration option to allow receipt of
          these packets.  This option SHOULD default to discarding them.
          In a point-to-point link with a 31-bit mask, a packet addressed to
          { , 0 } corresponds to one of the endpoints of
          such link, it MUST be treated as directed to the router on which
          the address is applied.
          (4) SHOULD NOT originate datagrams addressed to 0.0.0.0 or {
          , 0 }.  There MAY be a configuration option to
          allow generation of these packets (instead of using the relevant
          1s format broadcast).  This option SHOULD default to not
          generating them.
          In a point-to-point link with a 31-bit mask, the configuration of
          such a mask SHOULD allow for the generation of datagrams addressed
          to { , 0 }.
    With RFC 3021 (if I'm reading the above correctly), except for /31 P2P IPs, this shouldn't work, but the fact you've found it does, is likely due to most IP implementations not treating the all zeros host bits IP address as directed, above, but just as like another host IP.  Again, if nothing really has used this special case, it simplifies the IP implementation.
    In the above, technically, changing destination {, 0} as a MUST broadcast, should allow destination host to receive packet anyway.
    Rule 4 is also interesting, as it assumes only /31 hosts can send to all zero hosts.  This would be impossible to control if you don't know what the destination network-prefix is, and often only the destination truly knows.
    Disclaimer
    The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.
    Liability Disclaimer
    In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.
    Posting
    I'll try again

  • Airprint in the Enterprise across subnets [Solution]

    This is a message to help folks figure out how to setup
    Airprint across wired/wireless subnets. Hopefully it will help a few people.
    Airprint was designed to work with Bonjour on a local subnet/broadcast domain.
    To print in the enterprise where we have wired/wireless infrastructure,
    we need to use a DNS server to find the printer resources
    Assumptions:
    Our internal domain is: foocompany.com
    We create a new subdomain: bonjour.foocompany.com
    Creating a new subdomain allows up to apply DNS views so we can show print/bonjour services in
    close proximity of the user.
    You have a CUPS printer server (linux/apple) running at printserver.bonjour.foocompany.com
    1. Setup a DNS server
    If you setting up a test domain server, you can setup forwarding to your primary production server.
    This way all DNS queries continue to work
    In your named.conf file setup forwarding
    options {
    forwarders { YOURTOPNAMESERVER_IPADDR; YOURTOPNAMESERVER_IPADDR2; };
    forward first;
    allow-query-cache { any; }; // Allow client queries from other subnet to query from cache
    Create a new zone, "bonjour.foocompany.com"
    zone "bonjour.foocompany.com." { type master; file "/etc/bind/db.home"; };
    zone "foocompany.com" { type forward; forward only; forwarders { YOURTOPNAMESERVER_IPADDR; YOURTOPNAMESERVER_IPADDR2; }; };
    Create the following entries to support bonjour browsing
    #=======DNS====Begin======
    lb.dns-sd.udp IN PTR @
    b.dns-sd.udp IN PTR @
    dr.dns-sd.udp IN PTR @
    db.dns-sd.udp IN PTR @
    cf.dns-sd.udp IN PTR @
    printserver IN A 10.47.203.188
    # For every printer queue defined at the printer server you need to create a TXT and SRV entry
    # The visual printer name that show up in the iOS listbox will be the part before .ipp.tcp, example "hpv8a", "hpv8acolor"
    # _ipp and _printer seem to be equivalents, either seem to work on iOS.
    # Printer 1
    cups._sub._ipp.tcp IN PTR hpv8a.ipp.tcp
    universal._sub._ipp.tcp IN PTR hpv8a.ipp.tcp
    #Printer 2
    cups._sub._ipp.tcp IN PTR hpv8acolor.printer.tcp
    universal._sub._ipp.tcp IN PTR hpv8acolor.printer.tcp
    hpv8a.ipp.tcp IN SRV 0 0 631 printserver
    hpv8acolor.printer.tcp IN SRV 0 0 631 printserver
    # The "adminurl" points to the printer queue url on the CUPS server
    # The "rp" key points to the queue name as well
    hpv8a.ipp.tcp IN TXT ( "txtvers=1" "qtotl=1" "rp=printers/V8A08A246LJ" "adminurl=http://printserver:631/printers/V8A_08A24
    6_LJ" "ty=HP Laserjet V8A" "product=(HP LaserJet 4200)" "transparent=t" "copies=t" "duplex=t" "color=f" "pdl=application/octet-stream,
    application/pdf,application/postscript,image/jpeg,image/png,image/urf" "URF=W8,SRGB24,CP1,RS600" )
    hpv8acolor.printer.tcp IN TXT ( "txtvers=1" "qtotl=1" "rp=printers/V8A08A246_ColorLJ" "adminurl=http://printserver:
    631/printers/V8A08A246_ColorLJ" "ty=HP Laserjet V8A Color" "product=(HP color LaserJet 4650)" "transparent=t" "copies=t" "duplex=t" "
    color=t" "pdl=application/octet-stream,application/pdf,application/postscript,image/jpeg ,image/png,image/urf" "printer-type=0x801046" "URF=
    W8,SRGB24,CP1,RS600" )
    ####Printer TEMPLATE
    #cups._sub._ipp.tcp IN PTR NAMEX.printer.tcp
    #universal._sub._ipp.tcp IN PTR NAMEX.printer.tcp
    #NAMEX.ipp.tcp IN SRV 0 0 631 PRINTSERVERDNSNAME
    #NAMEX.ipp.tcp IN TXT ( "txtvers=1" "qtotl=1" "rp=printers/QUEUENAME"
    # "adminurl=http://PRINTSERVERDNSNAME:631/printers/QUEUENAME"
    # "ty=Printer name"
    # "product=(Printer PPD model line)" "transparent=t" "copies=t" "duplex=t" "color=f"
    # "pdl=application/octet-stream,application/pdf,application/postscript,image/jpeg ,image/png,image/urf"
    # "URF=W8,SRGB24,CP1,RS600" )
    #=======DNS====End======
    2. Setup CUPS
    Add printers to the CUPS server.
    Enable access to the printer queue from remote machines,
    GUI: "System->Admin->Printing->Server->Server Setting: Allow printing from the internet"
    Also make sure the following lines are present in /etc/cups/cupsd.conf
    # Allow remote access
    Port 631
    Listen /var/run/cups/cups.sock
    AccessLog syslog
    AccessLogLevel all
    LogLevel debug
    MaxLogSize 0
    SystemGroup lpadmin
    # Enable printer sharing and shared printers.
    Browsing On
    BrowseOrder allow,deny
    BrowseAllow all
    BrowseRemoteProtocols CUPS
    BrowseAddress @LOCAL
    BrowseLocalProtocols CUPS dnssd
    BrowseProtocols all
    DefaultAuthType Basic
    3. Change iPAD configs
    Add your DNS server as the first DNS server in the network settting page.
    Add "bonjour.foocompany.com" to the DNS domains to search
    4. Test printing
    Open up Photos application.
    Select a picture
    Select "Send To->Print"
    Select "Printer", now a list of printer names should show up as defined in the DNS server
    Select a printer and hit "Print"
    Fast task switch to Print Center to verify print job is being sent
    Thanks
    Ashish Desai
    Security Architect
    Fidelity Investments
    email: [email protected]

    Update for ios 8:
    With ios 8 it appears that _printer and _ipp are no longer equivalent. For this to work it looks like you have to use _ipp._tcp
    Also - the underscore characters are important and they are missing from the example above.
    Last - you can use the "note" field to add a second line that is displayed in smaller text below the printer name in ios 8.
    Here is an updated template:
    ####Printer TEMPLATE
    cups._sub._ipp._tcp IN PTR NAMEX._ipp._tcp
    universal._sub._ipp._tcp IN PTR NAMEX._ipp._tcp
    NAMEX._ipp._tcp IN SRV 0 0 631 PRINTSERVERDNSNAME
    NAMEX._ipp._tcp IN TXT ( "txtvers=1" "qtotl=1" "rp=printers/QUEUENAME"
    "adminurl=http://PRINTSERVERDNSNAME:631/printers/QUEUENAME"
    "note=more info about printer"
    "ty=Printer name"
    "product=(Printer PPD model line)" "transparent=t" "copies=t" "duplex=t" "color=f"
    "pdl=application/octet-stream,application/pdf,application/postscript,image/jpeg ,image/png,image/urf"
    "URF=W8,SRGB24,CP1,RS600" )

  • Get column values from list of values programmatically

    hi all
    how i get column values from list of values programmatically in the
    returnPopupDataListener method

    If this answers your question , please close this thread by marking it as answered.
    Thanks

  • Cisco ASA 5505 site to site Multiple subnet.

    Hi. I need some help configuring my cisco asa 5505.
    I've set up a VPN tunnel between two ASA 5505
    Site 1:
    Subnet 192.168.77.0
    Site 2:
    Have multiple vlans and now the tunnel goes to vlan400 - 192.168.1.0
    What I need help with:
    From site 1 i need to be able to reach another vlan on site 2. vlan480 - 192.168.20.0
    And from site 1 I need to reach 192.168.77.0 subnet from vlan480 - 192.168.20.0
    Vlan480 is used for phones. In vlan480 we have a PABX central.
    Is this possible to do?
    Any help would be greatfully appreciated!
    Config site 2:
    : Saved
    ASA Version 7.2(2)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password x encrypted
    names
    name 192.168.1.250 DomeneServer
    name 192.168.1.10 NotesServer
    name 192.168.1.90 OvServer
    name 192.168.1.97 TerminalServer
    name 192.168.1.98 w8-eyeshare
    name 192.168.50.10 w8-print
    name 192.168.1.94 w8-app
    name 192.168.1.89 FonnaFlyMedia
    interface Vlan1
    nameif Vlan1
    security-level 100
    ip address 192.168.200.100 255.255.255.0
    ospf cost 10
    interface Vlan2
    nameif outside
    security-level 0
    ip address 79.x.x.226 255.255.255.224
    ospf cost 10
    interface Vlan400
    nameif vlan400
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    ospf cost 10
    interface Vlan450
    nameif Vlan450
    security-level 100
    ip address 192.168.210.1 255.255.255.0
    ospf cost 10
    interface Vlan460
    nameif Vlan460-SuldalHotell
    security-level 100
    ip address 192.168.2.1 255.255.255.0
    ospf cost 10
    interface Vlan461
    nameif Vlan461-SuldalHotellGjest
    security-level 100
    ip address 192.168.3.1 255.255.255.0
    ospf cost 10
    interface Vlan462
    nameif Vlan462-Suldalsposten
    security-level 100
    ip address 192.168.4.1 255.255.255.0
    ospf cost 10
    interface Vlan470
    nameif vlan470-Kyrkjekontoret
    security-level 100
    ip address 192.168.202.1 255.255.255.0
    ospf cost 10
    interface Vlan480
    nameif vlan480-Telefoni
    security-level 100
    ip address 192.168.20.1 255.255.255.0
    ospf cost 10
    interface Vlan490
    nameif Vlan490-QNapBackup
    security-level 100
    ip address 192.168.10.1 255.255.255.0
    ospf cost 10
    interface Vlan500
    nameif Vlan500-HellandBadlands
    security-level 100
    ip address 192.168.30.1 255.255.255.0
    ospf cost 10
    interface Vlan510
    nameif Vlan510-IsTak
    security-level 100
    ip address 192.168.40.1 255.255.255.0
    ospf cost 10
    interface Vlan600
    nameif Vlan600-SafeQ
    security-level 100
    ip address 192.168.50.1 255.255.255.0
    ospf cost 10
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    switchport access vlan 500
    switchport trunk allowed vlan 400,450,460-462,470,480,500,510,600,610
    switchport mode trunk
    interface Ethernet0/3
    switchport access vlan 490
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    passwd x encrypted
    ftp mode passive
    clock timezone WAT 1
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group service Lotus_Notes_Utgaaande tcp
    description Frim Notes og ut til alle
    port-object eq domain
    port-object eq ftp
    port-object eq www
    port-object eq https
    port-object eq lotusnotes
    port-object eq pop3
    port-object eq pptp
    port-object eq smtp
    object-group service Lotus_Notes_inn tcp
    description From alle og inn til Notes
    port-object eq www
    port-object eq lotusnotes
    port-object eq pop3
    port-object eq smtp
    object-group service Reisebyraa tcp-udp
    port-object range 3702 3702
    port-object range 5500 5500
    port-object range 9876 9876
    object-group service Remote_Desktop tcp-udp
    description Tilgang til Remote Desktop
    port-object range 3389 3389
    object-group service Sand_Servicenter_50000 tcp-udp
    description Program tilgang til Sand Servicenter AS
    port-object range 50000 50000
    object-group service VNC_Remote_Admin tcp
    description Frå oss til alle
    port-object range 5900 5900
    object-group service Printer_Accept tcp-udp
    port-object range 9100 9100
    port-object eq echo
    object-group icmp-type Echo_Ping
    icmp-object echo
    icmp-object echo-reply
    object-group service Print tcp
    port-object range 9100 9100
    object-group service FTP_NADA tcp
    description Suldalsposten NADA tilgang
    port-object eq ftp
    port-object eq ftp-data
    object-group service Telefonsentral tcp
    description Hoftun
    port-object eq ftp
    port-object eq ftp-data
    port-object eq www
    port-object eq https
    port-object eq telnet
    object-group service Printer_inn_800 tcp
    description Fra 800  nettet og inn til 400 port 7777
    port-object range 7777 7777
    object-group service Suldalsposten tcp
    description Sending av mail vha Mac Mail programmet - åpner smtp
    port-object eq pop3
    port-object eq smtp
    object-group service http2 tcp
    port-object range 81 81
    object-group service DMZ_FTP_PASSIVE tcp-udp
    port-object range 55536 56559
    object-group service DMZ_FTP tcp-udp
    port-object range 20 21
    object-group service DMZ_HTTPS tcp-udp
    port-object range 443 443
    object-group service DMZ_HTTP tcp-udp
    port-object range 8080 8080
    object-group service DNS_Query tcp
    port-object range domain domain
    object-group service DUETT_SQL_PORT tcp-udp
    description For kobling mellom andre nett og duett server
    port-object range 54659 54659
    access-list outside_access_in extended permit ip any any
    access-list outside_access_out extended permit ip any any
    access-list vlan400_access_in extended deny ip any host 149.20.56.34
    access-list vlan400_access_in extended deny ip any host 149.20.56.32
    access-list vlan400_access_in extended permit ip any any
    access-list Vlan450_access_in extended deny ip any host 149.20.56.34
    access-list Vlan450_access_in extended deny ip any host 149.20.56.32
    access-list Vlan450_access_in extended permit ip any any
    access-list Vlan460_access_in extended deny ip any host 149.20.56.34
    access-list Vlan460_access_in extended deny ip any host 149.20.56.32
    access-list Vlan460_access_in extended permit ip any any
    access-list vlan400_access_out extended permit icmp any any object-group Echo_Ping
    access-list vlan400_access_out extended permit tcp any host NotesServer object-group Lotus_Notes_Utgaaande
    access-list vlan400_access_out extended permit tcp any host DomeneServer object-group Remote_Desktop
    access-list vlan400_access_out extended permit tcp any host TerminalServer object-group Remote_Desktop
    access-list vlan400_access_out extended permit tcp any host OvServer object-group http2
    access-list vlan400_access_out extended permit tcp any host NotesServer object-group Lotus_Notes_inn
    access-list vlan400_access_out extended permit tcp any host NotesServer object-group Remote_Desktop
    access-list vlan400_access_out extended permit tcp any host w8-eyeshare object-group Remote_Desktop
    access-list vlan400_access_out extended permit tcp any host w8-app object-group Remote_Desktop
    access-list vlan400_access_out extended permit tcp any host FonnaFlyMedia range 8400 8600
    access-list vlan400_access_out extended permit udp any host FonnaFlyMedia range 9000 9001
    access-list vlan400_access_out extended permit tcp 192.168.4.0 255.255.255.0 host DomeneServer
    access-list vlan400_access_out extended permit tcp 192.168.4.0 255.255.255.0 host w8-app object-group DUETT_SQL_PORT
    access-list Vlan500_access_in extended deny ip any host 149.20.56.34
    access-list Vlan500_access_in extended deny ip any host 149.20.56.32
    access-list Vlan500_access_in extended permit ip any any
    access-list vlan470_access_in extended deny ip any host 149.20.56.34
    access-list vlan470_access_in extended deny ip any host 149.20.56.32
    access-list vlan470_access_in extended permit ip any any
    access-list Vlan490_access_in extended deny ip any host 149.20.56.34
    access-list Vlan490_access_in extended deny ip any host 149.20.56.32
    access-list Vlan490_access_in extended permit ip any any
    access-list Vlan450_access_out extended permit icmp any any object-group Echo_Ping
    access-list Vlan1_access_out extended permit ip any any
    access-list Vlan1_access_out extended permit tcp any host w8-print object-group Remote_Desktop
    access-list Vlan1_access_out extended deny ip any any
    access-list Vlan1_access_out extended permit icmp any any echo-reply
    access-list Vlan460_access_out extended permit icmp any any object-group Echo_Ping
    access-list Vlan490_access_out extended permit icmp any any object-group Echo_Ping
    access-list Vlan490_access_out extended permit tcp any host 192.168.10.10 object-group DMZ_FTP
    access-list Vlan490_access_out extended permit tcp any host 192.168.10.10 object-group DMZ_FTP_PASSIVE
    access-list Vlan490_access_out extended permit tcp any host 192.168.10.10 object-group DMZ_HTTPS
    access-list Vlan490_access_out extended permit tcp any host 192.168.10.10 object-group DMZ_HTTP
    access-list Vlan500_access_out extended permit icmp any any object-group Echo_Ping
    access-list vlan470_access_out extended permit icmp any any object-group Echo_Ping
    access-list vlan470_access_out extended permit tcp any host 192.168.202.10 object-group Remote_Desktop
    access-list Vlan510_access_out extended permit icmp any any object-group Echo_Ping
    access-list vlan480_access_out extended permit ip any any
    access-list Vlan510_access_in extended permit ip any any
    access-list Vlan600_access_in extended permit ip any any
    access-list Vlan600_access_out extended permit icmp any any
    access-list Vlan600_access_out extended permit tcp any host w8-print object-group Remote_Desktop
    access-list Vlan600_access_out extended permit tcp 192.168.1.0 255.255.255.0 host w8-print eq www
    access-list Vlan600_access_out extended permit tcp 192.168.202.0 255.255.255.0 host w8-print eq www
    access-list Vlan600_access_out extended permit tcp 192.168.210.0 255.255.255.0 host w8-print eq www
    access-list Vlan600_access_in_1 extended permit ip any any
    access-list Vlan461_access_in extended permit ip any any
    access-list Vlan461_access_out extended permit icmp any any object-group Echo_Ping
    access-list vlan400_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.77.0 255.255.255.0
    access-list outside_20_cryptomap_1 extended permit ip 192.168.1.0 255.255.255.0 192.168.77.0 255.255.255.0
    access-list outside_20_cryptomap extended permit ip 192.168.1.0 255.255.255.0 192.168.77.0 255.255.255.0
    access-list Vlan462-Suldalsposten_access_in extended permit ip any any
    access-list Vlan462-Suldalsposten_access_out extended permit icmp any any echo-reply
    access-list Vlan462-Suldalsposten_access_out_1 extended permit icmp any any echo-reply
    access-list Vlan462-Suldalsposten_access_in_1 extended permit ip any any
    pager lines 24
    logging enable
    logging asdm informational
    mtu Vlan1 1500
    mtu outside 1500
    mtu vlan400 1500
    mtu Vlan450 1500
    mtu Vlan460-SuldalHotell 1500
    mtu Vlan461-SuldalHotellGjest 1500
    mtu vlan470-Kyrkjekontoret 1500
    mtu vlan480-Telefoni 1500
    mtu Vlan490-QNapBackup 1500
    mtu Vlan500-HellandBadlands 1500
    mtu Vlan510-IsTak 1500
    mtu Vlan600-SafeQ 1500
    mtu Vlan462-Suldalsposten 1500
    no failover
    monitor-interface Vlan1
    monitor-interface outside
    monitor-interface vlan400
    monitor-interface Vlan450
    monitor-interface Vlan460-SuldalHotell
    monitor-interface Vlan461-SuldalHotellGjest
    monitor-interface vlan470-Kyrkjekontoret
    monitor-interface vlan480-Telefoni
    monitor-interface Vlan490-QNapBackup
    monitor-interface Vlan500-HellandBadlands
    monitor-interface Vlan510-IsTak
    monitor-interface Vlan600-SafeQ
    monitor-interface Vlan462-Suldalsposten
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-522.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (vlan400) 0 access-list vlan400_nat0_outbound
    nat (vlan400) 1 0.0.0.0 0.0.0.0 dns
    nat (Vlan450) 1 0.0.0.0 0.0.0.0 dns
    nat (Vlan460-SuldalHotell) 1 0.0.0.0 0.0.0.0
    nat (Vlan461-SuldalHotellGjest) 1 0.0.0.0 0.0.0.0
    nat (vlan470-Kyrkjekontoret) 1 0.0.0.0 0.0.0.0
    nat (Vlan490-QNapBackup) 1 0.0.0.0 0.0.0.0 dns
    nat (Vlan500-HellandBadlands) 1 0.0.0.0 0.0.0.0
    nat (Vlan510-IsTak) 1 0.0.0.0 0.0.0.0
    nat (Vlan600-SafeQ) 1 0.0.0.0 0.0.0.0
    nat (Vlan462-Suldalsposten) 1 0.0.0.0 0.0.0.0
    static (vlan400,outside) 79.x.x.x DomeneServer netmask 255.255.255.255
    static (vlan470-Kyrkjekontoret,outside) 79.x.x.x 192.168.202.10 netmask 255.255.255.255
    static (vlan400,outside) 79.x.x.x NotesServer netmask 255.255.255.255 dns
    static (vlan400,outside) 79.x.x.231 TerminalServer netmask 255.255.255.255
    static (vlan400,outside) 79.x.x.234 OvServer netmask 255.255.255.255
    static (vlan400,outside) 79.x.x.232 w8-eyeshare netmask 255.255.255.255
    static (Vlan490-QNapBackup,outside) 79.x.x.233 192.168.10.10 netmask 255.255.255.255 dns
    static (Vlan600-SafeQ,outside) 79.x.x.235 w8-print netmask 255.255.255.255
    static (vlan400,outside) 79.x.x.236 w8-app netmask 255.255.255.255
    static (Vlan450,vlan400) 192.168.210.0 192.168.210.0 netmask 255.255.255.0
    static (Vlan500-HellandBadlands,vlan400) 192.168.30.0 192.168.30.0 netmask 255.255.255.0
    static (vlan400,Vlan500-HellandBadlands) 192.168.1.0 192.168.1.0 netmask 255.255.255.0
    static (vlan400,Vlan450) 192.168.1.0 192.168.1.0 netmask 255.255.255.0
    static (vlan400,outside) 79.x.x.252 FonnaFlyMedia netmask 255.255.255.255
    static (Vlan462-Suldalsposten,vlan400) 192.168.4.0 192.168.4.0 netmask 255.255.255.0
    static (vlan400,Vlan462-Suldalsposten) 192.168.1.0 192.168.1.0 netmask 255.255.255.0
    static (vlan400,Vlan600-SafeQ) 192.168.1.0 192.168.1.0 netmask 255.255.255.0
    static (Vlan600-SafeQ,vlan400) 192.168.50.0 192.168.50.0 netmask 255.255.255.0
    static (Vlan600-SafeQ,Vlan450) 192.168.50.0 192.168.50.0 netmask 255.255.255.0
    static (Vlan600-SafeQ,vlan470-Kyrkjekontoret) 192.168.50.0 192.168.50.0 netmask 255.255.255.0
    static (Vlan450,Vlan600-SafeQ) 192.168.210.0 192.168.210.0 netmask 255.255.255.0
    static (vlan470-Kyrkjekontoret,Vlan600-SafeQ) 192.168.202.0 192.168.202.0 netmask 255.255.255.0
    access-group Vlan1_access_out out interface Vlan1
    access-group outside_access_in in interface outside
    access-group outside_access_out out interface outside
    access-group vlan400_access_in in interface vlan400
    access-group vlan400_access_out out interface vlan400
    access-group Vlan450_access_in in interface Vlan450
    access-group Vlan450_access_out out interface Vlan450
    access-group Vlan460_access_in in interface Vlan460-SuldalHotell
    access-group Vlan460_access_out out interface Vlan460-SuldalHotell
    access-group Vlan461_access_in in interface Vlan461-SuldalHotellGjest
    access-group Vlan461_access_out out interface Vlan461-SuldalHotellGjest
    access-group vlan470_access_in in interface vlan470-Kyrkjekontoret
    access-group vlan470_access_out out interface vlan470-Kyrkjekontoret
    access-group vlan480_access_out out interface vlan480-Telefoni
    access-group Vlan490_access_in in interface Vlan490-QNapBackup
    access-group Vlan490_access_out out interface Vlan490-QNapBackup
    access-group Vlan500_access_in in interface Vlan500-HellandBadlands
    access-group Vlan500_access_out out interface Vlan500-HellandBadlands
    access-group Vlan510_access_in in interface Vlan510-IsTak
    access-group Vlan510_access_out out interface Vlan510-IsTak
    access-group Vlan600_access_in_1 in interface Vlan600-SafeQ
    access-group Vlan600_access_out out interface Vlan600-SafeQ
    access-group Vlan462-Suldalsposten_access_in_1 in interface Vlan462-Suldalsposten
    access-group Vlan462-Suldalsposten_access_out_1 out interface Vlan462-Suldalsposten
    route outside 0.0.0.0 0.0.0.0 79.x.x.225 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout uauth 0:05:00 absolute
    username x password x encrypted privilege 15
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.210.0 255.255.255.0 Vlan450
    http 192.168.200.0 255.255.255.0 Vlan1
    http 192.168.1.0 255.255.255.0 vlan400
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto map outside_map 20 match address outside_20_cryptomap_1
    crypto map outside_map 20 set pfs
    crypto map outside_map 20 set peer 62.92.159.137
    crypto map outside_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp enable vlan400
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    tunnel-group 62.92.159.137 type ipsec-l2l
    tunnel-group 62.92.159.137 ipsec-attributes
    pre-shared-key *
    telnet 192.168.200.0 255.255.255.0 Vlan1
    telnet 192.168.1.0 255.255.255.0 vlan400
    telnet timeout 5
    ssh 171.68.225.216 255.255.255.255 outside
    ssh timeout 5
    console timeout 0
    dhcpd update dns both
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface Vlan1
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface outside
    dhcpd address 192.168.1.100-192.168.1.225 vlan400
    dhcpd option 6 ip DomeneServer 81.167.36.11 interface vlan400
    dhcpd option 3 ip 192.168.1.1 interface vlan400
    dhcpd enable vlan400
    dhcpd address 192.168.210.100-192.168.210.200 Vlan450
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface Vlan450
    dhcpd option 3 ip 192.168.210.1 interface Vlan450
    dhcpd enable Vlan450
    dhcpd address 192.168.2.100-192.168.2.150 Vlan460-SuldalHotell
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface Vlan460-SuldalHotell
    dhcpd option 3 ip 192.168.2.1 interface Vlan460-SuldalHotell
    dhcpd enable Vlan460-SuldalHotell
    dhcpd address 192.168.3.100-192.168.3.200 Vlan461-SuldalHotellGjest
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface Vlan461-SuldalHotellGjest
    dhcpd option 3 ip 192.168.3.1 interface Vlan461-SuldalHotellGjest
    dhcpd enable Vlan461-SuldalHotellGjest
    dhcpd address 192.168.202.100-192.168.202.199 vlan470-Kyrkjekontoret
    dhcpd option 3 ip 192.168.202.1 interface vlan470-Kyrkjekontoret
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface vlan470-Kyrkjekontoret
    dhcpd enable vlan470-Kyrkjekontoret
    dhcpd option 3 ip 192.168.20.1 interface vlan480-Telefoni
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface vlan480-Telefoni
    dhcpd address 192.168.10.80-192.168.10.90 Vlan490-QNapBackup
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface Vlan490-QNapBackup
    dhcpd option 3 ip 192.168.10.1 interface Vlan490-QNapBackup
    dhcpd address 192.168.30.100-192.168.30.199 Vlan500-HellandBadlands
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface Vlan500-HellandBadlands
    dhcpd option 3 ip 192.168.30.1 interface Vlan500-HellandBadlands
    dhcpd enable Vlan500-HellandBadlands
    dhcpd address 192.168.40.100-192.168.40.150 Vlan510-IsTak
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface Vlan510-IsTak
    dhcpd option 3 ip 192.168.40.1 interface Vlan510-IsTak
    dhcpd enable Vlan510-IsTak
    dhcpd address 192.168.50.150-192.168.50.199 Vlan600-SafeQ
    dhcpd option 6 ip 81.167.36.3 81.167.36.11 interface Vlan600-SafeQ
    dhcpd enable Vlan600-SafeQ
    dhcpd address 192.168.4.100-192.168.4.150 Vlan462-Suldalsposten
    dhcpd option 6 ip DomeneServer 81.167.36.11 interface Vlan462-Suldalsposten
    dhcpd option 3 ip 192.168.4.1 interface Vlan462-Suldalsposten
    dhcpd enable Vlan462-Suldalsposten
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    prompt hostname context
    Cryptochecksum:x
    : end
    Config site 1:
    : Saved
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password x encrypted
    passwd x encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.77.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group Telenor
    ip address pppoe setroute
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    switchport access vlan 15
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    access-list outside_access_in extended permit icmp any any echo-reply log disable
    access-list outside_1_cryptomap extended permit ip 192.168.77.0 255.255.255.0 192.168.1.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.77.0 255.255.255.0 192.168.1.0 255.255.255.0
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable
    http 192.168.77.0 255.255.255.0 inside
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set pfs
    crypto map outside_map 1 set peer 79.160.252.226
    crypto map outside_map 1 set transform-set ESP-3DES-SHA
    crypto map outside_map interface outside
    crypto isakmp enable inside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet 192.168.77.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    vpdn group Telenor request dialout pppoe
    vpdn group Telenor localname x
    vpdn group Telenor ppp authentication chap
    vpdn username x password x store-local
    dhcpd auto_config outside
    dhcpd address 192.168.77.100-192.168.77.130 inside
    dhcpd dns 192.168.77.1 interface inside
    dhcpd option 6 ip 130.67.15.198 193.213.112.4 interface inside
    dhcpd enable inside
    dhcpd option 6 ip 130.67.15.198 193.213.112.4 interface outside
    tunnel-group 79.160.252.226 type ipsec-l2l
    tunnel-group 79.160.252.226 ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:x
    : end

    Hi,
    The addition of a new network to the existing L2L VPN should be a pretty simple process.
    Essentially you will have to add the network to the Crypto ACL present in the "crypto map" configurations. You will also have to configure the NAT0 configuration for it in the proper interfaces of the ASA. These configurations are all done on both ends of the L2L VPN connection.
    Looking at your above configurations it would seem that you will need the following configurations
    SITE 1
    We add the new network to both the crypto ACL and the NAT0 ACL
    access-list outside_1_cryptomap extended permit ip 192.168.77.0 255.255.255.0 192.168.20.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.77.0 255.255.255.0 192.168.20.0 255.255.255.0
    SITE 2
    We add the new network to the crypto ACL
    We create a new NAT0 configuration for the Vlan480 interface as it has no previous NAT0 configuration
    access-list outside_20_cryptomap_1 extended permit ip 192.168.20.0 255.255.255.0 192.168.77.0 255.255.255.0
    access-list VLAN480-NAT0 remark NAT0 for VPN
    access-list VLAN480-NAT0 permit ip 192.168.20.0 255.255.255.0 192.168.77.0 255.255.255.0
    nat (vlan480-Telefoni) 0 access-list VLAN480-NAT0
    These configurations should pretty much do the trick.
    Let me know if it worked
    - Jouni

  • I am trying to connect Dashboard shared variables to a server on a different subnet. Any ideas?

    My goal is to control a device that is connected to our wired network using an Android tablet via Dashboard.  I have created a vi with shared variables that controls the device as expected when it runs on a computer that is connected to the same wired network.  The problem is that my Android tablet running the Dashboard app cannot connect to the shared variables on the PC running the vi on the wired network.
    Our wireless network is on a separate subnet from our wired network.  I am able to ping my Android tablet from the PC on the wired network but when I try to connect a variable in Dashboard, the PC running the SVE cannot be found.  I tried listing it in the alternative server settings window and it still did not work.  The only way I have been able to get around this is to run the vi which launches the server on a laptop that is connected to the wireless network and the wired network at the same time.  My tablet can then find the server and my VI can connect to the instrument that is connected to the wired network.  The laptop is somehow acting as a bridge between the subnets.  I need to find a way for the Dashboard app to connect directly to the PC on the wired network.  My PC IP address is 192.168.0.105.  My Android IP address is 192.168.10.93.

    Data Dashboard doesn't care about subnets, but it has to be able to access the server using the right ports. There is probably a firewall blocking the shared variable ports. This document explains how to configure a firewall to allow shared variables to be accessed. Your challenge will probably be to figure out where the firewall is and how to configure it.
    It is also possible that the router that your Android device is connected to doesn't know how to route to the other network. Again, that is an issue with your router that you need to resolve.

  • Error in Updating a Result Set Programmatically

    Could anyone please help me !
    Why the row is always corrupted after executing the following code.
    I am using JDK 1.4 , the default JDBC:ODBC driver from sun and MS Access 2000
    try
    rs.updateString(1,jtfCity.getText().trim());
    rs.updateString(2,jtfCountry.getText().trim());
    rs.updateInt(3,Integer.parseInt(jtfPop1995.getText().trim()));
    rs.updateInt(4,Integer.parseInt(jtfPop2015.getText().trim()));
    rs.updateRow();
    catch(SQLException sqle)
    System.err.println("Error in update row");
    System.err.println(sqle);
    System.err.println(sqle.getMessage());
    System.err.println(""+sqle.getErrorCode());          

    Thanks for replying
    This is what I get:
    java.sql.SQLException:[Microsoft][odbc Microsoft Access Driver]
    Let me give you more background information. I am new in JDBC and is learning it by going through the examples in "JDBC API Tutorial and Reference 2nd Ed." published by SUN. I am using sdk1.31 (and have also tried sdk1.4) with Microsoft Access 2000. The demo program I am working with is trying to update a ResultSet programmatically using updateXXX().
    scrolling and row deletion using rs.delete() are ok.
    Here are my connection statements:
    Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
              connection = DriverManager.getConnection(sourceURL);
              statement = connection.createStatement(     ResultSet.TYPE_SCROLL_SENSITIVE,
                                                                ResultSet.CONCUR_UPDATABLE);

  • In our enterprise MPLS network we are using 192.168.20.0/24 subnet, in this subnet we have not assigned the IP 192.168.20.200/30 & 204/30, But still these subnets are reachable . Are these NNI IP ...Please explain.

    In our enterprise MPLS network we are using 192.168.20.0/24 subnet, in this subnet we have not assigned the IP 192.168.20.200/30 & 204/30, But still these subnets are reachable . Are these NNI IP ...Please explain.

    I have checked with ISP, there response is like below:
    Those are the NNI to GBNET IPs for Dominican Republic. They are Network IPs. You should be able to ping them-that means they are working.
    WANRT01#show  ip route | include 192.168.20.20
    B        192.168.20.200/30 [20/0] via 192.168.20.226, 02:18:29
    B        192.168.20.204/30 [20/0] via 192.168.20.226, 02:18:29
    Here its shows from any of our MPLS site we are able to trace the IP and it seems like, 192.168.20.204/30 is one more site but in actual its not.
    INMUMWANRT01#ping 192.168.20.205
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.20.205, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 224/232/260 ms
    INMUMWANRT01#trace              
    INMUMWANRT01#traceroute 192.168.20.205
    Type escape sequence to abort.
    Tracing the route to 192.168.20.205
    VRF info: (vrf in name/id, vrf out name/id)
      1 192.168.20.226 24 msec 24 msec 24 msec
      2 192.168.20.206 [AS 8035] 232 msec 232 msec 252 msec
      3 192.168.20.205 [AS 8035] 224 msec 224 msec *

  • Solution to use Airprint across subnets wired/wireless

    A lot of companies are trying to figure out how to setup airprint to print
    in the workplace, wired+wireless across subnets.
    We finally figured it out with some DNS magic and a CUPS server.
    I have documented the solution at a live document hosted at
    http://sites.google.com/site/iwastepaper/
    Hopefully it helps a few folks.
    <Edited by Host>

    You will want to make sure your APs can route from where ever you install them to the WLC managment address.
    How APs find the controller can happen a few different ways:
    1) DNS A record
    2) Layer 2 broadcast (which you seen already)
    3) IP Route Forward
    4) DHCP Option 43
    5) Manual Prime the AP
    Most folks lead with option 43.
    http://www.my80211.com/cisco-wlc-labs/2009/7/4/cisco-dhcp-option-43-configuration-nugget.html
    if you check the config guide you will explain the other processes.

  • NetBoot across subnets with a bootpd relay

    Hello Apple Community!
    I've got 4 subnets at my school, each with various Macs around campus.  I have a Mavericks server on each subnet currently, each with their own NetBoot images.  It's a pain to keep everything updated.  I can get a single client Mac (pre-2011) to boot across subnets using the bless command, but that's not really a viable solution for us to run a bless command on each client every single time we want to netboot.  So far, the solution has been just to have dedicated netboot servers on each subnet, but I know there has to be a better way.
    This article (OS X Server: How to use NetBoot across subnets - Apple Support) describes three different methods for netbooting across subnets, but two of them are not really viable for us.  Those involve reconfiguring the network to allow BootP data to pass across subnets or configuring one server with multiple network connections, one for each subnet.  However, option #2 describes configuring a bootpd relay.  Based on my reading, this sounds like exactly what I need.  However, I can't find any good documentation to walk me through setting it up.
    I've thoroughly read the bootpd man page, which has had me editing the /etc/bootpd.plist on multiple servers.  This hasn't gotten me very far.  My clients still don't see the remote NetBoot server.  It seems like the relay is supposed to redirect broadcasts from the remote Netboot server, through a local NetBoot server to the client.  But I have no idea how to make this work.
    Could someone please give me more guidance on what I'm supposed to be doing here?  I'd like to host a single NetBoot server and have any client on any subnet be able to option-boot to see the NetBoot startup options (I have multiple NetBoot images, from Apple Service Toolkit to DeployStudio and Mavericks/Yosemite installers in between).  Even if I could get it to just netboot to one default source (AST), I could deal with that.  I'm also happy to host multiple NetBoot servers, but with all my NetBoot images in one location.  I'm stumped in this multiple subnet environment and I need help.  Please help.

    Thanks again for your feedback.  I had forgotten I left the "tftp://" on the IP address.  Though, I've tried that multiple ways, starting with IP only.  Also, per the bootpd man page (https://developer.apple.com/library/mac/documentation/Darwin/Reference/ManPages/ man8/bootpd.8.html), <allow/> and <deny/> are lists for MAC address allowances and when nothing is defined everything goes through.  These are there by default, though I will remove them and see what happens.  Also, according to the man page, bootp_enabled enables on all connections when a boolean is set rather than an array.  Though I will still change this also and see what happens.  The array that comes after the netboot_disabled key is auto-generated by NetInstall when you turn the service on in Server.app.
    Essentially, that plist comes from a fresh activation of NetInstall.  I deleted the previous .plist, rebooted the server and when I turned on NetInstall, that's what was created, plus my bootp modifications.
    All that said, you said that you assumed I started the relay with the 'debug & logging' options enabled.  I haven't started the relay in any active sense.  So far, I've just been modifying this .plist, and rebooting a bunch of times, but that's where I seem to get lost.  Is there a way to actively "start" the relay?  I'd love to look at these 'debug & logging' options.  As for the 'Startup Disk' prefs on the client Mac, they do not show any significant change.  Basically, they just don't see the remote server as a startup option.  I have not gleaned any pertinent info from console, though I'm not sure I know what I'm looking for.
    On a side note, I had a wild hair to try something different.  I set my local subnet's server to look at a NetBootSP0 folder that was actually a symlink to a NetBootSP0 folder that was mounted as a file share from the remote NetBoot server.  This really looked like it might work.  When you boot the client, it saw the startup volumes from the remote server.  However, upon boot, it doesn't seem to make the connection and winds up booting back to the internal hard drive.  It was worth a try...

  • Jumpstart across subnets

    Hello
    I am having trouble configuring my jet toolkit to boot across subnets.
    It works fine in the same subnet but when it goes across subnets it seems to lose the default router for the client.
    {0} ok boot net:dhcp - install
    Resetting...
    POST Sequence 01 CPU Check
    POST Sequence 02 Banner
    LSB#00 (XSB#00-0): POST 2.12.0 (2009/09/09 15:17)
    POST Sequence 03 Fatal Check
    POST Sequence 04 CPU Register
    POST Sequence 05 STICK
    POST Sequence 06 MMU
    POST Sequence 07 Memory Initialize
    POST Sequence 08 Memory
    POST Sequence 09 Raw UE In Cache
    POST Sequence 0A Floating Point Unit
    POST Sequence 0B SC
    POST Sequence 0C Cacheable Instruction
    POST Sequence 0D Softint
    POST Sequence 0E CPU Cross Call
    POST Sequence 0F CMU-CH
    POST Sequence 10 PCI-CH
    POST Sequence 11 Master Device
    POST Sequence 12 DSCP
    POST Sequence 13 SC Check Before STICK Diag
    POST Sequence 14 STICK Stop
    POST Sequence 15 STICK Start
    POST Sequence 16 Error CPU Check
    POST Sequence 17 System Configuration
    POST Sequence 18 System Status Check
    POST Sequence 19 System Status Check After Sync
    POST Sequence 1A OpenBoot Start...
    POST Sequence Complete.
    Sun SPARC Enterprise M4000 Server, using Domain console
    Copyright 2009 Sun Microsystems, Inc. All rights reserved.
    Copyright 2009 Sun Microsystems, Inc. and Fujitsu Limited. All rights reserved.
    OpenBoot 4.24.12, 32768 MB memory installed, Serial #91113890.
    Ethernet address 0:21:28:6e:49:a2, Host ID: 856e49a2.
    Rebooting with command: boot net:dhcp - install
    Boot device: /pci@0,600000/pci@0/pci@8/pci@0/network@2:dhcp File and args: - install
    1000 Mbps full duplex Link up
    Timed out waiting for BOOTP/DHCP reply
    Timed out waiting for BOOTP/DHCP reply
    Timed out waiting for BOOTP/DHCP reply
    Timed out waiting for TFTP reply
    Timed out waiting for TFTP reply
    Timed out waiting for TFTP reply
    Timed out waiting for TFTP reply
    I have entered the router info in the defaultrouters file
    kenapps08g:global# cat defaultrouters
    # You can use this file to allow templates to be auto-populated with additional
    # default router settings, especially useful for managing large numbers o
    # server templates.
    # Format:
    # <subnet> <mask> <default router>
    # Example:
    # 192.168.1.0 255.255.255.0 192.168.1.254
    10.0.1.0 255.255.255.0 10.0.1.1
    10.0.2.0 255.255.255.0 10.0.2.1
    10.0.3.0 255.255.255.0 10.0.3.1
    </opt/SUNWjet/etc>
    kenapps08g:global# more dhcp.conf
    # This file is used to control some of the options for the DHCP boot
    # environment
    # DHCPDIR: The replies sent out by DHCP are limited in length; we use
    # this directory to create symlinks to the actual Solaris
    # media dirs; the intention is to keep paths short!
    # N.B. If you change this, please make sure the new area is
    # properly shared in /etc/dfs/dfstab
    DHCPDIR="/dhcp"
    # DEBUG_DHCP keep temporary files around after client_allocate_pdhcp.SunOS
    # has run. Non-null invokes debug
    DEBUG_DHCP=""
    # REMOTE_DHCP define the hostname of the Sun server running Sun's DHCP daemon
    REMOTE_DHCP="kenapps08g"
    # REMOTE_DHCP_METHOD define what method to use to propogate. ssh is currently
    # supported and requires you set up a trust relationship
    # between this server and it.
    REMOTE_DHCP_METHOD="ssh"
    # DHCP_FORMAT Which dhcp server type is supported. SUN is currently supported,
    # however, ISC is still in development. If REMOTE_DHCP is set,
    # you must set DHCP_FORMAT to SUN. Valid entries are "SUN"
    # and "NOOP". NOOP can be used if you are manually setting
    # up your own DHCP server with the required parameters.
    DHCP_FORMAT="SUN"
    kenapps08g:global# more dhcp_servers
    # You can use this file to define the DHCP servers responsible
    # for different subnets.
    # This is only required if you have multiple DHCP servers.
    # If a match is found, the settings in this file will be used,
    # otherwise the DHCP server defined in dhcp.conf will be used.
    # Format:
    # <client network> <client mask> <dhcp-server-name> <dhcp-server-tyep> <method>#
    # <dhcp-server-name> overrides the REMOTE_DHCP setting
    # <dhcp-server-type> overrides the DHCP_FORMAT setting
    # <method> overrides the REMOTE_DHCP_METHOD setting
    # Example:
    # 192.168.1.0 255.255.255.0 dhcpserver1 SUN ssh
    10.0.1.210 255.255.255.0 kenapps08g SUN ssh
    10.245.64.10 255.255.255.0 lisjump01g SUN ssh
    kenapps08g:global# more jumpstart.conf
    # This config file defines the jumpstart specific variables.
    # Version: $Revision: 1.8 $
    # Last Updated; $Date: 2009/04/15 12:41:29 $
    # Location of the additional media for patches and packages:
    # These paths should be URI form e.g. nfs://<serverip>/<path> or <path>
    # Currently only PKG_DIR and PATCH_DIR can be on a remote NFS server.
    # If they are just <path>, the appropriate address of the JumpStart server
    # will be added.
    # N.B. if the media location is on a different server, please ensure it is
    # routable from the client !
    # You can specify an alternative location for where the client can
    # NFS mount the /opt/SUNWjet directory. Simply provide the IP address
    # of the server or the IP address and path on the remote server
    # in the JS_CFG_SVR variable. However, this MUST be mounted
    # on the JET server in /opt/SUNWjet as well, and be rw by root.
    # e.g. JS_CFG_SVR="nas_server1" or
    # JS_CFG_SVR="nas_server1:/unixshare/SUNWjet"
    # When using an NFS server for images, even though the JET server
    # MUST have the boot media locally, it is possible to have the client
    # net boot from the remote NFS server. By default, clients will boot from
    # the JET server. To override this, set JS_CLIENT_BOOT to "remote".
    JS_Default_Root_PW=M4JVhMPO9CaQw
    JS_BUILD_DIR=/var/opt/sun/jet
    JS_PKG_DIR=/vendor/jumpstart/pkgs
    JS_PATCH_DIR=/vendor/jumpstart/patches
    JS_CFG_SVR=
    JS_SOLARIS_DIR=/vendor/jumpstart
    #JS_DHCP_VENDOR="SUNW.Ultra-5_10 SUNW.Ultra-30"
    JS_DHCP_VENDOR="SUNW.Sun-Fire-T1000 SUNW.Sun-Fire-V240 SUNW.SPARC-Enterprise"
    #JS_CLIENT_MANAGEMENT="bootp"
    JS_CLIENT_BOOT="local"
    kenapps08g:global# more server_interfaces
    # You can use this file to help JET determine the correct IP address to
    # use when it is configured on multi-homed hosts. It is also used to
    # define which servers on different subnets whcih can be used in conjnction
    # with dhcp.
    # As we don't know which side of the server clients will connect through,
    # you can set things up here - especially useful if this server is not
    # a router either.
    # Format:
    # <client network> <client mask> <our preferred ip address>
    # Example:
    # 192.168.1.0 255.255.255.0 10.0.0.1
    10.245.64.0 255.255.255.0 10.0.1.210
    10.0.3.0 255.255.255.0 10.0.1.210
    It has to be a defaultrouter setting somewhere because I can ping the server during jumpstart only from its own subnet.
    during the dhcp part it looks like the traffic is coming thru and it gets its offer then during the tftp part no traffic comes across anymore
    I am stuck on this one.
    thanks

    this file is in place with the interfaces
    kenapps08g:global# cat defaultrouters
    # You can use this file to allow templates to be auto-populated with additional
    # default router settings, especially useful for managing large numbers o
    # server templates.
    # Format:
    # <subnet> <mask> <default router>
    # Example:
    # 192.168.1.0 255.255.255.0 192.168.1.254
    10.0.1.0 255.255.255.0 10.0.1.1
    10.0.3.0 255.255.255.0 10.0.3.1
    183.1.2.0 255.255.255.0 183.1.2.209
    </opt/SUNWjet/etc>
    kenapps08g:global# cat server_interfaces
    # You can use this file to help JET determine the correct IP address to
    # use when it is configured on multi-homed hosts. It is also used to
    # define which servers on different subnets whcih can be used in conjnction
    # with dhcp.
    # As we don't know which side of the server clients will connect through,
    # you can set things up here - especially useful if this server is not
    # a router either.
    # Format:
    # <client network> <client mask> <our preferred ip address>
    # Example:
    # 192.168.1.0 255.255.255.0 10.0.0.1
    10.0.1.0 255.255.255.0 10.0.1.210
    10.0.3.0 255.255.255.0 10.0.1.210
    183.1.2.0 255.255.255.0 10.0.1.210

  • Front End servers within same Pool on different subnets

    The customer is looking to have Amazon AWS host Lync 2013, and despite Lync 2013 having built in HA via Pools, Amazon wants to split the Pools across two of their availability zones (AZ ). An AZ is nothing more than a metropolitan area network, or simply
    a data center located a few miles away. Essentially they want to split the Pools between their two AZs.
    I know that for Lync 2013, the only stretch Pool supported is the Persistent Chat server Pool, and that Front End Pools, Edge Pools, or Mediation Pools are not supported.
    Amazon states that the latency between their AZs is from 1 - 5 ms, which is well within tolerance, though they state that the AZs all have unique subnets.
    I know that none of this is supported, though I am being requested as to why it isn't.
    Forgetting about latency, is this not supported because all servers within a Pool must share the same IP subnet? Is this coded within Lync that only Pools within the same subnet will work? I think it is as with Lync 2010, a stretched VLAN was required for
    a FE Pool to work, which implies the same subnet.
    While on this, a Central site does not mirror that of an AD Site, where a Central Site is a reflection of Pools within an area. So can a Central Site span two AD sites? I believe the answer is yes when one considers that a remote branch office can also be
    its own AD site. The reason for asking this question is I am attempting to see if if the Central Site might also have something to do as to why stretched Pools aren't supported.
    Thanks!
    Christian
    Christian Frank

    Hi Guys,
    Just saw both of your responses. I totally agree that it isn't supported, and what Amazon has been proposing is essentially adding their HA via a redundant AZ so that their infrastructure is redundant, which is their HA (I don't agree!).
    What I am looking for is something a bit deeper as to why. For example, when Lync 2010 had the stretched FE Pool between two locations, it was done via a stretched VLAN, which implies that the servers on both ends must be on the same subnet.
    Amazon wants to stretch all the Pools, between their data centers, so they can say that the Lync infrastructure is highly available, though at each data center, the subnets will be different, and that is what I am attempting to validate.
    I know this isn't supported, though is it because the members within the pool would come from different IP subnets, and Lync 2013 is coded to expect fellow members to be within the same subnet? That essentialy is what the case of Lync 2010 FE Pools was when
    they stretched them. And if you go back to Exchange 2007, stretched VLAN was back then a way to create geo-clustering also, which is no longer the way.
    Frankly, I think it has to do with subnet, and I believe it has to do with how the Windows Fabric is written, and what it is expecting to see. I really think this is the case, which explains the whys as to how stretched Pools are no longer supported any
    longer. Yes?
    Thanks!
    Christian Frank

  • How to change the text in the legend of a graph programmat​ically in labview

    I have many graphs in one plot and want to show the legend the name of the graph (i.e. the filename). How do I change the text in the legend programmatically?

    Create a property node for your graph. Use the property node "Active Plot" to define which plot (or line) you want to rename. Then write the new legend label to the property node "Plot.Name". See attached.
    Tim
    Attachments:
    legend.vi ‏12 KB

Maybe you are looking for

  • Why does my iphone crash each time I start a new app?

    A couple of weeks ago, my iPhone (4S, newest iOS), started crashing I'd say once every four times I try to open an app. I'll open the app and within a second- the screen goes black, the white wheel comes up and it goes back to the lock screen. I've t

  • Monitor takes several attempts to turn on

    I have a new Mac Mini connected to LG flat screen monitor by thunderbolt to VGA cable. On start up I have to turn the monitor on and off several times before it stays on?

  • Kyocera 3035 prints grey background in Mail & Safari

    After upgrading to Snow Leopard, whenever I print with Mail, a grey background appears in the message portion. With Safari, the entire document has a grey background. Printing from other programs is unaffected. I am printing to a Kyocera CS-3035 usin

  • My mouse cursor disappears and does not come back when the mouse is moved.

    Ocassionally my cursor disappears, usually when the display has gone to sleep.  The mouse is still working because I can "mouse over" places on the screen, they are highlighted, and click on items, but there is no cursor.  Fortunately, I can usually

  • User Exit for the Funds Management Update

    Hi Experts , My requirment is to make the movement type 261 as stastical . This should be reflected in COO11 T Code, Please suggest me the User Exit Or The BADI. Thanks in Advance, Regards, Manish