Protection levels question

Is there a way to set the protection level of a class / method so that only classes in the classes package or super package has access.
What I mean is that I have two packages: msglib & msglib.gui. I would like to create methods in msglib.gui that would only be accessable to classes in the two above packages.
Is there a way to do this or should I just put all the classes in the same package and make everything the default protection level?

Is there a way to set the protection level of a class
/ method so that only classes in the classes package
or super package has access.No.
Is there a way to do this or should I just put all
the classes in the same package and make everything
the default protection level?Depends upon the class relationships. Over use of mutual dependence between classes in the same package is a "Code smell", so consider whether your class design makes innate sense.
See "Inapropriate Intimacy":
http://wiki.java.net/bin/view/People/SmellsToRefactorings

Similar Messages

  • VS 2008 Protection Levels & Deployment

    Hi All,
    I have developed a SSIS solution with multiples pacakges in VS 2008 using the protection level of Encrypt Sensitive with password, because VS 2008 wasn't saving the OLEDB passwords. So now it prompts me to enter the password each time I open a package within
    the solution, which is fine as I created and developed it. but my questions are
    1) is there a way save the passwords within the solution so it doesn't prompt me all the time?
    2) I tried changing the package protection level to server storage and it says can't save when using that protection level when saving to XML file format?
    3) When I deploy to the SQL server how can I run the solution without entering the password?
    Thanks

    The password can be hacked out of any executable.  You don't need to use a password in OLEDB statement if the database file permission are setup to only allow certain uses read/write access.  The windows login credentials will protect the data.
    SQL server has an option "Integrated Security=true" which also will use a windows credential.  You need to setup the SQL database to use windows credentials.  What is nice about this option is you can setup one user group in windows
    and then have your database use the windows group account.  The add users to the group.  This way you only have only one account for the database rather than having to manually add each user to the database access list or verbally give people the
    password to the account.
    See webpage below.
    http://www.connectionstrings.com/sql-server/
    jdweng

  • Change project protection level with dtutil (or other cmd)

    Hi - 
    After exporting a project from SSISDB (using catalog.get_project), the project and packages have protection level "ServerStorage". However, I am unable to execute a package (using dtexec) when it has this protection level. I need to change it to
    something else - programatically. 
    I can use dtutil to change protection level of the packages and that is well-documented - but how do I change the protection level of the project with dtutil? (or another cmd shell executable). Project and packages need same protection level or it won't
    compile - that's why I need to change the project as well.
    Thank you,
    Anders

    Hi Arthur,
    Thank you for the response. 
    I run it outside SSISDB with dtexec.exe. It doesn't need to be in the catalog in order to run it. 
    EXEC master.dbo.xp_cmdshell 'dtexec.exe /Project "D:\Run\TheProject.ispac" /Package "ThePackage.dtsx"'
    It is not enough to change protection level on the packages - the project also needs to change protection level. The ISPAC file has the @Project.manifest file which defines the project, including protection level, and it has to be the same as the packages
    in order to run the package in the project.
    So the question remains: How can I change the protection level of the project programatically? (not the packages, - those I can change with dtutil). 
    Thanks,
    Anders

  • Protection level "resynchronization"

    Have a physical standby setup - oracle 11.2.01 on linux - with active dataguard. All's been fine for a long while. There were performance issues on the standby server (also the home for other databases besides the dg standby). Someone tried using different physical ports and dataguard lost communication. Anyway, there were many logs not transported when I looked at it. In the broker it pointed to a redo transport issue which probably resulted from the network work being done. The database was set to maxavailability with 'SYNC' . So what do I do to get the thing sending logs again? I read to restart the standby which I did but that had no effect. Another person here wanted to set to maxperformance but when we downgraded to that, just the current log got sent and not all the others that needed to.
    I'm thinking I might have to manually copy over these logs. Does anyone know if that will be the case?
    The protection mode had been maxavailability and the protection level had been "resynchronization". Once I issued the command to set to max performance, now I get
    SQL> select protection_mode, protection_level from v$database;
    PROTECTION_MODE PROTECTION_LEVEL
    MAXIMUM PERFORMANCE MAXIMUM PERFORMANCE
    which is fine but like I said - many old logs need to be moved.
    Also, both databases use ASM. If I do need to copy over is there a way to copy from asm on one server directly to asm on another or do I need to go to OS files in the middle?

    So you have a log gap right? I would copy the archived redo from the primary over to the standby site and register them.
    You probably have this: (RUN ON STANDBY)
    SELECT MAX(R.SEQUENCE#) LAST_SEQ_RECD, MAX(L.SEQUENCE#) LAST_SEQ_SENT
    FROM V$ARCHIVED_LOG R, V$LOG L
    WHERE R.DEST_ID=2 AND L.ARCHIVED='YES';
    I cannot speak to the ASM question.

  • SRM 7.0 RFx: Supplier not able to reply to Header level questions

    Hi Gurus
    I am currently working on SRM 7.0. I am facing a strange issue.
    While creating an RFX I am able to create questions as both item level and header level and able to assign weights to the same.  I am also able to  see questions along with weights at the supplier's end however when I try to create bid it shows weights at header level questions as zero and the supplier response to the question is also not accepted.
    For questions at item level it is just working fine.
    Please suggest what could be wrong. waiting for your replies.
    Sohil

    Daniele,
    it could be due to multiple purchasing org. assignment to the suppliers.
    Regards
    Konstantin

  • Executing a SQL 2012 SSIS project with DTExec using Protection Level "EncryptAllWithPassword"

    I'm trying to execute a very basic SQL 2012 Project that only has 1 single package that contains a simply email task.
    The project will run fine from command line using basic syntax.
    dtexec /project  "F:\SSIS\Projects\project1\bin\Project 1 Configuration\project1.ispac" /package "Main.dtsx"
    Once I add the protection level of EncryptAllWithPassword to the project and the package things suddenly stop working. New command line syntax is.
    dtexec /project  "F:\SSIS\Projects\project1\bin\Project 1 Configuration\project1.ispac" /package "Main.dtsx" /P "Password"
    I get the following output.
    Microsoft (R) SQL Server Execute Package Utility
    Version 11.0.2100.60 for 64-bit
    Copyright (C) Microsoft Corporation. All rights reserved.
    Started:  5:14:49 PM
    Could not load project "F:\SSIS\Projects\project1\bin\Project 1 Configuration\project1.ispac" because of error 0x80131500.
    Description: The encrypted data in project manifest failed to load. The project
    manifest is corrupted or if the project is password protected, the specified password is incorrect.
    Source: Microsoft.SqlServer.ManagedDTS
    Started:  5:14:49 PM
    Finished: 5:14:49 PM
    Elapsed:  0.078 seconds
    I'm confident my passwords are entered correctly in the two spots. Is there something I'm missing in my command line to use protection levels correctly. I have also built the project and deployed to SSISDB.
    Thank you

    Add the PassWord attribute as  :
    dtexec /project  "F:\SSIS\Projects\project1\bin\Project
    1 Configuration\project1.ispac" /package "Main.dtsx" /P "YourPassWord"
    For more info :
    http://technet.microsoft.com/en-us/library/ms138023(v=sql.105).aspx

  • Very High-Level Question on Approach (PI ccBPM or CE7.1?)

    All -
    I have a very high-level question. I am not current on what would be the appropriate tool for my scenario.
    My scenario...
    Transitioning business to use new sales order system.
    This will be a phased roll-out, not Big Bang.
    Company ordering website needs to send orders to one of two systems (new and old).
    Assume order has a flag or some other value that is an indicator to which backend application it should be sent.
    Each recieving application has an order insert web service, which would be in PI 7.1's ESR.
    What we "envision" is that there would be some kind of fronting web/enterpise service that would read the "flag", then pass the message to the appropriate web service (and on to the appropriate application).
    But I really am not clear how to architect this, if any rules "engines" (ccBPM or in CE 7.1) would be  or should be used.
    You opinions are welcome...
    Thank you for your time...

    Hi Eric,
    It would be more elegant , if you can classify this orders logically and provide two user interfaces one for each type.
    But coming back to your question , if you are planning to implement the process in BPM , you could utilize the capabilities of BRM for this purpose . BRM comes with CE 7.1 and works in conjunction with BPM.
    [BRM Help|https://www.sdn.sap.com/irj/sdn/nw-rules-management]
    Once you want a complete roll out , you can remove the BRM  decision making.Logically this would solve the purpose. ccBPM is not really positioned for this approach. It can be used when you need to interact with multiple systems using different protocols.
    Caveat : The use of BPM will restrict your UI to WebDynpro Java (atleast for now). The whole process needs to be built around webservices or RFCs.
    Regards
    Bharathwaj

  • 'DataSet1' is not declared. It may be inaccessible due to its protection level.

    Hello,
    I am sorry if this has been asked elsewhere but i can't seem to find an answer that will help me.
    I am using visual studio 2013 and a data connection database from Microsoft access called RFID.mdb (which i made by editing the sample Northwind.mdb file)
    I have followed the Microsoft tutorials on how to connect a database and make a data set and i know have the database and dataset in the solution explorer,
    All i simply want to do is load the data i have from a text file into this database, i can load the data from the text file but i cannot seem to get the data into the data set so i can add it to the data base.
    The error i get is on
    'RFIDDataSet1' is not declared. It may be inaccessible due to its protection level. On line 24 and 29.
    I have tried removing the "1" as suggested and this gave me "Reference to a non-shared member requires an object reference."
    I am not sure what i am doing wrong or what could be wrong, could anyone offer some help?
    I am using visual basic.
    Code:
    Imports System.IO
    Public Class Form1
        Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load
            Dim fileReader As String
            fileReader = My.Computer.FileSystem.ReadAllText("C:\gobetwino\Project\testlog.txt")
            MsgBox(fileReader)
            If File.Exists(fileReader) Then
                Dim iofile As New StreamReader(fileReader)
                Dim ioline As String
                Dim DandT, Reader, Id
                ioline = iofile.Readline
                While Not ioline = ""
                    Dim mysplit = Split(ioline, ";")
                    DandT = mysplit(0)
                    Reader = mysplit(1)
                    Id = mysplit(2)
                    Dim newImportRow As RFIDDataSet.ImportRow
                    newImportRow = RFIDDataSet.Import.NewImportRow()
                    newImportRow.DateTime = DandT
                    newImportRow.ReaderNum = Reader
                    newImportRow.TagNum = Id
                    RFIDDataSet1.Import.Rows.Add(newImportRow)
                End While
            End If
        End Sub
    End Class
    Error lines:
    newImportRow = RFIDDataSet1.Import.NewImportRow()
    RFIDDataSet1.Import.Rows.Add(newImportRow)

    I already have a dataset when I connected the database.
    In my solution window I have:
    RFID.mbd (which has a single table called "Import" with the sections "DateTime", "ReaderNum" & "TagNum")
    RFIDDataSet.xsd
    What I am mainly trying to do is load the data from the text file "testlog.txt" to the database RFID.mdb.
    I have been following the Microsoft tutorial and it said to use a dataset.
    Thus my code currently now looks like this:
    Imports System.IO
    Public Class Form1
    Dim RFIDDataSet As New RFIDDataSet
    Dim ImportTableAdapter As New RFIDDataSetTableAdapters.ImportTableAdapter()
    Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load
    Dim fileReader As String
    fileReader = My.Computer.FileSystem.ReadAllText("C:\gobetwino\Project\testlog.txt")
    ImportTableAdapter.Fill(RFIDDataSet.Import)
    MsgBox(fileReader)
    If File.Exists(fileReader) Then
    Dim iofile As New StreamReader(fileReader)
    Dim ioline As String
    Dim DandT, Reader, Id
    ioline = iofile.Readline
    While Not ioline = ""
    Dim mysplit = Split(ioline, ";")
    DandT = mysplit(0)
    Reader = mysplit(1)
    Id = mysplit(2)
    Dim newImportRow As RFIDDataSet.ImportRow
    newImportRow = RFIDDataSet.Import.NewImportRow()
    newImportRow.DateTime = DandT
    newImportRow.ReaderNum = Reader
    newImportRow.TagNum = Id
    RFIDDataSet.Import.Rows.Add(newImportRow)
    End While
    MsgBox("Update successful")
    End If
    End Sub
    End Class
    I am not sure if what I am doing is correct because the program now shows the results in the message box instead of "Update Successful".
    Does this help in finding out what I am doing wrong when trying to load the data from my text file into a dataset which I then plan to use to update the database RFID.mdb

  • Regarding Customization , Access and Protection Levels

    Hi All,
    I need some information on Customization , Access and Protection Levels.
    I need to modify a Oracle Seeded workflow to do some customization wrt approval process.
    How do I determine which process can be modified or not.
    What is quick check to understand what values should I be looking for Customization , Access and Protection Levels on a process that needs to be modified.
    Please help...
    Thanks,

    Hi All,
    We have a requirement to modify the seeded oracle workflow in Purchasing.
    I need to add additional levels of validations by creating some custom processes which would be invoked from the seeded oracle process.
    Could anyone pls advise how do I make my customizations retain even after an upgrade takes place ?
    Thanks,

  • ASA 5505 Interface Security Level Question

    I am wondering if someone can shed some light on this for me. I have a new ASA 5505 with a somewhat simple config. I want to set up a guest VLAN on it for a guest wireless connection.
    I set up the ASA with the VLAN, made a trunk port, set up DHCP (on the ASA) on the guest VLAN, configured NAT, etc. Everything seem to be working with that. Guests are getting address on the correct subnet, etc.
    The only issue I have is that the Guest VLAN (192.168.22.0) can get to the secure (VLAN1 - 172.16.0.0). I set up the guest VLAN (VLAN 5) with a security level of 10, the secure with a level of 100. I figured that would be enough. To stop the guest from accessing the secure, I had to throw on an ACL (access-list Guest-VLAN_access_in line 1 extended deny ip any 172.16.0.0 255.255.255.0)
    Can someone  show me what I did wrong?
    Thank you for any help!
    To create the VLAN, I did the following:
    int vlan5
    nameif Guest-VLAN
    security-level 10
    ip address 192.168.22.1 255.255.255.0
    no shutdown
    int Ethernet0/1
    switchport trunk allowed vlan 1 5
    switchport trunk native vlan 1
    switchport mode trunk
    no shutdown
    below is the whole config.
    Result of the command: "sho run"
    : Saved
    ASA Version 9.1(3)
    hostname ciscoasa
    enable password zGs7.eQ/0VxLuSIs encrypted
    xlate per-session deny tcp any4 any4
    xlate per-session deny tcp any4 any6
    xlate per-session deny tcp any6 any4
    xlate per-session deny tcp any6 any6
    xlate per-session deny udp any4 any4 eq domain
    xlate per-session deny udp any4 any6 eq domain
    xlate per-session deny udp any6 any4 eq domain
    xlate per-session deny udp any6 any6 eq domain
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    switchport trunk allowed vlan 1,5
    switchport trunk native vlan 1
    switchport mode trunk
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 172.16.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address <External IP/Mask>
    interface Vlan5
    nameif Guest-VLAN
    security-level 10
    ip address 192.168.22.1 255.255.255.0
    boot system disk0:/asa913-k8.bin
    ftp mode passive
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Inside_Server1_80
    host <Inside_server1_IP>
    object network Inside_Server1_25
    host <Inside_server1_IP>
    object network Inside_Server1_443
    host <Inside_server1_IP>
    object network Inside_Server1_RDP
    host <Inside_server1_IP>
    object service RDP
    service tcp destination eq 3389
    object network Outside_Network1
    host <Outside_Network_IP>
    object network Outside_Network2
    host <Outside_Network_IP>
    object network Outside_Network2
    host <Outside_Network_IP>
    object network TERMINALSRV_RDP
    host <Inside_server2_IP>
    object network Inside_Server2_RDP
    host <Inside_Server2_IP>
    object-group network Outside_Network
    network-object object Outside_Network1
    network-object object Outside_Network2
    object-group network RDP_Allowed
    description Group used for hosts allowed to RDP to Inside_Server1
    network-object object <Outside_Network_3>
    group-object Outside_Network
    object-group network SBS_Services
    network-object object Inside_Server1_25
    network-object object Inside_Server1_443
    network-object object Inside_Server1_80
    object-group service SBS_Service_Ports
    service-object tcp destination eq www
    service-object tcp destination eq https
    service-object tcp destination eq smtp
    access-list inside_access_in extended permit ip any any
    access-list outside_access_in extended permit object-group SBS_Service_Ports any object-group SBS_Services
    access-list outside_access_in extended permit object RDP any object TERMINALSRV_RDP
    access-list outside_access_in extended permit object RDP object-group RDP_Allowed object Inside_Server1_RDP
    access-list outside_access_in extended permit object RDP object-group RDP_Allowed object Inside_Server2_RDP
    access-list Guest-VLAN_access_in extended deny ip any 172.16.0.0 255.255.255.0
    access-list Guest-VLAN_access_in extended permit ip any any
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu Guest-VLAN 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-714.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
    nat (inside,outside) dynamic interface
    object network Inside_Server1_80
    nat (inside,outside) static interface service tcp www www
    object network Inside_Server1_25
    nat (inside,outside) static interface service tcp smtp smtp
    object network Inside_Server1_443
    nat (inside,outside) static interface service tcp https https
    object network Inside_Server1_RDP
    nat (inside,outside) static interface service tcp 3389 3389
    object network TERMINALSRV_RDP
    nat (inside,outside) static <TerminalSRV_outside)IP> service tcp 3389 3389
    object network Inside_Server2_RDP
    nat (inside,outside) static interface service tcp 3389 3390
    nat (Guest-VLAN,outside) after-auto source dynamic obj_any interface
    access-group inside_access_in in interface inside
    access-group outside_access_in in interface outside
    access-group Guest-VLAN_access_in in interface Guest-VLAN
    route outside 0.0.0.0 0.0.0.0 <Public_GW> 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    http 172.16.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association pmtu-aging infinite
    crypto ca trustpool policy
    telnet timeout 5
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 192.168.22.50-192.168.22.100 Guest-VLAN
    dhcpd dns 8.8.8.8 4.2.2.2 interface Guest-VLAN
    dhcpd lease 43200 interface Guest-VLAN
    dhcpd enable Guest-VLAN
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server 129.6.15.30 prefer
    username <Username> VAn7VeaGHX/c7zWW encrypted privilege 15
    class-map global-class
    match default-inspection-traffic
    policy-map global-policy
    class global-class
      inspect icmp
      inspect icmp error
      inspect pptp
    service-policy global-policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:7f5d70668ebeb94f49f312612f76c943
    : end

    Hi,
    To my understanding they should not be able to connect to the more secure network IF you DONT have an interface ACL configured.
    One very important thing to notice and which I think is the most likely reason this happened is the fact that as soon as you attach an interface ACL to an interface then the "security-level" looses its meaning. The "security-level" has meaning as long as the interface is without an ACL. This makes the "security-level" only usable in very simple setups.
    What I think happend is that you have "permit ip any any" ACL on the interface that allowed all the traffic.
    Your option is to either remove the interface ACL completely or have the ACL configured like you have now. I mean first block traffic to your secure LAN and then allow all other traffic which would allow the traffic to Internet
    Hope this helps
    Please do remember to mark a reply as the correct answer if it answered your question.
    Feel free to ask more if needed.
    - Jouni

  • Video levels question

    Hello,
    As a new Premiere CS6 user I'm a bit confused about the way it handles video levels when compared to Sony Vegas.
    In Sony Vegas I'm used to 16 RGB being video black (0 IRE) and 235 RGB being video white (100 IRE).  This is what I understand as studio levels which is the range most professional video cameras like my EX1 record in when properly exposed. During editing if I design a graphic either in Photoshop or Sony Vegas I input 16 RGB for pure black and 235 RGB for pure white.  This graphic will display between 0-100IRE on the waveform monitor.  I keep my entire color correction workflow within this range (16-235 RGB / 0-100 IRE) and the resulting videos look proper on youtube (since the youtube player stretches the video out to full RGB levels during playback) and DVDs since the player seems to also expect studio levels (16-235 RGB).
    In Premiere however certain things appear to work differently.  Video seems to be handled in the same way as in Sony Vegas.  I came to this conclusion by comparing the same EX1 clip in both programs and it displayed identical on the waveform monitors. However when I create a graphic in Photoshop or using the Premiere titler or solid color I find that I must use 0 RGB to get 0 IRE and 255 RGB to get 100 IRE on the Premiere waveform monitor.
    So my question is should I create a white graphic as 235,235,235 or 255,255,255?  Is Premiere actually converting my graphics to legal video levels automatically or is it just showing up falsely in the waveform monitor?  Are there any pitfalls I need to be aware during exporting to stay in the legal video range of 16-235 RGB?
    Also will there be video level differences on output when using native YUV effects vs. RGB effects like Colorista and Looks?
    Many thanks,  Marc

    Ok, I think I figured it out.  When I bring a full range (0-255) RGB photo or graphic into Premiere it maps the image to studio levels (16-235) automatically.  In Sony Vegas it does not so you end up with superwhites and superblacks and have to do it manually.  In Sony Vegas even the default video background (if you fade to black) is superblack so you have to put a solid color and set it to 16,16,16 RGB in order to stay within the studio Levels legal range.  You have to be really careful about levels or they will be illegal and cause problems downstream.
    When I make a graphic in Premiere I no longer need to worry about the graphic being 16-235 (studio levels) as I do in Sony Vegas.  Premiere considers black as 0 RGB and white as 255 RGB.  On output everything will be studio levels.  I tested an upload of a H264 file exported from Premiere which had a white background of 235,235,235 and it was not full white on youtube.  If I do the same from Sony Vegas it would be fully white.
    Hopefully this will help someone in the future who migrates over to Premiere from Vegas or vice versa.    I prefer the way Premiere handles things.

  • Permission Level Question (Use Client Integration Features)

    Hello All, 
    I just had a general question on one of the options for permission levels in sharepoint. There's one called "Use Client Integration Features":
    Can anybody explain exactly what would be enabled if I enable this option? I know some basic things so far, such as if I enable this, the "Send To->E-mail a link" option would appear for users. However, I'm not exactly sure what else this would
    be used for. Any help would  be greatly appreciated.
    Thanks!
    Chris

    Hi,
    hope these links helps you-
    http://office.microsoft.com/en-us/sharepoint-server-help/change-how-to-open-a-document-in-a-library-with-one-click-HA101729873.aspx
    http://technet.microsoft.com/en-us/library/ee837425(v=office.14).aspx
    http://blogs.technet.com/b/officeasia/archive/2013/01/09/configure-sharepoint-server-to-open-office-documents-in-client-application-by-default.aspx
    Hope this helps!
    Ram - SharePoint Architect
    Blog - SharePointDeveloper.in
    Please vote or mark your question answered, if my reply helps you

  • A few SQL related protection group Questions - DPM 2012 R2

    Hi - Here is my environment: DPM 2012 R2 backing up SQL 2012 DBs. Some of the DBs are simple recovery model, some are full recovery model in the same protection group.
    1) Regarding the fact that DPM only looks to the recovery model when the DB is first added to the protection group, if I ever changed the recovery model in the future, would stepping through the "Modify Protection Group" wizard without changing
    anything be the solution for DPM not changing its methodology on the backing up or not backing up the log files? Or would I have to remove the affected databases from the protection group and add them back in?
    2) I have disk protection configured for 30 Days, sync every 15 minutes, and application recovery points once per day. Online protection is configured for 90 Days. Does this mean my disk consumption on the DPM side for full model databases will be the full
    size of the databases, plus the amount of changes observed over 30 days? OR does it mean it will keep 30 full copies of the DB? I am fairly sure the former.
    3) If I do decide to reduce the retention range on the disk side of this protection group to say 14 days, are there any specific issues with changing that after the PG has been working for some time?
    4) My former backup solution had an option to run consistency checks after every SQL job. Is that still considered best practice? Would the "Run a daily consistency check" be a better choice than the "Only run if a replica becomes inconsistent"
    option that I currently have in place? Would there be any ramifications to enabling this now after this PG has been in place for some time?
    Thanks very much!

    Hi
    Q1) Regarding the fact that DPM only looks to the recovery model when the DB is first added to the protection group, if I ever changed the recovery model in the future, would stepping through the "Modify Protection Group" wizard without changing
    anything be the solution for DPM not changing its methodology on the backing up or not backing up the log files? Or would I have to remove the affected databases from the protection group and add them back in?
    A1)
    Changing the Recovery Model of a Database
    To change the recovery model of a protected database to the simple recovery model
    Stop protection of the database, selecting the retain replica option.
    Change the recovery model on the SQL Server database.
    Add the database to a protection group.
    Q2) I have disk protection configured for 30 Days, sync every 15 minutes, and application recovery points once per day. Online protection is configured for 90 Days. Does this mean my disk consumption on the DPM side for full model databases will be the full
    size of the databases, plus the amount of changes observed over 30 days? OR does it mean it will keep 30 full copies of the DB? I am fairly sure the former.
    A2) Your disk consumption on the DPM will be for size of model databases plus the amount of changes observed over 30 days.
    Q3) If I do decide to reduce the retention range on the disk side of this protection group to say 14 days, are there any specific issues with changing that after the PG has been working for some time?
    A4) Not really, but to gain back the potential extra space allocated for the original 30 day retention - you can try shrinking the recovery point volume once the retention range is reduced and the older recovery points are pruned.  I would wait until
    after midnight to be sure the old RP's are deleted, then try to shrink.
    Q4) My former backup solution had an option to run consistency checks after every SQL job. Is that still considered best practice? Would the "Run a daily consistency check" be a better choice than the "Only run if a replica becomes inconsistent"
    option that I currently have in place? Would there be any ramifications to enabling this now after this PG has been in place for some time?
    A4)  A consistency check will only run if DPM detects the replica is inconsistent.  Even if you have the option selected to run nightly, if the replica is already consistent a consistency check will be skipped.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT]
    This posting is provided "AS IS" with no warranties, and confers no rights.

  • Imovie6/itunes audio level question

    i'm cutting a piece in imovie6. the audio attached to the video clip was recorded rather low, not too low, but a wee bit an the quiet side. i want to boost and level off the audio. on several boards the suggestion was to send the audio track via the imovie/ilife share menu to garageband where i could boost the audio level while adding a dose of compression to remove some of the now raised noise floor. i have tried this 2x and have not noticed/heard the difference (which should have been apparent). after garageband the path back to imovie6 is via itunes. in itunes i have been able to successful boost the audio via the get info box->options and raised the levels while also incorporating the "spoken word" setting in the equalizer.
    the question is: are the itune "changes" on the audio track or only via itunes playback? in other words, if i burned the louder audio track to a cd would the itune "changes" be there? or will those "changes" only be present when i play the track thru itunes.
    i hope my question is not too confusing.
    thanks in advance to those who care to share.
    be well
    rob

    I've not tried this and my system is busy, but...
    Have you tried panning the first clip to center, then control-click on that clip, choose 'copy', then lasso the remaining clips, control-click, paste attributes?
    Not sure it works for panning audio, so let us know.
    K

  • High Level Question - Why create a tag?

    We have been using a component architecture for about three years that seems to be very similar to the JSP component architecture. We have UI components (such as a listbox, entryfield, table, tree, etc) and an associated renderer. In our JSPs we directly call the renderer though to render the component (the component delegates to it's renderer).
    <%= pagebean.getEntryfield().render() %>
    I still can't see the great benefit of hiding that in a tag, especially considering our developers and page designers are the same people, and they are very good at Java. I wanted to simplify the developer APIs as much as possible (avoiding XML, etc). That's why we've stuck with the above API versus using tags, not to mention debugging Java is much easier. I am really excited about JSF, hoping we can move to a standard API versus our propriatary one. What do you all think?
    Dave

    We have been using a component architecture for about
    three years that seems to be very similar to the JSP
    component architecture. We have UI components (such
    as a listbox, entryfield, table, tree, etc) and an
    associated renderer. In our JSPs we directly call the
    renderer though to render the component (the component
    delegates to it's renderer).
    <%= pagebean.getEntryfield().render() %>
    I still can't see the great benefit of hiding that in
    a tag, especially considering our developers and page
    designers are the same people, and they are very good
    at Java. I wanted to simplify the developer APIs as
    much as possible (avoiding XML, etc). That's why
    we've stuck with the above API versus using tags, not
    to mention debugging Java is much easier. I am really
    excited about JSF, hoping we can move to a standard
    API versus our propriatary one. What do you all
    think?
    DaveInteresting question ... and I hope the answer is equally illuminating.
    JavaServer Faces has many aims, but an important aim relevant to this question is broadening the attractiveness of the Java platform to page authors and others who are not Java developers, and would find the syntax of your scriptlet to be totally opaque and not understandable. Further, what you haven't shown is how you configure the characteristics of your component (probably <jsp:set-property> or scriptlet expressions or something?).
    One of the mechanisms to improve this attractiveness will be to have high quality tools support for JavaServer Faces components -- not just the standard ones, but anyone's third party library. Picture the user who wants to use, say, a Calendar component, and your page author is using a GUI. What the user wants to be able to do is drag a Calendar off a template, drop it into their page, pop open a properties window, and configure all the detailed settings -- never seeing a line of code. The tag class (and the associated metadata in faces-config.xml) are what makes it possible for the tool to know what properties go in the property sheet.
    In your environment, where the page author is also a Java developer, you still get a little benefit (configuring components through tag attributes is still more concise than <jsp:setProperty> or scriptlets). But there are many many many more page authors in the world who don't know Java, and don't want to know Java. JavaServer Faces is after those folks too.
    Craig McClanahan
    PS: JavaServer Faces components can also be accessed at the Java API level, so you can use scriptlets to do so in your pages if you really want to.

Maybe you are looking for

  • Item category using approval mangement(AME) in quoting

    Dear all, I am working in AME(approval management) ..i want to use AME in quoting ...while i keying in the item in line item of quote line..the approval should automatically pick the item category ,based upon the item category then it should direct t

  • Contact Names not shown in E6-00

    Hi. I am not able to see the contact names on all incoming and outgoing calls. Any guess? Any solutions. I am also using the paid program / application Advanced Call Manger. Does this have any solutions? Thanks. Arvinder. Solved! Go to Solution.

  • Footnoting - Logos Bible Software and Pages

    Hey all. I am currently using Pages '09 and the new Logos Bible Software for mac. In Windows I used to be able to just copy paste to a pages document and it would create the footnote for me! I can't figure out how to set this up in Pages. Are any of

  • Java.lang.SecurityException: Authentication for user test1 denied in realm wl_realm

    Environment: WLS61 SP2 Two WLS61 servers on different machines. User test1 is authenticated against LDAP on server_1, then tries to execute a class (from JSP) that calls EJB on server_2. The environment properties for the call to EJB on server_2 to a

  • Wrong photo gets flagged

    I have a weird problem with the wrong photo(s) often getting flagged for rejection in the Ligthroom3 Beta. Here's one way to make it happen: 1. In grid view select a number of photos, say 6 2. Switch to survey view 3. Flag all but 2 for rejection and