PXI 6511 reading multiple ports in parallel

I am reading multiple ports in parallel, and it seems to be working fine until I send out data on the MIL STND 1553 bus then the 6511 readings are whacky. Don't know how the 1553 affects the 6511, but am wondering if there is a better way to read the 2 ports in parallel, maybe some of the instability (?) may go away.
Grasping at straws but figure this is something I can confirm through the community.
Is there anything obviously wrong (or flakey) about how I am reading these two ports? Is there a better way?
TIA
lmd2
Message Edited by lmd2 on 03-28-2006 02:18 PM
Lawrence M. David Jr.
Certified LabVIEW Architect
cell: 516.819.9711
http://www.aleconsultants.com
[email protected]
Attachments:
6511 Read 2ports.vi ‏122 KB

Thanx
this is a very good tip, I didn't know that multiple ports could be input with a comma delimiter.
the 1553 bus seems to not be an issue (?) but the circuit had a bad IC that was engaged by the 1553 command.
Anyway I rally appreciate the tip  -   that will come in handy for sure.
lmd2
Lawrence M. David Jr.
Certified LabVIEW Architect
cell: 516.819.9711
http://www.aleconsultants.com
[email protected]

Similar Messages

  • PXI 6512 to PXI 6511 using SCB-100

    Hi;
    Using LabView 8.6, I want to pass a discrete signal from a PXI 6512 (DO) to a PXI 6511(DI).
    Each of these cards have a SCB-100 connector block. I have set the switches (S1 to S6) of each card to "DIO passthrough" as specified in SCB-100 Installation Guide Figure 3.
    I'm using the following NI examples: Write Dig Chan.vi (running on 6512) and Read Dig Chan-Change Detection (running on 6511)
    1. I have connected the PXI 6512 SCB-100 pin #1 (Port 0 Line 0) to PXI 6511 SCB-100 pin #1 (Port 0 Line 0).
        Result: I does not work; that is:
                                              a) Changing voltage on 6512 is not detected on 6511 vi
                                              b) Changing voltage on 6512 MAX is not detected on 6511 vi
    2. I have a connected both pin #1 to pin #1 and pin # 9 (GRND) to pin #9 (GRND), doing the same as above (1.a and 1.b) , it still does not work.
    3. To make things worse, I put a voltmeter on the SCB-100 pins of 6512, no voltage is generated.
    I wonder:
        - How to connect two SCB-100 connectors for my case? is there something special to do in addition to setting the switches ?
        - How can I be sure using MAX that my cards are OK?
        -  What are the correct driver versions (is it "traditional DAQ driver"?) for my cards?
    Thank you in advance for the replies;
    Kizkas.

    Hello KizKas,
    When performing the write to the digital channel, have you tested other lines other that Port 0 Line 0?  Have you tried using a different breakout box, or a different cable?  Have you double-checked all of your connections? If you could try all of these steps and measure the voltage on the line using a voltmeter you should get more information on what is wrong with your system.
    The only steps you can perform in Measurement and Automation Explorer (MAX) to check to see if everything is working with your system is to first check to make sure that the icon next to your device under My System»Devices and Interfaces»NI-DAQmx Devices is green.
    Figure 1: Green is Good
    You can also attempt to reset the device or perform a self-test on the device itself by clicking on the device and clicking on the appropriate buttons.
    Figure 2: Self-Test and Reset Device
    For these devices the correct driver to use would be NI-DAQmx 8.8.
    Message Edited by Dan_K on 12-03-2008 11:01 AM
    Regards,
    Dan King
    Attachments:
    buttons.jpg ‏9 KB
    devices.jpg ‏38 KB

  • How to send multiple files in parallel using ftp with single connection

    Hi.
    i have written code for file upload manager using ftp..
    it perfectly working with sequence file uploading in single connection..
    And i tried to upload multiple files with parallel processing in a single connection.... but it is not working properly.. i also used thread concept
    but single file only transfered and connection refused...
    my code here...
    //////////////////// main class //////////////////////////////////////////
    ftp.connect();
    ftp.login();
    String [] archivos = new  String[100];
                                      File dir = new File("C:\\Files Uploading\\");
                                       archivos = dir.list();
                                       for (int s=0; s<archivos.length;s++)
         //Start Data Transfer Here
         new DataTransfer(archivos[s]).start();
                                       Thread.sleep(1000);
    /////////////////////// thread class ////////////////////////////////
    class DataTransfer extends Thread
          String FileName="";
          String LocalPath="",RemotePath="";
           public DataTransfer(String fname)
         FileName = fname;
         LocalPath = "C:\\Files Uploading\\" + FileName;
         RemotePath = FileName;
         System.out.println(LocalPath);          
            public void run()
                        System.out.println("DataTransfer Started");
         /File Transfer Here
         try
               FileInputStream input = new FileInputStream(LocalPath);
                               Ftp_Client.storeFile(RemotePath,input);
         System.out.println("Successfully sent : " + RemotePath);
         catch (Exception exc)
              System.out.println(exc.getMessage());
              System.out.println("DataTransfer Ended");
         }otherwise tell me any other alternate way

    And i tried to upload multiple files with
    parallel processing in a single connection....
    but it is not working properly.FTP isn't a multiplexing protocol. How could it work at all?

  • Multiple ports on single node cannot communicate

    I am a Sr. Tech Architect from SBC that it evaluating your product for utilization in our enterprise online order application in combination with the Solarmetric Kodo product.
    I was able to install and utilize your application and line command, sample applications no problem on a single jvm utilizing multiple ports and all the members were being recognized no problem. Suddenly, they are no longer being picked up. I am using the packaged configuration xml files as is, just running multiple dos windows on a Win 2k box and launching the line command application. The only other development work I have been doing on the box is test deploys to Apache of the product along with the integration of the Kodo product in a WSAD 5.1 environment, however, I have both those applications shut down and rebooted the machine with no success. I tried running the multicast test just for kicks and got no response back. Scratching my head as to what my be the problem all of a sudden.
    Thanks,
    Scott

    Scott,
    Did you, by any chance, install and enable "Microsoft Loopback Adapter"? If so, you'd need to disable it. If not, could you please e-mail me the command line and some output of the multicast test.
    Thanks,
    Gene
    [email protected]

  • ISE 1.2 and ACL's with multiple ports

    When creating a DACL for my groups I used the Syntax " permit tcp any 192.168.20.0 0.0.0.255 eq 22 443" for one of my acl's inside the DACL and the syntax check validated it. When I pushed it to my groups it also worked but I have heard that this type of multiple port ACL in ISE is not supported. Does anyone know if this is accurate?

    Thanks for the response but it's wrong. Cisco supports stacked ports in 1.2 for wired users. They carried over 1.1documentation to 1.2 and never updated it. We have it in writing from Cisco tac. 

  • ACE: a class-map with multiple ports... what about the probe/serverfarm?

    Hello Gilles,
    One question about something I was not able to find in the documentation.
    Lets say I have one class-map which includes 2 ports (in this case https and 5061).
    Can I associate this class-map to just 1 generic serverfarm and probe for both ports or I have to specify 2 serverfarms/rservers/probes?
    So, by not specifying the ports on the rserver, if a request is received on port 443 (or 5061), it is sent to the same respective port on the rserver?
    The same way is valid for the generic probe.  ACE module is able to probe both ports based on the class-map?
    Thanks and have a great day!!
    Giulio.
    probe tcp PROBE_GENERIC_TCP
      description This probe works for all TCP services by inheriting the VIP port.
      interval 15
      faildetect 2
      passdetect interval 15
      passdetect count 2
      open 2
    rserver host SERVER1_ACCESS
      ip address <1AC>
      inservice
    rserver host SERVER2_ACCESS
      ip address <2AC>
      inservice
    serverfarm host ACCESS-SFARM
      probe PROBE_GENERIC_TCP
      rserver SERVER1_ACCESS
        inservice
      rserver SERVER2_ACCESS
        inservice
    class-map match-any OCS_L4ACCESS
      2 match virtual-address x.x.x.176 tcp eq https
      2 match virtual-address x.x.x.176 tcp eq 5061
    policy-map type loadbalance first-match OCS_L4ACCESS
      class class-default
        sticky-serverfarm ACCESS_STICKY
    policy-map multi-match POLICY
    class OCS_L4ACCESS
    loadbalance vip inservice
    loadbalance policy OCS_L4ACCESS
    loadbalance vip icmp-reply active
    connection advanced-options OCS_VIPTIMEOUT
    nat dynamic XXX vlan 503

    Even if you use the 4710 appliance or expect the inheritance in the module software, it's worth considering if this is really what you want. If you keep multiple ports in the L3/L4 class-map you can't handle the services independently. You will have a common serverfarm for both https and 5061. If https service stops on one rserver, the ACE will place that rserver (and not that service) in out-of-operation state and it won't receive any 5061 traffic either. (You have the fail-on-all probe option but I wouldn't say it's a better choice. In that case, https traffic would be sent to the rserver even if https port is closed as long as there is at least one working service on it.) That's why I prefer a separate class-map and separate serverfarm for each service. (They can contain the same rservers, no need to duplicate.) BUT if the software supports probe port inheritance, you can benefit from it even in this scenario: serverfarm-443 and serverfarm-5061 can both use your PROBE_GENERIC_TCP.

  • Multiple Ports in WSDL

    Hi
    WSDL apparently supports more than one 'Port' definition within
    a Service defintion.
    I am wondering whether this would be possible at all in WL6.1, using wsgen ? Basically,
    I have a couple of session beans that
    I want to expose as webservices, thru a single WSDL file. Each bean would become
    a distinct PortType and ultimately Port in the
    WSDL Service definition. However, it looks like the wsgen tool
    cannot do this. Am I (hopefully!) wrong ?
    Also, the WL client-side examples show the following code to
    access a webservice:
    Trader service = (Trader)context.lookup(<webservice_uri>);
    If the <webservice_uri> has multiple Ports (and PortTypes), that
    say, correspond to multiple beans, how would the above resolve
    to the right bean ?
    thanks
    -john

    Hi John,
    No, this is not possible using wsgen. However you can manually edit the files
    in a WebLogic Web Services to do this. Actually, the concept of having a single
    Web Service, that exposes methods from multiple EJBs is pretty cool. Really shows
    that distinction between "service interface" and "service implementation" ;-)
    Anyway, the attached zip contains most of the files you would have to manually
    edit, and a sample client.
    Regards,
    Mike Wooten
    "john mani" <[email protected]> wrote:
    >
    Hi
    WSDL apparently supports more than one 'Port' definition within
    a Service defintion.
    I am wondering whether this would be possible at all in WL6.1, using
    wsgen ? Basically,
    I have a couple of session beans that
    I want to expose as webservices, thru a single WSDL file. Each bean would
    become
    a distinct PortType and ultimately Port in the
    WSDL Service definition. However, it looks like the wsgen tool
    cannot do this. Am I (hopefully!) wrong ?
    Also, the WL client-side examples show the following code to
    access a webservice:
    Trader service = (Trader)context.lookup(<webservice_uri>);
    If the <webservice_uri> has multiple Ports (and PortTypes), that
    say, correspond to multiple beans, how would the above resolve
    to the right bean ?
    thanks
    -john
    [multibindings.zip]

  • Opening multiple ports on Airport Extreme

    I need to open multiple ports on an Airport Extreme to allow for ftps service (about 500 ports). In port forwarding, it appears that I would have to enter 500 entries to do that (e.g. port 4001, 4002, 4003 etc.) Sounds wacky. In other routers (or linux sortware), multiple entries can be entered like "400, 4000-4500". Apple docs don't address this (from what I could find). Is there a syntax for multiple port forwarding?

    Are you using the round 802.11b/g AirPort Extreme base station (AEBS) or the square 802.11b/g/n AEBS?
    The round AEBS does not allow you to enter ranges. The only solution for a great number of ports is to use the default host option and send ALL the ports to the designated computer.
    I believe that the square AEBS allows you to enter ranges.

  • ERROR OWS-04045 during accessing multiple ports based web service

    I use WSA to publish a web service which have multiple ports.
    The ant build script :
    <oracle:assemble appName="${app.name}" ear="${app.name}.ear"
    targetNamespace="http://www.xxx.com" classpath="${domestic.class.path}"
    input="${web.home.path}/WEB-INF/classes" output="${archive.output.path}"
    style="rpc" mappingFileName="type-mapping.xml" appendToExistingDDs="true"
    serviceName="${app.name}">
    <oracle:porttype interfaceName="com.xxx.service.ICompanyDefinerWebService"
    className="com.xxx.CompanyWebServiceImpl">
    <oracle:port name="company" uri="company" />
    </oracle:porttype>
    <oracle:porttype interfaceName="com.xxx.IUserDefinerWebService"
    className="com.xxx.UserProfileWebServiceImpl">
    <oracle:port name="userprofile" uri="userprofile" />
    </oracle:porttype>
    </oracle:assemble>
    There is a class name UserDTO which extends another class AbstractDTO, which locates in another package. I used a type-mapping file for giving them different namespaces.
    After deployment, I can use the url http://localhost:8888/xxx/userprofile to access the web service. OC4J provided a javascript based stub for testing.
    But I met some problems. When I use the web stub to access it , error occurs.
    ERROR OWS-04045 Malformed Request Message:Caught exception while handling request: unexpected element name: expected={http://www.xxx.com/framework/bean}operationRecord, actual={http://www.xxx.com/user/dto}operationRecord
    I switched the form to display in xml before invoke, I found there are different and correct namespaces on these 2 elements (UserDTO and OperationLog) .So, I'm very strange why the server will response such a fault information.
    In addition, if I use default style (just document-wrapped) to publish web service, almost all methods can not be accessed on web stub which is provided by oracle.
    Surely, the problem is caused by multiple port. The soap specification is 1.2 and JDK is SUN 1.5.0-b6, OC4J is 10.1.3.3
    I just want to konw whether oracle have some better practices or suggestion for publishing a web service which will have multiple ports.
    The other problem is we can not use abstract class(only support interface) when we want to use WSA to assemble a web service based EAR.

    Is it possible to use several "class L4VIPCLASS" inside the "policy-map multi-match VIPs" in order to have several VIPs to load-balance services for several serverfarms?
    Something like this:
    class-map match-all L4VIPCLASS-1
    2 match virtual-address 172.16.1.1 tcp eq www
    class-map match-all L4VIPCLASS-2
    2 match virtual-address 172.16.1.2 tcp eq www
    class-map match-all L4VIPCLASS-3
    2 match virtual-address 172.16.1.3 tcp eq 8081
    policy-map type loadbalance http first-match WEB_POLICY-1
    class class-default
    serverfarm-1
    policy-map type loadbalance http first-match WEB_POLICY-2
    class class-default
    serverfarm-2
    policy-map type loadbalance http first-match WEB_POLICY-3
    class class-default
    serverfarm-3
    policy-map multi-match VIPs
    class L4VIPCLASS-1
    loadbalance vip inservice
    loadbalance policy WEB_POLICY-1
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    nat dynamic 1 vlan 11
    class L4VIPCLASS-2
    loadbalance vip inservice
    loadbalance policy WEB_POLICY-2
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    nat dynamic 2 vlan 22
    class L4VIPCLASS-3
    loadbalance vip inservice
    loadbalance policy WEB_POLICY-3
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    nat dynamic 3 vlan 33
    interface vlan XX
    service-policy input VIPs
    Many thanks for your support.

  • Can imapd listen on multiple ports?

    For historical reasons, we've got some multiplexors that expect to make the back-end imap connecto to port 993, and some others that want to talk to 994. Is it possible to configure imapd to listen on multiple ports?
    Thanks!

    I just realized this would be doable if the MMP would do STARTTLS to the back-end (since then I could enable STARTTLS on the default port and keep SSL on connect on the other port).
    If only.....

  • CAN: Reicht es aus, an der PXI-Karte 8464 / 2 Port an einem selbst gemachten Kabel nur CAN_H und CAN_L anzuschlie​ßen??

    Reicht es aus, an der PXI-Karte 8464 / 2 Port an einem selbst gemachten Kabel nur CAN_H und CAN_L anzuschließen?? Arbeiten die beiden CAN Schnittstellen CAN0 und CAN1 dann einwandfrei??

    Was die Verdrahtung angeht reicht das, jedoch sollten Sie das Kabel auf jedenfall terminieren. In der Anleitung der Karte steht genau drin, wie das zu machen ist.

  • Listening multiple ports

    is there anyway a serversocket can listen to multiple ports?like the the serversocket can listen ports between 1 to 1024?thanks!

    no methods that i know of. except to create an array of serversockets but pass the handling of sockets to a centralized location.

  • How to read multiple arguments separated with space in one line

    How to modify the
    public static void main (String[] args){
    }so that it can read multiple arguments separated with space in a single line?
    e.g.
    java myprogram username password host
    java myprogram2 ipaddress port
    Thx.

    public static void main (String[] args){
      int index = 0;
      for(String arg : args) {
        System.out.println("args["+(index++)+" = "+arg);
    }

  • Extended acl - multiple ports on same acl line

    hello
    i'm working on a (long) acl and have started looking at putting multiple ports on the same line
    e.g.
    instead of:
    ip access-list extended test3
    permit tcp any host 10.10.10.1 eq 80
    permit tcp any host 10.10.10.1 eq 443
    i'd use:
    ip access-list extended test3
    permit tcp any host 10.10.10.1 eq 80 443
    its shortening the acl considerably but the question is:
    does this method reduce the TCAM resources required (compared to writing the acl in long hand)?
    what are the maximum number of ports that can be included on the same line - is it platform/ios dependant?
    thanks
    andy

    Hello
    No. I went ahead with the acl with multiple ports in each ACE and it worked fine. It was deployed on an old WS-C3750G-24PS-E and worked pretty well. When I checked the tcam on the switch I got the following output:
    Cisco3750#show platform tcam utilization
    CAM Utilization for ASIC# 0                      Max            Used
                                                             Masks/Values    Masks/values
    IPv4 security aces:                          1024/1024         33/33
    Note: Allocation of TCAM entries per feature uses
    a complex algorithm. The above information is meant
    to provide an abstract view of the current TCAM utilization
    As there were other ACLs on the switch it was difficult to gauge if the multiple ports per ACE approach to ACLs actually saved any TCAM resources. If you find anything out post back - I'd be interested to hear.
    thanks
    Andy

  • Scan multiple ports on multiple computers

    Hey guys,
    I wrote the following batch script to use along with portqry tool which is availabe from microsoft download center.
    The tool can scan multiple ports on a single computer, but it is not capable of scanning multiple ports on multiple computers in one attempt. Also it gives a big output which is a bit tough if you are trying to prepare a report.
    Here is the batch file which takes input from server.txt where all the computer names present and scans for the below ports on each computer and gives you output in a beautiful way.
    TCP: 135, 445, 1433, 1434, 1024, 1040
    UDP: 1433, 1434
    Copy and paste the below code in a batch file and use it along with portqry.exe.
    echo off
    for /f "tokens=* delims= " %%a in (server.txt) do call :vk %%a
    :vk
    portqry -n %1 -e 1434 -q -p udp
    if errorlevel = 2 goto filtered_1434
    if errorlevel = 1 goto failed_1434
    if errorlevel = 0 goto success_1434
    goto 135
    :filtered_1434
    Echo %1 udp Port 1434 is listening or filtered
    goto 135
    :failed_1434
    Echo %1 udp Port 1434 is not listening
    Goto 135
    :success_1434
    Echo %1 udp Port 1434 is listening
    goto 135
    :135
    portqry -n %1 -e 135 -q -p tcp
    if errorlevel = 2 goto filtered_135
    if errorlevel = 1 goto failed_135
    if errorlevel = 0 goto success_135
    goto 445
    :filtered_135
    Echo %1 tcp Port 135 is listening or filtered
    goto 445
    :failed_135
    Echo %1 tcp Port 135 is not listening
    Goto 445
    :success_135
    Echo %1 tcp Port 135 is listening
    goto 445
    :445
    portqry -n %1 -e 445 -q -p tcp
    if errorlevel = 2 goto filtered_445
    if errorlevel = 1 goto failed_445
    if errorlevel = 0 goto success_445
    goto 1433_tcp
    :filtered_445
    Echo %1 tcp Port 445 is listening or filtered
    goto 1433_tcp
    :failed_445
    Echo %1 tcp Port 445 is not listening
    Goto 1433_tcp
    :success_445
    Echo %1 tcp Port 445 is listening
    goto 1433_tcp
    :1433_tcp
    portqry -n %1 -e 1433 -q -p tcp
    if errorlevel = 2 goto filtered_1433_tcp
    if errorlevel = 1 goto failed_1433_tcp
    if errorlevel = 0 goto success_1433_tcp
    goto 1434_tcp
    :filtered_1433_tcp
    Echo %1 tcp Port 1433 is listening or filtered
    goto 1434_tcp
    :failed_1433_tcp
    Echo %1 tcp Port 1433 is not listening
    Goto 1434_tcp
    :success_1433_tcp
    Echo %1 tcp Port 1433 is listening
    goto 1434_tcp
    :1434_tcp
    portqry -n %1 -e 1434 -q -p tcp
    if errorlevel = 2 goto filtered_1434_tcp
    if errorlevel = 1 goto failed_1434_tcp
    if errorlevel = 0 goto success_1434_tcp
    goto 1024
    :filtered_1434_tcp
    Echo %1 tcp Port 1434 is listening or filtered
    goto 1024
    :failed_1434_tcp
    Echo %1 tcp Port 1434 is not listening
    Goto 1024
    :success_1434_tcp
    Echo %1 tcp Port 1434 is listening
    goto 1024
    :1024
    portqry -n %1 -e 1024 -q -p tcp
    if errorlevel = 2 goto filtered_1024
    if errorlevel = 1 goto failed_1024
    if errorlevel = 0 goto success_1024
    goto 1040
    :filtered_1024
    Echo %1 tcp Port 1024 is listening or filtered
    goto 1040
    :failed_1024
    Echo %1 tcp Port 1024 is not listening
    Goto 1040
    :success_1024
    Echo %1 tcp Port 1024 is listening
    goto 1040
    :1040
    portqry -n %1 -e 1040 -q -p tcp
    if errorlevel = 2 goto filtered_1040
    if errorlevel = 1 goto failed_1040
    if errorlevel = 0 goto success_1040
    goto 1433
    :filtered_1040
    Echo %1 tcp Port 1040 is listening or filtered
    goto 1433
    :failed_1040
    Echo %1 tcp Port 1040 is not listening
    Goto 1433
    :success_1040
    Echo %1 tcp Port 1040 is listening
    goto 1433
    :1433
    portqry -n %1 -e 1433 -q -p udp
    if errorlevel = 2 goto filtered_1433
    if errorlevel = 1 goto failed_1433
    if errorlevel = 0 goto success_1433
    goto end
    :filtered_1433
    Echo %1 udp Port 1433 is listening or filtered
    goto end
    :failed_1433
    Echo %1 udp Port 1433 is not listening
    Goto end
    :success_1433
    Echo %1 udp Port 1433 is listening
    goto end
    :End

    For what it's worth, I wrote a PowerShell script that does something like this a while back.
    http://gallery.technet.microsoft.com/scriptcenter/97119ed6-6fb2-446d-98d8-32d823867131

Maybe you are looking for

  • No redirection to different url upon http connections limit exceeded

    Hi, As of Standalone OC4j 10.1.2, if you want messages to be redirected to a different URL when the maximum connections limit is reached, you would include the HTTP redirect URL to max-http-connections tag inside server.xml. <max-http-connections max

  • Hide the design view for the report

    Dear All, I would like to block or hide the design view for the Crystal report. Please let me know. Thanks, Raja

  • Support Package level in FM

    Could anyone tell us which is the last level of Support Packages in SAP R/3 Enterprise Public Services ECC 6.0? Thanks in advance.

  • Migration steps to an Intel mSATA unit

    Hello All: In a July thread in this Forum harrisb reported his experiences installing an "OEM" mSATA (Intel 310 80Gig unit. I never became clear to me whether forarmed with the Intel Migration Assistant software I would need to clone my current state

  • HT1600 Update was not successful after Restart

    Cannot update the latest Apple TV 3 software release.  The update appears to download but then never gets to step 2 and shows the error message "The update was not successful."  I have tried this several times with the same result. The Apple TV opera