QoS Shaping Subinterface

This may not even be possible but figured I'd ping a few other brains. We are in the process of setting multiple sub-interfaces out to branch offices off our own transport. Part of this is providing them committed sub-rate interface speeds. Easy enough with an MQC shaping policy. However here's the gotcha we'd like if other sub-interfaces on the PHY aren't in use to allow the site to burst. I'm wondering if this kind of dynamic sharper is possible.
policy-map Ring-Traffic
class Voice
priority percent 30
class Signal
priority percent 5
class class-default
random-detect
policy-map Shape-DATX
class class-default
bandwidth 60000
shape average 60000000
service-policy Ring-Traffic
policy-map Shape-CRCO
class class-default
bandwidth 20000
shape average 20000000
service-policy Ring-Traffic
interface GigabitEthernet3/0/1
no ip address
speed auto
duplex auto
negotiation auto
interface GigabitEthernet3/0/1.39
description CRCO
encapsulation dot1Q 39
ip address 10.39.39.1 255.255.255.252
service-policy output Shape-CRCO
interface GigabitEthernet3/0/1.40
description DATX
encapsulation dot1Q 40
ip address 10.40.40.1 255.255.255.252
service-policy output Shape-DATX
So in the above example if Gi3/0/1.40 had zero traffic Gi3/0/1.39 should be able to take all of it's 60Mbps. Basically dynamic load sharing. Not sure if this is even possible with QoS MQC. Curious as to others thoughts.
Thanks.

Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Not that I'm aware of.

Similar Messages

  • IPSEC Tunnel Protection and per-tunnel QOS shaping doesnt do any shaping.

    I am having a small brain implosion as to why this will not work.
    I have tried the QOS policy on the tunnel interfaces and on the ATM interface. No shaping occurs. The interfaces transmit at their leisure.
    Please can someone having a better day than me tell me what I am doing wrong?
    Below is the relevant (and standard) config. without the service-policy command applied anywhere. Any help appreciated.
    class-map match-any APPSERVERS
     match access-group name TERMINALSERVERS
    class-map match-any VOICE
     match protocol sip
     match protocol rtp
     match  dscp ef
    policy-map QOSPOLICY
     class VOICE
        priority 100
     class APPSERVERS
        bandwidth percent 33
     class class-default
        fair-queue 16
    policy-map TUNNEL
     class class-default
        shape average 350000
      service-policy QOSPOLICY
    interface Tunnel0
     bandwidth 350
     ip address 172.20.58.2 255.255.255.0
     ip mtu 1420
     load-interval 30
     qos pre-classify
     tunnel source Dialer0
     tunnel destination X.X.X.X
     tunnel mode ipsec ipv4
     tunnel path-mtu-discovery
     tunnel protection ipsec profile IPSECPROFILE
    interface Tunnel1
     bandwidth 350
     ip address 172.21.58.2 255.255.255.0
     ip mtu 1420
     load-interval 30
     delay 58000
     qos pre-classify
     tunnel source Dialer0
     tunnel destination Y.Y.Y.Y
     tunnel mode ipsec ipv4
     tunnel path-mtu-discovery
     tunnel protection ipsec profile IPSECPROFILE
    interface ATM0/0/0
     no ip address
     load-interval 30
     no atm ilmi-keepalive
    interface ATM0/0/0.1 point-to-point
     pvc 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
    interface Dialer0
     bandwidth 400
     ip address negotiated
    Thanks,
    Paul

    Hi mate,
    This is an 1841 with 12.4 (20) but Ive tried it on 15.1 on a 1941 also. I get some measure of traffic reduction but I cannot fathom what it is actually doing.
    In the lab with the 1841 and a flat shaper I get this:
    policy-map SHAPE
     class class-default
        shape average 600000
    interface Tunnel0
     bandwidth 700
     service-policy output SHAPE
    R1#sh policy-map int
     Tunnel0
      Service-policy output: SHAPE
        Class-map: class-default (match-any)
          18664 packets, 26423115 bytes
          30 second offered rate 452000 bps, drop rate 0 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 45/0/0
          (pkts output/bytes output) 18659/27808530
          shape (average) cir 600000, bc 2400, be 2400
          target shape rate 600000
    R1#sh policy-map int
     Tunnel0
      Service-policy output: SHAPE
        Class-map: class-default (match-any)
          19044 packets, 26964413 bytes
          30 second offered rate 451000 bps, drop rate 0 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 45/0/0
          (pkts output/bytes output) 19039/28378426
          shape (average) cir 600000, bc 2400, be 2400
          target shape rate 600000
    It just holds the data rate around 450 kbps. ??
    Here are the types of results I get when the HQoS is applied to the Tunnel interface in the lab:
    policy-map QOS
     class IP2
        drop
     class IP3
        priority 300
     class class-default
    policy-map TUNNEL
     class class-default
        shape average 600000
      service-policy QOS
    interface Tunnel0
     bandwidth 700
     service-policy output TUNNEL
    R1#sh policy-map int
     Tunnel0
      Service-policy output: TUNNEL
        Class-map: class-default (match-any)
          14843 packets, 20884436 bytes
          30 second offered rate 362000 bps, drop rate 75000 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/3942/0
          (pkts output/bytes output) 14009/15858326
          shape (average) cir 600000, bc 2400, be 2400
          target shape rate 600000
          Service-policy : QOS
            queue stats for all priority classes:
              Queueing
              queue limit 64 packets
              (queue depth/total drops/no-buffer drops) 0/3942/0
              (pkts output/bytes output) 6464/9540288
            Class-map: IP2 (match-all)
              385 packets, 533940 bytes
              30 second offered rate 28000 bps, drop rate 28000 bps
              Match: access-group 102
              drop
            Class-map: IP3 (match-all)
              10411 packets, 14628188 bytes
              30 second offered rate 191000 bps, drop rate 75000 bps
              Match: access-group 103
              Priority: 300 kbps, burst bytes 7500, b/w exceed drops: 3942
            Class-map: class-default (match-any)
              4047 packets, 5722308 bytes
              30 second offered rate 143000 bps, drop rate 0 bps
              Match: any
              queue limit 64 packets
              (queue depth/total drops/no-buffer drops) 0/0/0
              (pkts output/bytes output) 7545/6318038
    This is after 10 minutes of running transfers to all endpoints to utilise the classes in the policy.
    So why dont we see shaping that moves towards the configured values?
    Thanks.

  • QoS Atm subinterface to Internet Policy Map Help

    I have a 40meg connection to the Internet via 7200 router using ATM ubr.  I have been trying to design a Strict priorty for a particular subnet, then a 1 percent Scavenger Class the rest being class default with fair queue and random detect.
    I can build the classes and policy maps yet the service-policy will not allow and inbound or outbound placement on the sub-interface.  Any help on this would be most appreciated.
    Thanks
    Jason

    That's correct, CBWFQ or LLQ is not supported on the PVC configured as UBR ATM class of service because of the nature of UBR service, there is no guarantee that any traffic will get through, the actual traffic rate can be anything.
    Some documentation mention that this is not supported, here is one for 12.4T train:
    "CBWFQ is supported on variable bit rate (VBR) and available bit rate (ABR) ATM connections. It is not supported on unspecified bit rate (UBR) connections."
    http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/congstion_mgmt_oview_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1001237
    Regards,
    Raphael

  • MVRF over dot1q interfaces

    Attached is the network connectivity showing the connectivity between our CE's and the PE's
    All sites which have a ethernet lastmile are terminated on a switch which is then trunked to the PE. Subinterfaces are used on the PE to create BGP adjacencies between the CE and the PE
    Now i have to connect another site again via EoSDH. This site needs to be MVRF capable and hence i am planning to use subinterfcaes and dot1q even on the CE to segregate the traffic.
    Will the CE-PE peering work if i just create a dot1q trunk on the agg switch towards the CE as well or do i need some other configuration
    Narayan

    Hi Narayan
    Funnily enough i have just been doing something similiar in our lab because i need to do the same kind of thing.
    In answer to your question yes you need to make the link from your agg switch to your new CE an 802.1q trunk and then obviously apply the subinterfaces and vlan interfaces into the relevant vrf's.
    This type of setup worked well in my lab using a mixture of 7200/2600 routers and 3560 switches.
    I would like to say it has gone well in production but i'm having issues with my SP getting some answers on QOS/Shaping/subinterfaces so i might be picking your brains on that if you don't mind.
    Jon

  • I have 300 stores and I'm looking for a global QOS config that would shape/policy the bandwith based on a % of the detected ISP link speed

    Hi,
    We have 300 stores with mostly the same router config.
    The router in each store is a cisco 891 router capable of doing QOS.
    Each of our store is connected to internet through a local Internet Service Provider (ISP).  They all have different ISP.
    Each store has different Internet plan with different speed, some are DSL, other are using cable modem.
    The connection between the router and the modem is 100Mbps. But the real speed after the modem will be different depending of the Internet plan the store is using. Exemple : 20Mbps download / 2Mbps upload.
    I'm looking for a standard QOS config that would be put in each routeur and that would shape/policy the bandwith based on a % of the detected ISP link speed.  The goal here is to prevent a single desktop computer of the store to take all available bandwith of the ISP link because of youtube , cloud photo upload, etc.
    Because the wan of the router is in the modem at 100Mbps, I cannot use this bandwith indication for the % calculation. The ISP link speed (after the modem)  is much lower than that.  
    In other words, I dont want to set specific qos value or bandwith manual value in each of my 300 router. Especially because the ISP speed is not the same in each site, it's a big job and it's changing all the time.  Stores owner boost their link, etc.
    So, Is there a way within the router to detect the Wan real max speed and to assign dynamically % of the deduced value and assign it to different policy-map rules, etc.
    regards
    Jonathan D

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    I'm unaware of any (one) "built-in" feature that will do what you're desire.  (BTW, I don't believe PfR, as mentioned by Matt, will do what you desire either, but I've haven't used it in several years.)
    I was looking to address a somewhat similar problem several months ago, and believe I could construct dynamic QoS shaping using an embedded device script working with IP SLA monitoring.  However, the "problem" site (using a cable modem) closed, so I didn't pursue it further.
    An alternative approach would be to use as few policy models as possible.  For example if there are sites with 2, 3 or even 5 Mbps uploads, you might use a 2 Mbps shaper for each.  Of course, sites with more available bandwidth won't obtain the full advantage of it, but your maintenance support will be easier.  Conversely, especially for cable modems, running under their nominal speed might provide much more predictable performance, as HFCs are generally much more variable in their actual available bandwidth, moment to moment.

  • DMVPN Design: Multi-Hub, Router Per-Tunnel QoS

    Some DMVPN questions:
    1) A site I've worked with has about 7 hubs and 5 spokes. This looks at best a bit odd to me. The Cisco design docs all have at most 2 hub sites. Is more than 2 DMVPN hub sites a good idea / bad idea? Pros / cons / drawbacks? I've googled this topic heavily, found little.
    2) If two sites are DMVPN hub sites that have NHRP map statements for  each other, can they both be doing the Per-Tunnel QoS feature to get some QoS shaping towards each other?
    3) What is recommended for DMVPN QoS in general? And for a spoke site where the hub site is doing the Per-Tunnel QoS? Just put some QoS on the physical link?

    Ray,
    There could be multiple reasons for it not to function, the config on hub seems just fine, we'd need to inspect the spokes and check (most likely) in debugs if correct group is being sent from spoke.
    Also coexistance of other service-policy etc etc.
    The feature is quite simple (some level of simplification), spoke says he is in group X when registering, hub assigns this NHRP mapping a service-policy.
    M.

  • Per Session / per User shaping and queuing not working on 7206/7204 on 15.2

    Hello,
    we are running the following scenario - to provide QoS (shaping/queueing) for our broadband (pppoe) users, we have configured several service-policies on our 7206/7204 BRAS-Routers. The service-policies are applied with RADIUS-Attributes when the pppoe-users dials in. The service-policies look like this
    policy-map POL-BM-DEF-P_4m-DSCP-OUT
     description << Parent Policy 4 mbps >>
     class class-default
      shape average 3900000
      bandwidth 3900
       service-policy POL-BM-DEF-C_4m-DSCP-OUT
    policy-map POL-BM-DEF-C_4m-DSCP-OUT
     description << Child Policy 4 mbps >>
     class CM-VO-DEF-DSCP
      priority 900
      police cir 900000
       conform-action transmit
       exceed-action drop
     class CM-VS-DEF-DSCP
      bandwidth 100
     class CM-ID-DEF-DSCP
      bandwidth 900
     class CM-MS-DEF-DSCP
      bandwidth 600
     class CM-MC-DEF-DSCP
      bandwidth 300
     class CM-NC-DEF-DSCP
      bandwidth 150
     class CM-NM-DEF-DSCP
      bandwidth 150
     class class-default
      bandwidth 800
    We are applying the policies with the following Cisco-AV-Pair attribute
    lcp:interface-config=service-policy output POL-BM-DEF-P_4m-DSCP-OUT
    Until recently that did work pretty good when using software 12.2(33)SRC3. But it turned out that there is a bug in this software that causes that the policy is applied but not working correct sometimes. See bug CSCsv27825. Although that bug does not match the software we are using, the symptoms do. Basically the parent shaper is not working, so there is no backpressure, no need for qos to kick in ;-)
    The recommendation was to upgrade to Version 15.2(4)M5. When downloading the image there was a recommendation on the website to use Version 15.2(4)M6 instead, because of some important bugfixes. So we installed that, system cmes back online, everything works - except the service-policies. they are not applied at all any more.
    After doing some tests it turns out that
    - Policies that shape are not applied. It does not matter if using the ip:sub-qos-policy-out=xxx or lcp:interface-config=service-policy output xxx attribute.
    - Policies that police like the one here are applied
    policy-map POL-POLICE-DEF-P_1M-DSCP-OUT
     class class-default
      police 1000000
    We prefer the shaping way, because of the smoother handling of bursty traffic.
    Any ideas/recommendations ? I've tbeen readign a litte bit on the internet - that problem is not new, but unfortunately no one has a solution :-(
    Best regards
    Carsten
    Short update: as soon as some queuing configuration is present in the policy (parent and/or child) it is not applied. i tried to be extra clever and combine the "policer" parent policy with our child-policy which does priority queuing - not applied. Even the parent-policy alone with no child policy (just the shaper)  is not gettign applied.
    Any ideas what to debug to get a reason why it is not working ?

    Please Ignore Spelling errors. "I asked" replaced "It asked".
    Please Reply as soon as Possible !

  • Cisco ISR G2 EHWIC Shaping is available ? (SDWRR)

    Hello
    I think normally Modular Qos Shaping feature should be configure into routed port, however if it is switched port. Is it possible? 
    Here is the related link below, it seems that IEEE 802.1P QoS (Traffic Prioritization) is available on EHWIC.
    So I would be better if I can let me know how to  configire Modular Qos Shaping on this switch port.
    http://www.cisco.com/c/en/us/products/collateral/routers/3900-series-integrated-services-routers-isr/data_sheet_c78-612808.html
    IEEE 802.1P QoS (Traffic Prioritization) 
    Each port has eight QoS queues. Strict priority is enforced by default. The routers support SDWRR with configurable weight on each queue 
    Best Regards,
    Masanobu Hiyoshi

    Hello.
    SDWRR is Layer2 QoS.
    Here is a details for 3750 - http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750/software/release/12-2_52_se/configuration/guide/3750scg/swqos.html#wp1163879

  • 7600 SIP-400 looped to same 7600

    Hi,
    We are proposing to install SIP-400's into our PE's 7600 (sup32) in order to provide egress traffic shaping and qos for our customers.
    We are proposing to connect the SIP gig interfaces back to another line card on the same device, instead of putting another switch in front of our existing PE. This saves us a switch and lets us take advantage of the port density in our current 7600 PE's (which is why we purchased them in the first place).
    We also plan to utilise the same approach to implement pwe xconnects on the SIP-400 subinterfaces. VLAN uniqueness per port is the key feature of the SIP-400 that facilitates this.
    Has anyone run a similar setup? Any experiences to share?
    I have tested in the lab and can't see any issues so far.
    Does anyone know of a more cost effective qos / shaping solution for Ethernet tails? The SIP or ES20 based solutions seem overpriced for the pretty basic functionality we are after here. Doesn't have to be a Cisco box.
    Kent.

    "Doesn't have to be a Cisco box. "
    If you're still interested in solving this (or haven't already), you can mail me at [email protected]
    Cheers,
    Anton

  • Rate-limit a subnet per ip by policmap !

    hi all ,
    i have subnet /24 with 250 ips and need each ip of the entire this subnet to has QOS/shaping or policing by 2 M.
    is there a quick method on cisco to do it ??
    i dont want to create 250 classp-maps !!!!!
    i have cisco 3900 and asa 5520
    not sure if wt i need supported or not.
    plz advise
    regards

    Hi,
    Let me start of by saying that I have not played around with these settings that many times myself. I have usually set connection timeout values for certain connections more than use connection limits
    Wonder if something along these lines would work
    access-list WEB-SERVER-CONNECTIONLIMIT extended permit tcp any host eq www
    access-list WEB-SERVER-CONNECTIONLIMIT extended permit tcp any host https
    class-map WEB-SERVER-CONNECTIONLIMIT
    match access-list WEB-SERVER-CONNECTIONLIMIT
    policy-map global_policy
    class WEB-SERVER-CONNECTIONLIMIT
      set connection per-client-max per-client-embryonic-max
    I am not sure but to my understanding the destination IP address you use in the ACL depends on your software. I am using 8.4(5) so I actually used the local IP address as the destination of the ACL even though the host was Static NATed to a public IP address
    - Jouni

  • ES20 - Port Queues

    Hi,
    I have a 7609 with a WS-X6748-GE-TX. When I show the port capabilities I
    can see rx-(1q8t), tx-(1p3q8t)
    If I show queueing on an interface I see all the WRED and WRR queue
    configuration.
    This is great, I can make changes and view changes.
    I also have an ES20 and ES20+ line card in the chassis. When I show the
    port capabilities I see x-(NotDef-t), tx-(NotDef-t)
    When I show queueing on an interface I see nothing for the ES20. For the
    ES20+ I get
    Interface GigabitEthernet1/1 queueing strategy: Weighted Round-Robin
    Port QoS is enabled
    Port is untrusted
    Extend trust state: not trusted [COS = 0]
    Default COS is 0
    So the ES20 tells me nothing and the ES20+ only shows a subset of what I
    see with the WS-X6748-GE-TX.
    Is there something I am missing in my config to show what queues I have
    available on the ES line cards '(1p3q8t)'
    From reading the line card configuration guides I can see ingress
    scheduling is not supported and egress is but when I configure a egress
    policy-map with my random-detect configuration I still see no queueing
    info for the ports.
    Thanks
    Anthony

    Hi Anthony,
    ES and 6748 are two completely different type of LC based on different hardware.
    ES20 LC support 16K hw queues to give you an example in addition to H-QoS, shaping,..
    You should use the show policy-map interface command instead.
    HTH
    Laurent.

  • QoS:: Traffic Shaping query

    Hi,
    I want to apply QoS:: Traffic shaping with CBWFQ to our enterprise network, i want to ask you that where i should apply classification and QoS policy i mean to which interface. We have a Central site router 3660 and branch sites connected either to F.R E1 or TDM E1. I tried to create class maps and policy maps at the central site router and apply the desired policy to the desired branch site at the subinterface at the main router but CBWFQ is NOT supported at the subinterfaces, Should I apply policy maps at each branch site router or where ???
    plz. HELP

    Its always better that the classification be done at the access sites in your case. QOS policies can be applied on any interface. I think they can be applied to sub interface aswell . Please refer to the configuration documents on Frame-Relay to learn how to apply QOS on Frame-relay interfaces.

  • Configuring QoS for FIOS Router MI-424WR: Traffic Priority and Shaping

    Please only read on if you are an experienced internet user familiar with setting the advanced QoS and Firewall settings for the MI-424WR and make use of wireless adaptors from a PC to provide connectivity.
    This is my first post and my first week since I moved from Time Warner Cable over to FIOS for iNet (plus HDTV and phone).     While all my services work, the router as delivered and setup is not optimum for internet quality of service.  Instead it was probably out of the box optimized for HDTV and telephone to satisfy most customers and reduce support overhead.   The average FIOS consumer is multimedia sensitive, but that is not so in my genre of internet consumer.   Here in lies the core of my reason for seeking help from like minded and experienced users in this community.
    One of the main driving forces in my switching to FIOS was to improve my multiplayer gaming experience where ultra low ping latency and high upload data rates dramatically affect the quality of connection and thus gameplay.    The cable internet service from TimeWarner was providing solid 2MB/1MB down/up data rates with no issues like what Im having now with FIOS.   Again the reason for the switch was both financial and in hope of gaining better data rates and quality of service.   Now with FIOS Im getting about 24/15 down/up data rate on the Extreme FIOS 25/25 plan when measured from my house to Los Angeles server (50 miles away) via Speedtest.net or DslReports.com/tests.     Latency wise, the ping has gone down from 150 to 50ms when measured to my friends who I connect to online that are on the East coast.   The data rate and latency has greatly improved in going from Cable to FIOS.   So far, so good.
    Where the problem shows up now, is that now I get an internet "hiccup" every 5-10 minutes that lasts about 1/2 to 2 seconds.   For the average internet user that just streams multimedia or cruises on the net; this is probably undetectable or noticed.   I never had this problem over the same PCs connected wirelessly to my DLINK DGL-4500 Gaming Router when my ISP was TimeWarner's cable service.    Now, using the FIOS and MI-424WR router with everythings being the same; Im experiencing this degregation in quality of service.    Even putting the PC's IP into the DMZ doesnt make any difference, so it is not related to port forwarding.    The issue is squarely in the lap of FIOS and this router as delivered and configured.    This is where the "game" is a foot, and where I need expertise in an area Im new to. 
    I am not new to being hands on with inet trouble shooting asI have been setting up my own home network (I work from home over VPN to work) for decades;  I would like to leverage the skills of those who are experts in the area that I think can address this issue.   That being QoS and the other device class mechanisms of this router.   Its my guess that this periodic hiccup can be minimized and even eliminated using these advanced features of this all-in-one TV/iNet/Tele router.   
    With that context being laid down, this hiccup doesnt show up if:
    a.  I connect two PCs connected to the same ethernet hub of the MI-424WR (traffic just over the LAN and not WAN)
    b.  When I was on Cable with my own gaming router wirelessly DHCP connected to my PC and using port forwarding or using the DMZ.  
    The hiccup does exist when:
    a.  Going from internet through the MI-424WR to the wireless DHCP connected PC with port forwarding
    b.  Even putting the wireless DHCP connected PC into the MI-424WR's DMZ has no effect
    I did read the manual and tried some QoS pritority and shaping and managed to reduce how often the hiccup occured, but I was just making guesses at the settings.   I put in the IP for the PCs I use for my gaming applications (which are very ping and jitter sensitive) into the QoS priority (value 7) and shaping GUI.    Im hoping someone with experience can tell me exactly how to use it and what settings to input.   Im not clear on the device and connection types offered in the QoS menus. 
    Another thing, is I couldnt find settings for the turning on/off the ICMP echo.   But I assume this is on because it can be pinged by folks on the net to my WAN IP.
    Here is the manual for the Verizon provided M424WR router (Current Version of firmware: 20.10.7)
    download link
    Here are the QoS traffic priority and shaping values Ive been experimenting with:
    Click to view QoS Traffic Priority
    Click to view QoS Traffic Shaping
    And why it matters to have a solid and stable inet connection for internet gaming?  The hiccup causes slewing or jitter which equates to positional errors in the 3D world that ruins the smooth gameplay that is needed for high end gaming.
    Heres a snapshot of me flying the wing of another flight simmer who is on the East coast and me on the West coast.
    Click to view
    Thank you in advance.
    Thomas "AV8R"
    MSEE

    TMAS wrote:
    the router as delivered and setup is not optimum for internet quality of service.  Instead it was probably out of the box optimized for HDTV and telephone to satisfy most customers and reduce support overhead.  
    That's not accurate.  VZ telephone service does not go through the Actiontec.  Also, there are no default settings for QOS in the Actiontec since QOS is rarely needed with FIOS upload speeds.
    TMAS wrote:I get an internet "hiccup" every 5-10 minutes that lasts about 1/2 to 2 seconds.  
       You should not be experiencing periodic "hiccups".  Something is clearly amiss.
    TMAS wrote:
    With that context being laid down, this hiccup doesnt show up if:a.  I connect two PCs connected to the same ethernet hub of the MI-424WR (traffic just over the LAN and not WAN)
    The hiccup does exist when:
    a.  Going from internet through the MI-424WR to the wireless DHCP connected PC with port forwarding
    b.  Even putting the wireless DHCP connected PC into the MI-424WR's DMZ has no effect
    Lets see.  The issue shows up on a wireless connection, but not a wired connection.  You think this is a QOS issue and not a wireless issue why?  Have you tried changing the wireless channel?  It very possible you have neighbors on the same channel.  Is the DGL-4500 wireless still on?  Could that be interfering?TMAS wrote:
    Another thing, is I couldnt find settings for the turning on/off the ICMP echo.  
    The settting to enable/disable ICMP echo is on the Firewall/Remote Administration page.
    TMAS wrote:
    Here are the QoS traffic priority and shaping values Ive been experimenting with:Click to view QoS Traffic Priority
    Click to view QoS Traffic Shaping 
    The traffic proirity settings you linked are applied only to your wireless connections.  QOS between the router and your wireless PC will only serve to prioritize traffic between the router and that PC and have no affect on your internet traffic.  Assuming you are not running browsers, VOIP and other traffic from that PC while you're gaming, then that will not accomplish anything.  i.e.  You're giving your only traffic highest priority, but that traffic is not competing with anything (except other nearby wireless connections on the same channel).
    On the traffic shaping screenshot, you have broadband ethernet checked, but according to your other thread, your WAN connection is Broadband Coax, not Broadband ethernet.

  • Can Anyone Help Me Configure My Verizon (D-Link) DSL-2750B "Traffic Shaping" (QoS)?

    Well ... I just spent a wonderful hour and a half (not) bouncing around VZ technical support, etc. trying to get assistance regarding configuring my DSL router.* Between the low-quality Skype connection to India and my lack of success, I'm a little bummed out right now.
    Could one of you perhaps help me? I'm trying to configure a single, wire-attached network node (port 4 of the router) so that it can only consume up to 320 Kbps of my 750 Kbps (7.5 Mbps) DSL bandwidth ... no matter what. This results from this node consuming virtually all of the circuit's bandwidth when streaming or during bulk file transfers.
    I have tried to remedy the problem using priority with no discernible impact.
    The Quality of Service (QoS) element called Traffic Shaping (Services | QoS | Traffic Shaping), described on Page 51 of the VZ DSL-2750B User Manual , appears to be the ideal solution to my problem. Repeated attempts at activating this QoS have all resulted in no throttling of bandwidth consumption.
    My most recent attempt was to define the device on Port 4 as the DMZ host ... and then apply a new rule (320 TX, 320 RX) to this interface. Again, no joy.
    Does anyone have any experience with this service on this router?
    Am I chasing my tail trying to configure the router without validating that my circuit is not configured with "Fastpath (PSE) inactive"?
    If the circuit configuration is a potential problem, which office should I ask for at VZ customer service?
    Here is the information from the System page of the Router Control Panel:
      Gateway ID: PX2M1BC000000
      Software Version: 5.4.12.1.44
      Release Date: Feb 19 2012
      Platform: D-Link DSL-2750B
      Board Tag:... Ntag-5_4_12_1_44
      Compilation Flags:... LIC=/home/bat/bat/dlink_bcm96328_5_4_12_1/20120219_1343/conf/jpkg_bcm9636x_dlink.lic CONFIG_RG_PROD_IMG=y DIST=DLINK_DSL2750B
    I'll note that the Router provides a notification that "RX QOS might not operate when Fastpath (PSE) is active" when I update the router configuration page concerning Traffic Shaping. Because Fastpath is not mentioned in the User Manual, I'm guessing that Fastpath (PSE) might be a configurable attribute of the circuit servicing my PoP, but I have no idea if this is the case.
    I searched for relevant messages on this board ... without success. If this has already been addressed, please provide a link, and accept my apologies. (My Google-Fu tends to be weak.)

    The asterisk in the first post refers to the following summary of events:
    10:40 - Attempt to solve my configuration question using VZ chat begins.
    10:49 - VZ chat agent Danish refers me to phone support.  (Chat ID number is 020813176471 if you're with VZ and are interested.)
    10:50 - Call VZ phone support.
    11:02 - Talk with Angel.  Because she has not heard of, nor received training in, "traffic shaping," she says my question about configuring this VZ DSL modem must be addressed by "Premium Technical Support."  She transfers me.
    11:13 - Talk with Pamela.  Premium Technical Support only responds to questions about 3d party products.  Because my question concerns a VZ DSL modem, Basic Technical Support is responsible.  She transfers me.
    11:17 - Talk with Joe.  He says either the vendor (D-Link) or premium technical support is required.  Because I had already tried with D-Link (they referred me to Verizon, as this modem was built exclusively for VZ), I explained what I had already experienced, and described how I wanted "assistance configuring my VZ DSL modem, specifically a feature described on page 51 of the User Manual."  He transfers me.
    11:23 - The automated phone system asks for my 12-digit customer ID.  I wasn't able to find it fast enough, and rolled through to Financial Services.  Eventually Trig picked up, listened to my story, and transferred me to "Technical Support" providing the direct dial number, just in case (866.945.79xx).
    11:32 - Entered the phone queue.  Lots of hissing and clicks.
    11:35 - Talk with Monika.  (The voice clarity from this point onward was on the order of 1st-generation Skype.  Between the horrible language problem -- Monika is in India don'cha know -- and the lousy line quality, this was the most frustrating.)  No matter what I said, I couldn't convey the reason for my call.  I asked to talk with a supervisor, which Monika related was not possible.  She also related that she could not transfer me to an American POC or supervisor.
    12:01 - Hung up the phone ... and started down the path that led to my post immediately above.
    I was repeatedly queried about the account name and number throughout the process.  Conveying this information was especially challenging during the Indian call segment.

  • WAN multi-site traffic shaping/QoS setup

    We have multiple sites connected to a private WAN cloud (Layer 2) with varying CIR's.  Our QoS setup from our main site is 3 tiered in order to shape traffic to our overall CIR at the main site and shape traffic on different child classes based on the remote CIR.  Parent policy is applied to interface connected to the service provider.  We continue to have drops even though we don't seem to be reaching the CIRs for the remote sites or the CIR limit on the ciruit.  I've worked with TAC and we have adjusted queue limits based on drops but this is an ongoing issue.  Should there be a relationship between the queue limits and shape averages?
    Sample config
    NOTE: Shape averages are 95% of CIR
    Policy-map Parent
    class class-default
      shape average 142500000
      queue-limit 1024 packets
       service-policy ASE-Remotes-Policy
    policy-map ASE-Remotes-Policy
    Class site1
    shape average 4750000
      queue-limit 400 packets
       service-policy ASE-QoS-Policy
    Class site2
    shape average 19000000
      queue-limit 1024 packets
       service-policy ASE-QoS-Policy
    class site 3
    shape average 95000000
      queue-limit 1024 packets
       service-policy ASE-QoS-Policy
    multiple other sites
    policy-map ASE-QoS-Policy
     class VoIP
      priority percent 40
      queue-limit 1024 packets
     class Citrix
      bandwidth percent 40
      queue-limit 1024 packets
     class class-default
      queue-limit 1024 packets

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    Logically, what you're doing makes sense, but only Cisco "knows" how their queuing really works.  I've long suspected their embedded CBWFQ shapers have their own queues, which you may not have direct control over for setting their queue depths.
    Yes, logically, there's a relationship between bandwidth (including shaping) and queue limits, but it depends on multiple factors.  Shaping is also a special case, because although you're trying to emulate a certain link bandwidth, it's not the same.

Maybe you are looking for