Query vlan in cisco ACE

I've configured query vlan FT internface as follow:
class-map type management match-any query_VLAN
  2 match protocol icmp any
policy-map type management first-match query_VLAN_MGT
  class query_VLAN
    permit
interface vlan 11
  description ##query vlan##
  ip address 192.30.3.196 255.255.255.252
  peer ip address 192.30.3.195 255.255.255.252
  access-group input ANY-ANY
  service-policy input query_VLAN_MGT
  no shutdown
ft interface vlan 10
  ip address 192.30.3.192 255.255.255.252
  peer ip address 192.30.3.191 255.255.255.252
  no shutdown
ft peer 1
  heartbeat interval 300
  heartbeat count 10
  ft-interface vlan 10
  query-interface vlan 11
and when I do "sh ft peer sum" I see following:
sh ft peer sum
Peer Id                      : 1
State                        : FSM_PEER_STATE_COMPATIBLE
Maintenance mode             : MAINT_MODE_OFF
FT Vlan                      : 10
FT Vlan IF State             : UP
My IP Addr                   : 192.30.3.191
Peer IP Addr                 : 192.30.3.192
Query Vlan                   : 11
Query Vlan IF State          : UP, Manual validation - please ping peer
Peer Query IP Addr           : 192.30.3.196
Heartbeat Interval           : 300
Heartbeat Count              : 10
SRG Compatibility            : COMPATIBLE
License Compatibility        : COMPATIBLE
FT Groups                    : 5
would you please advise why "Query Vlan IF State " is showing "Manual validation - please ping peer" do I need to configure anything else?
Thanks....

You don't need to configure anything further. Your config looks good.
The query interface thing can be a bit misleading.  The ACE does not use the query interface until the FT vlan goes down. This is the reason why we added a etxt to request users to manually verify query interface is functioning properly as below :
"Manual validation - please ping peer"
So if you need to check if the query vlan is up, then manually ping the peer ip address. That's what the message means.
- Andrew

Similar Messages

  • ACE - Query VLAN Interfaces Status

    Hi,
    I am wondering what the status of the query vlan interface means in the command 'show ft peer detail':
    Query Vlan IF State          : UP, Manual validation - please ping peer
    I am pretty sure that I did not see this status when I configured query vlan last time. Current version is A2(2.3).
    Unfortunately this status does not seem to be documented anywhere on CCO.
    I appreciate any help!
    Thanks,
    Daniel

    Hi Daniel,
    The FT Query VLAN interface is an optional, yet very good, feature to be used when using redundant ACE modules or appliances. Without it, if the FT VLAN was to go down, the standby ACE will no longer receive FT heartbeats from the active ACE and therefore take the active role.  However, if the active ACE is still running fine in the active role, then you don't want the standby ACE to take over as active because that will put them into an active/active scenario, which may lead to connectivity issues.
    This is where the FT Query VLAN interface comes in.  If the FT VLAN goes down, the standby ACE will notice this, but before taking the active role, it will ping it's peer IP address configured on the interface that is designated as the FT Query VLAN.  If the ping is successful, then it will stay in the standby role, thereby saving you some headaches.
    The status that you are seeing is the ACE's way of telling you that the interface is UP, but if you want to know if it can successfully ping the peer IP address, then you would have to manually ping the peer IP address from the CLI.  The ACE does not periodically check the ping connectivity through any automatic mechanism.  The automatic mechanism is only triggered by the FT VLAN going down.
    Does this help?
    Sean

  • Need help to Configure Cisco ACE 4710 Cluster Deployment

    Dear Experts,
    I'm newbie for Cisco ACE 4710, and still I'm in learning stage. Meanwhile I got chance at my work place to deploy a Cisco ACE 4710 cluster which should load balance the traffic between  two Application Servers based on HTTP and HTTPS traffic. So I was looking for good deployment guide in Cisco SBA knowledge base then finall found this guide.
    http://www.cisco.com/en/US/docs/solutions/SBA/February2013/Cisco_SBA_DC_AdvancedServer-LoadBalancingDeploymentGuide-Feb2013.pdf
    This guide totally fine with my required deployment model. I have same deployment environment as this guide contains with ACE cluster that connects to two Cisco 3750X (Stack) switches. But I have some confusion places in this guide
    This guide follow the "One-armed mode" as a deployment method. But when I go through it further I have noticed that they have configured server VLAN as a 10.4.49.0/24 (all servers reside in it) and Client side VIP also in same VLAN which is 10.4.49.100/24 (even NAT pool also).
    My confusion is, as I have learned about Cisco ACE 4710 one-armed mode deployment method, it should has two VLAN segments, one for Client side which client request come and hit the VIP and then second one for Server side. which means besically two VLANs. So please be kind enough to go through above document then tell me where is wrong, what shoud I need to do for the best. Please this is an urgent, so need your help quickly.
    Thanks....!
    -Amal-

    Dear Kanwal,
    I need quick help for you. Following are the Application LB requirements which I received from my clinet side.
    Following detail required for configuring Oracle EBS Apps tier on HA:
    LBR IP and Name required to configure EBS APPS Tier (i.e, ap1ebs & ap2ebs nodes)
    Suggested IP and Name for LBR:
    IP : 172.25.45.x [should be on same 172.25.45 subnet of ap1ebs & ap2ebs nodes]
    ebiz.xxxx.lk [on port 80 for http protocol accessibility]
    This LBR IP & name must be resolve and respond on DNS network
    Server Farm detail for LBR Setup
    Following detail will be use for configuring the LBR:
    LBR IP and Name :
    IP : 172.25.45.x [should be on same 172.25.45 subnet of ap1ebs & ap2ebs nodes]
    ebiz.xxxx.lk [on port 80 for http protocol accessibility]
    This LBR IP & name must be resolve and respond on DNS network
    Server Farm Detail for LBR setup:
    Server 1 (EBS App1 Node, ap1ebs):
    IP : 172.25.45.19
    Server Name: ap1ebs.xxxx.lk [ap1ebs hostname is an example, actual hostname will be use]
    Protocol: http
    Port: 8000
    Server 2 (EBS App2 Node, ap2ebs):
    IP : 172.25.45.20
    Server Name: ap2ebs.xxxx.lk [ap2ebs hostname is an example, actual hostname will be use]
    Protocol: http
    Port: 8000
    Since my client needs to access URL ebiz.xxxx.lk which should be resolved by IP 172.25.45.21 (virtual IP) via http (80) before they deploy the app on the two servers I just ran web service on both servers (Linux) and was trying to access http://172.25.45.21 it was working fine and gave me index.html page. Now after my client has deployed the application then when he tries to access the page http://172.25.45.21 he cannot see his main login page. But still my testing web servers are there on both servers when I type http://172.25.45.21 it will get index.html page, but not my client web login page. What can I do for this ?
    Following are my latest config :
    probe http Get-Method
      description Check to url access /OA_HTML/OAInfo.jsp
      interval 10
      faildetect 2
      passdetect interval 30
      request method get url /OA_HTML/OAInfo.jsp
      expect status 200 200
    probe udp http-8000-iRDMI
      description IRDMI (HTTP - 8000)
      port 8000
    probe http http-probe
      description HTTP Probes
      interval 10
      faildetect 2
      passdetect interval 30
      passdetect count 2
      request method get url /index.html
      expect status 200 200
    probe https https-probe
      description HTTPS traffic
      interval 10
      faildetect 2
      passdetect interval 30
      passdetect count 2
      ssl version all
      request method get url /index.html
    probe icmp icmp-probe
      description ICMP PROBE FOR TO CHECK ICMP SERVICE
    rserver host ebsapp1
      description ebsapp1.xxxx.lk
      ip address 172.25.45.19
      conn-limit max 4000000 min 4000000
      probe icmp-probe
      probe http-probe
      inservice
    rserver host ebsapp2
      description ebsapp2.xxxx.lk
      ip address 172.25.45.20
      conn-limit max 4000000 min 4000000
      probe icmp-probe
      probe http-probe
      inservice
    serverfarm host ebsppsvrfarm
      description ebsapp server farm
      failaction purge
      predictor response app-req-to-resp samples 4
      probe http-probe
      probe icmp-probe
      inband-health check log 5 reset 500
      retcode 404 404 check log 1 reset 3
      rserver ebsapp1 80
        conn-limit max 4000000 min 4000000
        probe icmp-probe
        inservice
      rserver ebsapp2 80
        conn-limit max 4000000 min 4000000
        probe icmp-probe
        inservice
    sticky http-cookie jsessionid HTTP-COOKIE
      cookie insert browser-expire
      replicate sticky
      serverfarm ebsppsvrfarm
    class-map type http loadbalance match-any default-compression-exclusion-mime-type
      description DM generated classmap for default LB compression exclusion mime types.
      2 match http url .*gif
      3 match http url .*css
      4 match http url .*js
      5 match http url .*class
      6 match http url .*jar
      7 match http url .*cab
      8 match http url .*txt
      9 match http url .*ps
      10 match http url .*vbs
      11 match http url .*xsl
      12 match http url .*xml
      13 match http url .*pdf
      14 match http url .*swf
      15 match http url .*jpg
      16 match http url .*jpeg
      17 match http url .*jpe
      18 match http url .*png
    class-map match-all ebsapp-vip
      2 match virtual-address 172.25.45.21 tcp eq www
    class-map type management match-any remote_access
      2 match protocol xml-https any
      3 match protocol icmp any
      4 match protocol telnet any
      5 match protocol ssh any
      6 match protocol http any
      7 match protocol https any
      8 match protocol snmp any
    policy-map type management first-match remote_mgmt_allow_policy
      class remote_access
        permit
    policy-map type loadbalance first-match ebsapp-vip-l7slb
      class default-compression-exclusion-mime-type
        serverfarm ebsppsvrfarm
      class class-default
        compress default-method deflate
        sticky-serverfarm HTTP-COOKIE
    policy-map multi-match int455
      class ebsapp-vip
        loadbalance vip inservice
        loadbalance policy ebsapp-vip-l7slb
        loadbalance vip icmp-reply active
        nat dynamic 1 vlan 455
    interface vlan 455
      ip address 172.25.45.36 255.255.255.0
      peer ip address 172.25.45.35 255.255.255.0
      access-group input ALL
      nat-pool 1 172.25.45.22 172.25.45.22 netmask 255.255.255.0 pat
      service-policy input remote_mgmt_allow_policy
      service-policy input int455
      no shutdown
    ft interface vlan 999
      ip address 10.1.1.1 255.255.255.0
      peer ip address 10.1.1.2 255.255.255.0
      no shutdown
    ft peer 1
      heartbeat interval 300
      heartbeat count 10
      ft-interface vlan 999
    ft group 1
      peer 1
      no preempt
      priority 110
      associate-context Admin
      inservice
    ip route 0.0.0.0 0.0.0.0 172.25.45.1
    Hope you will reply me soon
    Thanks....!
    -Amal-

  • Urgent!!! Cisco ACE and asymetric routing assistance needed

    I am wondering if someone can give me pointers on the cisco ACE
    and asymetric routes. I've attached the diagram:
    -Cisco IOS IP address is 192.168.15.4/24 and 4.1.1.4/24
    -Firewall External interface is 192.168.15.1/24,
    -Firewall Internal interface is 192.168.192.1/24,
    -F5_BigIP External interface is 192.168.192.4/24,
    -F5_BigIP Internal interface is 192.168.196.1/24 and 192.168.197.1/24,
    -host_y has IP addresses of 192.168.196.10/24 and 192.168.197.10/24,
    -Checkpoint has static route for 192.168.196.0/24 and 192.168.197.0/24
    pointing to the F5_BigIP,
    -host_y is dual-home to both VLAN_A and VLAN_B with the default
    gateway on host_y pointing to VLAN_A which is 192.168.196.1,
    -host_x CAN ssh/telnet/http/https to both of host_y IP addresses
    of 192.168.196.10 and 192.168.197.10.
    In other words, from host_x, when I try to connect to host_y
    via IP address of 192.168.197.10, the traffics will go through VLAN_B
    but the return traffics will go through VLAN_A. Everything
    is working perfectly for me so far.
    Now customer just replaces the F5_BigIP with Cisco ACE. Now,
    I could not get it to work with Asymetric route with Cisco ACE. In
    other words, from host_x, I can no longer ssh or telnet to host_y
    via IP address of 192.168.197.10.
    Anyone knows how to get asymetric route to work on Cisco ACE?
    Thanks in advance.

    That won't work because ACE uses the vlan id to distinguish between flows.
    So when the response comes back on a different vlan, ACE can't find the flow it belongs to and it drops it.
    Even if we could force it to accept the packet, ACE would then try to create a new flow for this packet and it will collide with the flow already existing on the frontend.
    You would need to force your host to respond on the same vlan the traffic came in.
    This could be done with client nat on ACE using different nat pool.
    Gilles.

  • Slow connection in one server if accessing through Cisco ACE

    Hi,
    Good day, Can someone help me on my problem? I have 3 servers, server1, server2 and server3. When one pc accessing the server 3 application via Cisco ACE, it experienced a slow connection but when direct access without Cisco Ace, it's fast. The connection of this PC through cisco ace and direct access have no issue.
    What need to do in my configuration? Below is my configuration
    logging enable
    logging timestamp
    logging trap 7
    logging buffered 7
    logging monitor 7
    logging host 167.81.126.5 udp/514
    logging host 137.55.152.147 udp/514
    resource-class SG_01
      limit-resource all minimum 0.00 maximum unlimited
      limit-resource sticky minimum 10.00 maximum equal-to-min
    boot system image:c4710ace-mz.A3_2_0.bin
    login timeout 30
    peer hostname singapore-ace2
    hostname singapore-ace1
    interface gigabitEthernet 1/1
      channel-group 14
      no shutdown
    interface gigabitEthernet 1/2
      channel-group 14
      no shutdown
    interface gigabitEthernet 1/3
      channel-group 14
      no shutdown
    interface gigabitEthernet 1/4
      channel-group 14
      no shutdown
    interface port-channel 14
      description ISOLAN-ACE-TRUNK
      ft-port vlan 99
      switchport trunk native vlan 1
      switchport trunk allowed vlan 12,14,112
      no shutdown
    clock timezone SGT 8 0
    ntp server 137.55.152.1
    context Admin
      member SG_01
    access-list ALL line 8 extended permit ip any any
    access-list ALL line 9 extended permit icmp any any
    ip domain-name ysn.psg.philips.com
    probe http singapore_01
      description This probe used to monitor application url-app-script
      interval 5
      passdetect interval 5
      request method get url /insiteserverstatus/insiteserverstatus.aspx
      expect status 200 200
      open 1
    probe http singapore_02
      description This probe used to monitor IIS-login-page
      interval 5
      passdetect interval 5
      request method get url /InSiteLumiledsApplication/
      expect status 200 200
      open 1
    probe icmp uplink
      description This probe used in conjunction with ft track host
      interval 2
      faildetect 2
      passdetect interval 3
    parameter-map type connection PARAM_L4STICKY-IP
      exceed-mss allow
    rserver host sggysnysn1ms013
      ip address 137.55.152.135
      inservice
    rserver host sggysnysn1ms014
      ip address 137.55.152.136
      inservice
    rserver host sggysnysn1ms018
      ip address 137.55.152.145
      inservice
    serverfarm host PLI9058
      probe singapore_01
      probe singapore_02
      rserver sggysnysn1ms013
        inservice
      rserver sggysnysn1ms014
        inservice
      rserver sggysnysn1ms018
        inservice
    sticky ip-netmask 255.255.255.255 address both SG_GROUP_01
      timeout 720
      replicate sticky
      serverfarm PLI9058
    class-map type management match-any HTTPS-ALLOW_CLASS
    class-map match-all L4STICKY-IP_141:ANY_CLASS
      2 match virtual-address 137.55.152.141 any
    class-map type http loadbalance match-any NO_MS018
      50 match source-address 137.55.155.31 255.255.254.0
    class-map type management match-any SSH-ALLOW_CLASS
      2 match protocol ssh source-address 167.81.124.0 255.255.255.192
      3 match protocol ssh source-address 167.81.126.0 255.255.255.192
    class-map type management match-any remote_access
      2 match protocol xml-https any
      3 match protocol icmp any
      5 match protocol ssh any
      6 match protocol http any
      7 match protocol https any
      8 match protocol snmp any
    policy-map type management first-match remote_mgmt_allow_policy
      class remote_access
        permit
    policy-map type loadbalance first-match L7PLBSF_STICKY-NETMASK_POLICY
      class class-default
        sticky-serverfarm SG_GROUP_01
        insert-http X-Forwarded-For header-value "%is"
    policy-map multi-match PLI9058-VIPs_POLICY
      class L4STICKY-IP_141:ANY_CLASS
        loadbalance vip inservice
        loadbalance policy L7PLBSF_STICKY-NETMASK_POLICY
        loadbalance vip icmp-reply
        connection advanced-options PARAM_L4STICKY-IP
    interface vlan 12
      description Client-side vlan
      bridge-group 1
      no normalization
      mac-sticky enable
      access-group input ALL
      access-group output ALL
      service-policy input PLI9058-VIPs_POLICY
      no shutdown
    interface vlan 14
      ip address 137.55.152.236 255.255.255.248
      peer ip address 137.55.152.237 255.255.255.248
      service-policy input remote_mgmt_allow_policy
      no shutdown
    interface vlan 112
      description Server-side vlan
      bridge-group 1
      no normalization
      access-group input ALL
      access-group output ALL
      nat-pool 1 137.55.152.141 137.55.152.141 netmask 255.255.255.192 pat
      no shutdown
    interface bvi 1
      ip address 137.55.152.189 255.255.255.192
      alias 137.55.152.188 255.255.255.192
      peer ip address 137.55.152.190 255.255.255.192
      description Bridge-Group 1 Virtual Interface
      no shutdown
    ft interface vlan 99
      ip address 192.168.1.1 255.255.255.252
      peer ip address 192.168.1.2 255.255.255.252
      no shutdown
    ft peer 1
      heartbeat interval 100
      heartbeat count 10
      ft-interface vlan 99
    ft group 1
      peer 1
      priority 150
      peer priority 50
      associate-context Admin
      inservice
    ft track host test1
      track-host 137.55.152.234
      peer track-host 137.55.152.235
      peer probe uplink priority 50
      probe uplink priority 50
    ip route 0.0.0.0 0.0.0.0 137.55.152.233

    Hi Earsdale,
    All the three servers are using the same configuration, so, I'm afraid it's not possible to give you a simple answer. You will need more troubleshooting.
    I would recommend you to start by checking the differences between the servers because one of those differences is certainly causing the failure.
    Also, it would be helpful to get traffic captures on the TenGig interface of the ACE to compare the behavior of the connection when going to the different servers, as well as the differences when being load-balanced vs accessing the server directly.
    If you need help with this troubleshooting, you can always open a TAC service request
    Regards
    Daniel

  • Cisco ACE - "show conn" command queries

    Hi all,
    i have some queries regarding the "show conn" command in Cisco ACE.
    Working Scenario:
    VIP : 10.10.10.1
    Server 1 : 10.10.20.1
    Server 2 : 10.10.20.2
    Client: 30.30.30.1
    When a client 30.30.30.1 initiates a connection to the VIP on 10.10.10.1, the ACE load balances it to Server 1, 10.10.20.1. Looking at the "show conn" table, it shows that Server 1 is replying back to the Client 30.30.30.1 through the ACE.
    Now, my question is when the ACE returns the traffic to the Client, should the Client be seeing the source IP coming from the VIP or Server 1? My understanding is that the Client should be seeing traffic returning from the VIP. But the show conn table does not seem to suggest so.
    show conn table
    conn-id    np dir proto vlan source                destination           state
    ----------+--+---+-----+----+---------------------+---------------------+------+
    1768       1  in  TCP   10   30.30.30.1:9221   10.10.10.1:80       ESTAB
    41         1  out TCP   52    10.10.20.1:80    30.30.30.1:9221   CLOSED

    Daniel,
    The client is expecting a response from the VIP otherwise there would be an asymmetrical routing problem and conns will never complete.
    The fact that you're seeing 30.30.30.1 as the destination address is just that the server is able to see client's IP address on the request, when your backend servers sends the reply back to the client this response is forced to go through the ACE, when the ACE looks at the packet it matches with a previously conn created on the flow table so it "NATs"  the reply so now the source of the packet is the VIP and destination is 30.30.30.1.
    This is a expected behavior as you're not using S-NAT on your network.
    HTH.
    Pablo

  • VPC / Cisco ACE and the Nexus 2K and 5K

    Hi all,
    So we have a test environment that looks like the following. We have 2 5K's switch 1 and switch 2. Switch 1 has two 10gb connections downstream to a 2K and switch 2 has two 10Gb connections downstream to the other 2K. We have a few servers that are multi-homed with LACP and VPC via the 2Ks and it works a treat.
    We have our Cisco ACE 01, ports 1 and 2 going to one of the 2K's and we have ports 3 and 4 going to the other 2K, ACE02 ports 1 and 2 going to one of the 2K's and we have ports 3 and 4 going to the other 2K. If i enable VPC and none LACP based etherchannel i cannot get the ACE's talking to each other, but looking at the VPC status its all healthy and up.
    Has anyone managed to multi-home the ACE between two 2K's with VPC successfully? 
    If I disable the links so each ACE only has links upstream in a traditional port-channel and not cross connected, the ACE's can see each other with no issues.
    Cheers

    Doh.. so we had a cable patching issue in the end. Let this be a lesson to all networking chaps - always check the basics first! Now we have patched the cables as per design the VPC has been established and works.
    Now we  have VPC is working we are simulating link failures. When we restore a shutdown physical port within the port-channel/VPC that sits between the 2K and ACE (simulating a port failure) the ACE's lose sight of each other for about 10 seconds and causes an short outage until the port is up and up. The logs on the ACE show 'the Peer x.x.x.x is not reachable. Error: Heartbeat stopped. No alternate interface configured' but the VLAN for the FT interface is carried over all four ACE NIC's that are multi-homed to two 2K's... very strange, i would not expect this, it's like the MAC addresses for the FT interface are waiting to be timed out on the 2K until they are switched on another interface within the port-channel and VPC.
    Anyone seen this before?

  • Cisco ACE & MARS

    Can Cisco ACE be added to CSMARS.
    MARS version is 5.3.2

    If a device not supported by MARS can send syslog in clear text format, then it can be parsed by MARS using a custom parser.
    The customer parser allows you to define new devices and applications in order that they can report to MARS.
    The reason why you need the syslog servers to work with MARS is that the more devices you can have reporting to MARS the greater the accuracy of the analysis it provides.
    In a nutshell this is how MARS works (with a tip of the cap to Dale Tesch):
    The logging data from devices is used in parallel by MARS with the information gleaned from querying network device routing tables, configurations, ARP tables, CAM tables, system probes, and other processes to determine the topology of the network and the location of devices.
    After log data is collected and the alert information is analyzed, it is cross-referenced with this topology information to determine its validity and to calculate attack paths.
    MARS was built to enhance the common data provided by syslog and SNMP. Once the data from multiple devies is summarized it can be used both as an early warning alert system and as a forensics tool to analyze successful attacks.
    Hope this helps.
    Paul

  • Cisco ACE module missing licence file - no connectivity

    Hi,
    We have 2 ACE modules that were delivered without any licenses.
    There is no IP connectivity whatsoever to these modules and I'm guessing this is due to the fact there are no licenses installed.
    Have tried asking Cisco to no avail - and am not sure if there is an actual problem with them or not.
    The VLANs are assigned correctly and I can see inbound ICMP echo from the 6509 that its hosted in, but no outbound packets ever leave the ACE. I've applied a mgmt policy to enable ping/telnet/ssh etc.
    switch/Admin# sh vlans
    Vlans configured on SUP for this module
    vlan4  vlan30-31  vlan160  vlan180-195  vlan360  vlan380-395  vlan560  vlan580-
    595  vlan760  vlan780-795
    switch/Admin# sh ip int bri
    Interface       IP-Address      Status                  Protocol
    vlan4           10.119.127.196  up                      up
    vlan30          10.119.127.241  up                      up
    vlan31          10.119.127.245  up                      up
    interface vlan 4
      description ACE Mgmt interface for Admin Context
      ip address 10.119.127.196 255.255.255.224
      service-policy input REMOTE_MGMT
      no shutdown
    vlan4 is up
      Hardware type is VLAN
      MAC address is 00:1f:ca:7b:6f:33
      Mode : routed
      IP address is 10.119.127.196 netmask is 255.255.255.224
      FT status is non-redundant
      Description:ACE Mgmt interface for Admin Context
      MTU: 1500 bytes
      Last cleared: never
      Alias IP address not set
      Peer IP address not set
      Assigned from the Supervisor, up on Supervisor
      Config download failures : 1
         2980 unicast packets input, 16363862 bytes
         240857 multicast, 3026 broadcast
         0 input errors, 0 unknown, 0 ignored, 0 unicast RPF drops
         0 unicast packets output, 187712 bytes
         0 multicast, 2933 broadcast
         0 output errors, 0 ignored
    switch/Admin# sh arp
    Context Admin
    ================================================================================
    IP ADDRESS      MAC-ADDRESS        Interface  Type      Encap  NextArp(s) Status
    ================================================================================
    10.119.127.193  00.00.00.00.00.00  vlan4     GATEWAY    -       * 3 req     dn
    10.119.127.196  00.1f.ca.7b.6f.33  vlan4     INTERFACE  LOCAL     _         up
    10.119.127.245  00.1f.ca.7b.6f.33  vlan31    INTERFACE  LOCAL     _         up
    10.119.127.241  00.1f.ca.7b.6f.33  vlan30    INTERFACE  LOCAL     _         up
    ================================================================================
    Total arp entries 4
    The ARP table for the adjacent switch SVI has a valid MAC upon reboot, but soon after resets to 00.00.00.00.00.00
    Problem is that once Cisco eventually send me the license file I have no way of TFTP'ing it to the ACE module.
    Any suggestions/advice?

    Thanks for the info - so I should at least be able to connect to a license-less ACE at least, but these modules seem to have a problem.
    If the modules are reloaded (from the ACE) or reset (from the Supervisor) they initially have the ARP entry (however still cannot communicate to the attached Supervisor via SVI) which eventually resets.
    Info as requested:
    switch/Admin# sh resource usage
                                                         Allocation
            Resource         Current       Peak        Min        Max       Denied
    Context: Admin
      conc-connections              9          9          0          0          0
      mgmt-connections              0          0          0          0          0
      proxy-connections             0          0          0          0          0
      xlates                        0          0          0          0          0
      bandwidth                     0         76          0  125000000  296849008
        throughput                  0         76          0          0  296849008
        mgmt-traffic rate           0          0          0  125000000          0
      connection rate               0          2          0          0         15
      ssl-connections rate          0          0          0          0          0
      mac-miss rate                 0          0          0          0          0
      inspect-conn rate             0          0          0          0          0
      acl-memory                    0       6336          0          0         11
      sticky                        0          0          0          0          0
      regexp                        0          0          0          0          0
      syslog buffer                 0          0          0          0          0
      syslog rate                   0          0          0          0         24
    Context: APPLICATION
      conc-connections              0          0    2000000          0          0
      mgmt-connections              0          0      25000          0          0
      proxy-connections             0          0     262144          0          0
      xlates                        0          0     262144          0          0
      bandwidth                     0          0  125000000  125000000          0
        throughput                  0          0  125000000          0          0
        mgmt-traffic rate           0          0          0  125000000          0
      connection rate               0          0     250000          0          0
      ssl-connections rate          0          0        250          0          0
      mac-miss rate                 0          0        500          0          0
      inspect-conn rate             0          0       1500          0          0
      acl-memory                    0          0   19650480          0          0
      sticky                        0          0     419430          0          0
      regexp                        0          0     262144          0          0
      syslog buffer                 0          0    1048576          0          0
      syslog rate                   0          0      25000          0          0
    Context: BACK_END
      conc-connections              0          0    2000000          0          0
      mgmt-connections              0          0      25000          0          0
      proxy-connections             0          0     262144          0          0
      xlates                        0          0     262144          0          0
      bandwidth                     0          0  125000000  125000000          0
        throughput                  0          0  125000000          0          0
        mgmt-traffic rate           0          0          0  125000000          0
      connection rate               0          0     250000          0          0
      ssl-connections rate          0          0        250          0          0
      mac-miss rate                 0          0        500          0          0
      inspect-conn rate             0          0       1500          0          0
      acl-memory                    0          0   19650480          0          0
      sticky                        0          0     419430          0          0
      regexp                        0          0     262144          0          0
      syslog buffer                 0          0    1048576          0          0
      syslog rate                   0          0      25000          0          0
    Context: FRONT_END
      conc-connections              0          0    2000000          0          0
      mgmt-connections              0          0      25000          0          0
      proxy-connections             0          0     262144          0          0
      xlates                        0          0     262144          0          0
      bandwidth                     0          0  125000000  125000000          0
        throughput                  0          0  125000000          0          0
        mgmt-traffic rate           0          0          0  125000000          0
      connection rate               0          0     250000          0          0
      ssl-connections rate          0          0        250          0          0
      mac-miss rate                 0          0        500          0          0
      inspect-conn rate             0          0       1500          0          0
      acl-memory                    0          0   19650480          0          0
      sticky                        0          0     419430          0          0
      regexp                        0          0     262144          0          0
      syslog buffer                 0          0    1048576          0          0
      syslog rate                   0          0      25000          0          0
    Context: TEST_DEV
      conc-connections              0          0    2000000          0          0
      mgmt-connections              0          0      25000          0          0
      proxy-connections             0          0     262144          0          0
      xlates                        0          0     262144          0          0
      bandwidth                     0          0  125000000  125000000          0
        throughput                  0          0  125000000          0          0
        mgmt-traffic rate           0          0          0  125000000          0
      connection rate               0          0     250000          0          0
      ssl-connections rate          0          0        250          0          0
      mac-miss rate                 0          0        500          0          0
      inspect-conn rate             0          0       1500          0          0
      acl-memory                    0          0   19650480          0          0
      sticky                        0          0     419430          0          0
      regexp                        0          0     262144          0          0
      syslog buffer                 0          0    1048576          0          0
      syslog rate                   0          0      25000          0          0
    switch/Admin# sh cde health
    CDE BRCM INTERFACE
    ======================
    Packets received                                             3357
    Packets transmitted                                            12
    Broadcom interface CRC error count                              0
    BRCM VOQ status                           [empty]      [not full]
    BRCM pull status                                        [pulling]
    CDE HYPERION INTERFACE
    ======================
    Packets received                                          7668407
    Packets transmitted                                        967915
    Short packets drop count                                        0
    Fifo Full drop count                                            0
    Protocol error drop count                                       0
    FCS error drop count                                            0
    CRC error drop count                                            0
    Num times flow control triggered on hyp interface                0
    Num self generated multicast packets filtered              967915
    HYP IXP0 VOQ status                       [empty]      [not full]
    HYP IXP1 VOQ status                       [empty]      [not full]
    HYP SLOW VOQ status                       [empty]      [not full]
    HYP tx pull status                                      [pulling]
    CDE IXP0 INTERFACE
    ======================
    Packets received                                           964680
    Packets transmitted                                       6581196
    Num bad pkts recvd on fast spi channel0                         0
    Num bad pkts recvd on slow spi channel8                         0
    Num bad pkts recvd on fast spi channel2                         0
    Num bad pkts recvd on slow spi channel4                         0
    IXP0 Fast VOQ status                      [empty]      [not full]
    IXP0 BRCM VOQ status                      [empty]      [not full]
    IXP0 pull status                                        [pulling]
    IXP0 spi src status                                     [healthy]
    IXP0 spi snk status                                     [healthy]
    CDE1 SWITCH1 INTERFACE
    ======================
    Packets received (hyp, ixp0)                                 3241
    Packets received (bcm)                                          6
    Packets received (daughter card 0)                              0
    Packets received (daughter card 1)                              0
    Packets Errors received (hyp, ixp0)                             0
    Packets Errors received (bcm)                                   0
    Packets Errors received (daughter card 0)                       0
    Packets Errors received (daughter card 1)                       0
    Packets transmitted (ixp1)                                 122653
    Packets transmitted (nitrox)                                    0
    Packets Errors transmitted (ixp1)                               0
    Packets Errors transmitted (nitrox)                             0
    CDE2 SWITCH2 INTERFACE
    ======================
    Packets received (ixp1)                                    122653
    Packets received (nitrox)                                       0
    Packets Errors received (ixp1)                                  0
    Packets Errors received (nitrox)                                0
    Packets transmitted (hyp, ixp0)                              3241
    Packets transmitted (broadcom)                                  6
    Packets transmitted (daughter card 0)                           0
    Packets transmitted (daughter card 1)                           0
    Packets Errors transmitted (ixp1)                               0
    Packets Errors transmitted (nitrox)                             0
    Packets Errors transmitted (daughter card 0)                    0
    Packets Errors transmitted (daughter card 1)                    0
    CDE IXP1 INTERFACE
    ======================
    Packets received                                             3247
    Packets transmitted                                        122653
    Num bad pkts recvd on fast spi channel0                         0
    Num bad pkts recvd on slow spi channel8                         0
    Num bad pkts recvd on fast spi channel2                         0
    Num bad pkts recvd on slow spi channel4                         0
    IXP1 Fast VOQ status                      [empty]      [not full]
    IXP1 BRCM VOQ status                      [empty]      [not full]
    IXP1 pull status                                        [pulling]
    IXP1 spi src status                                     [healthy]
    IXP1 spi snk status                                     [healthy]
    CDE NITROX INTERFACE
    ======================
    Packets received                                                0
    Packets transmitted                                             0
    Num bad pkts recvd on fast spi channel0                         0
    Num bad pkts recvd on slow spi channel8                         0
    Num bad pkts recvd on fast spi channel2                         0
    Num bad pkts recvd on slow spi channel4                         0
    NTX Fast VOQ status                       [empty]      [not full]
    NTX BRCM VOQ status                       [empty]      [not full]
    NTX pull status                                         [pulling]
    NTX spi src status                                      [healthy]
    NTX spi snk status                                      [healthy]
    == Backplane ==
    ITASCA_SYS_CNTL1 0x300  data 0x61f0000
    ITASCA_SYS_CNTL2 0x304  data 0x80630000

  • Cisco ACE Module with Bluecoat Cache Proxy, Transparent and spoofing client IP

    Hello Dears,
    I'm trying to implement Cache loadbalancing through Cisco ACE Module.
    I have 2 Bluecoat cache proxies, when i do configure transparent proxy without spoofing client IP, everything work properly, but when I enable spoofing client IP (reflect client IP address), clients are not able to access internet, although they are going to cache servers, I can see their sessions.
    I'm afraid that I have a problem in the returned traffic PBR.
    can anyone help please.
    Thanks

    Hi Ibrahim
    I ahve reviewed the config. The ACE config is all god but I do see some issue with the switch side. If you are doing ip spoofing, then "match ip address" in pbr should be the client ip address. However, what you did is ip address between the ACE and MSFC. Try to configure the test client ip address into the below access-list.
    msfc---vlan 265---ACE--vlan 264----CE farm
    interface vlan 265
      description Interface_With_MSFC_SUBS_2_INTERNET
      ip address 168.168.1.52 255.255.255.248
      access-group input PERMIT_ALL
      service-policy input L3L4_PM
      no shutdown
    ip route 0.0.0.0 0.0.0.0 168.168.1.50
    ip access-list extended HSDPA_2_CACHE
    permit tcp 168.168.0.0 0.0.255.255 any eq www   <<<-- wrong
    ip access-list extended Internet_2_CACHE
    permit tcp any eq www 168.168.0.0 0.0.255.255   <<<---wrong
    interface Vlan 265
    description Interface_With_ACE
    ip address 168.168.1.50 255.255.255.248
    route-map INTERNET_2_HSDPA permit 10
    description "PBR for Response HTTP Traffic"
    match ip address Internet_2_CACHE
    set ip next-hop 168.168.1.52
    route-map HSDPA_2_INTERNET permit 10
    match ip address HSDPA_2_CACHE
    set ip next-hop 168.168.1.52
    regards
    Andrew

  • Cisco ACE loadbalancing matching more than one header in L7 class map

    Dear All,
    This is regarding Cisco ACE loadbalancing matching more than one header in L7 class map. I have a small setup with ACE 30 module in Cisco6500. I have got three webservers. Presently I have following configuration where I am mathing one url header.
    class-map type http loadbalance match-all L7_WEB_HEADER_MATCH
    description MATCH THE HOST HEADER OF HTTP REQUEST
    2 match http header Host header-value ".*abhisar.com*"
    So for above configuration, when traffic is coming for abhisar.com, it is working fine.
    Now, I have following headers and DNS entry is pointing to same virtual IP for all http url header same as abhisar.com
    abhisarindia.com
    indiaabhi.com
    So new configuration will be
    class-map type http loadbalance match-any L7_WEB_HEADER_MATCH
    description MATCH THE HOST HEADER OF HTTP REQUEST
    2 match http header Host header-value ".*abhisar.com*"
    4 match http header Host header-value ".*abhisarindia.com*"
    6 match http header Host header-value ".*indiaabhi.com*"
    So just want to confirm if this is fine.
    Thank You,
    Abhisar.

    Dear Rajesh,
    Thank you for reply. I will let you know once I carry out this activity.
    Thank You,
    Abhisar.

  • Standby cisco ACE loadbalancer issues (network connectivity)

    Hi ALL,
                We are having issues with the secondary (standby) load balancer ACE module on a 6500 switch. We see that the loadblanacer is not able to get onto the network which leads to problem with fault tolerance as well. Following is the ft status found on the load balancer for one of the contexts (this is the same pattern seen on all the contexts).
    switch/Admin# sh ft group status
    FT Group                     : 1
    Configured Status            : in-service
    Maintenance mode             : MAINT_MODE_OFF
    My State                     : FSM_FT_STATE_ACTIVE
    Peer State                   : FSM_FT_STATE_UNKNOWN
    Peer Id                      : 1
    No. of Contexts              : 1
    Sh arp on all the contexts shows the gateway/rserver to be unreachable. Please find the screenshot below for one of the contexts (the same pattern is seen on the LB for all other contexts)
    switch/1_Context# sh arp
    Context CSD_Context
    ================================================================================
    IP ADDRESS      MAC-ADDRESS        Interface  Type      Encap  NextArp(s) Status
    ================================================================================
    172.21.128.97   00.00.00.00.00.00  vlan942   GATEWAY    -                   dn
    172.21.128.103  00.0b.fc.fe.1b.09  vlan942   ALIAS      LOCAL     _         up
    172.21.128.105  00.12.43.dc.93.23  vlan942   INTERFACE  LOCAL     _         up
    7.0.0.4         00.0b.fc.fe.1b.09  vlan943   NAT        LOCAL     _         up
    - 7.0.0.6
    172.21.147.196  00.0b.fc.fe.1b.09  vlan943   ALIAS      LOCAL     _         up
    172.21.147.198  00.12.43.dc.93.24  vlan943   INTERFACE  LOCAL     _         up
    172.21.147.200  00.00.00.00.00.00  vlan943   RSERVER    -       * 3 req     dn
    172.21.147.202  00.00.00.00.00.00  vlan943   RSERVER    -       * 2 req     dn
    172.21.147.204  00.00.00.00.00.00  vlan943   RSERVER    -                   dn
    172.21.147.206  00.00.00.00.00.00  vlan943   RSERVER    -                   dn
    172.21.147.208  00.00.00.00.00.00  vlan943   RSERVER    -       * 3 req     dn
    172.21.147.210  00.00.00.00.00.00  vlan943   RSERVER    -       * 2 req     dn
    172.21.147.212  00.00.00.00.00.00  vlan943   RSERVER    -       * 1 req     dn
    172.21.147.214  00.00.00.00.00.00  vlan943   RSERVER    -       * 1 req     dn
    172.21.147.216  00.00.00.00.00.00  vlan943   RSERVER    -       * 3 req     dn
    7.0.0.1         00.0b.fc.fe.1b.09  vlan943   NAT        LOCAL     _         up
    - 7.0.0.3
    The problem is that we see the problem only on the secondary loadbalancer. primary is just running file
    also i can see some traffic denial in admin context for resource usage
    switch/Admin# sh resource usage
                                                         Allocation
            Resource         Current       Peak        Min        Max       Denied
    Context: Admin
      conc-connections              9          9     160000    6560000          0
      mgmt-connections              0         46       2000      82000          0
      proxy-connections             0          4      20972     859830          0
      xlates                        0          0      20972     859830          0
      bandwidth                     0   17715713   10000000  535000000    5799749
        throughput                  0   17710993   10000000  410000000    5799749
        mgmt-traffic rate           0       4720          0  125000000          0
      connection rate               0         43      20000     820000          0
      ssl-connections rate          0          0        100       4100          0
      mac-miss rate                 0          1         40       1640          0
      inspect-conn rate             0          0        120       4920          0
      acl-memory                56336      56336    1570072   64460552          6
      sticky                        0          0      83886          0          0
      regexp                        0          0      20972     859832          0
      syslog buffer             82944      82944      82944    3447808          0
      syslog rate                   0         44       2000      82000         25
    Context: INTEGRATION_Context
      conc-connections              0       3934     160000          0          0
      mgmt-connections              0         98       2000          0          0
      proxy-connections             0         33      20972          0          0
      xlates                        0          0      20972          0          0
      bandwidth                     0   10019910   10000000  125000000      40857
        throughput                  0   10000000   10000000          0      40857
        mgmt-traffic rate           0      19910          0  125000000          0
      connection rate               0         49      20000          0          0
      ssl-connections rate          0          0        100          0          0
      mac-miss rate                 0         32         40          0          0
      inspect-conn rate             0         58        120          0          0
      acl-memory                11920      11920    1570072          0          0
      sticky                        0          1      83886          0          0
      regexp                        0          0      20972          0          0
      syslog buffer                 0      82944      82944    3447808          0
      syslog rate                   0        312       2000          0          0
    these above 2 contexts are the only one which has bandwidth resource usage exceeding the limit. but i somehow am not sure if this is the issue. as there is just no traffic on the secondary .. then how can the bandwidth reach the threshold? can anyone throw some light on the below issue?
    thanks and regards
    kiran

    vlan on Standby_ACE switch
    svclc multiple-vlan-interfaces
    svclc module 1 vlan-group 1,4,12,13,
    svclc vlan-group 1  968
    svclc vlan-group 12  132
    svclc vlan-group 13  367-372,374,375,379,380,538,805,807,808,818,913,915
    svclc vlan-group 13  917-920,922-924,933,934,937,938,942-949,972,976-979,983
    svclc vlan-group 13  984
    ip subnet-zero
    no ip source-route
    vlans on standby ACE
    switch/Admin# sh vlans
    Vlans configured on SUP for this module
    vlan132  vlan360  vlan367-375  vlan379-380  vlan538  vlan805  vlan807-808  vlan818  vlan913  vlan91
    5  vlan917-920  vlan922-924  vlan930  vlan933-934  vlan937-938  vlan942-949  vlan968  vlan971-972  v
    lan976-979  vlan983-984
    switch/Admin#
    Active_LB_host_switch is the switch hosting the  active ACE thats connected on ten7/4 and 8/4 which is bundeled and made into
    port-channel (po72)
    CDP neighbor hosting the active ACE
    Active_LB_host_switch
                     Ten 7/4           148          R S I     WS-C6513  Ten 7/4
    Active_LB_host_switch
                     Ten 8/4           156          R S I     WS-C6513  Ten 8/4
    Po72 allows all the vlans which is the configured for ACE modules.
    Port                Vlans allowed on trunk
    Po72                132,140,181,359-383,538,668,702,805-808,815-816,818-820,836,907,909-920,922-925,
                929-935,937-949,967-973,976-984,987,3212
    vlan 968 is the FT vlan and the same hass been allowed on the trunk port.
    everything looks good to me but still not sure why isnt the ACE module not coming to the network. it was working fine
    a few months back but all of a sudden it lost the network connectivity. i am not even able to ping the physical ip of the
    ACE module.
    thanks and regards
    kiran

  • Cisco ACE A2(2.0) - webhost-redirection

    Hello,
    We are currently running the version ACE A2(2.0), pretty old one on Cisco ACE Module.  We have applied webhost-redirection https://%h%p 302 but it doesn't seem to take effect and always go back to the host header value.
    Is it a bug or a missing feature within A2(2.0) build ?
    Please assist.
    Thanks.

    Also is there a way to check in ACE logs as to what are the redirects taking place to identify any issues etc.
    Thanks.

  • Cisco ACE dynamic rerouting (dc to dc failover)

    Good day,
    We currtenly have two dc's (site A and site B)
    We are using netapps as our SAN and we ar booting our server directly from the SAN
    SAN A and SAN B are insync and the network between site A and site B is routed.
    The challange:
    When a server is failover from site A to B it still has an ip adress that is routed to site A.(due to the SAN boot)
    We have a cold - hot design in regards to the servers (so no clustering of ESX)
    I have been reading about cisoc ACE and i think that it would solve the challange by dynamily updateing OSPF.
    Can any one please confirm that cisco ACE will solve this challlange (whitout the need for any other additional hardware)
    Thanks a lot,
    Regards,
    joli-coeur Wouter
    (CCIE Security 23078)

    It's more related to disaster recovery planning than ACE configuration
    The cleanest way is to use L2 extension.
    Otherwise you can use VMWare SRM to change the ip addresses of your VMs, or run an OSPF process and replicate all the subnets and put it in the "shutdown state" (or announcing it with a very high cost, proximity routing will do the rest - ACE module can do this for the VIPs with OSPF route health injection, ACE4710 doesn't support RHI but on the upstream router you can define an IP SLA probe and perform conditionnal redistribution), or use a dummy VRF with all your subnets and when enabling DRP, perform route leaking... use NAT with DNS-based failover etc...
    There is no generic answer to your problem.

  • How can ftp service on non-standard port be load balanced using Cisco ACE.

    How can ftp service on non-standard port be load balanced using Cisco ACE.For example ftp service required on tcp 2000 port

    Hi Samarjit,
    you can do this by specifying the port number in the class map that you create . Please find the below mentioend config guide where you can specify the tcp/udp port , range or ports or even the wild card to match the port.
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/v3.00_A1/configuration/administration/guide/mapolcy.html#wp1318826
    Regards
    Abijith

Maybe you are looking for

  • How can I save downloaded iOS system updates when using multiple iPhones

    I have multiple iPhones, and every time I want to update them, I have to wait forever for these downloads to transfer. The update downloads, but is not saved so that I can use it for another iPhone, requiring me to download the same file yet again, a

  • How do I batch convert .ai to .jpg or .png in Bridge CC 2014?

    I have found where you could "Export" them out in older versions of Bridge but no "Export" function exist in CC 2014.

  • The $1 million question

    Hello to all and I hope that someone can help. I have been accustomed to using the magnifier tool under windows, being a horizontal bar on top of the screen which magnifies the area of the mouse. The advantage of this tool is that I keep my full wind

  • DAQcard 6024E crashes with windows 2000

    I am using a daqcard with windows 2000pro and labview 7 and it occasionally stops responding and I have to do multiple re-boots of the pc before it starts working again. it also seems to occasionaly have problems being recognised by windows and max,

  • Business Partner Issue

    Dear Guys, We have attached custom function modules to BP Events (using TCode BUS7). All these function modules getting called in Dialog Mode (Transaction BP) but these function module are not getting called when we use BAPI BAPIBUSISM007_CREATEFROMD