Redistributing Routes based on TAGS

Hi,
I have a bunch of static routes I am RD'ing into OSPF and marking with a tag of 123
I want to then RD these routes ( only routes marked with tag 123) into EIGRP.
Can I achieve this with a route-map and a command in my EIGRP statement?
I'll start with
route-map RD-123 permit 10
match tag 123
Do I then need to deny everything else with another sequence number?
Can I achieve what I am trying to do above?
Thanks

Hi,
yes, you can do that.
If you redistribute your static routes to OSFP tagging with 123 on one router, you can then configure on another router:
router eigrp x
redistribute ospf y route-map RD-123
uisng your route-map suggested in your original post. You deon't need any deny entry in the route-map.
You can even use
redistribute ospf y match external 2 route-map RD-123
to be safer.
Best regards,
Milan

Similar Messages

  • [svn:fx-trunk] 11483: Adding a LRU cache for the transcoding results of a CFF based DefineFont4 tag to avoid transcoding the same font description twice .

    Revision: 11483
    Author:   [email protected]
    Date:     2009-11-05 16:01:37 -0800 (Thu, 05 Nov 2009)
    Log Message:
    Adding a LRU cache for the transcoding results of a CFF based DefineFont4 tag to avoid transcoding the same font description twice.
    Also we now throw a better error when CFFFontManager is asked to embed a local font by name as this is not yet supported.
    QE notes: Please test that the same font embedded twice does not take twice as long as a single embedding.
    Doc notes: N/A
    Bugs:
    SDK-23966 - Compiler should generate a warning or error when embedAsCFF is true and src:local is used for font embedding
    SDK-23806 - OEM compiler appears to transcode embedded fonts twice
    SDK-23788 - Search fonts recursively
    Reviewer: Paul
    Tests run: Checkintests, bug test cases
    Is noteworthy for integration: Yes
    Ticket Links:
        http://bugs.adobe.com/jira/browse/SDK-23966
        http://bugs.adobe.com/jira/browse/SDK-23806
        http://bugs.adobe.com/jira/browse/SDK-23788
    Modified Paths:
        flex/sdk/trunk/lib/flex-fontkit.jar
        flex/sdk/trunk/modules/swfutils/src/java/flash/fonts/FontDescription.java
        flex/sdk/trunk/modules/swfutils/src/java/flash/swf/tags/DefineFont4.java

  • Select Switch Executive Route based on Socket Index

    Hi,
    I have a sequence set up in TestStand which simultaneously tests up to 4 UUT's. In order to run a current measurments, I need to be able to switch each device through the DMM. I have the routes properly configured in Swith Executive, and everything runs fine when I switch manually using the Test Panel feature. What I need to do now though, is choose which device is routed to the DMM based on its test socket number. 
    So, for the "Measure Current" test step on "Test Socket 0", I go to the Properties>Switching window and just select "Connect_UUT0" route group. This works fine for a single test socket, but how can I dynamically switch route when I have more than one UUT?
    I'm aware of the "RunState.TestSockets.MyIndex" variable, but I can't seem to select a route based on this. ie: In "Routes to Connect" I typed "Str(Connect_UUT)+Str(RunState.TestSockets.MyIndex)" after I read a similar solution on this forum, but I just get an error.
    I'd really appresciate some help on this,
    Thanks,
    Kevin
    Solved!
    Go to Solution.

    Hey Kevin,
    You shouldn't need to do Str(Connect_UUT). You're likely getting the error because it's trying to interpret Connect_UUT as a variable instead of a string. Try this instead:
    "Connect_UUT"+Str(RunState.TestSocks.MyIndex)
    I think that will work, but let us know if you run into any more trouble!
    Daniel E.
    TestStand Product Support Engineer
    National Instruments

  • Router based activity  and method call issue

    Hi All
    Iam presently working of Router based task flow(Bounded task flow) and page fragments
    here in above router based task flow i have used the method call.
    In above method call i return status ,and on basis of that status i redirect it to success page or error page(the success and error page are page fragments i.e. .jsff page).
    i have done the drag and drop of the above mentioned router based task flow in my jspx page in a facet as a region.
    below is the code for the my jspx page
    <af:region value="#{bindings.testtaskflowvalidations.regionModel}"
                           id="r1"/>but my problem is that the method call which i included in above router based ,that method is not called(method call is not being happened).
    So what changes i need to make so that the method is being is called.
    currently iam using jdevloper 11.1.1.4.0
    Thanks and Regards
    Bipin Patil.
    Edited by: Bipin Patil on Jun 29, 2011 1:59 AM

    Hi
    iam not getting any kinds of server errors.
    below is my router code
    <?xml version="1.0" encoding="windows-1252" ?>
    <adfc-config xmlns="http://xmlns.oracle.com/adf/controller" version="1.2">
      <task-flow-definition id="ValidationTaskFlow">
        <default-activity id="__1">ValidationTask</default-activity>
        <managed-bean id="__25">
          <managed-bean-name id="__24">validationBean</managed-bean-name>
          <managed-bean-class id="__27">com.test.Validate</managed-bean-class>
          <managed-bean-scope id="__26">pageFlow</managed-bean-scope>
        </managed-bean>
        <router id="ValidationTask">
          <case>
            <expression>#{pageFlowScope.Validationstatus == 'true'}</expression>
            <outcome id="__2">success</outcome>
          </case>
          <case>
            <expression>#{pageFlowScope.Validationstatus == 'false'}</expression>
            <outcome id="__3">fail</outcome>
          </case>
          <default-outcome>fail</default-outcome>
        </router>
        <view id="validationsuccess">
          <page>/pages/main.jsff</page>
        </view>
        <view id="validationerror">
          <page>/pages/hashkeyvalidationerror.jsff</page>
        </view>
        <method-call id="ValidationStatusSupplier">
          <method>#{pageFlowScope.validationBean.onBeforePhase}</method>
          <outcome id="__9">
            <fixed-outcome>ValidateFlow</fixed-outcome>
          </outcome>
        </method-call>
        <control-flow-rule id="__10">
          <from-activity-id id="__11">ValidationTask</from-activity-id>
          <control-flow-case id="__12">
            <from-outcome id="__14">success</from-outcome>
            <to-activity-id id="__13">validationsuccess</to-activity-id>
          </control-flow-case>
          <control-flow-case id="__16">
            <from-outcome id="__15">fail</from-outcome>
            <to-activity-id id="__17">validationerror</to-activity-id>
          </control-flow-case>
        </control-flow-rule>
        <control-flow-rule id="__19">
          <from-activity-id id="__20">ValidationStatusSupplier</from-activity-id>
          <control-flow-case id="__23">
            <from-outcome id="__21">ValidateFlow</from-outcome>
            <to-activity-id id="__22">ValidationTask</to-activity-id>
          </control-flow-case>
        </control-flow-rule>
        <use-page-fragments/>
        <visibility id="__18">
          <url-invoke-allowed/>
        </visibility>
      </task-flow-definition>
    </adfc-config>

  • Route based on ip hash policy

    I got ucs chassis connected to 2 7k in vpc mode. Can i use route base on IP hash as a vmware load balancing policy or does it have to be route based on virtual port ID

    yes sorry i mean the ucs chassis to FI and FI to 7k.
    FI connected via VPC. Can i use IP hash load balancing?

  • Route based VPN ?

    Hi all,
    Are there any Cisco gears supporting route-based vpn (not GRE over IPSec) ?

    Same problem here. Just works on Snow Leopard. Now I have to use a Windows virtual machine to connect to Linux based PPTP VPN. It is a shame.
    I noticed that I can ping and SSH to the VPN server machine. In my case, the local IP address for that machine is 192.168.41.6. I can ping it and SSH it.
    MacBook-de-Daniel:~ daniel$ ping -c 4 192.168.41.6
    PING 192.168.41.6 (192.168.41.6): 56 data bytes
    64 bytes from 192.168.41.6: icmp_seq=0 ttl=64 time=262.643 ms
    64 bytes from 192.168.41.6: icmp_seq=1 ttl=64 time=320.283 ms
    64 bytes from 192.168.41.6: icmp_seq=2 ttl=64 time=258.763 ms
    64 bytes from 192.168.41.6: icmp_seq=3 ttl=64 time=271.596 ms
    --- 192.168.41.6 ping statistics ---
    4 packets transmitted, 4 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 258.763/278.321/320.283/24.670 ms
    However, I am not able to ping or SSH or anything to any IP address in the 192.168.41.0 network (that is the network I am connection to through VPN). This works perfectly on Snow Leopard. For example:
    MacBook-de-Daniel:~ daniel$ ping -c 4 192.168.41.20
    PING 192.168.41.20 (192.168.41.20): 56 data bytes
    Request timeout for icmp_seq 0
    36 bytes from 190.223.188.1: Communication prohibited by filter
    Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
    4  5  00 5400 f68e   0 0000  3d  01 ea46 172.16.7.7  192.168.41.20
    Request timeout for icmp_seq 1
    Request timeout for icmp_seq 2
    --- 192.168.41.20 ping statistics ---
    4 packets transmitted, 0 packets received, 100.0% packet loss
    I don't know how to solve this situation in Lion. It is upsetting. Please Apple, solve it. Or tell us how to solve it. Thanks.

  • Can CSS route based on cookie info in HTTP request

    Hi
    I am new to CSS and am interested as it might be able to provide a solution to a problem I have seen.
    We currently have 3 Windows Servers running an ASP-based web application with a clustered SQL Server backend. The front end uses windows load balancing to distribute the load. All 3 servers are configured the same and there is only one application.
    The problem lies with the way an the application maintains session state. I am told it uses a non-persistant cookie on the client which corresponds to a session object on the server. This is opposed to maintaining state in central location such as the database. Obviously this means the client needs to be stuck to a particular server for that session. This is currently achieved by setting the Windows NLB to single affinity which places traffic from a particular IP address to the same server. This does work but the clients source IP is changed by a downstream firewall to a NAT overload address meaning all clients appear with the same IP address (different port) and hence always end up on just one server.
    The obvious next step in my mind would be to change the way NAT is done but this is not possible. The next obvious idea would be to change the application so that it maintains state in the database so the affinity of the Windows NLB could be disabled meaning requests would be dealt with using the source IP and port and hence distributed evenly. I am told this cannot be done either :) Joy!
    So I have begain to look at other possible solutions. Apologies for my very limited knowledge on the CSS as I am trying to get my head around how it can be configured. I am thinking that it may be able to help me if I used it instead of Windows NLB. I am interested in the way you can use Layer 5 stickiness. Would it be able to examine the cookie in the HTTP request and route the traffic to the correct server?
    I am aware that this will not alleviate the failover issue. If one of the servers were to fall over then the client would have to login again, however I am under the impression that this is acceptable behaviour. The main driver here is to provide load balancing to improve application performance by using all resources opposed to just one.
    Many many thanks to anyone who can give me advise on this.

    Hi Gilles
    Thanks for the info. Sounds like we are on the right path. Unfortunately I am unable to get much information from the developers. Long story. I did logon to the system whilst doing a network trace. The following is what I found in the HTTP header:
    Hypertext Transfer Protocol
    GET /XXXXX/Includes/style.asp HTTP/1.1\r\n
    Accept: */*\r\n
    Referer:
    http://xxx.xxxxx.xxx/xxxxx/login.asp\r\n
    Accept-Language: en-gb\r\n
    Accept-Encoding: gzip, deflate\r\n
    User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)\r\n
    Host: xxxx.xxxxx.xxxxx\r\n
    Connection: Keep-Alive\r\n
    Cookie: ASPSESSIONIDQCBCDSCR=AEHBCJEDDGMMCCBHBICLELGD\r\n
    \r\n
    Why do you configure 2 services? How would I go about this given the cookie in the HTTP request?
    Many thanks
    Gary

  • Inbound mail routing based on LDAP attribute mailsystem

    Hi gents and ladies,
    i have a small question ...
    is it possible to route an email to a recipient based on an LDAP attribute like mailsystem or ldap attribute domain ?
    We have an infrastructure with domino and Xchange. All users have a - so called - maindomain.net SMTP Address.
    Is it possible to manage such routing via mail policies or message filters ?
    Or is it just easy to realize this jjust with SMTP routing list ? e.g. maindomain.net gets an entry in SMTP routing pointing to the domino gateway ... if no delivery is possible the default gateway (Xchange gateway) would be used instead ?
    Thanks in advance for your help and hints.                

    Hello  HPGroh2013,
    I think I answered your question in the previous entry, at least it looks the same to me.
    Regards,
    Andreas

  • Routing based on header record RECPOR in IDOC File

    I am working a flat file (actually, its an IDOC file) that will enter the configuration scenario through a Seebruger SFTP adatper.  Since this is a flat file, and not XML, I need to convert this to XML prior to doing content based routing in the receiver/interface determination.
    I am most concerned with the RECPOR field.
    RCVPOR : Receiver port
    internal data type : CHAR
    Internal length : 000010 characters
    Position in segment : 024, Offset : 0263. external length : 000010
    The scneario is a simple passthrough.  What I envision doing is converting the IDOC Flat file to an XML structure, then doing content based routing on the one field I am interested in, as mentioned above.
    Is there a way to do this without modifying the payload in teh sender/receiver channels, or am I going to be forced to doing content conversion with MessageTransformationBean?
    Since all of my routing will be done on 10 characters, I see breaking the file up into 3 fields...characters 1-263, 263-273, 273-EOF does some one have a sample of how to separate this, and how to recombine the values in the receiver?

    If I wanted to break the file up into 3 elements in a simple XML strcuture....
    I know its possible to do this using fixed field lengths...is there a method to break that file up int a simple xml structure with, lets say, 3 elements....
    Where field 1 contains from the start of the file (1) thorugh say character 31.  Filed 2 contains 31-41 then the third field to contain the rest of the file?  These 'flat files' could be any one of a dozen or so IDOC files that are being sent to me from an external EDI Translator.

  • Routing based on destination IP and traffic type

    Is it possible to route traffic based on the destination IP and the type of traffic?
    ASA5512
    Software 9.2.1
    We have an ASA 5512 that is used as a VPN termination point. Our employees connect from one of our customer sites to this VPN point. The customer also hosts services on the same IP address that our employees use to access our VPN on.
    What I want to do is to use a different route for certain traffic to take to get to these other services provide by our customer, for instance they offer an FTP site and I want to use a different route to get our internal users to this FTP site. Is this possible to achieve?
    Any help would be greatly appreciated.
    Murray

    Technically speaking the ASA doesn't do policy based routing.  However, you might be able to simulate something similar to PBR by using a combination of static routes and NAT.
    If you describe your Network setup, ASA, and how the alternate route is connected to your customer, we might be able to help you better.
    Please remember to select a correct answer and rate helpful posts

  • OTL Approvals routing based on the project and task type

    We are implementing OTL with Projects in our system.
    We have about 200 projects each with a different project manager. The requirement is to route billable tasks to project managers and non billable tasks to HR Supervisor. Employees may enter time for both billable and non-billable tasks in the same timecard.
    I tried using fast formula approval style, but it does not split the timecard data based on the chosen project - task. All the time entries are sent to the same approver.
    I tried using 2 time categories(using 2 user defined valuesets). However it seems ELA will not work when have different project managers for projects in the same time category.
    Please suggest a way to implement approvals for this requirement

    The best approach here would be a custom Workflow.

  • Router is not tagging all packets

    Hi, I have a 7200 router configured for mpls when i ping a network in the LFIB from the router itself the packet is labeled but if the packet comes from a non mpls interface and is going to the same network in the FLIB the packet is not labeled ... I am running version 12.0(23)S6,i understand this is not mpls behavior, is this a bug?
    vdo_conf#sh mpls for 172.17.80.8
    Local Outgoing Prefix Bytes tag Outgoing Next Hop
    tag tag or VC or Tunnel Id switched interface
    3011 4034 172.17.80.8/32 0 Fa0/0.2 172.16.80.10
    vdo_conf#
    regards,
    asanes

    Bear in mind that when the router acts as an edge LSR (does label imposition) the FIB is looked up rather than the LFIB. This should apply whether the frame is locally originated or being forwarded. Make sure cef is enabled on the ingress interface.
    Hope this helps,

  • Is it possible to set a playlist not based on tags on Vision

    I've always had a well organised music archi've on my pc and would like to have such on my zen vison M. I keep mp3s in folders:country/artist/album. To be exact i have mp3 of folk music from different countries and when i try to create a playlist on my Vision M, total chaos appears, some of my mp3s don't even have any tags,so tags are not helpful, just the opposite.

    No, Violation of copyright laws

  • Exclude an entire category of images based on tags

    I like to ensure that all my photos have the location tagged in them. However, some old photos have not had this done. I would like to show all photos that do not have any tag from the category of "Places". For some other groupings, I've been able to accomplish this by right clicking on the tag and using "Exclude media with..." to hide photos that have that one tag. However, to accomplish what I am asking, I would have to do this for each an every tag and sub-category within the category of "Places".
    There must be an easier way.
    FYI: I'm using PSE10
    Thanks,
    Ed

    I don't think so.  The Find...By Details (MetaData) dialog box I showed in reply to your other question inexplicably does not allow a "not included" clause for keyword tags.  That's a sorry excuse for a database application. 
    You can request that feature at
    http://feedback.photoshop.com/photoshop_family/products/photoshop_family_photoshop_element s
    Added:
    On second thought, you might get what you want by building a query which contains all keyword tags except the keyword tag (or category) you want.  Then, after the results are displayed in Organizer, use the "Options...Hide Results that do not match" as kind of a reverse query:
    Awkward, and you'll get extra images if they're in a version set or stack, but that looks like the best at present.  The ones you want will have the little "No" icon on 'em:
    On third thought (I gotta get some sleep... ), build a query containing the keyword tag or category for your location and then use the "Hide..." option to reverse the query.
    Ken
    Message was edited by: photodrawken for additional technique

  • Import Routes based on Multiple RT

    dear all,
    sorry if repost, i've tried to search but can't find the thread.
    currently i am trying to import routes within vrf by matching two route-target exported by other PE. is it can be done with cisco router or not. I have tried with couple way but still no hope.
    the scenario is , PE#1 will advertise route with VRF ABC and put two RT and the other PE#2 is going to received the routes advertise by PE#1 vrf ABC by matching two RT (it must be two RT) not only one.
    I've tried using import map but no clue at all, is there any way to do matching multiple route target within PE#2 to import route vrf ABC from PE#1 by matching every extcommunity [10:111 AND 1:10] ?
    Thanks & Regards,
    Rano
    PE#1
    ip vrf ABC
    rd 1:111
    export map exp_map
    import map imp_map
    route-map exp_abc permit 10
    set extcommunity rt  10:111 1:10
    ip extcommunity-list 10 permit rt 10:111
    ip extcommunity-list 11 permit rt 1:10
    route-map imp_abc permit 10
    match extcommunity 10 11
    interface Loopback111
    ip vrf forwarding ABC
    ip address 1.11.111.1 255.255.255.0
    PE#2
    ip vrf ABC
    rd 1:111
    import map imp_abc
    export map exp_abc
    route-map exp_abc permit 10
    set extcommunity rt  10:111 1:10
    ip extcommunity-list 10 permit rt 10:111
    ip extcommunity-list 11 permit rt 1:10
    route-map imp_abc permit 10
      match extcommunity 10 11
    interface Loopback111
      ip vrf forwarding ABC
      ip address 1.22.111.1 255.255.255.0

    Hello Rano,
    I think you should use the extended extcommunity lists for this:
    in this way instead of matching any RT of the list of RT extcommunities attributes you are going to match using a regular expression the list of RTs but seen as a text string.
    That is you may need to match the whole string "RT:10:111 RT:1:10" using a regular expression.
    You may want to match both "RT:10:111 RT:1:10" and "RT:1:10 RT:10:111" to be sure
    the ip extended extcommunity list should use an index >= 100
    Edit:
    with regular expression I mean something like
    ip extcommunity 100 permit ^RT:10:111 RT:1:10$
    ip extcommunity 100 permit ^RT:1:10 RT:10:111$
    where ^ means the beginning of the string and $ means the end of the string without these anchors the following string would be a match
    "RT:10:111 RT:1:10 RT:10:200"
    some tests have to be done to find the correct notation
    see
    http://www.cisco.com/en/US/partner/docs/ios/iproute/command/reference/irp_bgp2.html#wp1016299
    the right name can be expanded extcommunity list
    see this example
    IP Extended Community-List Configuration Mode Example
    In the following example, an expanded named extended community list is configured in IP Extended community-list configuration mode. A list entry is created with a sequence number 10 that will permit a route target or route origin pattern that matches any network number extended community from autonomous system 65412.
    Router(config)# ip extcommunity-list RED
    Router(config-extcom-list)# 10 permit 65412:[0-9][0-9][0-9][0-9][0-9]_
    Router(config-extcom-list)# exit
    Edit2:
    I can confirm the notation I've checked some tests I did some years ago
    Extended community (expanded) access list 120
        permit ^RT:16232:1$
    this for example allows to match if the RT is made of only one value and that value is 16232:1
    Hope to help
    Giuseppe

Maybe you are looking for

  • ORA-04030: out of process memory when using Java Stored Procedures

    Hello, I have a problem using Java Stored Procedures in Oracle 10g. My Java application performs http posts to a webservice and the response is parsed in order to populate some DB tables. There is a scheduled job which calls the Java Stored Procedure

  • Unable to Place Orders

    For the past couple of months, I have been unable to place orders on Bestbuy.com when using only giftcards.  I have tried clearing my cache and using different computers, but the problem still persists.  The orders go through if part of the order is

  • Flex 2 SDK Tutorials

    I recently started reading up and learning a little about Flex 2.0. I work a lot with Coldfusion and it seems like a good match. I have very little Flash / AS experience although I have been a developer using many other languages (CF, VB, C#, JSP, et

  • Public/Private Sequences

    Is there a way to specify a subsequence to be private or public? Let's say, we have a Verify Temperature Sequence Module. The module has Test Temperature and a Get Temperature subsequences. I want to call the module from my UUT Test but don't want to

  • Systemd and suspend to disk

    Hello, I have the same problem as described in this bug: [systemd] hibernation does not work: https://bugs.archlinux.org/task/37028 I followed the report to: Dave Reisner (falconindy) wrote: Therefore: If you want the resume hook to work with the sys