Regarding the performance comparision of application/web servers

i want the details of performance comparision of application/web servers and which is the best, efficient and easy to use.

Try google.
However for the most part the performance is not related to the application/web server that you use.
It more depends on
- the machine you are running it on
- what code you are running on it.
With regards to "best", you can debate that forever.
Tomcat is widely used, mainly because it is free. But it is solid.

Similar Messages

  • How to increase the performance of an Application

    Hi,
    I am using jdeveloper11.1.1.2.0 and weblogic server10.3.2.I have lot of txn in the database.when click the txn menu then page landing is very slow.My Txn data is 24thousands records.
    My RAM is 8GB and 64bit machine .So how to fast my application?Is any idea then Please help me.
    Thanks
    Anup

    Hi Frank,
    I have follow the below link but there is no performance effect of my application.
    http://www.gebs.ro/blog/oracle/adf-view-object-performance-tuning-analysis/
    On VO level ,In Tuning
    I have modified In batch Of 26 ,As needed ,and Query Optimizer hints FIRST_ROWS_26
    AND ON the page level ,Table Column Property,Fetch size i have modified 26 and page definition level ExchangeTradedPlacementHeadVOIterator default range size is 25.
    So i have above change but there is no effect on the performance of my application.
    Please give me the Solution what will i do to increase the performance of an application.
    Thanks
    Anup

  • How to improve the performance of Swing Application?

    My project is a Swing based application which uses java 1.2.1 API.
    The problem is my application is very slow and gets hung many times, inspite of the system configuration being good ( 256 Mb RAM, 733MHz processor).
    Do give me some suggestions to improve the performance.
    Regards,
    sudhakar

    The system configuration is more than enough to run java applications.
    You are probalbly doing time-consuming operations in the event thread. Which blocks the event thread and the gui seems not to be responding. If you you have a very bad design.
    Use a thread for time consuming operations.

  • Regarding the performance of the Transaction F.01 Program RFBILA00

    Hi Everyone,
    We are running the transaction F.01for financial statements. The program is RFBILA00. We are facing the performance issue with this program. The version is ECC 6.0
    Is there any solution to reduce the running time of this program. We are not using the business area.
    Thanks,
    Senthil

    1.Run time analysis transaction SE30
    This transaction gives all the analysis of an ABAP program with respect to the database and the non-database processing.
    2.SQL Trace transaction ST05
    The trace list has many lines that are not related to the SELECT statement in the ABAP program. This is because the execution of any ABAP program requires additional administrative SQL calls. To restrict the list output, use the filter introducing the trace list.
    The trace list contains different SQL statements simultaneously related to the one SELECT statement in the ABAP program. This is because the R/3 Database Interface - a sophisticated component of the R/3 Application Server - maps every Open SQL statement to one or a series of physical database calls and brings it to execution. This mapping, crucial to R/3s performance, depends on the particular call and database system. For example, the SELECT-ENDSELECT loop on the SPFLI table in our test program is mapped to a sequence PREPARE-OPEN-FETCH of physical calls in an Oracle environment.
    The WHERE clause in the trace list's SQL statement is different from the WHERE clause in the ABAP statement. This is because in an R/3 system, a client is a self-contained unit with separate master records and its own set of table data (in commercial, organizational, and technical terms). With ABAP, every Open SQL statement automatically executes within the correct client environment. For this reason, a condition with the actual client code is added to every WHERE clause if a client field is a component of the searched table.
    To see a statement's execution plan, just position the cursor on the PREPARE statement and choose Explain SQL. A detailed explanation of the execution plan depends on the database system in use.
    Or can use load balancing servers for user over load.

  • Regarding the performance in report

    Hi Abap Gurus,
                              i am working on the report. my requirement is that after executing the report data gets extracting after 11 hours.the required data is comonf perfectly.  how to improve the performance. any tips to follow the performance in the report.  if possible post the code.
    Moderator Message: Please search the forum for available information.
    Edited by: kishan P on Oct 19, 2010 4:50 PM

    Hi,
    Please check below thread;
    Extract from ALV List
    Regards
    Jana

  • Test the performance of JSP application

    is there any trusted tools to test the performance of jsp web applciation with JDBC code ?
    i need to test the performnce wth huge number of users ,
    thanks

    Hello,
    I think the author I already mentioned used this: http://grinder.sourceforge.net/
    It is for free.
    We have been writing our own tool. The tool was actually not difficult. Problematic was the interpretation of the results. I can only advise you to keep a good protocol about what you have been meassuring an how you did this. Otherwise people will come up with strange ideas about the results of your loadtest.
    You have to keep an eye on system ressources: The memory of the boxes involved, but also silly things like available connections. By opening and closing socket connections, we managed to run out of ressources on a SUN pretty fast...
    Please be also aware that a loadtest, ..well produces load. Since we were testing a system where the middletier called up to the mainframe for data, we had to pick late hours for our test. At one evening we took 50% of the capacity of the mainframe... Don't underestimate the time it needs for negotiating and scheduling such meassurements!
    good luck,
    einar

  • Regarding the performance

    I had an application which consists of many forms and each form will have different form objects.. the values already there in the database for these form objects should be displayed to the user in a popup so that he can select the existing ones. There can be be 10 form objects for which the data should be displayed to the user, and for each form object there can be records in thousands.
    For this i have approached the following way:
    So as soon as the user clicks on the form, Based on the form objects fr which the data has to be displayed.. I am retrieving the first 1000 records ( if the records are more than 1000) for each form object and storing in the session and when user browses through all these records and clicks on the next then the next 1000 records i am fetching from the database and replacing the session with the new records. that is at any point of time there will be only 1000 records for the form object and like that there are 10 form objects.
    I am retrieving these records using the cursors within the cursor and sending to the java client. at the client end i am splitting these curosors into result sets.
    Right now i am success fully doing with above procedure..but my question is the procedure i am following is an ideal one or not. Is there any better way to do the above task. Suggestions are appreciated.
    Thanks for your time
    bye
    s

    This sounds like a similar situation described in Re: Getting the records from database in order which was posted last week. Perhaps if you read th eadvic ethere it might help.
    Incidentally, why do you think you may have a problem? If the thing is working then I suggest you leave it alone, until a user complains about performance (or it fails some predefined acceptance criterion). I know refactoring is a very popular concept but it is not always appropriate.
    Cheers, APC

  • Number of elements in the FP affecting the performance of my application ?

    I developed a simple application which consists of aquiring a signal through a channel of a PXI 5102 module and commanding some relays of a SCXI 1161 module.
    This application has the following features :
    -The user can, at any time, change the configuration of the PXI 5102 module.
    -The signal acquired can be saved to a file whenever the user wants.
    -Instead of showing the signal acquired through the PXI 5102 channel, the user can load a given file which contains a saved signal.
    -The user can increase or decrease the pressure on a line through a VI that commands SCXI 1161 relays.
    As you can see, it is a fairly simple application but the problem is that it have been running for a time the fron
    t panel crashes. Is it because the high number of elements I have in the front panel ?
    To give you more information I tell you that the processes of saving, loading, decreasing and increasing the pressure on the line are event cases of an event structure.
    The front panel consists of a tab structure, 20 controls and indicators and a cluster consisting of 9 controls.

    No error take place. By crashing I mean that after a period of time the frontpanel control´s response to inputs of the user become so slow that after a short time there´s no response at all.
    The problem is that I´ve been dealing with this problem in this aplication for quite a while and although I´ve optimized, I think, its execution time and the way it deals with memory usage this problem persists.
    Since most of the operations performed by it depends on inputs by the user I´ve decided to use an event structure to manage them and decided to load the VIs related to them dynamically into memory to somewoh optimize memory usage.
    In order to make things more clear to you I´m sending you a zipped file containing pics that completely describe the frontpane
    l ad the block diagram of the appliction.
    Any help you can give will be deeply appreciated.
    PS : I´ve tried to sent the zipped file but awindow appeared notifying me that Developer Exchange is down for maintenance. If you need any more information to clarify what I mean please let me know.
    Sincerely,
    Giovani Marcelino Nesi
    DRV Desenvolvimento e Representação Virtual Ltda.

  • HI friends i am facing issue regarding the hosting of an application on the firewall .

    Dear friends i configure public ip on firewall interface ,and i have one more public ip for hosting of the sqp application publicly,so please how can i do this can any one let me know configuration is below.
    THE BELOW ARE THE IP ADD FOR THE SERVER HOSTING ,AND CONFIGURATION OF THE FIREWALL AND ROUTER FOLLLOW BELOW.
    PC IP : 72.93.232.66
    Subnet Mask: 255.255.255.252
    Gate Way ( Router IP ) : 72.93.232.65
    Domain Name : www.hrmstadrees.com
    Server Local IP for Application: http://10.10.10.4/MenaITech/Mename/
    ASA-CONFIG
    ASA Version 8.2(5)
    domain-name RAQ.com
    enable password lpW.MGeEHg0ISQZq encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    description Connected to TAD-Router G0/1
    nameif outside
    security-level 0
    ip address 72.93.19.174 255.255.255.252
    interface Ethernet0/1
    description Connected to Cisco SMB Switch G1
    nameif inside
    security-level 100
    ip address 10.15.1.1 255.255.255.248
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    no ip address
    management-only
    banner login ********  RAQ FIREWALL ********
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 8.8.8.8
    name-server 84.22.224.11
    name-server 84.22.224.12
    domain-name tadrees.com
    access-list split-tunnel standard permit 10.10.0.0 255.255.0.0
    access-list nonat extended permit ip 10.1.1.0 255.255.255.0 10.10.0.0 255.255.0.0
    access-list nonat extended permit ip 10.10.0.0 255.255.0.0 10.1.1.0 255.255.255.0
    access-list Mename-Access extended permit tcp any host 72.93.19.174 eq www
    pager lines 24
    logging enable
    logging buffered debugging
    logging asdm debugging
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    ip local pool sslvpnpool 10.1.1.1-10.1.1.254 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-702.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list nonat
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface www 10.10.10.4 www netmask 255.255.255.255
    access-group Mename-Access in interface outside
    router rip
    network 10.0.0.0
    version 2
    route outside 0.0.0.0 0.0.0.0 72.93.19.173 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server TAD-AD protocol nt
    aaa-server TAD-AD (inside) host 10.10.10.1
    aaa authentication ssh console LOCAL
    http server enable 444
    http 192.168.1.0 255.255.255.0 management
    http 0.0.0.0 0.0.0.0 outside
    http 0.0.0.0 0.0.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 0.0.0.0 0.0.0.0 inside
    telnet timeout 2
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 0.0.0.0 0.0.0.0 inside
    ssh timeout 20
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    enable outside
    no anyconnect-essentials
    svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
    svc enable
    tunnel-group-list enable
    internal-password enable
    group-policy sslvpn internal
    group-policy sslvpn attributes
    wins-server none
    dns-server none
    vpn-tunnel-protocol svc webvpn
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value split-tunnel
    default-domain value tadrees.com
    group-policy DfltGrpPolicy attributes
    webvpn
      svc ask enable default webvpn timeout 30
    username admin password s8Vngsgpp8NmOJP7 encrypted privilege 15
    username cisco password HWFflA1bzYiq7Uut encrypted privilege 15
    tunnel-group TAD-SSLV type remote-access
    tunnel-group TAD-SSLV general-attributes
    address-pool sslvpnpool
    authentication-server-group TAD-AD LOCAL
    default-group-policy sslvpn
    tunnel-group TAD-SSLV webvpn-attributes
    group-alias ssl enable
    group-url https://72.93.19.174/ssl enable
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:c23556bcb54d60cbd598593f6429d106
    : end
    ROUTER CONFIGURATION
    RAQ-Router#sho run
    Building configuration...
    Current configuration : 5623 bytes
    ! Last configuration change at 13:59:42 UTC Sat Sep 21 2013 by cisco
    ! NVRAM config last updated at 13:44:13 UTC Sat Sep 21 2013 by cisco
    ! NVRAM config last updated at 13:44:13 UTC Sat Sep 21 2013 by cisco
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname TAD-Router
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
    no aaa new-model
    no ipv6 cef
    ip source-route
    no ip cef
    ip domain name yourdomain.com
    ip name-server 8.8.8.8
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-1513054491
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1513054491
    revocation-check none
    rsakeypair TP-self-signed-1513054491
    crypto pki certificate chain TP-self-signed-1513054491
    certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31353133 30353434 3931301E 170D3132 30393236 31363239
      33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35313330
      35343439 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100AADE 6F39CF31 6832A80B DBCC6E4D 82AA4F8A B71E7118 50B53E0E FD94E7E9
      A6557FD6 30A099C0 D44E36BA 92CBE1EB 1C2789B6 A1260D38 B24637A5 255F18D7
      0B6F2B70 44CF0583 DADB7687 E4102B24 4FA18CDA 36A7CA2A 96F78C1C B92214D8
      087DC6D5 240F7449 DBC4AD01 17FBDC0A 9ECC24DF C7D57E33 9C9CF327 27F2A905
      78470203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 14D06F56 4B82A937 E11730CB BDEECF51 BDAE337F 98301D06
      03551D0E 04160414 D06F564B 82A937E1 1730CBBD EECF51BD AE337F98 300D0609
      2A864886 F70D0101 05050003 8181005A 297C5954 817B8D56 1443D1D5 B21DBA42
      F7EC486D B82CBA55 C2953C0E 756FAC1F B04C48C3 D208E4AF DE412F1C C4A97B38
      856AC4F2 A664C6CB 3E241FB6 4AD2DC4B BE5B4809 DE6269CC 0826E822 33F853B3
      3FE1E0E9 AA125902 C632B6E6 BE2EC625 0F7F2259 F408844B 9813429F 422EDBE0
      ADE0EA0D A2138291 D806C4F1 72C4A9
            quit
    license udi pid CISCO2911/K9 sn FCZ1633771T
    username bciscoadmin password 0 tadreesadmin
    username cisco privilege 15 password 0 c1sc0
    ip ssh version 1
    track 1 interface Dialer0 ip routing
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    description Connected to Internet Temp
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    ip address 72.93.19.173 255.255.255.252
    ip tcp adjust-mss 1452
    duplex auto
    speed auto
    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    pvc 0/35
      pppoe-client dial-pool-number 1
    pvc 0/99
      pppoe-client dial-pool-number 1
    interface Dialer0
    no ip address
    interface Dialer1
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1492
    ip flow ingress
    ip nat outside
    ip nat enable
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 0 123456
    ppp pap sent-username [email protected] password 0 123456
    no cdp enable
    ip forward-protocol nd
    no ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip route 0.0.0.0 0.0.0.0 Dialer1
    access-list 23 permit 10.10.10.0 0.0.0.7
    no cdp run
    control-plane
    banner login ^CC
    **    TADREES PRIVATE NETWORK ..... AUTHORIZED USERS ONLY    **
    ***************************************************************^C
    banner motd ^CC
                                                      ==================
                                                           WARNING
                                                      ==================
    If you are an unauthorized user LOG OFF NOW, all unauthorized access will be prosecuted to the full extent of the law
    This is a Private Network Device. This resource including all related equipment, networks and network devices, are provided for authorized Private use. Private systems are monitored for all lawful purposes, including ensuring authorized use, for manageme
    The monitoring on this system may include audits by authorized personnel to test or verify the validity, security and survivability of this system. During monitoring information may be examined, recorded, copied and used for authorized purposes. All
    Use of this system, constitutes consent to this policy and the policies and procedures set forth by the company
    Evidence of unauthorized use collected during monitoring will be used for criminal prosecution by  staff, legal counsel and law enforcement agencies.^C
    line con 0
    login local
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    login local
    transport input telnet ssh
    line vty 5 15
    login local
    transport input telnet ssh
    scheduler allocate 20000 1000
    end

    Let me get this correctly, you want to access the server over the public IP?

  • Optimizing the Performance of J2EE Applications

    received this invitation to an webinar that will interest many of you
    Topics to be Covered:
    - Deep transaction breakdown from end-user to backend system
    - Identifying bottlenecks
    - Spotting synchronization and deadlock issues
    - Isolating slow methods
    - Solving memory leaks
    Date:
    Wednesday, November 12, 2003
    Time:
    10:00 a.m. - 11:00 a.m. (EDT)
    in this webinar, please RSVP to Kimberly Buzzell at
    (770) 677-1048

    Hello,
    I think the author I already mentioned used this: http://grinder.sourceforge.net/
    It is for free.
    We have been writing our own tool. The tool was actually not difficult. Problematic was the interpretation of the results. I can only advise you to keep a good protocol about what you have been meassuring an how you did this. Otherwise people will come up with strange ideas about the results of your loadtest.
    You have to keep an eye on system ressources: The memory of the boxes involved, but also silly things like available connections. By opening and closing socket connections, we managed to run out of ressources on a SUN pretty fast...
    Please be also aware that a loadtest, ..well produces load. Since we were testing a system where the middletier called up to the mainframe for data, we had to pick late hours for our test. At one evening we took 50% of the capacity of the mainframe... Don't underestimate the time it needs for negotiating and scheduling such meassurements!
    good luck,
    einar

  • How to improve the performance of applications in Oracle Application Server 9i ?

    I have my applications deployed to Oracle 8.1.7 database using OSE in Oracle Application Server 9i. My machine has 256 MB RAM. It has both Oracle Application Server and Oracle 8i database server installed on it. When I try running my applications I find they are very slow. Can I get some guidelines using which I can better the performance of my Application? It can be in the form of code, memory ,disk space etc.
    Thanks in advance,
    Regards,
    krithika.
    null

    The system configuration is more than enough to run java applications.
    You are probalbly doing time-consuming operations in the event thread. Which blocks the event thread and the gui seems not to be responding. If you you have a very bad design.
    Use a thread for time consuming operations.

  • Is there any benchmarks about the performance of BI web Intelligence

    Need to know any benchmarks about the performance of business objects web intelligence report against number of records stored in a relational database

    There no as such benchmark. However you can verify the actual time take by report query when fired directly on DB and time taken by Report to execute. and if there is lots of difference, then those report would ideal for tuning.
    e.g. if MOnthwise revenue report takes 5 mins and the actual query takes only 1.5 mins when fired directly on DB. that means something wrong with universe/reports.
    I hope this help you to get started.
    Please share your exp. its interesting to know.
    --Kuldeep

  • How to optimize Database Calls to improve performance of an application

    Hi,
    I have a performance issue with my applications. It takes a lot of time to load, as it is making several calls to the database. And, moreover, the resultset has more than 2000 records that are returned. I need to know what is the better way to improve the performance
    1. What is the solution to optimize the database calls so that I can improve the performance of my application and also improve on the trun around time to load the web pages.
    2. Stored procedures are a good way to get the data from the result set iteratively. How can I implement this solution in Java?
    This is very important, and any help is greatly appreciated.
    Thanks in Advance,
    Sailatha

    latha_kaps wrote:
    I have a performance issue with my applications. It takes a lot of time to load, as it is making several calls to the database. And, moreover, the resultset has more than 2000 records that are returned. I need to know what is the better way to improve the performance
    1. What is the solution to optimize the database calls so that I can improve the performance of my application and also improve on the trun around time to load the web pages.
    2. Stored procedures are a good way to get the data from the result set iteratively. How can I implement this solution in Java?
    This is very important, and any help is greatly appreciated.1. 2000 records inside a resultset are not a big number.
    2. Which RDBMS you use?
    Concerning the answer to 2. you have different possibilities. The best thing is always to handle as many transactions as possible inside the database. Therefore a stored procedure is the best approach imho.
    Below there is an example for an Oracle RDBMS.
    Assumption #1 you have created an object (demo_obj) in your Oracle database:
    create type demo_obj as object( val1 number, val2 number, val3 number);
    create type demo_array as table of demo_obj;
    /Assumption #2 you've created a stored function to get the values of the array in your database:
    create or replace function f_demo ( p_num number )
    return demo_array
    as
        l_array demo_array := demo_array();
    begin
        select demo_obj(round(dbms_random.value(1,2000)),round(dbms_random.value(2000,3000)),round(dbms_random.value(3000,4000)))
        bulk collect into l_array
          from all_objects
         where rownum <= p_num;
        return l_array;
    end;
    /For getting the data out of database use the following Java program (please watch the comments):
    import java.sql.*;
    import java.io.*;
    import oracle.sql.*;
    import oracle.jdbc.*;
    public class VarrayDemo {
         public static void main(String args[]) throws IOException, SQLException {
              DriverManager.registerDriver(new oracle.jdbc.driver.OracleDriver());
              Connection conn = DriverManager.getConnection(
                        "jdbc:oracle:oci:@TNS_ENTRY_OF_YOUR_DB", "scott", "tiger"); // I am using OCI driver here, but one can use thin driver as well
              conn.setAutoCommit(false);
              Integer numRows = new Integer(args[0]); // variable to accept the number of rows to return (passed at runtime)
              Object attributes[] = new Object[3]; // "attributes" of the "demo_obj" in the database
              // the object demo_obj in the db has 3 fields, all numeric
              // create an array of objects which has 3 attributes
              // we are building a template of that db object
              // the values i pass below are just generic numbers, 1,2,3 mean nothing really
              attributes[0] = new Integer(1);
              attributes[1] = new Integer(2);
              attributes[2] = new Integer(3);
              // this will represent the data type DEMO_OBJ in the database
              Object demo_obj[] = new Object[1];
              // make the connection between oracle <-> jdbc type
              demo_obj[0] = new oracle.sql.STRUCT(new oracle.sql.StructDescriptor(
                        "DEMO_OBJ", conn), conn, attributes);
              // the function returns an array (collection) of the demo_obj
              // make the connection between that array(demo_array) and a jdbc array
              oracle.sql.ARRAY demo_array = new oracle.sql.ARRAY(
                        new oracle.sql.ArrayDescriptor("DEMO_ARRAY", conn), conn,
                        demo_obj);
              // call the plsql function
              OracleCallableStatement cs =
                   (OracleCallableStatement) conn.prepareCall("BEGIN ? := F_DEMO(?);END;");
              // bind variables
              cs.registerOutParameter(1, OracleTypes.ARRAY, "DEMO_ARRAY");
              cs.setInt(2, numRows.intValue());
              cs.execute();
              // get the results of the oracle array into a local jdbc array
              oracle.sql.ARRAY results = (oracle.sql.ARRAY) cs.getArray(1);
              // flip it into a result set
              ResultSet rs = results.getResultSet();
              // process the result set
              while (rs.next()) {
                   // since it's an array of objects, get and display the value of the underlying object
                   oracle.sql.STRUCT obj = (STRUCT) rs.getObject(2);
                   Object vals[] = obj.getAttributes();
                   System.out.println(vals[0] + " " + vals[1] + " " + vals[2]);
              // cleanup
              cs.close();
              conn.close();
    }For selecting 20.000 records it takes only a few seconds.
    Hth

  • How can i use Bi-Technical Content is used for measuring the performance of

    Hi
    recenetly i implemented the BI7.0 for one client. I want to know how to use 'BI Administraction Cockpit,.
    Actual what technical content does ???
    And how can i use technical content or statistics for measuring the performance of my queries. Please let me know
    kumar

    Hi Ravi,
    BI Admin Cockpit is enhancement of BW Statistics.
    http://help.sap.com/saphelp_nw2004s/helpdata/en/44/08a75d19e32d2fe10000000a11466f/frameset.htm
    Check this thread also:
    BI Statistics comparision with the old
    Regarding the performance check the link below.
    Re: Query - Performance
    http://help.sap.com/saphelp_nw2004s/helpdata/en/43/15c54048035a39e10000000a422035/frameset.htm
    Regards,
    Anil

  • How to increase the performance of an insert query?

    Hi,
    I am using oracle database for our application where we executes one insert query and need the performance of 300 insert queries to be executed per second.
    As of now we are getting only 30/sec.We are not knowing how to tune the database for getting this performance.
    we are doing all this though C programming under both linux and solaris environment.
    Can u guide me in this issue.
    Regards,
    vamsi krishna

    Performance tuning issue is not something you can get a straight forward answer for.
    You need to look at various aspects of the system to get close to or increase the performance of your application. Tuning just the database might not give you want you want.
    So, you need to look at the Application codes, Mermory, Disk IO, etc. Have a look at the Performance Tuning Guide from the Oracle Documentation Library for your Oracle Release and Operating System
    http://www.oracle.com/technology/documentation/index.html#previous

Maybe you are looking for