Regarding transparent containter wrapping

Hi
Am new to webdynpro, i need details on Transparent container wrapping.
1. How to create dymically a transparent container and how set the wrapping properties

Hi
Use the following code
hope it will be very helpful for you
IWDTransparentContainer trans=(IWDTransparentContainer)view.createElement(IWDTransparentContainer.class,"TranF");
trans.destroyAllChildren();
trans.createLayout(IWDMatrixLayout.class);
trans.createLayoutData(IWDMatrixData.class);
        Xop=Some Text like length more than 40
     int mop=Xop.length();
     if (mop>35)
          <Name>.setWrapping(true);
     }                                   else
          <Name>.setWrapping(false);
     <Name>.createLayoutData(IWDMatrixHeadData.class);
     trans.addChild<Name>
Regards
Dhinakar J

Similar Messages

  • Regarding transparent gif creation

    To anyone who knows more about this subject, I'm looking for some sample code.
    I've been having trouble redrawing an image as a gif while introducing transparent regions.
    The following method results in blackness where the transparency should be:
        [http://www.exampledepot.com/egs/java.awt.image/DrawOnImage.html]
    The next method accomplishes the transparency, but the non-transparent areas suffer in quality (I am drawing a BufferedImage of an outdoor scene after the transparency is drawn - it come out grainy). I think this is because in creating a new ColorModel to establish the transparent pixels, the original colors are approximated.
        [m-10305410]
    Can anyone show me how to establish a transparent gif with the original quality of the non-transparent areas preserved?
    Thanks.

    I think I can accomplish what you suggest by creating the bufferedImage as type TYPE_INT_ARGB.
    Although it doesn't show the creation of the BufferedImage in the first link of the two above, specifying TYPE_INT_ARGB doesn't seem to make a difference.
    The second link seems to provide a way around this by setting the transparency through use of a new ColorModel.
    This is guesswork. If it's a false assumption that initializing a BufferedImage with TYPE_INT_ARGB provides alpha support, let me know.
    By grainy, I mean pixelated.
    The code I used can be found at:
         [http://forums.sun.com/thread.jspa?threadID=5333259&tstart=45]
    I had posted the subject there earlier, but I think I didn't get to the point soon enough (no replies).
    You can cut and paste that code and try the two methods bWITH_TRANSPARENCY=true & bWITH_TRANSPARENCY=false and see the difference in the quality of the images produced. Just change "c:\\myjpg.jpg"; to point at a JPG file on your system.

  • Regarding Transparent Data Encryption.

    I am using Oracle 10g Release 10.1.0.2.0
    I issue following command by connecting "SYS" user
    ALTER SYSTEM SET ENCRYPTION KEY IDENTIFIED BY Welcome1;
    But it give me error
    ORA-02065: Illegal option for ALTER SYSTEM
    Please Advise.
    Regards

    I am using Win2000 Professional O/S.
    I have installed New Wallet from Oracle Wallet Manager. I save a wallet at C:\WALLET. This folder contains only one file name "ewallet".
    Now I mention this in Sqlnet.Ora file
    ENCRYPTION_WALLET_LOCATION =
    (SOURCE=
    (METHOD=file)
    (METHOD_DATA=
    (DIRECTORY=c:\wallet)))
    After that when I run this command it remains give the same error
    alter system set encryption key authenticated by "welcome";
    ORA-02065: Illegal option for ALTER SYSTEM

  • How to 100% Protect PL/SQL Code By Wrapped in Oracle Database 10g R2

    Hello,
    Is Possible to 100% Protect PL/SQL Code By Wrapped in Oracle 10g R2 ?
    If it is not possible by wrap in oracle 10g R2,
    Please, let me suggest, how i will be able to 100% protect PL/SQL code in Oracle Database 10g R2.
    Because, I have lot of functions, procedures & package's in my project.
    Which is running in field filed.
    So, i have needed to protect 100%.
    Also, will i convert to al functions, procedures & package's to .pll file ?
    And .pll file to .plx file?
    Is it possible to convert .plx file to .pll file ?
    Please, let know any better solutions in this case....
    Regards
    Mehedi

    Hello,
    No, wrapping is not a 100% secure method. It could prevent your code from amateurs, but not from professional hackers. Look at the article http://docs.oracle.com/cd/B28359_01/appdev.111/b28370/wrap.htm#BEHGBJAA
    It says: "•Wrapping is not a secure method for hiding passwords or table names.
    Wrapping a PL/SQL unit prevents most users from examining the source code, but might not stop all of them."
    Edited by: apiminov on 03.12.2012 3:23
    Edited by: apiminov on 03.12.2012 3:24

  • Best Illustrator method to make a logo background "transparent..."

    I have seen that there are several posts regarding "transparent backgrounds," but but they're difficult to follow. I apologize if this is old territory. If there is a solution somewhere already, I'd appreciate your pointing me towards it.
    I'm using AI within CS5.5 but new to it. I am importing/converting a JPG file to vector format. The image is a logo with a large black circle boundry and a white opaque background. The background elements inside the boundry circle are also opaque white, and I wish to leave that as is. The edges of the circle touch the  boundries of the JPG file tangentially by about 100px or so on each side when the JPG is viewed at original size.
    My objective is to make everything outside the boundry circle a "transparent" background. What would be the best/easiest way to do this within AI? Is there, for example, a tool that will draw a circle that I can expand to get on the edge of the black boundry circle, and then make everything outside it transparent?
    Thanks very much.
    Regards,
    Arnold

    Jacob Bugge wrote:
    Arnold,
    I am importing/converting a JPG file to vector format. The image is a logo with a large black circle boundry and a white opaque background.
    The cleanest/best way to vectorize  the black circle, and most likely the other shapes, is to recreate, using the appropriate tools, thereby replacing the original raster parts.
    You may use the raster image as a locked template, maybe on its own lower layer.
    In that case there will be no outlying parts to get rid of.
    But f you just wish to get rid of the outlying part, you may create a circle (with the Ellipse Tool) following the outer rim of the black circle, select that and the image, and Object>Clipping mask>Make.
    OK, a quick progress report...
    I am now back at my main desk and in front of my instance of AI. I am attempting to implement the above suggestion of using the clipping mask. First, a bit more background.
    The object I'm trying to edit is a JPEG file with a logo design... a  black circle with a flat b/w design inside on an opaque white background. There is only one (1) layer, and AI reports the background as being "locked." When I open the JPEG file in AI, it appears as 100%, RGB raster (file is 2341x2344px original size). When I hover over the design with the "select" tool, I see a blue square outline (I assume this is the JPEG file boundry). The edges of the circle circumfrence touch each edge the blue square outline.
    I see how to invoke the elipse tool,  and how to make a clipping mask (I have to remember to select more than one object, or I'll get an error).  But what do I do from there? How do I save just the part that remains (after clipping) on a transparent background? Everything I've tried so far seems to save it on the white opaque background.
    I'm stuck at this point. All help appreciated.
    Regards,
    Arnold.

  • CS2 Transparency

    I'm fairly green when it comes to graphic design, and even moreso regarding transparency. So, please forgive me if what I'm about to ask has been discussed ad nauseum, or is a particularly stupid question...
    A piece I'm working on at the moment (using InDesign CS2) uses 2 Pantone colours. I want to be able to print objects in one of the colours (say yellow) on top of a background of the other colour (say blue). Further, I want my yellow objects to have varying degrees of transparency, so that some of them almost blend in with the blue background.
    My question is this. If I specify that one of the yellow objects has an opacity of only 10%, does this mean that the yellow ink will be printed less heavily (ie. less dots of ink) on top of the blue background, to give a slightly green tinge to the blue colour? Instead, will the transparent yellow area knock a hole out of the blue, leaving me a very pale yellow area where the transparent yellow object sits?
    Another question. My understanding of tints of a Pantone colour is that, on white paper, the tint is created by simply printing the full strength ink less heavily - leading to more white paper showing through to create the lighter colour. However, isn't this just the same as transparency? On the other hand, how are various tints of a Pantone colour handled if printing on top of the blue background? Does each tint need to be mixed separately and treated as a separate colour?
    Just finally, I've heard that exported PDFs should be created using the PDF/X-1a standard to avoid transparency problems. Can someone confirm that this is correct, and perhaps explain why this is needed?
    Thanks for any help you can provide.
    Cheers,
    Steven

    I would approach it the same way as Scott to be honest. By using the overprint option you can specify which areas you'd like to blend and which you'd like to be backed out, This should allow you to give the appearance of a 3 colour job, whilst only printing two.

  • Photos with transparent background weird issue in album

    There is something very strange happening
    What I did
    I saved two images that had transparent background
    When I view it in my photo album the thumbnail shows the image but for the "background" it is some other random photo that isn't even in my camera roll! It just shows up only when I save these images with transparent background.  This happened for two images and the photos showing up are different (from the same night because I can see who is in it).
    When I view these images larger, the background photos do not appear , so it is very strange
    I took a screen shot of this too and would like to send to apple support

    I would not really expect AppleTv to handle transparency in an image, though maybe it does and this is some kind of bug.
    I would regard transparency handling as a non-basic feature to be honest, one that the majority of users will not expect to use or use.
    Does iPhoto handle transparency properly?
    Send feedback to:
    http://www.apple.com/feedback/appletv.html
    It may be something they can add fairly easily, but it may not either.
    Don't expect a reply from that link.
    AC

  • ASO and BSO Transparent partition

    Hi
    I have couple of questions regarding transparent partition, please help me out,
    1) I have two ASO cubes and one empty BSO cube, do I need to run security (apply filters) on both ASO and BSO cubes?
    2) How should I give access to users? For example: what should I write as "..."identified by" ....
    TO 'VZB_ISu'.'VB_IS' AT "localhost"
    AS "....." IDENTIFIED BY "....."
    AREA '"2006","2005",@IDESC("Month"),@IDESC("Scenario"),@IDESC("Measure_Type"),@IDESC("Measures"),@IDESC("Accounts"),@IDESC("RegionCompany"),@IDESC("Company"),@IDESC("RegionOrganization"),@IDESC("Organization"),@IDESC("Affiliate"),@IDESC("Product"),@IDESC("Ledger_Code"),@IDESC("Region"),@IDESC("Country")';
    3) Are their specific ways to tune an empty BSO cube transparently linked to ASO cube? BSO cube has no data.
    Thank you
    Namita

    Hi,
    1) You only need to set security on the BSO db (I'm assuming the users will not be connecting directly to the ASO db). When you setup your partition you define what user will be used to login to the ASO database. When ever an end-user retrieves data over the partition it's the partition user that logs into the ASO database to retrieve the data. You only need to make sure that the user defined in the partition has sufficient rights to retrieve that data.
    2) You can either use EAS to create the filter or MaxL...this is the example for create/replace filter: create filter sample.basic.filt1 read on 'Jan, sales', no_access on '@CHILDREN(Qtr2)';
    3) Try an avoid too many dynamic calcs in the target. These will obviously affect the retrieval times.
    Gee

  • Billboard planes and transparency problem

    Hi
    I have a project for which I need to use textured planes
    (transparency included) to optimize memory usage. I need something
    similar with “Look at camera” controller or billboard
    command so my planes will rotate around Z (vertical) axis to follow
    the camera movement so I won`t see them from the edge. I`ve tried
    billboard behavior included in the free version of ChromeLib (soon
    I`ll get the full version because is an extraordinary asset) but it
    doesn`t work even with ”Oriented to current camera”
    checked.
    I`ve tried even another way, from my 3D editor. I`ve linked a
    dummy object to my camera, limited movement inheritance only to
    horizontal axis (x,y) and I`ve put a “Look at”
    controller to my planes to follow the dummy. In editor works fine
    but isn`t exported in W3D, even that I don`t have any warnings
    regarding this.
    Another problem is regarding transparency. Objects with alpha
    channels sometimes behave strange. From some positions you can see
    through some parts of them. I`ve tried the various types of texture
    render formats but no luck. Do you have any idea how can I fix this
    because is annoying.
    Best regards.
    Mihai

    You can have them face the camera absolutley, rather than
    rotating round a fixed vertical axis very simply, like this:
    cModel.transform.rotation = cam.transform.rotation
    (this assumes your model and camera are both children of the
    world root - if not you'll need to do a 'getWorldTransform()' on
    the camera and use it appropriately)
    If you want to limit the axis, just reset the other rotation
    values each frame, like this:
    cModel.transform.rotation = cam.transform.rotation
    cModel.transform.rotation.x = 90
    cModel.transform.rotation.y = 0
    (the above settings work for me with the default orientation
    of planes created in max. If your planes have a different pivot
    orientation, you'll have to adjust the '90' and '0' values until
    you can see your billboard objects.
    hope this helps!
    - Ben

  • GSSContext's wrap() and MessageProp: Which enryption is used and available

    Hi there,
    I have got a question regarding GSSContext's wrap()/unwrap() methods.
    These methods take a parameter, class MessageProp,
    an instance of this class is used to indicate the desired Quality-of-Protection (QOP)The qop is can be set by an integer, but which kind of protection is it indicated by which number? Which kind of encryption is used, which are available?
    How secure are these message exchanges?

    ahh, I see, could've guessed that myself... Thank for your reply!
    Anyway, DES3 seems to be the weapon of choice as it is supported by the Java Kerberos module, but obviously not by my Active Directory/KDC.
    After some further investigations I found out that DES can be hacked withing 24h, but: the Kerberos clock skew is 5min and our ticket lifetime 8hrs. So there's a remaining risk which seems to be justifiable. What do you think of that?

  • Configuration Required for Transparent Firewall ASA8.2

    Dear All,
    I have one firewall need to be configured in transparent mode. I have inside and outside router. Can anyone just give me the configuration of transparent firewall ASA8.2 pelase. I didnt find the configuration on Cisco site.
    Regards,
    Ali.....

    Dear jcarvaja
    Reference made to our previous communication regarding transparent firewall. Following are my full config with your required capture. I can still ping to the managment of ASA from inside and outside. But traffic is not transiting.
    Inside Capture
    sh capture INSIDE
    24 packets captured
       1: 00:11:45.244326 802.3 encap packet
       2: 00:11:47.289245 802.3 encap packet
       3: 00:11:49.233325 802.3 encap packet
       4: 00:11:51.264039 802.3 encap packet
       5: 00:11:53.258607 802.3 encap packet
       6: 00:11:55.293060 802.3 encap packet
       7: 00:11:57.339719 802.3 encap packet
       8: 00:11:59.331113 802.3 encap packet
       9: 00:12:01.343549 802.3 encap packet
      10: 00:12:03.335218 802.3 encap packet
      11: 00:12:05.349347 802.3 encap packet
      12: 00:12:07.393152 802.3 encap packet
      13: 00:12:09.117242 arp who-has 7.7.7.3 tell 7.7.7.2
      14: 00:12:09.341931 802.3 encap packet
      15: 00:12:11.103693 arp who-has 7.7.7.3 tell 7.7.7.2
      16: 00:12:11.409341 802.3 encap packet
      17: 00:12:13.102198 arp who-has 7.7.7.3 tell 7.7.7.2
      18: 00:12:13.412393 802.3 encap packet
      19: 00:12:15.088832 arp who-has 7.7.7.3 tell 7.7.7.2
      20: 00:12:15.393244 802.3 encap packet
      21: 00:12:16.206959 802.3 encap packet
      22: 00:12:17.106043 arp who-has 7.7.7.3 tell 7.7.7.2
      23: 00:12:17.448661 802.3 encap packet
      24: 00:12:19.410760 802.3 encap packet
    Outside Capture
       1: 00:11:56.916105 802.3 encap packet
       2: 00:11:58.879074 802.3 encap packet
       3: 00:12:00.938367 802.3 encap packet
       4: 00:12:02.893935 802.3 encap packet
       5: 00:12:04.935437 802.3 encap packet
       6: 00:12:06.927488 802.3 encap packet
       7: 00:12:08.875702 802.3 encap packet
       8: 00:12:09.117242 arp who-has 7.7.7.3 tell 7.7.7.2
       9: 00:12:10.931104 802.3 encap packet
      10: 00:12:11.113244 arp who-has 7.7.7.3 tell 7.7.7.2
      11: 00:12:12.944088 802.3 encap packet
      12: 00:12:13.102198 arp who-has 7.7.7.3 tell 7.7.7.2
      13: 00:12:14.933331 802.3 encap packet
      14: 00:12:15.088832 arp who-has 7.7.7.3 tell 7.7.7.2
      15: 00:12:15.642453 802.3 encap packet
      16: 00:12:16.948101 802.3 encap packet
      17: 00:12:17.106043 arp who-has 7.7.7.3 tell 7.7.7.2
      18: 00:12:18.968348 802.3 encap packet
      19: 00:12:20.969066 802.3 encap packet
      20: 00:12:22.976695 802.3 encap packet
      21: 00:12:25.012572 802.3 encap packet
    ASA
    : Saved
    ASA Version 8.0(2)
    firewall transparent
    hostname ciscoasa
    enable password 8Ry2YjIyt7RRXU24 encrypted
    names
    interface Ethernet0/0
    nameif outside
    security-level 0
    interface Ethernet0/1
    shutdown
    no nameif
    no security-level
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    interface Ethernet0/3
    nameif inside
    security-level 100
    interface Ethernet0/4
    shutdown
    no nameif
    no security-level
    interface Ethernet0/5
    shutdown
    no nameif
    no security-level
    passwd 2KFQnbNIdI.2KYOU encrypted
    ftp mode passive
    access-list OUT extended permit icmp any any
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address 7.7.7.10 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    access-group OUT in interface outside
    access-group OUT in interface inside
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    no crypto isakmp nat-traversal
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect icmp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:00000000000000000000000000000000

  • Transparent Firewall with BVI

    Hi! I have a question regarding transparent firewalls using BVIs.
    Based from the diagram above, ASA1 is in Transparent mode.
    Port Gi0 is assigned BVI-1 and port Gi1 is assigned BVI-2.
    Is it possible for network 1 to communicate with network 2 ?
    The traffic will be passing through Firewall towards the router, The router will do the routing and then forward it back to the firewall then towards network 2?
    I am thinking of making port Gi2 of the firewall a trunk and use subinterfaces in order to forward BVI headers to the router.

    Hi Franzis,
    In transparent mode you can use only two interfaces which have to be on the same subnet:
    - The transparent security appliance uses an inside interface and an outside interface only. If your platform includes a dedicated management interface, you can also configure the management interface or subinterface for management traffic only.
    In single mode, you can only use two data interfaces (and the dedicated management interface, if available) even if your security appliance includes more than two interfaces.
    - Each directly connected network must be on the same subnet.
    Source link:
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a008089f467.shtml
    Regards
    Mariusz

  • Transparent user ID vs Authenticated user

    Reviewing a setup, and noticed in the later version of code, 8.0 for example, there are two methods for access.  Since FF and Safari have issues authenticating access when browsing, and IE does not, would the transparent user ID work the same way for authenticated users, and how would that work with AD?

    When you have transparent user ID enable and using AD agent(Context Directory Agent - CDA), this mechanism that maps IP Addresses to usernames in order to allow security gateways to understand which user is using which IP Address in the network, so those security gateways can now make decisions based on those users (or the groups to which the users belong to).
    CDA monitors in real time a collection of Active Directory domain controller (DC) machines for authentication-related events that generally indicate user logins; learns, analyzes, and caches mappings of IP Addresses and user identities in its database; and makes the latest mappings available to its consumer devices.
    Scenario example:
    User machine logs in to the domain and CDA agent will catch the user credentials information and map with the IP address of the client and store it in local cache then pass the info to the WSA.
    If the AD server down for example, the CDA will still be able to relay information regarding the users from its local cache to WSA.
    For more information regarding Transparent user identification or CDA, please see below link for overview:
    http://www.cisco.com/c/en/us/td/docs/security/ibf/cda_10/Install_Config_guide/cda10/cda_oveviw.html

  • Error message from database stored procedures

    I would like to have some error message show at client side from stored procedures.
    I use MS SQL Server and use RAISEERROR, but ColdFusion does not bring the error message just ignore the error continue to run the other part of code.
    I just want to know are there any way to bring stroed procedure error message to client, or I have to trap the error at Web Server or JavaScript level.
    Your help and information is great appreciated,
    Regards,
    Iccsi,

    Just wrap your cfstoredproc in a cftry/cfcatch.  See this for an example:
    http://stackoverflow.com/questions/1879754/accessing-raiseerror-message-from-cfstoredproc
    There's no way your javascript can trap this server-side error though, unless you were calling your CFM page that calls the stored proc via an AJAX request.

  • How to Hide page in interactive form

    Hello All,
    I have developed the Interactive form for one of the HR process. Form is pread across the three pages.
    My requirment is to hide the second page based on some condition. I have tried JAVA script to hide the page using below syntax but its not working.
    if ($record.CARRID.value == "AA") { this.presence = "invisible";}
    Am i missing something? Help needed... Thanks
    Regards,
    Sagar

    Hi Sagar,
    Wrap all the UI elements that you want to hide inside a subform. Then try the following script in the initialize event of the subform.
    if (this.CARRID.rawValue == "AA") { this.presence = "hidden";}
    Thanks & Regards,
    Sanoosh

Maybe you are looking for

  • Problem when installing Oracle 11g R2 x64 on rhel 5.8 x86_64

    Hi All, I'm trying to install oracle 11g software only to upgrade my database from 10g to 11g and i install all required packages listed in installation prerequisites but the below error appeared error in invoking target 'mkldflags ntcontab.o nnfgt.o

  • Distributed transactions and 2-phase commit in a SAP Netweaver environment

    Hello, I am a Java architect., I don't know very much the SAP technologies. I tried to found on forums or technical papers if SAP does support distributed transactions and two-phase commit, it's not clear. I found something on SAP WAS but my project

  • Color picker

    how to use color picker component in flash with string declared in actionscript 2.0 var mystr:String; i want to attach "color picker" with "mystr"

  • Wrong Chq Assigment in FCHU

    Dear All, While assigning the Cheque no. in FCHU the cheque number by mistake has been allotted to a document of other House Bank where as the document was posted with other bank outgoing account. The system does not display any error message and upd

  • Single Mailbox receiving 432-4.3.2 STOREDRV; mailbox server is too busy error emailing distribution group

    I have a user who is trying to email a distribution group with approximately 185 recipients, 183 internal, and 2 external. The user is recieving message delayed/pending for some (but not all) of the recipients. Approximately 15 recipients have reciev