Return Listener Problem

Hi all,
I have a page with a command button that when click on it open a dialog page . in dialog page I have a panelform with 5 LOVs and when user enter information and then press command button in second page, page was closed and ReturnListener method in first page must be executed but it didn't.
interesting when I don't open all 5 LOVs for example open 4 LOVs in second page and enter data manually and click command button on it, returnListener method in first page was executed. I don't know is there any limitation in number of LOVs in dialog page ????
I 'm confused !!!!
please help me.
with my best regards.

Hi Frank,
Thanks for your attention.
when I open one LOV 5 times ,it don't work too. but I don't see any error or exception .
I don't know why it happen ? It is Bug or error ?
I think if I can empty cache memory that with per LOV be used or do anything like this it will be resolved but I don't know how? I wrote this line code in returnListener method for LOVs in second page :
AdfFacesContext fc = AdfFacesContext.getCurrentInstance();
fc.getProcessScope().clear();
but it didn't work.

Similar Messages

  • Disabled attribute on link causes Return Listener disfunctioning

    Hello,
    Using JDev 11g Studio Edition Version 11.1.2.1.0
    I have a af:commandImageLink which, when clicked on, opens a Dialog.
    On the af:commandImageLink, a returnListener is defined and there is an EL expression on the disabled attribute.
    When the EL expression for the disabled attribute resolves to true during the LifeCycle processing, the returnListener isn't called, although the commandImageLink was enabled at the start of the LifeCycle processing that initiated the display of the Dialog in the first place.
    Is this expected behaviour, or is this a bug?
    Steven

    Frank,
    I understand that the dialog open and return listener aren't executed in the same request lifecycle.
    It seems that I didn't correctly explained the issue I'm facing.
    Here is a second attempt to describe the problem...
    1. The user clicks on the af:commandImageLink which results in a modal dialog being displayed.
    2. The user makes some changes within the modal dialog. The changes he made will cause the EL expression on the af:commandImageLink disabled attribute to evaluate to true.
    3. The changes are commit and the dialog is closed.
    Problem: The return Listener isn't called, since the disabled attribute on the af:commandImageLink is true.
    This seems like a bug to me.
    I would expect that the returnListener registered on the UI widget that causes the dialog open event, to be called when the dialog is closed. Even if the UI widget is disabled after the dialog is closed.
    The framework should honour the state of the UI widget at the time the dialog open event is raised to decide if the returnListener should be called.
    Does this make any sense?
    Steven.
    Edited by: Steven Janssens on 5-mrt-2012 4:27 - Relaunching question

  • Task Flow Return Listener not fire when FK association fields set manually

    Guys and Gals,
    I've spent two solid days on this and I'm not sure why my task flow return listener is not firing.
    I start by selecting a row in a table. I then click a "Convert" button which converts the Quote document into a Sales document. I then press Submit which commits the data and the task flow exits. At this point my task flow return listener should fire. It does not. This return listener would, in theory, refresh the visible Quotes table and update the selected Quote's status to "Closed".
    The Quote's "Closed" status is a transient attribute which is calculated by looking at the Sales' document Qty attribute. If the Quote Qty = Sales Qty, then the status is closed. This can be measured by utilizing an association where
    Sales' BaseRefDocId = Quotes' OrderId
    Sales' BaseRefRowId = Quotes' RowId
    Setting these two row attributes represent the association linking a Quote document row to a Sales document row.
            nvp.setAttribute("BaseRefDocId", baseRow.getAttribute("OrderId"));     // Take the Quote Id and put in the Sales' Id ref field
            nvp.setAttribute("BaseRefRowId", baseRow.getAttribute("Row_Id"));    // Take the Quote Row Id and put it in the Sales Row Id ref field
            targetRow.createAndInitRow(nvp);                                                    // Insert the new referenced row into the Sales' DocumentAfter two days of running tests, it is the code above that keeps the return listener from firing and the transient attribute from refreshing on the page. These fields are not mandatory, but are necessary for the Quotes status to change to closed. Simply leaving these lines of code out allows my task flow return listener to refresh correctly, albeit with an incorrect Quote status.
    My expression language statements, however, evaluate correctly irregardless of table refresh. If I refresh the table manually, the status will then display the correct value. All other methods of manipulating the table function correctly i.e. task flow return statements work.
    I'm pretty sure it has something to do with some kind of silent association / view link error blocking the task flow from firing behind the scenes.
    Does anyone have any ideas? Using JDev 11.1.2.1.0.
    Will

    Hi Frank,
    Yeah, I thought it was really weird as well. I banged my head up against the wall again today and finally managed to semi-fix the problem.
    The "Convert" table toolbar button has a "Disabled" attribute that I've been setting with something like #{bindings.QuoteIterator.currentRow == null}. If I take this out, everything works fine. However, if I put it in, the task flow will not return. What's screwy is that I have several of these "Quote" tables for other data collections such as Sales, Deliveries, Invoices, etc. About half of them fire a task flow return with the "Disabled" attribute set for the convert button, and the other half don't. They all return a task flow return if I just set "Disabled" to false.
    At three days and counting, this is really an issue I just don't get, and I'm not sure if I could reproduce the problem to submit it to support because everything appears just fine and I've been digging for days.

  • The screen on my Macbook goes blank, if I tilt the screen it returns. Problem getting worse.

    The screen on my Macbook goes blank, if I tilt the screen it returns. Problem getting worse. Should I take it to the apple store and see if they can replace the screen? is it expensive to replace the backlight/invertor?

    This sounds to me like a fairly common Inverter Fault.
    It is not the screen that needs replacing by the sounds of it,
    It sounds like either the inverter board or the inverter cable needs replacing.
    My understanding is that inverter / inverter cable repairs aren't too expensive, but not too cheap!
    Obviously your best way to find out how much it would cost to be repaired would be to take it in to an Apple Store, as I have never had to have one replaced myself, but the information I'm providing, is based on what I've read elsewhere.
    How old is the MacBook?
    Thanks,
    Ollie.

  • BUG: Return listener not being called for manually launched dialog

    Hello all,
    I have found a bug in the dialog framework. To set the stage, I have a ADF Faces page with a command button on it. The partial submit property is set to "true" and the use window property is also set to "true." I also have the returnListener property set to a method in the backing bean. When I set the Action property of the command button to a global navigation rule that launches a dialog, the return listener is being called correctly when I dismiss the dialog.
    However, when I launch the dialog from an action listener, the return listener is not being called. Here is my action listener code:
      public void al (ActionEvent ae)
        FacesContext context = FacesContext.getCurrentInstance();
        ViewHandler vh = context.getApplication().getViewHandler();
        UIViewRoot dialog = vh.createView(context, "/infrastructure/ICConfirmDelete.jspx");
        HashMap properties = new HashMap();
        properties.put("width", new Integer(300));
        properties.put("height", new Integer(300));
        AdfFacesContext.getCurrentInstance().launchDialog(dialog, null, ae.getComponent(), true, properties);
      }and here is my return listener:
      public void rl(ReturnEvent re)
        System.out.println("in return");
        System.out.println((String) re.getReturnValue());
      }OK - here's an update. If the command button is in the Actions facet of the page, everything works as expected. However, if the button is in the selection facet of a table (inside of afTableSelectOne) - it does not work properly as documented here. It also works correctly if the button is in the actions facet of the table. I think that this is a bug and needs to work - my use case (as you might tell from my code) is to do a delete confirmation dialog. My short-term workaround is to use the Action instead of ActionListener property on the command button, but the issue I have is that the pop-up dialog is just a tad too small, and is showing scrollbars.
    Regards,
    John
    Message was edited by:
    John Stegeman
    Added additional information about tableSelectOne

    Gabrielle,
    Sorry for the confusion.
    What does not work:
    Initiating a dialog from the ActionListener attached to a command button (where the command button is inside an afSelectTableOne) will not fire the returnListener when the dialog is closed.
    What does work:
    Initiating a dialog by returning a dialog-based navigation rule (e.g. a string starting with "dialog:") from the Action attached to a command button (even if the command button is inside an afSelectTableOne) - the return listener is called when the dialog is closed
    What also does work:
    Initiating a dialog with either method (Action or ActionListener) when the command button is elsewhere on the Page (e.g. in the Actions facet)
    Hope this clarifies the bug. I could send a test case if desired.
    Kind regards,
    John

  • Return listener not called for popup invoked from RichCommandToolbarButton

    I have a popup dialog which is shown via the adf framework by specifying <run-as-dialog> on the <task-flow-call>.
    This popup is shown in two different contexts: In one it is shown via RichCommandMenuItem, in the other it is shown via RichCommandToolbarButton. For both I do .setReturnListener via the same function pointing to the same MethodExpression.
    Subsequently in the bean for the popup I do .returnFromDialog.
    However, when the popup is invoked via the menu item, the return listener handler is called. But, when the popup is invoked via the toolbar button the return listener handler is not called.
    Can anyone suggest any reasons why a return listener from a RichCommandToolbarButton might not be called?
    Thank you,
    Ania.

    Yes, they are.
    RichCommandToolbarButton adfButton = new RichCommandToolbarButton();
    adfButton.setUseWindow(true);
    adfButton.setPartialSubmit(true);
    adfButton.setImmediate(true);
    adfButton.setWindowHeight(butDef.getHeight());
    adfButton.setWindowWidth(butDef.getWidth());
    RichCommandMenuItem menuItem = new RichCommandMenuItem();
    menuItem.setUseWindow(true);
    menuItem.setPartialSubmit(true);
    menuItem.setImmediate(true);
    menuItem.setWindowHeight(TableDefinitions.getTxnPropertyEditToolbarButton().getHeight());
    menuItem.setWindowWidth(TableDefinitions.getTxnPropertyEditToolbarButton().getWidth());

  • ADFFaces: returnFromDialog fails to invoke return listener after 5 attempts

    I am having an issue populating a text field using a selection from a pop-up dialog.
    The dialog is launched like the following:
    <af:commandLink action="dialog:search" useWindow="true" returnListener="somelistener"
    i have a returnListener defined in my backing bean and an ActionListener called from the dialog.
    The action listener method calls AdfFaces.getCurrentInstance().returnFromDialog(obj, null);
    This works fine in the beginning but after 5 or 6 attempts, it fails to populate the text field . Using the debugger I found that the return listener is no longer called after 5 attempts. But, it is called in the first few attempts.
    Has anyone else seen this behavior?
    Paul

    Hi Paul,
    I have reported this bug to Oracle (bug#6013033). You'll have to wait for the 11.1 release for the fix or ask for a merge on the 10.1.3.x branch through Metalink although support told me it would be very difficult to do so...
    You can find a workaround I posted here : [SOLVED] Re: ADFFaces: returnFromDialog fails to invoke return listener aft
    Other workarounds given through Metalink :
    Workaround steps
    ~~~~~~~~~~~~~
    1) Use a higher number for oracle.adf.view.faces.CLIENT_STATE_MAX_TOKENS
    In web.xml add the following
    <context-param>
    <param-name>oracle.adf.view.faces.CLIENT_STATE_MAX_TOKENS</param-name>
    <param-value>30</param-value>
    </context-param>
    This will not eliminate the issue. But if the dialog could be designed in such a way that we don't need that many requests (say increase range size), we could tackle the issue.
    2) Don't use token method.
    <context-param>
    <param-name>oracle.adf.view.faces.CLIENT_STATE_METHOD</param-name>
    <param-value>all</param-value>
    </context-param>
    This matches the client-side state saving behavior of JSF 1.1 as explained in the link specified above.
    3) Use server side state management.
    <context-param>
    <param-name>javax.faces.STATE_SAVING_METHOD</param-name>
    <param-value>server</param-value>
    </context-param>
    Seb.

  • How do I refresh a table with a bind variable using a return listener?

    JDev 11.1.2.1.0.
    I am trying to refresh a table with a bind variable after a record is added.
    The main page has a button which, on click, calls a task flow as an inline document. This popup task flow allows the user to insert a record. It has its own transaction and does not share data controls.
    Upon task flow return, the calling button's return dialog listener is invoked which should allow the user to see the newly created item in the table. The returnListener code:
        // retrieve the bind variable and clear it of any values used to filter the table results
        BindingContainer bindings = ADFUtils.getBindings();
        AttributeBinding attr = (AttributeBinding)bindings.getControlBinding("pBpKey");
        attr.setInputValue("");
        // execute the table so it returns all rows
        OperationBinding operationBinding = bindings.getOperationBinding("ExecuteWithParams");
        operationBinding.execute();
        // set the table's iterator to the newly created row
        DCIteratorBinding iter = (DCIteratorBinding) bindings.get("AllCustomersIterator");
        Object customerId = AdfFacesContext.getCurrentInstance().getPageFlowScope().get("newCustomerId");
        iter.setCurrentRowWithKeyValue((String)customerId);
        // refresh the page
        AdfFacesContext.getCurrentInstance().addPartialTarget(this.getFilterText());
        AdfFacesContext.getCurrentInstance().addPartialTarget(this.getCustomerTable());But the table does not refresh ... The bind variable's inputText component is empty. The table flickers as if it updates. But no new values are displayed, just the ones that were previously filtered or shown.
    I can do the EXACT SAME code in a button's actionListener that I click manually and the table will refresh fine. I'm really confused and have spent almost all day on this problem.
    Will

    Both options invoke the create new record task flow. The first method runs the "reset" code shown above through the calling button's returnListener once the task flow is complete. The second method is simply a button which, after the new record is added and the task flow returns, runs the "reset" code by my clicking it manually.
    I'm thinking that the returnListener code runs before some kind of automatic ppr happens on the table. I think this because the table contents flicker to show all customers (like I intend) but then goes back to displaying the restricted contents a split second later.
    Yes, the table is in the page that invokes the taskflow.
    Here are some pictures:
    http://williverstravels.com/JDev/Forums/Threads/2337410/Step1.jpg
    http://williverstravels.com/JDev/Forums/Threads/2337410/Step2.jpg
    http://williverstravels.com/JDev/Forums/Threads/2337410/Step3.jpg
    Step1 - invoke new record task flow
    Step2 - enter data and click Finish
    Step3 - bind parameter / table filter cleared. Table flickers with all values. Table reverts to previously filterd values.

  • Parallel Port Listener problem

    hello everyone,
    I have downloaded the javax.comm package and installed it as given in the installation instructions. I can print my files using the javax.comm classes. But i do not get the Parallel Port Event even if i register a listener.
    Also for all the methods such as is PrinterError(), isPrinterTimedOut(), isPaperOut() etc i do not get anything else but flase. Even if the printer is online or not, or if the paper is out etc, in all cases only false is returned by these methods. Please tel me what could be the problem.
    All these methods return false even when the printer is online or not :
    parallelPort.isPrinterBusy()
    parallelPort.isPrinterError()
    parallelPort.isPrinterSelected()parallelPort.isPrinterTimedOut()
    parallelPort.isPaperOut()

    Well, i think you should be looking for specs about the printer(s) to find out how they communicate with windows. That might not be that easy because not all company's will be very open about that. You should realise that any message windows gives you about the printerstatus comes to you via the drivers for that printer. The drivers know how to communicate with the printer, and that's different per printer.
    The most used standard for printing is Postscript (I believe HP6L is a postscript printer) wich is supported by the 'bigger' printers. There will be info about Postscript on the web, but it is owned by Adobe and I son't know how free the specs are...
    An older dot matrix printer is more likely to be using the lines that are signal out busy, error etc. You will find the pin layout here: http://www.doc.ic.ac.uk/~ih/doc/par/doc/regpins.html
    If all your after is printing your files you might want to use java.awt.PrintJob wich will let you print through the spooler of the operating system, thus letting the OS handle the printer with the right drivers.

  • Upgrade from 9i to 10g, solaris 8 listener problems now...

    I recently upgraded some databases from 9i to 10g. In an attempt to punt
    on the 9i listener - I attempted to start the 10g version of the listener
    which is producing the following error:
    -----paste
    lsnrctl startLSNRCTL for Solaris: Version 10.1.0.2.0 - Production on 15-AUG-2004
    15:13:03
    Copyright (c) 1991, 2004, Oracle. All rights reserved.
    Starting /data/oracle/app/oracle/product/10g/bin/tnslsnr: please wait...
    TNSLSNR for Solaris: Version 10.1.0.2.0 - Production
    Log messages written to
    /data/oracle/app/oracle/product/10g/network/log/listener.log
    Listening on:
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=host.place.com)(PORT=1521)))
    Connecting to (ADDRESS=(PROTOCOL=tcp)(PORT=1521))
    TNS-01114: LSNRCTL could not perform local OS authentication with the
    listener
    -----/paste
    Looking into the logs I see:
    -----paste
    TNSLSNR for Solaris: Version 10.1.0.2.0 - Production on 15-AUG-2004
    15:13:03
    Copyright (c) 1991, 2004, Oracle. All rights reserved.
    Log messages written to
    /data/oracle/app/oracle/product/10g/network/log/listener.log
    Trace information written to
    /data/oracle/app/oracle/product/10g/network/trace/listener.trc
    Trace level is currently 0
    Started with pid=524
    Listening on:
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=host.place.com)(PORT=1521)))
    TIMESTAMP * CONNECT DATA [* PROTOCOL INFO] * EVENT [* SID] * RETURN CODE
    15-AUG-2004 15:13:03 *
    (CONNECT_DATA=(CID=(PROGRAM=)(HOST=host)(USER=oracle))(COMMAND=status)(ARGUM
    ENTS=64)(SERVICE=LISTENER)(VERSION=168821248))
    * status * 1189
    TNS-01189: The listener could not authenticate the user
    TNS-12537: TNS:connection closed
    TNS-12560: TNS:protocol adapter error
    TNS-00507: Connection closed
    -----/paste
    I've read on this list that it might be a shared_memory_pool problem, So I
    think I've maxed out the mount of shared memory. This is a Sun Fire V240
    with 8G RAM, so /etc/system has:
    *set shmsys:shminfo_shmmax=268435456
    *set shmsys:shminfo_shmmax=4294967295
    set shmsys:shminfo_shmmax=8254455808
    set shmsys:shminfo_shmmin=200
    *set shmsys:shminfo_shmmni=200
    set shmsys:shminfo_shmmni=1024
    set shmsys:shminfo_shmseg=1024
    set semsys:seminfo_semmap=250
    set semsys:seminfo_semmni=500
    set semsys:seminfo_semmsl=500
    set semsys:seminfo_semmns=2000
    set semsys:seminfo_semmnu=500
    set semsys:seminfo_semume=100
    set semsys:seminfo_semvmx=32767
    set semsys:seminfo_semopm=100
    set noexec_user_stack = 1
    I am totally at a loss as to what the issue might be save some new tags
    needed in listener.ora... Any pointers/help more than welcome...
    Ian

    well, oracle's path seems to see 10g's version of the listener:
    hosts% which lsnrctl
    /data/oracle/app/oracle/product/10g/bin/lsnrctl
    I'm running this on the same host. ie loopback.
    After the error, the listener seems to be in the process table - but nothing can talk to it:
    oracle 856 818 0 20:05:06 pts/2 0:00 egrep lsnr
    oracle 838 1 0 19:57:26 ? 0:00 /data/oracle/app/oracle/product/10g/bin/tnslsnr LISTENER -inherit
    my listener.ora has:
    # listener.ora Network Configuration File: /data/oracle/app/oracle/product/10g/network/admin/listener.ora
    # Generated by Oracle configuration tools.
    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = /data/oracle/app/oracle/product/10g)
    (PROGRAM = extproc)
    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC))
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = host.place.com)(PORT = 1521))
    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = /data/oracle/app/oracle/product/10g)
    (PROGRAM = extproc)
    (SID_DESC =
    (GLOBAL_DBNAME = erdos)
    (ORACLE_HOME = /data/oracle/app/oracle/product/10g)
    (SID_NAME = simora1)
    (SID_DESC =
    (GLOBAL_DBNAME = datamine)
    (ORACLE_HOME = /data/oracle/app/oracle/product/10g)
    (SID_NAME = datamine)
    (SID_DESC =
    (GLOBAL_DBNAME = interpnt.place.com)
    (ORACLE_HOME = /data/oracle/app/oracle/product/10g)
    (SID_NAME = interpnt)
    tnsnames has:
    DATAMINE.PLACE.COM =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = erdos.place.com)(PORT = 1521))
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = datamine)
    EXTPROC_CONNECTION_DATA.PLACE.COM =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC))
    (CONNECT_DATA =
    (SID = PLSExtProc)
    (PRESENTATION = RO)
    INST1_HTTP.PLACE.COM =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = erdos.place.com)(PORT = 1521))
    (CONNECT_DATA =
    (SERVER = SHARED)
    (SERVICE_NAME = MODOSE)
    (PRESENTATION = http://HRService)
    INTERPNT.PLACE.COM =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = erdos.place.com)(PORT = 1521))
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = interpnt.place.com)
    ERDOS.PLACE.COM =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = erdos.place.com)(PORT = 1521))
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = erdos)
    SCALES03 =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = scales-a.place.com)(PORT = 1521))
    (CONNECT_DATA =
    (SID=SCALES03)
    (SERVICE_NAME = SCALES03)

  • Customer listener problem

    Hi
    After removing Sun RI from my web app I got now an error "Unknown lifecycle: DECORATOR_LIFECYCLE". This is the way I created my lifecycle (for handling exceptions - redirection to error page):
    package mydomain.faces.lifecycle;
    import javax.faces.context.FacesContext;
    import javax.faces.event.PhaseListener;
    import javax.faces.lifecycle.Lifecycle;
    public class LifecycleDecorator extends Lifecycle {
        private static org.apache.log4j.Logger LOG =
                org.apache.log4j.Logger.getLogger(log.Logger.class);
        private Lifecycle wrapped;
        public LifecycleDecorator(Lifecycle wrapped) {
            this.wrapped = wrapped;
        public void execute(FacesContext context) {
            try {
                wrapped.execute(context);
            } catch (Exception e) {
                LOG.error(e.getMessage(), e);
                context.getApplication().getNavigationHandler().handleNavigation(
                        context, null, "ERROR");
        public void render(FacesContext context) {
            try {
                wrapped.render(context);
            } catch (Exception e) {
                LOG.error(e.getMessage(), e);
                context.getApplication().getNavigationHandler().handleNavigation(
                        context, null, "ERROR");
        public void addPhaseListener(PhaseListener listener) {
            wrapped.addPhaseListener(listener);
        public void removePhaseListener(PhaseListener listener) {
            wrapped.removePhaseListener(listener);
        public PhaseListener [] getPhaseListeners() {
            return wrapped.getPhaseListeners();
    package mydomain.faces.lifecycle;
    import javax.faces.FactoryFinder;
    import javax.faces.lifecycle.*;
    import javax.servlet.ServletContextEvent;
    import javax.servlet.ServletContextListener;
    public class LifecycleContextListener implements ServletContextListener {
        public static final String DECORATOR_LIFECYCLE = "DECORATOR_LIFECYCLE";
        public LifecycleContextListener() {
        public void contextDestroyed(ServletContextEvent arg0) {
        public void contextInitialized(ServletContextEvent arg0) {
            // Inicjalizacja lifecycle
            LifecycleFactory factory = (LifecycleFactory)
                    FactoryFinder.getFactory(FactoryFinder.LIFECYCLE_FACTORY);
            if (factory != null) {
                Lifecycle defaultLifecycle =
                        factory.getLifecycle(LifecycleFactory.DEFAULT_LIFECYCLE);
                LifecycleDecorator decorator = new LifecycleDecorator(defaultLifecycle);
                factory.addLifecycle(DECORATOR_LIFECYCLE, decorator);
    }and in web.xml:
        <context-param>
            <param-name>javax.faces.LIFECYCLE_ID</param-name>
            <param-value>DECORATOR_LIFECYCLE</param-value>
        </context-param>
    <listener>
            <listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>
        </listener>
        <listener>
            <listener-class>mydomain.faces.lifecycle.LifecycleContextListener</listener-class>       
        </listener>It worked before removing Sun RI, but then my app had two implementations (myfaces too). Also I had a problem of unexpected session expiration - probably two sessions were created.
    Can anybody give me a hint how to solve this?
    Thanks in advance,
    Michal

    You're best bet for MyFaces assistance is to go to their user list.
    I'm curious, why are you moving from the RI?

  • Message Listener Problem (iDoc)

    I am receiving an iDoc successfully in the Message Listener within Mii.  I have created a Processing Rule for the Message Type and tied it to a simple BLS.  The BLS has an XML input parameter which is selected in the Processing Rule.
    The BLS simply maps the XML input parameter to an XML output parameter and that's it as I want to make sure communication is working before creating any BLS logic.
    The iDoc Message goes into failure status and this is what I get in the log:
    Unable to process request com.sap.jms.client.message.JMSObjectMessage@431f1d25
    [EXCEPTION]
    com.sap.xmii.bls.exceptions.TransactionLoadException: Unable to create transaction instance
    Any ideas why this is happening?

    After much searching and trial and error, I was able to locate the source of this problem.  While I was modifying the "Log Level" in the Processing Rule, someone else changed the Transaction Security to include the "SAP XMII Developer" role.  Once I remove this role from the BLS, the same symptom occurs. 
    It seems this is the only role that allows the Processing Rule to trigger the BLS's.  Is this hard coded somewhere in Mii that this role is required?  If so where can I find these types of requirements so I can avoid going through this for other Mii functionality in the future?
    Thanks

  • HELP!!! Listener problem on AIX 4.1 with oracle 7.2.2.0

    When I try to do "lnsrctl start" (or stop) the server give to me the error below:
    Connecting to (ADDRESS=(PROTOCOL=IPC)(KEY=ora7))
    TNS-12224: TNS:no listener
    TNS-12541: TNS:no listener
    TNS-12560: TNS:protocol adapter error
    TNS-00511: No listener
    IBM/AIX RISC System/6000 Error: 2: No such file or directory
    Connecting to (ADDRESS=(COMMUNITY=TCP.world)(PROTOCOL=TCP)(Host=BILANCIO)(Port=1521))
    TNS-12545: Connect failed because target host or object does not exist
    TNS-12560: TNS:protocol adapter error
    TNS-00515: Connect failed because target host or object does not exist
    IBM/AIX RISC System/6000 Error: 79: Connection refused
    Connecting to (ADDRESS=(COMMUNITY=TCP.world)(PROTOCOL=TCP)(Host=BILANCIO)(Port=1526))
    TNS-12545: Connect failed because target host or object does not exist
    TNS-12560: TNS:protocol adapter error
    TNS-00515: Connect failed because target host or object does not exist
    IBM/AIX RISC System/6000 Error: 79: Connection refused
    On metalink, solutions are client side, but I have this problem on server side.
    I try to change host name to ip add, but problem persist.
    I try to reboot server (because I think the problem was the oracle istance) but the db works correctly.
    What can I do?
    thank u so much!!!
    pedro

    Hello Pedro,
    Please can you tell me if you resolved this issue you were having and how did you resolve this. I am having the same issue now....
    We did a restore to a different box and now cannot connect to the database and having same issues you described.
    Your help will be appreciated,
    Regards
    Avishkar Bandu

  • ASA 5505 9.1(2) NAT/return traffic problems

    As part of an office move we upgraded our ASA to 9.1(2) and have been having what seem to be NAT problems with some services ever since. These problems manifest themselves with return traffic. For example, network time sync (NTP, port 123) works fine from the ASA, but hosts on the inside network cannot access external NTP servers (ntpq -pe shows all servers stuck in .INIT. status), creating problems with drifting clocks. Services like XBox Live also do not work; the XBox device can contact the internet, but return traffic from the service never gets back to the device.
    For NTP specifically, I've tried allowing NTP 123 through the firewall, but it doesn't help. Conceptually, this should not be required since an inside host is initiating the connection and the NAT rules "should" allow the return packets. To further muddy the waters around NTP, a Linux VM CAN get NTP if it's network adapter is in NAT mode (so it's NAT'ing through the host workstation, then through the Cisco) but CAN NOT get NTP if the adapter is running in bridged mode (so the VM is talking directly to the ASA as if it were just another machine on the inside network).
    I've stripped down the ASA config to the basics level, but still can't get this resolved. The main symptom of the problem is that if I disable the access-list rules around ICMP, I'll see lots of ICMP warnings in the ASA logs, which seems to indicate that there are traffic problems communiating with the inside hosts. I've narrowed the problem down to the ASA since replacing the device with a simple Netgear consumer-grade "firewall" lets all this traffic flow just fine.
    Network is extremely basic:
    DHCP ASSIGNED IP from ISP <----------> ASA <-----------------> inside (192.168.50.X)
                                                                      ^
                                                                     |----------------------- guest vlan (10.0.1.X)
    show running-config:
    Result of the command: "show running-config"
    : Saved
    ASA Version 9.1(2)
    hostname border
    domain-name mydomain.com
    enable password aaa encrypted
    passwd bbb encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    switchport trunk allowed vlan 1,3
    switchport trunk native vlan 1
    switchport mode trunk
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.50.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface Vlan3
    nameif Guest-VLAN
    security-level 10
    ip address 10.0.1.1 255.255.255.0
    boot system disk0:/asa912-k8.bin
    boot system disk0:/asa911-k8.bin
    boot system disk0:/asa831-k8.bin
    ftp mode passive
    clock timezone EST -5
    clock summer-time EDT recurring
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 208.104.2.36
    domain-name domain
    same-security-traffic permit inter-interface
    object network obj_any
    subnet 0.0.0.0 255.255.255.0
    object network Guest-WLAN
    subnet 0.0.0.0 255.255.255.0
    description Interent access for guest Wireless
    object network xbox-nat-tcp3074
    host 192.168.50.54
    object network xbox-nat-udp3074
    host 192.168.50.54
    object network xbox-nat-udp88
    host 192.168.50.54
    object service xbox-live-88
    service udp destination eq 88
    object network xbox
    host 192.168.50.54
    object network obj-inside
    subnet 192.168.50.0 255.255.255.0
    object network obj-xbox
    host 192.168.50.54
    object network plex-server
    host 192.168.50.5
    object network ubuntu-server
    host 192.168.50.5
    description Ubuntu Linux Server
    object network ntp
    host 192.168.50.5
    object network plex
    host 192.168.50.5
    object network INTERNET
    subnet 0.0.0.0 0.0.0.0
    object-group service xbox-live-3074 tcp-udp
    port-object eq 3074
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group service plex-server-32400 tcp
    description Plex Media Server
    port-object eq 32400
    access-list outside_access_in extended permit object-group TCPUDP any object xbox object-group xbox-live-3074 log alerts
    access-list outside_access_in extended permit object xbox-live-88 any object xbox log alerts
    access-list outside_access_in extended permit tcp any any eq echo
    access-list outside_access_in remark Plex Live access
    access-list outside_access_in extended permit tcp any object plex-server object-group plex-server-32400
    access-list outside_access_in extended permit icmp any any time-exceeded
    access-list outside_access_in extended permit icmp any any unreachable
    access-list outside_access_in extended permit icmp any any echo-reply
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu Guest-VLAN 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-713.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network xbox-nat-tcp3074
    nat (inside,outside) static interface service tcp 3074 3074
    object network xbox-nat-udp3074
    nat (inside,outside) static interface service udp 3074 3074
    object network xbox-nat-udp88
    nat (inside,outside) static interface service udp 88 88
    object network plex
    nat (inside,outside) static interface service tcp 32400 32400
    object network INTERNET
    nat (inside,outside) dynamic interface
    nat (Guest-VLAN,outside) after-auto source dynamic any interface
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    no user-identity enable
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    http server enable
    http 192.168.50.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec security-association pmtu-aging infinite
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    subject-name CN=border
    crl configure
    crypto ca trustpool policy
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca xxxx
      quit
    crypto ca certificate chain ASDM_TrustPoint0
    certificate xxxx
      quit
    crypto ikev2 remote-access trustpoint ASDM_TrustPoint0
    telnet timeout 5
    ssh 192.168.50.0 255.255.255.0 inside
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    vpn-addr-assign local reuse-delay 60
    dhcp-client client-id interface outside
    dhcpd auto_config outside
    dhcpd address 192.168.50.5-192.168.50.132 inside
    dhcpd address 10.0.1.50-10.0.1.100 Guest-VLAN
    dhcpd dns 208.104.244.45 208.104.2.36 interface Guest-VLAN
    dhcpd lease 86400 interface Guest-VLAN
    dhcpd enable Guest-VLAN
    threat-detection basic-threat
    threat-detection scanning-threat shun except ip-address 192.168.50.0 255.255.255.0
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    ntp server 152.19.240.5 source outside prefer
    ssl trust-point ASDM_TrustPoint0 outside
    username xxx password xxx/ encrypted privilege 15
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect icmp
    service-policy global_policy global
    prompt hostname context
    service call-home
    call-home reporting anonymous
    call-home
    contact-email-addr [email protected]
    profile CiscoTAC-1
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    hpm topN enable
    Cryptochecksum:xxx
    : end

    Hi,
    Configuration seems fine.
    With regards to the ICMP, you could also add this
    class inspection_default
      inspect icmp error
    I would probably start by trying out some other software level on the ASA
    Maybe some 8.4(x) software or 9.0(x) software. See if it some bug perhaps.
    One option is ofcourse to capture traffic directly on the ASA or on the hosts behind the ASA. And go through the information with Wireshark.
    - Jouni

  • Oracle Listener Problem

    I am having a problem starting the Oracle Listener after a system crash on Windows NT.
    However, if I first connect to the internet and then try to restart, everything works ok.
    Why should I have to connect to the internet with my laptop in order to start the Oracle Listener?
    The message I am getting is as follows.
    C:\WINNT\Profiles\timh\Desktop>net start OracleStartORCL
    The OracleStartORCL service is starting..........
    The OracleStartORCL service was started successfully.
    C:\WINNT\Profiles\timh\Desktop>net start OracleTNSListener80
    The OracleTNSListener80 service is starting.
    The OracleTNSListener80 service could not be started.
    A system error has occurred.
    System error 1067 has occurred.
    The process terminated unexpectedly.
    null

    some more info.
    Given below is the output of status. does anything look bad or am I doing something wrong?
    for the service"abcd" it says has two instances, one of the status is unknown. does that matter is it always like that or I am asking very dumb questions?
    Please excuse me if that is the case.
    C:\lsnrctl status
    LSNRCTL for 32-bit Windows: Version 9.2.0.1.0 - Production on 23-JUL-2007 14:54:28
    Copyright (c) 1991, 2002, Oracle Corporation. All rights reserved.
    Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=servername)(PORT=1521)))
    STATUS of the LISTENER
    Alias LISTENER
    Version TNSLSNR for 32-bit Windows: Version 9.2.0.1.0 - Produc
    tion
    Start Date 23-JUL-2007 10:27:09
    Uptime 0 days 4 hr. 27 min. 19 sec
    Trace Level off
    Security OFF
    SNMP OFF
    Listener Parameter File D:\oracle\ora92\network\admin\listener.ora
    Listener Log File D:\oracle\ora92\network\log\listener.log
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=servername.domain)(PORT=1521)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=servername.domain)(PORT=8080))(Presentation=HTTP)(Session=RAW))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=servername.domain)(PORT=2100))(Presentation=FTP)(Session=RAW))
    Services Summary...
    Service "PLSExtProc" has 1 instance(s).
    Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
    Service "abcd" has 2 instance(s).
    Instance "abcd", status UNKNOWN, has 1 handler(s) for this service...
    Instance "abcd", status READY, has 1 handler(s) for this service...
    Service "abcdXDB" has 1 instance(s).
    Instance "abcd", status READY, has 1 handler(s) for this service...
    The command completed successfully

Maybe you are looking for