RMI example just doesn't work (jdk1.5.0_01+jdk1.5.0)

Hi!
RMI example from the "Getting Started Using Java RMI" (http://java.sun.com/j2se/1.5.0/docs/guide/rmi/hello/hello-world.html) doesn't work.
Everything compiles fine , but when starting server with a command:
java -classpath test example.hello.Server
it says (on Linux Fedora Core 2):
Server exception: java.lang.NullPointerException
java.lang.NullPointerException
at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:343)
at sun.rmi.registry.RegistryImpl_Stub.bind(Unknown Source)
at example.hello.Server.main(Server.java:61)
On the Windows( XP SP2) it says:
Server exception: java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
java.lang.ClassNotFoundException: example.hello.Hello
java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
java.lang.ClassNotFoundException: example.hello.Hello
at sun.rmi.server.UnicastServerRef.oldDispatch(UnicastServerRef.java:385)
at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:240)
at sun.rmi.transport.Transport$1.run(Transport.java:153)
at java.security.AccessController.doPrivileged(Native Method)
at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
at java.lang.Thread.run(Thread.java:595)
at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:343)
at sun.rmi.registry.RegistryImpl_Stub.bind(Unknown Source)
at example.hello.Server.main(Server.java:61)
Caused by: java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
java.lang.ClassNotFoundException: example.hello.Hello
at sun.rmi.registry.RegistryImpl_Skel.dispatch(Unknown Source)
at sun.rmi.server.UnicastServerRef.oldDispatch(UnicastServerRef.java:375)
at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:240)
at sun.rmi.transport.Transport$1.run(Transport.java:153)
at java.security.AccessController.doPrivileged(Native Method)
at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
at java.lang.Thread.run(Thread.java:595)
Caused by: java.lang.ClassNotFoundException: example.hello.Hello
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:242)
at sun.rmi.server.LoaderHandler.loadProxyInterfaces(LoaderHandler.java:707)
at sun.rmi.server.LoaderHandler.loadProxyClass(LoaderHandler.java:651)
at sun.rmi.server.LoaderHandler.loadProxyClass(LoaderHandler.java:588)
at java.rmi.server.RMIClassLoader$2.loadProxyClass(RMIClassLoader.java:628)
at java.rmi.server.RMIClassLoader.loadProxyClass(RMIClassLoader.java:294)
at sun.rmi.server.MarshalInputStream.resolveProxyClass(MarshalInputStream.java:238)
at java.io.ObjectInputStream.readProxyDesc(ObjectInputStream.java:1494)
at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1457)
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1693)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1299)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:339)
... 9 more
Is it possible to make it work somehow?
Thank you!
Dmitriy Ulupov

There is quite enough data in the exception to figure this out, and the answer is 'none of the above'. Have a look at this:
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
java.lang.ClassNotFoundException: example.hello.Hello
java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
java.lang.ClassNotFoundException: example.hello.Hello
at sun.rmi.server.UnicastServerRef.oldDispatch(UnicastServerRef.java:385)
at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:240)
at sun.rmi.transport.Transport$1.run(Transport.java:153)
at java.security.AccessController.doPrivileged(Native Method)
at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
at java.lang.Thread.run(Thread.java:595)
at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall .java:247)
at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:343)
at sun.rmi.registry.RegistryImpl_Stub.bind(Unknown Source)The basic problem is java.lang.ClassNotFoundException: example.hello.Hello
and it occurs remotely when executing Naming.bind, i.e. it happens in the Registry. In other words the Registry cannot find examples.hello.Hello. There are several solutions to this including modifying the Registry's classpath or using the RMI codebase feature.

Similar Messages

  • STP just doesn't work as advertised

    So here's my question:
    Is anyone out there using this app having the amount of misery I'm having? Does STP seem half baked at this point of its development? It certainly does to me.
    I sincerely hope Apple is planning a major update to STP real soon, because frankly, (IMHO) this app just doesn't work as advertised. I am now giving up trying to mix 9 episodes of a show because I can no longer work around the litany of bugs in this program.
    This is a major disappointment, and I hope the product manager for STP is listening and moving forward to take corrective action ASAP.

    Hello Todd,
    Where do I begin? Well, let me preface by saying that I feel like I've given STP a fair shot at the show I'm working on (six weeks now). But almost everytime I run into a problem and present it to knowledgable STP users, they reply with "Uh, yeah, I think they know about that one - hopefully there'll be a fix soon".
    But here goes with a small sample of bugs - and features that SHOULD be in this app. If you can solve any of these issues, I'd be appreciate it!
    - STP will refuse to save a file in the waveform editor if the ORIGINAL filename contains certain (illegal?) characters. Even if you change the name of the file TO BE SAVED to something which "should" work fine, it still won't save. I spent many days tracking this one down because STP gives you no indication as to why it won't save the file.
    - STP will not allow you to perform FADES to/from silence in a MULTI-TRACK project (it will allow this in the waveform editor). This forces you to create keyframes on the VOLUME envelope (which requires numerous mouse clicks) to achieve the desired result.
    - Sometimes, all the faders and pan controls on the MIXER go grey, preventing any adjustment. The only work around is to recall a user layout (again, took a few days to figure this one out).
    - STP will not RELIABLY playback REALTIME EFX on tracks or busses. Often, EFX are simply skipped over (not played back), or they playback incorrectly.
    - The ON/OFF parameter of EFX cannot be mapped to AUTO (keyframe) envelope. This is a real pain because you may want to simply turn an effect ON or OFF based on time, without having to adjust other parameters of the effect to achieve the same result.
    - STP offers no easy way to navigate (SNAP) to the HEAD or TAIL of a clip on the timeline from the keyboard. The SNAP feature via the mouse is useless in this regard unless your zoomed all the way in.
    - STP offers no way to move clips in the TL in user designated increments.
    - When applying keyframes to a clip (for volume or pan as an example), STP requires that you manually add keyframes to the beginning and end of the clip - which takes way too long. There should be a way to highlight a clip(s) and with one keystroke, have it add keyframes to the HEAD and TAIL of every clip that was highlighted.
    - STP will sometimes report that it cannot playback all the tracks because of bandwidth issues, even when you've got a RAID that will support uncompressed HD/1080i bandwidth.
    - STP's screen refresh is agonizingly slow compared to Protools (for example), even when Protools is running on a MUCH slower CPU with far less RAM. Expanding/contract the timeline or tracks is "steppy" and slow.
    - STP will not warn you if you're overwriting a clip when dragging from the browser. For example, if you have a clip on TRACK1, and you drag a sound effect from the browser to TRACK1, but it's length is so long that it will overwrite clips that may be out of your view, you have no idea that those clips are now gone or truncated. STP should warn you, and/or allow you hold down a modifier key that forces the clip to fit into the available empty space only.
    - STP offers no way to easily copy an effect from one track to another from the mixer. Why can't I click and drag an effect from one fader to another to copy the effect with it's current settings?
    - Where are the user adjustments for metering ballistics? Reference levels?
    That's it for now!
    All the best.

  • L2TP on Cisco ASA 5505, just doesn't work??!

    This is pretty urgent, client expects me to have this up by lunch today
    So, there is this Cisco ASA 5505 ver 8.4.
    Most things work but now I want to setup a vpn connection...
    I have done this 2 ways, first by using the "VPN Wizard" in ASDM and then 5 hours later removing everything and configuring from cli.
    And it just doesn't work, client (WinXP & Win7) gets "error 792" and sometimes "error 789" (both indicating problem with phase 1, I'm pretty sure of that)
    Googling on those gives a few suggestions none works.
    All I get in the log on Cisco is the "Error processing payload: Payload ID: 1"
    Googling on that only comes up with a few pages telling me this message is caused by an error. (Yeah, I could never have guessed...)
    For the cli config, I followed this tutorial carefully (3 times actually...)
    http://www.cisco.com/en/US/docs/secu...html#wp1117464
    I'm using PSK for IPSec, entered same on Cisco and client - checked several times, this is not a password/PSK issue.
    Ports opened on Cisco: 500, 1701, 4500
    (For a try I opened all ports, no change.)
    And here's the "show run":
    Code:
    ASA Version 8.4(2)
    hostname ciscoasa
    enable password <string> encrypted
    passwd <string> encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    switchport access vlan 7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.5.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address #.#.#.# 255.255.255.252
    interface Vlan7
    description VLAN till kontor
    no forward interface Vlan2
    nameif kontor
    security-level 100
    ip address 172.16.5.1 255.255.255.0
    ftp mode passive
    clock timezone GMT 0
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Webserver
    host 192.168.5.2
    object network Webserver443
    host 192.168.5.2
    object network rdp
    host 192.168.5.2
    object network vpnserver
    host 192.168.5.2
    object service vpn-service-group
    object network VPN
    host 192.168.5.2
    object-group service Webports tcp-udp
    description Portar för webbserver
    port-object eq 443
    port-object eq www
    object-group service DM_INLINE_TCP_1 tcp
    group-object Webports
    port-object eq www
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group service VPNports tcp-udp
    port-object eq 1701
    port-object eq 4500
    port-object eq 500
    object-group service RDP tcp-udp
    port-object eq 3389
    object-group service vpn-services tcp-udp
    port-object eq 1701
    port-object eq 500
    access-list outside_access_in extended permit tcp any object Webserver eq www
    access-list outside_access_in_1 extended permit tcp any object Webserver object-group DM_INLINE_TCP_1
    access-list outside_access_in_1 remark Ãppnar för vpn
    access-list outside_access_in_1 extended permit object-group TCPUDP any any object-group VPNports
    access-list outside_access_in_1 extended permit object-group TCPUDP any any object-group RDP
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu kontor 1500
    ip local pool vpn1 10.10.10.10-10.10.10.50 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    object network obj_any
    nat (inside,outside) dynamic interface
    object network Webserver
    nat (inside,outside) static interface service tcp www www
    object network Webserver443
    nat (inside,outside) static interface service tcp https https
    object network rdp
    nat (inside,outside) static interface service tcp 3389 3389
    access-group outside_access_in_1 in interface outside
    route outside 0.0.0.0 0.0.0.0 79.142.243.33 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    aaa authorization command LOCAL
    aaa authorization exec LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA mode transport
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set TRANS_ESP_3DES_SHA mode transport
    crypto ipsec ikev2 ipsec-proposal 3DES-SHA
    protocol esp encryption aes-256 aes-192 aes 3des
    protocol esp integrity sha-1 md5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal 3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    subject-name CN=ciscoasa
    proxy-ldc-issuer
    crl configure
    crypto ca certificate chain ASDM_TrustPoint0
    .... (sorry, not giving you the cert...)
    crypto ikev2 policy 1
    encryption 3des
    integrity sha
    group 2 1
    prf sha
    lifetime seconds 86400
    crypto ikev1 enable outside
    crypto ikev1 policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 1
    lifetime 86400
    crypto ikev1 policy 20
    authentication rsa-sig
    encryption aes-256
    hash sha
    group 1
    lifetime 86400
    crypto ikev1 policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 1
    lifetime 86400
    crypto ikev1 policy 40
    authentication crack
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 50
    authentication rsa-sig
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 60
    authentication pre-share
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 70
    authentication crack
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 80
    authentication rsa-sig
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 90
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 100
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 110
    authentication rsa-sig
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 120
    authentication pre-share
    encryption 3des
    hash sha
    group 1
    lifetime 86400
    crypto ikev1 policy 130
    authentication crack
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 140
    authentication rsa-sig
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 150
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh scopy enable
    ssh 0.0.0.0 0.0.0.0 inside
    ssh 0.0.0.0 0.0.0.0 outside
    ssh timeout 10
    console timeout 0
    no vpn-addr-assign aaa
    no vpn-addr-assign dhcp
    l2tp tunnel hello 100
    dhcpd dns 8.8.8.8
    dhcpd auto_config outside
    dhcpd address 192.168.5.11-192.168.5.36 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy DefaultRAGroup internal
    group-policy DefaultRAGroup attributes
    vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec
    address-pools value vpn1
    group-policy DfltGrpPolicy attributes
    dns-server value 79.142.240.10
    vpn-tunnel-protocol l2tp-ipsec
    address-pools value vpn1
    username test password <string> nt-encrypted
    username someoneelse password <string> nt-encrypted privilege 15
    username someoneelse attributes
    vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec
    service-type admin
    username someone password <string> nt-encrypted privilege 0
    tunnel-group DefaultRAGroup general-attributes
    authorization-server-group LOCAL
    tunnel-group DefaultRAGroup ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    tunnel-group vpn1 type remote-access
    tunnel-group vpn1 ipsec-attributes
    ikev1 pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    privilege cmd level 3 mode exec command perfmon
    privilege cmd level 3 mode exec command ping
    privilege cmd level 3 mode exec command who
    privilege cmd level 3 mode exec command logging
    privilege cmd level 3 mode exec command failover
    privilege cmd level 3 mode exec command packet-tracer
    privilege show level 5 mode exec command import
    privilege show level 5 mode exec command running-config
    privilege show level 3 mode exec command reload
    privilege show level 3 mode exec command mode
    privilege show level 3 mode exec command firewall
    privilege show level 3 mode exec command asp
    privilege show level 3 mode exec command cpu
    privilege show level 3 mode exec command interface
    privilege show level 3 mode exec command clock
    privilege show level 3 mode exec command dns-hosts
    privilege show level 3 mode exec command access-list
    privilege show level 3 mode exec command logging
    privilege show level 3 mode exec command vlan
    privilege show level 3 mode exec command ip
    privilege show level 3 mode exec command ipv6
    privilege show level 3 mode exec command failover
    privilege show level 3 mode exec command asdm
    privilege show level 3 mode exec command arp
    privilege show level 3 mode exec command route
    privilege show level 3 mode exec command ospf
    privilege show level 3 mode exec command aaa-server
    privilege show level 3 mode exec command aaa
    privilege show level 3 mode exec command eigrp
    privilege show level 3 mode exec command crypto
    privilege show level 3 mode exec command ssh
    privilege show level 3 mode exec command vpn-sessiondb
    privilege show level 3 mode exec command vpnclient
    privilege show level 3 mode exec command vpn
    privilege show level 3 mode exec command dhcpd
    privilege show level 3 mode exec command blocks
    privilege show level 3 mode exec command wccp
    privilege show level 3 mode exec command dynamic-filter
    privilege show level 3 mode exec command webvpn
    privilege show level 3 mode exec command module
    privilege show level 3 mode exec command uauth
    privilege show level 3 mode exec command compression
    privilege show level 3 mode configure command interface
    privilege show level 3 mode configure command clock
    privilege show level 3 mode configure command access-list
    privilege show level 3 mode configure command logging
    privilege show level 3 mode configure command ip
    privilege show level 3 mode configure command failover
    privilege show level 5 mode configure command asdm
    privilege show level 3 mode configure command arp
    privilege show level 3 mode configure command route
    privilege show level 3 mode configure command aaa-server
    privilege show level 3 mode configure command aaa
    privilege show level 3 mode configure command crypto
    privilege show level 3 mode configure command ssh
    privilege show level 3 mode configure command dhcpd
    privilege show level 5 mode configure command privilege
    privilege clear level 3 mode exec command dns-hosts
    privilege clear level 3 mode exec command logging
    privilege clear level 3 mode exec command arp
    privilege clear level 3 mode exec command aaa-server
    privilege clear level 3 mode exec command crypto
    privilege clear level 3 mode exec command dynamic-filter
    privilege cmd level 3 mode configure command failover
    privilege clear level 3 mode configure command logging
    privilege clear level 3 mode configure command arp
    privilege clear level 3 mode configure command crypto
    privilege clear level 3 mode configure command aaa-server
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:dd92aa6707dc63e8ed7dad47cfecdd47
    : end
    In Pingvino Veritas!

    I lmost got it working now, new problem is that the connection is immediately ended.
    Logs shows that client is authenticated and assigned an ip.
    From the logs, all happens during one second:
    IPAA: Client assigned ip-address from local pool
    IPAA: Local pool request succeeded for tunnel-group
    IPAA: Freeing local pool address
    L2TP Tunnel created, tunnel_id is 24
    L2TP Tunnel deleted, tunnel_id =24
    IPSEC: An outbound remote access SA has been deleted
    IPSEC: An inbound remote access SA has been deleted
    Session is being torn down. Reason: L2TP initiated
    Teardown UDP connection

  • Time Machine Just Doesn't Work Anymore

    I was a happy Time Machine (with Time Capsule) user for months. But it just doesn't work anymore. It takes longer than an hour to do every hourly backup so it is backing up 24 hours a day. It finds hundreds of thousands of files changed every hour and tries to back them up. Finders says only tens of files have been modified all of today. I have tried rebuilding my spotlight indexes, repairing my Time Capsule with Disk Utility and starting over with a brand new backup. But it just backs up hundreds of thousands of files every hour. So I am turning off Time capsule since it is clearly broken. If anyone has any suggestions at all I would welcome them.

    Marcia,
    Consider the following, it might give you some ideas:
    Time Machine performs backups at the file level. If a single bit in a large file is changed, the WHOLE file is backed up again. This is a problem for programs that save data to monolithic virtual disk files that are modified frequently. These include Parallels, VMware Fusion, Aperture vaults, or the databases that Entourage and Thunderbird create. These should be excluded from backup using the Time Machine Preference Exclusion list. You will, however, need to backup these files manually to another external disk.
    One poster observed regarding Photoshop: “If you find yourself working with large files, you may discover that TM is suddenly backing up your scratch disk's temp files. This is useless, find out how to exclude these (I'm not actually sure here). Alternatively, turn off TM whilst you work in Photoshop.” (http://discussions.apple.com/thread.jspa?threadID=1209412)
    If you do a lot of movie editing, unless these files are excluded, expect Time Machine to treat revised versions of a single movie as entirely new files.
    If you frequently download software or video files that you only expect to keep for a short time, consider excluding the folder these are stored in from Time Machine backups.
    If you have recently created a new disk image or burned a DVD, Time Machine will target these files for backup unless they are deleted or excluded from backup.
    Installing new software, upgrading existing software, or updating Mac OS X system software can created major changes in the structure of your directories. Time Machine will backup every file that has changed since the installation.
    Files or folders that are simply moved or renamed are counted as NEW files or folders. If you rename any file or folder, Time Machine will back up the ENTIRE file or folder again no matter how big or small it is.
    George Schreyer describes this behavior: “If you should want to do some massive rearrangement of your disk, Time Machine will interpret the rearranged files as new files and back them up again in their new locations. Just renaming a folder will cause this to happen. This is OK if you've got lots of room on your backup disk. Eventually, Time Machine will thin those backups and the space consumed will be recovered. However, if you really want recover the space in the backup volume immediately, you can. To do this, bring a Finder window to the front and then click the Time Machine icon on the dock. This will activate the Time Machine user interface. Navigate back in time to where the old stuff exists and select it. Then pull down the "action" menu (the gear thing) and select "delete all backups" and the older stuff vanishes.” (http://www.girr.org/mac_stuff/backups.html)
    *TechTool Pro Directory Protection*
    This disk utility feature creates backup copies of your system directories. Obviously these directories are changing all the time. So, depending on how it is configured, these backup files will be changing as well which is interpreted by Time Machine as new data to backup. Excluding the folder these backups are stored in will eliminate this effect.
    *Backups WAY Too Large*
    If an initial full backup or subsequent incremental backup is tens or hundreds of Gigs larger than expected, check to see that all unwanted external hard disks are still excluded from Time Machine backups.
    This includes the Time Machine backup drive ITSELF. Normally, Time Machine is set to exclude itself by default. But on rare occasions it can forget. When your backup begins, Time Machine mounts the backup on your desktop. (For Time Capsule users it appears as a white drive icon labeled something like “Backup of (your computer)”.) If, while it is mounted, it does not show up in the Time Machine Prefs “Do not back up” list, then Time Machine will attempt to back ITSELF up. If it is not listed while the drive is mounted, then you need to add it to the list.
    *FileVault / Boot Camp / iDisk Syncing*
    Note: Leopard has changed the way it deals with FileVault disk images, so it is not necessary to exclude your Home folder if you have FileVault activated. Additionally, Time Machine ignores Boot Camp partitions as the manner in which they are formatted is incompatible. Finally, if you have your iDisk Synced to your desktop, it is not necessary to exclude the disk image file it creates as that has been changed to a sparsebundle as well in Leopard.
    Let us know if any of this helps.
    Cheers!

  • Is there a way to fix an iPod touch 4G home button that isn't stuck but just doesn't work?

    A couple weeks ago my home button got stuck. To fix it I found this video http://www.youtube.com/watch?v=yBfhCmq9VkA&list=WL429346A18D0B1E65 to help me out. The second option of using the charger ended up working, thus making the button work again. It was working fine after doing that but then it got stuck down again and I had to put the charger in and do that again. However, all of a sudden the home button just doesn't work anymore. It's not even stuck all the way down. I can press it repeatedly but still nothing.
    I've had the iPod for about 6 months now and got it off of amazon refurbished so warranty is out of the question i'm sure. If it really is broken with no way to fix it then that's fine as i've been using assitive touch for weeks now and am used to it since i've been using it egulary since there's no other way. I just wanted to ask and make sure first before anything else though.

    Try:
    http://snapguide.com/guides/calibrate-your-home-button/?utm_expid=69945963-15
    fix for Home button
    iPhone Home Button Not Working or Unresponsive? Try This Fix
    - If you have iOS 5 and later you can turn on Assistive Touch it add the Home and other buttons to the iPods screen. Settings>General>Accessibility>Assistive Touch
    - If not under warranty Apple will exchange your iPod for a refurbished one for:
    Apple - Support - iPod - Repair pricing
    You can do it an an Apple store by:
    Apple Retail Store - Genius Bar
    or sent it in to Apple. See:
    Apple - Support - iPod - Service FAQ
    - There are third-party places like the following that will repair the Home button. Google for more.
    iPhone Repair, Service & Parts: iPod Touch, iPad, MacBook Pro Screens

  • I have purchased the Acrobat pro subscription for 1 year and have followed the steps to install it. But when i go to start it, It crashes and it does this every time! I have restarted my mac pro and also restarted in safe mode but it just doesn't work! PL

    I have purchased the Acrobat pro subscription for 1 year and have followed the steps to install it. But when i go to start it, It crashes and it does this every time! I have restarted my mac pro and also restarted in safe mode but it just doesn't work! PLEASE HELP!!

    Hi jim1287,po
    Check for the latest updates. Installing latest updates should resolve this problem.
    Also, try to ran disk repair using safe mode in Mac, for instructions please visit: http://support.apple.com/kb/PH14204
    Try enabling root user profile on mac and try to check. OS X Mavericks: Enable and disable the root user
    Regards,
    Ajlan Huda.

  • My Apple TV Gen 1 just doesn't work

    Hello,
    I have setup/reset/setup this device so many times it just drives me crazy. I honestly believe that this technology just doesn't work.
    I have an iMac running the most up to date version of OS X 10.6.5, I have the latest version of iTunes, 10.1.1. I'm using the Airport Extreme.
    I have followed the directions to the letter!
    Please help!
    Thanks,
    Aloha
    John
    I have a number of movies, etc on my pc but to make things easier, i just opted to a custom sync, display only those items i have selected, and chose 3 movies only.
    I can see them on my tv, but when i select play, i always get an error indicating that this device is not authorized to play the content. I have deauthorized/authorized my pc many times.
    I'm thinking about just dumping all my apple products and just stick with a microsoft based pc.

    I am having the SAME issue. Just bought the Apple TV 1st Gen. from AppleStore, then followed the instructions to the letter. I am using iMac 10.5.8, Airport Extreme Base Station, AppleTV, and I have the most up-to-date iTunes and also made sure AppleTV is up to date. I get the same stupid error messages indicating the device is not authorized. Called Apple (no)Support, and was walked through restarting all my devices (like I didn't already try this, but just to make 'em happy, did it again...), didn't resolve the issue. "Steve" was like "...hmm, that shouldn't be doing that..." Really, dude? Maybe that's why I called you. Thanks for your time. Hope you guys enjoy my money I gave you.
    Anyone have any ideas? I am about to pack this thing up and send it back. When I purchase ALL Apple products that are advertised as being able to just plug and go, it should freakin' work.

  • I can't find any error in my vi but it just doesn't work please help

    I'm trying to control a robot named cs-113 and I find someone has already achieved this. He wrote a vi called robot cs-113.vi and I just tried to write a same one but it just doesn't work. Can anyone tell me why it doesn't work? Thanks for your help!
    由 normanshi 在 08-01-2006 04:11 AM 上編輯的訊息
    Attachments:
    robot-cs113.vi ‏79 KB
    cs-113 test.vi ‏62 KB

    It would really help if you were a little more specific about what isn't working. Also try debugging your application in highlighted execution with probes to find out exactly what data you're sending out the port.
    Jarrod S.
    National Instruments

  • ISight just doesn't work on Windows 7 64Bits

    I'm a new MacBook Pro user for a few days. I was attracted by the design of MacBook and knew I could install Windows on it, so after shopping for some time, I decided to get MBP 13". I got Windows 7 64Bits installed yesterdat; all the drivers are installed as well. I went to Control Panel\System, and I saw "Built-in iSight" listed. However, the camera device just doesn't work. In Control Panel, I didn't see the "Imaging and Scanning" icon. I tried to uninstall and reinstall the driver and no luck. I'm already using the latest Boot Camp, and I just don't know what to do now. I really need the camera working. Can someone help?

    Does this help? http://discussions.apple.com/message.jspa?messageID=11953256#11953256
    EZ Jim
    Mac Pro Quad Core (Early 2009) 2.93Ghz w/Mac OS X (10.6.4)  MacBook Pro (13 inch, Mid 2009) 2.26GHz (10.6.4)
    LED Cinema Display  G4 PowerBook  1.67GHz (10.4.11)  iBookSE 366MHz (10.3.9)  External iSight

  • Server 2008 r2 setting up firewall rule that just doesn't work!

    I have allocated static ip addresses to a group of PCs, then gone to Server 2008 r2 and gone to Windows firewall with advanced security and written a new custom rule. Am blocking internet explorer, have browsed to where it is lodged on PCs, added the ip
    addresses for blocking, in fact followed a detailed set of instructions but it just doesn't work! I am at a loss as to why, can anyone help please, driving me mad now! Thanks.

    Are you applying ADV firewall rules through GPO. If not then you need to create block rules on the clients i think. but I would create a block rule in GPO and link to these PC's OU.

  • Am unable to transfer/sync my "Notes" data from iPhone 6 to my MacAir and MacMini PC. Just doesn't work. Please advise.

    Am unable to transfer/sync my "Notes" data from iPhone 6 to my MacAir and MacMini PC. Just doesn't work. Please advise.
    regards / krishnakumar
    Cochin/India

    There may be other ways, but the best way I've found is:
    Set up an iCloud email account so that you can use the Notes part of this service.  Note that I said "iCloud email" not "iCloud" ... you need to enable the email service of iCloud in order to get the iCloud Notes feature.  Otherwise, the "Notes" app on your device will only store notes on your device, or maybe sync them with some other email account (e.g. Gmail, Yahoo ... but does so poorly IMO).
    On your Macs, set up the same iCloud account as on your iPhone.  Now that you've set up the email part of iCloud, you can enable the Notes feature of iCloud on your Macs.
    Be sure to set iCloud as the default account to store your notes, in case you have other email services with a Notes feature.
    New notes that you create on any device will sync to each other.
    Notes that you created before doing all this cannot sync to your Macs, since the notes were not in iCloud.  Just turning on iCloud Notes does not cause them to enter iCloud and sync -- you'd have to copy and paste them into a new note, after ensuring that iCloud is the default account for any new notes.

  • Brand New everything but just doesn't work as it should

    Hello,
            Just bought a £2000 HP Elitebook 2.8Ghz with 3gb ram, XP, and a lot a bells and whistles. Installed CS4 production Premium and then the updates for Premiere, Encore, Photoshop and Soundbooth.
    Started a new project, connected my Panasonic HVX200 to import DVCPROHD 1080i50 footage - simple you would think.
    Wont do it, locks up everytime.
    Now I started using Premiere on version 5.1 many years ago but stopped using it on version 6 after getting sick of its crashing and instability.
    I went over to FCP and it was a breath of fresh air to say the least.
    When Premiere Pro first came out, I tested it on a brand new laptop, crashed within the first minute and that was the end of that !
    After 5 years on virtually flawless FCP use I thought I'd try out Premiere again and guess what, nothings changed, it just doesn't work as it should.
    How anyone on these forums makes any money from it and keeps their sanity is beyond me.

    They must have corrected this oversight. I tried it out with the following TXT file, and indeed it no longer worked:
    There is no egg in eggplant nor ham in hamburger; neither apple nor pine in pineapple. English muffins weren't invented in England nor French fries in France. Sweetmeats are candies while sweetbreads, which aren't sweet, are meat. Quicksand works slowly, boxing rings are square and a guinea pig is neither from Guinea nor is it a pig. Why is it that writers write but fingers don't fing, grocers don't groce and hammers don't ham?
    If the plural of tooth is teeth, why isn't the plural of booth beeth? One goose, 2 geese. So one moose, 2 meese? Doesn't it seem crazy that you can make amends but not one amend. If you have a bunch of odds and ends and get rid of all but one of them, what do you call the thing left? Is it an odd, or an end?
    If teachers taught, why didn't preachers praught? If a vegetarian eats vegetables, what does a humanitarian eat? In what language do people recite at a play and play at a recital? Ship by truck and send cargo by ship? Have noses that run and feet that smell?
    How can a slim chance and a fat chance be the same, while a wise man and a wise guy are opposites? You have to marvel at the unique lunacy of a language in which your house can burn up as it burns down, in which you fill in a form by filling it out and in which an alarm goes off by going on.
    English was invented by people, not computers, and it reflects the creativity of the human race, which, of course, is not a race at all. That is why, when the stars are out, they are visible, but when the lights are out, they are invisible.
    What a pity. I just hope that the queueing is taking less time than in the past. I will look at your info ASAP and report back.

  • In "Examples" sendMailServlet doesn't work

    I installed tomcat4.0.3 in a linux machine. Everything is ok, all examples work, but only the last one does not. I get
    Apache Tomcat/4.0.3 - HTTP Status 503 - Servlet SendMailServlet is currently unavailable
    What is wrong?

    Hi,
    In "Examples" sendMailServlet doesn't work?Please find the extract from http://www.bigblock.com/support/wri_http.htm
    for HTTP error status 503
    503 Service Unavailable
    The web server is too busy processing current requests to
    listen to a new client. This error represents a serious
    problem with the webserver (normally solved with a reboot).
    Try again after restarting the Tomcat Server.
    Hope this helps.
    Good Luck.
    Gayam.Srinivasa Reddy
    Developer Technical Support
    Sun Micro Systems
    http://www.sun.com/developers/support/

  • Livid with Apple - It just doesn't work. EVER

    Hi Guys,
    As the title suggests I am beyond aggrevated with Apple. But in the interest of healthy blood pressure and actually solving the problem; I will now continue with the problem at hand.
    I have through the years provided support for clients who own Apples, and I have through many years of frustration (due to illogical, broken and unnecessary Apple software functions) and oh so many forum visits solved their problems to their satisfaction.
    This one takes the cake however.
    My client recently broke the glass of his iPad (64Gig) and is now unable to navigate around. He did however buy an ipad mini(16Gig) for his son afterwards and now wants all the kiddie apps loaded onto his sons. I proposed that we perform a backup of his iPad in iTunes and then just restore to the iPad mini as some of his apps was bought in Mauritius and are nor available here for purchase.
    First problem:
    We can't restore the backup (45gig of which 30 gigs are pictures) because the iPad mini has too little space. No problem (or so I thought), let's just delete his photos after I manually backed them up. It turns out we cant delete the photos on his iPad (syncing doesnt work, nor can we manually remove them) because iTunes (he is running 10.6.8 and cannot upgrade further) doesn't provide the function of deleting things, and like I just said the syncing doesn't work. This after trying EVERY solution and workaround presented in the forums.
    Second Problem:
    This would all have been easily solved if we could just do a memory upgrade on the mini. But Apple has seen fit to force their clients to go out and buy BRAND NEW iPad's if they want a small ram upgrade.
    Third problem:
    I tried the syncing seperately via iPhoto and guess what? After about 4 hours of waiting around for it to syncronize it did Jack Diddly Squat.
    Can anyone that maybe has had the same problem provide a solution?
    For those PR agents out there who actually care, just make things simple. People WANT simple. I'm done with punting your low quality products though.

    you can import ALL those photos into iphoto. Then EXPORT them to a large capacity hard drive. Then sort through the photos and sync em to the other ipad.
    When you export movies then make sure you choose ORIGINAL not JPEG.

  • TS4001 iCloud bookmark syncing just doesn't work.

    I've tried all of the disconnect, purge, wait and merge scenarios on on this and other web platforms and iCloud still keeps causing my bookmarks to revert to a long obsolete setup from weeks ago. It's clear I'm not the only one with the problem. Anyone have a better idea?
    I've disconnected the Mac and all of the other devices. I've deleted every folder and file I can find (including the bookmarks.plist in "Library/Safari" many times. I've waited days. I've reconnected and "merged" with iCloud. I've deleted all bookmark files on all other devices. Results are still the same - surprise! A return to an old set up.
    I'm a Mac fan. I'm an Apple fan. But this is really frustrating - its EXACTLY the kind of thing that Apple shouldn't do.
    MobileMe worked fine. What's going on?
    More importantly, what can I do to fix it once and for all?
    Is there a way to get to the bookmarks info in the cloud and clean it out?
    Is there a way to not "merge" but REPLACE the iCloud bookmark info?

    Yup.. I had less trouble getting SN to work with icloud than I did Lion.
    I just popped into the other conversation to say you can indeed use icloud with SN, but you have to have a basic knowledge of how to do things. Unfortunately some people want so much hand holding they just can't be helped.
    I was just trying to ensure everyone knew YOU CAN DO THIS. I didn't intend having to train everyone on the basics of computing and using OSX.
    Just showing a screen shot isn't going to assist anyone. There's more to it.
    I note one individual says "it doesn't work" when I know full well it does". Many have done this and the evidence is all over the web.
    One other person is afraid to screw up her machine by attemptoing anything. Why not use Carbon Copy Cloner and totally clone to a spare disk and then experiment away with the knowledge that the entire system could be brought back as original... in little more than a couple of minutes.??  But no.. "I'm afraid". They can't learn this way. Again, hand holding.
    So if people don't want to research, learn, understand. and try without fear.... then I can't help them.

Maybe you are looking for